Wenn eine Grafik bzw. ein Dokument fertig optimiert ist, können Sie mit dem Exportieren (oder, je nach ursprünglichem Dateityp, mit dem Speichern) fortfahren.

So können Sie ein Dokument beispielsweise als einzelnes Bild in das GIF-, JPEG- oder ein anderes Grafikdateiformat exportieren (oder in manchen Fällen speichern). Sie können auch das gesamte Dokument als HTML-Datei und zugehörige Bilddateien, nur ausgewählte Segmente oder einen bestimmten Bereich exportieren. Außerdem lassen sich Fireworks-Status und -Ebenen auch als separate Bilddateien exportieren.

Der Standardspeicherort, an dem exportierte Dateien von Fireworks abgelegt werden, wird von den folgenden Kriterien und in der folgenden Reihenfolge bestimmt:

  1. Die aktuelle Voreinstellung des Dokuments für Exportvorgänge, die festgelegt ist, falls Sie das Dokument bereits früher exportiert und dann die PNG-Datei gespeichert haben

  2. Das aktuelle Verzeichnis für das Exportieren und Speichern, das geändert wird, wenn Sie zu einem anderen Verzeichnis als das im Dialogfeld „Speichern“, „Speichern unter“ oder „Exportieren“ vorgegebene navigieren

  3. Der Speicherort der aktuellen Datei

  4. Verzeichnis, in dem neue Dokumente oder Bilder in Ihrem Betriebssystem standardgemäß abgelegt werden

    Der Standardspeicherort, an dem Fireworks ein Dokument ablegt, wird hingegen von völlig anderen Kriterien bestimmt. Weitere Informationen finden Sie unter Speichern von Fireworks-Dateien.

Exportieren von Seiten als Bilddateien

  1. Wählen Sie „Datei“ > „Exportieren“.

  2. Wählen Sie den Speicherort für die Exportdateien.

  3. Führen Sie einen der folgenden Schritte aus:

    • Wählen Sie aus dem Popupmenü „Exportieren“ die Option „Nur Bilder“ und aktivieren bzw. deaktivieren Sie das Kontrollkästchen „Nur aktuelle Seite“. Die Seiten werden in das Bildformat exportiert, das im Bedienfeld „Optimieren“ festgelegt ist.

    • Wählen Sie aus dem Popupmenü „Exportieren“ die Option „Seiten in Dateien“ und aus dem Popupmenü „Exportieren als“ die Option „Bilder“. Die Seiten werden in das Bildformat exportiert, das im Bedienfeld „Optimieren“ festgelegt ist.

    • Wählen Sie im Popupmenü „Exportieren“ die Option „Seiten in Dateien“ aus und im Popupmenü „Exportieren als“ die Option „Fireworks PNG“. Jede Seite wird in eine separate PNG-Datei exportiert, die mit Fireworks 8 abwärtskompatibel ist.

    Hinweis:

    Wenn Sie alle Seiten in dem ausgewählten Format speichern wollen, wählen Sie alle Seiten aus und optimieren dann die Einstellungen.

Exportieren eines einzelnen Bilds

Wenn Sie an einem vorhandenen Bild arbeiten, das Sie in Fireworks geöffnet haben, müssen Sie es möglicherweise nicht exportieren, sondern können es einfach speichern. Weitere Informationen finden Sie unter Speichern von Dokumenten in anderen Formaten.

Hinweis:

Um nur bestimmte Bilder eines Dokuments zu exportieren, müssen Sie das Dokument zunächst segmentieren und dann die gewünschten Segmente exportieren.

  1. Wählen Sie im Bedienfeld „Optimieren“ ein Dateiformat aus und legen Sie die formatspezifischen Optionen fest.

  2. Wählen Sie „Datei“ > „Exportieren“.

  3. Geben Sie einen Speicherort für die exportierte Bilddatei an.

    Am besten geeignet ist bei Webgrafiken in der Regel ein Ordner innerhalb der lokalen Website.

  4. Geben Sie einen Dateinamen ohne Erweiterung ein. Die Erweiterung wird während des Exports auf Basis des Dateityps angefügt.

  5. Wählen Sie im Popupmenü „Exportieren“ die Option „Nur Bilder“.

  6. Klicken Sie auf „Speichern“.

Exportieren eines segmentierten Dokuments

Wenn Sie ein segmentiertes Fireworks-Dokument exportieren, wird standardmäßig eine HTML-Datei mit den dazugehörigen Grafiken exportiert. Die exportierte HTML-Datei kann in einem Webbrowser angezeigt oder zur weiteren Bearbeitung in andere Anwendungen importiert werden.

Im Dialogfeld „HTML-Einstellungen“ muss vor dem Exportieren der richtige HTML-Stil gewählt werden. Siehe Festlegen von HTML-Exportoptionen.

Exportieren aller Segmente

  1. Wählen Sie „Datei“ > „Exportieren“.

  2. Navigieren Sie zu einem Ordner auf der Festplatte, in den die Datei exportiert werden soll.

  3. Wählen Sie im Popupmenü „Exportieren“ die Option „HTML und Bilder“.

  4. Geben Sie in das Feld „Dateiname“ (Windows) oder „Sichern unter“ (Mac OS) einen Dateinamen ein.

  5. Wählen Sie im Popupmenü „HTML“ die Option „HTML-Datei exportieren“.

  6. Wählen Sie im Popupmenü „Segmente“ die Option „Segmente exportieren“.

  7. (Optional) Aktivieren Sie die Option „Bilder in Unterordner ablegen“.

  8. Klicken Sie auf „Speichern“.

Exportieren gewählter Segmente

  1. Halten Sie die Umschalttaste gedrückt, um mehrere Segmente auszuwählen.

  2. Wählen Sie „Datei“ > „Exportieren“.

  3. Wählen Sie einen Speicherort für die exportierten Dateien, beispielsweise einen Ordner innerhalb Ihrer lokalen Website.

  4. Wählen Sie im Popupmenü „Exportieren“ die Option „HTML und Bilder“.

  5. Geben Sie einen Dateinamen ohne Erweiterung ein. Die Erweiterung wird während des Exports auf Basis des Dateityps angefügt.

    Wenn Sie mit Fireworks mehrere Segmente exportieren, wird der von Ihnen eingegebene Name als Stamm für die Namen aller exportierten Grafiken verwendet, außer für diejenigen, die Sie im Bedienfeld „Ebenen“ oder im Eigenschafteninspektor selbst benannt haben.

  6. Wählen Sie im Popupmenü „Segmente“ die Option „Segmente exportieren“.

  7. Um nur die vor dem Export gewählten Segmente zu exportieren, wählen Sie „Nur ausgewählte Segmente“ und vergewissern sich, dass die Option „Bereiche ohne Segmente einschließen“ nicht gewählt ist.

  8. Klicken Sie auf „Speichern“.

Aktualisieren eines Segments

Wenn Sie nach dem Export eines segmentierten Dokuments nachträglich Änderungen am Originaldokument in Fireworks vorgenommen haben, können Sie nur das geänderte Bild bzw. Segment aktualisieren. Damit Sie das Ersatzsegment schnell finden, sollten Sie Segmenten benutzerdefinierte Namen geben.

  1. Blenden Sie das Segment aus und bearbeiten Sie den darunter liegenden Bereich.

  2. Blenden Sie das Segment wieder ein.

  3. Klicken Sie mit der rechten Maustaste (Windows) bzw. bei gedrückter Ctrl-Taste (Mac OS) auf das Segment und wählen Sie „Ausgewähltes Segment exportieren“.

  4. Wählen Sie den Ordner des ursprünglichen Segments unter Verwendung desselben Basisnamen und klicken Sie auf „Speichern“.

  5. Klicken Sie auf „OK“, wenn Sie gefragt werden, ob die vorhandene Datei ersetzt werden soll.

    Hinweis:

    Dabei ist zur Vermeidung unerwünschter Ergebnisse im HTML-Dokument darauf zu achten, dass das neue Segment die ursprüngliche Exportgröße nicht überschreitet.

Exportieren einer Animation

Nachdem Sie Ihre Animation erstellt und animiert haben, können Sie sie exportieren. Für den Export einer Animation kann jeder der folgenden Dateitypen verwendet werden:

Animiertes GIF

Bei Clipart- und zeichentrickähnlichen Grafiken erzielen Sie mit animierten GIFs die besten Ergebnisse.

Flash SWF oder Fireworks PNG (kein Export erforderlich)

Exportieren Sie eine Animation als SWF-Datei, wenn Sie diese in Flash importieren möchten. Sie können den Exportvorgang auch überspringen und eine Fireworks-PNG-Quelldatei direkt in Flash importieren. Mit dieser direkten Methode haben Sie die Möglichkeit, alle Ebenen und jeden Status der Animation zu importieren und dann in Flash weiter zu bearbeiten. Siehe hierzu auch den Abschnitt Arbeiten mit Flash.

Mehrere Dateien

Der Export von Animationsstatus oder -ebenen in mehrere Dateien bietet sich an, wenn viele Symbole auf unterschiedlichen Ebenen für dasselbe Objekt vorliegen. So können Sie beispielsweise ein Werbebanner in mehreren Dateien exportieren, wenn jeder Buchstabe eines Firmennamens in einer Grafik animiert wird. Siehe Exportieren von Status oder Ebenen in mehrere Dateien.

Enthält ein Dokument mehrere Animationen, besteht die Möglichkeit, Segmente einzufügen, um jede Animation mit unterschiedlichen Animationseinstellungen, z. B. für Schleifen und Statusverzögerung, zu exportieren.

Exportieren einer animierten GIF

  1. Wählen Sie „Auswählen“ > „Auswahl aufheben“, um die Auswahl aller Segmente und Objekte aufzuheben. Wählen Sie dann im Bedienfeld „Optimieren“ das Dateiformat „Animiertes GIF“.

  2. Wählen Sie „Datei“ > „Exportieren“.

  3. Geben Sie einen Namen für die Datei ein und wählen Sie das Ziel.

  4. Klicken Sie auf „Speichern“.

Exportieren von mehreren animierten GIFs mit unterschiedlichen Animationseinstellungen

  1. Klicken Sie bei gedrückter Umschalttaste auf die Animationen, um sie alle auszuwählen.

  2. Wählen Sie „Bearbeiten“ > „Einfügen“ > „Rechteckiges Segment“ oder „Polygonsegment“.

  3. Klicken Sie im Meldungsfenster auf „Mehrere“.

  4. Wählen Sie jedes Segment einzeln und legen Sie im Bedienfeld „Status“ die jeweiligen Animationseinstellungen fest.

  5. Wählen Sie alle Segmente, die Sie animieren möchten, und dann im Bedienfeld „Optimieren“ das Dateiformat „Animiertes GIF“.

  6. Klicken Sie mit der rechten Maustaste (Windows) bzw. bei gedrückter Ctrl-Taste (Mac OS) auf die einzelnen Segmente und wählen Sie „Ausgewähltes Segment exportieren“, um jedes Segment einzeln zu exportieren. Geben Sie im Dialogfeld „Exportieren“ einen Namen für jede Datei ein, wählen Sie das Ziel und klicken Sie auf „Speichern“.

Exportieren von Status oder Ebenen in mehrere Dateien

Fireworks kann jede Ebene und jeden Status eines Dokuments als separate Bilddatei unter Verwendung der im Bedienfeld „Optimieren“ angegebenen Optimierungseinstellungen exportieren. Der Name der Ebene bzw. des Status wird zur Generierung des Dateinamens für die jeweiligen Exportdateien verwendet. Diese Exportmethode wird mitunter zum Exportieren von Animationen eingesetzt.

  1. Wählen Sie „Datei“ > „Exportieren“.

  2. Geben Sie einen Dateinamen ein, und wählen Sie einen Zielordner aus.

  3. Wählen Sie aus dem Popupmenü „Exportieren“ eine Option:

    Status in Dateien

    Exportiert Status in mehrere Dateien.

    Ebenen in Dateien

    Exportiert Ebenen in mehrere Dateien.

    Hinweis: Dadurch werden alle Ebenen des aktuellen Status exportiert.

  4. Wählen Sie „Bilder zuschneiden“, um jedes exportierte Bild automatisch zuzuschneiden und nur die Objekte in jedem Status einzuschließen. Deaktivieren Sie diese Option, wenn stattdessen die gesamte Leinwand eingeschlossen werden soll (inklusive leere Bereiche außerhalb der Objekte).

  5. Klicken Sie auf „Speichern“.

Exportieren eines Bereichs aus einem Dokument

  1. Wählen Sie im Bedienfeld „Werkzeuge“ das Exportbereichwerkzeug .

  2. Ziehen Sie den Auswahlrahmen zurecht, um den zu exportierenden Teil des Dokuments auszuwählen.

    Hinweis:

    Während des Zeichnens lässt sich die Position des Auswahlrahmens ändern. Halten Sie bei gedrückter Maustaste die Leertaste gedrückt. Ziehen Sie dann den Auswahlrahmen an eine andere Stelle auf der Leinwand. Lassen Sie die Leertaste los, um mit dem Zeichnen des Auswahlrahmens fortzufahren.

    Wenn Sie die Maustaste loslassen, bleibt der Exportbereich weiterhin ausgewählt.

  3. Passen Sie ggf. die Größe des Exportbereichs an:

    • Um die Größe des Exportbereich-Auswahlrahmens proportional anzupassen, ziehen Sie bei gedrückter Umschalttaste einen Griff.

    • Um die Größe des Auswahlrahmens von der Mitte aus anzupassen, ziehen Sie bei gedrückter Alt-Taste (Windows) bzw. Wahltaste (Mac OS) einen Griff.

    • Um Größe des Auswahlrahmens unter Beibehaltung der Proportionen von der Mitte aus anzupassen, ziehen Sie bei gedrückter Alt- und Umschalttaste (Windows) bzw. Wahl- und Umschalttaste (Mac OS) einen Griff.

  4. Doppelklicken Sie in den Exportbereich-Auswahlrahmen, um die Vorschau aufzurufen.

  5. Nehmen Sie die gewünschten Einstellungen in der Bildvorschau vor und klicken Sie auf „Exportieren“.

  6. Geben Sie einen Dateinamen ein und wählen Sie einen Zielordner aus.

  7. Wählen Sie aus dem Popupmenü „Exportieren“ die Option „Nur Bilder“.

  8. Klicken Sie auf „Speichern“.

    Hinweis:

    Wenn Sie den Vorgang abbrechen möchten, ohne den Bereich zu exportieren, doppelklicken Sie auf eine Stelle außerhalb des Exportbereich-Auswahlrahmens, und drücken Sie die Esc-Taste, oder wählen Sie ein anderes Werkzeug aus.

Exportieren von HTML-Code

Sofern Sie nicht ausdrücklich Gegenteiliges angeben, wird ein segmentiertes Fireworks-Dokument in Form einer HTML-Datei und zugehöriger Bilder exportiert. In welcher Form HTML-Code aus Fireworks exportiert wird, legen Sie im Dialogfeld „HTML-Einstellungen“ fest.

Fireworks generiert reinen HTML-Code, der von den meisten Webbrowsern und HTML-Editoren gelesen werden kann. Beim Export wird standardmäßig die UTF-8-Kodierung festgelegt.

Fireworks-HTML-Dateien können Sie auf verschiedenste Arten exportieren:

  • Exportieren Sie eine HTML-Datei, die Sie anschließend zur weiteren Bearbeitung in einem HTML-Editor öffnen können.

  • Exportieren Sie jede Seite einer Fireworks-Datei als separate HTML-Datei.

  • Kopieren Sie HTML-Code in die Zwischenablage von Fireworks, und fügen Sie ihn dann in ein bereits vorhandenes HTML-Dokument ein.

  • Exportieren Sie eine HTML-Datei, öffnen Sie sie in einem HTML-Editor, und kopieren Sie manuell Teile des Codes aus der Datei in ein anderes HTML-Dokument.

  • Exportieren Sie HTML-Code als CSS-Ebenen (Cascading Style Sheet) und als XHTML-Code.

  • Nehmen Sie mit dem Befehl „HTML aktualisieren“ Änderungen an einer zuvor erzeugten HTML-Datei vor.

    Aus Fireworks können Sie HTML-Dokumente im Generic-, Dreamweaver-, Microsoft® FrontPage®- und Adobe GoLive®-Format exportieren.

    Hinweis:  Adobe Dreamweaver bietet ein hohes Maß an Integrationsfähigkeit für Fireworks-Dokumente. Fireworks wickelt den Export von HTML-Code in Dreamweaver anders ab als für andere HTML-Editoren. Weitere Informationen zum Einfügen von exportiertem Fireworks-HTML-Code in Dreamweaver finden Sie im Abschnitt Arbeiten mit Dreamweaver.

    Die Methode des Exports von Fireworks-HTML in andere Anwendungen bietet sich ideal für die Arbeit im Team an. Bei dieser Methode wird der Arbeitsablauf in kleinere Abschnitte aufgesplittert, sodass zunächst eine Aufgabe in einer Anwendung erledigt und die Arbeit anschließend gegebenenfalls von einer anderen Person in einer anderen Anwendung fortgesetzt werden kann.

Einschließen von Kommentaren in exportierte HTML-Dateien

Kommentare in Fireworks-HTML-Code beginnen mit <!-- und enden mit -->. Jeglicher Text zwischen diesen beiden Tags wird weder als HTML- noch als JavaScript-Code interpretiert.

  1. Wählen Sie vor dem Exportieren im Dialogfeld „HTML-Einstellungen“ auf der Registerkarte „Allgemein“ die Option „HTML-Kommentare einschließen“.

Ergebnisse des Exportvorgangs

Wenn Sie HTML-Code aus Fireworks exportieren oder kopieren, wird Folgendes generiert:

  • Der für die Zusammensetzung der segmentierten Bilder erforderliche HTML-Code sowie etwaige JavaScript-Code, falls das Dokument interaktive Elemente enthält. Fireworks-HTML enthält Hyperlinks zu den exportierten Bildern und setzt die Hintergrundfarbe der Webseite auf die Leinwandfarbe.

  • Eine bzw. mehrere Bilddateien, je nachdem wie viele Segmente in dem betreffenden Dokument erstellt wurden und wie viele Zustände die Schaltflächen des Dokuments enthalten.

  • Falls erforderlich, eine Datei namens spacer.gif. Die Datei „spacer.gif“ ist eine transparente, 1 mal 1 Pixel große GIF-Datei, mit deren Hilfe Fireworks Abstandsprobleme behebt, die auftreten können, wenn segmentierte Bilder in einer HTML-Tabelle zusammengesetzt werden. Sie können gesondert angeben, ob Fireworks einen Abstandshalter exportieren soll.

  • Wenn Sie Popupmenüs exportieren, werden folgende Dateien exportiert: „mm_css_menu.js“ und eine CSS-Datei mit dem CSS-Code für das Popupmenü. Wenn Ihre Popupmenüs Untermenüs enthalten, wird außerdem eine Datei namens „arrows.gif“ exportiert.

  • Beim Exportieren oder Kopieren von HTML-Dateien in Dreamweaver werden Anmerkungsdateien erstellt, die die Integration zwischen Fireworks und Dreamweaver unterstützen. Die Dateien haben die Erweiterung .mno.

Exportieren von Fireworks-HTML-Code

  1. Wählen Sie „Datei“ > „Exportieren“.

  2. Navigieren Sie zu einem Ordner auf der Festplatte, in den die Datei exportiert werden soll.

  3. Wählen Sie aus dem Popupmenü „Exportieren“ die Option „HTML und Bilder“.

  4. Klicken Sie auf die Schaltfläche „Optionen“ und wählen Sie im Dialogfeld „HTML-Einstellungen“ auf der Registerkarte „Allgemein“ aus dem Popupmenü „HTML-Stil“ Ihren HTML-Editor. Sollte der gewünschte HTML-Editor nicht aufgeführt sein, wählen Sie „Generic“.

    Hinweis:

    Es ist sehr wichtig, dass Sie Ihren HTML-Editor als HTML-Stil angeben, denn anderenfalls funktionieren interaktive Elemente wie Schaltflächen und Rollover nach dem Import möglicherweise nicht wie erwartet.

  5. Klicken Sie auf „OK“.

  6. Wählen Sie aus dem Popupmenü „HTML“ die Option „HTML-Datei exportieren“.

  7. Wenn das Dokument Segmente enthält, wählen Sie aus dem Popupmenü „Segmente“ die Option „Segmente exportieren“.

  8. Wählen Sie „Bilder in Unterordner ablegen“, um Bilder in einem separaten Ordner zu speichern. Sie können einen bestimmten Ordner wählen oder den Fireworks-Standardordner für Bilder verwenden.

  9. Wenn Sie ein Fireworks-Dokument mit mehreren Seiten exportieren, deaktivieren Sie das Kontrollkästchen „Nur aktuelle Seite“, um alle Seiten in separate HTML-Dokumente zu exportieren.

  10. Klicken Sie auf „Speichern“.

    Die von Fireworks exportierten Dateien werden nach dem Exportieren als Inhalt der Festplatte angezeigt. An dem Speicherort, den Sie im Dialogfeld „Exportieren“ angegeben haben, werden Bilder und eine HTML-Datei generiert.

Kopieren von HTML-Code in die Zwischenablage

Zum Kopieren von HTML-Code in die Zwischenablage stehen Ihnen in Fireworks zwei Methoden zur Wahl: Sie können entweder den Befehl „HTML-Code kopieren“ verwenden oder im Dialogfeld „Exportieren“ die Option „In Zwischenablage kopieren“ wählen. Dieser HTML-Code lässt sich anschließend in ein Dokument in einem anderen HTML-Editor einfügen.

Wenn Sie sich für eine Methode zum Übertragen von Fireworks-HTML-Code in andere Anwendungen entscheiden, sollten Sie sich der Nachteile bewusst sein, die sich beim Kopieren von HTML-Code in die Zwischenablage ergeben:

  • Es besteht nicht die Möglichkeit, Bilder in einem Unterverzeichnis abzulegen. Sie müssen in demselben Ordner gespeichert werden, in den Sie den kopierten HTML-Code einfügen. Eine Ausnahme bildet hier Dreamweaver.

  • Sämtliche Hyperlinks oder Pfade, die in Fireworks-Popupmenüs enthalten sind, beziehen sich auf Ihre Festplatte. Das Kopieren von HTML-Code in Dreamweaver bildet eine Ausnahme.

  • Wenn Sie mit einem anderen HTML-Editor als Dreamweaver oder Microsoft FrontPage arbeiten, wird der JavaScript-Code für Schaltflächen, Verhalten und Rollover-Grafiken zwar kopiert, funktioniert aber u. U. nicht richtig.

    Sollte dies ein Problem darstellen, verwenden Sie die Option „HTML exportieren“, anstatt den HTML-Code in die Zwischenablage zu kopieren.

    Hinweis:  Im Dialogfeld „HTML-Einstellungen“ muss vor dem Kopieren von HTML-Code auf der Registerkarte „Allgemein“ der richtige HTML-Stil gewählt und die Option „HTML-Kommentare einschließen“ aktiviert werden.

Kopieren von Fireworks-HTML-Code mithilfe der Option „HTML-Code kopieren“

  1. Wählen Sie „Bearbeiten“ > „HTML-Code kopieren“.

  2. Folgen Sie den Anweisungen des Assistenten. Geben Sie bei entsprechender Aufforderung einen Zielordner für die exportierten Bilder an. Dabei muss es sich um den Ordner handeln, in dem die HTML-Datei gespeichert wird.

    Hinweis:

    Wenn Sie beabsichtigen, den HTML-Code in Dreamweaver einzufügen, spielt das Exportziel für die Bilder keine Rolle, solange es sich um das Dreamweaver-Verzeichnis der HTML-Datei handelt, in welche der Code eingefügt wird.

Kopieren von Fireworks-HTML-Code mithilfe des Dialogfelds „Exportieren“

  1. Wählen Sie „Datei“ > „Exportieren“.

  2. Geben Sie im Dialogfeld „Exportieren“ einen Zielordner für die exportierten Bilder an. Dabei muss es sich um den Ordner handeln, in dem die HTML-Datei gespeichert wird.

    Hinweis:

    Wenn Sie beabsichtigen, den HTML-Code in Dreamweaver einzufügen, spielt das Exportziel für die Bilder keine Rolle, solange es sich um das Dreamweaver-Verzeichnis der HTML-Datei handelt, in welche der Code eingefügt wird.

  3. Wählen Sie im Popupmenü „Exportieren“ die Option „HTML und Bilder“.

  4. Wählen Sie aus dem Popupmenü „HTML“ die Option „In Zwischenablage kopieren“.

  5. Wenn das Dokument Segmente enthält, wählen Sie aus dem Popupmenü „Segmente“ die Option „Segmente exportieren“.

  6. Klicken Sie auf die Schaltfläche „Optionen“, wählen Sie im Dialogfeld „HTML-Einstellungen“ Ihren HTML-Editor und klicken Sie auf „OK“.

  7. Klicken Sie auf „Speichern“.

Einfügen von in Fireworks kopiertem HTML-Code in ein anderes HTML-Dokument

  1. Öffnen Sie in Ihrem HTML-Editor ein vorhandenes HTML-Dokument oder erstellen Sie ein neues. Speichern Sie das Dokument in demselben Ordner, in welchen Sie die Bilder exportiert haben.

    Hinweis:

    Wenn Sie mit Dreamweaver arbeiten, ist es nicht erforderlich, die HTML-Datei in demselben Ordner wie die exportierten Bilder zu speichern. Sofern Sie die Bilder aus Fireworks in eine Dreamweaver-Site exportieren und die HTML-Datei in einem Ordner innerhalb dieser Site speichern, löst Dreamweaver die Pfade zu den entsprechenden Bildern auf.

  2. Zeigen Sie den HTML-Code an und platzieren Sie die Einfügemarke zwischen den <BODY>-Tags.

    Hinweis:

    Aus Fireworks kopierter HTML-Code enthält die öffnenden und schließenden <HTML>- und <BODY>-Tags nicht.

  3. Fügen Sie den HTML-Code ein.

    Wenn Sie Inhalte in die Zwischenablage kopieren, sollten sie anschließend an ihre definitive Zielposition innerhalb der Website exportiert werden. Da in Fireworks dokumentbezogene URLs verwendet werden, funktionieren die Links nicht mehr, wenn entweder die HTML-Datei oder die Grafiken verschoben werden.

Kopieren von Code aus einer exportierten Fireworks-Datei und Einfügen in ein anderes HTML-Dokument

  1. Öffnen Sie die exportierte Fireworks-HTML-Datei in einem HTML-Editor.

  2. Markieren Sie den gewünschten Code, und kopieren Sie ihn in die Zwischenablage.

  3. Öffnen Sie ein vorhandenes HTML-Dokument oder erstellen Sie ein neues.

  4. Fügen Sie den Code in die neue HTML-Datei ein. Dabei brauchen Sie die Tags <HTML> und <BODY> nicht zu kopieren, da diese im HTML-Zieldokument wahrscheinlich schon enthalten sind.

    Wenn Sie in Fireworks im Dialogfeld „HTML-Einstellungen“ die Option „HTML-Kommentare einschließen“ aktiviert hatten, befolgen Sie die Anweisungen in den Kommentaren, um den Code an der richtigen Stelle einzufügen.

  5. Falls das Fireworks-Dokument interaktive Elemente enthält, kopieren Sie den JavaScript-Code.

    JavaScript-Code ist von den Tags <SCRIPT> umgeben und befindet sich in dem durch <HEAD> gekennzeichneten Abschnitt des Dokuments. Der gesamte <SCRIPT>-Abschnitt ist zu kopieren und einzufügen, es sei denn, das Zieldokument enthält bereits einen <SCRIPT>-Abschnitt. In diesem Fall sollten Sie nur den Inhalt des <SCRIPT>-Abschnitts kopieren und in den bereits vorhandenen <SCRIPT>-Abschnitt einfügen, ohne dabei den Inhalt des vorhandenen Abschnitts zu überschreiben. Vergewissern Sie sich nach dem Einfügen des Codes außerdem, dass der <SCRIPT>--Abschnitt keine doppelten JavaScript-Funktionen aufweist.

Aktualisieren von exportiertem HTML-Code

Die Aktualisierungsoption ermöglicht es Ihnen, Änderungen an einem bereits exportierten Fireworks-HTML-Dokument vorzunehmen und bietet sich an, wenn nur ein Teil eines Dokuments aktualisiert werden soll.

Hinweis:

Die Funktionsweise des Befehls „HTML aktualisieren“ im Zusammenhang mit Dreamweaver-Dokumenten weicht von der Verwendung mit anderen HTML-Dokumenten ab. Weitere Informationen finden Sie unter Arbeiten mit Dreamweaver.

Beim Aktualisieren können Sie entscheiden, ob nur die geänderten Bilder ersetzt oder der gesamte Code und alle Bilder überschrieben werden sollen. Wenn nur die veränderten Bilder ersetzt werden sollen, werden alle Änderungen, die Sie außerhalb von Fireworks an der HTML-Datei vorgenommen haben, beibehalten.

Hinweis:

Umfassendere Änderungen am Dokumentenlayout sollten Sie in Fireworks vornehmen. Exportieren Sie die HTML-Datei anschließend erneut.

  1. Wählen Sie „Datei“ > „HTML aktualisieren“.

  2. Wählen Sie die zu aktualisierende Datei.

  3. Klicken Sie auf „Öffnen“.

  4. Führen Sie einen der folgenden Schritte aus:

    • Wenn kein von Fireworks generierter HTML-Code gefunden wird, klicken Sie auf „OK“, um neuen HTML-Code an das Ende des Dokuments anzuhängen.

    • Wenn in der betreffenden Datei dagegen Fireworks-HTML-Code enthalten ist, wählen Sie eine der folgenden Optionen und klicken danach auf „OK“:

      Bilder und HTML-Code ersetzen

      Ersetzt den zuvor von Fireworks generierten HTML-Code

      Nur Bilder aktualisieren

      Überschreibt nur die Bilder

  5. Wenn das Dialogfeld „Bildordner wählen“ angezeigt wird, wählen Sie einen Ordner und klicken auf „Öffnen“.

Exportieren von CSS-Ebenen

CSS-Ebenen können sich überlagern und übereinander gestapelt werden. Normalerweise weist Fireworks-HTML-Code keine derartigen Überlagerungen auf.

  1. Wählen Sie „Datei“ > „Exportieren“.

  2. Geben Sie einen Dateinamen ein, und wählen Sie einen Zielordner aus.

  3. Wählen Sie aus dem Popupmenü „Exportieren“ die Option „CSS und Bilder“.

    • Wählen Sie „Nur aktueller Status“, um nur den aktuellen Status zu exportieren.

    • Wählen Sie „Nur aktuelle Seite“, um nur die aktuelle Seite zu exportieren.

    • Wählen Sie „Bilder in Unterordner ablegen“, um einen Ordner für Bilder zu wählen.

  4. Klicken Sie auf „Optionen“, um die HTML-Seiteneigenschaften einzurichten.

  5. Klicken Sie auf „Durchsuchen“, um ein Hintergrundbild festzulegen und die Wiederholung des Hintergrundbilds einzurichten:

    • Wählen Sie „no repeat“ (Keine Wiederholung), um das Bild nur einmal anzuzeigen.

    • Wählen Sie „repeat“ (Wiederholen), um das Bild horizontal und vertikal zu wiederholen.

    • Wählen Sie „repeat-x“ (Wiederholen-x), um das Bild horizontal zu wiederholen.

    • Wählen Sie „repeat-y“ (Wiederholen-y), um das Bild vertikal zu wiederholen.

  6. Wählen Sie die Seitenausrichtung im Browser: links, mittig oder rechts.

  7. Klicken Sie auf „OK“ und dann auf „Speichern“.

Exportieren von XHTML

XHTML ist eine Kombination aus HTML, dem aktuellen Standard für die Formatierung und Anzeige von Webseiten, und XML (eXtensible Markup Language). XHTML ist abwärtskompatibel, also mit den meisten derzeit gebräuchlichen Webbrowsern anzeigbar, und kann von allen Geräten gelesen werden, die XML-Inhalte anzeigen. Dazu gehören PDAs, Mobiltelefone und andere Handgeräte.

Fireworks kann XHTML auch importieren. Siehe Erstellen von Fireworks-PNG-Dateien aus HTML-Dateien.

Weitere Informationen zu XHTML finden Sie in der XHTML-Spezifikation des World Wide Web Consortium (W3C) unter www.w3.org.

  1. Wählen Sie „Datei“ > „HTML-Einstellungen“, wählen Sie auf der Registerkarte „Allgemein“ aus dem Popupmenü „HTML-Stil“ einen XHTML-Stil und klicken Sie auf „OK“.

  2. Exportieren Sie das Dokument anhand einer der zum Exportieren oder Kopieren von HTML verfügbaren Methoden. Siehe Exportieren von HTML-Code.

    Hinweis:

    Beim Exportieren von XHTML-Code verwendet Fireworks die UTF-8-Kodierung.

Exportieren von Dateien mit und ohne UTF-8-Kodierung

UTF-8 (Universal Character Set Transformation Format-8) ist eine Textkodierungsmethode, die Webbrowsern die Anzeige unterschiedlicher Zeichensätze (wie chinesischen und englischen Text) auf derselben HTML-Seite ermöglicht. Die UTF-8-Kodierung ist standardmäßig aktiviert.

Fireworks bietet außerdem Unterstützung für das Importieren von UTF-8-kodierten Dokumenten. Siehe Erstellen von Fireworks-PNG-Dateien aus HTML-Dateien.

Exportieren von Dokumenten ohne UTF-8-Kodierung

  1. Wählen Sie „Datei“ > „HTML-Einstellungen“.

  2. Deaktivieren Sie auf der Registerkarte „Dokumentspezifisch“ das Kontrollkästchen „UTF-8-Kodierung verwenden“ und klicken Sie auf „OK“.

  3. Exportieren Sie das Dokument anhand einer der zum Exportieren oder Kopieren von HTML verfügbaren Methoden.

Festlegen von HTML-Exportoptionen

Über das Dialogfeld „HTML-Einstellungen“ können Sie bestimmen, wie Fireworks HTML-Dokumente exportiert. Die auf der Registerkarte „Dokumentspezifisch“ vorgenommenen Änderungen wirken sich nur auf das aktuelle Dokument aus. Bei den Einstellungen unter „Allgemein“ und „Tabelle“ handelt es sich dagegen um dokumentübergreifende Voreinstellungen, die für alle neuen Dokumente gelten.

  1. Führen Sie einen der folgenden Schritte aus:

    • Wählen Sie „Datei“ > „HTML-Einstellungen“.

    • Klicken Sie im Dialogfeld „Exportieren“ auf die Schaltfläche „Optionen“.

  2. Wählen Sie auf der Registerkarte „Allgemein“ die gewünschten Optionen.

    HTML-Stil

    Wählen Sie den Stil für exportierten HTML-Code.

    Generic HTML wird von jedem HTML-Editor unterstützt. Wenn Ihr Dokument aber Verhalten oder andere interaktiven Inhalte aufweist, wählen Sie Ihren spezifischen Editor aus, sofern er aufgelistet ist.

    Um das Dokument mit dem XHTML-Standard zu exportieren, wählen Sie im Popupmenü den entsprechenden XHTML-Stil.

    Erweiterung

    Wählen Sie im Popupmenü „Erweiterung“ eine Dateinamenerweiterung aus oder geben Sie eine neue ein.

    HTML-Kommentare einschließen

    Wählen Sie diese Option, um Hinweise darüber einzubinden, an welcher Stelle HTML-Code zu kopieren und einzufügen ist. Diese Option wird für Dokumente empfohlen, die interaktive Elemente wie Schaltflächen, Verhalten oder Rollover-Bilder enthalten.

    Dateiname in Kleinbuchstaben

    Wählen Sie diese Option, damit die Namen der HTML-Datei und der zugehörigen Bilddateien beim Export kleingeschrieben werden.

    Hinweis: Mit dieser Option wird die Erweiterung einer HTML-Datei nicht in Kleinbuchstaben geändert, wenn Sie im Popupmenü „Erweiterung“ eine großgeschriebene Erweiterung ausgewählt haben.

    CSS für Popupmenüs verwenden

    Wählen Sie diese Option, um CSS statt JavaScript für den Popupmenü-Code zu verwenden. Mit Dreamweaver können Sie die Menüs indizieren und die Links innerhalb des Codes aktualisieren.

    CSS in externe Datei schreiben

    Wählen Sie diese Option, um den CSS-Code in eine externe CSS-Datei zu schreiben, die beim Export am selben Speicherort wie die HTML-Datei abgelegt wird. Der Name der .css-Datei entspricht dem Namen der HTML-Datei (abgesehen von der Dateinamenserweiterung). Durch Auswahl dieser Option wird außerdem eine Datei namens mm_css_menu.js in das Verzeichnis mit der HTML-Datei exportiert.

    Hinweis: Diese Option steht nur zur Verfügung, wenn die Option „CSS für Popupmenüs verwenden“ aktiviert wurde.

    Dateierstellung (Mac OS)

    Wählen Sie aus dem Popupmenü eine zugehörige Anwendung. Wenn Sie auf die exportierte HTML-Datei auf der Festplatte doppelklicken, wird sie automatisch in der angegebenen Anwendung geöffnet.

  3. Wählen Sie auf der Registerkarte „Tabelle“ die gewünschten Einstellungen für Ihre HTML-Tabellen. Weitere Informationen finden Sie unter Festlegen der Exportform für HTML-Tabellen.

  4. Wählen Sie auf der Registerkarte „Dokumentspezifisch“ eine der folgenden Optionen:

    Segmentdateinamen

    Wählen Sie aus den Popupmenüs eine Formel für die automatische Benennung von Segmenten. Dabei können Sie entweder die Standardeinstellungen übernehmen oder eigene Optionen wählen.

    Hinweis: Wenn Sie in einem der ersten drei Menüs die Option „Ohne“ auswählen, exportiert Fireworks sich gegenseitig überschreibende Segmentdateien. Das Ergebnis des Exportvorgangs ist eine einzige Grafik und eine Tabelle, bei der in jeder Zelle diese Grafik angezeigt wird.

    Standard-ALT-Tag

    Geben Sie in dieses Textfeld den Text ein, der anstelle der Bilder angezeigt wird, während diese aus dem Internet heruntergeladen werden oder wenn der Ladevorgang fehlgeschlagen ist. In einigen Browsern wird der Text unter Umständen auch als Quickinfo angezeigt, wenn der Zeiger über das Bild bewegt wird. Dieser Text stellt außerdem eine Hilfe für sehbehinderte Webbenutzer dar.

    HTML-Dateien mit mehreren Navigationsleisten exportieren (zur Verwendung ohne Framesets)

    Wählen Sie diese Option beim Exportieren einer Navigationsleiste, die mehrere Seiten miteinander verknüpft. Fireworks exportiert zusätzliche Seiten für jede Schaltfläche in der Navigationsleiste.

    Bereiche ohne Segmente einschließen

    Wählen Sie diese Option, um Bereiche der Leinwand einzuschließen, die nicht mit Segmenten bedeckt sind.

    UTF-8-Kodierung verwenden

    Diese Option ist standardmäßig aktiviert. Damit können Zeichen aus verschiedenen Zeichensätzen im exportierten Dokument angezeigt werden. Um diese Option zu deaktivieren, heben Sie die Auswahl des Kontrollkästchens auf.

  5. Klicken Sie auf „Standardeinstellungen festlegen“, um diese Einstellungen als Ihre globalen Standardeinstellungen zu speichern..

Exportieren von Adobe PDF-Dateien

Wenn Sie einen Fireworks-Entwurf drucken oder zur Überprüfung weitergeben möchten, können Sie diesen in das Adobe PDF-Format exportieren. Redakteure und Bearbeiter können in Adobe Reader® oder Acrobat® Kommentare hinzufügen und die Kommentare anderer beantworten. Informationen zum Einrichten von PDF-Prüfdokumenten finden Sie in der Acrobat-Hilfe.

In exportierten PDF-Dateien bleiben alle Seiten und Hypertext-Links erhalten, sodass Bearbeiter im Dokument navigieren können, wie das im Internet der Fall wäre. Im Gegensatz zu HTML-Prototypen bietet Adobe PDF jedoch Sicherheitseinstellungen, mit denen Sie verhindern können, dass Bearbeiter Ihre Entwürfe ändern oder kopieren.

  1. Wählen Sie „Datei“ > „Exportieren“.

  2. Wählen Sie im Popupmenü „Exportieren“ die Option „Adobe PDF“.

  3. Wählen Sie die zu exportierenden Seiten und dann „PDF nach Export anzeigen“, um das PDF automatisch in Adobe Reader oder Acrobat zu öffnen.

  4. Klicken Sie zum Anpassen der PDF-Datei auf „Optionen“ und nehmen Sie dann die folgenden Einstellungen vor:

    Kompatibilität

    Bestimmt, welche Adobe PDF-Anwendungen zum Öffnen der exportierten Datei verwendet werden können.

    Komprimierung

    Bestimmt die Art der Bildkomprimierung zum Reduzieren der Dateigröße. Im Allgemeinen werden bei der JPEG- oder der JPEG2000-Komprimierung bessere Ergebnisse für Fotos mit graduellen Farbübergängen erzielt. Für Illustrationen mit großen, einfarbigen Bereichen ist ZIP besser geeignet.

    Qualität

    JPEG- oder JPEG2000-Komprimierung bietet Bildqualitätseinstellungen an. Bei der Auswahl von hoher Qualität entsteht eine große Datei mit guter Bildqualität.

    In Graustufen konvertieren

    Konvertiert alle Bilder in Graustufenbilder und reduziert so die Dateigröße.

    Textauswahl aktivieren

    Ermöglicht Bearbeitern das Kopieren von Text aus der exportierten Datei. Deaktivieren Sie diese Option, um die Dateigröße stark zu reduzieren.

    Anschnittwert

    Bestimmt die Breite des leeren Randes, der das Bild auf jeder Seite umgibt, in Pixeln. Wenn Sie beispielsweise einen Wert von 20 eingeben, wird um jedes Bild ein 20 Pixel breiter Rand angezeigt.

    Kennwort zum Öffnen des Dokuments verwenden

    Verlangt das Kennwort zum Öffnen der exportierten Datei.

    Kennwort zum Einschränken von Aufgaben verwenden

    Verlangt das Kennwort zum Schutz, um diese ausgewählten Funktionen ausführen zu können: Drucken, Bearbeiten, Kopieren und Kommentieren.

  5. Klicken Sie auf „OK“, um das Dialogfeld „Optionen“ zu schließen.

  6. Geben Sie einen Dateinamen und einen Speicherort an und klicken Sie anschließend auf „Speichern“.

    Hinweis:

    Falls Seiten in Ihren Fireworks-Dokumenten eine durchsichtige Leinwand haben, verlieren Objekte mit angewendeten Transparenzen ihre Transparenzeigenschaften, wenn Sie sie in PDF exportieren. Um dies zu vermeiden, stellen Sie die Leinwand vor dem Export in PDF auf einen nicht-transparenten Hintergrund ein.

Video

Kundennachweise mit Fireworks als PDF- oder HTML-Dateien erstellen (00:05:32)

Hier erfahren Sie, wie Sie mithilfe des Menüs „Fireworks-Export“ ein PDF- oder HTML-Dokument für Kundengenehmigungen oder Team-Reviews vorbereiten können.

Von Tom Green

Wenn Sie in Adobe Acrobat oder Adobe Reader exportierte PDF-Dateien anzeigen, sollten Sie die im Folgenden angeführten Einstellungen verwenden.

  1. Wählen Sie in Adobe Acrobat, oder Adobe Reader „Bearbeiten“ > „Voreinstellungen“.

  2. Wählen Sie links im Bedienfeld die Kategorie „Seitenanzeige“ aus.

  3. Setzen Sie die benutzerdefinierte Auflösung auf 72 Pixel/Zoll.

  4. Setzen Sie den Zoom-Wert auf 100 %.

Exportieren von FXG-Dateien

FXG ist ein von Flash Catalyst, Fireworks, Illustrator und Photoshop unterstütztes Format. Wenn Sie über den FXG-Export eine Datei mit Vektor- und Bitmapbildern exportieren, wird ein gesonderter Ordner mit dem Namen <Dateiname.assets> erstellt. Dieser Ordner enthält die mit der Datei verbundenen Bitmapbilder.

Das Importieren wird fehlschlagen, wenn eine der verbundenen Dateien aus diesem Ordner gelöscht wird.

Hinweis:

Elemente, Filter, Mischmodi, Verläufe und Masken, für die es in FXG kein entsprechendes Zuordnungs-Tag gibt, werden als Bitmapgrafiken exportiert.

  1. Wählen Sie „Datei“ > „Exportieren“ und öffnen Sie den Ordner, in dem Sie die Dateien speichern möchten.

  2. Geben Sie einen Namen für die FXG-Datei ein.

  3. Wählen Sie im Dialogfeld „Exportieren“ im Popupmenü „Exportieren“ die Option „FXG und Bilder“ aus.

  4. Klicken Sie auf „Speichern“.

Hinweis:

Objekte, die über die Leinwandränder in Fireworks hinausgehen, werden beim Öffnen der exportierten FXG-Datei in Flash Catalyst vollständig angezeigt.

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie