إذا كنت تكتب دليلاً أو مستندًا مرجعيًّا، فقد ترغب في تضمين إسناد ترافقي لإحالة القارئ من جزء إلى آخر بالمستند. مثال: لمزيد من المعلومات، راجع "فئران الحقول" في صفحة 249. ويمكنك تحديد ما إذا كان الإسناد الترافقي يُستمد من نمط فقرة، مثل نمط عنوان، أم من نقطة ارتساء نص أنشأتها. كما يمكنك تحديد تنسيق الإسناد الترافقي، مثل Page Number Only أو Full Paragraph & Page Number.

إدراج الإسنادات الترافقية

استخدم اللوحة Cross-References لإدراج إسنادات ترافقية في مستندك. لفتح اللوحة، اختر Window > Type & Tables > Cross-References.

اللوحة Cross-References
A. انقر فوق المؤشر المرئي الأخضر للذهاب إلى الوجهة. B. انقر فوق رقم الصفحة لتحديد المصدر. C. انقر فوق الرمز لإنشاء إسناد ترافقي. 

والنص الذي يُرجع إليه هو نص الوجهة. أما النص الذي يتم إنشاؤه من نص الوجهة فهو الإسناد الترافقي للمصدر.

عند إدراج إسناد ترافقي في المستند، يمكنك الاختيار من عدة تنسيقات مصممة مسبقًا، أو يمكنك إنشاء تنسيقك الخاص. يمكنك تطبيق نمط حرف على مصدر الإسناد الترافقي بأكمله، أو على النص ضمن الإسناد الترافقي. ويمكن مزامنة تنسيقات الإسناد الترافقي عبر الكتب.

نص مصدر الإسناد الترافقي قابل للتحرير ويمكن أن يمتد عبر الأسطر.

ملاحظة:

يتم تضمين الإسنادات الترافقية في ملفات Adobe PDF المصدرة إذا تم تحديد الروابط التشعبية في شاشة تصدير Adobe PDF في InDesign. ويتم تضمين الإسنادات الترافقية في ملف SWF المُصدّر في حالة تحديد Include Hyperlinks في مربع الحوار SWF.

إدراج الإسنادات الترافقية
إدراج الإسنادات الترافقية
  1. ضع نقطة الإدراج حيث تريد إدراج الإسناد الترافقي.
  2. قم بأي مما يلي لفتح مربع الحوار New Cross-Reference:

    • اختر Type > Hyperlinks & Cross-References > Insert Cross-Reference.

    • اختر Window > Type & Tables > Cross-References، ثم اختر Insert Cross-Reference من قائمة اللوحة.

    • انقر زر Create New Cross-Reference في اللوحة.

  3. في مربع الحوار ، اختر Paragraph أو Text Anchor من قائمة Link To.

    في حالة اختيار Paragraph، يمكنك إنشاء إسناد ترافقي إلى أي فقرة في المستند تحددها.

    إذا اخترت Text Anchor، يمكنك إنشاء إسناد ترافقي إلى أي نص أنشأت وجهة رابط تشعبي فيه. (راجع إنشاء وجهة رابط تشعبي). ويفيد إنشاء نقطة ارتساء نص على وجه الخصوص إذا كنت تريد استخدام نص مختلف غير الفقرة الوجهة الفعلية.

  4. بالنسبة إلى الخيار Document، حدد المستند الذي يحتوي على الوجهة التي تريد الرجوع إليها. يتم إدراج كل المستندات المفتوحة التي تم حفظها في القائمة المنبثقة. وإذا لم يكن المستند الذي تبحث عنه مفتوحًا، فاختر Browse، وحدد مكان الملف، ثم انقر Open.
  5. انقر نمط فقرة في المربع الأيسر لتقليل الاختيارات، ثم حدد الفقرة التي تريد الرجوع إليها. (أو في حالة تحديد Text Anchor، اختر نقطة ارتساء النص).
    أثناء إنشاء إسناد ترافقي، يمكن البحث عن فقرة معينة من قائمة الفقرات بمساعدة شريط البحث. يتم دعم أنواع البحث التالية:

    • البحث من البداية - لمطابقة التسلسل من بداية الفقرة.
    • Search anywhere - لمطابقة التسلسل من أي مكان في الفقرة.
  6. اختر تنسيق الإسناد الترافقي الذي تريد استخدامه من قائمة Format.

    يمكنك تحرير تنسيقات الإسناد الترافقي هذه أو إنشاء التنسيق الخاص بك. راجع استخدام تنسيقات الإسناد الترافقي.

  7. حدد خيارات مظهر PDF للإسناد الترافقي.

  8. انقر فوق OK.

عند إدراج إسناد ترافقي، تظهر علامة نقطة ارتساء نص في بداية الفقرة الوجهة. يمكنك عرض هذه العلامة عندما تختار Type > Show Hidden Characters. وفي حالة نقل هذه العلامة أو حذفها، يصبح الإسناد الترافقي غير محلول.

استخدام تنسيقات الإسنادات الترافقية

تظهر عدة تنسيقات للإسنادات الترافقية في مربع الحوار New Cross-Reference بشكل افتراضي. ويمكنك تحرير هذه التنسيقات أو حذفها، أو إنشاء التنسيقات الخاصة بك.

ملاحظة:

إذا قمت بحذف أو تحرير تنسيقات الإسنادات الترافقية في المستند وأردت إعادتها إلى التنسيقات الافتراضية، يمكنك اختيار Load Cross-Reference Formats من قائمة اللوحة واختيار مستند بتنسيقات غير محررة. ويمكنك أيضًا مزامنة تنسيقات الإسنادات الترافقية في الكتب.

إنشاء تنسيقات الإسنادات الترافقية أو تحريرها

بخلاف الإعدادات المسبقة الأخرى، يمكن تحرير تنسيقات الإسنادات الترافقية وحذفها. عند تحرير تنسيق إسناد ترافقي، يتم تحديث أي إسناد ترافقي مصدر يستخدم ذلك التنسيق تلقائيًا.

  1. قم بتنفيذ أي من الإجراءات التالية:
    • اختر Define Cross-Reference Formats من قائمة اللوحة Cross-References.

    • أثناء إسناد ترافقي أو تحريره، انقر الزر Create Or Edit Cross-Reference Formats.

  2. في مربع الحوار Cross-Reference Formats، قم بأحد الإجراءات التالية:
    • لتحرير تنسيق، حدد التنسيق الموجود على اليسار.

    • لإنشاء تنسيق، حدد تنسيقًا لبناء التنسيق الجديد عليه، ثم انقر فوق الزرCreate Format . يؤدي هذا إلى إنشاء تكرار للتنسيق المحدد.

  3. بالنسبة إلى الخيار Name، حدد اسم التنسيق.
  4. في مربع نص Definition، قم بإضافة أو إزالة أي نص حسب الحاجة. انقر أيقونة Building Block لإدراج كتل برمجية إنشائية من قائمة. انقر أيقونة Special Characters لتحديد الشُرَط، والمسافات، وعلامات التنصيص، والحروف الخاصة الأخرى.
  5. لتطبيق نمط حرف على الإسناد الترافقي بأكمله، حدد Character Style For Cross-Reference، ثم اختر أو أنشئ نمط حرف من القائمة.

    يمكنك أيضًا استخدام كتلة Character Style البرمجية الإنشائية لتطبيق نمط حرف على نص ضمن الإسناد الترافقي.

  6. انقر Save لحفظ التغييرات. انقر OK عند الانتهاء.

الكتل البرمجية الإنشائية للإسنادات الترافقية

الكتلة البرمجية الإنشائية

ما تقوم به

مثال

رقم الصفحة

يُدرج رقم الصفحة.

في صفحة <pageNum/>

في صفحة 23

رقم الفقرة

يُدرج رقم الفقرة في إسناد ترافقي إلى قائمة مرقمة.

راجع <paraNum/>

راجع 1

في هذا المثال، يُستخدم "1" فقط من الفقرة، "1. الحيوانات".

نص الفقرة

يُدرج نص الفقرة دون رقم الفقرة في إسناد ترافقي إلى قائمة مرقمة.

راجع “<paraText/>”

راجع "الحيوانات"

في هذا المثال، تُستخدم "الحيوانات" فقط من الفقرة، "1. الحيوانات".

فقرة بأكملها

تُدرج الفقرة بأكملها، بما في ذلك رقم الفقرة ونص الفقرة.

راجع “<fullPara/>”

راجع "1. الحيوانات"

فقرة جزئية

تتيح لك إنشاء إسناد ترافقي إلى الجزء الأول من فقرة، وحتى الحد المعين، مثل فاصلة أو واصلة طويلة.

راجع <fullPara delim=”:” includeDelim=”false”/>

راجع الفصل 7

في هذا المثال، يُستخدم "الفصل 7" فقط من العنوان "الفصل 7: الكلاب والقطط".

يعين المحدد (مثلاً: في هذا المثال)، ويوضح ما إذا كان المحدد مستثنى ("خطأ" أو "0") أو متضمنًا ("صحيح" أو "1") في الإسناد الترافقي المصدر.

راجع إنشاء إسنادات ترافقية إلى فقرات جزئية.

اسم نقطة ارتساء النص

يُدرج اسم نقطة ارتساء النص. يمكنك إنشاء نقاط ارتساء نص باختيار New Hyperlink Destination من قائمة لوحة Hyperlinks.

راجع <txtAnchrName/>

راجع الشكل 1

رقم الفصل

يُدرج رقم الفصل.

في الفصل <chapNum/>

في الفصل 3

اسم الملف

يُدرج اسم الملف للمستند الوجهة.

في <fileName/>

في newsletter.indd

نمط الحروف

يُطبّق نمط حرف على نص ضمن إسناد ترافقي.

راجع <cs name=”bold”><fullPara/></cs> في صفحة <pageNum>

راجع الحيوانات في صفحة 23.

يحدد اسم نمط الحرف، ويشمل النص الذي تريد تطبيق نمط الحرف عليه بين العلامات <cs name=""> و </cs>

راجع تطبيق أنماط الحرف ضمن إسناد ترافقي.

إنشاء إسنادات ترافقية إلى فقرات جزئية

يمكنك تصميم تنسيقات الإسنادات الترافقية لتتضمن الجزء الأول فقط من الفقرة. على سبيل المثال، إذا كانت لديك عناوين في المستند تبدو على هيئة "الفصل 7- من غرناطة إلى برشلونة"، يمكنك إنشاء إسناد ترافقي يُحيل إلى "الفصل 7" فقط.

إسناد ترافقي إلى فقرة جزئية
إسناد ترافقي إلى فقرة جزئية

A. ينتهي مصدر الإسناد الترافقي عند الواصلة الطويلة (^_( B. "خطأ" يستثني الواصلة الطويلة من المصدر 

عند إدراج كتلة Partial Paragraph البرمجية الإنشائية، يجب القيام بأمرين. أولاً، قم بتعيين المحدد بين علامات التنصيص. المحدد هو الحرف الذي ينهي الفقرة. تتضمن المحددات الشائعة الفواصل (الفصل 7: غرناطة)، والنقاط (الفصل 7. غرناطة)، والشُرَط (الفصل 7- غرناطة). لإدراج حروف خاصة مثل الواصلات الطويلة (^_)، والمسافات الطويلة (^m)، ورموز التعداد النقطي (^8)، اختر خيارًا من القائمة التي تظهر عند نقر أيقونة Special Characters.

ثانيًا، توضيح ما إذا كان الرمز المحدد مستثنى (الفصل 7) أو متضمن (الفصل 7-). استخدم includeDelim=”false” لاستثناء المحدد و includeDelim=”true” لتضمين المحدد. بدلاً من "خطأ" أو "صحيح"، يمكنك استخدام "0" أو "1"، على التوالي.

تطبيق أنماط الحرف ضمن إسناد ترافقي.

إذا كنت تريد التأكيد على جزء من نص ضمن إسناد ترافقي، يمكنك استخدم كتلة Character Style البرمجية الإنشائية. تتكون الكتلة البرمجية الإنشائية هذه من علامتين. العلامة <cs name=”stylename”> تشير إلى النمط المطبق، والعلامة </cs> تنهي نمط الحرف. وأي نص أو كتلة برمجية إنشائية بين هذه العلامات يكون منسقًا بالنمط المحدد.

تطبيق نمط حرف&nbsp;
تطبيق نمط حرف على قسم من الإسناد الترافقي.

A. تطبق هذه العلامة نمط حرف يُسمى "Red". B. تنهي هذه العلامة تنسيق نمط الحرف. C. يتم تطبيق نمط حرف يُسمى " Bold" على بقية مصدر الإسناد الترافقي. 
  1. أنشئ نمط الحرف الذي تريد استخدامه.
  2. في مربع الحوار Cross-Reference Formats، قم بإنشاء أو تحرير التنسيق الذي تريد تطبيقه.
  3. ضمن Definition، حدد النص والكتل البرمجية الإنشائية والتي تريد تطبيق نمط الحرف عليها.
  4. اختر Character Style من القائمة على يمين قائمة التعريف.
  5. اكتب اسم نمط الحرف بين علامات التنصيص تمامًا كما يظهر في لوحة Character Styles.

    أسماء النمط حساسة لحالة الأحرف. إذا كان نمط الحرف في مجموعة، فاكتب اسم المجموعة متبوعًا بعلامة النقطتين قبل نمط الحرف، مثل مجموعة النمط 1: أحمر.

  6. انقر Save لحفظ التنسيق، ثم انقر OK.

تحميل (استيراد) تنسيقات الإسنادات الترافقية

عند تحميل تنسيقات إسنادات ترافقية من مستند آخر، تستبدل التنسيقات الواردة أي تنسيقات موجودة تتشارك في نفس الاسم.

في InCopy، يمكنك استيراد تنسيقات إسنادات ترافقية فقط في المستندات المستقلة. لا يمكنك استيراد تنسيقات من مستند InCopy إلى مستند InDesign. إذا كان التنسيق الجديد أو المُعدل في مستند InCopy يتعارض مع تنسيق في مستند InDesign عند إيداع المجموعة النصية، يأخذ تنسيق InDesign الأولوية.

  1. اختر Load Cross-Reference Formats من قائمة اللوحة Cross-References.

  2. انقر نقرتين فوق المستند الذي يحتوي على تنسيقات الإسنادات الترافقية التي تريد استيرادها.

يمكنك أيضًا مشاركة تنسيقات الإسنادات الترافقية عبر المستندات من خلال مزامنة كتاب.

حذف تنسيقات الإسنادات الترافقية

لا يمكنك حذف تنسيق إسناد ترافقي تم تطبيقه على إسنادات ترافقية في المستند.

  1. في مربع الحوار Cross-Reference Formats، حدد التنسيق الذي تريد أن تحذفه.
  2. انقر فوق زر Delete Format .

إدارة الإسنادات الترافقية

عند إدراج إسناد ترافقي، تشير اللوحة Cross-References إلى حالة الإسناد الترافقي. على سبيل المثال، تشير الأيقونات إلى ما إذا كان نص الوجهة يظهر على اللوحة المؤقتة ، أو صفحة رئيسية ، أو طبقة مخفية ، أو في نص زائد ، أو في نص مخفي. الإسنادات الترافقية التي ترتبط بمناطق الوجهة تكون غير محلولة. تتيح لك اللوحة أيضًا معرفة ما إذا كانت فقرة الوجهة تم تحريرها (تسمى أيضًا قديمة أو مفقودة. يكون نص الوجهة مفقودًا إذا تعذر العثور على نص الوجهة أو الملف الذي يحتوي على نص الوجهة. ضع مؤشر الماوس على أي أيقونة لعرض وصف تنويه الأداة.

في InCopy، يمكنك إدارة الإسنادات الترافقية فقط في حالة سحب المجموعة النصية للتحرير.

تحديث الإسنادات الترافقية

تشير أيقونة تحديث إلى تغيير نص وجهة الإسناد الترافقي أو إلى تحرير نص مصدر الإسناد الترافقي. يمكنك تحديث الإسناد الترافقي بسهولة. إذا تحركت الوجهة إلى صفحة مختلفة، يتم تحديث الإسناد الترافقي تلقائيًا.

عند تحديث إسناد ترافقي، تتم إزالة أي تغييرات في التنسيق أجريتها على نص المصدر.

عند الطباعة أو الإخراج سيتم إخبارك ما إذا كانت الإسنادات الترافقية قديمة أو لا غير محلولة.

ملاحظة:

يمكنك أيضًا استخدام لوحة Preflight لتنبيهك عندما يكون الإسناد الترافقي قديمًا أو غير محلول. عند تحديد ملف تعريف، حدد Cross-References في قسم Text. راجع تحديد ملفات تعريف الاختبار المبدئي.

  1. حدد إسنادًا ترافقيًا قديمًا واحدًا أو أكثر. لتحديث كل الإسنادات الترافقية، تأكد من عدم تحديد أيٍّ منها.
  2. قم بتنفيذ أي من الإجراءات التالية:
    • انقر فوق الزر Update Cross-References في لوحة Cross-References.

    • اختر Update Cross-Reference من قائمة اللوحة Cross-References.

    • اختر Type > Hyperlinks & Cross-References > Update Cross-Reference.

لتحديث كل الإسنادات الترافقية في كتاب، اختر Update All Cross-References من قائمة لوحة الكتاب. يتم تنبيهك إذا بقيت أي إسنادات ترافقية غير محلولة.

في حالة نقل نص الوجهة المفقود إلى مستند مختلف، أو إذا كان المستند الذي يحتوي على نص الوجهة معادًا تسميته، يمكنك إعادة ربط الإسناد الترافقي. عند إعادة الربط، تتم إزالة أي تغييرات أُجريت الإسناد الترافقي للمصدر.

  1. في لوحة Cross-References، حدد الإسناد الترافقي الذي ترغب في إعادة ربطه.

  2. اختر Relink Cross-Reference من قائمة لوحة

  3. حدد مكان المستند الذي يظهر به نص الوجهة، ثم انقر Open.

إذا ظهر أي نص آخر في ذلك المستند، يمكنك إعادة ربط الإسنادات الترافقية الإضافية.

تحرير الإسنادات الترافقية

لتغيير مظهر الإسناد الترافقي للمصدر أو لتعيين تنسيق مختلف، يمكنك تحرير الإسناد الترافقي. وإذا قمت بتحرير إسناد ترافقي يرتبط بمستند مختلف، يمكنك تحرير الإسناد الترافقي.

  1. قم بتنفيذ أي من الإجراءات التالية:
    • اختر Type > Hyperlinks & Cross References > Cross-Reference Options.

    • في لوحة Cross-References، انقر نقرًا مزدوجًا فوق الإسناد الترافقي الذي ترغب في تحريره.

    • حدد الإسناد الترافقي، واختر Cross-Reference Options من قائمة اللوحة Cross-References.

  2. حرر الإسناد الترافقي، ثم انقر OK.

حذف الإسنادات الترافقية

عند حذف إسناد ترافقي، يتم تحويل الإسناد الترافقي للمصدر إلى نص.

  1. في اللوحة Cross-References، حدد الإسناد الترافقي أو الإسنادات الترافقية التي ترغب في حذفها.

  2. انقر فوق الرمز Delete، أو اختر Delete Cross-Reference من قائمة اللوحة.

  3. انقر Yes للتأكيد.

لإزالة إسناد ترافقي بالكامل، يمكنك أيضًا تحديد مصدر الإسناد الترافقي وحذفه.

تحرير نص مصدر الإسناد الترافقي

يمكنك تحرير نص مصدر الإسناد الترافقي. وتتمثل الميزة من تحرير نص الإسناد الترافقي في أنه يمكنك تغيير المسافات بين الحروف أو الكلمات حسب الحاجة لاحتواء النسخ أو عمل تغييرات أخرى. أما العيب فهو أنه عند تحديث أو إعادة ربط الإسناد الترافقي، يتغير أي تنسيق محلي أو يُزال.

تم ترخيص هذا العمل بموجب الترخيص العام غير المعدل الخاص بالإسناد وعدم التجارة والمشاركة الإصدار 3.0 ‏من ‏‏Creative Commons‏‏  إن بنود Creative Commons لا تشمل منشورات Twitter™‎ وFacebook.

إشعارات قانونية   |   سياسة الخصوصية على الإنترنت