Beveiligingsupdates beschikbaar voor Adobe Flash Player

Releasedatum: 20 februari 2014

ID kwetsbaarheidsprobleem: APSB14-07

Prioriteit: zie onderstaande tabel

CVE-nummer: CVE-2014-0498, CVE-2014-0499, CVE-2014-0502

Platform: alle platforms

Samenvatting

Adobe heeft beveiligingsupdates uitgebracht voor Adobe Flash Player 12.0.0.44 en eerdere versies voor Windows en Macintosh en Adobe Flash Player 11.2.202.336 en eerdere versies voor Linux. Deze updates verhelpen kwetsbaarheden die ertoe kunnen leiden dat een aanvaller de controle kan krijgen over het geïnfecteerde systeem. Adobe is op de hoogte van meldingen uit de praktijk dat er misbruik wordt gemaakt van een kwetsbaarheid voor CVE-2014-0502 en raadt gebruikers aan hun productinstallaties naar de nieuwste versies bij te werken:

  • Gebruikers van Adobe Flash Player 12.0.0.44 en eerdere versies voor Windows en Macintosh moeten bijwerken naar Adobe Flash Player 12.0.0.70
  • Gebruikers van Adobe Flash Player 11.2.202.336 en eerdere versies voor Linux moeten bijwerken naar Adobe Flash Player 11.2.202.341.
  • Adobe Flash Player 12.0.0.44 geïnstalleerd met Google Chrome wordt automatisch bijgewerkt naar de nieuwste Google Chrome-versie, die Adobe Flash Player 12.0.0.70 voor Windows, Macintosh en Linux bevat.
  • Adobe Flash Player 12.0.0.44 geïnstalleerd met Internet Explorer 10 wordt automatisch bijgewerkt naar de nieuwste versie van Internet Explorer 10, die Adobe Flash Player 12.0.0.70 voor Windows 8.0 omvat.
  • Adobe Flash Player 12.0.0.44 geïnstalleerd met Internet Explorer 11 wordt automatisch bijgewerkt naar de nieuwste versie van Internet Explorer 11, die Adobe Flash Player 12.0.0.70 voor Windows 8.1 bevat.
  • Gebruikers van Adobe AIR 4.0.0.1390 en eerdere versies voor Android dienen een update uit te voeren naar Adobe AIR 4.0.0.1628.
  • Gebruikers van de Adobe AIR 4.0.0.1390-SDK en eerdere versies dienen een update uit te voeren naar de Adobe AIR 4.0.0.1628-SDK.
  • Gebruikers van de Adobe AIR 4.0.0.1390-SDK & compiler en eerdere versies dienen een update uit te voeren naar de Adobe AIR 4.0.0.1628-SDK & compiler.

 

Van toepassing op de volgende softwareversies

  • Adobe Flash Player 12.0.0.44 en eerdere versies voor Windows en Macintosh
  • Adobe Flash Player 11.2.202.336 en eerdere versies voor Linux
  • Adobe AIR 4.0.0.1390 en eerdere versies voor Android
  • Adobe AIR 3.9.0.1390-SDK en eerdere versies
  • Adobe AIR 3.9.0.1390-SDK & compiler en eerdere versies

Als u wilt verifiëren welk versienummer het Adobe Flash Player-exemplaar heeft dat op uw computer is geïnstalleerd, opent u de pagina About Flash Player of klikt u met de rechtermuisknop op inhoud die in Flash Player wordt afgespeeld en selecteert u 'Informatie over Adobe (of Macromedia) Flash Player' in het menu. Als u meerdere browsers gebruikt, voert u deze controle uit voor elke browser die op uw systeem is geïnstalleerd.

Als u de versie van Adobe Flash Player voor Android wilt verifiëren, gaat u naar Instellingen > Toepassingen > Toepassingen beheren > Adobe Flash Player x.x.

Als je het versienummer wilt verifiëren van het Adobe AIR-exemplaar dat op je computer is geïnstalleerd, open je het technische artikel van Adobe AIR voor instructies.

Oplossing

Adobe raadt gebruikers aan om hun software bij te werken aan de hand van de onderstaande instructies:

  • Adobe raadt gebruikers van Adobe Flash Player 12.0.0.44 en eerdere versies voor Windows en Macintosh aan een update uit te voeren naar de nieuwste versie 12.0.0.70 door deze te downloaden vanuit het Downloadcentrum voor Adobe Flash Player. Ze kunnen ook het updatemechanisme in het product zelf gebruiken wanneer hierover een melding verschijnt.
  • Adobe raadt gebruikers van Adobe Flash Player 11.2.202.336 en eerdere versies voor Linux aan een update uit te voeren naar Adobe Flash Player 11.2.202.341 door deze te downloaden vanuit het Downloadcentrum voor Adobe Flash Player.
  • Voor gebruikers van Flash Player 11.7.700.261 en eerdere versies voor Windows en Macintosh die niet kunnen bijwerken naar Flash Player 12.0.0.44, heeft Adobe de update Flash Player 11.7.700.269 beschikbaar gesteld. Deze update kunt u hier downloaden.
  • Adobe Flash Player 12.0.0.44 geïnstalleerd met Google Chrome wordt automatisch bijgewerkt naar de nieuwste Google Chrome-versie, die Adobe Flash Player 12.0.0.70 voor Windows, Macintosh en Linux bevat.
  • Adobe Flash Player 12.0.0.44 geïnstalleerd met Internet Explorer 10 wordt automatisch bijgewerkt naar de nieuwste versie van Internet Explorer 10, die Adobe Flash Player 12.0.0.70 voor Windows 8.0 omvat.
  • Adobe Flash Player 12.0.0.44 geïnstalleerd met Internet Explorer 11 wordt automatisch bijgewerkt naar de nieuwste versie van Internet Explorer 11, die Adobe Flash Player 12.0.0.70 voor Windows 8.1 bevat.
  • Gebruikers van de Adobe AIR 4.0.0.1390-SDK dienen een update uit te voeren naar de Adobe AIR 4.0.0.1628-SDK.
  • Gebruikers van de Adobe AIR 4.0.0.1390-SDK & compiler en eerdere versies dienen een update uit te voeren naar de Adobe AIR 4.0.0.1680-SDK & compiler.
  • Gebruikers van Adobe AIR 4.0.0.1390 en eerdere versies voor Android dienen een update uit te voeren naar Adobe AIR 4.0.0.1628 door op een Android-apparaat naar Google Play te surfen.

Graadmeter voor prioriteit en ernst

Adobe heeft aan deze updates de volgende prioriteit toegekend en raadt gebruikers aan hun installatie bij te werken naar de recentste versies:

Product Bijgewerkte versie Platform Prioriteitsbeoordeling
Adobe Flash Player 12.0.0.70
Windows en Macintosh
1
  12.0.0.70 Internet Explorer 10 voor Windows 8.0 1
  12.0.0.70 Internet Explorer 11 voor Windows 8.1 1
  12.0.0.70 Chrome voor Windows, Macintosh en Linux 1
  11.7.700.269 Windows en Macintosh 1
  11.2.202.341 Linux 3
Adobe AIR 4.0.0.1628 Android 3
Adobe AIR-SDK & compiler 4.0.0.1628 Windows en Macintosh
3
Adobe AIR-SDK 4.0.0.1628 Windows en Macintosh 3

Deze updates verhelpen kritieke kwetsbaarheden in de software.

Details

Adobe heeft beveiligingsupdates uitgebracht voor Adobe Flash Player 12.0.0.44 en eerdere versies voor Windows en Macintosh en Adobe Flash Player 11.2.202.336 en eerdere versies voor Linux. Deze updates verhelpen kwetsbaarheden die ertoe kunnen leiden dat een aanvaller de controle kan krijgen over het geïnfecteerde systeem. Adobe is op de hoogte van meldingen uit de praktijk dat er misbruik wordt gemaakt van een kwetsbaarheid voor CVE-2014-0502 en raadt gebruikers aan hun productinstallaties naar de nieuwste versies bij te werken:

  • Gebruikers van Adobe Flash Player 12.0.0.44 en eerdere versies voor Windows en Macintosh moeten bijwerken naar Adobe Flash Player 12.0.0.70
  • Gebruikers van Adobe Flash Player 11.2.202.336 en eerdere versies voor Linux moeten bijwerken naar Adobe Flash Player 11.2.202.341.
  • Adobe Flash Player 12.0.0.44 geïnstalleerd met Google Chrome wordt automatisch bijgewerkt naar de nieuwste Google Chrome-versie, die Adobe Flash Player 12.0.0.70 voor Windows, Macintosh en Linux bevat.
  • Adobe Flash Player 12.0.0.44 geïnstalleerd met Internet Explorer 10 wordt automatisch bijgewerkt naar de nieuwste versie van Internet Explorer 10, die Adobe Flash Player 12.0.0.70 voor Windows 8.0 omvat.
  • Adobe Flash Player 12.0.0.44 geïnstalleerd met Internet Explorer 11 wordt automatisch bijgewerkt naar de nieuwste versie van Internet Explorer 11, die Adobe Flash Player 12.0.0.70 voor Windows 8.1 bevat.
  • Gebruikers van Adobe AIR 4.0.0.1390 en eerdere versies voor Android dienen een update uit te voeren naar Adobe AIR 4.0.0.1628.
  • Gebruikers van de Adobe AIR 4.0.0.1390-SDK en eerdere versies dienen een update uit te voeren naar de Adobe AIR 4.0.0.1628-SDK.
  • Gebruikers van de Adobe AIR 4.0.0.1390-SDK & compiler en eerdere versies dienen een update uit te voeren naar de Adobe AIR 4.0.0.1628-SDK & compiler.

Deze updates verhelpen een kwetsbaarheid voor stackoverloop die tot uitvoering van willekeurige code kan leiden (CVE-2014-0498).

Deze updates verhelpen een kwetsbaarheid met een geheugenlek waarmee de willekeurige indeling van geheugenadressen kan worden uitgeschakeld (CVE-2014-0499).

Deze updates verhelpen een double free-kwetsbaarheid die tot uitvoering van willekeurige code kan leiden (CVE-2014-0502).

Betrokken software     Aanbevolen Player-update Beschikbaarheid
Flash Player 12.0.0.44 en eerdere versies voor Windows en Macintosh   12.0.0.70 Flash Player Download Center
Flash Player 12.0.0.44 en eerdere versies (netwerkdistributie)   12.0.0.70 Flash Player-licenties
Flash Player 11.2.202.336 en eerder voor Linux   11.2.202.336 Flash Player Download Center
Flash Player 12.0.0.44 en eerder voor Chrome (Windows, Macintosh en Linux)   12.0.0.70
Google Chrome-releases
Flash Player 12.0.0.44 en eerder in Internet Explorer 10 voor Windows 8.0   12.0.0.70
Microsoft-beveiligingsadvies
Flash Player 12.0.0.44 en eerder in Internet Explorer 11 voor Windows 8.1   12.0.0.70
Microsoft-beveiligingsadvies
AIR 4.0.0.1390 en eerder voor Android   4.0.0.1628 Google Play
AIR 4.0.0.1390-SDK & compiler   4.0.0.1628 AIR SDK-download
AIR 4.0.0.1390-SDK   4.0.0.1628 AIR SDK-download

Dankbetuigingen

Adobe bedankt de volgende personen en organisaties voor het melden van de relevante problemen en voor hun inspanningen om samen met Adobe onze klanten te beschermen: