Beveiligingsupdates beschikbaar voor Adobe Flash Player

Releasedatum: 12 mei 2016

Laatst bijgewerkt: 3 juni 2016

ID kwetsbaarheidsprobleem: APSB16-15

Prioriteit: zie onderstaande tabel

CVE-nummers: CVE-2016-1096, CVE-2016-1097, CVE-2016-1098, CVE-2016-1099, CVE-2016-1100, CVE-2016-1101, CVE-2016-1102, CVE-2016-1103, CVE-2016-1104, CVE-2016-1105, CVE-2016-1106, CVE-2016-1107, CVE-2016-1108, CVE-2016-1109, CVE-2016-1110, CVE-2016-4108, CVE-2016-4109, CVE-2016-4110, CVE-2016-4111, CVE-2016-4112, CVE-2016-4113, CVE-2016-4114, CVE-2016-4115, CVE-2016-4116, CVE-2016-4117, CVE-2016-4120, CVE-2016-4121, CVE-2016-4160, CVE-2016-4161, CVE-2016-4162, CVE-2016-4163

Platform: Windows, Macintosh, Linux en Chrome OS

Samenvatting

Adobe heeft beveiligingsupdates uitgebracht voor Adobe Flash Player voor Windows, Macintosh, Linux en Chrome OS.  Deze updates verhelpen kritieke kwetsbaarheden die ertoe kunnen leiden dat een aanvaller de controle verkrijgt over het betreffende systeem.  Adobe is op de hoogte van een rapport waarin wordt gemeld dat er misbruik voor CVE-2016-4117 bestaat. Raadpleeg APSA16-02 voor meer informatie.

Van toepassing op de volgende versies

Product Van toepassing op de volgende versies Platform
Desktopruntime van Adobe Flash Player 21.0.0.226 en eerder
Windows en Macintosh
Adobe Flash Player Extended Support Release 18.0.0.343 en eerder Windows en Macintosh
Adobe Flash Player voor Google Chrome 21.0.0.216 en eerder Windows, Macintosh, Linux en Chrome OS
Adobe Flash Player voor Microsoft Edge en Internet Explorer 11 21.0.0.241 en eerder Windows 10
Adobe Flash Player voor Internet Explorer 11 21.0.0.241 en eerder Windows 8.1
Adobe Flash Player voor Linux 11.2.202.616 en eerder Linux
AIR-desktopruntime 21.0.0.198 en eerder Windows en Macintosh
AIR SDK 21.0.0.198 en eerder Windows, Macintosh, Android en iOS
AIR SDK & Compiler 21.0.0.198 en eerder Windows, Macintosh, Android en iOS
  • Als u wilt verifiëren welk versienummer het Adobe Flash Player-exemplaar heeft dat op uw computer is geïnstalleerd, opent u de pagina About Flash Player of klikt u met de rechtermuisknop op inhoud die in Flash Player wordt afgespeeld en selecteert u 'Informatie over Adobe (of Macromedia) Flash Player' in het menu. Als u meerdere browsers gebruikt, voert u deze controle uit voor elke browser die op uw systeem is geïnstalleerd.  
  • Als u het versienummer wilt verifiëren van het Adobe AIR-exemplaar dat op uw computer is geïnstalleerd, volgt u de instructies in het technische artikel voor Adobe AIR.

Oplossing

Adobe heeft aan deze updates de volgende prioriteit toegekend en raadt gebruikers aan hun installatie bij te werken naar de recentste versies:

Product Bijgewerkte versies Platform Prioriteitsbeoordeling Beschikbaarheid
Desktopruntime van Adobe Flash Player
21.0.0.242 Windows en Macintosh
1

Flash Player Download Center

Distributie Flash Player

Adobe Flash Player Extended Support Release 18.0.0.352 Windows en Macintosh
1 Uitgebreide ondersteuning
Adobe Flash Player voor Google Chrome 21.0.0.242 Windows, Macintosh, Linux en Chrome OS   1 Google Chrome-releases
Adobe Flash Player voor Microsoft Edge en Internet Explorer 11 21.0.0.242 Windows 10 en 8.1 1 Microsoft-beveiligingsadvies
Adobe Flash Player voor Linux 11.2.202.621 Linux 3 Flash Player Download Center
AIR-desktopruntime 21.0.0.215 Windows en Macintosh 3 AIR Download Center
AIR SDK 21.0.0.215 Windows, Macintosh, Android en iOS 3 AIR SDK-download
AIR SDK & Compiler 21.0.0.215 Windows, Macintosh, Android en iOS 3 AIR SDK-download
  • Adobe adviseert gebruikers van Adobe Flash Player Desktop Runtime voor Windows en Macintosh een update uit te voeren naar 21.0.0.242 via het mechanisme voor updates in het product wanneer ze daarom worden gevraagd[1], of door het Adobe Flash Player Download te bezoeken.
  • Adobe raadt gebruikers van de Adobe Flash Player Extended Support Release (ESR; release met uitgebreide ondersteuning) aan een update uit te voeren naar versie 18.0.0.352 door naar http://helpx.adobe.com/nl/flash-player/kb/archived-flash-player-versions.html te gaan.
  • Adobe raadt gebruikers van Adobe Flash Player voor Linux aan een update uit te voeren naar Adobe Flash Player 11.2.202.621 door naar het Adobe Flash Player Download Center te gaan.
  • De versie van Adobe Flash Player die wordt geïnstalleerd met Google Chrome, wordt automatisch bijgewerkt naar de nieuwste versie van Google Chrome, die Adobe Flash Player 21.0.0.242 voor Windows, Macintosh, Linux en Chrome OS bevat.
  • De versie van Adobe Flash Player die wordt geïnstalleerd met Microsoft Edge en Internet Explorer voor Windows 10 en 8.1 wordt automatisch bijgewerkt naar de nieuwste versie, die Adobe Flash Player 21.0.0.242 bevat. 
  • Adobe raadt gebruikers van de AIR-desktopruntime, AIR SDK en AIR SDK & Compiler aan een update uit voeren naar versie 21.0.0.215 door naar het AIR Download Center of het AIR Developer Center te gaan.
  • Ga naar de pagina Flash Player Help voor hulp bij het installeren van Flash Player.

[1] Gebruikers van Flash Player 11.2.x of hoger voor Windows of Flash Player 11.3.x of hoger voor Macintosh die de optie 'Adobe toestaan updates te installeren' hebben ingeschakeld, ontvangen de update automatisch. Gebruikers die de optie “Adobe toestaan updates te installeren” niet hebben ingeschakeld, kunnen de update installeren door het mechanisme voor automatische updates in het product te gebruiken wanneer hierover een melding verschijnt.

Details van kwetsbaarheid

  • Deze updates verhelpen kwetsbaarheden voor niet-compatibele typen die tot code-uitvoering kunnen leiden (CVE-2016-1105, CVE-2016-4117).
  • Deze updates verhelpen een kwetsbaarheid voor heapbufferoverloop die tot code-uitvoering kan leiden (CVE-2016-1097, CVE-2016-1106, CVE-2016-1107, CVE-2016-1108, CVE-2016-1109, CVE-2016-1110, CVE-2016-4108, CVE-2016-4110, CVE-2016-4121).
  • Deze updates verhelpen een kwetsbaarheid voor heap-bufferoverloop die tot code-uitvoering kan leiden (CVE-2016-1101).
  • Deze updates verhelpen een kwetsbaarheid voor bufferoverloop die tot code-uitvoering kan leiden (CVE-2016-1103).
  • Deze updates verhelpen kwetsbaarheden voor geheugenbeschadiging die tot code-uitvoering kunnen leiden (CVE-2016-1096, CVE-2016-1098, CVE-2016-1099, CVE-2016-1100, CVE-2016-1102, CVE-2016-1104, CVE-2016-4109, CVE-2016-4111, CVE-2016-4112, CVE-2016-4113, CVE-2016-4114, CVE-2016-4115, CVE-2016-4120CVE-2016-4160, CVE-2016-4161, CVE-2016-4162, CVE-2016-4163).
  • Deze updates verhelpen een kwetsbaarheid in het zoekpad van directory's dat wordt om bronnen te zoeken die tot code-uitvoering kunnen leiden (CVE -2016-4116).

Dankbetuigingen

  • Nicolas Joly van Microsoft Vulnerability Research (CVE-2016-1108, CVE-2016-1109, CVE-2016-1110)
  • Wen Guanxing van Pangu LAB, werkend met het Chromium Vulnerability Rewards Program (CVE-2016-1097)
  • Mateusz Jurczyk en Natalie Silvanovich van Google Project Zero (CVE-2016-1096, CVE-2016-1101, CVE-2016-1102, CVE-2016-1103, CVE-2016-1104)
  • Wen Guanxing van Pangu LAB (CVE-2016-1098, CVE-2016-1099, CVE-2016-1100)
  • willJ van Tencent PC Manager (CVE-2016-4109, CVE-2016-4110, CVE-2016-4111, CVE-2016-4112, CVE-2016-4113, CVE-2016-4114, CVE-2016-4115)
  • Ladislav Baco van CSIRT.SK (CVE-2016-4116)
  • Natalie Silvanovich van Google Project Zero (CVE-2016-1105, CVE-2016-1106, CVE-2016-4108)
  • Het beveiligingsteam van NSFOCUS (CVE-2016-1107)
  • Genwei Jiang van FireEye, Inc. (CVE-2016-4117)
  • bee13oy van CloverSec Labs (CVE-2016-4121)
  • Yuki Chen van Qihoo 360 Vulcan Team (CVE-2016-4120, CVE-2016-4160, CVE-2016-4161, CVE-2016-4162, CVE-2016-4163)

Revisies

13 mei 2016: de betrokken versies van Flash Player voor Microsoft Edge en Internet Explorer 11 zijn aangepast op Windows 10 en 8.1 van 21.0.0.213 en eerder tot 21.0.0.241 en eerder.  

19 mei 2016: CVE-2016-4120 en CVE-2016-4121 toegevoegd, die zijn opgelost in deze release, maar onopzettelijk niet zijn vermeld in de oorspronkelijke release van het bulletin. 

3 juni 2016: CVE-2016-4160, CVE-2016-4161, CVE-2016-4162 en CVE-2016-4163 toegevoegd, die zijn opgelost in deze release, maar onopzettelijk niet zijn vermeld in de oorspronkelijke release van het bulletin.