Rozwiązywanie problemów z procesorem graficznym (GPU) i sterownikiem karty graficznej | Lightroom

Ostatnia aktualizacja 24 maj 2023

Omówienie

Problemy wymienione poniżej mogą być spowodowane wadliwym, nieobsługiwanym lub niekompatybilnym procesorem graficznym (zwanym również kartą graficzną lub GPU) bądź sterownikiem karty graficznej. Rozwiązania wymienione w tej sekcji mogą pomóc w wyeliminowaniu następujących problemów:

  • Program Lightroom ulega awarii podczas uruchamiania, ulega awarii lub zawiesza w ogóle albo zwalnia bez wyjaśnienia.
  • Przesunięcie podstawowych suwaków wywoływania powoduje nieoczekiwane migotanie jasności obrazu lub przesunięcie kolorów
  • Pod polem wyboru „Użyj procesora graficznego” w oknie preferowanych ustawień wydajności Lightroom pojawia się komunikat „Przyspieszenie procesora graficznego zostało wyłączone z powodu błędów”.

Rozwiązanie 1: Wyłączanie procesora graficznego w celu szybkiego zidentyfikowania przyczyny problemu

Aby szybko sprawdzić, czy problem jest związany z procesorem graficznym lub sterownikiem, wykonaj poniższe kroki:

Uruchom program Lightroom.

Przejdź do jednego z następujących folderów:

  • (macOS) Lightroom > Preferencje > Ogólne
  • (Windows) Edycja > Preferencje > Ogólne

Usuń zaznaczenie opcji Użyj procesora graficznego.

Zamknij i ponownie uruchom program Lightroom.

Jeśli problem ustąpił, prawdopodobnie był spowodowany procesorem graficznym lub sterownikiem. Zobacz Rozwiązanie 4: Kroki rozwiązywania problemów z procesorem graficznym i sterownikiem graficznym, aby zapoznać się z dalszymi krokami rozwiązywania problemów. Jeśli problem nadal występuje, procesor graficzny nie jest przyczyną. 

Rozwiązanie 2: Ręczne wyłączenie procesora graficznego

Jeśli nie można uruchomić programu Lightroom lub program ulega awarii, zanim można usunąć zaznaczenie w polu Użyj procesora graficznego, oto jak ręcznie wyłączyć te preferencje:

Przejdź do jednego z następujących folderów:

  • (macOS) /Users/[nazwa użytkownika]/Library/Preferences/com.adobe.lightroomCC.plist
  • (Windows) C:\Users\[nazwa użytkownika]\AppData\Roaming\Adobe\Lightroom CC\Preferences\Lightroom CC Preferences.agprefs
Spostrzeżenie

(Windows) Niektóre z szukanych folderów mogą być ukryte. Aby je wyświetlić, wybierz kolejno Start > Panel sterowania> Wygląd i personalizacja> Opcje folderów. W obszarze Zaawansowane na karcie Widok upewnij się, że zaznaczona jest opcja Pokaż ukryte pliki i foldery, a następnie kliknij przycisk OK.

(macOS) Plik Biblioteka użytkownika jest ukryty w wersji systemu Mac OS X 10.7 i nowszych. Aby uzyskać tymczasowy dostęp do pliku Biblioteki użytkownika, naciśnij klawisz Option i wybierz polecenie Idź > Biblioteka w programie Finder.

Otwórz plik Lightroom CC Preferences.agprefs (Windows) / com.adobe.lightroomCC.plist (macOS) w edytorze tekstu.

Zmień wiersz useAutoBahn = true na useAutoBahn = false.

Zapisz i zamknij plik Lightroom CC Preferences.agprefs (Windows) / com.adobe.lightroomCC.plist (macOS).

Ponownie uruchom Lightroom.

Rozwiązanie 3: Wymuś używanie DirectX w systemie Windows lub Metal w systemie macOS przez program Lightroom

W przypadku awarii lub problemów z odświeżaniem wypróbuj następujące rozwiązanie:

Przejdź do opcji Pomoc > Informacje o systemie i przewiń do sekcji Informacje o procesorze graficznym w oknie dialogowym Informacje o systemie. Sprawdź, czy układ GPU jest ustawiony na tryb OpenGL.

OpenGL
OpenGL

Zamknij program Lightroom.

Znajdź plik Camera Raw GPU Config.txt.

  • (macOS) /Users/[nazwa użytkownika]/Library/Application Support/Adobe/CameraRaw/GPU/Adobe Lightroom/Camera Raw GPU Config.txt
  • (Windows) \Users\[nazwa użytkownika]\AppData\Roaming\Adobe\CameraRaw\GPU\Adobe Lightroom\Camera Raw GPU Config.txt

Folder Biblioteka jest domyślnie ukryty w systemie macOS X 10.7 i późniejszych wydaniach. Użyj następujących wskazówektutaj.

Ręcznie usuń plik Camera Raw GPU Config.txt.

Ponownie uruchom Lightroom.

Rozwiązanie 4: Rozwiązywanie problemów ze sterownikiem graficznym i GPU

W przypadku wystąpienia któregokolwiek z powyższych problemów spróbuj wykonać poniższe czynności w podanej kolejności.

Upewnij się, że używasz najnowszej wersji programu Lightroom.

Wybierz kolejno opcje Pomoc > Aktualizacje. Więcej informacji zawiera artykuł Aktualizowanie aplikacji Creative Cloud.

Upewnij się, że karta graficzna jest kompatybilna z programem Lightroom. Aby określić markę i model karty graficznej, zapoznaj się z częścią Jak określić markę i model karty graficznej?

Zaktualizuj sterownik karty graficznej.

Jeśli wystąpił którykolwiek z wymienionych powyżej problemów lub program Lightroom nie uzyskuje dostępu do procesora graficznego, a karta graficzna spełnia minimalne wymagania systemowe, zaktualizuj sterownik graficzny.

macOS:

Sterowniki karty graficznej są aktualizowane poprzez aktualizacje systemu operacyjnego. Upewnij się, że masz najnowsze aktualizacje systemu macOS, wybierając opcję Aktualizacja oprogramowania na karcie Aktualizacje w aplikacji ze sklepu App Store.

Windows:

Pobierz najnowsze sterowniki bezpośrednio z witryny producenta karty graficznej:

Wykonaj czystą instalację sterownika karty graficznej

W razie aktualizacji sterownika karty graficznej zaleca się usunięcie wszystkich poprzednich wersji sterownika karty graficznej z komputera przed zainstalowaniem nowego. Nazywa się to czystą instalacją.

Po określeniu marki i modelu karty graficznej na komputerze postępuj zgodnie z dokumentacją producenta karty i poniższymi zasobami:

Po zainstalowaniu aktualizacji ponownie uruchom program Lightroom. Włącz opcję Użyj procesora graficznego w oknie Preferencje i spróbuj ponownie wykonać kroki, które spowodowały problem.

Spostrzeżenie
  • W usłudze Windows Update nie zawsze znajdują się najnowsze i najlepsze sterowniki. Aktualizacje sterowników należy sprawdzać bezpośrednio w witrynie internetowej producenta posiadanej karty.
  • Upewnij się, że wybierasz prawidłowy sterownik. Sterowniki w komputerach przenośnych różnią się czasami nazwą od podobnych sterowników w komputerach stacjonarnych.
  • Niektórzy producenci kart graficznych mają inne oprogramowanie, które należy aktualizować wraz ze sterownikiem wideo. Uważnie przeczytaj instrukcje dotyczące aktualizacji. W razie jakichkolwiek wątpliwości skontaktuj się bezpośrednio z producentem karty graficznej.

Wyłącz akceleratory graficzne innych firm. Programy narzędziowe innych firm oraz haxies do zwiększania częstotliwości taktowania procesora graficznego nie są obsługiwane.

Używanie kilku kart graficznych z powodującymi konflikt sterownikami może prowadzić do problemów z funkcjami korzystającymi z procesora graficznego do przyspieszania lub działania w programie Lightroom. Aby uzyskać najlepsze rezultaty, do tej samej karty graficznej należy podłączyć (przynajmniej) dwa monitory.

(macOS)

Wyłącz opcję  Automatyczne przełączanie grafiki na karcie Oszczędzanie energii w Preferencjach systemowych.

Więcej szczegółów można znaleźć w dokumentacji firmy Apple: https://support.apple.com/en-in/HT202043

(Windows)

Jeśli musisz użyć więcej niż jednej karty graficznej, wyjmij lub wyłącz mniej wydajne karty. Załóżmy na przykład, że masz dwie różne karty korzystające z dwóch różnych sterowników — kartę graficzną NVIDIA i kartę graficzną AMD. W takim przypadku upewnij się, że do programu Lightroom została przypisana karta graficzna o wysokiej wydajności, a nie karta graficzna grafiki zintegrowanej lub energooszczędna karta graficzna.

NVIDIA:

  1. Kliknij prawym przyciskiem myszy w dowolnym miejscu na pulpicie i wybierz panel sterowania NVIDIA.
  2. Kliknij ustawienia opcji Zarządzaj 3D.
  3. c. Kliknij Ustawienia programu i dodaj plik Lightroom.exe. Zmień preferowany procesor graficzny na Wysokowydajny procesor NVIDIA.

AMD:

  1. Kliknij prawym przyciskiem myszy w dowolnym miejscu na pulpicie i wybierz narzędzie AMD Catalyst Control Center lub Configure Switchable Graphics.
  2. Kliknij przycisk Przeglądaj i wybierz opcję Wysoka wydajność zamiast Oszczędzanie energii.

Dodatkowe instrukcje na temat sposobu ustawienia danej karty jako podstawowej karty graficznej w systemie Windows znajdują się w dokumentacji sterownika producenta karty graficznej.

(Windows) Jeżeli poprzedni krok nie umożliwi rozwiązania problemu, rozważ wyłączenie kart graficznych.

Jeśli w systemie Windows używasz więcej niż jednej karty graficznej, Twoja karta z najwyższej półki może nie być ustawiona jako karta główna. Aby wyłączyć słabszą z tych dwóch kart, należy użyć konsoli Menedżer urządzeń w systemie Windows. W konsoli Menedżer urządzeń kliknij prawym przyciskiem myszy nazwę karty i wybierz opcję Wyłącz.

Wyłącz kartę graficzną
Wyłączanie karty graficznej

Nie korzystaj z programu Lightroom na maszynie wirtualnej (VM).

Uruchamianie programu Lightroom w maszynach wirtualnych (VM) nie zostało dokładnie przetestowane ani nie jest oficjalnie obsługiwane ze względu na znane problemy związane z funkcjami zależnymi od procesora graficznego w środowiskach VM.

Po wykonaniu powyższych kroków można sprawdzić rezultaty poprzez włączenie opcji Użyj procesora graficznego w oknie Preferencje.

Jeśli żadne z powyższych rozwiązań nie jest skuteczne, ostatnią opcją jest zakup kompatybilnej karty graficznej lub całkowite wyłączenie procesora graficznego poprzez wykonanie następujących kroków:

  1. Uruchom program Lightroom.
  2. Przejdź do jednego z następujących folderów:
    • (macOS) Lightroom > Preferencje > Ogólne
    • (Windows) Edycja > Preferencje > Ogólne
  3. Usuń zaznaczenie opcji Użyj procesora graficznego.
  4. Zamknij i ponownie uruchom program Lightroom.

Rozwiązywanie problemów z procesorem GPU w programie Lightroom (wersja ze sklepu Microsoft Store)

Jeśli program Lightroom (wersja ze sklepu Microsoft Store) nie może korzystać z procesora graficznego, spróbuj wykonać następujące czynności:

Zamknij program Lightroom.

W polu wyszukiwania wpisz Ustawienia graficzne i naciśnij klawisz Enter.

Wybierz pozycję Aplikacja uniwersalna w menu rozwijanym Wybierz aplikację, aby ustawić preferencje.

Aplikacja uniwersalna
Wybierz pozycję Aplikacja uniwersalna

Wybierz pozycję Adobe Lightroom z menu rozwijanego Wybierz aplikację i kliknij przycisk Dodaj.

W wyświetlonym oknie dialogowym kliknij przycisk Opcje.

Wybierz opcję Wysoka wydajność i kliknij przycisk Zapisz.

Wysoka wydajność
Wybierz opcję Wysoka wydajność

Uruchom program Lightroom.