Saiba como editar, atualizar e excluir modelos no Dreamweaver, e atualize modelos em um site do Contribute.

Quando você efetua alterações e salva um modelo, todos os documentos baseados no modelo são atualizados. Você também pode atualizar manualmente um documento baseado em modelo ou o site inteiro, caso isso seja necessário.

Observação:

Para editar um modelo para um site do Contribute, use o Dreamweaver; não é possível editar modelos no Contribute.

Use a categoria Modelos do painel Ativos para gerenciar modelos existentes, inclusive renomear e excluir arquivos de modelo.

Você pode executar as seguintes tarefas de gerenciamento de modelo usando o painel Ativos:

  • Criar um modelo

  • Editar e atualizar modelos

  • Aplicar ou remover um modelo em um documento

O Dreamweaver verifica a sintaxe do modelo ao salvá-lo, mas é recomendável verificar manualmente a sintaxe durante a edição do modelo.

Abrir um modelo para edição

Você pode abrir um arquivo de modelo diretamente para edição ou abrir um documento baseado em modelo e abrir o modelo anexado para edição.

Quando você realiza uma alteração em um modelo, o Dreamweaver solicita que você atualize os documentos baseados no modelo.

Observação:

Você também pode atualizar manualmente os documentos para refletir as alterações do modelo, caso isso seja necessário.

Abrir e editar um arquivo de modelo

  1. No painel Ativos (Janela > Ativos), selecione o ícone Modelos à esquerda do painel.

    O painel Ativos lista todos os modelos disponíveis para o site e exibe uma visualização do modelo selecionado.

  2. Na lista de modelos disponíveis, siga um destes procedimentos:
    • Clique com o botão direito do mouse no modelo e clique em Editar.
    • Clique duas vezes no nome do modelo a ser editado.
    • Selecione um modelo para edição e clique no botão Editar na parte inferior do painel Ativos.
  3. Salve o modelo. O Dreamweaver solicita que você atualize páginas com base no modelo.
  4. Clique em Atualizar para atualizar todos os documentos com base no modelo modificado; clique em Não atualizar se não quiser atualizar os documentos baseados no modelo modificado.

    O Dreamweaver exibe um registro que indica os arquivos que foram atualizados.

Abrir e modificar o modelo anexado ao documento atual

  1. Abra o documento baseado em modelo na janela Documento.
  2. Selecione Ferramentas > Modelos > Abrir modelo anexado.

  3. Modifique o conteúdo do modelo.

    Observação:

    Para modificar as propriedades de página do modelo, selecione Arquivo > Propriedades da página. (Os documentos baseados em um modelo herdam as propriedades de página do modelo)

  4. Salve o modelo. O Dreamweaver solicita que você atualize páginas com base no modelo.
  5. Clique em Atualizar para atualizar todos os documentos com base no modelo modificado; clique em Não atualizar se não quiser atualizar os documentos baseados no modelo modificado.

    O Dreamweaver exibe um registro que indica os arquivos que foram atualizados.

Renomear um modelo

  1. No painel Ativos (Janela > Ativos), selecione o ícone Modelos à esquerda do painel.

  2. Clique no nome do modelo para selecioná-lo.
  3. Clique no nome novamente para que o texto possa ser selecionado e insira um novo nome.

    Esse método de renomeação funciona da mesma forma que a renomeação de um arquivo no Windows Explorer (Windows) ou no Finder (Macintosh). Assim como no Windows Explorer e no Finder, faça uma pausa rápida entre os cliques. Não clique duas vezes no nome, pois esse procedimento abre o modelo para edição.

  4. Clique em outra área do painel Ativo ou pressione Enter (Windows) ou Return (Macintosh) para ativar a alteração.

    Um alerta pergunta se você deseja atualizar os documentos baseados nesse modelo.

  5. Para atualizar todos os documentos do site que utilizam esse modelo, clique em Atualizar. Clique em Não atualizar se você não quiser atualizar qualquer documento baseado nesse modelo.

Alterar a descrição de um modelo

A descrição do modelo aparece na caixa de diálogo Novo documento quando você cria uma página a partir de um modelo existente.

  1. Selecione Ferramentas > Modelos > Descrição.

  2. Na caixa de diálogo Descrição do modelo, edite a descrição e clique em OK.

Atualizar manualmente documentos baseados em modelos

Quando você faz uma alteração em um modelo, o Dreamweaver solicita que você atualize os documentos baseados no modelo. Você pode atualizar manualmente o documento atual ou o site inteiro, caso seja necessário. O processo de atualização manual dos documentos baseados em modelo é igual ao de reaplicação do modelo.

Aplicar alterações de modelo ao documento baseado em modelo

  1. Abra o documento na janela Documento.
  2. Selecione Ferramentas > Modelos > Atualizar página atual.

    O Dreamweaver atualiza o documento com todas as alterações do modelo.

Atualizar o site inteiro ou todos os documentos que usam determinado modelo

Você pode atualizar todas as páginas no site ou somente as páginas de um modelo específico.

  1. Selecione Ferramentas > Modelos > Atualizar páginas...

  2. No menu Pesquisar, siga um destes procedimentos:
    • Para atualizar todos os arquivos no site selecionado com seus modelos correspondentes, selecione Site inteiro e indique o nome do site no menu pop‑up adjacente.

    • Para atualizar os arquivos de um modelo específico, selecione Arquivos que usam e indique o nome do modelo no menu pop‑up adjacente.

    Atualizar documentos em modelos
    Atualizar documentos em modelos

  3. Verifique se Modelos está selecionado na opção Atualizar.
  4. Se você não quiser ver um registro dos arquivos que o Dreamweaver atualiza, desmarque a opção Mostrar registro; caso contrário, deixe essa opção selecionada.
  5. Clique em Iniciar para atualizar os arquivos como indicado. Se você marcou a opção Mostrar registro, o Dreamweaver fornecerá informações sobre os arquivos que ele tenta atualizar, inclusive informações sobre o sucesso da atualização.
  6. Clique em Fechar.

Atualizar modelos em site do Contribute

Os usuários do Contribute não podem alterar um modelo do Dreamweaver. Entretanto, você pode usar o Dreamweaver para alterar um modelo de um site do Contribute

Lembre-se do seguinte ao atualizar modelos em um site do Contribute:

  • O Contribute somente recupera modelos novos e alterados no site quando o Contribute é iniciado e quando um usuário do Contribute altera as respectivas informações de conexão. Se você efetuar alterações em um modelo enquanto um usuário do Contribute edita um arquivo baseado nesse modelo, o usuário não verá as alterações no modelo até reiniciar o Contribute.

  • Se você remover uma região editável de um modelo, o usuário do Contribute que estiver editando uma página baseada nesse modelo pode ficar confuso sobre o que fazer com o conteúdo da região editável.

Para atualizar um modelo em um site do Contribute, siga as etapas a seguir.

  1. Abra o modelo do Contribute no Dreamweaver, edite-o e salve-o. Para obter instruções, consulte Abrir um modelo para edição.
  2. Solicite que todos os usuários do Contribute que estiverem trabalhando no site reiniciem o Contribute.

Excluir um arquivo de modelo

  1. No painel Ativos (Janela > Ativos), selecione o ícone Modelos à esquerda do painel.

  2. Clique no nome do modelo para selecioná-lo.
  3. Clique no botão Excluir  na parte inferior do painel e confirme se deseja excluir o modelo.

    Observação:

    Depois de excluído, o arquivo de modelo não pode ser recuperado. O arquivo de modelo é excluído do site.

    Os documentos baseados em um modelo excluído não são desanexados do modelo; eles retêm a estrutura e as regiões editáveis que o arquivo de modelo tinha antes de ser excluído. É possível converter esse documento em um arquivo HTML sem regiões editáveis ou bloqueadas.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online