Guia do Usuário Cancelar

Como usar o Git no Dreamweaver

  1. Guia do usuário do Dreamweaver
  2. Introdução
    1. Noções básicas de web design responsivo
    2. Novidades do Dreamweaver
    3. Desenvolvimento Web com o Dreamweaver – Visão geral
    4. Dreamweaver/Perguntas frequentes
    5. Atalhos de teclado
    6. Requisitos de sistema do Dreamweaver
    7. Resumo dos recursos
  3. Dreamweaver e Creative Cloud
    1. Sincronizar as configurações do Dreamweaver com a Creative Cloud
    2. Bibliotecas da Creative Cloud no Dreamweaver
    3. Uso de arquivos do Photoshop no Dreamweaver
    4. Trabalhe com o Adobe Animate e o Dreamweaver
    5. Extraia das Bibliotecas arquivos SVG otimizados para a Web
  4. Áreas de trabalho e exibições do Dreamweaver
    1. Espaço de trabalho do Dreamweaver
    2. Otimizar espaço de trabalho no Dreamweaver para desenvolvimento visual
    3. Pesquisa de arquivos baseada no nome de arquivo ou no conteúdo | Mac OS
  5. Configurar sites
    1. Sobre sites do Dreamweaver
    2. Configurar uma versão local do site
    3. Conectar-se a um servidor de publicação
    4. Configurar um servidor de teste
    5. Importar e exportar configurações de site do Dreamweaver
    6. Trazer sites existentes de um servidor remoto para a raiz do site local
    7. Recursos de acessibilidade do Dreamweaver
    8. Configurações avançadas
    9. Definir preferências de site para transferência de arquivos
    10. Especificar configurações do servidor proxy no Dreamweaver
    11. Sincronizar as configurações do Dreamweaver com a Creative Cloud
    12. Como usar o Git no Dreamweaver
  6. Gerenciar arquivos
    1. Criar e abrir arquivos
    2. Gerenciamento de arquivos e pastas
    3. Obter e colocar arquivos no servidor
    4. Devolver e retirar arquivos
    5. Sincronizar arquivos
    6. Comparar arquivos em busca de diferenças
    7. Encobrir arquivos e pastas em seu site do Dreamweaver
    8. Ativar as Design Notes para sites do Dreamweaver
    9. Impedir possível ataque ao Gatekeeper
  7. Layout e design
    1. Usar auxílios visuais para layout
    2. Sobre usar o CSS para criar o layout da página
    3. Criar sites responsivos usando o Bootstrap
    4. Criar e usar consultas de mídia no Dreamweaver
    5. Apresentar conteúdo em tabelas
    6. Cores
    7. Design responsivo usando layouts de grade fluida
    8. Extract no Dreamweaver
  8. CSS
    1. Noções sobre as folhas de estilos em cascata
    2. Aplicar layout às páginas usando o CSS Designer
    3. Usar pré-processadores de CSS no Dreamweaver
    4. Como definir preferências de estilo CSS no Dreamweaver
    5. Mover regras de CSS no Dreamweaver
    6. Converter CSS inline em uma regra de CSS no Dreamweaver
    7. Trabalhar com tags div
    8. Aplicação de degradês ao fundo
    9. Criar e editar efeitos de transição do CSS3 no Dreamweaver
    10. Formatar código
  9. Conteúdo e ativos de página
    1. Definir propriedades da página
    2. Configurar propriedades de cabeçalho e propriedades de link de CSS
    3. Trabalhar com texto
    4. Localizar e substituir texto, tags e atributos
    5. Painel DOM
    6. Editar na Visualização dinâmica
    7. Codificar documentos do Dreamweaver
    8. Selecionar e exibir os elementos na janela Documento
    9. Definir propriedades de texto no Inspetor de propriedades
    10. Verificar ortografia de uma página Web
    11. Usar regras horizontais no Dreamweaver
    12. Adicionar e modificar combinações de fontes no Dreamweaver
    13. Trabalhar com ativos
    14. Inserir e atualizar datas no Dreamweaver
    15. Criar e gerenciar ativos favoritos no Dreamweaver
    16. Inserir e editar imagens no Dreamweaver
    17. Adicionar objetos de mídia
    18. Adição de vídeos no Dreamweaver
    19. Inserir vídeo HTML5
    20. Inserir arquivos SWF
    21. Adicionar efeitos de áudio
    22. Inserir áudio HTML5 no Dreamweaver
    23. Trabalhar com itens da biblioteca
    24. Usar texto em árabe e hebraico no Dreamweaver
  10. Vinculação e navegação
    1. Sobre vinculação e navegação
    2. Vinculação
    3. Mapas de imagem
    4. Solucionar problemas com links
  11. Efeitos e widgets do jQuery
    1. Usar widgets de interface e para dispositivos móveis do jQuery no Dreamweaver
    2. Usar efeitos do jQuery no Dreamweaver
  12. Programar sites
    1. Sobre codificação no Dreamweaver
    2. Ambiente de codificação no Dreamweaver
    3. Definir preferências de codificação
    4. Personalizar codificação por cores
    5. Escrever e editar código
    6. Dicas de código e preenchimento de código
    7. Recolher e expandir código
    8. Reutilizar código com snippets
    9. Linting de código
    10. Otimizar código
    11. Editar código na Visualização de design
    12. Trabalhar com conteúdo do cabeçalho das páginas
    13. Inserir inclusões de servidor no Dreamweaver
    14. Usar bibliotecas de tags no Dreamweaver
    15. Importar tags personalizadas para o Dreamweaver
    16. Usar comportamentos JavaScript (instruções gerais)
    17. Aplicar comportamentos internos do JavaScript
    18. Sobre XML e XSLT
    19. Executar transformações XSL do servidor no Dreamweaver
    20. Executar transformações XSL do cliente no Dreamweaver
    21. Adicionar entidades de caracteres para XSLT no Dreamweaver
    22. Formatar código
  13. Fluxos de trabalho entre produtos
    1. Instalar e usar extensões no Dreamweaver
    2. Atualizações dentro do aplicativo no Dreamweaver
    3. Inserir documentos do Microsoft Office no Dreamweaver (somente Windows)
    4. Trabalho com o Fireworks e o Dreamweaver
    5. Editar conteúdo em sites do Dreamweaver usando o Contribute
    6. Integração do Business Catalyst ao Dreamweaver
    7. Criar campanhas de email personalizadas
  14. Modelos
    1. Sobre os modelos do Dreamweaver
    2. Reconhecimento de modelos e documentos baseados em modelo
    3. Criar um modelo do Dreamweaver
    4. Criar regiões editáveis nos modelos
    5. Criar regiões e tabelas repetitivas no Dreamweaver
    6. Usar regiões opcionais em modelos
    7. Definir atributos de tag editáveis no Dreamweaver
    8. Como criar modelos aninhados no Dreamweaver
    9. Editar, atualizar e excluir modelos
    10. Exportar e importar conteúdo xml no Dreamweaver
    11. Aplicar ou remover um modelo em um documento
    12. Editar conteúdo em modelos do Dreamweaver
    13. Regras de sintaxe para tags de modelo no Dreamweaver
    14. Definir preferências de realce para regiões de modelo
    15. Vantagens de usar modelos no Dreamweaver
  15. Dispositivo móvel e multitela
    1. Criar consultas de mídia
    2. Alterar a orientação de página para dispositivos móveis
    3. Criar aplicativos Web para dispositivos móveis usando o Dreamweaver
  16. Sites dinâmicos, páginas e formulários Web
    1. Noções sobre aplicativos Web
    2. Configurar o computador para desenvolvimento de aplicativos
    3. Solucionar problemas de conexões de banco de dados
    4. Remover scripts de conexão no Dreamweaver
    5. Criar páginas dinâmicas
    6. Visão geral das fontes de conteúdo dinâmico
    7. Definir origens de conteúdo dinâmico
    8. Adicionar conteúdo dinâmico a páginas
    9. Alterar conteúdo dinâmico no Dreamweaver
    10. Exibir registros de banco de dados
    11. Fornecer e solucionar problemas de live data no Dreamweaver
    12. Adicionar comportamentos personalizados de servidor no Dreamweaver
    13. Criar formulários usando o Dreamweaver
    14. Usar formulários para reunir informações de usuários
    15. Criar e ativar formulários do ColdFusion no Dreamweaver
    16. Criar formulários Web
    17. Suporte aprimorado a HTML5 para elementos de formulário
    18. Desenvolver um formulário usando o Dreamweaver
  17. Criação visual de aplicativos
    1. Criar páginas mestre e detalhadas no Dreamweaver
    2. Criar páginas de pesquisa e de resultados
    3. Criar uma página de inserção de registro
    4. Criar uma página de registro de atualização no Dreamweaver
    5. Criar páginas de exclusão de registro no Dreamweaver
    6. Usar comandos ASP para modificar um banco de dados no Dreamweaver
    7. Criar uma página de registro
    8. Criar uma página de logon
    9. Criar uma página que apenas usuários autorizados podem acessar
    10. Proteger pastas no ColdFusion usando o Dreamweaver
    11. Usar componentes do ColdFusion no Dreamweaver
  18. Testar, visualizar e publicar sites
    1. Visualizar páginas
    2. Visualizar páginas Web do Dreamweaver em vários dispositivos
    3. Testar seu site do Dreamweaver

 

Leia este artigo para saber como usar o Git para gerenciar seus arquivos e código-fonte no Dreamweaver.

O Dreamweaver oferece suporte ao Git, um sistema de controle de versões distribuído de código aberto, para gerenciar o código-fonte. Com a integração ao Git no Dreamweaver, você pode trabalhar em seu código de forma independente em qualquer lugar e depois mesclar suas alterações ao repositório central do Git. O Git ajuda a acompanhar as alterações em um arquivo e também permite que você reverta às versões anteriores.

Os repositórios do Git também são úteis quando você trabalha em equipe, pois o Git permite criar e manter ramificações com facilidade. Por exemplo, se você deseja fazer mudanças no design de seu site, e, ao mesmo tempo, outro membro da equipe atende a pedidos de alteração para o mesmo site, vocês podem trabalhar independentemente usando o Git. Nesse caso, ambos podem criar uma ramificação independentemente e fazer suas alterações em seus respectivos repositórios locais. O repositório local contém o histórico completo de todas as alterações à fonte feitas por você. Você pode pausar e mesclar as alterações com o repositório central a qualquer momento. Mesclar garante que o repositório central sempre tenha o código mais recente com as alterações de ambos.

Veja a seguir como começar a usar o Git no Dreamweaver.

Introdução ao Git no Dreamweaver

Se você for um novo usuário do Git, primeiro é necessário baixar o cliente Git e criar uma conta do Git. Um cliente do Git é essencial para que você use o Git no Dreamweaver.

Se você já tiver uma conta do Git, faça logon com sua conta. Verifique se você baixou o cliente Git no sistema. 

Siga estas etapas para começar a usar o Git no Dreamweaver:

  1. Baixe o cliente Git correspondente ao seu sistema operacional.

  2. Crie uma conta para seu cliente Git.

    Se você já tiver uma conta do Git, forneça suas credenciais para fazer logon no cliente Git.

O painel do Git

Recomenda-se instalar o cliente Git com as configurações padrão. O Dreamweaver seleciona automaticamente o caminho para o executável.

Agora você pode iniciar o Dreamweaver e associar seu site a um repositório do Git.

O Dreamweaver oferece suporte a operações do Git por meio do painel do Git (Janela > Git). Como usuário do Dreamweaver, você pode usar esse painel para executar operações comuns do Git, como Confirmar, Push, Pull e Fetch.

Observação:

Você pode exibir este painel no Dreamweaver somente depois de baixar o cliente Git em seu computador.

O painel do Git no Dreamweaver CC
O painel do Git no Dreamweaver

A. Confirmar B. Recuperar todos os acessos remotos e atualizar contadores C. Git Pull D. Git Push E. Mostrar histórico de repositório F. Mostrar histórico de arquivos G. Criar tag H. Abrir o console bash/terminal I. Mais ações J. Pesquisar K. Diff L. Reverter arquivo 

Associar seu site ao Git

Para começar a usar o Git no Dreamweaver, primeiro você deve associar seu site do Dreamweaver a um repositório do Git. Um repositório do Git é como uma pasta que você cria para ajudar a controlar as alterações nos arquivos. Você pode ter quantos repositórios do Git quiser em seu computador. Cada repositório no sistema é independente. Ou seja, as alterações salvas em um repositório do Git não afetam o conteúdo de outro.

Você pode associar seu site a um repositório criando um novo repositório ou clonando um já existente. Quando um repositório é inicializado ou criado, um repositório vazio do Git é criado no diretório de trabalho atual, com um arquivo .gitignore na pasta.

No entanto, quando um repositório existente do Git é clonado, todos os arquivos do repositório pai são clonados para o sistema local.

Leia para saber como inicializar um repositório do Git ou clonar um repositório.

Inicializar um repositório do Git

Ao começar a trabalhar com o Git no Dreamweaver, crie um repositório. Quando você inicializa um repositório do Git para seu site, um repositório do Git é criado onde for possível adicionar arquivos associados ao seu site do Dreamweaver.

  1. Como usuário do Dreamweaver, você pode começar com um novo site. Ou, você pode ter um site existente que deseja associar a um repositório do Git. Seja como for, siga este procedimento para inicializar um repositório do Git.

    • Para associar um novo site do Dreamweaver, clique em Site > Novo site.
    • Para associar um site do Dreamweaver existente, clique em Site > Gerenciar sites. Na caixa de diálogo Gerenciar sites, clique duas vezes no site que deseja associar a um repositório do Git.
  2. Se estiver criando um novo site, especifique um nome para o site.

    Se tiver uma pasta que contenha os arquivos relacionados ao seu site, aponte para a pasta no campo Pasta do site local.

    Especificar o nome e o local da pasta para o seu novo site do Dreamweaver
    Especificar o nome e o local da pasta para o seu novo site do Dreamweaver

    Se você deseja associar seu novo site a um repositório do Git existente, certifique-se de que a Pasta do site local aponte para o repositório do Git apropriado.

  3. Marque a caixa de seleção Associar um repositório Git a este site. Em seguida, selecione a opção Redefinir como um repositório Git.

    Inicializar um repositório do Git no Dreamweaver
    Inicializar um repositório do Git para o seu novo site do Dreamweaver

  4. Clique em Salvar.

    Observe que os arquivos da sua pasta local agora são visíveis no painel Arquivos (visualização do Git). Os arquivos estão em um estado não rastreado. Ou seja, esses arquivos ainda não estão confirmados no repositório do Git.

    Você pode continuar trabalhando em seus arquivos e confirmá-los mais tarde. Além disso, é possível abrir o painel do Git (Janela > Git) e confirmar os arquivos de seu repositório. Para saber como confirmar arquivos no Git, consulte Controlar e confirmar alterações.

Clonar um repositório existente

Se já estiver trabalhando com um repositório existente do Git hospedado no Github, no Bitbucket ou em outros serviços de hospedagem conhecidos, você poderá executar o procedimento a seguir para clonar o repositório de dentro do Dreamweaver. Ao clonar um repositório existente, você cria uma cópia do repositório de destino no sistema local.

  1. Clique em Site > Novo site.

  2. Na caixa de diálogo Configuração do site, marque a caixa de seleção Associar um repositório do Git a este site. Em seguida, selecione Clonar repositório Git atual usando URL.

  3. Especifique o URL do repositório que você quer clonar.

    Certifique-se de que o URL https do repositório de destino que está inserindo é válido. Para testar se o URL é válido, clique no botão Testar nesta caixa de diálogo. URLs inválidos resultam em erros ao clonar e executar ações como Git Fetch ou Git Pull.

    Clonar um repositório do Git no Dreamweaver
    Clonar um repositório do Git no Dreamweaver

    Observação:

    No momento, não há suporte à clonagem de um URL usando uma chave SSH com frase secreta no Dreamweaver. Os campos de nome de usuário e senha estão desabilitados.

  4. Para salvar as credenciais inseridas, marque a caixa de seleção Salvar credenciais. Isso poupa você de ter que inserir suas credenciais toda vez que executar ações remotas como Git Push ou Git Pull.

  5. Clique em Salvar.

    Depois de clonar um repositório, é criada uma cópia local do repositório de origem. É possível exibir e editar os arquivos locais pelo Dreamweaver.

    O instantâneo do repositório original que foi clonado é exibido em Painel do Git > Origem no canto superior direito.

    Observe o repositório de origem no painel do Git
    Observe o repositório de origem no painel do Git

Como usar o Git para controle de versão

Agora que associou seu site do Dreamweaver com um repositório do Git, você consegue exibir os arquivos no Git pelo painel Arquivos (exibição Git). O Git classifica os arquivos no seu repositório local como:

  • Arquivos não rastreados: arquivos que você nunca confirmou no repositório do Git. Depois que você inicializa um repositório do Git, os arquivos são não rastreados até você os confirmar.
  • Arquivos inalterados: arquivos que não foram modificados.
  • Arquivos modificados: arquivos que foram editados.
  • Arquivos testados: arquivos modificados e prontos para serem confirmados.

Usando o Git, você pode acompanhar as modificações nos arquivos. Quando você modifica os arquivos em seu sistema local, os arquivos modificados aparecem em uma cor diferente no painel Arquivos. Quando você clica duas vezes e abre o arquivo na Visualização de código, também pode ver a marca da medianiz destacando as linhas que foram modificadas. Você pode prosseguir e confirmar seus arquivos modificados no Git para sincronizar as alterações.

Quando você confirma os arquivos, o Git permite que você insira mensagens de registro para cada confirmação e reveja as alterações usando o recurso de diferenciação. Também é possível visualizar o histórico de versões para cada arquivo e para o repositório inteiro.

Veja a seguir como controlar as edições dentro do Dreamweaver e confirmar as alterações no Git.

Acompanhar edições no Git

No painel Arquivos do Dreamweaver, observe o ícone do Git que permite alternar entre a visualização do FTP e a visualização do Git. Clique no ícone do Git para alternar para a visualização do Git.

Se você inicializar um repositório do Git e não confirmar os arquivos, estes permanecerão não rastreados. Porém, se você confirmar os arquivos depois de inicializar o repositório, os arquivos serão reconhecidos pelo Git.

Exibir os arquivos não rastreados no painel Arquivos
Exibir os arquivos não rastreados no painel Arquivos

Arquivos após a confirmação no repositório do Git
Exibir os arquivos confirmados reconhecidos pelo Git

Se você clonar todos os arquivos de outro repositório, os arquivos serão reconhecidos pelo Git novamente.

Quando você modifica um arquivo e clica em Salvar, o painel Arquivos exibe os arquivos modificados em uma cor diferente. Clique duas vezes no arquivo modificado para ver as alterações exatas na Visualização de código.

Marca da medianiz na Visualização de código
Marca da medianiz na Visualização de código

Uma marca da medianiz indica as linhas nas quais as alterações foram feitas. Marcas de medianiz em verde indicam novos códigos que foram adicionados. Marcas de medianiz em amarelo indicam códigos modificados, enquanto marcas de medianiz em vermelho indicam uma linha de código que foi removida.

Marcas de medianiz indicam alterações feitas no código no Dreamweaver
Marcas de medianiz indicam alterações no código

Ao clicar na marca de medianiz amarela, o aplicativo exibe a alteração no código. A linha de código excluída aparece em vermelho, enquanto o código recém-adicionado aparece em verde.

Observe um símbolo de R no canto esquerdo das linhas de código excluídas. Clique no símbolo de R para adicionar o código excluído de volta ao arquivo.

Clique no símbolo de R para adicionar o código excluído no Git no Dreamweaver
Clique no símbolo de R para adicionar o código excluído

Use marcas de medianiz para visualizar a diferenciação e revisar suas alterações antes de confirmar as alterações no repositório do Git.

Exibir a diferenciação para arquivos modificados

Ao abrir o painel do Git, você verá uma lista dos arquivos modificados. Clique em um arquivo nesta lista para exibir as alterações feitas nele após a confirmação anterior (diferenciação). Para exibir a diferenciação de um arquivo, siga um destes procedimentos no painel do Git:

  • Para exibir as edições por arquivo, clique em cada arquivo. Os realces em vermelho indicam a versão anterior, enquanto os realces em verde indicam a alteração que você fez agora.
  • Selecione o arquivo para o qual deseja exibir a diferenciação. Clique em  (ícone Diferenciação). É exibida a caixa de diálogo Git Diff, na qual as alterações são realçadas em vermelho e verde.
Exibir a diferenciação para arquivos modificados
Exibir a diferenciação para arquivos modificados

Confirmar alterações

Para salvar todas as alterações no repositório local, é necessário confirmar as alterações feitas nos arquivos. Confirme as alterações no Git:
  1. No painel do Git, selecione o(s) arquivo(s) que deseja confirmar e clique em Confirmar.

    Confirmar alterações no seu repositório local do Git
    Confirmar alterações no seu repositório local do Git

  2. Clique em  (ícone Confirmar).

    Quando você clica em Confirmar, o sistema exibe a caixa de diálogo Git Commit. Essa caixa de diálogo exibe os arquivos que contêm modificações.

    Você pode clicar em cada arquivo para exibir as modificações, antes de continuar a confirmar os arquivos.

  3. Para confirmar os arquivos, digite uma mensagem de confirmação na caixa de mensagem e clique em OK.

    Após a confirmação dos arquivos, eles também são removidos do painel do Git.

    Confirmar as alterações no Git
    Confirmar as alterações no Git

Reverter alterações

Caso já tenha confirmado suas alterações e queira reverter para a versão anterior de um arquivo, faça o seguinte:

  1. No painel do Git, selecione o(s) arquivo(s) que deseja reverter.

  2. Clique no ícone de encaixado no painel do Git e selecione Reverter todas as alterações desde a última confirmação.

    A versão anterior dos arquivos é restaurada no repositório local. Os arquivos restaurados podem ser exibidos no painel Arquivos.

    Reverter alterações depois de confirmar arquivos
    Reverter alterações depois de confirmar arquivos

    Observação:

    Se quiser reverter um arquivo depois da confirmação, você deverá tê-lo confirmado pelo menos duas vezes.

  3. Para reverter alterações antes de Confirmar, execute as seguintes etapas:

    Caso deseje manter a última versão confirmada de um arquivo antes de confirmá-lo:

    1. Vá para o painel do Git, clique no arquivo que deseja manter e, em seguida, no ícone Atualizar.
    2. Na caixa de diálogo de confirmação, clique em OK.

    O arquivo selecionado é removido da lista de arquivos modificados e a versão anterior do arquivo é restaurada.

    Reverter um arquivo antes de confirmar as alterações no Git
    Reverter um arquivo antes de confirmar as alterações

Criar tags

Você pode criar tags sempre que confirmar as alterações no Git. É possível usar tags para identificar confirmações importantes. Por exemplo, uma devolução para uma grande alteração solicitada pelo cliente. As tags atuam como um ponteiro para uma confirmação específica.

  1. Para criar uma tag, clique em  (ícone Criar tag) no painel do Git.

  2. Na caixa de diálogo Criar tag, especifique um nome para a tag. Clique em OK.

    Criar uma tag para sua confirmação
    Criar uma tag para sua confirmação

    A tag que você criou é associada à sua confirmação.

    Se você criar uma tag após realizar uma confirmação, a tag será associada automaticamente à confirmação mais recente.

Visualizar o histórico do arquivo

Toda vez que confirma um arquivo no Git, você pode visualizar o histórico do arquivo juntamente com os detalhes da confirmação. Esse recurso ajuda a identificar confirmações importantes e as tags associadas a confirmações.

  1. No painel do Git, siga um destes procedimentos:
  • Selecione o arquivo desejado e clique em  (ícone Mostrar histórico do arquivo).
  • Clique com o botão direito do mouse no arquivo dentro do painel Arquivos e selecione Histórico do arquivo.

O sistema exibe o Histórico de arquivos Git do arquivo selecionado. Também é possível visualizar os detalhes da confirmação desse arquivo na mesma caixa de diálogo.

Visualizar o histórico do arquivo no Git
Visualizar o histórico do arquivo no Git

Visualizar o histórico do repositório

Além de visualizar o histórico de um arquivo no Git, é possível visualizar as alterações feitas no nível do repositório. Você pode visualizar todas as alterações e confirmações feitas no nível do repositório. Para visualizar o histórico do repositório, execute as seguintes etapas:

  1. No painel do Git, clique no ícone Mostrar histórico do repositório. O sistema exibe o Histórico do repositório do Git com os detalhes de todas as confirmações.

  2. Você pode ver a mensagem de confirmação, a data e a hora de quando os arquivos foram confirmados, além das tags associadas a uma confirmação e os detalhes do usuário que confirmou os arquivos.

  3. Normalmente, o histórico do repositório especifica a lista de arquivos que foram confirmados no nível do repositório. Você pode clicar em cada arquivo para exibir o histórico de alterações no nível do arquivo.

Como usar o Git para colaboração

Um dos recursos mais distintos do Git são as ramificações. Ao contrário da maioria dos sistemas de controle de versão, uma ramificação do Git pode ser igualada a uma linha independente de todos os seus arquivos ou código associados. Por padrão, seu repositório tem uma ramificação denominada “master” (mestre). A ramificação mestre é a ramificação principal ou definitiva. Você pode criar ramificações a partir da mestre e fazer edições em cada uma delas.

Também é possível criar uma ramificação a partir de outra, onde você está fazendo uma cópia da ramificação pai. Você pode trabalhar de forma independente nas duas ramificações no mesmo repositório do Git. Por exemplo, você pode trabalhar em um novo recurso para o seu site em uma ramificação enquanto atende aos pedidos de alterações em outra ramificação.

O Git também permite mesclar ramificações caso você queira incorporar as alterações da ramificação atual a uma ramificação de destino. Quando você mescla duas ramificações, ambas continuam a existir de forma independente. Você pode continuar a trabalhar com as ramificações pai e de destino.

No Dreamweaver, quando desenvolvedores e designers trabalham juntos em um site, cada usuário pode criar uma ramificação a partir da mestre e fazer alterações de forma independente. Sempre que necessário, eles podem facilmente mesclar as alterações deles com outra ramificação e continuar a trabalhar com as duas ramificações.

Para saber mais sobre como criar e gerenciar ramificações no Git, leia as seguintes seções:

Criar ramificações no Git

  1. No painel Arquivos, selecione a lista suspensa que relaciona todas as ramificações.

  2. Clique em Gerenciar ramificações.

    Criar uma ramificação no Git
    Criar uma ramificação no Git

  3. Na caixa de diálogo Gerenciar ramificações, clique no sinal + no canto inferior esquerdo.

    Clique no sinal de mais na parte inferior da caixa de diálogo Gerenciar ramificações
    Clique no sinal de mais na parte inferior da caixa de diálogo Gerenciar ramificações

  4. Na caixa de diálogo Criar ramificação, selecione a ramificação de origem da qual você deseja fazer uma cópia.

    Se essa for a primeira ramificação que você está criando, a ramificação de origem será sua ramificação mestre.

    Selecione a ramificação de origem
    Selecione a ramificação de origem

  5. No campo Nome da ramificação, especifique um nome para a nova ramificação.

  6. Clique em OK.

Mesclar ramificações

  1. No painel Arquivos, selecione a lista suspensa que relaciona todas as suas ramificações.

  2. Clique em Gerenciar ramificações. Na caixa de diálogo Gerenciar ramificações, selecione a ramificação que você deseja mesclar.

  3. Clique em  (ícone Mesclar ramificação) na parte inferior da caixa de diálogo.

  4. Na caixa de diálogo Mesclar ramificação, selecione a Ramificação de destino. Essa ramificação é o repositório de destino com o qual você deseja mesclar a ramificação.

    Como opção, especifique uma mensagem associada a essa mesclagem.

  5. Clique em OK para mesclar sua ramificação com o destino.

    Mesclar ramificações no Git
    Mesclar ramificações no Git

    Se as alterações no arquivo de uma confirmação entrarem em conflito com as alterações de outra ramificação, o processo de mesclagem será pausado. O sistema exibe uma mensagem de conflito juntamente com os arquivos que estão causando o conflito.

    O painel do Git também exibe os arquivos em que ocorre o conflito. Observe o ícone que indica que há um conflito.

    Painel do Git com arquivos em que ocorre um conflito durante a mesclagem
    Painel do Git com arquivos em que ocorre um conflito durante a mesclagem

    Para prosseguir com a mesclagem, primeiro você deve resolver o conflito. Para fazer isso, use a opção Rebase ou continue com a mesclagem usando a opção Sem avanço rápido.

  6. Se você encontrar um conflito de mesclagem, escolha uma das seguintes opções:

    • Usar rebase: quando você seleciona a opção Rebase, suas alterações atuais são aplicadas sobre os conflitos na ramificação de destino. Depois de escolher Rebase e clicar em OK, abra o painel do Git para exibir os arquivos que ainda precisam ser confirmados. Você pode então cancelar ou reiniciar a operação de rebase. Ao cancelar a operação, a ação é interrompida e a ramificação de destino não sofre alterações. Quando você a reinicia, suas alterações são ignoradas em favor dos conflitos encontrados na ramificação de destino.
    • Criar uma confirmação de mesclagem mesmo quando mesclar resolve como um avanço rápido: também é possível mesclar sua confirmação independentemente dos conflitos exibidos entre a ramificação e a ramificação de destino. Nesse caso, a mesclagem é forçada, com suas alterações substituindo as alterações na ramificação de destino.

    Para saber mais sobre rebase no Git, consulte Rebase no Git.

Trabalhar com repositórios remotos

Os repositórios remotos no Git são versões de um projeto que são hospedadas em outra rede. Para poder acessar um repositório remoto, crie uma conexão com ele. Dependendo dos direitos de acesso especificados no repositório remoto, você pode ter acesso somente leitura ou acesso de gravação ao repositório.

Quando você trabalha em equipe, os repositórios remotos ajudam a enviar dados por push e pull, de e para outros repositórios. No painel do Git no Dreamweaver, você pode criar uma conexão remota e executar várias operações do Git como Fetch, Git Push, Git Pull e Atualização Remota.

Leia os procedimentos abaixo para saber como criar e gerenciar repositórios remotos.

Adicionar um repositório remoto

Você pode adicionar um repositório remoto para compartilhar arquivos, seu progresso de trabalho e para acessar seus arquivos de projeto hospedados em outra rede. Adicionando um repositório remoto, você estabelece uma conexão remota com o repositório de destino. O Dreamweaver permite criar repositórios remotos no painel do Git.

Antes de adicionar um repositório remoto, certifique-se de que o outro repositório tenha configurações públicas habilitadas.

  1. No painel do Git, clique em Criar acesso remoto.

  2. Especifique um nome para o repositório remoto.

  3. Insira o URL e as credenciais para o repositório remoto.

    Para garantir que você inseriu um URL válido ao adicionar um repositório remoto, clique em Testar após digitar o URL. Quando você clica em Testar, a validade do URL é testada.

    Esse teste não é aplicável para validar credenciais.

    Adicionar um repositório remoto no Dreamweaver
    Adicionar um repositório remoto

    Cuidado:

    Se você não inserir um URL válido ou credenciais válidas, ocorrerão erros na execução do Git Pull, Git Push, Fetch e assim por diante.

  4. Clique em OK.

    Quando você adiciona um repositório remoto, ele aparece na lista suspensa na parte superior do painel do Git. Há também outros ícones para executar Git Push, Git Pull, Fetch remoto e atualizar contadores.

    Adicionar repositórios remotos no Git
    Adicionar repositórios remotos no Git

Gerenciar repositórios remotos

Após adicionar um repositório remoto e estabelecer uma conexão, você pode usar Fetch e Pull para exportar os arquivos do repositório remoto para seu repositório local. Também é possível usar Push para enviar seus arquivos ao repositório remoto. No entanto, primeiro é necessário usar Fetch para importar os arquivos do repositório remoto antes de realizar uma ação Git Push pela primeira vez.

Lembre-se de confirmar todos os seus arquivos no repositório local antes de tentar aplicar Push a eles. Caso seu repositório local tenha arquivos testados, a ação Git Push continuará não tendo êxito. 

É possível executar as seguintes operações do Git pelo Dreamweaver:

Recuperar todos

Clique em  para recuperar todos os arquivos de todas as suas conexões remotas. Recomenda-se que você execute uma ação Git Fetch antes de executar Git Push ou Git Pull. Esta ação recupera apenas os arquivos de um acesso remoto e não modifica o repositório local.

Extrair arquivos do repositório remoto

Você pode extrair alterações de um único repositório ou de um grupo de repositórios. Ao clicar no ícone Git Pull, o sistema exibe a caixa de diálogo Git Pull com várias opções.

  1. No painel do Git, clique em  (ícone Git Pull) para extrair os arquivos modificados do repositório remoto e mesclar as alterações com seu repositório local.

  2. Na caixa de diálogo Git Pull, selecione a ramificação de rastreamento, especifique se deseja extrair alterações da ramificação atual ou de outra ramificação e, em seguida, defina as configurações de pull.

    Executar um Git Pull de repositórios remotos
    Executar um Git Pull de repositórios remotos

  3. Por padrão, é selecionada a mesclagem padrão. Nesse caso, os arquivos do acesso remoto são extraídos para seu repositório local por meio de pull e as alterações são mescladas ao seu local.

  4. Você também pode escolher uma das seguintes opções:

    • Evitar mesclagem manual: selecione esta opção para desativar a mesclagem manual dos arquivos.
    • Mesclar sem confirmação: selecione essa opção para continuar com a mesclagem no repositório remoto mesmo sem confirmar seus arquivos testados.
    • Usar rebase: selecione essa opção para executar uma rebase. Quando você usa o rebase, as alterações da ramificação atual são tiradas e aplicadas no histórico da ramificação de que você está extraindo arquivos. O histórico de últimas confirmações da ramificação é regravado. Os arquivos agora correspondem às versões da ramificação do destino de onde você está extraindo os arquivos. Embora rebasing produza um histórico limpo do Git para a ramificação, você deve ter sempre cautela ao escolher a opção Usar rebase.
    • Usar redefinição flexível: selecione essa opção para executar uma redefinição ou rebase flexível. É possível escolher a opção Usar redefinição flexível quando você extrai os arquivos de um repositório remoto pela primeira vez. Nesse caso, o repositório remoto atua como um repositório pai do qual o repositório local recebe todas as alterações. No entanto, as alterações no repositório local são mantidas. O Git não reconhece arquivos que não estão presentes no repositório remoto, mas residem em seu repositório local. Esses arquivos são exibidos como arquivos excluídos depois de você ter executado uma redefinição flexível. Se você optar por manter estes arquivos no seu repositório local, as alterações remotas serão perdidas.
    Cuidado:

    Se prosseguir com a redefinição flexível, seus arquivos não reconhecidos serão excluídos.

Enviar arquivos para o repositório remoto

Após estabelecer conexão com repositórios remotos, quando você modifica e confirma os arquivos modificados, o Git registra essas alterações. O ícone Git Push no painel do Git exibe imediatamente o número de arquivos que foram modificados. Esses arquivos podem agora ser enviados por push para o repositório remoto.

Quando você executa um Git Push, as confirmações que você fez no repositório local são enviadas por push para o repositório remoto.

Para enviar os seus arquivos de dentro do Dreamweaver:

  1. No painel do Git, clique no ícone Git Push.

    O sistema exibe a caixa de diálogo Git Push. Você pode enviar por push as suas confirmações para a ramificação de rastreamento atual ou para outra ramificação que você especificar.

    Enviar as confirmações locais por push para um repositório remoto do Git
    Enviar as confirmações locais por push para um repositório remoto do Git

  2. Também é possível definir as configurações de push nessa caixa de diálogo. A opção Push padrão está selecionada por padrão.

  3. Você também pode selecionar as seguintes opções:

    • Push forçado: selecione essa opção para enviar à força suas alterações ao repositório remoto, independentemente de possíveis conflitos.
    • Excluir ramificação remota: selecione essa opção para excluir a ramificação remota existente e enviar os arquivos locais para o repositório remoto.
  4. Se desejar, marque a caixa de seleção Enviar tags para enviar as tags para o repositório remoto.

  5. Clique em OK.

    Se houver algum conflito entre as confirmações locais e as confirmações feitas no repositório remoto, é recomendado que os conflitos sejam resolvidos primeiro. Depois, você poderá enviar as alterações.

    Para fazer isso, primeiro será necessário extrair as alterações do repositório remoto, resolver os conflitos e, depois, enviar os arquivos sem conflitos.

Pesquisar por arquivos no painel do Git

A barra de pesquisa no painel do Git permite que você pesquise por arquivos usando o nome do arquivo. Esse recurso é especialmente útil quando você tem um grande número de arquivos associados ao seu site.

Para procurar por um arquivo, basta digitar o nome de arquivo na barra de pesquisa. Os arquivos que contêm a sua consulta de pesquisa são exibidos imediatamente.

Adicionar arquivos à lista de itens ignorados

Quando não deseja que o Git atue em um arquivo, você pode adicionar o arquivo ao .gitignore. O Git ignora os arquivos nessa pasta sempre que você executa qualquer ação, inclusive confirmação, push e pull. Você deve confirmar o arquivo .gitignore em seu repositório para que qualquer outro usuário que esteja clonando seu repositório também fique ciente dos arquivos na pasta .gitignore.

Para adicionar arquivos a .gitignore, vá para o painel Arquivos no Dreamweaver. Selecione e clique com o botão direito do mouse no arquivo que você deseja que o Git ignore, e selecione Git > Adicionar ao .gitignore.

Adicionar arquivos a .gitignore
Adicionar arquivos a .gitignore

A qualquer momento, se quiser remover um arquivo de .gitignore, selecione o arquivo no painel Arquivos. Clique com o botão direito do mouse e selecione Git > Remover de .gitignore.

Certifique-se de confirmar o arquivo .gitignore nos repositórios locais e remotos depois de modificar esse arquivo.

Acessar o Git pela linha de comando

Nas seções anteriores deste artigo, você aprendeu como usar o painel do Git (UI) para executar tarefas como associar um repositório do Git ao seu site, criar e gerenciar conexões remotas, enviar arquivos para um repositório ou retirar arquivos de um repositório. Você também pode executar essas ações e muito mais usando os comandos do git.

Para executar qualquer operação do Git usando o terminal, siga um destes procedimentos:

  • Clique em Janela > Git e clique no ícone Abrir o console Bash/Terminal.
  • No painel Arquivos, alterne para a visualização do Git. Clique no ícone Abrir terminal de Git ao lado da lista suspensa de repositórios.

Para conhecer os comandos comuns do git, consulte a Folha de dicas do Git

Observação:

Algumas ações como git stash e combinar confirmações após o envio só são possíveis pela linha de comando no momento.

Certas ações, como inicializar um repositório do Git a partir da linha de comando, também são refletidas na interface do Dreamweaver.

No entanto, se você modificar arquivos usando a linha de comando enquanto o aplicativo do Dreamweaver estiver fechado, a seguinte mensagem será exibida na próxima vez que iniciar o Dreamweaver:

Mensagem exibida quando os arquivos são modificados usando a interface de linha de comando
Mensagem exibida quando os arquivos são modificados usando a interface de linha de comando

Definir preferências do Git no Dreamweaver

Nas preferências do Git no Dreamweaver, você pode definir algumas configurações para usar o Git no Dreamweaver. É possível usar a caixa de diálogo Preferências para definir preferências do Git, como o caminho para o terminal, as configurações de tempo limite e assim por diante.

  1. Selecione Editar > Preferências.

  2. Na caixa de diálogo Preferências, selecione Git.

  3. Na caixa de diálogo Preferências do Git, defina o seguinte:

    • Caminho para o executável do Git: o arquivo .exe do cliente Git. Se o executável estiver salvo em outro local, navegue até o local onde você salvou o arquivo .exe do Git.
    • Tempo limite padrão de operação Git: especifique o tempo limite em segundos para qualquer operação remota do Git.
    • Caminho para o terminal: o caminho completo para o arquivo executável para abrir e usar o terminal do Git.
    • Argumentos do comando: forneça argumentos, se houver, para os comandos do Git.
    Definir preferências para o Git no Dreamweaver
    Definir preferências para o Git no Dreamweaver

  4. Clique em Aplicar para salvar as configurações.

Observação:

Reinicie o Dreamweaver para que suas preferências atualizadas entrem em vigor.

 Adobe

Receba ajuda com mais rapidez e facilidade

Novo usuário?