Obtenha e coloque arquivos do/no servidor e gerencie transferências de arquivo usando o Dreamweaver.

Caso você esteja trabalhando em um ambiente colaborativo, use o sistema de devolução/retirada para transferir arquivos entre sites locais e remotos. No entanto, caso você seja a única pessoa trabalhando no site remoto, você pode usar os comandos Obter e Colocar para transferir arquivos sem devolver ou retirá-los.

Para obter mais informações sobre como devolver e retirar arquivos, consulte Devolver e retirar arquivos.

Ao transferir um documento entre uma pasta local e remota usando o painel Arquivos, você tem a opção da transferência dos arquivos dependentes do documento. Arquivos dependentes são imagens, folhas de estilos externas e outros arquivos referenciados no documento que um navegador lê ao carregar o documento.

Observação:

Normalmente, é uma boa ideia baixar arquivos dependentes ao retirar um novo arquivo, mas caso as versões mais recentes dos arquivos dependentes já estejam no disco local, não há necessidade de baixá-los novamente. Isso também acontece no carregamento e na devolução dos arquivos: não há necessidade caso cópias atualizadas já estejam no site remoto.

Os itens de biblioteca são tratados como arquivos dependentes.

Alguns servidores informam erros quando colocam itens de biblioteca. No entanto, você pode encobrir esses arquivos para impedir sua transferência.

Sobre as transferências de arquivo em segundo plano

Você pode realizar outras atividades, não relacionadas a servidor, enquanto obtém ou coloca arquivos. A transferência de arquivo de fundo funciona com todos os protocolos de transferência compatíveis com o Dreamweaver: FTP, SFTP, LAN, WebDAV e RDS.

Entre as atividades não relacionadas a servidor estão operações comuns como digitar, editar folhas de estilos externas, gerar relatórios de todo o site e criar novos sites.

Entre as atividades relacionadas a servidor que o Dreamweaver não pode realizar durante transferências de arquivo estão as seguintes:

  • Colocar/obter/devolver/retirar arquivos

  • Desfazer retirada

  • Criar uma conexão de banco de dados

  • Ligar dados dinâmicos

  • Visualizar dados na Visualização dinâmica

  • Inserir um serviço da Web

  • Excluir arquivos remotos ou pastas

  • Visualizar em um navegador em um servidor de teste

  • Salvar um arquivo em um servidor remoto

  • Inserir uma imagem de um servidor remoto

  • Abrir um arquivo em um servidor remoto

  • Colocar automaticamente arquivos ao salvar

  • Arrastar arquivos para o site remoto

  • Recortar, copiar ou colar arquivos no site remoto

  • Atualizar Visualização remota

Por padrão, a caixa de diálogo Atividade de arquivo em segundo plano é aberta durante transferências de arquivos. Você pode minimizar a caixa de diálogo clicando no botão Minimizar do canto superior direito. Fechar a caixa de diálogo durante transferências de arquivos resulta no cancelamento da operação.

Obter arquivos de um servidor remoto

Você pode copiar arquivos do site remoto para o site local de uma das seguintes maneiras:

O Dreamweaver cria um registro da atividade de arquivo durante a transferência que você pode exibir e salvar.

Observação:

Você não pode desativar a transferência de arquivos em segundo plano. Caso o registro detalhado esteja aberto na janela Atividade de arquivo em segundo plano, você pode fechá-lo para melhorar o desempenho.

O Dreamweaver também registra toda a atividade de transferência de arquivos FTP. Caso ocorra um erro quando você estiver transferindo um arquivo usando o FTP, o registro de FTP do site pode ajudá-lo a determinar o problema.

Obter arquivos de um servidor remoto usando o painel Arquivos

  1. No painel Arquivos (Janela > Arquivos), selecione os arquivos que você deseja baixar.

    Normalmente, você seleciona esses arquivos na Visualização remota, mas é possível selecionar os arquivos correspondentes na Visualização local se preferir. Caso a Visualização remota esteja ativa, o Dreamweaver copiará os arquivos selecionados para o site local; caso a Visualização local esteja ativa, o Dreamweaver copiará as versões remotas dos arquivos locais selecionados para o site local.

    Observação:

    Para obter apenas os arquivos cuja versão remota é mais recente do que a versão local, use a opção Sincronizar.

  2. Siga um dos seguintes procedimentos para obter o arquivo:
    • Clique no botão Obter na barra de ferramentas do painel Arquivos.

    • Clique com o botão direito do mouse (Windows) ou com a tecla Control pressionada (Macintosh) no arquivo do painel Arquivos e escolha Obter no menu de contexto.

  3. Clique em Sim na caixa de diálogo Arquivos dependentes para baixar arquivos dependentes; caso você já tenha cópias locais dos arquivos dependentes, clique em Não. O padrão é não baixar arquivos dependentes. Você pode editar essa opção em Editar > Preferências > Site.

    O Dreamweaver baixa os arquivos selecionados da seguinte forma:

    • Caso você esteja usando o sistema de devolução/retirada, a obtenção de um arquivo resulta em uma cópia local somente leitura do arquivo; o arquivo permanece disponível no site remoto ou no servidor de teste para que os demais membros da equipe retirem.

    • Caso você não esteja usando o sistema de devolução/retirada, a obtenção de um arquivo resultará em uma cópia com os privilégios de leitura e gravação.

    Observação:

    Caso esteja trabalhando em um ambiente colaborativo, ou seja, caso outros estejam trabalhando nos mesmos arquivos, você não deve desativar Ativar devolução e retirada de arquivos. Caso outras pessoas estejam usando o sistema de devolução/retirada com o site, você também deve usá-lo.

    Para parar a transferência de arquivos a qualquer momento, clique no botão Cancelar da caixa de diálogo Atividade de arquivo em segundo plano.  

Obter arquivos de um servidor remoto usando a janela Documento

  1. Verifique se o documento está ativo na janela Documento.
  2. Siga um dos seguintes procedimentos para obter o arquivo:
    • Selecione Site > Obter.

    • Clique no ícone Gerenciamento de arquivos na barra de ferramentas da janela Documento e, em seguida, selecione Obter no menu.

    Observação:

    Caso o arquivo atual não faça parte do site atual no painel Arquivos, o Dreamweaver tentará determinar a qual site definido localmente o arquivo atual pertence. Caso o arquivo atual pertença a apenas um site local, o Dreamweaver abrirá o site e executará a operação Obter.

Exibir o registro de FTP

  1. Clique no menu Opções no canto superior direito do painel Arquivos.
  2. Selecione Exibir > Registro de FTP do site.

Observação:

No painel Arquivos expandido, você pode clicar no botão Registro de FTP para exibir o registro.

Colocar arquivos em um servidor remoto

Você pode colocar arquivos do site local no site remoto, normalmente sem alterar o status de retirada do arquivo.

Há duas situações comuns em que você pode usar o comando Colocar em vez de Devolver:

  • Você não está em um ambiente colaborativo e não está usando o sistema de devolução/retirada.
  • Você deseja colocar a versão atual do arquivo no servidor, mas continuará editando-o.

Observação:

Caso você coloque um arquivo que não existia anteriormente no site remoto e esteja usando o sistema de devolução/retirada, o arquivo é copiado para o site remoto e, em seguida, retirado para que você possa continuar a edição.

Você pode usar o painel Arquivos ou a janela Documento para colocar arquivos. O Dreamweaver cria um registro da atividade de arquivo durante a transferência que você pode exibir e salvar.

Observação:

Você não pode desativar a transferência de arquivos em segundo plano. Caso o registro detalhado esteja aberto na janela Atividade de arquivo em segundo plano, você pode fechá-lo para melhorar o desempenho.  

O Dreamweaver também registra toda a atividade de transferência de arquivos FTP. Caso ocorra um erro quando você estiver transferindo um arquivo usando o FTP, o registro de FTP do site pode ajudá-lo a determinar o problema.

Para um tutorial sobre como colocar arquivos em um servidor remoto, consulte www.adobe.com/go/vid0163_br.

Para ver um tutorial sobre como solucionar problemas de publicação, consulte www.adobe.com/go/vid0164_br.

Colocar arquivos em um servidor remoto ou de teste usando o painel Arquivos

  1. No painel Arquivos (Janela > Arquivos), selecione os arquivos a serem carregados.

    Normalmente você seleciona esses arquivos na Visualização local, mas pode selecionar os arquivos correspondentes na Visualização remota se preferir.

    Observação:

    Você só pode colocar esses arquivos cuja versão local é mais recente do que a versão remota.

  2. Siga um dos seguintes procedimentos para colocar o arquivo no servidor remoto:
    • Clique no botão Colocar na barra de ferramentas do painel Arquivos.

    • Clique com o botão direito do mouse (Windows) ou com a tecla Control pressionada (Macintosh) no arquivo do painel Arquivos e escolha Colocar no menu de contexto.

  3. Caso o arquivo não tenha sido salvo, uma caixa de diálogo é exibida (caso você defina essa preferência na categoria Site da caixa de diálogo Preferências) permitindo a você salvar o arquivo antes de colocá-lo no servidor remoto. Clique em Sim para salvar o arquivo ou em Não para colocar a versão salva anteriormente no servidor remoto.

    Observação:

    Se você não salvar o arquivo, todas as alterações que você fez desde a última gravação serão colocadas no servidor remoto. No entanto, como o arquivo permanece aberto, você pode continuar salvando as alterações depois de colocar o arquivo no servidor caso desejado.

  4. Clique em Sim para atualizar os arquivos dependentes com os arquivos selecionados ou clique em Não para evitar o carregamento de arquivos dependentes. O padrão é não carregar arquivos dependentes. Você pode editar essa opção em Editar > Preferências > Site.

    Observação:

    Normalmente, é uma boa ideia carregar arquivos dependentes ao devolver um novo arquivo, mas caso as versões mais recentes dos arquivos dependentes já estejam no servidor remoto, não há necessidade de carregá-los novamente.

    Para parar a transferência de arquivos a qualquer momento, clique no botão Cancelar da caixa de diálogo Atividade de arquivo em segundo plano.

Colocar arquivos em um servidor remoto usando a janela Documento

  1. Verifique se o documento está ativo na janela Documento.
  2. Siga um dos seguintes procedimentos para colocar o arquivo:
    • Selecione Site > Colocar.

    • Clique no ícone Gerenciamento de arquivos na barra de ferramentas da janela Documento e, em seguida, selecione Colocar no menu.

    Observação:

    Caso o arquivo atual não faça parte do site atual no painel Arquivos, o Dreamweaver tentará determinar a qual site definido localmente o arquivo atual pertence. Caso o arquivo atual pertença a apenas um site local, o Dreamweaver abrirá o site e executará a operação Colocar.

Exibir o registro de FTP

  1. Clique no menu Opções no canto superior direito do painel Arquivos.
  2. Selecione Exibir > Registro de FTP do site.

Observação:

No painel Arquivos expandido, você pode clicar no botão Registro de FTP para exibir o registro.

Gerenciar transferências de arquivo

Você pode exibir o status das operações de transferência de arquivo, bem como uma lista de arquivos transferidos e seus resultados (êxito na transferência, ignorado ou falha). Você também pode salvar um registro da atividade do arquivo.

Observação:

O Dreamweaver permite realizar outras atividades não relacionadas a servidor durante a transferência de arquivos para ou de um servidor.

Cancelar uma transferência de arquivo

  1. Clique no botão Cancelar da caixa de diálogo Atividade de arquivo em segundo plano. Se a caixa de diálogo não estiver em exibição, clique no botão Atividade de arquivo na parte inferior do painel Arquivos.

Mostrar a caixa de diálogo Atividade de arquivo em segundo plano durante transferências

Clique no botão Atividade de arquivo ou Registro na parte inferior do painel Arquivos.

Exibir detalhes da última transferência de arquivo

  1. Clique no botão Registro na parte inferior do painel Arquivos para abrir a caixa de diálogo Atividade de arquivo em segundo plano.
  2. Clique na seta de expansão Detalhes.

Salvar um registro da última transferência de arquivo

  1. Clique no botão Registro na parte inferior do painel Arquivos para abrir a caixa de diálogo Atividade de arquivo em segundo plano.
  2. Clique no botão Salvar registro e salve as informações como um arquivo de texto.

    Você pode revisar a atividade de arquivo abrindo o arquivo de registro no Dreamweaver ou em qualquer editor de textos.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online