Guia do Usuário Cancelar

Vinculação

  1. Guia do usuário do Dreamweaver
  2. Introdução
    1. Noções básicas de web design responsivo
    2. Novidades do Dreamweaver
    3. Desenvolvimento Web com o Dreamweaver – Visão geral
    4. Dreamweaver/Perguntas frequentes
    5. Atalhos de teclado
    6. Requisitos de sistema do Dreamweaver
    7. Resumo dos recursos
  3. Dreamweaver e Creative Cloud
    1. Sincronizar as configurações do Dreamweaver com a Creative Cloud
    2. Bibliotecas da Creative Cloud no Dreamweaver
    3. Uso de arquivos do Photoshop no Dreamweaver
    4. Trabalhe com o Adobe Animate e o Dreamweaver
    5. Extraia das Bibliotecas arquivos SVG otimizados para a Web
  4. Áreas de trabalho e exibições do Dreamweaver
    1. Espaço de trabalho do Dreamweaver
    2. Otimizar espaço de trabalho no Dreamweaver para desenvolvimento visual
    3. Pesquisa de arquivos baseada no nome de arquivo ou no conteúdo | Mac OS
  5. Configurar sites
    1. Sobre sites do Dreamweaver
    2. Configurar uma versão local do site
    3. Conectar-se a um servidor de publicação
    4. Configurar um servidor de teste
    5. Importar e exportar configurações de site do Dreamweaver
    6. Trazer sites existentes de um servidor remoto para a raiz do site local
    7. Recursos de acessibilidade do Dreamweaver
    8. Configurações avançadas
    9. Definir preferências de site para transferência de arquivos
    10. Especificar configurações do servidor proxy no Dreamweaver
    11. Sincronizar as configurações do Dreamweaver com a Creative Cloud
    12. Como usar o Git no Dreamweaver
  6. Gerenciar arquivos
    1. Criar e abrir arquivos
    2. Gerenciamento de arquivos e pastas
    3. Obter e colocar arquivos no servidor
    4. Devolver e retirar arquivos
    5. Sincronizar arquivos
    6. Comparar arquivos em busca de diferenças
    7. Encobrir arquivos e pastas em seu site do Dreamweaver
    8. Ativar as Design Notes para sites do Dreamweaver
    9. Impedir possível ataque ao Gatekeeper
  7. Layout e design
    1. Usar auxílios visuais para layout
    2. Sobre usar o CSS para criar o layout da página
    3. Criar sites responsivos usando o Bootstrap
    4. Criar e usar consultas de mídia no Dreamweaver
    5. Apresentar conteúdo em tabelas
    6. Cores
    7. Design responsivo usando layouts de grade fluida
    8. Extract no Dreamweaver
  8. CSS
    1. Noções sobre as folhas de estilos em cascata
    2. Aplicar layout às páginas usando o CSS Designer
    3. Usar pré-processadores de CSS no Dreamweaver
    4. Como definir preferências de estilo CSS no Dreamweaver
    5. Mover regras de CSS no Dreamweaver
    6. Converter CSS inline em uma regra de CSS no Dreamweaver
    7. Trabalhar com tags div
    8. Aplicação de degradês ao fundo
    9. Criar e editar efeitos de transição do CSS3 no Dreamweaver
    10. Formatar código
  9. Conteúdo e ativos de página
    1. Definir propriedades da página
    2. Configurar propriedades de cabeçalho e propriedades de link de CSS
    3. Trabalhar com texto
    4. Localizar e substituir texto, tags e atributos
    5. Painel DOM
    6. Editar na Visualização dinâmica
    7. Codificar documentos do Dreamweaver
    8. Selecionar e exibir os elementos na janela Documento
    9. Definir propriedades de texto no Inspetor de propriedades
    10. Verificar ortografia de uma página Web
    11. Usar regras horizontais no Dreamweaver
    12. Adicionar e modificar combinações de fontes no Dreamweaver
    13. Trabalhar com ativos
    14. Inserir e atualizar datas no Dreamweaver
    15. Criar e gerenciar ativos favoritos no Dreamweaver
    16. Inserir e editar imagens no Dreamweaver
    17. Adicionar objetos de mídia
    18. Adição de vídeos no Dreamweaver
    19. Inserir vídeo HTML5
    20. Inserir arquivos SWF
    21. Adicionar efeitos de áudio
    22. Inserir áudio HTML5 no Dreamweaver
    23. Trabalhar com itens da biblioteca
    24. Usar texto em árabe e hebraico no Dreamweaver
  10. Vinculação e navegação
    1. Sobre vinculação e navegação
    2. Vinculação
    3. Mapas de imagem
    4. Solucionar problemas com links
  11. Efeitos e widgets do jQuery
    1. Usar widgets de interface e para dispositivos móveis do jQuery no Dreamweaver
    2. Usar efeitos do jQuery no Dreamweaver
  12. Programar sites
    1. Sobre codificação no Dreamweaver
    2. Ambiente de codificação no Dreamweaver
    3. Definir preferências de codificação
    4. Personalizar codificação por cores
    5. Escrever e editar código
    6. Dicas de código e preenchimento de código
    7. Recolher e expandir código
    8. Reutilizar código com snippets
    9. Linting de código
    10. Otimizar código
    11. Editar código na Visualização de design
    12. Trabalhar com conteúdo do cabeçalho das páginas
    13. Inserir inclusões de servidor no Dreamweaver
    14. Usar bibliotecas de tags no Dreamweaver
    15. Importar tags personalizadas para o Dreamweaver
    16. Usar comportamentos JavaScript (instruções gerais)
    17. Aplicar comportamentos internos do JavaScript
    18. Sobre XML e XSLT
    19. Executar transformações XSL do servidor no Dreamweaver
    20. Executar transformações XSL do cliente no Dreamweaver
    21. Adicionar entidades de caracteres para XSLT no Dreamweaver
    22. Formatar código
  13. Fluxos de trabalho entre produtos
    1. Instalar e usar extensões no Dreamweaver
    2. Atualizações dentro do aplicativo no Dreamweaver
    3. Inserir documentos do Microsoft Office no Dreamweaver (somente Windows)
    4. Trabalho com o Fireworks e o Dreamweaver
    5. Editar conteúdo em sites do Dreamweaver usando o Contribute
    6. Integração do Business Catalyst ao Dreamweaver
    7. Criar campanhas de email personalizadas
  14. Modelos
    1. Sobre os modelos do Dreamweaver
    2. Reconhecimento de modelos e documentos baseados em modelo
    3. Criar um modelo do Dreamweaver
    4. Criar regiões editáveis nos modelos
    5. Criar regiões e tabelas repetitivas no Dreamweaver
    6. Usar regiões opcionais em modelos
    7. Definir atributos de tag editáveis no Dreamweaver
    8. Como criar modelos aninhados no Dreamweaver
    9. Editar, atualizar e excluir modelos
    10. Exportar e importar conteúdo xml no Dreamweaver
    11. Aplicar ou remover um modelo em um documento
    12. Editar conteúdo em modelos do Dreamweaver
    13. Regras de sintaxe para tags de modelo no Dreamweaver
    14. Definir preferências de realce para regiões de modelo
    15. Vantagens de usar modelos no Dreamweaver
  15. Dispositivo móvel e multitela
    1. Criar consultas de mídia
    2. Alterar a orientação de página para dispositivos móveis
    3. Criar aplicativos Web para dispositivos móveis usando o Dreamweaver
  16. Sites dinâmicos, páginas e formulários Web
    1. Noções sobre aplicativos Web
    2. Configurar o computador para desenvolvimento de aplicativos
    3. Solucionar problemas de conexões de banco de dados
    4. Remover scripts de conexão no Dreamweaver
    5. Criar páginas dinâmicas
    6. Visão geral das fontes de conteúdo dinâmico
    7. Definir origens de conteúdo dinâmico
    8. Adicionar conteúdo dinâmico a páginas
    9. Alterar conteúdo dinâmico no Dreamweaver
    10. Exibir registros de banco de dados
    11. Fornecer e solucionar problemas de live data no Dreamweaver
    12. Adicionar comportamentos personalizados de servidor no Dreamweaver
    13. Criar formulários usando o Dreamweaver
    14. Usar formulários para reunir informações de usuários
    15. Criar e ativar formulários do ColdFusion no Dreamweaver
    16. Criar formulários Web
    17. Suporte aprimorado a HTML5 para elementos de formulário
    18. Desenvolver um formulário usando o Dreamweaver
  17. Criação visual de aplicativos
    1. Criar páginas mestre e detalhadas no Dreamweaver
    2. Criar páginas de pesquisa e de resultados
    3. Criar uma página de inserção de registro
    4. Criar uma página de registro de atualização no Dreamweaver
    5. Criar páginas de exclusão de registro no Dreamweaver
    6. Usar comandos ASP para modificar um banco de dados no Dreamweaver
    7. Criar uma página de registro
    8. Criar uma página de logon
    9. Criar uma página que apenas usuários autorizados podem acessar
    10. Proteger pastas no ColdFusion usando o Dreamweaver
    11. Usar componentes do ColdFusion no Dreamweaver
  18. Testar, visualizar e publicar sites
    1. Visualizar páginas
    2. Visualizar páginas Web do Dreamweaver em vários dispositivos
    3. Testar seu site do Dreamweaver
  19. Solução de problemas
    1. Problemas corrigidos
    2. Problemas conhecidos

 

 

Aprenda a configurar a navegação entre páginas da Web. Vincule arquivos e documentos, atualize, altere e teste links no Dreamweaver.

Antes de criar um link, você deve entender como funcionam caminhos absolutos, relativos a documentos e relativos à raiz do site. Você pode criar vários tipos de links em um documento:

  • Um link para outro documento ou para um arquivo, como um arquivo gráfico, de filme, PDF ou de som.
  • Um link de âncora nomeado, que salta para um local específico em um documento.

  • Um link de email, que cria uma nova mensagem de email em branco com o endereço do destinatário já preenchido.

  • Links nulos e de script, usados para anexar comportamentos a um objeto ou para criar um link que executa o código JavaScript.

Você pode usar o Inspetor de propriedades e o ícone Apontar para arquivo para criar links de uma imagem, objeto ou texto para outro documento ou arquivo.

O Dreamweaver cria os links para outras páginas em seu site usando caminhos relativos a documentos. Você também pode configurar o Dreamweaver para criar novos links usando caminhos da raiz do site.

Sempre salve um novo arquivo antes de criar um caminho relativo a documentos; esse tipo de caminho não é válido sem um ponto inicial definido. Se você criar um caminho relativo a documentos antes de salvar o arquivo, o Dreamweaver usará temporariamente um caminho absoluto começando com arquivo:// até o arquivo ser salvo. Depois que o arquivo for salvo, o Dreamweaver converterá o caminho arquivo:// em um caminho relativo.

Você pode anexar um comportamento a qualquer link de um documento. Avalie a possibilidade de usar os seguintes comportamentos ao inserir elementos vinculados em documentos:

Definir texto da barra de status

Determina o texto de uma mensagem e o exibe na barra de status, no canto inferior esquerdo da janela do navegador. Por exemplo, você pode usar esse comportamento para descrever o destino de um link na barra de status em vez de mostrar o URL associado.

Abrir janela do navegador

Abre um URL em uma nova janela. Você pode especificar as propriedades da nova janela, incluindo o nome, o tamanho e seus atributos (se pode ser redimensionada, se tem uma barra de menus, etc.).

Menu de salto

Edita um menu de salto. Você pode alterar a lista de menus, especificar um arquivo vinculado diferente ou alterar o local do navegador no qual o documento vinculado é aberto.

Você pode usar o ícone de pasta do Inspetor de propriedades ou a caixa Link para criar links de uma imagem, objeto ou texto para outro documento ou arquivo.

  1. Selecione texto ou uma imagem na Visualização de design da janela Documento.
  2. Abra o Inspetor de propriedades (Janela > Propriedades) e execute um dos procedimentos a seguir:
    • Clique no ícone de pasta à direita da caixa Link para navegar até um arquivo e selecioná-lo.

      O caminho até o documento vinculado aparece na caixa URL. Use o menu pop-up Em relação a na caixa de diálogo Selecionar arquivo para escolher o tipo de caminho (em relação ao documento ou à raiz) e clique em OK. O tipo de caminho selecionado é aplicado somente no link atual. (Você pode alterar a configuração padrão da caixa Em relação a para o site.)

    • Digite o caminho e o nome de arquivo do documento na caixa Link.

      Para vincular-se a um documento do seu site, insira um caminho relativo a um documento ou à raiz do site. Para vincular-se a um documento externo ao seu site, insira um caminho absoluto incluindo o protocolo (como http://). Você pode usar essa abordagem para inserir um link para um arquivo que ainda não foi criado.

  3. Na lista suspensa Destino, selecione um local no qual o documento será aberto:

    • _blank carrega o documento vinculado em uma nova janela do navegador não nomeada.
    • _parent carrega o documento vinculado no quadro pai ou na janela pai do quadro que contém o link. Se o quadro que contém o link não estiver aninhado, o documento vinculado será carregado na janela completa do navegador.
    • _self carrega o documento vinculado no mesmo quadro ou janela do link. Esse destino é o padrão, normalmente não é necessário especificá-lo.
    • _top carrega o documento vinculado na janela completa do navegador, removendo todos os quadros.
    • _new carrega o arquivo vinculado em uma nova janela.
  1. Selecione texto ou uma imagem na Visualização de design da janela Documento.
  2. Siga um dos dois procedimentos abaixo para criar um link:
    • Arraste o ícone Apontar para arquivo (ícone de destino) à direita da caixa Link no Inspetor de propriedades e aponte para uma âncora visível no documento atual, uma âncora visível em outro documento aberto, um elemento que tenha uma ID exclusiva atribuída a ele ou um documento no painel Arquivos.

    • Arraste a partir da seleção feita com shift e ponte para uma âncora visível no documento atual, uma âncora visível em outro documento aberto, um elemento que tenha uma ID exclusiva atribuída a ele ou um documento no painel Arquivos.

    é possível vincular outro documento aberto somente se os documentos não estiverem maximizados na janela Documento. Para dispor os documentos lado a lado, selecione Janela > Organizar > Em cascata ou Janela > Organizar > Lado a lado. Ao apontar para um documento aberto, esse documento vai para o primeiro plano da tela enquanto você seleciona suas opções.

O comando Hiperlink permite criar um link de texto para uma imagem, objeto ou outro documento ou arquivo.

  1. Coloque o ponto de inserção no documento onde você deseja que o link seja exibido.
  2. Siga um destes procedimentos para exibir a caixa de diálogo Hiperlink:

    • Selecione Inserir > Hiperlink.

    • Na categoria Comum do painel Inserir, clique no botão Hiperlink.

  3. No campo Texto, insira o texto do link.
    No menu suspenso Link, selecione o nome do arquivo que você deseja vincular. Também é possível clicar no ícone de pasta para navegar até o arquivo que você deseja vincular.

  4. No menu pop-up Destino, selecione a janela na qual o arquivo deve ser aberto ou digite seu nome.

    Os nomes de todos os quadros nomeados no documento atual aparecem na lista pop-up. Se você especificar um quadro que não existe, a página vinculada será aberta em uma nova janela que tem o nome especificado. Você também pode selecionar um dos seguintes nomes de destino reservados:

    • _blank carrega o arquivo vinculado em uma nova janela do navegador não nomeada.
    • _parent carrega o arquivo vinculado no conjunto de molduras pai ou na janela do quadro que contém o link. Se o quadro que contém o link não estiver aninhado, o arquivo vinculado será carregado na janela de navegador em tamanho integral.
    • _self carrega o arquivo vinculado no mesmo quadro ou janela do link. Esse destino é o padrão, normalmente não é necessário especificá-lo.
    • _top carrega o arquivo vinculado na janela de navegador em tamanho integral, removendo todos os quadros.
    • _new carrega o arquivo vinculado em uma nova janela.
  5. Na caixa de Índice de guias, insira um número para a ordem de guias.
  6. Na caixa Título, insira um título para o link.
  7. Na caixa Chave de acesso, insira um equivalente do teclado (uma letra) para selecionar o link no navegador.
  8. Clique em OK.

Você pode inserir um link para um documento do Microsoft Word ou Excel em uma página existente.

  1. Na Visualização de design, abra página no local que você deseja que o link seja exibido.

  2. Arraste o arquivo do local atual para a página do Dreamweaver, posicionando o link no local desejado. A caixa de diálogo Inserir documento é exibida.

  3. Selecione Criar um link e clique em OK.

    Se o documento ao qual você está se vinculando estiver localizado fora da pasta raiz do site, o Dreamweaver solicitará que você copie o documento para a raiz do site.

    Ao copiar o documento para a pasta raiz do site, você garantirá que o documento estará disponível quando o site for publicado.

  4. Ao fazer upload da sua página para o servidor Web, envie também o arquivo Word ou Excel. Sua página agora contém um link para o documento Word ou Excel. O texto do link é o nome do arquivo vinculado. Você pode alterar o texto do link na janela Documento se desejar.

Por padrão, o Dreamweaver cria os links para outras páginas em seu site usando caminhos relativos a documentos. Para usar o caminho relativo à raiz do site, defina primeiro uma pasta local no Dreamweaver escolhendo uma pasta raiz local para servir como o equivalente da raiz do documento em um servidor. O Dreamweaver usa essa pasta para determinar os caminhos relativos à raiz do site para arquivos.

  1. Selecione Site > Gerenciar sites.
  2. Na caixa de diálogo Gerenciar sites, clique duas vezes no seu site na lista.
  3. Na caixa de diálogo Configuração de site, expanda as Configurações avançadas e selecione a categoria Informações locais.
  4. Defina o caminho relativo de novos links selecionando a opção Documento ou Raiz do site.

    A alteração dessa configuração não converterá o caminho de links existentes depois de você clicar em OK. A configuração é aplicada somente a novos links criados com o Dreamweaver.

  5. Clique em Salvar.

    A configuração do novo caminho é aplicada somente no site atual.

Você pode usar o Inspetor de propriedades para criar links para uma seção específica de um documento criando primeiro âncoras nomeadas. As âncoras nomeadas permitem definir marcadores em um documento, que normalmente são colocados em um tópico específico ou na parte superior de um documento. Em seguida, você cria links para essas âncoras nomeadas, que direcionam o visitante rapidamente para a posição especificada.

A criação de um link para uma âncora nomeada é um processo de duas etapas. Primeiro, crie uma âncora nomeada e, em seguida, crie um link para a âncora nomeada.

Criar uma âncora

  1. Na janela Documento, selecione e destaque o item que você deseja definir como uma âncora.

  2. Abra o Inspetor de propriedades e verifique se o item selecionado tem uma ID. Se o campo ID estiver vazio, adicione uma ID. Por exemplo, Âncora.

    Criar uma âncora
    Criar uma âncora

    Depois que você adicionar a ID, observe a alteração no código. id="<ID name>" é inserido no código da sua seleção.

    ID da âncora no código
    Adicionar âncoras para vinculação

  1. Na Visualização de design da janela Documento, selecione um texto ou uma imagem a partir do qual um link será criado.
  2. Na caixa Link do Inspetor de propriedades, digite um sinal de número (#) e o nome da âncora. Por exemplo, para vincular-se a uma âncora chamada “top” no documento atual, digite #top. Para vincular-se a uma âncora chamada “top” em um documento diferente da mesma pasta, digite nome_do_arquivo.html#top.
    Observação:

    Os nomes de âncora diferenciam minúsculas de maiúsculas.

  1. Abra o documento que contém a âncora nomeada.
    Observação:

    Na Visualização de design, selecione Exibir > Opções de Visualização de design > Auxílios visuais > Elementos invisíveis para tornar as âncoras visíveis, caso você não as veja.

  2. Na Visualização de design da janela Documento, selecione um texto ou uma imagem a partir do qual um link será criado. (Se o link for criado a partir de outro documento aberto, é necessário alternar para ele.)
  3. Siga um destes procedimentos:
    • Clique no ícone Apontar para arquivo (ícone de destino) à direita da caixa Link no Inspetor de propriedades e arraste-o até a âncora à qual você deseja se vincular: seja uma âncora no mesmo documento ou em outro documento aberto.

    • Arraste com a tecla Shift pressionada na janela Documento desde o texto ou a imagem selecionado até a âncora desejada: seja uma âncora no mesmo documento ou em outro documento aberto.

Um link de email abre uma nova janela de mensagem em branco (usando o programa de email associado ao navegador do usuário) quando é clicado. Na janela da mensagem de email, a caixa Para é atualizada automaticamente com o endereço especificado no link de email.

  1. Na Visualização de design da janela Documento, posicione o ponto de inserção onde você deseja que o link de email seja exibido ou selecione o texto ou a imagem que será exibido como link de email.
  2. Escolha uma destas opções para inserir o link:
    • Selecione Inserir > Link de email.

    • Na categoria Comum do painel Inserir, clique no botão Link de email.

  3. Na caixa Texto, digite ou edite o corpo do email.
  4. Na caixa Email, digite o endereço de email e clique em OK.
  1. Selecione texto ou uma imagem na Visualização de design da janela Documento.
  2. Na caixa Link do Inspetor de propriedades, digite mailto: seguido por um endereço de email.

    Não digite nenhum espaço entre o sinal de dois pontos e o endereço de email.

Preenchimento automático da linha de assunto de um email

  1. Crie um link de email usando o Inspetor de propriedades como descrito acima.
  2. Na caixa Link do Inspetor de propriedades, adicione ?subject= após o email e digite um assunto após o sinal de igual. Não digite nenhum espaço entre o ponto de interrogação e o final do endereço de email.

    A entrada completa deve ser similar ao seguinte:

    mailto:someone@yoursite.com?subject=Email do seu site

Um link nulo é um link não designado. Use links nulos para anexar comportamentos em objetos ou texto em uma página. Por exemplo, você pode anexar um comportamento em um link nulo para que esse link troque uma imagem ou exiba um elemento absolutamente posicionado (elemento AP) quando o ponteiro for movido sobre o link.

Os links de script executam o código JavaScript ou chamam uma função JavaScript e são úteis para fornecer aos visitantes informações adicionais sobre um item sem que eles precisem sair da página da Web atual. Os links de script também podem ser usados para realizar cálculos, validar formulários ou executar outras tarefas de processamento quando um visitante clica em um item específico.

  1. Selecione texto, uma imagem ou um objeto na Visualização de design da janela Documento.
  2. No Inspetor de propriedades, digite javascript:; (a palavra javascript seguida por um sinal de dois pontos e por um sinal de ponto-e-vírgula) na caixa Link.
  1. Selecione texto, uma imagem ou um objeto na Visualização de design da janela Documento.
  2. Na caixa Link do Inspetor de propriedades, digite javascript: seguido por algum código ou chamada de função JavaScript. Não digite nenhum espaço entre o sinal de dois pontos e o código ou chamada.

O Dreamweaver pode atualizar links para e de um documento sempre que você mover ou renomear o documento em um site local. Esse recurso funciona melhor quando você armazena o site inteiro (ou uma seção inteira) no disco local. O Dreamweaver não altera arquivos na pasta remota até você colocar os arquivos locais nessa pasta ou verificá-los no servidor remoto.

Para agilizar o processo de atualização, o Dreamweaver pode criar um arquivo de cache para armazenar informações sobre todos os links da pasta local. O arquivo de cache é atualizado de forma invisível à medida que você adiciona, altera ou exclui links do site local.

  1. Selecione Editar > Preferências (Windows) ou Dreamweaver > Preferências (macOS).
  2. Na caixa de diálogo Preferências, selecione Geral na lista de categorias à esquerda.
  3. Na seção Opções do documento das preferências de Geral, selecione uma opção no menu pop-up Atualizar links ao mover arquivos.

    Sempre

    Atualiza automaticamente todos os links para e de um documento selecionado sempre que esse documento é movido ou renomeado.

    Nunca

    Não atualiza automaticamente todos os links para e de um documento selecionado quando esse documento é movido ou renomeado.

    Solicitar

    Exibe uma caixa de diálogo que lista todos os arquivos afetados pela alteração. Clique em Atualizar para atualizar os links nesses arquivos ou clique em Não atualizar para não alterar os arquivos.

  4. Clique em OK.

Criar um arquivo de cache para o site

  1. Selecione Site > Gerenciar sites.
  2. Selecione um site e clique em Editar.
  3. Na caixa de diálogo Configuração de site, expanda as Configurações avançadas e selecione a categoria Informações locais.
  4. Na categoria Informações locais, selecione Ativar o cache.

    Na primeira vez em que você alterar ou excluir links para arquivos na pasta local depois de iniciar o Dreamweaver, o aplicativo solicitará o carregamento do cache. Se você clicar em Sim, o Dreamweaver carregará o cache e atualizará todos os links para o arquivo que acaba de ser alterado. Se você clicar em Não, a alteração será registrada no cache, mas o Dreamweaver não carregará o cache nem atualizará os links.

    O cache talvez demore alguns minutos para ser carregado em sites maiores porque o Dreamweaver deve determinar se o cache está atualizado comparando os carimbos de data/hora dos arquivos do site local com os carimbos de data/hora registrados no cache. Se não tiver alterado nenhum arquivo fora do Dreamweaver, você poderá clicar com segurança no botão “Parar” quando for exibido.

Recriar o cache

  1. No painel Arquivos, selecione Site > Avançado > Recriar o cache do site.

Além de configurar o Dreamweaver para atualizar automaticamente os links sempre que um arquivo for movido ou renomeado, você pode alterar manualmente todos os links (inclusive os links de email, de FTP, nulos e de script) para que eles apontem para outro lugar.

Essa opção é mais útil quando você deseja excluir um arquivo que está vinculado a outros arquivos, mas pode ser usada para outras finalidades. Por exemplo, imagine que você vincule as palavras “filmes deste mês” a /filmes/julho.html no site inteiro. Em 1º de agosto, você teria que alterar esses links para que apontassem para /filmes/agosto.html.

  1. Selecione um arquivo na Visualização local do painel Arquivos.
    Observação:

    se estiver alterando um link de email, de FTP, nulo ou de script, você não precisa selecionar um arquivo.

  2. Selecione Site > Opções de site > Alterar link no site inteiro.

  3. Preencha as seguintes opções na caixa de diálogo Alterar link no site inteiro:

    Alterar todos os links para

    Clique no ícone de pasta para navegar até o arquivo de destino do qual você deseja se desvincular e selecioná-lo. Se estiver alterando um link de email, de FTP, nulo ou de script, digite o texto completo do link que está alterando.

    Em links para

    Clique no ícone de pasta para navegar e selecionar o novo arquivo ao qual você deseja vincular. Se estiver alterando um link de email, de FTP, nulo ou de script, digite o texto completo do link de substituição.

  4. Clique em OK.

    O Dreamweaver atualiza todos os documentos vinculados ao arquivo selecionado, fazendo com que eles apontem para o novo arquivo, usando o formato de caminho já utilizado no documento (por exemplo, se o caminho antigo era relativo ao documento, o novo caminho também deve ser relativo ao documento).

    Depois de alterar um link no site inteiro, o arquivo selecionado fica órfão (isto é, nenhum arquivo do disco local aponta para ele). Você pode excluí-lo com segurança sem quebrar nenhum link no site local do Dreamweaver.

    Observação:

    Como essas alterações ocorrem localmente, você deve excluir de modo manual o arquivo órfão correspondente na pasta remota e colocar ou verificar todos os arquivos nos quais os links foram alterados; caso contrário, os visitantes do site não verão as mudanças.

Os links não estão ativos no Dreamweaver, isto é, você não pode abrir um documento vinculado clicando no link na janela Documento.

  1. Siga um destes procedimentos:
    • Clique com o botão direito no link e selecione Abrir página vinculada.

    • Pressione a tecla Control (Windows) ou Command (Macintosh) e clique duas vezes no link.

    Observação:

    O documento vinculado deve residir no disco local.

 Adobe

Receba ajuda com mais rapidez e facilidade

Novo usuário?

Adobe MAX 2024

Adobe MAX:
a conferência da criatividade

14 a 16 de outubro, Miami Beach e online

Adobe MAX

A conferência da criatividade

14 a 16 de outubro, Miami Beach e online

Adobe MAX 2024

Adobe MAX:
a conferência da criatividade

14 a 16 de outubro, Miami Beach e online

Adobe MAX

A conferência da criatividade

14 a 16 de outubro, Miami Beach e online