Há quatro modos principais que podem afetar o desempenho no Photoshop:

  • otimizar a configuração de seu hardware
  • especificar preferências de desempenho
  • usar bons hábitos de trabalho no Photoshop
  • criar algumas etapas para acelerar seu SO

Para obter os melhores resultados, porém, adote uma abordagem holística para otimizar o desempenho do Photoshop. Leia todas as sugestões apresentadas aqui e considere quais implementar dentro do contexto da configuração do computador, os tipos de arquivos que você usa e seu fluxo de trabalho específico. Cada circunstância é única e requer uma combinação diferente de técnicas para obter o desempenho mais eficiente do Photoshop.

Otimizar a configuração de seu hardware

Use um processador suficientemente rápido

A velocidade da unidade central de processamento ou CPU do computado limita velocidade do processamento do Photoshop. O Photoshop CS4 requer um PowerPC G5 ou processador Intel de múltiplo núcleo (Mac OS) ou um processador de 1,8 GHz ou mais rápido (Windows). O Photoshop CS5, CS6 e CC requer um processador Intel de múltiplos núcleos (Mac OS) ou um processador de 2 GHz ou mais rápido (Windows).

O Photoshop normalmente é executado mais rapidamente com mais núcleos de processador, embora alguns recursos tirem maior vantagem dos núcleos adicionais do que outros. Existe uma lei de diminuição de retornos com múltiplos processadores: quanto mais processadores você usa, menos você obtém de cada núcleo adicional. Portanto, o Photoshop não executa quatro vezes mais rápido em um computador com 16 núcleos de processador quanto em um computador com quatro núcleos. Para a maioria dos usuários, o aumento do desempenho que mais que seis núcleos fornecem não justifica o aumento de custo.

O Photoshop CS6, CC e CC 2014 também usa mais o processador gráfico (GPU) do que as versões anteriores para aprimorar o desempenho de mais recursos. Este aumento no uso da GPU pode causar problemas de desempenho ao executar o Photoshop CS6 e posterior em um ambiente virtual. As máquinas virtuais não podem acessar a GPU.

Máximo de RAM

O Photoshop usa memória de acesso aleatório (RAM) para processar imagens. Se o Photoshop não possuir memória suficiente, ele utiliza espaço no disco rígido, também conhecido como disco de trabalho, para processar informações. O acesso às informações na memória é mais rápido do que o acesso às informações em um disco rígido. Portanto, o Photoshop é mais rápido quando pode processar todos ou a maioria das informações da imagem na RAM. Se possível, aloque RAM suficiente para o Photoshop poder acomodar seu maior arquivo de imagem.

Que quantidade de RAM o Photoshop pode acessar?

Versão do Photoshop Versão do sistema operacional A quantidade máxima de memória RAM que o Photoshop pode utilizar
CS4, CS5 e posterior, 32 bit Windows 32 bits 1,7 GB
CS4, CS5 e posterior, 32 bit Windows 64 bits 3,2 GB
CS4, CS5 e posterior, 64 bit* Windows 64 bits Tanta memória RAM quanto for possível caber no computador.
CS4, 32 bits Mac OS 3 GB
CS5, 32 bits Mac OS 2,1 GB
CS5 e posterior, 64 bit Mac OS Tanta memória RAM quanto for possível caber no computador.

*O Photoshop de 64 bits não tem suporte oficial no Windows XP de 64 bits, mas deve ser possível executá-lo.

Para obter mais informações sobre o desempenho e o Photoshop 64 bit, consulte Benefícios e limitações do sistema operacional de 64 bit | Photoshop CS4, CS5, CS6, CC, CS6, CC.

Para obter instruções sobre a alocação de memória RAM para o Photoshop, consulte Uso de memória.

Use um disco rígido rápido e grande ao trabalhar com imagens grandes

O Photoshop lê e grava as informações da imagem no disco quando não há memória RAM suficiente para conter toda ela. Consulte o indicador de eficiência descrito abaixo para determinar se obter um disco rígido mais rápido ou disco de estado sólido irá aprimorar seu desempenho. Se o número de eficiência estiver acima de cerca de 95%, gastar mais dinheiro em um disco mais rápido pode ter pequeno benefícios.

Para aprimorar o desempenho do Photoshop, use um disco com uma taxa de transferência rápida de dados. Por exemplo, use um disco rígido interno ou um disco externo conectado por meio de uma interface rápida como a Thunderbolt, FireWire 800, eSATA ou USB3. Os servidores de rede (disco rígido acessado através da rede) têm taxas de transferência mais lenta de dados.

O Photoshop CS4 ao CS6 requer pelo menos 1 GB de espaço livre no disco rígido (Windows) ou 2 GB de espaço livre no disco rígido (Mac OS). O Photoshop CC requer pelo menos 2,5 GB (Windows) ou 3,2 GB (Mac OS). A instalação requer espaço adicional e a Adobe recomenda mais espaço no disco rígido para a memória virtual e espaço de disco de trabalho.

As matrizes Fast RAID 0 são ótimas como discos de trabalho, especialmente se a matriz é usada exclusivamente para o disco de trabalho. Verifique também se a matriz é desfragmentada regularmente e que esta não seja o volume de inicialização. 

Discos de estado sólido

A instalação do Photoshop em um disco de estado sólido (SSD) permite que o Photoshop seja iniciado com extrema rapidez, provavelmente em menos de um segundo. Mas esta inicialização mais rápida é a única experiência de economia de tempo. Esse é o único momento em que muitos dados são lidos do SSD.

Para obter o maior benefício de um SSD, use-o como o disco de trabalho. Usando-o como um disco de trabalho oferece aprimoramentos de desempenho significativos se você tiver imagens não cabem inteiramente na RAM. Por exemplo, alternar ladrilhos entre a RAM e um SSD é muito mais rápido do que alternar entre a RAM e um disco rígido.

Se o SSD não tiver muito espaço livre (o arquivo de trabalho cresce para caber no SSD), adicione um disco rígido secundário ou terciário. (Adicione-o após o SSD.) Certifique-se de que os discos foram selecionados como discos de trabalho no painel Desempenho em Preferências.

Além disso, os SSDs variam bastante em termos de desempenho, muito mais do que os discos rígidos. Usar uma unidade anterior e mais lenta resulta em pouca melhora em relação a um disco rígido.

Observação: adicionar RAM para melhorar o desempenho é mais econômico do que comprar um SSD. Se dinheiro não for problema, você sairá ganhando com RAM instalada no computador, e irá executar o Photoshop CS5 como um aplicativo 64 de bits, mas ainda tem de melhorar o desempenho. Por isso considere a utilização de um disco de estado sólido como o seu disco de trabalho.

Conforme mencionado anteriormente, um SSD não aumenta o desempenho quando o indicador de eficiência já for alto. Quanto menor o indicador de eficiência, maior a melhoria que um SSD oferece.

Definir as preferências de desempenho

As preferências de desempenho que você especifica afetam bastante o desempenho do Photoshop. Para definir preferências de desempenho, escolha Photoshop > Preferências > Desempenho (Mac OS) ou Editar > Preferências > Desempenho (Windows). Em seguida especifique opções em cada uma das seguintes áreas:

Uso de memória

Quanto mais memória RAM disponível para o Photoshop, mais rápido ele pode processar informações sobre a imagem. A área de uso de memória da caixa de diálogo Preferências de desempenho informará quanto de RAM está disponível para o Photoshop. Ela também mostra um intervalo ideal para o sistema.

Observação: a RAM disponível não é a RAM total. O Photoshop subtrai a RAM necessária para o sistema operacional.

Por padrão, o Photoshop usa 70% da RAM disponível. É possível atribuir mais ou menos memória RAM para o Photoshop ao mudar o valor na caixa Deixar o Photoshop usar. Ou, é possível arrastar o seletor de uso de memória. Reinicie o Photoshop para que as alterações tenham efeito.

A alocação de RAM padrão de 70% é perfeita para a maioria das pessoas que executam a versão de 32 bits do Photoshop. Para localizar a alocação de RAM ideal para seu sistema, altere-a em incrementos de 5% e controle o desempenho no indicador de status de Eficiência. Consulte Vigiar o indicador de Eficiência.

Se você executa a versão de 64 bits do Photoshop e recebe erros de sem RAM ou sem memória, aumente a alocação de RAM. Sem outros aplicativos em execução, você pode aumentar a alocação de memória RAM para 100% para aprimorar o desempenho do Photoshop.

Se você executa a versão de 32 bits do Photoshop, pode receber erros de RAM insuficiente se definir a alocação de RAM para 100%. Se ocorrerem erros de insuficiência de memória RAM, reduza a alocação de memória RAM para 85% a 90% e volte a testar. Se os problemas continuarem, reduza a alocação da RAM em incrementos de 5% e teste novamente até a ocorrência de erros cessar, ou, se puder, ou use a versão de 64 bits do Photoshop.

Discos de trabalho

Defina o disco de trabalho para um disco rígido desfragmentado que tenha suficiente espaço não utilizado e velocidades rápidas de leitura/gravação (consulte Desfragmentar o disco rígido). Se você tiver mais de um disco rígido, pode especificar discos de trabalho adicionais. O Photoshop oferece suporte a 64 exabytes de espaço em disco de trabalho em um total de quatro volumes. (Um exabyte é igual a 1 bilhão de gigabytes.)

Se o disco de inicialização for um disco rígido (ao contrário de um disco de estado sólido), tente usar uma unidade diferente para o disco de trabalho principal. Se o disco de inicialização for um SSD, não há benefícios em selecionar um disco diferente como o disco de trabalho principal. Usar o SSD para o disco de inicialização do sistema e como o volume de trabalho principal tem bom desempenho. E, provavelmente é melhor que utilizar um outro disco rígido para o trabalho. Para obter mais informações, consulte Designar discos de trabalho na Ajuda do Photoshop

Preferências de histórico e cache

Níveis de cache

O Photoshop usa cache de imagem para acelerar o redesenho de imagens de alta resolução. Com o cache, o Photoshop utiliza versões em baixa resolução de imagens para atualizar rapidamente a imagem na tela. A opção Níveis de cache permite que você informe ao Photoshop para salvar em entre oito níveis de dados de imagem em cache. Quanto mais níveis de cache você tiver, mais lentamente o Photoshop abre o arquivo, mas é mais responsivo enquanto você trabalha. Quanto menos níveis de cache você tiver, mais rapidamente a imagem é carregada, mas o Photoshop terá execução mais lenta. 

A configuração padrão de Níveis do cache é 4. No entanto, você mudar isso dependendo dos tipos de arquivos com que trabalha e quanto de RAM tiver.

Se você usa arquivos relativamente pequenos — mais ou menos 1 megapixel ou 1280 por 1024 pixels — e muitas camadas (mais de 50), defina o cache como 1 ou 2. Configurar a opção Níveis de cache como 1 desativa o cache de imagens; somente a imagem da tela atual é armazenada em cache.

Observação: alguns recursos no Photoshop não produzem resultados de mais alta qualidade se níveis de cache forem 1.

Se você usar arquivos com dimensão de pixels maiores, digamos 50 megapixels, defina os Níveis de cache superior a 4. Definir um nível de cache mais alto melhora o desempenho ao acelerar os tempos de redesenho.

Otamanho do ladrilho de cache é a quantidade de dados (ladrilhos) que o Photoshop opera ao mesmo tempo. O Photoshop processa cada ladrilho de dados e em seguida redesenha-o. O Photoshop é mais eficiente quando opera em ladrilhos maiores, mas tamanhos de ladrilho maiores levam mais tempo para serem redesenhados. Camadas maiores tornam as operações complexas como filtros de nitidez ir mais rápido. Entretanto, alterações secundárias como traçados de pincel são mais responsivas quando o Photoshop usa camadas menores. 

No Photoshop CS4, você pode alterar o tamanho do ladrilho de cache usando o plug-in opcional Ladrilhos maiores (consulte Plug-in Ladrilhos maiores (Photoshop CS4).

No Photoshop CS5 e CS6, você pode escolher um tamanho de camada no menu suspenso Tamanho de camadas de cache em Preferências de desempenho. Se você tiver um processador Intel Core, escolha 128 K ou 1024 K. Se o processador for o Intel Pentium 4 ou AMD, o Photoshop será mais eficiente usando 132 K ou 1032 K.

No Photoshop CS5 e CS6, a seção Histórico e cache, nas Preferências de desempenho, também tem três predefinições de cache: Alto e fino, Padrão, e Grande e plano. Estas opções definem o nível de cache e o tamanho da camada com base no tipo do documento que você está editando e a quantidade de RAM que estiver instalada no computador.

  • Alto e fino Melhor para editar imagens com dimensões em pixels menores que possuem várias camadas (dezenas a centenas).
  • Grande e plano Melhor para editar imagens com dimensões em pixels maiores (muitas dezenas de centenas de megabytes) e menos camadas.
  • Padrão Para imagens intermediárias.

Estados do histórico

Cada estado do histórico, ou instantâneo, de uma operação que afeta a imagem inteira, aumenta a quantidade do espaço do disco de trabalho de que o arquivo precisa. O Photoshop cria uma cópia do original. Assim, por exemplo, quando você aplica um desfoque gaussiano à uma imagem de 500 KB e cria um instantâneo dessa edição no painel Histórico, o Photoshop requer 1 MB de espaço no disco de trabalho para a imagem. Quando você aplica um ajuste de níveis, um filtro de ruído e uma máscara de nitidez à uma imagem de 5 MB e salva um instantâneo do histórico de cada estado, a imagem precisa de 15 MB de espaço no disco de trabalho.

Cada estado do histórico ou instantâneo no painel Histórico aumenta o espaço no disco de trabalho usado pelo Photoshop.  Quanto mais pixels que uma operação altera, mais espaço de trabalho o estado do histórico correspondente consome. Um estado de histórico que corresponde a um traçado de pintura pequeno ou uma operação não- destrutiva como a criação ou modificação de uma camada de ajuste consome pouco espaço de trabalho. Um estado de histórico correspondente a aplicar um filtro à imagem inteira consome muito mais espaço de trabalho.

Você pode salvar o espaço do disco de trabalho e melhorar o desempenho limitando ou reduzindo o número de estados que o Photoshop pode salvar no painel Histórico. O Photoshop pode salvar até 1.000 estados do histórico; por padrão, ele permite salvar 20. Para reduzir esse número, clique no menu suspenso de Estados do histórico, na área Histórico e cache da caixa de diálogo Preferências de desempenho, e arraste para um valor inferior.

Plug-in de ladrilhos maiores (Photoshop CS4)

O plug-in, que se localiza na pasta Plug-ins opcionais no DVD do aplicativo, está desativado por padrão. Para ativá-lo, copie-o na pasta Extensões, na pasta Plug-ins do Photoshop CS4, e remova o til (~) do nome de arquivo. Somente ative o plug-in se você tiver mais de 1 GB de RAM instalada.

Quando você ativa o plug-in, ele aumenta o tamanho do ladrilho da imagem no Photoshop. O Photoshop redesenha mais dados de uma vez porque cada ladrilho é maior e cada arquivo é desenhado, completo, de cada vez. Leva menos tempo para redesenhar menos ladrilhos que são maiores do que para redesenhar mais ladrilhos que são menores. Camadas maiores às vezes parecem ser redesenhadas mais lentamente. De fato pode levar mais tempo para os resultados serem vistos na tela se você estiver fazendo pequenos ajustes repetidos. Contudo, o tempo total que leva para calcular e desenhar a imagem final é menor. Atualizações de tela enquanto pinta serão menos suaves com Ladrilhos maiores instalado.

Se você passar a maior parte do tempo pintando ou rapidamente ajustando controles em filtros ou painéis e o redesenho do Photoshop for responsivo, não ative Ladrilhos maiores. Mas se passa o tempo observando barras de progresso na tela, ative Ladrilhos maiores para melhorar o desempenho.

Configurações de GPU

O Photoshop CS4 e posterior alavanca a GPU no adaptador de vídeo do computador para acelerar as operações de redesenho na tela. Para o Photoshop acessar o GPU, o adaptador de vídeo deve ter um GPU que ofereça suporte a OpenGL. Ele também requer pelo menos 128 MB de VRAM (vídeo RAM) e um driver que ofereça suporte a OpenGL 2.0 e Shader Model 3.0.

O Photoshop CS6 requer 256 MB de VRAM.O Photoshop 13.1 não pode exibir os recursos em 3D se você tiver menos de 512 MB de VRAM na sua placa de vídeo. O Photoshop CC requer 512 MB de VRAM. 

O melhor modo de otimizar a aceleração do GPU é manter o driver do adaptador de vídeo atualizado. Para obter mais informações sobre a aceleração da GPU e instruções sobre como atualizar os drivers de vídeo, consulte as Perguntas frequentes da GPU no Photoshop CCPerguntas frequentes da GPU no Photoshop CS6 ou Suporte para a GPU e Open GL | Photoshop CS4, CS5. Para obter instruções sobre como especificar as configurações da GPU na caixa de diálogo Preferências de desempenho, consulte Perguntas frequentes da GPU no Photoshop CCPerguntas frequentes da GPU no Photoshop CS6 ou Recursos e preferências da GPU e Open GL | Photoshop e Bridge | CS4, CS5.

OpenCL

OpenCL é uma tecnologia que permite aos aplicativos usar o processador que está no adaptador de vídeo, ou seja, a GPU. Vários recursos usam OpenCL no Photoshop CC, então eles devem ficar mais rápidos. Certifique-se de que o OpenCL está ativado para executar esses recursos na velocidade mais rápida.

Para ativar o OpenCL, escolha Editar > Preferências > Desempenho (Windows) ou Photoshop > Preferências > Desempenho (Mac OS). Clique em Configurações avançadas e selecione Usar OpenCL.

Os recursos que são habilitados para OpenCL são:

  • Panorama de vídeo
  • Galeria de desfoque (Íris, Campo e Desfoque de alterar a inclinação)

Salvar em segundo plano e salvar automaticamente as informações de recuperação

A preferência de salvar em segundo plano está ativada por padrão. Quando estiver ativada, o Photoshop permite continuar a trabalhar enquanto os comandos Salvar e Salvar são executados em vez da necessidade de aguardar até que eles sejam concluídos. Se você deseja exibir o andamento de uma operação de gravação em segundo plano, poderá selecionar Andamento da gravação no menu suspenso Status. As operações da gravação executadas em segundo plano (ou seja, com preferência ativada) demoram mais. Entretanto, não é necessário aguardar em elas sejam concluídas para continuar trabalhando.

Na maioria dos casos, as operações de gravação em segundo plano não afetam significativamente o desempenho ou o tempo de resposta de operações normais do Photoshop. Entretanto, se você estiver editando um arquivo que é muito maior do que a memória RAM disponível, a operação de gravação pode afetar o tempo de resposta ou desempenho até que a gravação seja completada.

A preferência Salvar automaticamente as informações de recuperação é ativada somente se Salvar em segundo plano estiver ativada. Se ativada, as informações de recuperação são salvas para cada arquivo aberto no intervalo especificado. Essas informações de recuperação são salvas em segundo plano em um local oculto. O arquivo original é nunca é modificado. O arquivo original somente é modificado em resposta aos seus comando Salvar ou Salvar como explícitos. Se o Photoshop ou o sistema tiver erro fatal, as informações recuperadas são abertas da próxima vez que você inicia o Photoshop.

Definir um valor menor para o intervalo de recuperação oferece mais proteção contra erros fatais. Na maioria dos casos, salvar as informações de recuperação não afeta o desempenho ou o tempo de resposta do Photoshop. Entretanto, dependendo das operações que estiver fazendo, e do tamanho e do número de arquivos abertos, podem haver algum impacto no desempenho.  Este problema terá maior probabilidade se os arquivos que você está modificando são maiores do que a RAM disponível.

Possíveis problemas:

Se o Photoshop parece diminuir seu desempenho de forma intermitente, Salvar andamento no menu suspenso Status na parte inferior esquerda da janela da imagem. Caso perceba problemas de desempenho enquanto a barra de andamento estiver se movendo, aumente o valor da preferência Salvar automaticamente cada informação de recuperação. Ou, desative a preferência.

As informações de recuperação são salvas no mesmo local que os arquivos de trabalho do Photoshop. Isso aumenta a quantidade de espaço que o Photoshop utiliza nos discos de trabalho especificados nas preferências de discos de trabalho no painel Desempenho em Preferências. Se você manter com frequência muito arquivos grandes abertos enquanto trabalha, o espaço pode ser significativo. Se você tiver o erro de espaço em disco insuficiente ao executar comandos diferentes do comando Salvar, adicione espaço de disco de trabalho. Ou, desative automaticamente a preferência Salvar automaticamente as informações de recuperação.

Dicas para aumentar o desempenho do Photoshop

Trabalhar dentro de limitações de tamanho do arquivo

Quanto maior o arquivo com que você trabalha, mais provável é que encontre problemas de desempenho. 

O Photoshop suporta um tamanho máximo de arquivo de 300.000 x 300.000 pixels, exceto arquivos PDF, que são limitados a 30.000 x 30.000 pixels e 200 x 200 polegadas.

Capacidade de Tamanho do arquivo no Photoshop:

  • Arquivos PSD: 2 GB
  • Arquivos TIFF: 4 GB (O Photoshop CS6 suporta arquivos TIFF mais de 4 GB)

Observação:grande parte dos aplicativos não consegue funcionar com arquivos TIFF maiores que 2 GB.

  • Arquivos PSB: 4 exabytes (4096 petabytes ou 4 milhões de terabytes).
  • Arquivos PDF: 10 GB (páginas são limitadas por um tamanho máximo de 200 polegadas)

Consulte também Tamanho de arquivo na Ajuda do Photoshop CS5.

O Photoshop CS6 suporta profundidade de bits ímpares além da profundidade de bits pares.

Vigiar o indicador Eficiência

Observe o indicador de eficiência ao trabalhar no Photoshop. Ele Informa quanto o Photoshop tiver usado toda a RAM disponível e começa a usar o disco de trabalho, o que torna o desempenho mais lento. Na parte inferior da janela da imagem, clique no menu suspenso e escolha Eficiência. (Você também pode exibir o status de Eficiência no painel Informações. Consulte Trabalhar com o painel Informações na Ajuda do Photoshop CS5.) Se o valor de eficiência for menor que 100%, o Photoshop usa o disco de trabalho. Portanto, ele está funcionando mais lentamente. Se a eficiência for inferior a 90% a 95%, aloque mais RAM para o Photoshop em Preferências de desempenho (consulte Uso de memória) ou adicione RAM ao sistema.

Indicador de status de Eficiência

Fechar janelas desnecessárias do documento

As janelas de documento usam mais RAM no Photoshop CS4 e posterior do que nas versões anteriores. Muitas imagens abertas no Photoshop podem resultar em uma mensagem de erro "sem RAM” ou fazer com que o Photoshop seja executado com lentidão. Se isso ocorrer, feche algumas janelas do documento.

Reduza o número de padrões e predefinições de ponta de pincel carregados.

Para reduzir a quantidade que o Photoshop utiliza de espaço de trabalho, minimize o número de padrões e pontas de pincel que se mantém carregado. Salve as predefinições que não requer agora em um arquivo de predefinição. Ou exclua-os se forem carregados de um arquivo de predefinição.

Para ver o padrão ou as predefinições de pincel carregado, escolha Editar > Gerenciador de predefinições. A seguir, escolha Tipo de predefinição > Padrões ou Tipo de predefinição > Pincéis. Para salvar o padrão ou as predefinições de pincel que você não estiver usando, selecione-os no Gerenciador de predefinições. A seguir, clique em Salvar definição e especifique um nome de arquivo para a mesma. Clique no botão Excluir para excluí-las das predefinições carregadas. Se elas forem necessárias em outro momento, você pode recarregá-las com o Gerenciador de predefinições ou com diversos menus suspenso para padrões e pincéis.

Minimizar ou desativar miniaturas de visualização de painel

Sempre que você alterar o documento, o Photoshop atualiza todas as miniaturas visíveis nos painéis Camadas e Canais. Esta atualização pode afetar o tempo de resposta ao pintar rapidamente, mover ou ajustar as camadas. Quanto mais miniaturas estão visíveis, maior este efeito.

Para minimizar ou desativar visualizações de miniaturas nesses painéis, clique no painel Canais, Camadas ou Caminhos e escolha Opções do painel. Na área Tamanho da miniatura, selecione um tamanho menor ou escolha Nenhum, e em seguida clique em OK.

Definir a opção Maximizar a compatibilidade de arquivos PSD e PSB para Perguntar

O recurso Maximizar a compatibilidade dos arquivos PSD e PSB anexa uma cópia achatada da imagem quando você a salva. Esses dados extras asseguram que os arquivos PSD e PSB possam ser abertos em versões anteriores do Photoshop, no Photoshop Lightroom e em aplicativos que não são da Adobe que ofereçam suporte a arquivos PSD.  Também permite visualizações do QuickLook Finder e a caixa de diálogo Abrir no Mac OS. Para grandes arquivos em camadas contendo apenas algumas camadas o aumento de tamanho pode ser significativo. Salvar informações de compatibilidade também leva mais tempo para documentos grandes.

Para salvar documentos mais rápido em troca de mais espaço em disco:

  1. Para documentos de 16 bits e 32 bits PSD e PSB, ative Desativar compactação de arquivos PSD e PSB no painel Manuseio de arquivos que manipula na caixa de diálogo Preferências.

  2. Para arquivos TIFF, não selecione a compactação ZIP para documentos ou suas camadas na caixa de diálogo Opções de TIFF.

Para obter mais informações, consulte Maximizar a compatibilidade ao salvar arquivos na Ajuda do Photoshop CS5.

Trabalhar no modo de imagem de 8 bits

O Photoshop pode executar várias operações em imagens de 16 bits e 32 bits. Contudo, essas imagens exigem mais memória, espaço de trabalho e tempo de processamento do que as imagens de 8 bits. Para converter a imagem para 8 bits por canal, escolha Imagem > Modo > 8 bits/Canal. Para obter mais informações, consulte Profundidade de bits na Ajuda do Photoshop.

Observação: a conversão em 8 bpc exclui dados da imagem. Salve uma cópia da imagem original de 16 bits ou 32 bits antes converter em 8 bpc.

O Camera Raw pode abrir imagens com 8 bits ou 16 bits por canal. Para alterar essa configuração, abra a caixa de diálogo Camera Raw ao abrir um arquivo bruto. Clique no texto azul sublinhado abaixo da imagem de visualização, selecione 8 bits/Canal  ou 16 bits/Canal no menu suspenso Profundidade.

Desativar a visualização de fontes WYSIWYG

Desativar a Lista de visualização de fontes WYSIWYG acelera o processamento de fontes no Photoshop. No Photoshop CS4 e CS5, escolha Photoshop > Preferências > Tipo (Mac OS) ou Editar > Preferências > Tipo (Windows). Cancele a seleção de Tamanho de visualização de fonte e clique em OK. No Photoshop CS6 e CC, escolha Tipo > Tamanho da fonte de visualização > Nenhum.

Consulte Solução de problemas de fontes | Photoshop CS5 para obter mais ajuda com as fontes.

Reduzir a resolução da imagem

Quanto maior a resolução, mais espaço de memória e espaço em disco o Photoshop precisará para exibir, processar e imprimir uma imagem. Uma resolução de imagem mais alta não necessariamente fornece uma qualidade de imagem superior. Mas pode indicar um desempenho mais lento no Photoshop, o uso de espaço de disco de trabalho adicional e uma impressão mais lenta. A resolução ideal para imagens depende de como as imagens são exibidas e impressas. Geralmente é útil fazer o processamento da imagem na resolução original. A seguir, quando você inicia a otimização da imagem para uma determinada mídia de saída, reduza o tamanho e a resolução de imagens para outro apropriado para a mídia. (Salve uma cópia de suas resolução completa original)

Para imagens apresentadas na tela ou por e-mail, pense em termos de dimensões totais de pixels. Muitas imagens da Web não tem mais de 700 pixels de largura. As exibições estão se tornando maiores a todo tempo, mas as maiores de uso comum hoje são de 2560 x 1600 pixels, ou aproximadamente quatro megapixels.

Para reduzir a resolução de uma imagem no Photoshop, escolha Imagem > Tamanho da imagem. Na caixa de diálogo Tamanho da imagem, assegure que as caixas Restringir proporções e Reamostrar imagem estejam selecionadas. Insira um novo valor para Largura ou Altura de dimensões de pixels. (A inserção de um valor altera ambos porque a opção Restringir proporções fixa seu relacionamento.)

Para imagens impressas, o aumento da resolução além de cerca de 360 DPI traz benefícios marginais se houver na maioria dos casos. Se você produz muitas impressões, vale a pena fazer experimentos para obter uma resolução que lhe dará resultados agradáveis.

Para reduzir a resolução de uma imagem no Photoshop, escolha Imagem > Tamanho da imagem. Na caixa de diálogo Tamanho da imagem, selecione Reamostrar imagem. Altere os valores de Tamanho do documento para refletir o tamanho físico em que planeja imprimir o documento. A seguir, reduza o valor Resolução e clique em OK. Se o valor da resolução for menor do que tinha em mente, em vez de maior (em outras palavras, se estivesse aumentando a resolução do documento em vez de diminuindo o) consulte outra documentação sobre a impressão de imagens sobre como melhor imprimir imagens de baixa resolução.

Se você for aumentar a resolução da imagem para impressão em vez de diminuir, execute esse aumento de resolução como uma das suas últimas etapas antes de imprimir a imagem. Assim, você não precisa processar todas essas informações extras nas etapas anteriores.

Para obter mais informações, consulte Recorte, redimensionamento e reamostragem avançados | Photoshop, assim como Preparando para imprimir do Photoshop e O que há de novo e como imprimir no Photoshop.

Descartar Desfazer, a Área de transferência e estados do Histórico

Desfazer, a Área de transferência e estados do Histórico guardam dados de imagem. Para liberar RAM, escolha Editar > Descartar e, em seguida, Desfazer, Área de transferência, Históricos, ou Todos. 

Observação: o comando Descartar não pode ser desfeito.

O conteúdo da área de transferência são geralmente grandes se você estiver copiando e colando dados em documentos grandes. E, elas são de pouca utilidade quanto tiver terminado de colar. Os estados de Desfazer e de Histórico, no entanto, geralmente contêm dados úteis para corrigir erros anteriores. A limpeza do histórico e desfazer torna mais RAM disponível imediatamente. Entretanto, os estados de histórico não utilizados são movidos automaticamente da RAM para o disco de trabalho enquanto você trabalha. Portanto, limpar o histórico e desfazer somente é útil em condições limitadas.

A Galeria de filtros permite testar um ou mais filtros em uma imagem antes de aplicar os efeitos, o que pode economizar um tempo considerável. Para obter mais informações, consulte Visão geral de Galeria de filtros na Ajuda do Photoshop.

Arrastar entre arquivos

Arrastar e soltar camadas ou arquivos é mais eficiente do que copiá-los e colá-los. Arrastar ignora a área de transferência e transfere os dados diretamente. Copiar e colar podem envolver potencialmente mais transferência de dados e são muito menos eficientes.

Usar camadas com sensatez

As camadas são fundamentais para trabalhar no Photoshop, mas aumentam o tamanho de arquivos e o tempo de redesenho. O Photoshop recompõe cada camada depois de cada modificação na imagem. Depois de concluídas as alterações nas camadas, é possível achatá-las (mesclá-las) para reduzir o tamanho de um arquivo. Selecione as camadas no painel Camadas, clique com o botão direito do mouse (Windows) ou pressione a tecla Control+clique (Mac OS) e escolha Mesclar camadas. (Certifique-se de remover as camadas vazias do arquivo já que elas aumentam o tamanho do arquivo. Selecione as camadas vazias no painel Camadas, clique com o botão direito do mouse [Windows] ou Control-clique [Mac OS] e escolha Excluir camada). Para achatar todas as camadas em um arquivo, escolha Camada > Achatar imagem.

Observação: o Photoshop não permite separar camadas depois de mescladas. Escolha Editar > Desfazer ou use o painel Histórico para retornar a um estado não mesclado.

Se você não altera freqüentemente algumas das camadas, considere converter camadas ou conjuntos de camadas em Objetos inteligentes, o que economiza espaço em disco e melhora o desempenho. Selecione as camadas ou conjuntos de camadas no painel Camadas, clique com o botão direito do mouse (Windows) ou pressione a tecla Control+clique (Mac OS) e escolha Converter em objeto inteligente.

Salvar arquivos TIFF sem camadas

O Photoshop pode salvar camadas em arquivos TIFF. Os arquivos TIFF com camadas são maiores do que arquivos TIFF achatados e requerem mais recursos de processamento e impressão. Se você trabalhar com um arquivo TIFF com camadas, salve o arquivo com camadas original como um arquivo Adobe Photoshop (.psd). Em seguida, quando estiver pronto para salvar o arquivo no formato TIFF, escolha Arquivo > Salvar como. Na caixa de diálogo Salvar como, escolha Formato > TIFF, selecione Salvar como cópia, cancele a seleção de Camadas e clique em Salvar.

Para a velocidade adicional ao exportar arquivos TIFF, escolha compactação ZIP. No entanto, a compactação ZIP produz arquivos TIFF menores.

Não exportar a Área de transferência

A configuração de Exportar a área de transferência faz com que o Photoshop torne o conteúdo da área de transferência disponível para outros programas. Se você copia grandes quantidades de dados no Photoshop, mas não os deseja colar em outros aplicativos, economize tempo ao desativar a opção Exportar área de transferência.

  1. Escolha Photoshop > Preferências > Geral (Mac OS) ou Editar > Preferências > Geral (Windows).
  2. Cancele a seleção Exportar a área de transferência.
  3. Clique em OK.

Otimizar o sistema operacional para o Photoshop

Fechar aplicativos desnecessários e itens de inicialização

Outros aplicativos de código aberto e itens de inicialização diminuem a quantidade de memória disponível para o Photoshop. Encerre aplicativos desnecessários, itens de inicialização e extensões e, a seguir, torne mais memória disponível para o Photoshop. Consulte os seguintes tópicos nos documentos de suporte de solução de problemas no sistema operacional do Adobe:

Em seguida, consulte Uso de memória para obter instruções sobre alocação de RAM ao Photoshop.

Desabilitar a Soneca do aplicativo (Mac)

Executar limpeza de disco (Windows)

Quando você trabalha em um aplicativo, uma cópia do seu arquivo de dados é armazenada temporariamente em seu disco rígido. Muitos aplicativos criam arquivos .tmp e, em seguida, os excluem quando você sai do aplicativo. Falhas ou erros de sistema, contudo, podem impedir um aplicativo de excluir esses arquivos, fazendo com que eles tomem espaço em disco e criem problemas. De vez em quando, execute Limpeza de disco para remover arquivos temporários e qualquer outro arquivo que não esteja sendo usado.

  1. Siga um destes procedimentos:

    • No Windows XP: selecione Iniciar > Programas > Acessórios > Ferramentas do sistema > Limpeza de disco.
    • No Windows Vista/Windows 7/8: escolha Iniciar, digite Limpeza de disco na caixa de texto Pesquisar, e escolha Limpeza de disco na lista de Programas.
  2. Selecione uma unidade para efetuar a limpeza, se for o caso.
  3. Selecione Arquivos temporários e qualquer outro arquivo a ser excluído.
  4. Clique em OK.

Desfragmentar o disco rígido

À medida que adicionar, excluir e mover arquivos em um disco rígido, o espaço disponível já não é mais um bloco único e contíguo. Se o sistema não dispuser de espaço suficiente contíguo, são salvos fragmentos de um arquivo em diferentes locais do disco rígido. Leva mais tempo para o Photoshop ler ou gravar um arquivo fragmentado do que um salvo em um local contíguo.

Para obter instruções sobre desfragmentação de discos rígidos no Windows, consulte estes tópicos da Ajuda da Microsoft:

  • (Windows XP) “Tarefas de manutenção que melhoram o desempenho.” Siga as instruções em “Etapa 4. Desfragmente sua unidade de disco rígido”.
  • (Windows 7 e Vista) "Melhorar o desempenho desfragmentando o disco rígido"
  • (Windows 8) "Otimizar o seu disco rígido"

No Mac OS, use um utilitário de disco como o Disk Defragmenter, Symantec Norton Utilities ou Micromat Drive 10. A fragmentação raramente é um problema no Mac OS, a menos que você executa normalmente com a unidade quase cheia. Para obter mais informações, consulte Desfragmentar o disco rígido e verificar erros.

Observação: as matrizes de RAID não se tornam fragmentadas. A fragmentação provavelmente pode ser um problema se você usa um único disco para tudo. Ela também pode ser um problema se os arquivos permanentes e o disco de trabalho do Photoshop compartilham um volume, especialmente se não houver muito espaço livre. Neste caso, desfragmentar o disco pode fazer uma grande diferença.

É desnecessário desfragmentar os discos de estado sólido, pois o desempenho deles não é reduzido significativamente com níveis normais de fragmentação.

Instalar atualizações atuais do sistema operacional

Atualizações do sistema operacional do Windows e do Mac OS X melhoram o desempenho e a compatibilidade com aplicativos. 

Obtenha pacotes de serviços do Windows e outras atualizações no site da Microsoft. Para obter ajuda com a instalação de pacotes de serviços e outras atualizações, contate o suporte técnico da Microsoft.

Para obter atualizações para o Mac OS X, escolha a Atualização de software no menu Apple. Para obter assistência na instalação das atualizações, contate o suporte técnico da Apple.

Importante:: antes de instalar uma atualização de sistema, verifique os requisitos de sistema para o software da Adobe a fim de garantir a compatibilidade. (Verifique também algum software ou hardware de terceiros que você usa com o software da Adobe.) Se a atualização não estiver listada, entre em contato com a Adobe ou o fabricante do software ou hardware de terceiros.

Especificar uma memória virtual fixa (Windows)

A memória virtual permite que o sistema utilize espaço no disco rígido para armazenar as informações normalmente armazenadas na memória Ele leva mais tempo para acessar informações em um disco rígido do que para acessar informações na memória. Por isso usar uma porção do disco rígido como memória virtual pode reduzir o desempenho. Além de isso, o Photoshop não pode usar o espaço de disco rígido que o sistema usa para a memória virtual dos arquivos de discos de trabalho. (Ele usa o disco de trabalho para armazenar informações de imagem enquanto você trabalha).

Especificar uma configuração fixa de memória virtual ajuda a impedir que arquivos do disco de trabalho do Photoshop concorram pelo mesmo espaço com a memória virtual. Especialmente se você definir a configuração de memória virtual em uma unidade diferente do que o disco de trabalho principal. Para os dois tipos de memória virtual, use uma unidade com espaço livre suficiente e contíguo e para melhorar o desempenho. Além de isso, mantenha o arquivo de paginação em uma unidade diferente, vazia e desfragmentada.

Como sempre, dicas para usar discos separados para a memória virtual e discos de trabalho não se aplicam para os discos de estado sólido. Com um SSD, é vantajoso colocar a maior quantidade todos os arquivos intensamente usados em um SSD. Pô-los no mesmo SSD causa pouca ou nenhuma penalidade.

Para alterar a memória virtual no Windows XP, feche todos os aplicativos e em faça o seguinte:

  1. Selecione Iniciar > Configurações > Painel de controle e dê um clique duplo em Sistema.
  2. Clique na guia Avançado e, em seguida, selecione Configurações na seção Desempenho.
  3. Clique na guia Avançado e, na seção Memória virtual, clique em Alterar.
  4. A partir da lista Unidade, selecione um disco rígido que possua 1,5 vezes a quantidade de RAM instalada no computador. Por exemplo, se o computador tiver 2 MB de RAM, selecione um disco rígido que tenha, pelo menos, 4 GB de espaço livre em disco rígido.
  5. Na seção Tamanho do arquivo de paginação para a unidade selecionada, selecione Tamanho personalizado. Na caixa Tamanho inicial, digite um valor igual ao dobro da quantidade de RAM instalada no computador.
  6. Na caixa Tamanho máximo, insira um valor igual a quatro vezes a quantidade de RAM instalada no computador.
  7. Clique em Configurar e, em seguida, clique em OK.  
  8. Clique para fechar o applet Painel de controle do sistema
  9. Clique em Sim na caixa de diálogo Alterar configurações do sistema para reiniciar o Windows.

Para alterar a memória virtual no Windows 7 e Vista, feche todos os aplicativos e faça o seguinte:

  1. Selecione Iniciar > Painel de controle e dê um clique duplo em Sistema.
  2. Selecione Configurações avançadas do sistema na lista Tarefas.
  3. Selecione a guia Avançado e clique em Configurações na seção Desempenho.
  4. Selecione a guia Avançado e clique em Alterar.
  5. Cancele a seleção de Gerenciar automaticamente o tamanho do arquivo de paginação de todas as unidades.
  6. Clique em cada letra do disco rígido para mostrar o espaço disponível nessa unidade. Selecione um disco rígido que possua três vezes a quantidade de RAM instalada no computador e que não contenha um disco de trabalho.
  7. Selecione Tamanho personalizado e digite a quantidade de RAM física mais 300 MB na caixa Tamanho inicial. Digite três vezes a quantidade de RAM instalada no computador na caixa Tamanho máximo. 
  8. Clique em Configurar e, em seguida, clique em OK. Continue para clicar em OK para sair de todas as caixas de diálogo.
  9. Reinicie o computador: se houver aplicativos abertos, selecione Reiniciar mais tarde, feche os aplicativos e, em seguida, reinicie o Windows. Caso contrário, clique em Reiniciar agora.

Para alterar a Memória Virtual no Windows 8, feche todos os aplicativos e faça o seguinte:

  1. Clique em Iniciar > Painel de Controle. Se não houver botão Iniciar, escolha o ícone de pastas e procure o painel de controle no seu computador.
  2. Escolha Sistema e segurança > Sistema.
  3. Siga as etapas acima para o Windows 7 e Vista, começando com a etapa 3.

Para obter mais informações, consulte estes tópicos da Ajuda da Microsoft:

  • (Windows XP) “Para alterar o tamanho do arquivo de paginação da memória virtual”
  • (Windows Vista, Windows 7 e Windows 8) “Alterar o tamanho da memória virtual”

Consulte também Memória virtual, um excerto de Real World Photoshop CS5 for Photographers (Peachpit Press), de Conrad Chavez.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online