About preflight fixups

You can use the Preflight tool to fix many errors in a document. To do this, you add error corrections, called fixups, to a profile. The fixup automatically corrects the problem, if possible, or provides information so that you can correct the problem in the source file. A profile with a fixup has the gray wrench icon next to it. An outline of a wrench means that no fixups are associated with the profile.

Preflight includes several predefined fixups that you can add to a profile. These cover a broad range of errors that affect color, fonts, images, print production, compliance with international standards like PDF/X and PDF/A, and other areas. Preflight also includes a toolkit for creating your own single fixups.

Note:

A fixup permanently changes the document.

For example, fixups can perform the following actions to correct errors:

  • Convert color spaces, just as the Convert Color feature does.

  • Repair documents and eliminate unneeded content to reduce file size, just as PDF Optimizer does.

  • Convert the PDF to a different version.

  • Widen hairlines.

  • Flatten transparency.

  • Remove objects outside the trim and bleed boxes.

  • Prepare the PDF for PDF/X, PDF/E, or PDF/A conversions.

  • Set document information.

Add fixups to a profile

The Preflight tool includes a collection of fixups that you can add to a profile. These are all available from the Fixups section of each profile.

  1. Open the Preflight dialog box (Tools > Print Production > Preflight), select a profile, and click the Edit link next to the profile name.

  2. Expand the category with the profile you want, and then expand the profile.
    Expanded category
  3. If necessary, unlock the profile so that you can modify it. Choose Unlock from the pop-up menu at the top.

  4. Select Custom Fixups from the items under the profile.

    Fixups are available from the Fixups section of each profile
    Fixups are available from the Fixups section of each profile.

  5. Select a fixup from the column on the right and click the left-facing arrow to move the fixup to the column on the left.

    You can add as many fixups as you want.

    Note:

    To remove a fixup from a profile, select the fixup from the list on the left and click the right-facing arrow.

Edit Fixup dialog box overview

The Edit Fixup dialog box lists the types of predefined fixups you can add to a profile, and the values associated with each fixup. You can use the Edit Fixup dialog box to change the values associated with a fixup, or create a custom fixup based on an existing one. Like checks, fixups are organized by categories.

Edit Fixup dialog box
<span class="uicontrol">Edit Fixup</span> dialog box

A. Fixup name B. Fixup categories C. Search D. Areas in the fixup that can be modified  E. Fixup criteria F. Button to see which profiles use the fixup 

Create or modify fixups

You can create a custom fixup for certain jobs or output devices. The settings you specify determine such things as what output intent is used, what color conversions take place, how images are compressed and sampled, and what PDF compatibility level the PDF must support. Although you can modify any of the predefined fixups, as long as they are unlocked, it is better to duplicate an existing fixup and change its values. This technique is useful if the fixup belongs to multiple locked profiles, and you don’t want to find and unlock all those profiles. A duplicated fixup is unlocked by default because it does not yet belong to a profile. You can also create a single fixup that can be quickly run without it being part of a profile.

Create a fixup for a profile

  1. In the Profiles panel of the Preflight dialog box, click the Select Profiles button .

  2. Select a profile and click the Edit button next to the profile name.

  3. On the left side of the dialog box, under the profile, select Fixups.

  4. If necessary, choose Unlocked from the pop-up menu.

  5. Under Fixups In This Profile, click the New icon .

  6. Name the fixup and specify the criteria.

Create a fixup based on an existing one

  1. Follow steps 1 through 4 for creating a fixup for a profile.
  2. In the Preflight Edit Profile dialog box, select the fixup you want to modify, and click the Duplicate button  on the right.

  3. In the Duplicate Fixup dialog box, modify the information as needed or create a new column.
  4. To see which profiles currently use this fixup, click Usage. You may need to unlock other profiles before you can modify the fixup.

  5. Do any of the following, and click OK:

    • To rename the fixup, type in the Name box at the top.

    • To change how an error is handled, specify options or values for each selected fixup option.

Create a single fixup

  1. In the Profiles panel of the Preflight dialog box, click the Select Single Fixups button .

  2. Choose Options > Create Fixup.

  3. Name the fixup and specify the criteria.

    The new fixup appears in the group appropriate to its category and type.

Duplicate a single fixup

  1. In the Profiles panel of the Preflight dialog box, click the Select Single Fixups button .

  2. Select an existing fixup, and choose Options > Duplicate Fixup.

Set up favorite single fixups

  1. In the Profiles panel of the Preflight dialog box, click the Select Single Fixups button .

  2. Expand the groups as desired.
  3. Select a single fixup, click the flag next to the name, and then choose Favorite.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy