About flattening

If your document or artwork contains transparency, to be output it usually needs to undergo a process called flattening. Flattening divides transparent artwork into vector-based areas and rasterized areas. As artwork becomes more complex (mixing images, vectors, type, spot colors, overprinting, and so on), so does the flattening and its results.

Flattening may be necessary when you print or when you save or export to other formats that don’t support transparency. To retain transparency without flattening when you create PDF files, save your file as Adobe PDF 1.4 (Acrobat 5.0) or later.

You can specify flattening settings and then save and apply them as transparency flattener presets. Transparent objects are flattened according to the settings in the selected flattener preset.

Note:

Transparency flattening cannot be undone after the file is saved.

Overlapping art
Overlapping art is divided when flattened.

Note:

For more information on transparency output issues, see the Print Service Provider Resources page of the Adobe Solutions Network (ASN) (English only), available on the Adobe website.

Flattener Preview dialog box overview

Use the preview options in the Flattener Preview dialog box to highlight the areas and objects that are transparent, as well as those affected by transparency flattening. Transparent content is highlighted in red, and the rest of the artwork appears in grayscale.

Use this information to adjust the flattener options before you apply the settings, and then save them as flattener presets. You can then apply these presets from other dialog boxes. For example, PDF Optimizer (Save As Other > Optimized PDF), Advanced Print Setup dialog box, and the PostScript Settings dialog box (File > Export To).

Flattener Preview dialog box
Flattener Preview dialog box displays a preview of current PDF page using preview and flattener settings.

Open the Flattener Preview dialog box

  • Choose Tools > Print Production > Flattener Preview.

Preview which areas of artwork will be flattened

Use the preview options in the Flattener Preview to highlight areas that are affected by flattening. You can use this color-coded information to adjust flattening options.

Note:

The Flattener Preview is not intended for precise previewing of spot colors, overprints, and blending modes. Instead, use Overprint Preview mode for those purposes.

  1. Display the Flattener Preview panel (or dialog box):
    • In Illustrator, choose Window > Flattener Preview.

    • In Acrobat, choose Tools > Print Production > Flattener Preview.

    • In InDesign, choose Window > Output > Flattener Preview.

  2. From the Highlight menu, choose the kind of areas you want to highlight. The availability of options depends on the content of the artwork.
  3. Select the flattening settings you want to use: Either choose a preset or, if available, set specific options.

    Note:

    (Illustrator) If the flattening settings aren’t visible, select Show Options from the panel menu to display them.

  4. If the artwork contains overprinted objects that interact with transparent objects, in Illustrator, select an option from the Overprints menu. You can preserve, simulate, or discard overprints. In Acrobat, choose Preserve Overprint to blend the color of transparent artwork with the background color to create an overprint effect.
  5. At any time, click Refresh to display a fresh preview version based on your settings. Depending on the complexity of the artwork, you may need to wait a few seconds for the preview image to appear. In InDesign, you can also choose Auto Refresh Highlight.

    Note:

    In Illustrator and Acrobat, to magnify the preview, click in the preview area. To zoom out, Alt-click/Option-click in the preview area. To pan the preview, hold down the spacebar and drag in the preview area.

Transparency Flattener options

You can set Transparency Flattener options when creating, editing, or previewing flattener presets in Illustrator, InDesign, or Acrobat.

Highlight (preview) options

None (Color Preview)

Disables previewing.

Rasterized Complex Regions

Highlights the areas that will be rasterized for performance reasons (as determined by the Rasters/Vectors slider). Keep in mind that the boundary of the highlight area has a higher probability of producing stitching problems (depending on the print-driver settings and the rasterization resolution). To minimize stitching problems, select Clip Complex Regions.

Transparent Objects

Highlights the objects that are sources of transparency, such as objects with partial opacity (including images with alpha channels), objects with blending modes, and objects with opacity masks. In addition, note that styles and effects may contain transparency, and overprinted objects may be treated as sources of transparency if they are involved in transparency or if the overprint needs to be flattened.

All Affected Objects

Highlights all objects that are involved in transparency, including transparent objects and objects that are overlapped by transparent objects. The highlighted objects will be affected by the flattening process—their strokes or patterns will be expanded, portions of them may get rasterized, and so on.

Affected Linked EPS Files (Illustrator only)

Highlights all linked EPS files that are affected by transparency.

Affected Graphics (InDesign only)

Highlights all placed content affected by transparency or transparency effects. This option is useful for service providers who need to see graphics that require attention to print properly.

Expanded Patterns (Illustrator and Acrobat)

Highlights all patterns that will be expanded if involved in transparency.

Outlined Strokes

Highlights all strokes that will be outlined if involved in transparency or because Convert All Strokes To Outlines is selected.

Outlined Text (Illustrator and InDesign)

Highlights all text that will be outlined if involved in transparency or because Convert All Text To Outlines is selected.

Note:

In the final output, outlined strokes and text may appear slightly different from native ones, especially very thin strokes and very small text. However, the Flattener Preview doesn’t highlight this altered appearance.

Raster-Fill Text And Strokes (InDesign only)

Highlights text and strokes that have rasterized fills as a result of flattening.

All Rasterized Regions (Illustrator and InDesign)

Highlights objects and intersections of objects that will be rasterized because there is no other way of representing them in PostScript or because they are more complex than the threshold specified by the Rasters/Vectors slider. For example, the intersection of two transparent gradients will always be rasterized, even if the Rasters/Vectors value is 100. The All Rasterized Regions option also shows raster graphics (such as Photoshop files) involved in transparency, and raster effects such as drop shadows and feathers. Note that this option takes longer to process than the others.

Transparency Flattener Preset options

Name/Preset

Specifies the name of the preset. Depending on the dialog box, you can type a name in the Name text box or accept the default. You can enter the name of an existing preset to edit that preset. However, you can’t edit the default presets.

Raster/Vector balance

Specifies the amount of vector information that will be preserved. Higher settings preserve more vector objects, while lower settings rasterize more vector objects; intermediate settings preserve simple areas in vector form and rasterize complex ones. Select the lowest setting to rasterize all the artwork.

Note:

The amount of rasterization that occurs depends on the complexity of the page and the types of overlapping objects.

Line Art And Text Resolution

Rasterizes all objects, including images, vector artwork, text, and gradients, to the specified resolution. Acrobat and InDesign allow a maximum of 9600 pixels per inch (ppi) for line art, and 1200 ppi for gradient mesh. Illustrator allows a maximum of 9600 ppi for both line art and gradient mesh. The resolution affects the precision of intersections when flattened. Line Art and Text Resolution should generally be set to 600‑1200 to provide high-quality rasterization, especially on serif or small point sized type.

Gradient And Mesh Resolution

Specifies the resolution for gradients and Illustrator mesh objects rasterized as a result of flattening, from 72 to 2400 ppi. The resolution affects the precision of intersections when flattened. Gradient and mesh resolution should generally be set between 150 and 300 ppi, because the quality of the gradients, drop shadows, and feathers do not improve with higher resolutions, but printing time and file size increase.

Convert All Text To Outlines

Converts all type objects (point type, area type, and path type) to outlines and discards all type glyph information on pages containing transparency. This option ensures that the width of text stays consistent during flattening. Note that enabling this option will cause small fonts to appear slightly thicker when viewed in Acrobat or printed on low-resolution desktop printers. It doesn’t affect the quality of the type printed on high-resolution printers or imagesetters.

Convert All Strokes To Outlines

Converts all strokes to simple filled paths on pages containing transparency. This option ensures that the width of strokes stays consistent during flattening. Note that enabling this option causes thin strokes to appear slightly thicker and may degrade flattening performance.

Clip Complex Regions

Ensures that the boundaries between vector artwork and rasterized artwork fall along object paths. This option reduces stitching artifacts that result when part of an object is rasterized while another part of the object remains in vector form. However, selecting this option may result in paths that are too complex for the printer to handle.

 

Note:

Some print drivers process raster and vector art differently, sometimes resulting in color stitching. You may be able to minimize stitching problems by disabling some print-driver specific color-management settings. These settings vary with each printer, so see the documentation that came with your printer for details.

Stitching feature in Acrobat
Stitching, where rasters and vectors meet.

(Illustrator only) Select Preserve Alpha Transparency (Flatten Transparency dialog box only)

Preserves the overall opacity of flattened objects. With this option, blending modes and overprints are lost, but their appearance is retained within the processed artwork, along with the level of alpha transparency (as when you rasterize artwork using a transparent background). Preserve Alpha Transparency can be useful if you are exporting to SWF or SVG, since both of these formats support alpha transparency.

(Illustrator only) Select Preserve Spot Colors And Overprints (Flatten Transparency dialog box only)

Generally preserves spot colors. It also preserves overprinting for objects that aren’t involved in transparency. Select this option when printing separations if the document contains spot colors and overprinted objects. Deselect this option when saving files for use in page-layout applications. With this option selected, overprinted areas that interact with transparency are flattened, while overprinting in other areas is preserved. The results are unpredictable when the file is output from a page-layout application.

Preserve Overprint (Acrobat only)

Blends the color of transparent artwork with the background color to create an overprint effect.

About transparency flattener presets

If you regularly print or export documents that contain transparency, you can automate the flattening process by saving flattening settings in a transparency flattener preset. You can then apply these settings for print output as well as for saving and exporting files to PDF 1.3 (Acrobat 4.0) and EPS and PostScript formats. In addition, in Illustrator you can apply them when saving files to earlier versions of Illustrator or when copying to the clipboard; in Acrobat, you can also apply them when optimizing PDFs.

These settings also control how flattening occurs when you export to formats that don’t support transparency.

You can choose a flattener preset in the Advanced panel of the Print dialog box or of the format-specific dialog box that appears after the initial Export or Save As dialog box. You can create your own flattener presets or choose from the default options provided with the software. The settings of each of these defaults are designed to match the quality and speed of the flattening with an appropriate resolution for rasterized transparent areas, depending on the document’s intended use:

High Resolution

is for final press output and for high-quality proofs, such as separations-based color proofs.

Medium Resolution

is for desktop proofs and print-on-demand documents that will be printed on PostScript color printers.

Low Resolution

is for quick proofs that will be printed on black-and-white desktop printers and for documents that will be published on the web or exported to SVG.

Create a flattener preset

You can save transparency flattener presets in a separate file. Using a separate file makes it easy to back them up or to make them available to service providers, clients, or others in your workgroup. Once you create a custom flattener preset, you can edit it in PDF Optimizer.

Flattener presets are stored in the same location as printer settings files:

(Windows XP)

\Documents and Settings\[current user]\Application Data\Adobe\Acrobat\10.0\Preferences

(Windows Vista®/Windows 7)

\Users\[current user]\AppData\Roaming\Adobe\Acrobat\10.0\Preferences

(Mac OS)

Users/[current user]/Library/Preferences/Adobe/Acrobat/10.0

Note:

Flattener presets created in Acrobat have a different file format from the presets created in other Adobe applications, so you cannot share them between applications.

  1. Choose Tools > Print Production > Flattener Preview.

  2. To base a preset on an existing one, select it from the Preset menu.
  3. Set flattening options.
  4. If necessary, click Reset to return to the default settings.
  5. Click Save.
  6. Type a name and click OK.

Note:

To delete a custom preset, choose it from the Preset menu and press Delete. Low, Medium, and High settings are built-in and can’t be deleted.

Apply a flattener preset

  • Do one of the following:
    • In the Flattener Preview dialog box, choose a preset from the menu, specify a page range, and click Apply.

    • In the PDF Optimizer, select Transparency on the left, and then select a preset from the list.

    • In the Advanced Print Setup dialog box, select the Output panel on the left, and then select a preset from the Transparency Flattener Preset menu.

    • Choose File > Export To > Encapsulated PostScript or PostScript, and then click Settings. In the Output panel, select a preset from the Transparency Flattener Preset menu.

Edit a flattener preset in the PDF Optimizer

You can modify custom presets only.

  1. Choose File > Save As Other > Optimized PDF.
  2. Select Transparency on the left.
  3. Double-click the custom preset you want to edit, modify the settings, and click OK.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy