The default view of a 3D model lets you quickly revert to a starting point at any time as you interact with the model. A default view is different from a preview, which determines what the 3D model looks like when it’s not activated. The list of all available views for the 3D model appears in the Views menu on the 3D toolbar and in the View pane of the Model Tree.

You can also create additional views of the 3D model in Acrobat that let you quickly navigate the 3D content as you want (such as top, bottom, left, right, inside, outside, exploded, or assembled). A view can include lighting, camera position, rendering mode, the Model Tree state, and transparency and cross section settings. Custom views can include precise camera properties.

You can link views to bookmarks in the Bookmarks panel, or you can use the Go To 3D View action to link views to buttons and links that you create on the page.

Default view

When you create a PDF from a 3D model or add a 3D file to an existing PDF, Acrobat creates an initial default view. The default view is generated independently of whether additional default views are created or views exist in the 3D file.

The characteristics of the default view generated are as follows:

  • A perspective projection is used.

  • The viewpoint is placed away from the object such that all visible nodes fill most of the field view.

  • The direction and orientation of the offset is mainly along the negative X-axis, with a relatively small offset along the negative Y-axis, and a smaller positive Z-axis offset.

  • The camera points at the center of the visible nodes, oriented such that the Z-axis is vertical and upwards direction is positive in the displayed annotation.

Set the background color, render mode and lighting for the default view by checking the Show Advanced Options box in the Insert 3D dialog, selecting the 3D tab and adjusting the parameters shown.

Create a custom view

  1. With the Hand tool, click the 3D model to enable it.
  2. Use the Rotate, Pan, and Zoom tools in the 3D toolbar to change the view.
  3. In the View Properties dialog box, select the display settings to include in the view.

    Properties that are not selected use the settings that were last displayed. For example, if Background Color is not selected, the background color of the view remains the same as the background that was previously displayed.

    The view is listed as NewView in the View pane of the Model Tree. Select it to rename it.

Display a view

  • Use these methods to change the view, as appropriate:
    • From the 3D toolbar, select the view from the Views pop-up menu.

    • In the Model Tree, click the view name.

    • Click the Default View icon .

Change the default view

  • In the View pane of the Model Tree, do one of the following:
    • Select a view, and then choose Set As Default View from the Options menu.

    • Right-click a view, and then choose Set As Default View.

Note:

To create a new view, choose Views > Manage Views from the 3D toolbar or the context menu. In the subsequent Manage Views dialog that appears, click the New View button.

Change the poster to match the default view

  1. Using the Select Object tool (Tools > Rich Media > Select Object,) double-click the 3D model.

  2. In the Edit 3D dialog box, click the Launch settings tab.
  3. Under the Poster Image area, select Retrieve poster from default view.
  4. Click OK, and then save the PDF.

This process requires a 3D model with one or more defined views, which you can create. You can associate the view with an existing bookmark or link, or you can create a new one for this purpose.

  1. Do one of the following:
    • To create a new bookmark, click the New Bookmark button  at the top of the Bookmarks panel, and type a new name for the bookmark. Then, right-click it and choose Properties.

    • To create a new link, choose Tools > Edit PDF > Link > Add or Edit Link, and drag to create a link rectangle anywhere on the page. Then, under Link Action, in the Create Link dialog box, select Custom Link, and click Next.

    • To link a view to an existing bookmark or link, right-click the bookmark or link, and choose Properties.

  2. In the Properties dialog box, click the Actions tab.
  3. From the Select Action menu, choose Go To A 3D/Multimedia View, and then click Add.
  4. In the Select A 3D View dialog box, select the 3D annotation for the 3D model from the list on the left, and then select a view option on the right:

    Current View

    Matches the 3D rotation, pan, and zoom characteristics that are active in your document at the time you create the link or bookmark, whether or not this view is listed on the Model Tree as a defined view.

    First View

    Changes to the view that appears at the top of the list in the Model Tree.

    Last View

    Changes to the view definition that appears at the bottom of the list in the Model Tree.

    Previous View

    Moves up the Model Tree list of defined views, one view at a time.

    Next View

    Moves down the Model Tree list of defined views, one view at a time.

    Named View

    Changes to the defined view that you select from the list appearing below this option.

  5. (Optional) To make a bookmark or link also jump to a specific page and page view, choose Go To A Page View on the Selection Action menu, and click Add. Then use the scroll bars and zoom tools to adjust the page view before you click the Set Link button. When finished, click Close in the Properties dialog box.

Delete a 3D view

  • Do one of the following:
    • On the 3D toolbar, open the Views pop-up menu and choose Manage Views. Select the views you want to remove, and click Delete View.

    • In the View pane of the Model Tree panel, select the views you want to remove. From within the View pane, either click the Delete button  or click the Options button and choose Delete View.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy