About preflight profiles

The success of a preflight inspection depends on how well you define the criteria for the inspection. The inspection criteria are packaged in a file called a preflight profile. A preflight profile includes one or more checks, fixups, or both checks and fixups. Each check includes one or more property statements that validate the PDF content. Preflight shows an error only if all the property statements in the check are in error. In the Preflight Edit Profile dialog box, you can specify which values to use and how to handle mismatches. For example, you can choose a profile that simply reports mismatches, or one that automatically fixes a mismatch according to its specified parameters. A profile with a fixup has the filled-in gray wrench icon next to it.

Adobe Acrobat includes several predefined preflight profiles, organized into groups, such as Digital Printing, PDF Analysis, Prepress, and PDF/A, PDF/E, or PDF/X Compliance. You can use the predefined profiles as is or modify them to create custom profiles. The checks that make up the profiles (called rules in previous versions of Acrobat) are organized by categories, such as Document, Pages, Images, and so on. Each check in a category governs a particular document property.

To help you determine what document properties the preflight profile analyzes, you can review information about each selected check in the Preflight Edit Profile dialog box. This information describes what criteria the check uses to analyze, and possibly fix, a document property.

View profiles

  1. Do one of the following:
    • If the Preflight dialog box is not open, choose Tools > Print Production > Preflight.

    • If another panel is displayed in the Preflight dialog box, click the Profiles tab.

  2. Expand the profile groups as desired.

    The list includes all predefined profiles, and any custom profiles you’ve created.

Set up favorite profiles

  1. Do one of the following:
    • If the Preflight dialog box is not open, choose Tools > Print Production > Preflight.

    • If another panel is displayed in the Preflight dialog box, click the Profiles tab.

  2. Expand the groups as desired.
  3. Select a profile, click the flag next to the name, and then choose Favorite.

Preflight Edit Profile dialog box overview

The Preflight Edit Profile dialog box lists all available profiles and shows which document properties are being analyzed. From this dialog box you can unlock and lock a profile, create a new group for organizing profiles, and specify inspection criteria. You can access additional options and information by expanding the profile.

To open the Preflight Edit Profile dialog box, expand a profile group in the Preflight dialog box, select a profile, and click Edit (or choose Edit Preflight Profiles from the Options menu).

Preflight Edit Profile dialog box
Preflight Edit Profile dialog box

A. Profile B. Predefined set of checks C. More options D. Profile groups 

Add and remove profiles

You can create your own custom preflight profiles. Before you create a new profile from scratch, review existing profiles for ones that achieve results similar to those you want. If possible, duplicate an existing profile and modify only the relevant portion.

A preflight profile must contain at least one check or fix and one property that validate the PDF content. When you build a check from scratch, you can use existing properties or create new properties as you go. For best results when creating and modifying profiles, add only as many checks as you need to validate the PDF content, and keep the checks and properties simple and straightforward. For example, you can use a PDF/X profile to check for certain criteria, and then add checks for non-PDF/X criteria, such as image resolution.

Create a profile

  1. In the Profiles panel of the Preflight dialog box, click the Select Profiles button .

  2. Choose Options > Create New Preflight Profile.

  3. Type a name and purpose for the new profile and specify other options as desired.

    By default, newly created profiles appear under the Custom Profiles group, unless you assigned them to a different group.

  4. Expand the profile in the column on the left.
  5. Modify checks (as provided).
  6. Add additional checks and fixups.

Duplicate a profile

  1. In the Profiles panel of the Preflight dialog box, click the Select Profiles button .

  2. Select an existing profile, and choose Options > Duplicate Preflight Profile.

    The duplicate profile is added to the same group as the original profile.

Create a profile group

  1. In the Preflight Edit Profile dialog box, choose New Group from the Group menu.

  2. Type a name for the group and click OK.

    Note:

    If you select a group of profiles, all profiles are moved to the new group.

Remove a profile

  • In the Preflight Edit Profile dialog box, select the profile and click Delete .

Import or export preflight profiles

Preflight profiles can be shared with other users. For example, print service providers can provide them to their customers to ensure that jobs pass an inspection defined by those profiles before the jobs are handed off. Users in a workgroup can create their own profiles as a way to check a document before uploading to the web or printing to a special printer, or to check in-house production.

To exchange a profile, you package it for import and export. The package includes all checks and properties for the selected profile.

Import a preflight profile

  1. Do one of the following:
    • In the Preflight dialog box, choose Import Preflight Profile from the Options menu.

    • In the Preflight Edit Profile dialog box, click the Import icon .

  2. Locate the preflight package file (.kfp extension), and click Open. The profile appears in the Profiles list in the Imported Profiles group.
  3. (Optional) If the profile is locked, choose Unlocked from the pop-up menu in the Preflight Edit Profile dialog box. You can edit a profile after it is unlocked.
  4. (Optional) If prompted, enter the password.

Note:

You can also import a preflight profile by dragging the file to the Acrobat DC window or Acrobat DC application icon.

Export a preflight profile

  1. If needed, rename the profile (in the Edit Profile dialog box) before starting the export process.
  2. To lock the profile before you export it, choose Locked from the pop-up menu in the Preflight Edit Profile dialog box. You can also select Password Protected and enter a password.
  3. Do one of the following:
    • In the Preflight dialog box, choose Export Preflight Profile from the Options menu.

    • In the Preflight Edit Profile dialog box, click the Export icon .

  4. Specify a location for the package, and click Save. Don’t rename the file.

Lock, unlock, and password-protect profiles

You can prevent unauthorized changes to preflight profiles by locking profiles and giving them passwords. This may be useful if preflight profiles are shared among several users. You can lock or password-protect preflight profiles when you first create them or any time you save the preflight profiles. By default, all predefined preflight profiles are locked.

Unlocking a locked preflight profile
Unlocking a locked preflight profile

Lock a profile

  1. In the Preflight Edit Profile dialog box, select a profile.
  2. Choose Locked from the pop-up menu at the upper left of the dialog box.

    The options become unavailable.

Password protect a profile

  1. In the Preflight Edit Profile dialog box, select a profile.
  2. Choose Password Protected from the pop-up menu at the upper left of the dialog box.
  3. Type and reenter the password, and click OK. You can use uppercase and lowercase letters, numerals, or punctuation marks.

    The options become unavailable.

Unlock or unprotect a profile

  1. In the Preflight Edit Profile dialog box, select a profile.
  2. Choose Unlocked from the pop-up menu at the upper left of the dialog box.
  3. If prompted, enter the correct password, and click OK.

Change profile settings

You can change the settings of a single profile.

Change general profile settings

  1. Open the Preflight Edit Profile dialog box.
  2. Expand the profile group and select a profile.
  3. If the profile is locked, choose Unlocked from the pop-up menu.
  4. Change any of the following settings:
    • Enter a new name for the profile, and describe it in the Purpose box.

    • To apply password protection to the profile, selectPassword Protected from the pop-up menu. When prompted, type and reenter the password, and click OK. Otherwise, choose Unlocked.

    • Enter your name and email address.

    • Assign the profile to a group. Select an existing group from the menu, or select New Group, type a name, and click OK. Groups are sorted alphabetically.

  5. When you finish editing a password-protected profile, select Locked from the pop-up menu. You may also want to password-protect it again.
  6. Click OK, or click Save to save your changes without closing the dialog box.

Modify existing check and alert settings

  1. Open the Preflight Edit Profile dialog box.
  2. Expand the profile group and select a profile.
  3. If the profile is locked, choose Unlocked from the pop-up menu.
  4. Expand the profile to view the groups of properties available for the profile.
  5. Select a property group.
  6. Set options to specify the criteria for the inspection. Options vary according to the selected category of properties under the profile. You can select or deselect criteria, edit values, or activate a property.
  7. Select an alert option from the pop-up menu to specify how to handle mismatches during the inspection.
  8. Click OK, or click Save to save your changes without closing the dialog box.

Preflight alert options

For each check in a profile, you specify how to handle mismatches during the inspection. You can select from the menu next to each alert icon. The icon for the alert appears next to the check in the Preflight dialog box.

Error 

Generates an error message for this check (or any checks in this category). Choose this option for mismatches that you must correct before proceeding to the next stage in the workflow.

Warning 

Generates a warning message for this check (or any checks in this category). Choose this option for mismatches that you want to know about and may need to correct before final output.

Info 

Generates a simple note for this check (or any checks in this category). Choose this option for mismatches that you want to know about but do not need to correct before final output.

Inactive 

Never generates an alert message for this check (or any checks in this category). Choose this option for mismatches that will not affect the output quality of the PDF document. You must change the state from Inactive to any other state to make the text boxes available.

View a profile summary

You can view a description of each check and its inspection criteria for a given profile by creating a profile summary.

  • In the Preflight dialog box, select a profile, and choose Create Profile Summary from the Options menu.
    A profile summary is a PDF file
    A profile summary is a PDF file.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy