Note:

Products used:

  • Adobe Captivate (2017 release)
  • MS PowerPoint 2016

You can import and edit Microsoft PowerPoint presentations in Adobe Captivate. Imported slides can be edited in a Microsoft PowerPoint environment from within Adobe Captivate. You can choose to link to the source PowerPoint presentation to keep it in sync with the Adobe Captivate project.

When a PowerPoint presentation is linked to an Adobe Captivate project, Adobe Captivate creates a reference to the source presentation. When the linked presentation is opened in Adobe Captivate for editing, the source presentation is loaded into Adobe Captivate. Because the source presentation is referenced, and not embedded into the project, linking to presentations does not affect the file size of the Adobe Captivate project.

When you import a presentation into Adobe Captivate without linking to it, the entire source presentation is embedded into the project. Editing an embedded presentation does not affect its source file. However, embedding increases the file size of the Adobe Captivate project. You can embed the presentation when the location of the Microsoft PowerPoint presentation is not fixed. Embedding is also useful when the Adobe Captivate project must be opened on a computer that doesn't have access to the Microsoft PowerPoint presentation.

Adobe Captivate supports PowerPoint presentations with the extensions .ppt, .pps, .pptx, and .ppsx. You can import PPT and PPS slides even if you do not have PowerPoint installed on your computer. However, you can’t edit them after import. To import PPTX and PPSX slides, you must have Microsoft PowerPoint installed on your system. Adobe Captivate converts PPTX files to PPT files during import. 

Scenario

PowerPoint version required

Import PPT file

Need not install Microsoft PowerPoint if you are importing slides from a PPT file.

Import PPTX file

(For Windows) Microsoft PowerPoint 2013 or 2016

(For Mac) Microsoft PowerPoint 2013 or 2016

Edit PPT file

(For Windows) Microsoft PowerPoint 2013 or 2016

(For Mac) Microsoft PowerPoint 2013 or 2016

Edit PPTX file

(For Windows) Microsoft PowerPoint 2013 or 2016

(For Mac) Microsoft PowerPoint 2013 or 2016

Open, edit, and save the PowerPoint file in Microsoft PowerPoint before importing it into Adobe Captivate. Performing this procedure ensures that the PowerPoint version installed on your computer is stable.

PowerPoint tips

Follow these guidelines when you work with Adobe Captivate and PowerPoint:

  • Do not close or use PowerPoint launched by Adobe Captivate during import or round-tripping.
  • Launch both Adobe Captivate and PowerPoint in the same mode, that is either both in Administrator mode or both in non-Administrator mode. It is recommended that you launch both in Administrator mode.
  • Avoid doing any copy/paste action (even in other applications such as Notepad, or file copy), when Adobe Captivate is using PowerPoint.
  • Avoid parallel edits. For example, suppose you edit a linked PowerPoint file within Adobe Captivate and the source file in Microsoft PowerPoint simultaneously. In such cases, the results are unpredictable.
  • Avoid editing PPTX and PPSX files with older Microsoft PowerPoint versions. If you want to edit an embedded PPTX of PPSX file outside of Adobe Captivate, export the file from the resource Library and then edit the file. The edited file can then be updated in Adobe Captivate.
  • If you have installed any interactive PowerPoint plug-ins, ensure that you launch Microsoft PowerPoint before you open the presentation in Adobe Captivate for editing.
  • Avoid linking to PowerPoint files over the network on a shared network drive. The results are unpredictable if you lose connectivity while working with the shared file.
  • Ensure that the size of the slides in both Captivate and PowerPoint are properly aligned.
  • If you have imported an audio file in PowerPoint slides, make sure that the audio file you are importing is in the same location as the PPT file.
  • Reduce the Captivate file size by compacting the PowerPoint file.

Import PowerPoint presentations into Adobe Captivate

  1. In an open project, select File > Import > PowerPoint Slides or in the button bar, select Slides > PowerPoint Slide.

  2. Navigate to and select the PowerPoint presentation file format that you want to import.

  3. Click Open.

  4. Decide where to place the imported PowerPoint slides in the Adobe Captivate project. Add the slides to the end of the project, or click a slide in the list and add the PowerPoint slides after that slide.

  5. Click OK.

  6. In the Convert PowerPoint Presentations dialog box, do the following:

    1. Select the PowerPoint slides to convert to Adobe Captivate project slides.

    2. Set navigation preferences for the selected slides.

      Import PowerPoint dialog
      Import PowerPoint dialog

    3. If you want to link to the PowerPoint presentation, select Linked. If you want to embed the PowerPoint presentation, clear Linked.

      Adobe Captivate ensures that all Microsoft PowerPoint animations, all hierarchical animations (One by One, By level at Once etc.) that can be applied on Smart Art objects, all paragraph level animations on text having Text effects (glow, shadow, 3D, reflection, etc.), triggered Animations, audio bookmarks, and many more features are supported when a PPTX is imported.

      If you select the High Fidelity option, you can import the features of the PPTX file.

      Adobe Captivate always honors the timing of the PPTX slide. If you have modified the slide timing further in Microsoft PowerPoint (Rehearse Timings and Advance Slide -> After), select Slide Duration so that these altered settings are included in the import procedure.

  7. Click OK.

    The PowerPoint slides are imported into the Adobe Captivate project and they appear in the designated location. If necessary, you can change the order of the slides.

    Note:

    Transitions applied in a PowerPoint file do not work in Captivate. For example, if you have applied a Morph transition to your PPTX slide, the transition do not work in Captivate after importing the PPTX.

Narration in a PowerPoint presentation slide is imported as a sound object and appears as a separate object on the Timeline. Even in the linked mode, changes made to the audio file in Adobe Captivate after import are not reflected in the respective Microsoft PowerPoint presentation. Similarly, changes made to the audio file in Microsoft PowerPoint are not reflected in the Adobe Captivate project. Object sounds are retained in the SWF file that is created from slides containing such objects.

Slide labels and notes are imported only during the first import. Any subsequent changes to the labels and notes in PowerPoint are not reflected in Adobe Captivate.

Create Adobe Captivate projects from PowerPoint presentations

  1. In an open project, Select File > New > Project From MS PowerPoint.

  2. Navigate to and select the PowerPoint presentation file format that you want to import.

  3. In the Convert PowerPoint Presentations dialog box, do the following:

    1. Enter the name of the project.

    2. Select a size for the new Adobe Captivate project. The size displayed is the actual size of the slide in PowerPoint. Best practice is not to change the size.

    3. Select the PowerPoint slides to convert to Adobe Captivate project slides.

    4. Set navigation preferences for the selected slides.

    5. If you want to link to the PowerPoint presentation, select Linked. If you want to embed the PowerPoint presentation, deselect Linked.

    6. Note:

      If you have inserted notes into your PowerPoint slides, the notes are also imported when you import the PPTX. To see the notes in Captivate, select Window > Slide Notes.

  4. Click OK.

Insert Adobe Captivate projects into PowerPoint presentations

You can insert Adobe Captivate projects into Microsoft PowerPoint presentations in a few simple steps. Publish an Adobe Captivate project as a SWF file. Then open a PowerPoint presentation and insert the published SWF file into a slide.

note: For information on inserting Adobe Captivate projects into Microsoft PowerPoint 2007, see the topic on PowerPoint 2007 on the Microsoft website.

  1. Create and edit the project in Adobe Captivate.

  2. Publish the project as a SWF file.

  3. Note the location of the saved SWF file.

  4. Open the PowerPoint presentation to which you want to add the Adobe Captivate project.

  5. Add the Developer menu in PowerPoint, if not already added.

    To add the Developer menu in PowerPoint, click File > Options. In the PowerPoint Options dialog, select Customize Ribbon in the left pane, and enable the Developer check-box, as shown below:

    PowerPoint options dialog
    PowerPoint options dialog

  6. In the Developer menu, in the Controls toolbox, choose More Controls, as shown below:

    More Controls
    More Controls
  7. From the list of objects, select Shockwave Flash Object.

  8. Drag diagonally to create a box for the project.

    Note:

    You can resize the box in which the project appears. Return to the slide that contains the project in PowerPoint, and drag the resizing handles.

  9. Right-click (Windows) or Control-click (Mac OS) the box and select Property Sheet.

  10. In the Properties dialog, choose the property Movie.

    Enter the location of the SWF file to add. Type the full path, including the filename (for example, C\:My Documents\MyFile.swf) or URL to the SWF file that you want to play.

    Properties dialog
    Properties dialog

  11. Click OK.

  12. In the Properties dialog box (opened in step 9), set the following properties:

    • Set the Playing property to True to play the file automatically when the slide is displayed. If the SWF file has a Start/Rewind control built in to it, you can set the Playing property to False.

    • If you don't want the animation to play repeatedly, set the Loop property to False. (Click the cell to display a down arrow; then click the arrow and select False.)

    • Set Embed Movie to True to ensure that the Adobe Captivate project is always included with the PowerPoint presentation.

    Movie properties
    Movie properties

  13. When you finish setting options, close the Properties dialog box.

  14. Test the project.

Edit imported PowerPoint slides within Adobe Captivate

You can edit an individual slide or the entire set of slides imported from a PowerPoint presentation within Adobe Captivate without launching PowerPoint. If you want to edit only a few slides, edit each slide individually. It is faster than editing the entire presentation.

Note:

Single-slide edit mode is not supported on Mac.

When you send an Adobe Captivate project with linked slides for editing, send the PowerPoint presentation along with the project. Sometimes the recipient has to relink the presentation before editing it.

  1. Import the PowerPoint presentation into your project.

  2. Open the slides and then navigate to a slide imported from PowerPoint.

  3. Right-click (Windows) or Control-click (Mac OS) the slide generated from Microsoft PowerPoint, select Edit with Microsoft PowerPoint and then select one of the following options:

    Edit Slide

    Edit the selected slide

    Edit Presentation

    Edit the entire presentation.

    Find Presentation In Library

    Locate the presentation in the library. When you select this option, the presentation is highlighted in the library.

    Export Animation

    Convert the selected slide to a SWF file. After conversion, Adobe Captivate prompts you to save the SWF file.

  4. When you select Edit Slide or Edit Presentation, the PowerPoint editing environment opens within the Adobe Captivate window (if you are using Adobe Captivate on Windows. You can edit the slides in Microsoft PowerPoint.

    If you are using Adobe Captivate on Mac OS, see Using Adobe Captivate with Microsoft PowerPoint on Mac OS.

  5. After you complete editing, click Save PPT.

  6. The Adobe Captivate editing environment appears.

  7. Save the project.

Update PowerPoint presentation changes made outside Adobe Captivate

Updating is necessary when the PowerPoint file is linked and the changes are made directly in Microsoft PowerPoint.

  1. Open the Adobe Captivate project and then navigate to a slide that was imported from the PowerPoint presentation.

  2. Right-click (Windows) or Control-click (Mac OS) the slide generated from Microsoft PowerPoint, and then select Edit with Microsoft PowerPoint > Find Presentation In Library. When you select this option, the PowerPoint presentation containing the slide is highlighted in the library.

  3. Right-click (Windows) or Control-click (Mac OS) the presentation in the Presentation folder.

  4. Select Update.

    Note:

    If the file in the Adobe Captivate library and the original Microsoft PowerPoint file are not in sync, the color of the dot in the status column in the library changes from green to orange . If you remove or relocate the source Microsoft PowerPoint file, then a question mark appears in the status column. Click to relink.

  1. Open the Adobe Captivate project and then navigate to a slide that was imported from the PowerPoint presentation.

  2. Right-click (Windows) or Control-click (Mac OS) the slide generated from Microsoft PowerPoint, and then select Edit with Microsoft PowerPoint > Find Presentation in the Library. When you select this option, the PowerPoint presentation containing the slide is highlighted in the library.

  3. In the Library panel, right-click (Windows) or Control-click (Mac OS) the presentation in the Presentation folder.

  4. Do one of the following:

    1. Select Change To Linked if you have not linked to (embedded) the presentation during import. Specify a location for the linked file on your computer.

    2. Select Change To Embedded to embed the linked file into your project.

When you send an Adobe Captivate project for editing, the recipient sometimes has to relink the presentation to the project.

  1. Open the Adobe Captivate project and navigate to a slide that was imported from the PowerPoint presentation.

  2. Right-click (Windows) or Control-click (Mac OS) the slide generated from Microsoft PowerPoint, and then select Edit with Microsoft PowerPoint > Find Presentation in the Library.

    When you select this option, the PowerPoint presentation containing the slide is highlighted in the library.

  3. Right-click (Windows) or Control-click (Mac OS) the presentation.

  4. In the Presentation Properties dialog, click Update, select the new path, and then click OK.

    Presentation properties
    Presentation properties

Reduce file size of projects with embedded slides

You can import a presentation into an Adobe Captivate project without linking (embedded mode). The entire presentation is embedded into the Adobe Captivate project. Slides that are not selected during import are also imported into the Adobe Captivate project, but they are not visible in the project. When you choose to reduce the file size, Adobe Captivate deletes such slides permanently from the project. This process is irreversible.

  1. Open the Adobe Captivate project and navigate to a slide that was imported from the PowerPoint presentation.

  2. Right-click (Windows) or Control-click (Mac OS) the slide generated from Microsoft PowerPoint, and then select Edit with Microsoft PowerPoint > Find Presentation in the Library.

    When you select this option, the PowerPoint presentation containing the slide is highlighted in the library.

  3. In the Library panel, right-click (Windows) or Control-click (Mac OS) the presentation in the Presentation folder.

  4. Select Compact.

    note: The Compact option is disabled for linked presentations.

Using Adobe Captivate with Microsoft PowerPoint on Mac OS

The following list describes the changes in behavior when you use Adobe Captivate with Microsoft PowerPoint on Mac OS:

  • When you select to edit a presentation (added as Adobe Captivate project), the presentation opens in Microsoft PowerPoint and not in Adobe Captivate. On Microsoft Windows, you can edit the presentation from within Adobe Captivate.

    When you edit the presentation in Microsoft PowerPoint, you can continue to work in Adobe Captivate.

    Note: Do not edit the presentation when Adobe Captivate updates the project, else the changes are lost. Let Adobe Captivate update the project and then modify the presentation.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy