Problém

Pokud jste v počítači Macintosh nebo v počítači se systémem Windows 7 nebo novějším přihlášeni k určitému uživatelskému účtu, chová se aplikace společnosti Adobe neočekávaným způsobem. Aplikace se například nespustí, nespouštějí se v ní správně příkazy, vrací chyby nebo se nečekaně zavře. Při přihlášení k novému nebo jinému uživatelskému účtu k problémům nedochází.

Na úvod

Systém Mac OS:

Než začnete provádět úlohy uvedené v tomto dokumentu, vytvořte záložní kopii spouštěcího disku.

Při provádění určitých kroků uvedených v tomto dokumentu se v aplikaci Finder zobrazí okno Ověřit totožnost. Když se okno Ověřit totožnost zobrazí, zadejte uživatelské jména a heslo pro účet správce a potom klikněte na tlačítko OK.

Příčin neočekávaného chování při použití určitého účtu může být celá řada. V tomto dokumentu jsou uvedeny pouze nejčastější příčiny. O další pomoc s odstraňováním problémů s uživatelskými účty požádejte podporu společnosti Apple.

Windows

Než začnete provádět úlohy uvedené v tomto dokumentu, zazálohujte si systémovou jednotku.

Při provádění těchto úloh se někdy otevře dialogové okno Řízení uživatelských účtů se žádostí o dovolení pokračovat. Přečtěte si podrobnosti uvedené v dialogovém okně a rozhodněte se, zda chcete pokračovat. Pokud dialogové okno zrušíte, nebudete moci v dané úloze pokračovat.

V některých úlohách uvedených v tomto dokumentu se objevují skryté složky. V Průzkumníkovi Windows se skryté složky ve výchozím nastavení nezobrazují. Informace o zobrazení skrytých složek najdete v článku Zobrazení skrytých souborů, složek a přípon názvů souborů | Windows XP, Vista, Windows 7.

Příčin neočekávaného chování při použití určitého účtu může být celá řada. V tomto dokumentu jsou uvedeny pouze nejčastější příčiny. O další pomoc s odstraňováním problémů s uživatelskými účty požádejte výrobce počítače nebo přejděte na web nápovědy a podpory společnosti Microsoft na adrese http://support.microsoft.com.

Řešení

Přihlaste se k uživatelskému účtu, při jehož použití k neočekávanému chování aplikace společnosti Adobe dochází. Potom proveďte následující úlohy (v uvedeném pořadí):

Systém Mac OS:

1. Udělte oprávnění ke čtení příslušných složek a zápisu do nich

Zkontrolujte, že má daný uživatelský účet oprávnění ke čtení následujících složek a zápisu do nich:

  • /Applications/Adobe
  • /Applications/.AdobePatchFiles (tato složka je skrytá, použijte příkaz Otevřít > Otevřít složku).
  • /Applications/Utilities/Adobe
  • /Library/Application Support/Adobe
  • /Library/Preferences/com.adobe
  • /Users/[uživatel]/Library/Application Support/Adobe
  • /Users/[uživatel]/Library/Caches/Adobe
  • /Users/[uživatel]/Library/Caches/com.adobe
  • /Users/[uživatel]/Library/Preferences/Adobe
  • /Users/[uživatel]/Library/Preferences/com.adobe

Po udělení oprávnění se z uživatelského účtu odhlaste a znovu se k němu přihlaste, případně restartujte počítač, aby se provedené změny projevily.

2. Znovu vytvořte soubory předvoleb aplikace společnosti Adobe specifické pro účet

Aplikace společnosti Adobe ukládají vlastní nastavení uživatelů do souborů předvoleb. Každý uživatelský účet má vlastní sadu souborů předvoleb.

Pokud k neočekávanému chování aplikace společnosti Adobe dochází pouze při použití určitého uživatelského účtu, je možné, že je poškozen některý ze souborů předvoleb dané aplikace. Vytvoření nepoškozených souborů předvoleb aplikace společnosti Adobe můžete vynutit přejmenováním aktuálních souborů předvoleb. Některé aplikace společnosti Adobe ukládají vždy několik souborů předvoleb do složky. U těchto aplikací stačí přejmenovat danou složku.

Některé aplikace společnosti Adobe ukládají předvolby do složek i do samostatných souborů. Například aplikace Adobe Photoshop CS4 používá soubor předvoleb s názvem com.adobe.Photoshop.plist i složku předvoleb s názvem Adobe Photoshop CS4 Settings. Chcete-li docílit toho, aby aplikace Photoshop CS4 vytvořila nepoškozené soubory předvoleb, přejmenujte obě tyto položky. Přejmenujte je například na Old com.adobe.Photoshop.plistOld Adobe Photoshop CS4 Settings.

Aplikace společnosti Adobe ukládají soubory a složky předvoleb obecně do jednoho nebo několika z následujících umístění:

  • /Users/[uživatelské jméno]/Library/Preferences
  • /Users/[uživatelské jméno]/Library/Preferences/Adobe
  • /Users/[uživatelské jméno]/Library/Application Support/Adobe

Důležité informace: Počínaje systémem Apple Mac OS X 10.7 je složka uživatelské knihovny ve výchozím nastavení skryta. Pokud potřebujete přístup k souborům ve skryté složce knihovny z důvodu řešení potíží s aplikací společnosti Adobe, přečtěte si článek Přístup k souborům ve skryté uživatelské knihovně.

Některé aplikace společnosti Adobe ukládají další soubory předvoleb do dalších umístění. Aplikace Adobe Premiere Pro CS4 například ukládá další soubory předvoleb do složek s názvy Layouts, Settings a Styles. Tyto soubory jsou umístěny ve složce /Users/[uživatelské jméno]/Documents/Adobe/Premiere Pro/4.0.

Přesné názvy a umístění souborů a složek předvoleb pro aplikaci společnosti Adobe, se kterou máte potíže, najdete na adrese www.adobe.com/cz/support. Ve znalostní bázi podpory zadejte do vyhledávacího pole heslo „předvolby“ a název a verzi aplikace. Potom se podívejte do dokumentu „Řešení systémových chyb a případů zablokování“ nebo do dalších dokumentů uvedených ve výsledcích hledání.

Při vytváření nových souborů předvoleb aplikace společnosti Adobe postupujte následujícím způsobem:

  1. Ukončete aplikaci společnosti Adobe.
  2. Přejmenujte soubory a složky předvoleb aplikace společnosti Adobe.
  3. Otevřete aplikaci společnosti Adobe. Aplikace vytvoří soubory předvoleb znovu.

Po vytvoření nových souborů a složek předvoleb zkuste problém reprodukovat.

Pokud k problému dochází i nadále, není způsoben poškozeným souborem předvoleb. Chcete-li obnovit vlastní nastavení pro daný uživatelský účet, odstraňte nové soubory a složky předvoleb. Potom obnovte původní názvy všech přejmenovaných položek.

Pokud k problému již nedochází, byl jeho příčinou poškozený soubor předvoleb. Vlastní nastavení přidružené k předchozím souborům předvoleb však budou ztracena.

3. Odstraňte problémy s písmy specifickými pro účet

V systému Mac OS lze písma nainstalovat pro všechny uživatelské účty nebo pouze pro konkrétní uživatelský účet. Soubory písem specifických pro účet jsou umístěny ve složce /Users/[uživatelské jméno]/Library/Fonts.

Pokud se aplikace společnosti Adobe při použití určitého uživatelského účtu chová neočekávaně, může být příčinou poškozený soubor písma nainstalovaný pouze pro daný účet.

Pomocí aplikace Kniha písem, která je součástí systému Mac OS X, všechna písma specifická pro daný účet dočasně vypněte. Po vypnutí písem specifických pro účet vyhledejte soubory mezipaměti písem společnosti Adobe a odstraňte je. Postupujte takto:

  1. Ukončete všechny otevřené aplikace.
  2. Pokud k zapínání a vypínání písem obvykle používáte nástroj pro správu písem od jiného výrobce, tak tento nástroj dočasně vypněte. Pokyny naleznete v dokumentaci k tomuto nástroji.
  3. Otevřete aplikaci Kniha písem. (Aplikace Kniha písem je ve výchozím nastavení umístěna ve složce aplikací.)
  4. Ve sloupci Sbírka vyberte položku Uživatel. Potom proveďte jednu z následujících akcí:

    • Pokud je sloupec Písmo prázdný, nejsou pro daný uživatelský účet nainstalována žádná specifická písma. Zbývající kroky této úlohy přeskočte a pokračujte úlohou 3.
    • Pokud se ve sloupci Písmo zobrazuje alespoň jedno písmo, vyberte možnost Úpravy > Vypnout „Uživatel“.
  5. V aplikaci Finder vyberte možnost Soubor > Hledat. V horní části předního okna aplikace Finder se zobrazí možnosti hledání.

  6. Soubory mezipaměti písem společnosti Adobe vyhledáte nastavením následujících možností hledání:

    • Systém Mac OS X v.10.4.x: V horním řádku možností hledání vyberte možnost Domov. Ve dvou rozevíracích nabídkách v druhém řádku vyberte položky Název a Začíná na. Do textového pole napravo od položky Začíná na potom zadejte text AdobeFnt.
    • Systém Mac OS X v.10.5.x a novější: V horním řádku možností hledání vyberte název uživatelského účtu (zobrazený v uvozovkách). Ve dvou rozevíracích nabídkách v druhém řádku vyberte položky Název a Začíná na. Do textového pole napravo od položky Začíná na potom zadejte text AdobeFnt.
  7. Ve výsledcích hledání odstraňte všechny soubory, jejichž název začíná na AdobeFnt a končí příponou .lst.

  8. Otevřete aplikaci společnosti Adobe a pokuste se problém reprodukovat.

Pokud k problému dochází i nadále, není způsoben písmem specifickým pro účet. Písma specifická pro účet znovu zapněte (otevřením aplikace Kniha písem, výběrem položky Uživatel ve sloupci Sbírka a výběrem možnosti Úpravy > Zapnout). Potom pokračujte úlohou 3.

Pokud k problému již nedochází, je jeho příčinou nějaké písmo specifické pro účet. Chcete-li přesně zjistit, který soubor písma problém způsobuje, postupujte následujícím způsobem:

  1. Otevřete aplikaci Kniha písem.

  2. Ve sloupci Sbírka vyberte položku Uživatel.

  3. Ve sloupci Písmo vyberte jedno z vypnutých písem.

  4. Vyberte možnost Úpravy > Zapnout [Název písma].

  5. Otevřete aplikaci společnosti Adobe a pokuste se problém reprodukovat. Potom proveďte jednu z následujících akcí:

    • Pokud k problému dochází i nadále, ukončete aplikaci společnosti Adobe a opakujte kroky 3 až 5.
    • Pokud k problému již nedochází, bylo jeho příčinou naposledy zapnuté písmo. Nechte dané písmo vypnuté nebo je odstraňte a požádejte jeho vydavatele o náhradní soubor písma.

4. Odstraňte soubory mezipaměti Adobe specifické pro účet

Některé aplikace společnosti Adobe vytvářejí dočasné datové soubory označované jako soubory mezipaměti. Pokud jsou soubory mezipaměti pro uživatelský účet příliš velké nebo poškozené, mohou způsobit neočekávané chování aplikace společnosti Adobe.

Postupujte takto:

  1. Ukončete všechny aplikace společnosti Adobe.

  2. V aplikaci Finder přejděte do složky /Users/[uživatelské jméno]/Library/Caches.

  3. Ve složce Caches odstraňte složku Adobe.

  4. Odstraňte všechny další složky ve složce Caches, které jsou pojmenovány po problematické aplikaci společnosti Adobe.

  5. Odstraňte všechny další složky ve složce Caches, které jsou pojmenovány po součástech problematické aplikace společnosti Adobe. Pokud například odstraňujete problémy s aplikací Photoshop CS4, odstraňte ze složky Caches také složku Adobe Camera Raw.

  6. Otevřete aplikaci společnosti Adobe a pokuste se problém reprodukovat.

Pokud k problému dochází i nadále, pokračujte další úlohou.

5. Odstraňte problémy s položkami otevíranými při přihlášení, které jsou specifické pro účet

Položky Po přihlášení jsou aplikace nebo dokumenty, které se automaticky otevírají při přihlášení k uživatelskému účtu. (Pokud je zapnuto automatické přihlašování, otevírají se automaticky také při spuštění počítače.) Některé položky otevírané při přihlášení jsou po otevření skryté. Pokud k neočekávanému chování aplikace společnosti Adobe dochází při použití určitého účtu, je možné, že je některá z položek otevíraných při přihlášení pro daný účet nefunkční, poškozená nebo nekompatibilní s používanou aplikací společnosti Adobe.

Chcete-li zjistit, zda není problém s aplikací společnosti Adobe způsoben některou z položek otevíraných při přihlášení pro daný uživatelský účet, postupujte následujícím způsobem:

  1. V nabídce Apple vyberte příkaz Odhlásit uživatele [jméno uživatele].

  2. V dialogovém okně pro potvrzení klikněte na tlačítko Odhlásit. Po chvíli se zobrazí přihlašovací okno.

  3. V přihlašovacím okně vyberte název uživatelského účtu, v rámci kterého chcete problém vyřešit.

  4. Do textového pole Heslo zadejte heslo k tomuto uživatelskému účtu,alezatím nestiskávejte klávesu Return ani neklikejte na tlačítko Přihlásit se.

  5. Podržte klávesu SHIFT a klikněte na tlačítko Přihlásit. Po zobrazení Docku klávesu SHIFT uvolněte. Položky po spuštění zůstanou zakázány, dokud se neodhlásíte (nebo nerestartujete počítač).

  6. Otevřete aplikaci společnosti Adobe a pokuste se problém reprodukovat.

Pokud k problému dochází i nadále, není způsoben položkou otevíranou při přihlášení. Můžete se tedy odhlásit (výběrem příkazu Odhlásit uživatele [Uživatelské jméno] v nabídce Apple), a tím položky otevírané při přihlášení znovu aktivovat. Pak se ke stejnému účtu přihlaste znovu, aniž byste drželi klávesu Shift. Potom pokračujte úlohou 5.

Pokud k problému již nedochází, byla jeho příčinou nějaká položka otevíraná při přihlášení. Chcete-li přesně zjistit, která položka otevíraná při přihlášení problém způsobuje, postupujte následujícím způsobem:

Pokud k problému dochází i nadále, není způsoben písmem specifickým pro účet. Písma specifická pro účet znovu zapněte (otevřením aplikace Kniha písem, výběrem položky Uživatel ve sloupci Sbírka a výběrem možnosti Úpravy > Zapnout). Potom pokračujte úlohou 3.

Pokud k problému již nedochází, je jeho příčinou nějaké písmo specifické pro účet. Chcete-li přesně zjistit, který soubor písma problém způsobuje, postupujte následujícím způsobem:

  1. V nabídce Apple vyberte příkaz Odhlásit uživatele [Uživatelské jméno].

  2. Znovu se přihlastekestejnému účtu. Nedržte stisknutou klávesu Shift.

  3. V nabídce Apple vyberte příkaz Předvolby systému.

  4. V okně Předvolby systému klikněte na možnost Účty.

  5. Pokud má ikona v dolní části okna podobu zamknutého zámku, klikněte na ni a poveďte ověření.

  6. Vyberte uživatelský účet, u kterého problém odstraňujete.

  7. Klikněte na kartu Přihlášení.

  8. Vytvořte seznam aktuálních položek otevíraných při přihlášení.

  9. Vyberte nějakou položku otevíranou při přihlášení a stiskněte klávesu Delete.

  10. Otevřete aplikaci společnosti Adobe a pokuste se problém reprodukovat. Potom proveďte jednu z následujících akcí:

    • Pokud k problému dochází i nadále, ukončete aplikaci společnosti Adobe a opakujte kroky 9 a 10.
    • Pokud k problému již nedochází, byla jeho příčinou naposledy odstraněná položka otevíraná při přihlášení. Požádejte vydavatele dané položky otevírané při přihlášení o informace o dostupnosti aktualizované verze. Obnovte ostatní položky otevírané při přihlášení (přetažením jejich ikon do oblasti Přihlášení v okně Předvolby systému). Nebo přeinstalujte aplikaci přidruženou k položce otevírané při přihlášení.

6. Obnovte nastavení přístupu ke složce Library pro daný uživatelský účet

Tuto úlohu proveďte pouze v případě, že odstraňujete problémy s účtem správce opatřeným heslem.

Pro každý soubor a složku ve svazku se systémem Mac OS X je nastaveno oprávnění a vlastnictví používané v systému Unix. Toto nastavení určuje, které uživatelské účty mají k danému souboru nebo složce přístup a které účty přístup nemají.

K neočekávanému chování aplikace Adobe při použití určitého účtu může dojít v případě, že je nastavení přístupu ke složce Library (nebo její podsložce) pro příslušný účet poškozené nebo nesprávně omezené. Toto nastavení můžete opravit pomocí příkazů chmodchown systému Unix. Postupujte takto:

  1. V aplikaci Finder vyberete možnost Otevřít > Domov. V předním okně aplikace Finder se otevře domovská složka pro daný uživatelský účet. Poznamenejte si název v záhlaví daného okna aplikace Finder. Jedná se o „krátkéuživatelské jméno“pro daný účet. (Toto krátkéuživatelské jménoje potřebné k provedení kroku 3.)

  2. Otevřete aplikaci Terminál, která se ve výchozím nastavení nachází zde: /Aplikace/Utility.

  3. V okně aplikace Terminál zadejte příkaz založený na některé z níže uvedených šablon příkazů a potom stiskněte klávesu Return. (Po stisknutí klávesy Return se zobrazí výzva k zadání hesla. Zadejte heslo k uživatelskému účtu a znovu stiskněte klávesu Return. Při zadávání jednotlivých znaků hesla nevidíte žádnou odezvu, například hvězdičky. Takové chování je normální.)

    Důležité informace: Všechny níže uvedené příkazy jsou pouze šablony, nikoli skutečně zadávané příkazy. Při zadávání skutečného příkazu nahraďte proměnnou uživatelské_jméno krátkým uživatelským jménem zjištěným v kroku 1. Při zadávání krátkého uživatelského jména používejte pouze malá písmena. (V systému Mac OS X v10.4.x zadejte krátké uživatelské jméno dvakrát a jednotlivé výskyty oddělte dvojtečkou. V systému Mac OS X v.10.5.x zadejte krátké uživatelské jméno, za ním dvojtečku a potom slovo staff.)

    Šablona příkazu pro systém Mac OS X v.10.4.x:


    sudo chown-R uživatelské_jméno:uživatelské_jméno~/Library

    Šablona příkazu pro systém Mac OS X v.10.5.x:

    sudo chown-R uživatelské_jméno:staff~/Library

  4. Zadejte následující příkaz (přesně tak, jak jej vidíte) a potom stiskněte klávesu Return.

    sudo chmod -R 700 ~/Library

  5. Ukončete aplikaci Terminál.

  6. Otevřete aplikaci společnosti Adobe a pokuste se problém reprodukovat.

Pokud k problému dochází i nadále, pokračujte další úlohou.

7. Opravte spouštěcí disk

Příčinou neočekávaného chování aplikace společnosti Adobe při použití určitého uživatelského účtu může být poškození disku, které ovlivňuje pouze příslušný účet.

Pokud jste s počítačem dostali instalační disk systému Mac OS X, postupujte podle následujících kroků. Jestliže daný disk nemáte, opravte spouštěcí disk pomocí příkazu fsck v aplikaci Terminál. Nebo můžete použít nástroj pro opravu disku od jiného výrobce. Pokyny týkající se použití příkazu fsck najdete v článku TS1417 na webu podpory společnosti Apple. Pokyny týkající se použití nástroje pro opravu disku od jiného výrobce najdete v dokumentaci k příslušnému nástroji.

  1. Do optické jednotky počítače vložte instalační disk systému Mac OS X.
  2. V nabídce Apple vyberte příkaz Restartovat.
  3. Až uslyšíte spouštěcí zvuk, stiskněte klávesu C na klávesnici a držte ji.
  4. Po zobrazení spouštěcího okna s indikátorem průběhu klávesu C uvolněte.
  5. Pokud vás instalační program systému Mac OS X vyzve k výběru jazyka, vyberte požadovaný jazyk.
  6. Po zobrazení nabídky instalačního programu (v levé horní části obrazovky) vyberte možnost Instalátor > Disková utilita.
  7. Na levé straně okna Disková utilita vyberte spouštěcí disk.
  8. Klikněte na možnost Záchrananapravé straně.

  9. Klikněte na možnost Opravit disk.

  10. Pokud se po dokončení procesu opravy zobrazí, že byly chyby disku opraveny, opakujte krok 9. Jestliže při procesu opravy nejsou nalezeny žádné chyby, otevřete aplikaci společnosti Adobe a pokuste se problém reprodukovat.

Pokud k problému dochází i nadále, pokračujte další úlohou.

8. Použijte nový uživatelský účet

Pokud se aplikace při použití určitého účtu stále chová neočekávaně, doporučuje společnost Adobe zkopírovat (nebo přesunout) všechny osobní soubory do nového uživatelského účtu a tento nový účet používat místo původního účtu.

O pomoc s kopírováním osobních souborů do nového účtu požádejte pracovníky podpory společnosti Apple.

Windows

1. Udělte oprávnění ke čtení příslušných složek a zápisu do nich

Zkontrolujte, že má daný uživatelský účet oprávnění ke čtení následujících složek a zápisu do nich:

  • C:\Program Files\Adobe
  • C:\Program Files\Common Files\Adobe
  • C:\Program Files (x86)\Adobe
  • C:\Program Files (x86)\Common Files\Adobe
  • C:\ProgramData\Adobe
  • C:\Users\\AppData\Roaming\Adobe
  • C:\Users\\AppData\Roaming\com.adobe.
  • C:\Users\\AppData\Local\Adobe
  • C:\Users\\AppData\LocalLow\Adobe
  • C:\Users\\AppData\Local\VirtualStore\Program Files\Common Files\Adobe

2. Znovu vytvořte soubory předvoleb aplikace společnosti Adobe specifické pro účet

Aplikace společnosti Adobe ukládají vlastní nastavení uživatelů do souborů předvoleb. Každý uživatelský účet má vlastní sadu souborů předvoleb.

Pokud k neočekávanému chování aplikace společnosti Adobe dochází pouze při použití určitého uživatelského účtu, může to být způsobeno poškozením některého ze souborů předvoleb dané aplikace. Vytvoření nepoškozených souborů předvoleb aplikace společnosti Adobe můžete vynutit přejmenováním složky, která dané soubory předvoleb obsahuje.

Aplikace Adobe Premiere Pro CS4 například ukládá soubory předvoleb do složky s názvem 4.0, která je umístěna ve složce C:\Users\[uživatelské jméno]\AppData\Roaming\Adobe\Premiere Pro. Chcete-li dosáhnout toho, aby aplikace Adobe Premiere Pro CS4 vytvořila soubory předvoleb znovu, přejmenujte složku 4.0 (například na Old_4.0).

Aplikace společnosti Adobe ukládají soubory a složky předvoleb obecně do jednoho nebo obou z následujících umístění:

  • C:\Users\[uživatelské jméno]\AppData\Roaming\Adobe
  • C:\Users\[uživatelské jméno]\AppData\Local\Adobe

Některé aplikace společnosti Adobe ukládají další soubory předvoleb do dalších umístění. Aplikace Adobe Premiere Pro CS4 například ukládá další soubory předvoleb do složek s názvy Styles a Layouts, které jsou umístěné ve složce C:\Users\[uživatelské jméno]\Documents\Adobe\Premiere Pro\4.0.

Přesné názvy a umístění složek předvoleb pro aplikaci společnosti Adobe, se kterou máte potíže, najdete na adrese www.adobe.com/support. Ve znalostní bázi podpory zadejte do vyhledávacího pole heslo „předvolby“ a název a verzi aplikace. Potom sepodívejtedo dokumentu „Řešení systémových chyb a případů zablokování“ nebo do dalších dokumentů uvedených ve výsledcích hledání.

Při vytváření nových souborů předvoleb aplikace společnosti Adobe postupujte následujícím způsobem:

  1. Zavřete aplikaci společnosti Adobe.

  2. Přejmenujte složky předvoleb aplikace společnosti Adobe.

  3. Spusťte aplikaci společnosti Adobe. Aplikace vytvoří nepoškozené soubory předvoleb.

Po vytvoření nových souborů předvoleb zkuste problém reprodukovat.

Pokud k problému dochází i nadále, není způsoben poškozeným souborem předvoleb. Chcete-li obnovit vlastní nastavení aplikace společnosti Adobe pro daný uživatelský účet, tak nové složky předvoleb odstraňte. Potom obnovte původní názvy přejmenovaných složek.

Pokud k problému již nedochází, byl jeho příčinou poškozený soubor předvoleb. (Pro daný uživatelský účet není k předchozímu souboru předvoleb přidruženo vlastní nastavení.)

3. Odstraňte dočasné soubory specifické pro účet

Některé aplikace společnosti Adobe ukládají data do dočasných souborů. V případě, že jsou dočasné soubory specifické pro účet již velké, zastaralé nebo poškozené, může se aplikace společnosti Adobe chovat neočekávaným způsobem.

Chcete-li dočasné soubory odstranit, použijte nástroj Vyčištění disku. Viz článek Odstranění dočasných souborů pomocí nástroje Vyčištění disku (Windows 7 a Vista).

Nástroj Vyčištění disku ve výchozím nastavení neodstraňuje soubory umístěné ve složce Temp specifické pro účet, které byly během posledních sedmi dnů použity. Všechny dočasné soubory můžete odebrat ručním odstraněním obsahu složky Temp.

Odmítnutí záruk: Při ručním odstranění obsahu složky Temp mohou být nepříznivě ovlivněny aplikace, které nevydala společnost Adobe. Pokud se rozhodnete provést následující úlohu, postupujte opatrně. Společnost Adobe neposkytuje podporu při řešení problémů způsobených ručním odstraněním souborů ve složce Temp.

Chcete-li ručně odstranit obsah složky Temp pro daný účet, postupujte následujícím způsobem:

  1. Zavřete všechny aplikace.

  2. Vyberte možnost Start > Všechny programy > Příslušenství. Klikněte pravým tlačítkem na příkazový řádek a zvolte příkaz Spustit jako správce.

  3. V okně příkazového řádku zadejte následující příkaz (přesně tak, jak je uveden níže) a potom stiskněte klávesu Enter:

    del %temp%\*.* /s /q

    Poznámka: Příkazdel slouží k odstranění souborů. Argument %temp%\*.* je tvořen kombinací proměnné prostředí pro umístění složky Temp pro daný účet a zástupných znaků označujících všechny soubory. Parametr /s určuje, že budou do příkazu zahrnuty všechny soubory ve všech podsložkách. Parametr /q zabraňuje zobrazování žádosti o potvrzení odstranění každého souboru v systému Windows.

  4. V okně příkazového řádku se zobrazí seznam odstraněných souborů. (V seznamu mohou být uvedeny soubory, které nebylo možné odstranit. Pravděpodobně se zobrazí také zpráva „Přístup byl odepřen.“ nebo „Proces nemá přístup k souboru, neboť jej právě využívá jiný proces.“ Takové chování je normální.)

  5. Zavřete okno příkazového řádku.

Po odstranění dočasných souborů otevřete aplikaci společnosti Adobe a pokuste se problém reprodukovat.

Pokud k problému dochází i nadále, pokračujte další úlohou.

4. Odstraňte problémy s položkami otevíranými při spuštění, které jsou specifické pro účet

Položky otevírané při spuštění jsou aplikace nebo dokumenty, které se automaticky otevírají při přihlášení k uživatelskému účtu. Pokud k neočekávanému chování aplikace společnosti Adobe dochází při použití jednoho účtu, je možné, že je některá z položek otevíraných při spuštění pro daný účet nefunkční, poškozená nebo nekompatibilní s používanou aplikací.

Chcete-li zjistit, zda není problém s aplikací společnosti Adobe způsoben některou z položek otevíraných při spuštění pro daný uživatelský účet, postupujte následujícím způsobem:

  1. V Průzkumníkovi Windows přejděte do umístění C:\Users\[uživatelské jméno]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup.

  2. Proveďte jednu z následujících akcí:

    • Pokud je složka Po spuštění prázdná nebo zcela chybí, neexistují pro tento účet žádné specifické položky otevírané při spuštění. Zbývající kroky uvedené v této části přeskočte a pokračujte úlohou 4.
    • Jestliže se ve složce Po spuštění nachází alespoň jedna položka, vytvořte na ploše novou složku s názvem Pomocná složka.
  3. Všechny položky ze složky Po spuštění přesuňte do složky Pomocná složka, kterou jste vytvořili.

  4. V nabídce Start klikněte na příkaz Odhlásit se.

  5. Přihlaste se ke stejnému účtu.

  6. Otevřete aplikaci společnosti Adobe a pokuste se problém reprodukovat.

Pokud k problému dochází i nadále, není způsoben položkou otevíranou při spuštění, která je specifická pro účet. Všechny položky umístěné ve složce Pomocná složka můžete přesunout zpět do složky C:\Users\[uživatelské jméno]\AppData\Roaming\Microsoft\Windows\Nabídka Start\Programy\Po spuštění. Pokračujte úlohou 4.

Pokud k problému již nedochází, byla jeho příčinou nějaká položka otevíraná při spuštění, která je specifická pro účet. Chcete-li přesně zjistit, která položka otevíraná při spuštění problém způsobuje, postupujte následujícím způsobem:

  1. Zavřete aplikaci společnosti Adobe.

  2. Přesuňte jednu položku ze složky Pomocná složka zpět do složky C:\Users\[uživatelské jméno]\AppData\Roaming\Microsoft\Windows\Nabídka Start\Programy\Po spuštění.

  3. V nabídce Start klikněte na příkaz Odhlásit se.

  4. Přihlaste se ke stejnému účtu.

  5. Otevřete aplikaci společnosti Adobe a pokuste se problém reprodukovat. Potom proveďte jednu z následujících akcí:

    • Pokud k problému dochází i nadále, opakujte kroky 1 až 5.
    • Pokud k problému již nedochází, byla jeho příčinou naposledy aktivovaná položka otevíraná při spuštění. Odeberte ji ze složky Po spuštění a požádejte vydavatele dané položky otevírané při spuštění o informace o dostupnosti aktualizované verze. Přesuňte všechny zbývající položky ze složky Pomocná složka zpět do složky C:\Users\[uživatelské jméno]\AppData\Roaming\Microsoft\Windows\Nabídka Start\Programy\Po spuštění.

5. Obnovte nastavení přístupu ke složkám aplikačních dat specifickým pro účet

Tuto úlohu proveďte pouze v případě, že odstraňujete problémy s účtem správce, který nenívsíťové doméně.

K chybám specifickým pro účet může docházet v případě, že účet nemá ke složkám se soubory předvoleb aplikací společnosti Adobe a k datovým souborům specifickým pro účet úplný přístup pro čtení/zápis. Můžete použít příkazicaclsk obnovení nastavení přístupu. Postupujte následujícím způsobem:

  1. Zavřete všechny aplikace.

  2. Vyberte možnost Start > Všechny programy > Příslušenství. Klikněte pravým tlačítkem na příkazový řádek a zvolte příkaz Spustit jako správce. Otevře se okno příkazového řádku.

  3. V okně příkazového řádku zadejte následující příkazy (přesně tak, jak jsou uvedeny níže). Po zadání každého příkazu stiskněte klávesu Enter. 

    Důležité informace: Před a za každým přepínačem (/T, /C a /grant) v každém příkazu musí být zadána mezera.

    icacls „%userprofile%\AppData\Local“ /T /C /grant „%username%“:F

    icacls „%userprofile%\AppData\Roaming“ /T /C /grant „%username%“:F

    icacls „%userprofile%\AppData\Local“ /T /C /grant system:F

    icacls „%userprofile%\AppData\Roaming“ /T /C /grant system:F

  4. Zavřete okno příkazového řádku.

  5. Otevřete aplikaci společnosti Adobe a pokuste se problém reprodukovat.

Pokud k problému dochází i nadále, pokračujte další úlohou.

6. V registru systému Windows znovu vytvořte klíč Adobe specifický pro účet

Odmítnutí záruk: Tato úloha vyžaduje úpravu registru systému Windows. Registr obsahuje informace související se systémem, které jsou pro váš počítač a aplikace zcela zásadní. Před úpravou registru vytvořte jeho záložní kopii. Společnost Adobe neposkytuje podporu při řešení problémů způsobených nesprávnou úpravou registru. Další informace o registru systému Windows a Editoru registru najdete na webu nápovědy a podpory společnosti Microsoft na adrese http://support.microsoft.com.

  1. Zavřete všechny aplikace.

  2. Klikněte na tlačítko Start. Zadejte příkaz regedit do pole Zahájit hledání a potom stiskněte klávesu Enter. Otevře se Editor registru.

  3. V levém podokně Editoru registru najděte a vyberte následující klíč:

    HKEY_CURRENT_USER\Software\Adobe.

  4. Zvolte možnost Soubor > Export.

  5. V dialogovém okně Exportovat soubor registru vyberte možnost Vybraná větev v části Rozsah exportu. Zadejte název a umístění záložního klíče registru a potom klikněte na tlačítko Uložit.

  6. Pravým tlačítkem myši klikněte na klíč Adobe a vyberte příkaz Odstranit.

  7. V dialogovém okně Potvrdit odstranění klíče klikněte na tlačítko OK.

  8. Zavřete Editor registru.

  9. Otevřete aplikaci společnosti Adobe a pokuste se problém reprodukovat.

Pokud k problému dochází i nadále, není způsoben poškozenou položkou registru. Provedením následujících kroků můžete obnovit záložní kopii klíče Adobe:

  1. Zavřete všechny aplikace.

  2. Klikněte na tlačítko Start. Zadejte příkaz regedit do pole Zahájit hledání a potom stiskněte klávesu Enter. Otevře se Editor registru.

  3. V Editoru registru vyberte možnost Soubor> Importovat.

  4. V dialogovém okně Importovat soubor registru přejděte do umístění, kam jste v předchozích krocích uložili záložní klíč. Vyberte soubor a klikněte na tlačítko Otevřít.

7. Opravte systémový pevný disk

Příčinou nesprávné funkce aplikace společnosti Adobe při použití určitého uživatelského účtu může být poškození disku, které ovlivňuje pouze příslušný účet.

Informace o opravě systémového pevného disku najdete v článku Oprava a defragmentace pevných disků (Windows 7 a Vista).

Až danou jednotku opravíte, otevřete aplikaci společnosti Adobe a pokuste se problém reprodukovat. Pokud k problému dochází i nadále, pokračujte další úlohou.

8. Použijte nový uživatelský účet

Pokud se aplikace při použití určitého účtu stále chová neočekávaně, zkopírujte (nebo přesuňte) všechny osobní soubory do účtu, při jehož použití k neočekávanému chování nedochází. Tento nový účet používejte místo původního účtu.

O pomoc s kopírováním osobních souborů do nového uživatelského účtu požádejte výrobce počítače. Nebo přejděte na web nápovědy a podpory společnosti Microsoft na adrese http://support.microsoft.com.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online