How you construct an Adobe Illustrator file can directly affect onscreen appearance and printing. Illustrator can take longer to display and print complex files (or not print them at all). Factors like printer RAM and resolution also affect Illustrator files. But the best way to make sure that Illustrator displays and prints your file quickly is to create an efficient Illustrator file.

Create efficient Adobe Illustrator files

To create efficient Adobe Illustrator files, do one or more of the following:

  • Save imported raster image files at a resolution optimized for the intended print resolution. Make sure that the files' resolution in pixels per inch (ppi) or samples per inch (spi) is twice the line screen (lpi) of the printer. (That is, lpi x 2 = ppi or spi.)
  • Use optimal resolution settings for rasterized objects and effects by doing one or more of the following:
    • To specify transparency settings, choose File > Print, then choose Advanced from the menu on the left. Specify a Line Art And Text Resolution Option setting from a Transparency Preset or from a custom transparency setting that reflects the printer's resolution.
    • To specify a resolution for a raster effect, choose Effect > Document Raster Effects Settings, and then specify 72 ppi for resolution. Before printing a document, specify a resolution that reflects the printer's resolution.
  • When printing separations, specify the appropriate screen ruling to produce 256 levels of gray. To specify the screen ruling in Illustrator, choose File > Print, and then choose Output from the menu on the left.
  • Limit the number of text transformations, type along a path, and typeface changes.
  • Delete or move objects hidden behind other elements to a nonprinting layer.
  • Copy and paste Illustrator elements between documents instead of placing them as EPS files.
  • Use gradient fills instead of blends when printing to a PostScript Level 2 device.

    Note: If you print to a PostScript Level 1 or to a PostScript-compatible device, choose File > Print > Graphics and select Compatible Gradient Printing. Examples of PostScript-compatible devices include the Apple Personal LaserWriter NT and Hewlett-Packard Series II or III printer using a PostScript Level 1 cartridge. PostScript-compatible devices (also called clones) include older QMS printers, for example.

  • Use the minimum number of steps when creating a blend.
  • Ungroup elements and nested groups.
  • Simplify paths by using the minimum number of points required to draw the path.
  • Split long complex paths into shorter line segments using the scissors tool. Before you split paths, consider saving a copy of the file; doing so allows you to use the original, unsplit file if needed.
  • Use the Object > Path > Simplify command to remove unnecessary anchor points from complex objects.
  • Transform (that is, rotate, scale, and skew) or crop raster image files in an image-editing application (such as Adobe Photoshop) before importing them.
  • Use clipping paths (masks) and compound paths sparingly.
  • Use duplicated elements instead of pattern fills, or expand objects with pattern fills before printing. (Before expanding objects, consider saving a copy of the file; doing so allows you to use the original, unexpanded objects if needed.)
  • Eliminate any unused patterns, spot colors, gradients, brushes, symbols, or styles.
  • Limit the number of complex elements in the document. For information, see the section "Complex Elements," below.
  • Use the Cleanup command to delete stray points, unpainted objects, and empty text paths from the document.
  • Whenever possible, link raster image files instead of embedding them.
  • Use Symbols for repeating elements to ensure that illustrator saves and uses only one definition, which improves drawing performance.
  • Rasterize Bristle Brushes (CS5) paths to reduce the complexity and number of the Bristle Brush paths. Select the Bristle Brush paths and choose Object > Rasterize.

Decrease print time when printing Adobe Illustrator files

To decrease the time it takes to print an Illustrator document, do one or more of the following:

  • If you plan to place an EPS image in an Illustrator document, save the image in binary format instead of ASCII (hexadecimal) format.
  • Increase the flatness value, by doing one of the following:
    • Set a lower output resolution for the Illustrator document. (Using a lower output resolution creates less accurate curves, but improves print performance.) Choose File > Print, and then choose Graphics. Then drag the Flatness Quality/Speed slider to the right.
    • Set a higher flatness value at the printer.
  • Use fonts that are available at the printer (that is, resident in the printer's hard disk or ROM). If you are using fonts that reside on the printer, select None for font downloading in the Graphics pane of the Print dialog box.
  • Specify the smallest paper size needed. Choose File > Print and specify a page size. Larger page sizes increase the amount of memory required by the printer to image the page.
  • Print through Ethernet connections.
  • Print to a PostScript Level 2 or 3 printer.
  • Print to a device with more RAM.
  • Print at a lower resolution.
  • Make sure you're using the most current printer driver for your printer. Contact your printer manufacturer for information about which printer driver to use, or for driver updates.
  • If you are printing to a PostScript printer, make sure you're using the correct PostScript Printer Description (PPD) file, or use a generic PPD file. Contact your printer manufacturer for information about which PPD file to use.
  • If you are printing to a non-PostScript printer, and your printer driver includes a color optimization option (for example, Vivid Color, Intelligent Color), disable that option. For more information, see the documentation for the printer driver.
  • Set the Quality/Speed slider all the way to the left to flatten all transparent artwork as Raster instead of vector. Choose File > Print, and then choose Advanced from the menu. Select Custom located to the right of the Preset menu and move the Raster/Vector slider all the way to the left.

Complex elements in an Illustrator document

The greater the number or combination of elements listed below, the more memory-intensive the Illustrator document. Effects and elements that have the potential to be memory intensive or complex include:

  • Compound paths (for example, text converted to paths)
  • Pattern fills
  • Gradient fills
  • Transparency and raster effects
  • 3D effects (Illustrator CS and later)
  • Symbols
  • Masks
  • Paths with many points or curves
  • Transformations
  • Text on a path
  • Stroked text
  • Text with horizontal scaling, tracking, or kerning applied
  • Large page sizes
  • Downloadable fonts
  • High-resolution printing
  • Linked or embedded raster images
  • Mesh objects
  • Live Trace Objects (Illustrator CS2 and later)
  • Bristle Brushes (Illustrator CS5 and later)

Additional Information


This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy