Aggiornamenti di sicurezza disponibili per Adobe Flash Player

Data di pubblicazione: 20 febbraio 2014

Identificatore di vulnerabilità: APSB14-07

Priorità: consultare la tabella riportata di seguito

Codice CVE: CVE-2014-0498, CVE-2014-0499, CVE-2014-0502

Piattaforme: tutte

Adobe ha rilasciato aggiornamenti di sicurezza per Adobe Flash Player 12.0.0.44 e versioni precedenti per Windows e Macintosh, e Adobe Flash Player 11.2.202.336 e versioni precedenti per Linux. Questi aggiornamenti risolvono vulnerabilità che possono consentire a eventuali aggressori di assumere il controllo del sistema interessato. Adobe è a conoscenza di segnalazioni relative a tentativi di sfruttare la vulnerabilità di CVE-2014-0502 e consiglia agli utenti di aggiornare le proprie installazioni dei prodotti alle versioni più recenti:

  • Gli utenti di Adobe Flash Player 12.0.0.44 e versioni precedenti per Windows e Macintosh devono eseguire l'aggiornamento ad Adobe Flash Player 12.0.0.70.
  • Gli utenti di Adobe Flash Player 11.2.202.336 e versioni precedenti per Linux devono eseguire l'aggiornamento ad Adobe Flash Player 11.2.202.341.
  • Se Adobe Flash Player 12.0.0.44 è stato installato con Google Chrome, verrà aggiornato automaticamente alla versione più recente di Google Chrome, che includerà Adobe Flash Player 12.0.0.70 per Windows, Macintosh e Linux.
  • Se Adobe Flash Player 12.0.0.44 è stato installato con Internet Explorer 10 verrà aggiornato automaticamente alla versione più recente di Internet Explorer 10, che includerà Adobe Flash Player 12.0.0.70 per Windows 8.0.
  • Se Adobe Flash Player 12.0.0.44 è stato installato con Internet Explorer 11 verrà aggiornato automaticamente alla versione più recente di Internet Explorer 11, che includerà Adobe Flash Player 12.0.0.70 per Windows 8.1.
  • Gli utenti di Adobe AIR 4.0.0.1390 e versioni precedenti per Android devono eseguire l'aggiornamento ad Adobe AIR 4.0.0.1628.
  • Gli utenti di Adobe AIR 4.0.0.1390 SDK e versioni precedenti devono eseguire l'aggiornamento ad Adobe AIR 4.0.0.1628 SDK.
  • Gli utenti di Adobe AIR 4.0.0.1390 SDK & Compiler e versioni precedenti devono eseguire l'aggiornamento ad Adobe AIR 4.0.0.1628 SDK & Compiler.

 

Versioni del software interessate

  • Adobe Flash Player 12.0.0.44 e versioni precedenti per Windows e Macintosh
  • Adobe Flash Player 11.2.202.336 e versioni precedenti per Linux
  • Adobe AIR 4.0.0.1390 e versioni precedenti per Android
  • Adobe AIR 3.9.0.1390 SDK e versioni precedenti
  • Adobe AIR 3.9.0.1390 SDK & Compiler e versioni precedenti

Per verificare il numero di versione di Adobe Flash Player installato sul proprio sistema, accedere alla pagina Informazioni su Flash Player, oppure fare clic con il pulsante destro del mouse sul contenuto eseguito in Flash Player e selezionare "Informazioni su Adobe (o Macromedia) Flash Player" dal menu. Se si utilizzano più browser, eseguire la verifica per ogni browser installato sul sistema in uso.

Per verificare la versione di Adobe Flash Player per Android, selezionare Settings > Applications > Manage Applications > Adobe Flash Player x.x (Impostazioni > Applicazioni > Gestione applicazioni > Adobe Flash Player x.x).

Per verificare il numero di versione di Adobe AIR installato sul proprio sistema, seguire le istruzioni indicate nella Nota tecnica di Adobe AIR.

Soluzione

Adobe consiglia agli utenti di aggiornare le installazioni dei prodotti in uso attenendosi alle istruzioni fornite di seguito.

  • Adobe consiglia a tutti gli utenti di Adobe Flash Player 12.0.0.44 e versioni precedenti per Windows e Macintosh di eseguire l'aggiornamento alla versione più recente 12.0.0.70 scaricandola dal Centro di download di Adobe Flash Player oppure utilizzando, quando richiesto, il meccanismo di aggiornamento automatico integrato nel prodotto.
  • Adobe consiglia a tutti gli utenti di Adobe Flash Player 11.2.202.336 e versioni precedenti per Linux di eseguire l'aggiornamento ad Adobe Flash Player 11.2.202.341 scaricandolo dal Centro di download di Adobe Flash Player.
  • Per gli utenti di Flash Player 11.7.700.261 e versioni precedenti per Windows e Macintosh che non possono eseguire l'aggiornamento a Flash Player 12.0.0.44, è stato reso disponibile l'aggiornamento Flash Player 11.7.700.269, scaricabile qui.
  • Se Adobe Flash Player 12.0.0.44 è stato installato con Google Chrome, verrà aggiornato automaticamente alla versione più recente di Google Chrome, che includerà Adobe Flash Player 12.0.0.70 per Windows, Macintosh e Linux.
  • Se Adobe Flash Player 12.0.0.44 è stato installato con Internet Explorer 10 verrà aggiornato automaticamente alla versione più recente di Internet Explorer 10, che includerà Adobe Flash Player 12.0.0.70 per Windows 8.0.
  • Se Adobe Flash Player 12.0.0.44 è stato installato con Internet Explorer 11 verrà aggiornato automaticamente alla versione più recente di Internet Explorer 11, che includerà Adobe Flash Player 12.0.0.70 per Windows 8.1.
  • Gli utenti di Adobe AIR 4.0.0.1390 SDK devono eseguire l'aggiornamento ad Adobe AIR 4.0.0.1628 SDK.
  • Gli utenti di Adobe AIR 4.0.0.1390 SDK & Compiler e versioni precedenti devono eseguire l'aggiornamento ad Adobe AIR 4.0.0.1680 SDK & Compiler.
  • Gli utenti di Adobe AIR 4.0.0.1390 e versioni precedenti per Android devono eseguire l'aggiornamento ad Adobe AIR 4.0.0.1628 accedendo a Google Play da un dispositivo Android.

Classificazione dei livelli di priorità e gravità

Adobe classifica questi aggiornamenti in base ai seguenti livelli di priorità e consiglia agli utenti di aggiornare le proprie installazioni alle versioni più recenti:

Prodotto Versione aggiornata Piattaforma Livello di priorità
Adobe Flash Player 12.0.0.70
Windows e Macintosh
1
  12.0.0.70 Internet Explorer 10 per Windows 8.0 1
  12.0.0.70 Internet Explorer 11 per Windows 8.1 1
  12.0.0.70 Chrome per Windows, Macintosh e Linux 1
  11.7.700.269 Windows e Macintosh 1
  11.2.202.341 Linux 3
Adobe AIR 4.0.0.1628 Android 3
Adobe AIR SDK e Compiler 4.0.0.1628 Windows e Macintosh
3
Adobe AIR SDK 4.0.0.1628 Windows e Macintosh 3

Questi aggiornamenti risolvono vulnerabilità critiche all'interno del software.

Dettagli

Adobe ha rilasciato aggiornamenti di sicurezza per Adobe Flash Player 12.0.0.44 e versioni precedenti per Windows e Macintosh, e Adobe Flash Player 11.2.202.336 e versioni precedenti per Linux. Questi aggiornamenti risolvono vulnerabilità che possono consentire a eventuali aggressori di assumere il controllo del sistema interessato. Adobe è a conoscenza di segnalazioni relative a tentativi di sfruttare la vulnerabilità di CVE-2014-0502 e consiglia agli utenti di aggiornare le proprie installazioni dei prodotti alle versioni più recenti:

  • Gli utenti di Adobe Flash Player 12.0.0.44 e versioni precedenti per Windows e Macintosh devono eseguire l'aggiornamento ad Adobe Flash Player 12.0.0.70.
  • Gli utenti di Adobe Flash Player 11.2.202.336 e versioni precedenti per Linux devono eseguire l'aggiornamento ad Adobe Flash Player 11.2.202.341.
  • Se Adobe Flash Player 12.0.0.44 è stato installato con Google Chrome, verrà aggiornato automaticamente alla versione più recente di Google Chrome, che includerà Adobe Flash Player 12.0.0.70 per Windows, Macintosh e Linux.
  • Se Adobe Flash Player 12.0.0.44 è stato installato con Internet Explorer 10 verrà aggiornato automaticamente alla versione più recente di Internet Explorer 10, che includerà Adobe Flash Player 12.0.0.70 per Windows 8.0.
  • Se Adobe Flash Player 12.0.0.44 è stato installato con Internet Explorer 11 verrà aggiornato automaticamente alla versione più recente di Internet Explorer 11, che includerà Adobe Flash Player 12.0.0.70 per Windows 8.1.
  • Gli utenti di Adobe AIR 4.0.0.1390 e versioni precedenti per Android devono eseguire l'aggiornamento ad Adobe AIR 4.0.0.1628.
  • Gli utenti di Adobe AIR 4.0.0.1390 SDK e versioni precedenti devono eseguire l'aggiornamento ad Adobe AIR 4.0.0.1628 SDK.
  • Gli utenti di Adobe AIR 4.0.0.1390 SDK & Compiler e versioni precedenti devono eseguire l'aggiornamento ad Adobe AIR 4.0.0.1628 SDK & Compiler.

Questi aggiornamenti risolvono una vulnerabilità di sovraccarico dello stack che potrebbe provocare l'esecuzione di codice arbitrario (CVE-2014-0498).

Questi aggiornamenti risolvono una vulnerabilità di perdita di memoria che potrebbe essere utilizzata per evitare la randomizzazione del layout degli indirizzi di memoria (CVE-2014-0499).

Questi aggiornamenti risolvono una doppia vulnerabilità disponibile che potrebbe determinare l'esecuzione di codice arbitrario (CVE-2014-0502).

Software interessati     Aggiornamento consigliato Disponibilità
Flash Player 12.0.0.44 e versioni precedenti per Windows e Macintosh   12.0.0.70 Centro di download di Flash Player
Flash Player 12.0.0.44 e versioni precedenti (distribuzione in rete)   12.0.0.70 Licenze Flash Player
Flash Player 11.2.202.336 e versioni precedenti per Linux   11.2.202.336 Centro di download di Flash Player
Flash Player 12.0.0.44 e versioni precedenti per Chrome (Windows, Macintosh e Linux)   12.0.0.70
Google Chrome Releases
Flash Player 12.0.0.44 e versioni precedenti in Internet Explorer 10 per Windows 8.0   12.0.0.70
Avviso di sicurezza di Microsoft
Flash Player 12.0.0.44 e versioni precedenti in Internet Explorer 11 per Windows 8.1   12.0.0.70
Avviso di sicurezza di Microsoft
AIR 4.0.0.1390 e versioni precedenti per Android   4.0.0.1628 Google Play
AIR 4.0.0.1390 SDK & Compiler   4.0.0.1628 Download di AIR SDK
AIR 4.0.0.1390 SDK   4.0.0.1628 Download di AIR SDK

Ringraziamenti

Adobe desidera ringraziare i singoli e le organizzazioni seguenti per la collaborazione e per aver segnalato i problemi specifici, contribuendo così a proteggere la sicurezza dei nostri clienti: