ColdFusion Builder は Eclipse ベースの開発環境であり、これを利用すると Adobe ColdFusion アプリケーションを開発して ColdFusion サーバーで実行できます。ColdFusion Builder では、コーディングツールやデバッグツールを利用して ColdFusion アプリケーションを開発できます。

ワークベンチについて

ColdFusion Builder ワークベンチは、Adobe ColdFusion アプリケーションの開発に必要な機能をすべて備えた環境です。ColdFusion Builder IDE の基本機能の多くは、Eclipse から受け継いでいます。ColdFusion Builder プラグインをインストールすると、ColdFusion アプリケーションの作成に必要な機能を追加できます。また、これらのプラグインには、IDE のユーザーインターフェイスを変更するためのツールもあり、アプリケーションのビルドをサポートする主要機能が提供されます。

ワークベンチ ワークベンチは ColdFusion Builder の開発環境です。

ワークベンチには、パースペクティブ、エディター、ビューという 3 つの主要エレメントがあります。アプリケーション開発プロセスの各種段階で 3 つのエレメントを様々に組み合わせて使用します。ワークベンチには、アプリケーションの開発に必要なツールがすべて用意されています。

パースペクティブ パースペクティブは、ワークベンチにあるビュー、エディター、メニューおよびツールバーのグループです。これは、基本的には特定の種類の作業に役立つ特別な作業環境です。例えば、ColdFusion Builder には 2 つのパースペクティブがあります。アプリケーションの開発には ColdFusion Builder 開発パースペクティブを使用し、アプリケーションのデバッグには ColdFusion デバッグパースペクティブを使用します。

パースペクティブの詳細については、「ColdFusion Builder パースペクティブについて」を参照してください。

エディター エディターでは様々なファイルを編集できます。使用できるエディターは、インストールされている Eclipse プラグインの数と種類によって異なります。ColdFusion Builder には、CFML、HTML、JavaScript、および CSS(Cascading Style Sheets:カスケーディングスタイルシート)のコードを記述するためのエディターが含まれています。ColdFusion Builder でのコード編集の詳細については、「ColdFusion Builder のエディター」と「ColdFusion Builder でのコード編集」を参照してください。

ビュー ビューは一般にエディターをサポートします。例えば、CFML を編集するときには、ColdFusion Builder 開発パースペクティブにアウトラインビューとスニペットビューも表示されます。これらのビューは、ColdFusion アプリケーションの開発をサポートするため、CFML ファイルが編集用に開かれると表示されます。

ビューの中にはワークベンチ自体の主要な機能をサポートするものがあります。例えば、ファイルエクスプローラービューでは、ワークベンチ内のファイルおよびフォルダーを管理できます。RDS データビューおよび RDS ファイルビューには、リモートサーバーとローカルサーバーのデータソース、ファイル、およびディレクトリが表示されます。

ビューという用語は、Adobe Dreamweaver® やその他の Adobe 開発ツールで使用されるパネルという用語と同義です。

ColdFusion Builder 開発パースペクティブのビューについて詳しくは、「ColdFusion Builder 開発パースペクティブ」を参照してください。

ColdFusion デバッグパースペクティブのビューについて詳しくは、「ColdFusion デバッグパースペクティブ」を参照してください。

ワークスペース ワークベンチと混同しないでください。ワークスペースとは、ファイルシステム内の特定の領域です。ワークスペースには、アプリケーションプロジェクトの構成要素となるリソース(ファイルとフォルダー)が格納されます。1 つのワークスペースに複数のプロジェクトを格納することもできます。一度に使用できるワークスペースは 1 つだけですが、ColdFusion Builder を起動するたびに異なるワークスペースを選択できます。詳細については、「プロジェクトの管理」を参照してください。

リソース リソースという一般用語は、ワークスペース内のプロジェクトに含まれるファイルとフォルダーを意味します。詳細については、「ColdFusion ページ、インターフェイス、およびコンポーネントの追加」と「その他のファイルの追加」を参照してください。

プロジェクト アプリケーションを構成するリソースはすべてプロジェクト内にあります。最初にプロジェクトを作成しないと、ColdFusion Builder でアプリケーションを構築できません。詳細については、「プロジェクトの管理」を参照してください。

ワークベンチのメニューとツールバー

ワークベンチのコマンドにアクセスするには、メニューバー、右クリックのコンテキストメニュー、ツールバー、およびキーボードショートカットを使用します。

ワークベンチのメニュー

ColdFusion Builder ワークベンチには次のメインメニューがあります。

ファイルメニュー

ファイルメニューでは、ワークベンチリソースの作成、保存、エディターの終了、印刷、インポート、エクスポート、およびワークベンチの終了を行います。

メニューコマンド

説明

新規

リソースを作成します。ColdFusion コンポーネント、インターフェイス、またはページを作成する前に、それらのリソースを保存するためのプロジェクトを作成しておく必要があります。

ファイルを開く

編集するファイルを開きます。ワークスペースに含まれないファイルを開くこともできます。

閉じる

アクティブなエディターを閉じます。ファイルを閉じる前に、変更を保存するかどうかを確認するメッセージが表示されます。

すべて閉じる

開いているエディターをすべて閉じます。ファイルを閉じる前に、変更を保存するかどうかを確認するメッセージが表示されます。

保存

アクティブなエディターの内容を保存します。

別名保存

アクティブなエディターの内容を別のファイル名で他の場所に保存できます。

すべて保管

開いているすべてのエディターの内容を保存します。

前回保存した状態に戻す

アクティブなエディターの内容を、前回保存した内容に戻します。

移動

現在選択されているリソースを別のプロジェクトに移動します。

名前変更

選択されているリソースの名前を変更します。

更新

リソースにファイルシステムの現在の内容を反映します。

行区切り文字の変換

開発プラットフォームまたはデプロイ先プラットフォームのオペレーティングシステムに合わせて行区切り文字を変換します。

  • Windows(デフォルト)
  • UNIX
  • MacOS 9

印刷

アクティブなエディターの内容を印刷します。

ワークスペースの切り替え

別のワークスペースに切り替えるためのワークスペースランチャーを開きます。ワークベンチは、別のワークスペースに切り替えるたびに再起動されます。

再開

ColdFusion Builder を再起動します。

インポート

インポートウィザードを使用して、ワークベンチにリソースをインポートします。

エクスポート

エクスポートウィザードを使用して、ワークベンチからリソースをエクスポートします。

プロパティ

選択されているリソースのプロパティダイアログボックスを表示します。プロパティダイアログボックスには、リソースのパスと最終変更日が表示されます。また、プロジェクトのリソースが親のエンコードや行区切り文字を継承しているか、特定の値に設定されているかに関する情報も表示されます。

最近使ったファイルのリスト

最近ワークベンチでアクセスしたファイルのリストです。これらのファイルを開くには、ファイルメニューでファイル名をクリックします。このリストに表示するファイルの数は、環境設定ダイアログボックスで設定できます。

終了

開いているリソースを閉じて、ワークベンチを終了します。

ナビゲートメニュー

ナビゲートメニューでは、ワークベンチ内のリソースを探して、該当する場所に移動できます。

メニューコマンド

説明

次へジャンプ

選択したリソースがルートに来るように、リソースの階層内を移動します。つまり、プロジェクト内のフォルダーを選択してから「次へジャンプ」を選択すると、選択したフォルダー(およびフォルダー内のアーティファクト)のみがナビゲータービューに表示されます。このコマンドは、複雑な階層構造を持つ大規模なプロジェクト内を移動するときに便利です。

ジャンプ

特定のリソースにジャンプするか、前に表示されていた階層に戻ります。例えば、特定のリソースを選択して「次へジャンプ」コマンドを選択した後に、ジャンプ/戻るを選択するとします。「戻る」コマンドを実行すると、「次へジャンプ」コマンドの実行前と同一の階層が表示されます。

宣言を開く

選択したコード要素の宣言を開きます。

クイックアウトライン

アウトラインビューの簡易版を表示します。ページのコード構造が階層状になってポップアップメニューに表示されます。

リソースを開く

リソースを開くダイアログボックスを使用して、ワークスペース内のリソースを選択し、エディターで開きます。

表示

別のビューで現在選択されているリソースを探して選択できます。エディターがアクティブになっている場合は、これらのコマンドを使用して、別のビューで現在編集されているリソースを選択できます。

次へ

アクティブなビューのリストまたはテーブル内で次の項目に移動します。

前へ

アクティブなビューのリストまたはテーブル内で前の項目に移動します。

最後の編集位置

アクティブなエディター内で最後に編集した位置に移動します。

指定行へジャンプ

アクティブなエディター内の特定の行に移動します。

戻る

以前に開いたファイルにエディターのフォーカスを移動します。

進む

以前のファイルからエディターのフォーカスを戻します。

プロジェクトメニュー

プロジェクトメニューでは、ワークベンチのプロジェクトを管理します。

メニューコマンド

説明

プロジェクトを開く

現在選択されているプロジェクトを開きます。このコマンドは、現在選択されているプロジェクトが閉じられている場合にのみ使用できます。

プロジェクトを閉じる

現在開いているプロジェクトを閉じます。

プロパティ

プロジェクトのプロパティダイアログボックスを表示します。

ウィンドウメニュー

ウィンドウメニューでは、ワークベンチの各種ビュー、パースペクティブ、およびアクションの表示、非表示、管理を行います。

メニューコマンド

説明

新規ウィンドウ

現在開いているパースペクティブと同じパースペクティブで、新しいワークベンチウィンドウを開きます。

新規エディター

現在アクティブなエディターと同じタイプのエディターを開きます。

パースペクティブを開く

ワークベンチ内に新しいパースペクティブを開きます。

ビューの表示

ワークベンチに表示するビューを選択できます。

パースペクティブのカスタマイズ

現在選択されているパースペクティブをカスタマイズできます。

パースペクティブの別名保管

現在選択されているパースペクティブを保存し、カスタマイズした独自のパースペクティブを作成します。

パースペクティブのリセット

カスタマイズしたパースペクティブを元の状態に戻します。

パースペクティブを閉じる

現在開いているパースペクティブを閉じます。

すべてのパースペクティブを閉じる

ワークベンチで開いているパースペクティブをすべて閉じます。

ナビゲーション

ワークベンチのビュー、パースペクティブ、エディターを切り替えるためのショートカットがあります。

環境設定

ワークベンチを使用するための設定を指定できます。ワークベンチ本体だけでなく、ワークベンチに含まれるビューやエディターの外観に関連する様々な設定項目があります。

ツールバー

ワークベンチツールバー

ワークベンチツールバーには、頻繁に使用される重要なコマンドのボタンがあります。これらのコマンドは、ColdFusion Builder の各種メニューからも使用できます。

ワークベンチツールバー

ワークベンチツールバーには、次のボタンが(左から右の順に)表示されます。

ボタン / コマンド

説明

新規

作成できるプロジェクトとドキュメントのすべてのタイプを表示するポップアップメニューが表示されます。

保存

エディターで開かれていて現在選択されているドキュメントを保存します。

印刷

エディターで開かれていて現在選択されているドキュメントを印刷します。

新規 ColdFusion プロジェクト

ColdFusion プロジェクトを作成するためのウィザードを開きます。

CFC を開く

ナビゲータービューに表示されているプロジェクトで使用できるすべての CFC を表示します。

デバッグ

プロジェクトで現在開かれているファイルを使用してデバッグセッションを開始します。付帯しているポップアップメニューから、プロジェクト内の他のアプリケーションファイルを選択することもできます。

実行

プロジェクトで現在開かれているファイルを実行します。付帯しているポップアップメニューから、プロジェクト内の他のアプリケーションファイルを選択することもできます。

外部ツール

カスタム起動設定を選択します。

検索

プロジェクト内のファイルのテキスト文字列およびファイル名のパターンを検索します。

次の注釈

先の位置にあるコード注釈を選択して移動できます。

前の注釈

前の位置にあるコード注釈を選択して移動できます。

最後の編集位置

現在開いているファイルで最後に編集したコード要素に移動します。

戻る

以前に開いたファイルにエディターのフォーカスを移動します。

進む

以前のファイルからエディターのフォーカスを戻します。

CFML エディターのツールバー

CFML エディターのユーザーインターフェイスには、使用頻度の高いコマンドをすばやく実行するためのボタンがあります。これらのコマンドは、ColdFusion Builder の各種メニューからも使用できます。このツールバーには使用頻度の高いコード要素へのショートカットとして機能するボタンもあり、それらのボタンを使用できるかどうかは CFML エディターで入力したコードの内容に依存します。

CFML エディターのツールバー

ボタン / コマンド

説明

タグエディターを開く

タグエディターを開きます。タグエディターについて詳しくは、Tag Editorを参照してください。

cfabort の挿入

cfabort タグを挿入します。このコマンドを使用できるかどうかはスクリプトコードの内容に依存します。

cfdump の挿入

cfdump タグを挿入します。このコマンドを使用できるかどうかはスクリプトコードの内容に依存します。

cfoutput で囲む

選択したコードを cfoutput タグで囲みます。このコマンドを使用できるかどうかは、CFML エディターで入力したスクリプトコードの内容に依存します。

cfset の挿入

cfset タグを挿入します。

cfscript ブロックの挿入

cfscript コードブロックを挿入します。

CF Try/Catch で囲む

内容に応じて、選択したコードを cftry または cfcatch タグで囲みます。このコマンドを使用できるかどうかはスクリプトコードの内容に依存します。

## で囲む

選択したコードを「#」マークで囲みます。

CF コメント <!-- で囲む / 解除

選択したコードをコメント化するか、選択したコードのコメント化を解除します。

/* */ で囲む / 解除

選択したコードを「/* */」マークで囲むか、選択したコードから「/* */」マークを外します。

一重引用符で囲む

選択したコードを一重引用符で囲みます。

二重引用符で囲む

選択したコードを二重引用符で囲みます。

大文字へ

選択したコードのテキストを大文字に変更します。

小文字へ

選択したコードのテキストを小文字に変更します。

ColdFusion Builder パースペクティブについて

パースペクティブとは、作業に必要なエディターとビューを 1 つにまとめたものを指します。ColdFusion Builder には、ColdFusion Builder 開発パースペクティブと ColdFusion Builder デバッグパースペクティブという 2 つのパースペクティブがあります。

パースペクティブの表示と切り替え

特定のパースペクティブに関連付けられているファイルを開くと、そのパースペクティブが自動的に開きます。つまり、パースペクティブは、実行しようとしているタスクに合わせて自動的に変化します。例えば、ColdFusion プロジェクトを作成する場合は、ワークベンチに開発パースペクティブが表示されます。同様に、デバッグセッションを始めるときには、ColdFusion Builder がデバッグパースペクティブに切り替わります。

デフォルトでは、同じウィンドウ内に複数のパースペクティブが開きます。パースペクティブを新しいウィンドウで開くには、次のようにします。

  1. ウィンドウ/環境設定を選択します。
  2. ツリービュー構造で、一般/パースペクティブを選択します。
  3. 「新規パースペクティブを開く方法」で、「同じウィンドウ」を選択します。

手動でパースペクティブを切り替えるには、次のいずれかの操作を行います。

  • メインメニューでウィンドウ/パースペクティブを開く/その他を選択します。
  • ワークベンチのメインツールバーにあるパースペクティブバーを使用します。

Eclipse には定義済みのパースペクティブが数多く用意されています。したがって、プラグイン設定の ColdFusion Builder を使用している場合は、他のパースペクティブも使用できます。

Eclipse パースペクティブを表示するには、次のいずれかの操作を行います。

  • メインメニューでウィンドウ/パースペクティブを開く/その他を選択します。
  • ワークベンチのメインツールバーにあるパースペクティブバーで をクリックし、「その他」を選択します。

デフォルトのパースペクティブの設定

  1. ウィンドウ/環境設定を選択します。
  2. ツリービュー構造で、一般/パースペクティブを選択します。
  3. 「選択可能なパースペクティブ」でデフォルトとして設定するパースペクティブを選択し、「デフォルトにする」をクリックします。
  4. 「OK」をクリックします。

デフォルトに設定したパースペクティブの名前の後には「(デフォルト)」と表示されます。

ColdFusion Builder 開発パースペクティブ

ColdFusion Builder 開発パースペクティブは、ColdFusion Builder で ColdFusion アプリケーションを作成、編集、設定、または実行するときに使用します。さらに、ローカルやリモートの ColdFusion サーバーの設定と管理もできます。

ColdFusion Builder 開発パースペクティブには次のビューがあります。

アウトラインビュー

アウトラインビューには、エディターで現在開いているファイル内の要素の階層が表示されます。例えば、CFC ファイル内の関数や HTML ファイル内のタグが表示されます。

アウトラインビューでは、CFML、HTML、JavaScript、および CSS ページの構造の調査とナビゲートを行います。複数のコード要素を含むページでは、アウトラインビューを使用して、ページのコード構造を階層形式で表示できます。

アウトラインビューの要素は、アルファベット順、またはページ内の要素定義の順に並べ替えることができます。このビューでは、すべてのコード要素を表示するか、特定のコード要素のみを表示するかを選択できます。

  • アウトラインビューには、CFML コードの構造が表示されます。例えば、アウトラインビューの各アイテムは CFML タグを表す場合があります。
  • コード全体をスクロールせずに、エディター内の要素に直接移動するには、アウトラインビューで要素をダブルクリックします。アウトラインビューでアイテムを選択すると、そのアイテムがエディター内で強調表示されるので、コードのナビゲートがより簡単になります。
  • アウトラインビュー内のタグや要素を検索するには、フィルターを使用します。フィルターフィールドに、検索するタグまたは要素の名前を入力します。一致する文字列がアウトラインビューに表示されます。

アウトラインビューで表示する CFML タグを指定するには、ColdFusion/エディタープロファイル/エディター/アウトラインを選択します。必要に応じて、タグを選択、追加、または削除します。

RDS ファイルビューおよび RDS データビュー

Remote Data Services(RDS)を使用するには、ColdFusion サーバーのインストール時に RDS を有効にします。ColdFusion Builder には、リモートサーバー上のファイルやデータソースにアクセスするためのビューが用意されています。

RDS ファイルビューには、リモートサーバーおよびローカルサーバーのファイルとディレクトリが表示されます。RDS データビューには、リモートサーバーで設定されたデータソースが表示されます。

ColdFusion Builder で追加した ColdFusion サーバーインスタンスは自動的に RDS ファイルビューおよび RDS データビューからアクセス可能になります。

RDS ファイルビューでのリモートサーバーの設定

RDS ファイルビューを使用してリモートサーバーを手動で設定し、そのサーバー上のファイルにアクセスするには、次のようにします。

  1. ColdFusion Builder パースペクティブの右上隅にある RDS ファイルビューをクリックします。
  2. RDS ファイルビュー内で右クリックし、RDS 構成を選択します。
  3. 「新規」をクリックします。
  4. リモートサーバーの情報(ホスト名、ポート番号、ユーザー名、パスワードなど)を指定します。
  5. 「パスワードを要求」を選択します。
  6. 「接続のテスト」をクリックして、RDS 構成が正しいことを確認します。「OK」をクリックします。
  7. RDS ファイルビューからリモートサーバーを選択します。
  8. リモートサーバー上のファイルとディレクトリを表示するためのパスワードを指定します。

RDS データビューでのリモートサーバーの設定

RDS データビューを使用してリモートサーバーを設定し、リモートサーバー上のデータソースにアクセスするには、次のようにします。

  1. RDS データビューをクリックします。
  2. RDS データビュー内で右クリックし、「RDS 構成」を選択します。
  3. 「新規」をクリックします。
  4. サーバーの情報(ホスト名、ポート番号、リモートサーバーを使用するためのユーザー名、パスワードなど)を指定します。
  5. 「パスワードを要求」を選択します。
  6. 「接続のテスト」をクリックして、RDS 構成が正しいことを確認します。「OK」をクリックします。
  7. 新しく設定したサーバーを RDS データビューで展開して、データソースを表示します。

RDS クエリビューア

RDS クエリビューアでは、選択したデータソースに対するクエリを作成して実行できます。

RDS クエリビューアは RDS データビューツールバーから起動できます。RDS クエリビューアを使用してクエリを作成または実行するには、次のようにします。

  1. RDS データビューで をクリックして、RDS クエリビューア領域を開きます。
  2. 空白の領域にクエリを入力します。RDS データビュービューから RDS クエリビューアにテーブルと列をドラッグしてクエリを作成することもできます。
  3. ドロップダウンリストからサーバーとデータソースを選択します。
  4. 「クエリの実行」をクリックします。RDS クエリビューア領域にクエリの結果が表示されます。
  1. RDS クエリビューア

RDS データビュービューのテーブルを右クリックして、「テーブルの内容の表示」を選択します。RDS クエリビューアでは、選択したテーブルにあるすべてのレコードを表示できます。

ナビゲータービュー

ナビゲータービューには ColdFusion プロジェクトやその他のプロジェクトが表示され、プロジェクトのファイルやフォルダーの間をナビゲートできます。

ファイルビュー

ファイルビューには ColdFusion Builder がインストールされているローカルコンピューター上のファイルとディレクトリが表示され、新しいファイルを作成できます。

ColdFusion Builder の外部でファイルを編集した場合は、そのファイルを ColdFusion Builder で自動的に更新できます。これを行うには、ウィンドウ/環境設定/一般/ワークスペースを選択し、「自動的に更新」を選択します。

また、FTP サイトを追加したり、FTP サーバー上のファイルを参照することもできます。ColdFusion プロジェクトを FTP 接続に関連付ければ、ファイルのアップロード、ダウンロード、および同期を簡単に行えます。詳細については、「FTP および Secure FTP 接続によるプロジェクトのデプロイ」を参照してください。

サーバービュー

ColdFusion サーバーの詳細(サーバー名、ステータス、説明、サーバータイプ、サーバーホスト、ポートなど)が表示されます。サーバービューでは次の作業を行えます。

  • ColdFusion サーバーの追加と削除
  • サーバーの起動と停止
  • サーバーモニターの起動
  • ColdFusion Server Administrator の起動
  • サーバーログを開く

詳細については、「サーバーの管理」を参照してください。

ソースビューとデフォルトブラウザービュー

ソースビューには、ファイルのソースコードが表示されます。デフォルトブラウザービューには、HTML または CFML ページの出力が表示されます。

コンソールビュー

コンソールビューには、ColdFusion サーバーの状態と、ColdFusion サーバーからのメッセージが表示されます。

TailView ビュー

TailView ビューには、サーバーログとワークスペースログが表示され、ログを簡単にナビゲートできます。ログを自動的に表示するには、RDS を構成して有効にする必要があります。

サーバーを選択した後は、Server Manager のボタンバーにあるショートカットからログを開くことができます。ログを選択すると、TailView ビューにログの内容が表示されます。デフォルトでは、TailView ビューに例外ログが表示されます。サーバー ビューを使用している場合は、ビュー内を右クリックして「ログを開く」を選択すると、例外ログが開きます。

ログを手動で開くには、TailView ビューで右クリックして、「追加」を選択します。コンピューターのファイルシステムにあるログファイルを参照して選択します。

TailView ビューのツールバーには、(左から右の順に)次のボタンがあります。これらのボタンを使用すると、複数のログを個別のタブで管理できます。

TailView ツールバー

ボタン / コマンド

説明

左に移動

サーバーログまたはワークスペースログを左に移動します。

右に移動

サーバーログまたはワークスペースログを右に移動します。

ログを追加します

コンピューターのファイルシステムでログファイルを開きます。

ログファイルの監視を開始します

ログファイルの監視を開始します。

ログファイルの監視を停止します

ログファイルの監視を停止します。

ログファイルを再ロードします

ログファイルを再ロードします。

表示されているログファイルをクリアします

TailView ビューに表示されているログファイルを削除します。ただし、コンピューターのファイルシステムからは削除されません。

ディスク上のログファイルを消去

コンピューターのファイルシステムからログファイルを削除します。

ログタブを削除します

コンピューターのファイルシステムからログファイルを削除します。

すべてのログタブを削除します

TailView ビューからすべてのログタブを削除します。

スクロールロック

コンソールビューがスクロールしないように固定します。

色の設定

TailView ビューにログファイルを表示するときの色を設定します。

サービスブラウザービュー

サービスブラウザービューには、Server Manager で追加されたサーバーが一覧表示され、CFC(ColdFusion Component:ColdFusion コンポーネント)、および Web サービスとそのメソッドを参照できます。

ColdFusion コンポーネントの表示

サービスブラウザービューには、次のコンポーネントが一覧表示されます。

  • ColdFusion コンポーネントブラウザーに一覧表示されるコンポーネント. ColdFusion コンポーネントブラウザーの場所は、cf_root¥wwwroot¥CFIDE¥componentutils¥componentdoc.cfm です。
  • ColdFusion Administrator のマッピングページで指定されたディレクトリに配置されているコンポーネント
  • ColdFusion Administrator のカスタムタグのパスページで指定されたディレクトリに配置されているコンポーネント

サービスブラウザービューのツールバーには、(左から右の順に)次のボタンがあります。これらのボタンを使用すると、CFC 内のメソッドをアクセスタイプ(リモート、パブリック、パッケージ、プライベート)に基づいてフィルタリングできます。

サービスブラウザーツールバー

ボタン / コマンド

説明

システム CFC の表示

システム CFC の表示と非表示を切り替えるトグルボタン。システム CFC は、サーバーの Web ルート内に保存されます。

リモートの表示

アクセスタイプがリモートのメソッドの表示と非表示を切り替えるトグルボタン。

Public の表示

アクセスタイプがパブリックのメソッドの表示と非表示を切り替えるトグルボタン。

パッケージの表示

アクセスタイプがパッケージのメソッドの表示と非表示を切り替えるトグルボタン。

Private の表示

アクセスタイプがプライベートのメソッドの表示と非表示を切り替えるトグルボタン。

Web サービスを管理する

サービスブラウザービューでは、Web サービスの一覧に対して WSDL URL の追加や削除を行うことで、Web サービスの一覧を管理できます。

  • Web サービスの一覧を表示するには、サービスブラウザービューで をクリックします。
  • 新しい Web サービスを一覧に追加するには、 をクリックし、有効な WSDL URL を入力して「OK」をクリックします。
  • Web サービスを削除するには、該当する Web サービスを選択して をクリックします。

ColdFusion ファイルを編集する際には、サービスブラウザービューを使用して、Web サービスの実行や Web サービスオブジェクトの作成を行う CFML コードを生成できます。ActionScript ファイルを編集する際にも、サービスブラウザーを使用して ActionScript を生成できます。Web サービスを実行または作成するには、次のようにします。

  1. コードを挿入する位置にポインターを配置します。
  2. Web サービスの一覧を表示します。
  3. Web サービスまたは Web サービス内のメソッドを強調表示し、右クリックして次のいずれかを選択します。
  • Web サービスを挿入する場合は「CFObject の挿入」
  • Web サービスを作成する場合は「CreateObject の挿入」

拡張機能ビュー

拡張機能ビューでは次の作業を行えます。

  • 拡張機能のインストールとアンインストール
  • 拡張機能のインポートとリロード

拡張機能ビューには、拡張機能名やインストールされている拡張機能の説明などの詳細も表示されます。

拡張機能ビューのツールバーには(左から右の順に)次のボタンがあります。これらのボタンを使用すると、拡張機能ビューで拡張機能を管理できます。

拡張機能ビューのツールバー

ボタン / コマンド

説明

アーカイブファイルから拡張機能をインストール

インストールするアーカイブファイルを選択して、拡張機能のインストールウィザードを開きます。

フォルダーから拡張機能をインポート

拡張機能ファイルを含むフォルダーを選択します。

選択した拡張機能をアンインストール

選択した拡張機能をアンインストールします。

選択した拡張機能の詳細を表示

選択した拡張機能の詳細を表示します。

スニペットビュー

コードスニペットとは、ファイルに挿入して何度でも再利用できるテキストであり、これを作成することにより、同じテキストを毎回入力する必要がなくなります。コードスニペット、変数、およびプレーンテキストを作成して保存するには、ColdFusion スニペットビューを使用します。コードスニペットは、既存のドキュメントまたは新規のドキュメントに追加できます。

スニペットビューのツールバーには(左から右の順に)次のボタンがあります。これらのボタンを使用すると、スニペットビューでコードスニペットを管理できます。

コードスニペットツールバー

ボタン / コマンド

説明

スニペットビューの更新

スニペットビューの表示を更新します。

選択されているスニペットをドキュメントに挿入

選択されているスニペットをドキュメントに挿入します。

新規スニペットの作成

コードスニペットを作成します。

選択されているスニペットの編集

選択されているコードスニペットを編集できます。

選択されているスニペットの削除

選択されているコードスニペットを削除します。

スニペットパッケージの新規作成

コードスニペットを追加するためのスニペットパッケージを作成します。

選択されているスニペットパッケージの削除

選択されているスニペットパッケージを削除します(パッケージが空の場合のみ)。スニペットを含んでいるスニペットパッケージを削除することはできません。

 

コードスニペットの作成

  1. コードスニペット領域で をクリックします。
  2. 新規スニペットダイアログボックスで、スニペット名、コードの開始ブロック、および終了ブロックを指定します。
  3. 「OK」をクリックするとコードスニペットが作成されます。

コードスニペットの挿入

  1. 挿入ポイントにカーソルを移動します。
  2. コードスニペット領域でコードスニペットを選択します。
  3. コードスニペットツールバーで をクリックします。

エディターでコードを選択してスニペットを挿入すると、選択したコードの開始ブロックと終了ブロックの間にスニペットがラップされます。エディターでコードを選択せずにスニペットを挿入すると、現在のキャレットの位置にスニペットが挿入されます。 キャレットとは、次の文字が出現する位置を示す CFML エディター内のマーカーです。コードスニペット領域では既存のコードスニペットやコードスニペットパッケージ全体を編集したり削除したりすることもできます。

トリガーテキストを使用したスニペットの挿入

トリガーテキストを使用して CFML エディターにスニペットを挿入することもできます。例えば、スニペットを作成し、そのスニペットに「abc」というトリガーテキストを設定します。このスニペットをエディターに挿入するには、「abc」と入力し、Ctrl + J キー(Windows の場合)または Command + J キー(Mac の場合)を押します。テキスト abc がスニペットに置換されます。

スニペットを保存するパスの指定

スニペットは、スニペットのディレクトリに XML ファイルとして保存されます。デフォルトでは、スニペットはプロジェクトワークスペースの workspace/.metadata/snippets ディレクトリに格納されます。別のディレクトリを指定するには、次のようにします。

  1. ウィンドウメニューから「環境設定」を選択します。
  2. 環境設定ダイアログボックスのツリービュー構造で、ColdFusion/スニペットを選択します。
  3. スニペットを保存するディレクトリのパスを指定します。

システム定義スニペット変数

スニペット変数の大文字と小文字は区別されます。次のシステム定義変数が用意されています。

変数

説明

$${DATE}

4 桁の年号を含むシステム日付。例:12/01/2009

$${TIME}

12 時間表記のシステム時刻。例:03:15:05 PM

$${DATETIME}

システム日時。例:12/01/2009 15:15:05 PM

$${DAYOFWEEK}

完全な曜日名。例:Monday

$${CURRENTFILE}

現在開いているファイル名。例:application.cfm

$${CURRENTFOLDER}

現在開いているフォルダーの完全修飾パス。例:C:¥workspace¥myproject

$${CURRENTPATH}

現在開いているファイルの完全修飾パス。例:C:¥workspace¥myproject¥application.cfm

$${CURRENTPRJPATH}

現在開いているプロジェクトのプロジェクト名。例:myproject

$${USERNAME}

現在のユーザーの名前。

$${MONTHNUMBER}

月(01 ~ 12)。

$${DAYOFMONTH}

日(01 ~ 31)。

$${DAYOFWEEKNUMBER}

1 ~ 7 の数値で表した曜日。日曜日が週の始まりになります。したがって、月曜日は 2 になります。

$${DATETIME24}

24 時間表記の日時。例:12/01/2009 15:30:00

$${YEAR}

4 桁の数値で表した現在の年。例:2009

$${YEAR2DIGIT}

2 桁の数値で表した現在の年。例:09

例えば、現在の日付を挿入するには、次のシステム定義変数を使用します。

Date: $${DATE}

ユーザー定義スニペット変数

ユーザー定義変数では、変数名とデフォルト値の入力を求められます。例えば、次のユーザー定義変数では、作成者名の入力を求められます。

Author name: $${Author}

ColdFusion デバッグパースペクティブ

ColdFusion Debugging デバッグパースペクティブには、ColdFusion アプリケーションをデバッグするためのツールがあります。また、コードにブレークポイントを追加したり、コード内の関数にステップインまたはステップオーバーしたり、式を評価するための様々なビューが用意されています。エディターとデバッグツールを組み合わせて使用すると、修正が必要なコード行を検索して強調表示することができます。

ColdFusion デバッグパースペクティブには次のビューがあります。

変数ビュー

変数ビューのツールバーには、(左から右の順に)次のボタンが付いています。これらのボタンを使用すると、現在の変数(変数スコープも含む)を表示できます。

変数ビューのツールバー

ボタン / コマンド

説明

型名の表示

変数の型を表示します。

論理構造の表示

このコマンドは、ColdFusion Builder ではサポートされていません。

すべてを折りたたむ

ビュー内の情報を折りたたんで、変数の型のみを表示します。

デバッグ出力バッファービュー

デバッグ出力バッファーには次の 2 のペインがあります。

ブラウザー アプリケーションの実行中にブラウザーに出力される内容を表示します。デバッグするページの URL を指定します。

注意:「ホーム」ボタンをクリックすると、環境設定ダイアログボックス(ウィンドウ/環境設定/ColdFusion/デバッグの設定)でホームページの URL として指定した URL が表示されます。デバッガーの設定を編集する方法については、「ColdFusion Builder でのデバッガー設定の指定」を参照してください。

サーバー出力バッファー デバッガーの出力を 2 つのビュー(ソースビューと HTML ビュー)に表示します。

サーバー出力バッファーペインには、デバッガーがブレークポイントで一時停止したときにのみ出力が表示されます。表示される内容は、一時停止したブレークポイントに到達するまでの出力のみです。

注意:サーバー出力バッファーには、外部ブラウザーで実行されたページの出力も表示されます。

ブレークポイントビュー

ブレークポイントビューのツールバーには、(左から右の順に)次のボタンがあります。これらのボタンを使用するとデバッグセッション中にブレークポイントを管理できます。

ブレークポイントビューのツールバー

ボタン / コマンド

説明

選択されたブレークポイントを削除

選択されたブレークポイントを削除します。

すべてのブレークポイントを削除

すべてのブレークポイントを削除します。

選択したターゲットでサポートされるブレークポイントを表示

現在デバッグ中のブレークポイントを表示します。

ブレークポイント用のファイルへジャンプ

選択されたブレークポイントが設定されているファイルに移動します。

すべてのブレークポイントをスキップ

すべてのブレークポイントを無視します。

すべてを展開

ビュー内のブレークポイント情報をすべて展開します。

すべてを折りたたむ

ビュー内のブレークポイント情報をすべて折りたたみます。

デバッグビューにリンク

アプリケーションの実行が停止されたときに、選択されたブレークポイントをデバッグビューで強調表示します。

Java 例外ブレークポイントの追加

選択されたブレークポイントに達したときに返す Java 例外を指定できます。

メニュー

ブレークポイントビューに表示する情報の種類を指定できます。

式ビュー

式ビューは、変数や関数を使用して式を作成し、式の検査、評価、監視を行うときに使用します。また、変数ビューで選択した変数の評価と監視を行うこともできます。

式ビューのツールバーには、(左から右の順に)次のボタンがあります。これらのボタンを使用すると、式の作成、評価、監視を行えます。

式ビューのツールバー

ボタン / コマンド

説明

型名の表示

変数の型を表示します。

論理構造の表示

ビューに論理構造を表示します。

すべてを折りたたむ

ビュー内の式をすべて折りたたみます。

新規監視式を作成

監視式を追加します。

選択された式の削除

選択された変数または監視式を削除します。

すべての式を削除

式ビューに表示されている変数と監視式をすべて削除します。

アウトラインビュー

アウトラインビューには、現在のソースファイルの内容がアウトライン形式で表示されます。詳細については、アウトラインビューを参照してください。

デバッグビュー

デバッグビューには、各デバッグセッションの結果が表示されます。デバッグビューには、ブレークポイントでページの実行が中断したとき、またはコードにステップインまたはステップオーバーしたときのスタックトレースが表示されます。

デバッグツールバーには、(左から右の順に)次のボタンがあります。

デバッグツールバー

ボタン / コマンド

説明

再開

デバッグセッションを再開します。

中断

デバッグセッションを一時停止します。

終了

デバッグセッションを停止します。

切断

リモートでデバッグしている場合に、選択したデバッグターゲットからデバッガーを切断します。

終了したすべての起動を削除

終了したすべてのデバッグターゲットをビューから消去します。

ステップイン

インクルードされたコード、UDF、CFC を含めて、コードを行単位で実行します。

ステップオーバー

インクルードされたコード、UDF、CFC を除いて、コードを行単位で実行します。

ステップリターン

インクルードされたコード、UDF、CFC の呼び出し元ページに戻ります。

フレームにドロップ

このコマンドは、ColdFusion Builder ではサポートされていません。

ステップフィルター/ステップデバッグの使用

すべてのステップ関数でステップフィルターを適用します。

編集ビュー

編集ビューにはソースのタブが並んで表示されます。各タブは、開いているソースファイルに対応します。

サーバービュー

サーバービューは、ColdFusion Builder からサーバーの起動、停止、管理を行う場合に使用します。また、サーバービューからは、ColdFusion サーバーモニターと ColdFusion Server Administrator も起動できます。

サーバービューのツールバー

サーバービューのツールバーには、(左から右の順に)次のボタンがあります。これらのボタンを使用すると、サーバーを管理できます。

ボタン / コマンド

説明

サーバーの追加

サーバーを追加します。

サーバーを起動

サーバーを起動します。

サーバーを再起動

サーバーを停止して起動します。

サーバーを一時停止

サーバーを一時停止します。

サーバーを停止

サーバーを停止します。

コンソール / シェルを開く

新しいコンソールを開き、他のサーバーを選択するためのポップアップメニューを表示します。

ログを開く

TailView ビューでサーバーログを開きます。

サーバーの管理方法とサーバービューの使用方法について詳しくは、「サーバービューの使用」を参照してください。

コンソールビュー

コンソールビューには、CFML コードに含まれる trace ステートメントの出力と、デバッガー自体からのフィードバック(ステータス、警告、エラーなど)が表示されます。

コンソールビューのツールバーには、(左から右の順に)次のボタンがあります。これらのボタンを使用すると、コンソールビューで trace ステートメントを表示して管理できます。

コンソールツールバー

ボタン / コマンド

説明

コンソールのクリア

コンソールビューの内容をすべて消去します。

スクロールロック

コンソールビューがスクロールしないように固定します。

コンソールのピン留め

他のプロセスが選択されたときに、コンソールの内容が更新されないようにします。

選択されたコンソールの表示

選択されたコンソールを表示します。

コンソールを開く

新しいコンソールを開き、他のコンソールビューを選択するためのポップアップメニューを表示します。

問題ビュー

コードを入力するときに、ColdFusion Builder コンパイラーによってシンタックスエラーや他のコンパイルエラーが検出されると、問題ビューにそれらのエラーが表示されます。問題ビューには、ColdFusion Builder で開かれている CFML ファイルに関連するエラーのみが表示されます。

TailView ビュー

TailView ビューには、サーバーログが表示されます。詳細については、「TailView ビュー」を参照してください。

ワークベンチへのビューの追加

ワークベンチには、ColdFusion Builder のデフォルトの開発パースペクティブとデバッグパースペクティブに関連付けられているビューの他にも、様々なビューを追加できます。これらのビューをワークベンチに追加すると、アプリケーション開発プロセスの効率化を図ることができます。

  1. ワークベンチにビューを追加するには、ウィンドウ/ビューの表示/その他/一般を選択します。

これらオプションのビューはタイプで分類され、ワークベンチの異なる機能または特定の Eclipse プラグインに関連付けられます。

タスク、ブックマーク、検索などのワークベンチビューは、ColdFusion Builder でのアプリケーション開発に役立つビューです。

ColdFusion Builder のエディター

エディターはリソースタイプに関連付けられているため、ワークベンチでリソースを開くと、該当するエディターが開かれます。ワークベンチは、アプリケーションを開発するためのドキュメント中心型(およびプロジェクト中心型)の環境です。

CFML エディターは、CFML ファイルを編集するときに使用します。詳細については、「ColdFusion Builder でのコード編集」を参照してください。

HTML エディターは HTML コードを編集するときに、JavaScript エディターは JavaScript コードを編集するときにそれぞれ使用します。CSS エディターではカスケーディングスタイルシートを表示して編集することができ、アプリケーションの視覚的要素にスタイルを適用できます。

カーソルにリンク機能を使用すると、現在編集しているコードのタイプに応じてエディターを切り替えることができます。これらのエディターには、コードの色付け、コードアシスト、アウトラインビューなど、コードのナビゲーションを容易にし、コードの有効性を維持するための機能が数多く含まれています。

CFML、HTML、JavaScript、CSS コードを入力する際には、コードの完成を支援するためのヒントが表示されます。この機能をコードアシストといいます。詳細については、コードアシストを参照してください。

パースペクティブのカスタマイズ

パースペクティブのレイアウトはカスタマイズできます。つまり、パースペクティブ内で表示するビューとエディターは設定可能です。例えば、特定のパースペクティブではタスクビューを表示し、別のパースペクティブでは表示しないように設定できます。また、パースペクティブに関連する次の項目も設定できます。

  • ファイル/新規 のサブメニュー項目
  • ウィンドウ/パースペクティブ/その他のサブメニュー項目
  • ウィンドウ/ビューの表示/その他のサブメニュー項目
  • ツールバーとメインメニューに表示するアクションセット(ボタンとオプション)

注意:プラグイン設定の ColdFusion Builder では、メニューの名前がやや異なります。

カスタマイズされたパースペクティブの作成

  1. 変更するパースペクティブを開きます。
  2. ウィンドウ/パースペクティブのカスタマイズを選択します。
  3. カスタマイズされたパースペクティブに追加する項目または削除する項目の種類に応じて、「ショートカット」タブまたは「コマンド」タブの「コマンドグループの可用性」タブを選択します。
  4. 選択したパースペクティブのメニューおよびツールバーに表示する要素のチェックボックスをオンにします。
  5. 「OK」をクリックします。
  6. ウィンドウ/パースペクティブの別名保管を選択します。
  7. パースペクティブの別名保管ダイアログボックスで、変更したパースペクティブの名前を入力し、「OK」をクリックします。

注意:変更したパースペクティブを保存すると、変更したパースペクティブの名前がウィンドウ/パースペクティブを開く/その他メニューに追加されます。

カスタマイズされたパースペクティブの削除

削除可能なパースペクティブは、独自に作成したもののみです。ワークベンチに最初から付属するパースペクティブは削除できません。

  1. ColdFusion Builder でウィンドウ/環境設定を選択します。
  2. 環境設定ダイアログボックスの左側にツリービュー構造が表示されます。
  3. ツリービュー構造で、一般/パースペクティブを選択します。
  4. 「選択可能なパースペクティブ」で、削除するパースペクティブを選択します。
  5. 「削除」をクリックし、確認ダイアログで「はい」をクリックします。
  6. 「OK」をクリックします。

カスタマイズされたパースペクティブのリセット

変更済みのパースペクティブは、初期のレイアウトに戻すことができます。

  1. ColdFusion Builder でウィンドウ/環境設定を選択します。
  2. 環境設定ダイアログボックスの左側にツリービュー構造が表示されます。
  3. ツリービュー構造で、一般/パースペクティブを選択します。
  4. 「選択可能なパースペクティブ」で、リセットするパースペクティブを選択します。
  5. 「リセット」をクリックし、「OK」をクリックします。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

法律上の注意   |   プライバシーポリシー