FXG 정보

Adobe Flex®에서 사용하도록 구성된 그래픽을 Illustrator에서 만드는 경우 FXG 포맷으로 저장할 수 있습니다. FXG는 FLEX 프레임워크에서 사용하는 XML 기반의 프로그래밍 언어인 MXML 하위 세트를 기반으로 하는 그래픽 파일 포맷입니다. Adobe Flash Builder/Adobe Flash Catalyst와 같은 응용 프로그램에서 FXG 파일을 사용하여 더욱 풍부한 인터넷 응용 프로그램과 작업을 개발할 수 있습니다. FXG로 저장할 때 이미지는 총 픽셀 수가 16,777,216개 미만이어야 하며 폭이나 높이도 8192픽셀 이하여야 합니다.

이러한 포맷 사용에 대한 자세한 내용은 Adobe Flex 웹 사이트(www.adobe.com/products/flex)를 참조하십시오.

Flash Catalyst에서 Illustrator(.ai) 및 FXG(.fxg) 문서를 모두 바로 가져올 수 있습니다. 특정 Flash Catalyst 내용을 Illustrator에서 가져오려면 Flash Catalyst에서 사용할 수 있는 [Edit in Illustrator] 옵션을 사용합니다. 하지만 일부 개체나 속성은 Illustrator와 Flash Catalyst에서 다르게 처리됩니다. FXG 옵션을 사용하면 이러한 개체와 속성의 변환을 제어할 수 있습니다. 이 옵션과 더불어 Illustrator 컨텐츠를 Flash Catalyst에 바로 붙여넣을 수도 있습니다.

Illustrator에서 컨텐츠를 FXG 형식으로 저장할 때 FXG 사양과 호환되지 않는 개체나 속성은 컨텐츠의 복합성 및 FXG 매핑을 기준으로 확장되거나, 래스터화되거나, 윤곽선이 설정되거나 삭제됩니다. 예를 들어, FXG에서 지원되지 않는 3D 효과가 있는 아트웍을 보존하려면 컨텐츠가 래스터화되어 FXG 형식으로 저장됩니다.

Illustrator와 FXG 사이의 개체 및 속성 매핑 목록은 Illustrator 개체 및 속성의 FXG 매핑을 참조하십시오.

FXG를 사용하기 위한 최상의 조건

Illustrator 파일을 FXG 포맷으로 저장하고 Flash Catalyst에서 편집하는 동안 다음 지침을 사용하십시오.

  • FXG용 컨텐츠를 만들기 위해서는 Flash Catalyst나 기본 RGB 프로파일을 사용합니다.

  • 브러쉬는 확장된 패스로 인한 성능 문제를 초래할 수 있으므로 사용을 피합니다.

  • FXG에서는 그림자 만들기, 내부 광선, 외부 광선 및 흐림 효과에 대해서만 매핑을 제공하므로다른 효과보다이 효과들을 사용하는 것을 추천합니다.

  • FXG에 저장할 때 윤곽선을 만들지 않으려면 텍스트의 가로 또는 세로 크기를 조절하지 않습니다.

  • FXG는 필터에서 블랜드를 지원하지 않습니다. 편집이 가능한 필터가 있거나 자동 저장 옵션이 있는 FXG를 저장해야 할 경우에는 정확한 모양을 위해 개체에 필터(그림자 만들기, 내부/외부 광선)를 적용할 때 블렌드를 [보통]으로 설정하도록 합니다.

  • 대부분의 경우 Illustrator에서 만들어진 항목은 수평 또는 수직 선 가장자리가 선명하게 보이도록 Flash Catalyst에서 픽셀 물리기로 렌더링됩니다. 컨텐츠가 Illustrator와 Flash Catalyst 간에 전환되지 않도록 하려면 Illustrator에서 작업할 때 [픽셀 격자에 정렬] 옵션을 선택합니다. 픽셀 격자에 개체를 정렬하는 방법에 대한 자세한 내용은 웹 작업 과정을 위한 픽셀 정렬 패스 그리기를 참조하십시오.

  • 기본 문서 배경에 블렌딩된 보통 이외의 블렌드 모드에 있는 개체는 Flash Catalyst에서 다르게 표시될 수 있습니다. 보통 이외의 블렌드 모드에 있는 개체는 항상 그 뒤에 다른 개체가 있어야 합니다.

  • 기울어진 항목은 지원되지 않으며 Flash Catalyst로 가져오면 다르게 배치될 수 있습니다.

  • 9슬라이스 크기 조절 격자는 Flash Catalyst에서 지원되지 않습니다.

  • 반사된 비트맵 및 심볼은 Flash Catalyst에서 지원되지 않습니다.

  • 별색과 배합 색상은 Flash Catalyst에서 지원되지 않습니다.

  • 수직 텍스트는 Flash Catalyst에서 지원되지 않습니다.

  • 선택한 개체나 속성에 대한 특정 데이터 수정 사항에 대해 알려주는 경고 메시지가 표시됩니다. 하지만 일부 경우 경고 메시지가 적절하지 않을 수 있습니다. 예를 들어, 언어를 일부러 미국 이외의 값으로 설정하면 "일부 OpenType 속성이 누락되었습니다"와 같은 경고 메시지가표시됩니다. 컨텐츠 편집 가능성에 대한 이 경고 메시지는 [Illustrator 개인 데이터 저장] 옵션을 선택한 경우에만 표시됩니다.

Illustrator 파일을 FXG 형식으로 저장

최대 모양 및 편집 가능성을 유지하는 동안 FXG에서 Illustrator 컨텐츠를 매핑하기 위해 문서를 FXG 형식으로 저장할 수 있습니다. 이렇게 하면 Illustrator나 Flash Catalyst에서 이 문서를 열 수 있습니다.

  1. 파일 > 다른 이름으로 저장을 클릭하거나 파일 > 사본 저장을 클릭합니다.

  2. 파일 이름을 입력하고 파일을 저장할 위치를 선택합니다.

  3. 파일 포맷으로 Adobe FXG(*.FXG)를 선택하고 저장을 클릭합니다. [FXG 옵션] 대화 상자가 표시됩니다.

    FXG 옵션 대화 상자
    FXG 옵션 대화 상자

  4. [FXG 옵션] 대화 상자에서 필요한 옵션을 설정합니다. 이 대화 상자에서 사용할 수 있는 옵션은 다음과 같습니다.

    Illustrator 개인 데이터 저장

    이 옵션은 기본적으로 선택됩니다. 이 옵션을 선택하면 Illustrator에서 FXG 파일을 가져올 때 더 잘 편집할 수 있습니다.

    Illustrator에서 FXG 파일을 가져오면 FXG 파일에 대한 최대 편집 가능성을 얻을 수 있습니다.

    참고: 이 옵션은 모든 컨텐츠가 기본 Illustrator 형식으로 지원되는 것을 보장하지는 않습니다. 예를 들어, 브러쉬 선은 브러쉬 선에 대한 Illustrator 개인 데이터의 보유를 위한 지원이 없으므로 보존되지 않습니다. 하지만 Illustrator 개인 데이터를 통한 FXG 가져오기에서 효과는 라이브로 보존됩니다.

    미사용 심볼 포함

    이 옵션을 사용하여 사용하지 않은 심볼을 FXG 파일에 유지하거나 버립니다. 미사용 심볼을 FXG로 저장하면 파일 크기가 커질 수 있습니다.

    연결된 이미지를 다운샘플(72ppi)

    72ppi 연결된 이미지 파일의 다운샘플을 위해 표준 웹 요구 사항인 이 옵션을 사용합니다.

    필터

    그림자 만들기, 내부 광선, 외부 광선 및 가우스 흐림 은 FXG에서 필터로 지원됩니다 Illustrator에서는 내보내기 시 이러한 필터의 모양을 어느 정도 유지하는 대신 편집 가능성은 다소 저하됩니다. 모양의 일부를 손실하는 대신 이러한 필터의 편집 가능성을 유지하려면 [편집 가능성 유지(FXG로 변환)]를 선택합니다. 편집 가능성보다 모양을 원하는 경우에는 다른 옵션(모양 보존(확장), 모양 보존(래스터화))을 선택합니다.

    텍스트

    모양을 유지하고 편집 기능을 유지하려면 [자동 변환] 옵션을 선택합니다. 선택한 아트웍에 대해 편집 가능성을 유지할 수 없을 경우 모양을 보존하도록 아트웍이 확장되거나 래스터화됩니다. 텍스트의 시각적 모양을 보존하려면 모양 보존(래스터화) 옵션이나 모양 보존(윤곽선 만들기)을 선택하여 파일 크기가 더 작아지도록 벡터 윤곽선으로 변환합니다. 텍스트의 최대 편집 가능성을 위해서는 [편집 가능성 유지(FXG로 변환)]를 선택합니다. 하지만 이 옵션으로 인해 모양이 손실될 수 있습니다.

    그라디언트

    그라디언트는 그라디언트에 16개를 초과하는 정지점이 있을 때 FXG와 완전히 호환되지 않습니다. 50%와 동일하지 않은 그라디언트 중간점은 FXG로 바로 매핑됩니다. Illustrator는 먼저 이러한 중간점을 실제 정지점으로 추정을 시도하며, 추정할 수 없는 경우 그라디언트가 래스터화됩니다.

    Illustrator에는 FXG에서 그라디언트를 내보낼 때 우선 순위를 결정하는 기능이 있습니다. 컨텐츠 편집 가능성을 우선적으로 고려하는 경우에는 [편집 가능성 유지(FXG로 변환)]를 선택합니다. [자동 변환] 옵션을 사용하여 시각적 모양을 보존하면서 편집 기능도 유지합니다. 자동 변환은 분석을 수행하고 컨텐츠가 편집 가능하게 유지되고 여전히 모양을 일치시킬 수 있는지 결정합니다. 컨텐츠를 편집 가능하게 유지하면 모양이 일치되지 않는 경우 아트가 래스터화됩니다.

    블렌드

    [모양 보존(래스터화)]을 선택하여 모양을 보존하도록 래스터화하거나 Illustrator에서 블렌드의 복합성을 기반으로 블렌딩 옵션을 자동으로 확장하거나 래스터화할 수 있도록 [자동 변환]을 선택할 수 있습니다.

    코드 표시

    FXG 파일을 생성하기 전에 이 단추를 클릭하여 FXG 코드를 볼 수 있습니다.

    FXG는 항상 [대지 사용] 옵션을 활성화한 채 저장됩니다. 대지는 Flash Catalyst에서 상태로 가져옵니다.

    참고:

    FXG 컨텐츠를 저장하는 동안 지정된 대지 범위는 페이지의 작성이나 Flash Catalyst용 상태를 결정합니다. 복수 대지가 있는 문서를 FXG 형식으로 저장하는 경우 완전히 대지 외부에 놓인 컨텐츠는 저장되지 않습니다.

    겹쳐진 대지의 경우 FXG 형식으로 저장할 때 대지 간에 공유된 컨텐츠는 각 페이지에 저장됩니다. 따라서 동일한 컨텐츠가 있는 복수 대지가 저장됩니다.

  5. 확인을 클릭합니다. Illustrator가 변경을 수행하여 내용을 FXG에 저장하는 경우 내용 변경 사항이 [FXG 저장 경고]대화 상자에 표시됩니다.

    FXG 경고 대화 상자
    FXG 경고 대화 상자

Illustrator 및 Flash Catalyst 작업흐름

FXG 파일을 Illustrator에서 가져오거나 열려면 [파일] > [열기]를 클릭하거나 .fxg 파일을 선택합니다.

Flash Catalyst에서 [Edit in Illustrator] 옵션을 선택하여 Illustrator에서 FXG 파일을 열 수도 있습니다. 자세한 내용은 Adobe Flash Catalyst 문서에서 아트웍 라운드트립 편집을 참조하십시오.

참고:

Illustrator에서는 FXG 컨텐츠를 연결할 수는 없고 포함할 수만 있습니다.

Illustrator에서 Flash Catalyst 개체 추가 또는 편집

Flash Catalyst에서 FXG 파일의 개체와 속성을 편집하려면 Flash Catalyst의 [Edit in Illustrator] 옵션을 사용합니다. 선택된 개체는 Illustrator에서 열립니다. Illustrator에서 편집을 끝내면 개체가 FXG 포맷으로 다시 변환되고 Flash Catalyst로 다시 전달됩니다.

Flash Catalyst에서 FXG 파일에 대한 작업을 하는 동안 Illustrator에서 FXG 파일 개체를 편집할 수 있습니다. Illustrator에서 개체를 편집하려면

  1. Flash Catalyst에서, Illustrator에서 편집할 개체를 선택합니다.

  2. 다음 중 하나를 수행합니다.

    • 개체를 마우스 오른쪽 단추로 클릭한 다음 Adobe Illustrator CS5 옵션에서 [편집]을 선택합니다.

    • [Modify] > [Edit in Adobe Illustrator CS5]를 선택합니다.

    Illustrator CS5가 열리고 해당 FXG 파일이 편집할 수 있도록 자동으로 열립니다. Illustrator 창의 왼쪽 위 모퉁이에서 [완료] 및 [취소] 옵션을 사용할 수 있습니다.

    Illustrator에서 열린 FXG 파일에 사용할 수 있는 완료 및 취소 옵션
    Illustrator에서 열린 FXG 파일에 사용할 수 있는 완료 및 취소 옵션

    참고:

    Illustrator에서는 선택한 개체만 편집에 사용할 수 있습니다. 모든 다른 개체는 볼 수 있지만 편집할 수는 없습니다.

  3. 선택한 개체를 변경하거나 새 개체를 만듭니다.

  4. Illustrator의 오른쪽 하단에 있는 [완료] 단추를 클릭하여 이 모드를 종료합니다.

    [완료] 단추를 클릭하면 편집된 개체와 모든 새 개체는 FXG 형식으로 다시 변환되고 Flash Catalyst로 다시 전달됩니다.

    취소를 클릭하는 경우 파일에 수행된 변경 사항을 저장하지 않도록 확인하는 대화 상자가 표시됩니다.

    Illustrator에서 편집의 취소를 확인하는 대화 상자
    Illustrator에서 편집의 취소를 확인하는 대화 상자

  5. Flash Catalyst의 [FXG Options] 대화 상자에서 필요한 옵션을 설정한 다음 [확인]을 클릭합니다.

Flash Catalyst의 Illustrator 내용 가져오기

Flash Catalyst에서는 FXG(.fxg) 포맷 파일을 사용하여 다양한 인터넷 응용 프로그램과 기능을 만듭니다. Illustrator와 Flash Catalyst 간의 컨텐츠를 다음 세 가지 방법으로 사용할 수 있습니다.

  • Flash Catalyst에서 .ai 파일을 바로 가져오기

  • Illustrator에서 .fxg로 저장했던 .fxg 파일을 Flash Catalyst에서 가져옵니다.

  • Illustrator의 개체를 복사하여 Flash Catalyst 문서에 붙여넣습니다.

자세한 내용은 Adobe Flash Catalyst 문서에서 아트웍 라운드트립 편집을 참조하십시오.

컨텐츠를 복사하여 Flash Catalyst에 붙여넣으면 특정 개체와 그 속성이 FXG 사양과 호환되지 않을 수 있습니다. 시각적 모양이나 편집 가능성 또는 그 두 가지 모두를 수동으로 제어하고 보존하도록 설정을 지정할 수 있습니다.

Flash Catalyst에 Illustrator 개체를 붙이려면

  1. 열려 있는 Adobe Illustrator CS5 파일에서 개체를 선택하여 복사합니다.

  2. 열려 있는 Flash Catalyst 파일에서 개체를 붙여넣습니다.

  3. [Illustrator Import Options] 대화 상자에서 Illustrator 파일을 FXG 형식으로 저장의 4단계에 서술된 대로 올바른 옵션을 지정합니다.

Illustrator 개체 및 속성의 FXG 매핑

다음은 FXG로 직접 매핑되는 개체와 속성의 목록입니다.

Illustrator 개체/속성

개체/속성 하위 영역

FXG 태그

FXG로 내보내기

FXG 가져오기

Illustrator 개인 데이터 지원

비헤이비어

패스/열기

선분 이동

<패스>

라이브 매핑

라이브 매핑

없음

선분

<패스>

라이브 매핑

라이브 매핑

없음

큐빅 베지어 선분

<패스>

라이브 매핑

라이브 매핑

없음

<Line>

라이브 매핑

라이브 매핑

없음

컴파운드 패스

<패스>

라이브 매핑

라이브 매핑

없음

모양/닫힌 패스

원형

<Ellipse>

라이브 매핑

라이브 매핑

없음

사각형/둥근 사각형

<Rect>

라이브 매핑

라이브 매핑

없음

별모양/다각형

<패스>

라이브 매핑

라이브 매핑

없음

플레어

<패스>

확장

확장

없음

컴파운드 모양

<Group><Path>

확장

확장

있음

단색 칠

<Fill><Solid Colors>

라이브 매핑

라이브 매핑

없음

색상은 견본 라이브러리를 위해 보존되지 않습니다.

배합/별색/등록/전체 배합

<Fill><Solid Colors>

단색으로 변환

단색으로 변환

없음

색상은 견본 라이브러리를 위해 보존되지 않습니다.

선형 그라디언트 칠

<Fill><LinearGradient>

라이브 매핑

라이브 매핑

있음

[FXG 저장] 옵션을 사용하여 [FXG에서 그라디언트 내보내기]를 선택할 수 있는 옵션이 있습니다.

방사형 그라디언트 칠

<Fill><RadialGradient>

라이브 매핑

라이브 매핑

있음

[FXG 저장] 옵션을 사용하여 [FXG에서 그라디언트 내보내기]를 선택할 수 있는 옵션이 있습니다.

패턴 칠

래스터화됨

래스터화됨

없음

여러 칠(모양 패널)

확장

확장

있음

여러 선(모양 패널)

확장

확장

있음

패턴 선

래스터화

래스터화

없음

단색 선

<Stroke><SolidColorStroke>

라이브 매핑

라이브 매핑

없음

색상은 견본 라이브러리를 위해 보존되지 않습니다.

선 심도

라이브 매핑

라이브 매핑

없음

선 연결/선 단면 스타일

<선>

<joints=””>

<caps=””>

라이브 매핑

라이브 매핑

없음

파선/점선/선 정렬

확장

확장

없음

투명도

개체/레이어/그룹/칠/선에 대한 불투명도

<알파>

라이브 매핑

라이브 매핑

없음

투명도 패널 옵션

투명도

녹아웃

래스터화

래스터화

있음

혼합 격리

래스터화

래스터화

있음

[속성] 패널 옵션

속성 패널

칠 중복 인쇄/중복 인쇄/선/이미지 맵/URL

누락됨

누락됨

없음

레이어 및 하위 레이어

<그룹>

라이브 매핑

라이브 매핑

없음

가려진/잠긴 레이어

라이브 매핑

라이브 매핑

없음

그룹

<그룹>

라이브 매핑

라이브 매핑

없음

블렌드 그룹

확장

확장

없음

블렌드는 [FXG 저장 옵션]으로 처리됨:

[자동]: 단계, 모양을 기준으로 블렌드의 복잡성을 자동으로 감지하여 출력이 너무 복잡하면 래스터화하고, 아니면 확장합니다.

[래스터화]: 블렌드 출력을 항상 래스터화합니다.

라이브 페인트 그룹

확장

확장

없음

심볼

<Graphic/Movie>

<Library><Definitions>

라이브 매핑

라이브 매핑

없음

가져온 이미지(포함/연결됨)

연결된/포함된 이미지

래스터화

래스터화

있음

개인 데이터는 Illustrator에 라운드트립으로 포함된 아트를 유지하기 위한 목적으로만 기록됩니다.

래스터 아트

래스터화

래스터화

없음

불투명 마스크

<maskType=luminosity>

라이브 매핑

라이브 매핑

있음

효과

3D

돌출과 경사

래스터화

래스터화

있음

FXG에서의 벡터 효과 매핑에 대한 경험적 법칙은 효과를 사용하여 개체를 확장하는 것입니다. 하지만, 3D 효과가 있는 개체를 확장하면 수많은 패스가 생성되고 Flash Catalyst에서 성능 문제가 발생하기 때문에 3D 효과가 래스터화됩니다.

축 중심 회전

래스터화

래스터화

래스터화

FXG에서의 벡터 효과 매핑에 대한 경험적 법칙은 효과를 사용하여 개체를 확장하는 것입니다. 하지만, 3D 효과가 있는 개체를 확장하면 수많은 패스가 생성되고 Flash Catalyst에서 성능 문제가 발생하기 때문에 3D 효과가 래스터화됩니다.

회전

래스터화

래스터화

있음

FXG에서의 벡터 효과 매핑에 대한 경험적 법칙은 효과를 사용하여 개체를 확장하는 것입니다. 하지만, 3D 효과가 있는 개체를 확장하면 수많은 패스가 생성되고 Flash Catalyst에서 성능 문제가 발생하기 때문에 3D 효과가 래스터화됩니다.

모양으로 변환 효과

사각형/둥근 사각형/원형

확장

확장

있음

왜곡 및 변형

자유 왜곡/오목과 볼록/변형/비틀기/지그재그

확장

확장

있음

거칠게 하기/비틀기

확장

확장

없음

패스

패스 이동/개체 윤곽선/윤곽 선

확장

확장

있음

패스파인더

추가/교차 영역/교차 영역 제외/제외/이면 개체 제외/나누기/재단/병합/자르기/윤곽선/교차색 짙게 혼합/교차색 옅게 혼합/트랩

확장

확장

있음

래스터화

래스터화

래스터화

있음

스타일화

화살표 추가/모퉁이 둥글리기/스크리블

확장

확장

있음

그림자 효과

<filters>

<DropShadowfilter>

라이브 매핑

라이브 매핑

있음

내용을 FXG로 저장하면 "모드"가 항상 "복수"로 설정되고 "어두움"이 [그림자 만들기] 효과에서 마지막으로 사용된 색상으로 대체됩니다.

내부 광선

<filters>

<GlowFilter inner=”true”

라이브 매핑

라이브 매핑

있음

내용을 FXG로 저장하면 "모드"가 항상 "표준"으로 설정되고 "가운데"가 [가장자리]로 변환됩니다.

외부 광선

<filters><GlowFilter> 또는

<filters><GlowFilter inner="false">

라이브 매핑

라이브 매핑

있음

FXG로 저장하면 “모드”가 “표준”으로 설정됩니다.

변형

부채꼴/아래 부채꼴/위 부채꼴/아치/돌출/아래쪽 조개 모양/위쪽 조개 모양/깃발/물결/물고기 눈 모양/상승/물고기/부풀리기/양쪽 누르기/비틀기

확장

확장

있음

흐림 효과

가우스 흐림

<filters><BlurFilter>

라이브 매핑

라이브 매핑

있음

고급/방사형 흐림 효과

래스터화

래스터화

있음

그래프

막대/누적 막대/막대/누적/선/영역/산포/파이/레이더 그래프

래스터화

래스터화

없음

그래픽 스타일

확장

확장

없음

추적 개체

확장

확장

없음

이미지 맵

누락됨

누락됨

없음

둘러싸기 왜곡

확장

확장

없음

외부 아트

래스터화

래스터화

없음

망 아트

래스터화

래스터화

없음

패턴

래스터화

래스터화

없음

클리핑 패스 및 클립 그룹

<Mask maskType="clip">

라이브 매핑

라이브 매핑

없음

칠 클리핑 패스가 있는 마스크 개체는 FXG 저장 시 래스터화됩니다.

그라디언트

선형/방사형 그라디언트/그라디언트 멈춤/위치/각도

라이브 매핑

라이브 매핑

있음

그라디언트는 [FXG 저장 옵션]으로 처리됩니다.

[자동]: FXG에서 그라디언트를 매핑할 수 있는지 자동으로 감지합니다. 그라디언트가 매핑 가능하면 그라디언트 매핑이 FXG 내용에 저장되고, 아니면 그라디언트 개체가 래스터화됩니다.

편집 가능성 유지[FXG로 변환]: 이 옵션은 사용 가능한 매핑에 관계없이, 모양에 대해 선호되는 FXG 내 그라디언트의 편집 가능성을 유지합니다.

이미지/심볼/그라디언트의 변형

이동/크기 조절

라이브 매핑

라이브 매핑

없음

<Through Transform Effect>

회전/반사/크기 조절

확장

확장

있음

변수

누락됨

누락됨

Flash 텍스트

누락됨

누락됨

SVG 상호 작용

누락됨

누락됨

플러그-인 아트 Adobe

확장

확장

없음

플러그-인 아트 타사

확장

확장

없음

혼합 모드

어둡게 하기/곱하기/색상 번/밝게 하기/화면/색상 닷지/오버레이/소프트 라이트/하드 라이트/차이/제외/색조/채도/색상/광도

라이브 매핑

라이브 매핑

없음

브러쉬

붓글씨/산포/아트/패턴/강모

확장

확장

없음

단위

점/파이카/인치/밀리미터/센티미터

픽셀로 변환

환경 설정에 따라 Illustrator 제품으로 변환

없음

픽셀

라이브 매핑

환경 설정에 따라 Illustrator 제품으로 변환

없음

문서 프로파일

RGB 프로파일로 변환

RGB 프로파일로 변환

없음

문서 방향

세로(수직)/가로(수평)

누락됨

누락됨

있음

원근감 격자

누락됨

누락됨

없음

색상 프로필 포함

누락됨

누락됨

없음

Photoshop 효과

예술

색연필/오려내기/드라이 브러쉬/필름 그레인/프레스코/네온광/페인트 덥스/패널 칼/플라스틱 포장/포스터 가장자리/거친 파스텔 효과/문지르기 효과/스폰지 효과/언더페인팅 효과/수채화 효과

래스터화

래스터화

있음

흐림 효과

가우스 흐림

라이브 매핑

라이브 매핑

있음

방사형/고급 흐림 효과

래스터화

래스터화

있음

브러쉬 선

강조된 가장자리/각진 선/그물눈/어두운 선/잉크 윤곽선/뿌리기/스프레이 선/수미-에

래스터화

래스터화

있음

왜곡

광선 확산/유리/바다 물결

래스터화

래스터화

있음

픽셀화

색상 하프톤/수정화/메조틴트/점묘화

래스터화

래스터화

있음

선명 효과

언샵 마스크

래스터화

래스터화

있음

스케치

저부조/분필과 목탄/목탄/크롬/크레용/그래픽 펜/하프톤 패턴/메모지/복사/석고/망사 효과/도장/가장자리 찢기/물 종이

래스터화

래스터화

있음

스타일화

가장자리 광선 효과

래스터화

래스터화

있음

텍스처

균열/그레인/모자이크 타일/패치워크/스테인드 글라스/텍스처화

래스터화

래스터화

있음

비디오

인터레이스 제거/NTSC 색상

래스터화

래스터화

있음

분할 영역

누락됨

누락됨

없음

안내선

누락됨

누락됨

없음

심볼 세트

<Group><Symbol>

확장

확장

없음

XMP

누락됨

누락됨

없음

복수 대지

단일 대지

<d:layerType=Page>

라이브 매핑

라이브 매핑

없음

대지 외부의 개체는 항상 버려집니다.

  • 주 그래픽의 크기는 다음과 같습니다.

    • 폭: 최대 폭의 대지

    • 높이: 최대 높이의 대지

  • FXG에 대해 [대지] 옵션을 사용하고, 각 대지에 해당하는 페이지만 있는 단일 FXG 파일을 생성합니다.

    • Illustrator에서는 각 대지에 대한 FXG 파일이 생성되지 않습니다.

    • 모든 대지를 선택하면 모든 대지를 가진 단일 FXG 파일이 생성됩니다.

    • 1, 3, 5와 같은 범위를 선택하면 대지 1, 3, 5에 해당하는 페이지가 있는 단일 FXG 파일만 생성됩니다.

다음 텍스트 속성이 FXG와 호환됩니다.

속성 유형

Illustrator 속성

FXG 태그

맵/윤곽선/놓기/변환/부분

문자 속성

글꼴 이름

fontFamily

보존됨

글꼴 크기

fontSize

보존됨

행간

lineHeight

보존됨

밑줄

textDecoration

보존됨

취소선

lineThrough

보존됨

자간

trackingRight

보존됨

칠 색상

color

보존됨

투명도

textAlpha

보존됨

커닝

누락됨

기준선 이동

baselineShift

보존됨

일본어 속성(공백, 비율 간격, 합성, 문자 회전)

CJK 언어의 경우 텍스트가 윤곽선으로 표시되고(초기값이 아닌 경우) 다른 언어의 경우에는 윤곽선이 누락됩니다.

단락 속성

정렬

textAlign

보존됨

마지막으로 정렬된 줄과 강제 정렬(왼쪽, 가운데, 오른쪽 또는 전체)

textAlignLast

보존됨

첫 줄 왼쪽 들여쓰기

textIndent

보존됨

왼쪽 들여쓰기

paragraphstartindent

보존됨

오른쪽 들여쓰기

paragraphendindent

보존됨

spaceBefore

paragraphspacebefore

보존

spaceAfter

paragraphspaceafter

보존

가로/세로 텍스트 프레임

blockProgression

보존됨

서식 있는 텍스트 속성

width

높이

height

x

x

y

y

들여쓰기 간격

paddingLeft

들여쓰기 간격

paddingRight

들여쓰기 간격

paddingTop

들여쓰기 간격

paddingBottom

이전 텍스트

확장됨

패스의 텍스트

확장됨

지원되지 않는 [영역 문자] 옵션이 있는 텍스트 개체

지원되지 않는 [영역 문자] 옵션이 누락됨

텍스트 흐름이 있는 텍스트 개체

자동 모드에서 확장됨

사각형이 아닌 모양의 텍스트 개체

기타 기능

표에서 이전에 언급된 것 이외의 문자 속성

누락됨

이전에 언급된 것 이외의 단락 속성

누락됨

문자 스타일

누락됨(모양은 보존됨)

단락 스타일

누락됨(모양은 보존됨)

탭 설정

tabStops

보존됨

Open Type 기능

보존됨(부분)

합성 글꼴

스크립트의 기본 글꼴로 대체됩니다.

텍스트 프레임 칠

개체가 확장됨

다음은 Illustrator에서는 지원하지 않지만 FXG에서는 지원하는 속성 목록입니다.

속성 이름

FXG 태그

Illustrator 가져오기: 지원 수준

비헤이비어

LinearGradientstroke

<Stroke><LinearGradientstroke>

변경되지 않는 한 보존됨

Illustrator는 변경될 때까지 이 속성에 대한 FXG 데이터를 보존합니다. Illustrator에서의 편집으로 이 속성에 직접적인 영향이 있는 경우, Illustrator에서 데이터를 덮어쓰므로 이 속성이 누락됩니다.

RadialGradientstroke

<Stroke><RadialGradientstroke>

변경되지 않는 한 보존됨

Illustrator는 변경될 때까지 이 속성에 대한 FXG 데이터를 보존합니다. Illustrator에서의 편집으로 이 속성에 직접적인 영향이 있는 경우, Illustrator에서 데이터를 덮어쓰므로 이 속성이 누락됩니다.

ColorTransform

변경되지 않는 한 보존됨

Illustrator는 변경될 때까지 이 속성에 대한 FXG 데이터를 보존합니다. Illustrator에서의 편집으로 이 속성에 직접적인 영향이 있는 경우, Illustrator에서 데이터를 덮어쓰므로 이 속성이 누락됩니다.

혼합 모드:

추가/알파/지우기/반전/제외

변경되지 않는 한 보존됨

Illustrator는 변경될 때까지 이 속성에 대한 FXG 데이터를 보존합니다. Illustrator에서의 편집으로 이 속성에 직접적인 영향이 있는 경우, Illustrator에서 데이터를 덮어쓰므로 이 속성이 누락됩니다.

그룹에 있는 9개의 분할 영역 속성

변경되지 않는 한 보존됨

Illustrator는 변경될 때까지 이 속성에 대한 FXG 데이터를 보존합니다. Illustrator에서의 편집으로 이 속성에 직접적인 영향이 있는 경우, Illustrator에서 데이터를 덮어쓰므로 이 속성이 누락됩니다.

효과:

GradientBevel/Bevel/GradientGlow/

변경되지 않는 한 보존됨

Illustrator는 변경될 때까지 이 속성에 대한 FXG 데이터를 보존합니다. Illustrator에서의 편집으로 이 속성에 직접적인 영향이 있는 경우, Illustrator에서 데이터를 덮어쓰므로 이 속성이 누락됩니다.

ColorMatrix/변위 맵/컨볼루션/AdjustColor 필터

변경되지 않는 한 보존됨

Illustrator는 변경될 때까지 이 속성에 대한 FXG 데이터를 보존합니다. Illustrator에서의 편집으로 이 속성에 직접적인 영향이 있는 경우, Illustrator에서 데이터를 덮어쓰므로 이 속성이 누락됩니다.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책