إنشاء تخطيط Flex

تاريخ آخر تحديث 12 نوفمبر 2026

تعلم كيفية إنشاء تخطيطات Flex في Adobe InDesign باستخدام حاويات فارغة وكائنات موجودة وإطارات نص ذاتية التحجيم.

الرابط العميق للتعبئة التوليدية في Adobe InDesign

جرب في التطبيق
استخدم ملف عينة وتعلم كيفية العمل مع Flex Layout.

إنشاء تخطيط Flex فارغ

حدد عدة كائنات في مستندك.

حدد أيقونة تخطيط Flex من لوحة Properties. تتم إضافة الكائنات المحددة إلى حاوية Flex.

اسحب الكائنات وأفلتها في الحاوية. تتكيف عناصر الحاوية تلقائيًا استنادًا إلى إعدادات حاوية Flex: الاتجاه والمحاذاة والضبط والتباعد.

  • تخطيط Flex قابل للبرمجة.
  • اضغط على Esc لنقل التحديد من كائن فرعي إلى الكائن الأساسي داخل تخطيط Flex.

تغيير حجم إطار النص تلقائيًا باستخدام خيارات إطار النص

أضف إطار نص كعنصر فرعي في تخطيط Flex أو حدد إطار نص Flex Layout Child.

انتقل إلى Object > Text Frame Options، وحدد خيار Auto-Size من مربع الحوار Text Frame Options.

حدد Height Only أو Width Only أو Height and Width أو Height and Width (Keep Proportions). الخيار الافتراضي هو Off.

تغيير حجم إطار النص تلقائيًا باستخدام خيارات Flex Layout Child

أضف إطار نص كعنصر فرعي مرن في Flex Layout أو حدد إطار نص Flex Layout Child.

في خيارات Flex Layout Child في لوحة Properties، حدد خيار Auto لـ W أو H. يتم الآن تغيير حجم الإطار تلقائيًا ليتناسب مع محتواه بدلاً من تجاوزه.

لقطة شاشة لإطار نص محدد داخل Flex Layout وخيارات Flex Layout Child مُبرزة في لوحة Properties.
قم بتحديث العرض والارتفاع إلى Auto في خيارات Flex Layout Child.

إنشاء تخطيط Flex في مستند موجود

عندما تحول تحديدًا إلى Flex Layout، يحلل InDesign المحاذاة والمسافات لتطبيق سلوك التخطيط المناسب. يساعد هذا تخطيطاتك في الاستجابة بشكل متسق لتغييرات المحتوى.

حدد عدة كائنات أو مجموعات تريد تضمينها في Flex Layout.

للمجموعات: انقر بزر الماوس الأيمن على المجموعة المحددة وحدد Flex Layout > Convert to Flex Layout.

لعدة كائنات: انقر بزر الماوس الأيمن على الكائنات المحددة وحدد Flex Layout > Add to Flex Layout.

ملاحظة

يكتشف InDesign تلقائياً الاتجاه والخصائص لـ Flex Layout. لتشغيله أو إيقاف تشغيله، حدد Edit > Preferences > General (Windows) أو InDesign > Preferences > General (macOS)، ثم حدد أو ألغِ تحديد خيار Auto-detect and apply Flex Layout settings، وحدد OK.

استخدام الاكتشاف التلقائي لتحويل مجموعة من العناصر ذات الأحجام المختلفة إلى تخطيط Flex لن يعيد ترتيبها.

حسب الحجم. يمكنك الآن استخدامه للحفاظ على الترتيب الأصلي دون الإخلال بتصميمك المرئي المقصود.

يكتشف InDesign خصائص التخطيط بناءً على كيفية محاذاة الكائنات المحددة:

  • التحديدات المحاذاة: يطابق اتجاه الحاوية المحاذاة، ويتم تعيين الحجم إلى Auto على طول ذلك المحور، ويتم تعيين المسافات إلى Space Between.
  • التحديدات غير المحاذاة: يتم تشغيل Wrap Content، وتستخدم الحاوية حجماً ثابتاً على المحور الأساسي وحجماً تلقائياً على المحور الثانوي.

يمكنك ضبط الاتجاه والتبرير والمسافات واللف والمحاذاة.

مساحة عمل InDesign مع لوحة Flex Layout التي تظهر الخصائص للضبط، مفتوحة فوق حاوية flex محولة.
صقل خصائص Flex Layout باستخدام لوحة Flex Layout.

حوّل العناصر الأصلية إلى إعدادات باستخدام Flex Layouts لبناء هياكل متداخلة.

أضف أو أزل عناصر لترى كيف يستجيب التخطيط وصقله حتى يتكيف بسلاسة.

ملاحظة

الاكتشاف التلقائي لا ينشئ Flex Layouts متداخلة. المجموعات التي تحتوي بالفعل على Flex Layout تُعامل كأشياء منفردة، لذا حول المجموعات الداخلية يدوياً قبل أو بعد إنشاء الحاوية الخارجية.