Nadat u een afbeelding of document hebt geoptimaliseerd, kunt u het exporteren (of opslaan, afhankelijk van het oorspronkelijke bestandstype).

U kunt een document exporteren (of in sommige gevallen opslaan) als één afbeelding in GIF-, JPEG- of een andere grafische bestandsindeling. U kunt het volledige document ook exporteren als een HTML-bestand en de bijbehorende afbeeldingsbestanden, alleen de geselecteerde segmenten of een opgegeven gebied. Bovendien kunt u Fireworks-frames en -lagen exporteren als afzonderlijke afbeeldingsbestanden.

De standaardlocatie waarnaar Fireworks bestanden exporteert, wordt in onderstaande volgorde bepaald door:

  1. De huidige exportvoorkeur van het document; u hebt deze gedefinieerd als u het document ooit hebt geëxporteerd en het vervolgens hebt opgeslagen als een PNG-bestand

  2. De huidige locatie voor exporteren en opslaan, die u hebt gedefinieerd toen u in de dialoogvensters Opslaan, Opslaan als of Exporteren navigeerde naar een andere locatie dan de standaardlocatie

  3. De locatie van het huidige bestand

  4. De standaardlocatie van uw besturingssysteem voor het opslaan van nieuwe documenten of afbeeldingen

    De standaardlocatie waar Fireworks een document opslaat, wordt daarentegen bepaald door een andere set criteria. Zie Fireworks-bestanden opslaan voor meer informatie.

Pagina's exporteren als afbeeldingsbestanden

  1. Selecteer Bestand > Exporteren.

  2. Kies de locatie voor de exportbestanden.

  3. Ga op een van de volgende manieren te werk:

    • Selecteer Alleen afbeeldingen in het pop-upmenu Exporteren en schakel het selectievakje Alleen huidige pagina in of uit. De pagina's worden geëxporteerd naar de afbeeldingsindeling die is ingesteld in het deelvenster Optimaliseren.

    • Selecteer Pagina's naar bestanden in het pop-upmenu Exporteren en selecteer Afbeeldingen in het pop-upmenu Exporteren als. De pagina's worden geëxporteerd naar de afbeeldingsindeling die is ingesteld in het deelvenster Optimaliseren.

    • Selecteer Pagina's naar bestanden in het pop-upmenu Exporteren en selecteer Fireworks PNG in het pop-upmenu Exporteren als. Elke pagina wordt geëxporteerd als een afzonderlijk PNG-bestand dat compatibel is met de oudere versie Fireworks 8.

    Opmerking:

    als u alle pagina's in de geselecteerde indeling wilt exporteren, selecteert u alle pagina's en optimaliseert u vervolgens de instellingen.

Eén afbeelding exporteren

Wanneer u met een bestaande afbeelding werkt die u hebt geopend in Fireworks, kunt u deze opslaan in plaats van deze te exporteren. Zie Documenten in andere indelingen opslaan voor meer informatie.

Opmerking:

wanneer u slechts bepaalde afbeeldingen in een document wilt exporteren, dient u uw document eerst op te delen in segmenten en vervolgens alleen de gewenste segmenten te exporteren.

  1. Selecteer in het deelvenster Optimaliseren een bestandsindeling en stel indelingsspecifieke opties in.

  2. Selecteer Bestand > Exporteren.

  3. Selecteer een locatie waar u het afbeeldingsbestand naartoe wilt exporteren.

    De beste locatie voor webafbeeldingen is doorgaans een map in uw lokale website.

  4. Typ een bestandsnaam zonder extensie. Tijdens het exporteren wordt op basis van het bestandstype een bestandsextensie toegevoegd.

  5. Selecteer Alleen afbeeldingen in het pop-upmenu Exporteren.

  6. Klik op Opslaan.

Een gesegmenteerd document exporteren

Als u een gesegmenteerd Fireworks-document exporteert, worden standaard een HTML-bestand en daaraan gekoppelde afbeeldingen geëxporteerd. U kunt het geëxporteerde HTML-bestand weergeven in een webbrowser of importeren in een andere toepassing om het verder te bewerken.

Voordat u gaat exporteren, dient u de gewenste HTML-stijl te selecteren in het dialoogvenster HTML instellen. Zie HTML-exportopties instellen.

Alle segmenten exporteren

  1. Selecteer Bestand > Exporteren.

  2. Navigeer naar de map op uw vaste schijf waarnaar u wilt exporteren.

  3. Selecteer in het pop-upmenu Exporteren de optie HTML en afbeeldingen.

  4. Typ een bestandsnaam in het vak Bestandsnaam (Windows) of Opslaan als (Mac OS).

  5. Selecteer in het pop-upmenu HTML de optie HTML-bestand exporteren.

  6. Selecteer in het pop-upmenu Segmenten de optie Segmenten exporteren.

  7. (Optioneel) Selecteer Afbeeldingen in submap plaatsen.

  8. Klik op Opslaan.

Geselecteerde segmenten exporteren

  1. Houd Shift ingedrukt terwijl u klikt om meerdere segmenten te selecteren.

  2. Selecteer Bestand > Exporteren.

  3. Selecteer een locatie waarin u de geëxporteerde bestanden wilt opslaan, zoals een map op uw lokale website.

  4. Selecteer in het pop-upmenu Exporteren de optie HTML en afbeeldingen.

  5. Typ een bestandsnaam zonder extensie. Tijdens het exporteren wordt op basis van het bestandstype een bestandsextensie toegevoegd.

    Als u meerdere segmenten exporteert, gebruikt Fireworks de door u opgegeven naam als basisnaam voor alle geëxporteerde afbeeldingen, met uitzondering van afbeeldingen die u een aangepaste naam hebt gegeven in het deelvenster Lagen of in de eigenschappencontrole.

  6. Selecteer in het pop-upmenu Segmenten de optie Segmenten exporteren.

  7. Als u alleen de vóór het exporteren geselecteerde segmenten wilt exporteren, kiest u Alleen geselecteerde segmenten en zorgt u ervoor dat Inclusief gebieden zonder segmenten niet is geselecteerd.

  8. Klik op Opslaan.

Een segment bijwerken

Als u al een gesegmenteerd document hebt geëxporteerd en daarna in Fireworks wijzigingen aanbrengt in het oorspronkelijke document, kunt u alleen de gewijzigde afbeelding of het gewijzigde segment bijwerken. Gebruik segmenten met aangepaste namen, dan kunt u het te vervangen segment gemakkelijker vinden.

  1. Verberg het segment en bewerk het onderliggende gebied.

  2. Maak het segment weer zichtbaar.

  3. Klik met de rechtermuisknop (Windows) of houd Control (Mac OS) ingedrukt en klik op het segment. Selecteer vervolgens Geselecteerd segment exporteren.

  4. Selecteer de map waarin het oorspronkelijke segment met dezelfde basisnaam zich bevindt en klik op Opslaan.

  5. Klik op OK als u wordt gevraagd of u het bestaande bestand wilt vervangen.

    Opmerking:

    u kunt het segment beter niet groter maken dan het oorspronkelijke exportformaat in Fireworks, dat leidt namelijk tot ongewenste resultaten in het HTML-document nadat het segment is bijgewerkt.

Een animatie exporteren

Nadat u een animatie hebt gemaakt en geoptimaliseerd, kan deze worden geëxporteerd. U kunt een animatie exporteren als een van de volgende bestandstypen:

Geanimeerde GIF-bestanden

Kies deze optie voor de beste resultaten met clipart en tekenfilmachtige afbeeldingen.

Flash SWF of Fireworks PNG (geen export vereist)

U kunt een animatie het beste exporteren als een SWF-bestand als u dit wilt importeren in Flash. U kunt het exporteren ook overslaan door een Fireworks PNG-bronbestand rechtstreeks te importeren in Flash. Met gebruik van deze directe methode kunt u alle lagen en frames van uw animatie importeren en deze verder bewerken in Flash. Zie Werken met Flash.

Meerdere bestanden

Het is handig animatieframes of lagen te exporteren als meerdere bestanden wanneer er vele symbolen op verschillende lagen van hetzelfde object staan. U kunt bijvoorbeeld een banneradvertentie exporteren als meerdere bestanden als elke letter van een bedrijfsnaam is geanimeerd in een afbeelding. Zie Frames of lagen exporteren als meerdere bestanden.

Als uw document meerdere animaties bevat, kunt u segmenten invoegen om elke animatie te exporteren met gebruik van verschillende animatie-instellingen, zoals herhaling en framevertraging.

Een geanimeerde GIF exporteren

  1. Selecteer Selecteren > Selectie opheffen om de selectie van alle segmenten en objecten op te heffen. Selecteer Geanimeerde GIF als de bestandsindeling in het deelvenster Optimaliseren.

  2. Selecteer Bestand > Exporteren.

  3. Typ een naam voor het bestand en selecteer de bestemming.

  4. Klik op Opslaan.

Meerdere geanimeerde GIF's exporteren met verschillende animatie-instellingen

  1. Houd Shift ingedrukt en klik op de animaties om ze allemaal te selecteren.

  2. Selecteer Bewerken > Invoegen > Rechthoekig segment of Veelhoeksegment.

  3. Klik in het berichtenvak op Meerdere.

  4. Selecteer elk segment afzonderlijk en stel in het deelvenster Frames verschillende animatie-instellingen voor elk segment in.

  5. Selecteer alle segmenten die u wilt animeren en selecteer in het deelvenster Optimaliseren de optie Geanimeerde GIF als de bestandsindeling.

  6. Klik met de rechtermuisknop (Windows) of houd Control (Mac OS) ingedrukt en klik op elk segment. Selecteer Geselecteerd segment exporteren om elk segment afzonderlijk te exporteren. Typ in het dialoogvenster Exporteren een naam voor elk bestand, selecteer de bestemming en klik op Opslaan.

Frames of lagen exporteren als meerdere bestanden

Fireworks kan elke laag of elk frame in een document exporteren als een afzonderlijk afbeeldingsbestand en de optimalisatie-instellingen gebruiken die zijn opgegeven in het deelvenster Optimaliseren. De naam van de laag of het frame bepaalt de bestandsnaam van elk geëxporteerd bestand. Deze exportmethode wordt soms gebruikt voor het exporteren van animaties.

  1. Selecteer Bestand > Exporteren.

  2. Typ een bestandsnaam en selecteer een doelmap.

  3. Selecteer een optie in het pop-upmenu Exporteren:

    Frames naar bestanden

    Hiermee exporteert u frames als meerdere bestanden.

    Lagen naar bestanden

    Hiermee exporteert u lagen als meerdere bestanden.

    Opmerking: Alle lagen op het huidige frame worden geëxporteerd.

  4. Selecteer Afbeeldingen bijsnijden als u elke geëxporteerde afbeelding automatisch wilt uitsnijden, zodat alleen de objecten op elk frame worden opgenomen. Schakel deze optie uit als u het hele canvas wilt exporteren (dus ook de lege gebieden om de objecten heen).

  5. Klik op Opslaan.

Een gebied uit een document exporteren

  1. Selecteer de tool Exportgebied in het deelvenster Tools.

  2. Sleep een selectiekader om het gedeelte van het document te definiëren dat u wilt exporteren.

    Opmerking:

    u kunt de positie van het selectiekader tijdens het slepen aanpassen. Houd de muisknop en de spatiebalk ingedrukt en sleep het selectiekader naar een andere locatie op het canvas. Laat de spatiebalk los om door te gaan met het tekenen van het selectiekader.

    Het exportgebied blijft geselecteerd als u de muisknop loslaat.

  3. Wijzig, indien nodig, het formaat van het exportgebied:

    • Houd Shift ingedrukt en sleep een handgreep om de grootte van het selectiekader rond het exportgebied proportioneel aan te passen.

    • Houd Alt (Windows) of Option (Mac OS) ingedrukt en sleep een handgreep om het formaat van het selectiekader vanuit het middelpunt te wijzigen.

    • Houd Alt en Shift (Windows) of Option en Shift (Mac OS) ingedrukt en sleep een handgreep om het formaat vanuit het middelpunt te wijzigen en de verhoudingen te behouden.

  4. Dubbelklik in het selectiekader van het exportgebied om naar Voorvertoning afbeelding te gaan.

  5. Pas de instellingen in Voorvertoning afbeelding aan en klik op Exporteren.

  6. Typ een bestandsnaam en selecteer een doelmap.

  7. Selecteer Alleen afbeeldingen in het pop-upmenu Exporteren.

  8. Klik op Opslaan.

    Opmerking:

    dubbelklik buiten het selectiekader van het exportgebied, druk op Escape of selecteer een andere tool om het exporteren te annuleren.

HTML exporteren

Tenzij u een andere instelling kiest, worden bij het exporteren van een gesegmenteerd Fireworks-document een HTML-bestand en de bijbehorende afbeeldingen geëxporteerd. U gebruikt het dialoogvenster HTML instellen om te bepalen hoe Fireworks HTML-bestanden exporteert.

Fireworks genereert zuivere HTML die door de meeste webbrowsers en HTML-editors kan worden gelezen. Standaard wordt UTF-8-codering gebruikt bij het exporteren.

U kunt Fireworks HTML op verschillende manieren exporteren:

  • Exporteer een HTML-bestand dat u later kunt openen voor bewerking in een HTML-editor.

  • Exporteer elke pagina in een Fireworks-bestand naar een afzonderlijk HTML-bestand.

  • Kopieer HTML-code naar het klembord in Fireworks en plak die code rechtstreeks in een bestaand HTML-document.

  • Exporteer een HTML-bestand, open het in een HTML-editor, kopieer handmatig gedeelten van de code uit het bestand en plak die code in een ander HTML-document.

  • Exporteer HMTL als CSS-lagen en XHTML.

  • Gebruik de opdracht HTML bijwerken om wijzigingen aan te brengen in een HTML-bestand dat u eerder hebt gemaakt.

    In Fireworks kunt u HTML exporteren in Generic-, Dreamweaver-, Microsoft® FrontPage®- en Adobe GoLive®-indelingen.

    Opmerking: Adobe Dreamweaver is nauw geïntegreerd met Fireworks. Fireworks verwerkt het exporteren van HTML naar Dreamweaver op een andere manier dan het exporteren van HTML naar andere HTML-editors. Zie Werken met Dreamweaver als u Fireworks HTML exporteert naar Dreamweaver.

    De methode voor het exporteren van Fireworks HTML naar andere toepassingen is bij uitstek geschikt wanneer u in een team werkt. De workflow wordt opgedeeld in segmenten, zodat iemand een taak kan uitvoeren in een toepassing en iemand anders later verder kan gaan in een andere toepassing.

Opmerkingen opnemen in geëxporteerde HTML

Fireworks HTML-opmerkingen beginnen met <!-- en eindigen met -->. Alle tekens tussen deze twee markeringen worden niet opgevat als HTML- of JavaScript-code.

  1. Selecteer de optie Inclusief HTML-opmerkingen in het tabblad Algemeen van het dialoogvenster HTML instellen voordat u bestanden exporteert.

Exportresultaten

Het volgende wordt gegenereerd wanneer u HTML kopieert of exporteert uit Fireworks:

  • De HTML-code die nodig is om gesegmenteerde afbeeldingen weer samen te stellen en eventuele JavaScript-code als het document interactieve elementen bevat. Fireworks HTML bevat koppelingen naar de geëxporteerde afbeeldingen en stelt de achtergrond van de webpagina in op de kleur van het canvas.

  • Een of meerdere afbeeldingsbestanden, afhankelijk van het aantal segmenten in uw document en het aantal statussen van de knoppen.

  • Een bestand met de naam spacer.gif, als dat nodig is. Spacer.gif is een transparant GIF-bestand van 1 pixel bij 1 pixel dat Fireworks gebruikt voor het corrigeren van spatieproblemen als gesegmenteerde afbeeldingen opnieuw worden samengesteld in een HTML-tabel. U kunt kiezen of Fireworks een spacer exporteert.

  • De volgende bestanden worden geëxporteerd als u pop-upmenu's exporteert: mm_css_menu.js en een CSS-bestand dat de CSS-code van het pop-upmenu bevat. Als uw pop-upmenu's submenu's bevatten, wordt er ook een bestand met de naam arrows.gif geëxporteerd.

  • As u HTML exporteert of kopieert naar Dreamweaver, worden notitiebestanden gemaakt die de integratie tussen Fireworks en Dreamweaver bevorderen. Deze bestanden hebben de extensie .mno.

Fireworks HTML exporteren

  1. Selecteer Bestand > Exporteren.

  2. Navigeer naar de map op uw vaste schijf waarnaar u wilt exporteren.

  3. Selecteer in het pop-upmenu Exporteren de optie HTML en afbeeldingen.

  4. Klik op de knop Opties en selecteer de gewenste HTML-editor in het pop-upmenu HTML-stijl op het tabblad Algemeen van het dialoogvenster HTML instellen. Selecteer Algemeen als uw HTML-editor niet wordt vermeld.

    Opmerking:

    het is belangrijk dat u de juiste HTML-editor selecteert als de HTML-stijl, zodat de interactieve elementen, zoals knoppen en rollovers, naar behoren functioneren als u ze importeert in de HTML-editor.

  5. Klik op OK.

  6. Selecteer in het pop-upmenu HTML de optie HTML-bestand exporteren.

  7. Selecteer Segmenten exporteren in het pop-upmenu Segmenten als uw document segmenten bevat.

  8. Selecteer Afbeeldingen in submap plaatsen als u afbeeldingen in een aparte map wilt opslaan. U kunt een bepaalde map selecteren of u kunt de standaardafbeeldingenmap van Fireworks gebruiken.

  9. Als u een Fireworks-document met meerdere pagina's exporteert, schakelt u het selectievakje Alleen huidige pagina uit om alle pagina's te exporteren als afzonderlijke HTML-documenten.

  10. Klik op Opslaan.

    Na het exporteren staan de door Fireworks geëxporteerde bestanden op uw vaste schijf. Er worden afbeeldingen en een HTML-bestand gegenereerd op de locatie die u hebt opgegeven in het dialoogvenster Exporteren.

HTML-code kopiëren naar het Klembord

U kunt HTML-code op twee verschillende manieren naar het Klembord kopiëren in Fireworks. U kunt de opdracht HTML-code kopiëren gebruiken of de optie Kopiëren naar klembord selecteren in het dialoogvenster Exporteren. Later plakt u deze HTML in een document in een HTML-editor van uw keuze.

Overweeg de volgende nadelen van het kopiëren van HTML-code naar het Klembord als u besluit hoe u Fireworks HTML in andere toepassingen wilt plaatsen:

  • Het is niet mogelijk afbeeldingen op te slaan in een submap. De afbeeldingen moeten in dezelfde map staan als het HTML-bestand waar u de gekopieerde HTML hebt geplakt. Naar Dreamweaver gekopieerde HTML vormt een uitzondering.

  • Alle koppelingen of paden die in Fireworks-pop-upmenu's worden gebruikt, worden aan uw vaste schijf toegewezen. Naar Dreamweaver gekopieerde HTML vormt een uitzondering.

  • Als u een andere HTML-editor dan Dreamweaver of Microsoft FrontPage gebruikt, wordt de JavaScript-code die aan knoppen, gedrag en rolloverafbeeldingen is gekoppeld wel gekopieerd, maar het kan zijn dat deze niet naar behoren functioneert.

    Als u deze nadelen te zwaar vindt wegen, gebruikt u de optie HTML exporteren in plaats van HTML te kopiëren naar het Klembord.

    Opmerking: Het is belangrijk dat u, voordat u HTML-code kopieert, de juiste HTML-stijl selecteert en Inclusief HTML-opmerkingen kiest op het tabblad Algemeen van het dialoogvenster HTML instellen.

Fireworks HTML kopiëren met gebruik van de optie HTML-code kopiëren

  1. Selecteer Bewerken > HTML-code kopiëren.

  2. Volg de instructies van de wizard. Geef bij de aanwijzing een map op als bestemming voor de geëxporteerde afbeeldingen. U dient hier de locatie voor uw HTML-bestand op te geven.

    Opmerking:

    Als u van plan bent de HTML-code in Dreamweaver te plakken, is de exportlocatie van de afbeeldingen niet belangrijk, als ze maar op dezelfde Dreamweaver-site staan als het HTML-bestand waarin u de code gaat plakken.

Fireworks HTML kopiëren met gebruik van het dialoogvenster Exporteren

  1. Selecteer Bestand > Exporteren.

  2. Geef een doelmap voor de geëxporteerde afbeeldingen op in het dialoogvenster Exporteren. U dient hier de locatie voor uw HTML-bestand op te geven.

    Opmerking:

    als u van plan bent de HTML-code in Dreamweaver te plakken, is de exportlocatie van de afbeeldingen niet belangrijk, als ze maar op dezelfde Dreamweaver-site staan als het HTML-bestand waarin u de code gaat plakken.

  3. Selecteer in het pop-upmenu Exporteren de optie HTML en afbeeldingen.

  4. Selecteer in het pop-upmenu HTML de optie Kopiëren naar klembord.

  5. Selecteer Segmenten exporteren in het pop-upmenu Segmenten als uw document segmenten bevat.

  6. Klik op de knop Opties, selecteer uw HTML-editor in het dialoogvenster HTML instellen en klik op OK.

  7. Klik op Opslaan.

Uit Fireworks gekopieerde HMTL in een HTML-document plakken

  1. Open een bestaand HTML-document in de HTML-editor of maak een nieuw document. Sla het document op de exportlocatie van uw afbeeldingen op.

    Opmerking:

    u hoeft het HTML-bestand niet op dezelfde locatie op te slaan als de geëxporteerde afbeeldingen als u Dreamweaver gebruikt. Als u de afbeeldingen uit Fireworks naar een Dreamweaver-site exporteert en het HTML-bestand op een locatie in die site opslaat, kan Dreamweaver de paden naar de gekoppelde afbeeldingen oplossen.

  2. Geef de HTML-code weer en plaats het invoegpunt tussen de <BODY>-tags.

    Opmerking:

    de uit Fireworks gekopieerde HTML-code bevat de openingstag <HTML> en de afsluitende tag <BODY> niet.

  3. Plak de HTML-code.

    Exporteer afbeeldingen als u naar het Klembord kopieert, indien mogelijk, naar hun locatie op de website. Fireworks gebruikt documentrelatieve URL's, dat betekent dat de URL-koppelingen worden verbroken als de HTML of de afbeeldingen worden verplaatst.

Code uit een geëxporteerd Fireworks-bestand kopiëren en in een ander HTML-document plakken

  1. Open het geëxporteerde Fireworks HTML-bestand in een HTML-editor.

  2. Markeer de vereiste code en kopieer deze naar het Klembord.

  3. Open een bestaand HTML-document of maak een nieuw HTML-document.

  4. Plak de code in het nieuwe HTML-bestand. U hoeft de tags <HTML> en <BODY> niet te kopiëren. Als het goed is, staan deze namelijk al in het HTML-doeldocument.

    Als u Inclusief HTML-opmerkingen kiest in het dialoogvenster HTML instellen in Fireworks, volgt u de aanwijzingen in de opmerkingen om de code naar de gewenste locatie te kopiëren en plakken.

  5. Als uw Fireworks-document interactieve elementen bevat, kopieert u de JavaScript-code.

    JavaScript-code wordt omgeven door <SCRIPT>-tags en bevindt zich in de sectie <HEAD> van het document. Kopieer en plak de volledige sectie <SCRIPT>, tenzij uw doeldocument al een sectie <SCRIPT> bevat. In dat geval dient u alleen de inhoud van de sectie <SCRIPT> in de bestaande sectie<SCRIPT> te kopiëren en te plakken, waarbij u moet opletten dat u niet de inhoud van de bestaande sectie overschrijft. Nadat u de code hebt geplakt, controleert u de sectie <SCRIPT> op gedupliceerde JavaScript-functies.

Geëxporteerde HTML bijwerken

Door een Fireworks HTML-document bij te werken, kunt u wijzigingen aanbrengen in een reeds geëxporteerd document. Dat is handig als u een document slechts gedeeltelijk wilt bijwerken.

Opmerking:

HTML bijwerken functioneert op een andere manier in Dreamweaver-documenten dan in andere HTML-documenten. Zie Werken met Dreamweaver voor meer informatie.

Tijdens het bijwerken kunt u alleen de gewijzigde afbeeldingen vervangen of juist alle code en afbeeldingen overschrijven. Als u ervoor kiest alleen de gewijzigde afbeeldingen te vervangen, blijven alle wijzigingen behouden die u buiten Fireworks in het HTML-bestand hebt aangebracht.

Opmerking:

als de documentlay-out aanzienlijk is gewijzigd, brengt u uw wijzigingen aan in Fireworks en exporteert u het HTML-bestand opnieuw.

  1. Selecteer Bestand > HTML bijwerken.

  2. Selecteer het bestand dat u wilt bijwerken.

  3. Klik op Openen.

  4. Ga op een van de volgende manieren te werk:

    • Als er geen door Fireworks gegenereerde HTML wordt gevonden, klikt u op OK om nieuwe HTML in te voegen aan het einde van het document.

    • Als door Fireworks gegenereerde HTML wordt gevonden, selecteert u een van de volgende opties en klikt u op OK:

      Afbeeldingen en hiermee verbonden HTML vervangen

      Hiermee vervangt u de vorige Fireworks HTML

      Alleen afbeeldingen bijwerken

      Hiermee overschrijft u alleen de afbeeldingen

  5. Als het dialoogvenster Map voor afbeeldingen selecteren wordt weergegeven, selecteert u een map en klikt u op Openen.

CSS-lagen exporteren

CSS-lagen kunnen elkaar overlappen en op elkaar worden gestapeld. In Fireworks overlapt gewone HTML-uitvoer niet.

  1. Selecteer Bestand > Exporteren.

  2. Typ een bestandsnaam en selecteer een doelmap.

  3. Selecteer in het pop-upmenu Exporteren de optie CSS en afbeeldingen.

    • Als u alleen het huidige frame wilt exporteren, selecteert u Alleen huidig frame.

    • Als u alleen de huidige pagina wilt exporteren, selecteert u Alleen huidige pagina.

    • Selecteer Afbeeldingen in submap plaatsen om een map voor de afbeeldingen te kiezen.

  4. Klik op Opties om de HTML-paginaeigenschappen in te stellen.

  5. Klik op Bladeren om een achtergrondafbeelding op te geven en de achtergrondafbeeldingstegels in te stellen:

    • Selecteer Niet herhalen om de afbeelding maar eenmaal weer te geven.

    • Selecteer Herhalen als u de afbeelding zowel horizontaal als verticaal wilt herhalen.

    • Selecteer Herhalen-x als u de achtergrondafbeelding horizontaal wilt herhalen.

    • Selecteer de optie Herhalen-y als u de achtergrondafbeelding verticaal wilt herhalen.

  6. Selecteer de pagina-uitlijning op de browser als links, midden of rechts.

  7. Klik op OK en vervolgens op Opslaan.

XHTML exporteren

XHTML is een combinatie van HTML (de huidige standaard voor het opmaken en weergeven van webpagina's) en XML (Extensible Markup Language). XHTML is achterwaarts compatibel (dat wil zeggen dat de meeste hedendaagse webbrowser het kunnen weergeven) en kan worden gelezen door alle apparaten die XML-inhoud weergeven, zoals PDA's, mobiele telefoons en andere handheldapparatuur.

Fireworks kan ook XHTML importeren. Zie Fireworks PNG-bestanden maken van HTML-bestanden.

Meer informatie over XHTML vindt u in de W3C (World Wide Web Consortium) XHTML-specificatie op www.w3.org.

  1. Selecteer eerst Bestand > HTML instellen en vervolgens een XHTML-stijl in het pop-upmenu HTML-stijl van het tabblad Algemeen en klik op OK.

  2. Exporteer uw document met een van de methoden die beschikbaar zijn voor het exporteren of kopiëren van HTML. Zie HTML exporteren.

    Opmerking:

    Fireworks gebruikt UTF-8-codering voor het exporteren naar XHTML.

Bestanden exporteren met en zonder UTF-8-codering

UTF-8 , een afkorting van Universal Character Set Transformation Format-8, is een methode voor tekstcodering die browsers in staat stelt verschillende tekensets weer te geven op dezelfde HTML-pagina, zoals Chinese en Engelse tekst. UTF-8-codering is standaard ingeschakeld.

Fireworks kan ook documenten importeren die UTF-8-codering gebruiken. Zie Fireworks PNG-bestanden maken van HTML-bestanden.

Documenten exporteren zonder UTF-8-codering

  1. Selecteer Bestand > HTML instellen

  2. Schakel het selectievakje UTF-8-codering op het tabblad Documentspecifiek uit en klik op OK.

  3. Exporteer uw document met een van de volgende methoden die beschikbaar zijn voor het exporteren of kopiëren van HTML.

HTML-exportopties instellen

In het dialoogvenster HTML instellen kunt u bepalen hoe Fireworks HTML exporteert. Wijzigingen die u aanbrengt in het tabblad Documentspecifiek betreffen alleen het huidige document. De instellingen Algemeen en Tabel zijn algemene voorkeuren en gelden voor alle nieuwe documenten.

  1. Ga op een van de volgende manieren te werk:

    • Selecteer Bestand > HTML instellen

    • Klik op de knop Opties in het dialoogvenster Exporteren.

  2. Selecteer de gewenste opties in het tabblad Algemeen.

    HTML-stijl

    Selecteer de stijl voor de geëxporteerde HTML.

    Algemene HTML werkt in alle HTML-editors. Als uw document echter gedrag of interactieve inhoud bevat, selecteert u uw specifieke editor als deze in de lijst voorkomt.

    Selecteer de gewenste XHTML-stijl in het pop-upmenu als u uw document wilt exporteren met gebruik van de XHTML-standaard.

    Extensie

    Selecteer een bestandsextensie in het pop-upmenu of typ een nieuwe extensie.

    Inclusief HTML-opmerkingen

    Schakel deze optie in om opmerkingen betreffende de locatie van het kopiëren en plakken op te nemen in de HTML. Aanbevolen als uw document interactieve elementen bevat, zoals knoppen, gedrag of rolloverafbeeldingen.

    Bestandsnaam in kleine letters

    Schakel deze optie in om de naam van het HTML-bestand en de gekoppelde afbeeldingsbestanden na het exporteren in kleine letters weer te geven.

    Opmerking: De extensie van het HTML-bestand verandert niet in kleine letters als u hoofdletters hebt geselecteerd voor de extensie in het pop-upmenu Extensie.

    CSS gebruiken voor pop-upmenu's

    Selecteer deze optie om CSS te gebruiken in plaats van JavaScript voor uw pop-upmenucode. U kunt Dreamweaver gebruiken om de menu's te indexeren en om de koppelingen in de code bij te werken.

    CSS naar een extern bestand schrijven

    Schakel deze optie in als u de CSS-code naar een extern CSS-bestand wilt schrijven dat naar dezelfde locatie wordt geëxporteerd als het HTML-bestand. De naam van het CSS-bestand komt overeen met de naam van het HTML-bestand (met uitzondering van de bestandsextensie). Als u deze optie kiest, wordt ook een bestand met de naam mm_css_menu.js naar dezelfde locatie geëxporteerd als het HTML-bestand.

    Opmerking: Deze optie is alleen beschikbaar als u de optie CSS gebruiken voor pop-upmenu's hebt gekozen.

    Bestandenmaker (Mac OS)

    Selecteer een gekoppelde toepassing in het pop-upmenu. Dubbelklik op het geëxporteerde HTML-bestand op uw vaste schijf om het automatisch te openen in de geselecteerde toepassing.

  3. Selecteer instellingen voor uw HTML-tabellen op het tabblad Tabel. Zie Definiëren hoe HTML-tabellen worden geëxporteerd voor nadere informatie.

  4. Maak op het tabblad Documentspecifiek een keuze uit de volgende opties:

    Segmentbestandsnamen

    Selecteer een formule voor automatische naamgeving van segmenten in de pop-upmenu's. U kunt de standaardinstellingen gebruiken of uw eigen opties kiezen.

    Opmerking: Als u Geen selecteert als optie voor een van de eerste drie menu's, worden in Fireworks segmentbestanden geëxporteerd die elkaar overschrijven. Dit heeft één geëxporteerde afbeelding tot gevolg, en een tabel waarin deze afbeelding in elke cel wordt weergegeven.

    Standaard ALT-markering

    Typ de tekst die in plaats van alle afbeeldingen moet worden weergegeven tijdens het downloaden van afbeeldingen van het web en in plaats van afbeeldingen die niet kunnen worden gedownload. In sommige browsers kan deze tekst ook als knopinfo worden weergegeven wanneer de muisaanwijzer boven de afbeelding wordt gehouden. Dit is ook handig voor slechtziende webgebruikers.

    Meerdere HTML-bestanden op navigatiebalk (voor gebruik zonder framesets) exporteren

    Schakel deze optie in wanneer u een navigatiebalk exporteert die verschillende pagina's aan elkaar koppelt. Fireworks exporteert aanvullende pagina's voor elke knop op de navigatiebalk.

    Gebieden zonder segmentobjecten opnemen

    Schakel deze optie in om gebieden van het canvas waarop zich geen segmenten bevinden op te nemen.

    UTF-8-codering

    Deze optie is standaard ingeschakeld. Er kunnen dan tekens uit verschillende tekensets worden weergegeven in het geëxporteerde document. Schakel het selectievakje uit als u deze optie niet wilt gebruiken.

  5. Klik op Standaardwaarden instellen om deze instellingen op te slaan als uw globale standaardinstellingen..

Adobe PDF-bestanden exporteren

Wanneer u een Fireworks-ontwerp wilt afdrukken of wilt distribueren ter revisie, exporteert u het naar Adobe PDF. Revisoren kunnen opmerkingen toevoegen en reageren op opmerkingen van anderen in Adobe Reader® of Acrobat®. Zie Help bij Acrobat voor meer informatie over het instellen van PDF-revisies.

In geëxporteerde PDF-bestanden blijven alle pagina's en hypertextkoppelingen behouden, zodat revisoren op dezelfde manier in bestanden kunnen navigeren als op het web. In tegenstelling tot HTML-prototypen verschaft Adobe PDF echter beveiligingsinstellingen die voorkomen dat revisoren uw ontwerpen bewerken of kopiëren.

  1. Kies Bestand > Exporteren.

  2. Kies Adobe PDF in het pop-upmenu Exporteren.

  3. Kies de pagina's die u wilt exporteren, en selecteer PDF weergeven na exporteren om de PDF automatisch te openen in Adobe Reader of Acrobat.

  4. Klik op Opties en pas de volgende instellingen aan als u het PDF-bestand wilt aanpassen:

    Compatibiliteit

    Hier bepaalt u in welke Adobe PDF-toepassingen het geëxporteerde bestand kan worden geopend.

    Compressie

    Hier bepaalt u het type afbeeldingscompressie waardoor het bestand kleiner wordt gemaakt. Doorgaans biedt JPEG- en JPEG2000-compressie betere resultaten bij afbeeldingen zoals foto's met geleidelijke kleurovergangen. ZIP is een goede keuze voor illustraties met grote gebieden effen kleuren.

    Kwaliteit

    Voor JPEG- of JPEG2000-compressie, biedt afbeeldingskwaliteitsinstellingen. Als u een hoge kwaliteit selecteert, resulteert dit in een groot bestandsformaat en een goede afbeeldingskwaliteit.

    Omzetten in grijswaarden

    Hiermee zet u alle afbeeldingen om in grijswaarden, zodat de bestandsgrootte kleiner wordt.

    Tekstselectie toestaan

    Hiermee kunnen revisoren tekst uit het geëxporteerde bestand kopiëren. Als u deze optie uitschakelt, wordt de bestandsgrootte aanzienlijk kleiner.

    Afloopwaarde

    Hiermee bepaalt u in pixels de breedte van het lege kader dat de afbeelding op iedere pagina omringt. Als u hier bijvoorbeeld 20 opgeeft, wordt elke afbeelding omringd door een kader van 20 pixels.

    Wachtwoord gebruiken om document te openen

    Hiermee is het wachtwoord voor het openen van documenten nodig om het geëxporteerde bestand te kunnen openen.

    Wachtwoord gebruiken om taken te beperken

    Hiermee is het beveiligingswachtwoord nodig om de volgende functies te kunnen uitvoeren: afdrukken, bewerken, kopiëren en opmerkingen plaatsen.

  5. Klik op OK om het dialoogvenster Opties te sluiten.

  6. Geef een bestandsnaam en een locatie op en klik vervolgens op Opslaan.

    Opmerking:

    als uw Fireworks-document pagina's met een transparant canvas bevat, gaan de transparantiekenmerken van objecten waarop transparantie-opties zijn toegepast verloren wanneer u het document naar PDF exporteert. Als u dit wilt voorkomen, kunt u het canvas instellen op een niet-transparante achtergrond wanneer u naar PDF exporteert.

Video

Proefdrukken voor de klant maken in de vorm van PDF- of HTML-bestanden met Fireworks (00:05:32)

Leer hoe u het menu Exporteren in Fireworks kunt gebruiken om een PDF- of een HTML-document te maken voor goedkeuring door de klant of teamrevisie.

Door Tom Green

Wanneer u geëxporteerde PDF-bestanden weergeeft in Adobe Acrobat of Adobe Reader, gebruikt u de volgende instellingen:

  1. Selecteer in Adobe Acrobat of Adobe Reader Bewerken > Voorkeuren.

  2. Selecteer Paginaweergave in het linkerdeelvenster.

  3. Stel de aangepaste resolutie in op 72 pixels per inch.

  4. Stel de zoomwaarde in op 100%.

FXG-bestanden exporteren

FXG is een bestandsindeling die wordt ondersteund door Flash Catalyst, Fireworks, Illustrator en Photoshop. Wanneer u een bestand met vector- en bitmapafbeeldingen exporteert aan de hand van een FXG-export, wordt een afzonderlijke map met de naam <filename.assets> gemaakt. De map bevat de bitmapafbeeldingen die zijn gekoppeld aan het bestand.

De importbewerking mislukt als een van de gekoppelde bestanden uit deze map is verwijderd.

Opmerking:

Elementen, filters, overvloeimodi, verlopen en maskers waarvoor geen bijbehorende toewijzingsmarkering aanwezig is in FXG, worden geëxporteerd als bitmapafbeeldingen.

  1. Selecteer Bestand > Exporteren en navigeer naar de locatie waar u de bestanden wilt opslaan.

  2. Geef een bestandsnaam op voor het FXG-bestand.

  3. Selecteer FXG en afbeeldingen in het menu Exporteren van het dialoogvenster Exporteren.

  4. Klik op Opslaan.

Opmerking:

Objecten die in Fireworks buiten het canvas vallen worden volledig weergegeven wanneer het geëxporteerde FXG-bestand wordt geopend in Flash Catalyst.

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid