Dit artikel biedt u een overzicht van de nieuwe functies in Adobe Flash Professional CS6.

Ondersteuning voor Adobe AIR 3.4 (alleen Flash Professional CS6 Update 12.0.2)

In het kader van Flash Professional CS6 Update 12.0.2 breidt Flash Professional de ondersteuning voor AIR 3.4 en Flash Player 11.4 uit. Dankzij deze update kunt u functies benutten die worden aangeboden in AIR 3.4 en de workflow voor het publiceren van toepassingen op iOS-apparaten verbeteren.

Toolkit voor CreateJS 1.2

Dankzij de release van de Toolkit for CreateJS 1.2 wordt het omzetten van knoppen in HTML5 ondersteund. In deze update zijn bovendien meerdere aan JSX gerelateerde fouten gecorrigeerd. Ook andere problemen, zoals het wegvallen van meerdere lege hoofdframes, zijn opgelost in deze update.

U kunt de Toolkit for CreateJS 1.2 downloaden en installeren vanuit Adobe Extension Manager CS6. Zie De Flash Professional Toolkit voor CreateJS gebruiken voor meer informatie over de Toolkit.

Mobiele inhoud simuleren voor AIR

Met de nieuwe simulator voor mobiele inhoud kunt u hardwaretoetsen, versnellingsmeters, multi-touch en geolocaties simuleren.

Een netwerkinterface kiezen voor externe foutopsporing voor AIR

Wanneer u een AIR-toepassing publiceert naar een Android- of iOS-apparaat, kunt u kiezen welke netwerkinterface u voor externe foutopsporing wilt gebruiken. Flash Pro verpakt het IP-adres van de geselecteerde netwerkinterface in de foutopsporingsmodus van de mobiele toepassing. De toepassing kan dan automatisch verbinden met het IP-adres van de host om een foutopsporingssessie te starten wanneer de toepassing wordt gestart op het mobiele doelapparaat. Kies Bestand > Publicatie-instellingen en selecteer het tabblad Implementatie in het dialoogvenster AIR-instellingen voor toegang tot de instelling. Voor meer informatie leest u de artikelen met als onderwerp Toepassingen voor AIR voor iOS verpakken en Publiceren voor Adobe AIR voor bureaublad.

 

Toolkit voor CreateJS

De Adobe Flash Professional-toolkit voor CreateJS vormt een uitbreiding van Flash Professional CS6. Hiermee kunnen ontwikkelaars en animatoren hun assets maken voor HTML5-projecten met behulp van open-source CreateJS JavaScript-bibliotheken. De uitbreiding biedt ondersteuning voor de meeste basisopties voor animaties en illustraties van Flash Professional, inclusief vectoren, bitmaps, klassieke tweens, geluiden, bewegingsgeleiders, geanimeerde maskers en JavaScript-tijdlijdscripts. Met de toolkit voor CreateJS kunt u de inhoud van het werkgebied en de bibliotheek met één klik exporteren als JavaScript-code. U kunt de code vervolgens in de browser bekijken, zodat u heel snel en gemakkelijk indrukwekkende HTML5-inhoud maakt.

Met de toolkit voor CreateJS kunnen gebruikers van Flash Pro gemakkelijker de overgang maken naar HTML5. De toolkit converteert bibliotheeksymbolen en inhoud op het werkgebied naar een begrijpbare en eenvoudig ingedeelde JavaScript-code die gemakkelijk kan worden gebruikt door ontwikkelaars die op hun beurt interactiviteitsfuncties willen toevoegen met JavaScript en de CreateJS-API's die zo herkenbaar zijn voor ActionScript 3-gebruikers. De toolkit voor CreateJS biedt ook de optie om een eenvoudige HTML-pagina te publiceren waarmee u snel een voorvertoning van de elementen kunt bekijken. Zie dit artikel voor meer informatie.

Sprite-werkbladen exporteren

Het is nu mogelijk een sprite-werkblad te exporteren door een symbool te selecteren in de bibliotheek of in het werkgebied. Een sprite-werkblad is één afbeeldingsbestand dat alle grafische elementen bevat die in het geselecteerde symbool worden gebruikt. Deze elementen zijn naast elkaar gerangschikt in het bestand. U kunt ook de bitmaps in de bibliotheek opnemen wanneer u een symbool selecteert in de bibliotheek. Ga als volgt te werk om een sprite-werkblad te maken:

  1. Selecteer een symbool in de bibliotheek of in het werkgebied.
  2. Klik met de rechtermuisknop en kies Sprite-werkblad exporteren.

Bijzonder efficiëntie compressie van SWF-bestanden

Voor SWF-bestanden die zijn bedoeld voor Flash Player 11 of later is het nieuwe compressiealgoritme LZMA beschikbaar. Dit nieuwe compressietype kan maar liefst 40% efficiënter zijn, vooral voor bestanden die veel ActionScript- of vectorafbeeldingen bevatten.

  1. Kies Bestand > Publicatie-instellingen
  2. Selecteer de optie Film comprimeren in het gedeelte Geavanceerd van het dialoogvenster en kies LZMA in het menu.

Publiceren in de modus Direct

In de nieuwe venstermodus Direct kan inhoud met hardwareversnelling worden gebruikt aan de hand van Stage3D. (Voor Stage3D is Flash Player 11 of later vereist.)

  1. Kies Bestand > Publicatie-instellingen
  2. Selecteer Omsluitend HTML-bestand.
  3. Selecteer Direct in het menu Venstermodus.

Zie dit artikel voor meer informatie.

Ondersteuning voor de rendermodus Direct in AIR-plug-ins

Deze functie verleent de ondersteuning voor rendering voor StageVideo/Stage3D uit de modus Direct van Flash Player aan AIR-toepassingen. De nieuwe instelling renderMode=direct kan worden gebruikt in het beschrijvingsbestand van een AIR-toepassing. De modus Direct kan worden ingesteld voor AIR for Desktop, AIR for iOS en AIR for Android.

Foutopsporing in iOS via Wi-Fi

Het is nu in iOS mogelijk fouten op te sporen in AIR-toepassingen aan de hand van Wi-Fi, inclusief onderbrekingspunten, stap in en stap uit, variabele watchers en tracering.

Zie AIR Debug Launcher voor meer informatie over foutopsporing bij AIR-toepassingen.

Ondersteuning voor captive runtime voor AIR

Het dialoogvenster Publicatie-instellingen voor AIR bevat nu een optie waarmee u de AIR-runtime kunt insluiten in het toepassingspakket.
Een toepassing met een ingesloten runtime kan op elke desktop en op elk apparaat met Android of iOS worden uitgevoerd, ook als de gemeenschappelijke AIR-runtime niet geïnstalleerd is.

Aangeraden door Adobe:

Bekijk de video's over Adobe AIR met CRS-ondersteuning (Captive Runtime Support) voor mobiele apparaten en het bureaublad.

Native extensies voor AIR

U kunt native extensies opnemen in de AIR-toepassingen die u ontwikkelt in Flash Pro. Aan de hand van native extensies kunnen uw toepassingen alle functies van het doelplatform benutten, ook als de runtime zelf niet over geïntegreerde ondersteuning voor deze functies beschikt.

De nieuwste Flash Player ophalen vanuit Flash Pro

U kunt nu via het menu Help in Flash Pro rechtstreeks naar de downloadpagina van Flash Player op Adobe.nl gaan.

PNG-reeks exporteren

Gebruik deze functie om afbeeldingsbestanden te genereren waarmee Flash Pro of andere toepassingen inhoud kunnen genereren. PNG-reeksen worden bijvoorbeeld veel gebruikt in games. Met deze functie kunt u een reeks PNG-bestanden exporteren uit een bibliotheekitem of afzonderlijke filmclips, grafische symbolen of knoppen in het werkgebied.

  1. Selecteer één filmclip, knop of grafisch symbool in de bibliotheek of in het werkgebied.
  2. Klik er met de rechtermuisknop op om het contextmenu te openen.
  3. Kies PNG-reeks exporteren.
  4. Kies een locatie voor de uitvoer in het dialoogvenster Opslaan van het systeem. Klik op OK.
  5. Kies de gewenste opties in het dialoogvenster PNG exporteren. Klik op Exporteren om de PNG-reeks te exporteren.

Trefwoorden: Wat is er nieuw in Flash CS6, Flash Professional CS6 Nieuwe functies, Flash CS6 Nieuwe functies, Wat is er nieuw in Flash Professional CS6

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid