Lees dit artikel voor meer informatie over het toevoegen, instellen en aanpassen van lagen in Adobe Muse.

Opmerking:

Adobe Muse voegt geen nieuwe functies meer toe en stopt op donderdag 26 maart 2020 met de ondersteuning. Zie de pagina Einde van levensduur voor Adobe Muse voor meer informatie en assistentie.

Werken met het deelvenster Lagen in Muse

Muse bevat een deelvenster Lagen waarmee u uw pagina-elementen kunt structureren en uw site-ontwerpen kunt ordenen. In dit artikel vindt u informatie over het deelvenster Lagen en strategieën om uw projecten gemakkelijker te kunnen bijwerken.

Wat zijn lagen?

Standaard bevat elke pagina van een Muse-site minstens één benoemde laag. Met meerdere lagen kunt u specifieke gebieden of soorten inhoud op de pagina maken en bewerken zonder andere gebieden te beïnvloeden of per ongeluk andere inhoud te wijzigen. U kunt bijvoorbeeld lagen gebruiken om inhoud op de hoofdpagina en informatie op de zijbalk weer te geven in hetzelfde webontwerp. U kunt ook inhoud die zelden wordt bijgewerkt in één laag plaatsen en de inhoud die u vaak bijwerkt op een andere laag van dezelfde pagina plaatsen.

Beschouw lagen als transparante vellen die op elkaar zijn gestapeld. Als er zich geen objecten op een laag bevinden, kunt u door de laag heen kijken en andere objecten zien die zich op de lagen erachter bevinden.

Bekijk het deelvenster Lagen en neem even de tijd om te ontdekken hoe de stapelvolgorde werkt.

Deelvenster Lagen in Adobe Muse
Het deelvenster Lagen in Adobe Muse.

In het bovenstaande voorbeeld heeft Laag 1 een tekstgebied met een 1, heeft Laag 2 een tekstgebied met een 2 en heeft Laag 3 een tekstgebied met een 3.

Alle elementen die in Laag 3 (de bovenste laag) zijn geplaatst, worden boven de elementen in Laag 2 en Laag 1 weergegeven. Dit gedrag is vergelijkbaar met de stapelvolgorde die optreedt wanneer u een object selecteert en Rangschikken > Op voorgrond kiest. Behalve wanneer u elementen in specifieke lagen plaatst, worden de lagen zodanig geordend dat u de stapelvolgorde van groepen elementen kunt bepalen.

Als u de stapelvolgorde wilt wijzigen, kunt u een laag selecteren en slepen om de plaats van de laag in de volgorde van het deelvenster Lagen te wijzigen. In dit voorbeeld is Laag 1 naar de bovenkant van het deelvenster Lagen gesleept en is Laag 3 verplaatst naar de onderkant van de stapel.

De volgorde van de lagen wijzigen in Adobe Muse
Wijzig de volgorde van de lagen als u een ander element bovenaan wilt plaatsen.

Elke laag kan meerdere elementen bevatten en de stapelvolgorde van de elementen op elke laag bepaalt ook of de items boven of onder andere items op de pagina worden weergegeven.

Met lagen kunt u precies de rangschikking bepalen van pagina-elementen in uw Muse-siteprojecten.

Lagen gebruiken in Muse-sites

Zelfs als u al eerder in andere toepassingen met lagen hebt gewerkt, zoals in afbeeldingseditors, is het belangrijk dat u weet hoe lagen in Muse werken:

Lagen uitvouwen en lagen samenvouwen. Elke laag heeft een driehoekje links van de laagnaam. In samengevouwen toestand, kunt u op het driehoekje klikken om de inhoud van de laag uit te breiden en de lijst met objecten en hun stapelvolgorde in die laag voor de actieve pagina weergeven. Groepen, widgets en bepaalde widgetonderdelen hebben ook driehoeken waarop u kunt klikken om de set uit te breiden en om hun ingesloten objecten weer te geven. U kunt de objecten vergrendelen en ontgrendelen, in een andere volgorde plaatsen en toevoegen aan of verwijderen uit een groep. Voor lagen zonder objecten op de huidige pagina wordt geen driehoek weergegeven omdat deze al zijn uitgevouwen.

Objecten op stramienpagina's worden onder aan elke laag weergegeven. Stramienitems kunnen vóór objecten op documentpagina's worden weergegeven als de stramienpagina-objecten op een hogere laag worden geplaatst, maar standaard bevinden deze zich onder aan de stapelvolgorde.

Lagen omvatten alle pagina's van een site, met inbegrip van stramienen. Als u bijvoorbeeld Laag 1 verbergt terwijl u de startpagina van uw document bewerkt, wordt de inhoud van Laag 1 op alle pagina's verborgen totdat u de inhoud opnieuw weergeeft.

Het deelvenster Lagen verkennen

Het deelvenster Lagen is bijzonder krachtig en bevat veel nuttige functies die u kunnen helpen efficiënter werken. Neem de tijd om bekend te raken met de belangrijkste kenmerken:

  • Nieuwe lagen maken
  • Laagopties instellen
  • Objecten aan lagen toevoegen
  • Objecten op lagen selecteren, verplaatsen en kopiëren
  • Objecten op een andere laag plakken
  • Een laag dupliceren
  • De volgorde van lagen wijzigen
  • Lagen en objecten tonen of verbergen
  • Lagen vergrendelen of ontgrendelen
  • Lagen verwijderen
  • Lagen in een document samenvoegen

Deze eigenschappen worden verderop uitgebreid beschreven. De belangrijkste elementen van het deelvenster Lagen zijn gemarkeerd in onderstaande illustratie.

De verschillende functies van het deelvenster Lagen.
De verschillende functies van het deelvenster Lagen.

A. Doellaag B. Laag verwijderen C. Nieuwe laag D. Zoeken naar E. Help over lagen F. Vergrendelde laag G. Verborgen laag H. Zichtbare laag 

Nieuwe lagen maken

U kunt op elk gewenst moment lagen toevoegen door op de knop Nieuwe laag onder aan het deelvenster Lagen te klikken. Het aantal lagen dat een document kan bevatten, wordt alleen beperkt door de hoeveelheid RAM waarover Muse kan beschikken. De nieuwe lagen die u maakt, worden altijd boven in het deelvenster Lagen weergegeven, maar u kunt ze naar een andere positie slepen.

Ga als volgt te werk om een nieuwe laag te maken:

  1. Klik op het tabblad Lagen om het deelvenster Lagen te activeren of kies Venster > Lagen om het deelvenster Lagen te openen als dit is gesloten.
  2. Klik op de knop Nieuwe laag onder aan het deelvenster Lagen.

Opmerking: als u een nieuwe laag wilt maken en ook het dialoogvenster Laagopties wilt openen, houdt u Alt of Option ingedrukt terwijl u op de knop Nieuwe laag klikt.

Laagopties instellen

U kunt de kenmerken van lagen in het deelvenster Lagen bijwerken om de kleurcode voor die laag te wijzigen, om lagen te tonen of te verbergen, om hulplijnen weer te geven of te verbergen en om lagen te vergrendelen om te voorkomen dat ze per ongeluk worden geselecteerd en bewerkt. Ga als volgt te werk om de laagopties bij te werken:

  1. Klik met de rechtermuisknop of dubbelklik op een bestaande laag. (Of houd Alt/Option ingedrukt terwijl u op de knop Nieuwe laag klikt).
  2. Geef in het dialoogvenster Laagopties dat wordt weergegeven de laagopties op en klik vervolgens op OK.
Dialoogvenster Laagopties
Werk de instellingen in het dialoogvenster Laagopties bij.

U kunt de volgende instellingen bijwerken:

  • Naam: voer een beschrijvende naam in voor de laag om uw pagina-inhoud gemakkelijker te kunnen ordenen.
  • Kleur: wijs een kleur toe waaraan u de objecten op die laag kunt herkennen. Als u een kleur aan een laag toewijst, kunt u de lagen van de verschillende geselecteerde objecten gemakkelijker herkennen. Als deze optie is geselecteerd op de pagina, wordt voor het object de kleur van de bijbehorende laag weergegeven in het selectiekader, de selectiehandgrepen, tekstkaders en de randen van afbeeldingskaders. De laagkleur wordt niet weergegeven wanneer de selectie van objecten wordt opgeheven.
  • Laag tonen: selecteer deze optie om de laag zichtbaar te maken. Als u deze optie selecteert, activeert u hetzelfde gedrag aan als wanneer u op het oogpictogram klikt om de laag zichtbaar te maken in het deelvenster Lagen.
  • Laag vergrendelen: selecteer deze optie om te voorkomen dat de objecten op de laag worden gewijzigd.

Objecten aan lagen toevoegen

Elk nieuw object wordt op de doellaag geplaatst, dit is de laag met de vet gedrukte naam en het driehoekje in de rechterbovenhoek van de laag in het deelvenster Lagen. Wijs een bepaalde laag aan als doellaag door erop te klikken.

Ga op een of meerdere van de volgende manieren te werk om objecten aan de doellaag toe te voegen:

  • Nieuwe objecten maken met de tool Tekst of de tool Rechthoek.
  • Tekst of afbeeldingen importeren, plaatsen of plakken.
  • Objecten op andere lagen selecteren en deze naar de nieuwe laag verplaatsen.

U kunt geen nieuwe objecten tekenen of plaatsen op een verborgen of vergrendelde laag. Wanneer u een tekentool of de tool Tekst selecteert of een bestand plaatst wanneer de doellaag is verborgen of vergrendeld, verandert de aanwijzer in een pictogram van een doorgestreept potlood wanneer de aanwijzer in de ontwerpweergave op de pagina wordt geplaatst. In dat geval moet u de doellaag tonen of ontgrendelen of een zichtbare, niet-vergrendelde doellaag activeren.

Als u Bewerken > Plakken kiest wanneer de doellaag is verborgen of vergrendeld, wordt er een waarschuwingsbericht weergegeven waarin u kunt kiezen of u de doellaag wilt tonen of ontgrendelen.

Wanneer u op een laag in het deelvenster Lagen klikt om de laag te activeren, verschijnt er in de rechterbovenhoek van de laag waarop u hebt geklikt een driehoekje, wordt de naam van de laag vet weergegeven en wordt de laag ook gemarkeerd om aan te geven dat het de doellaag is.

Objecten op lagen selecteren, verplaatsen en kopiëren

U kunt standaard elk object op elke laag selecteren. In het deelvenster Lagen markeren gekleurde vierkantjes helemaal rechts lagen die geselecteerde objecten bevatten. Een klein vakje geeft aan dat ten minste één object in die laag is geselecteerd en een groot vierkant aangeeft dat alle objecten in die laag momenteel zijn geselecteerd. Aan de hand van de selectiekleur van de laag kunt u een objectlaag herkennen. Als u wilt voorkomen dat objecten op een bepaalde laag worden geselecteerd, moet u de laag vergrendelen (of verbergen).

  • Als u afzonderlijke objecten in een laag wilt selecteren, klikt u op het driehoekje links van de laagnaam om de laag uit te vouwen en selecteert u het doelelement in de lijst. U kunt het doelobject ook naar een andere locatie slepen zonder het te selecteren.
  • Als u alle objecten op een specifieke laag wilt selecteren, klikt u op het vierkantje rechts van de laagnaam.
  • Als u objecten wilt verplaatsen of kopiëren naar een andere laag, gebruikt u de selectietool om een of meer objecten op een pagina of stramienpagina te selecteren. Sleep in het deelvenster Lagen het gekleurde vierkantje rechts van de lijst met lagen om de geselecteerde objecten naar de andere laag te verplaatsen.

Objecten op een andere laag plakken

De optie Lagen behouden bij plakken is van invloed op de manier waarop objecten die zijn geplakt vanaf andere locaties, op elkaar reageren.

Als de optie Lagen behouden bij plakken is ingeschakeld, behouden objecten die zijn geknipt of geplakt vanaf andere lagen, hun laagtoewijzingen wanneer ze op een nieuwe pagina of positie worden geplakt. Als u een object op een pagina plakt die niet dezelfde lagen heeft als de pagina vanwaar het object is gekopieerd, voegt Muse de laagnaam van het object toe aan het deelvenster Lagen van het tweede document en wordt het object op de bijbehorende laag geplakt.

Als u de optie Lagen behouden bij plakken niet selecteert, worden objecten die vanaf andere lagen worden geknipt of gekopieerd, samen op de huidige doellaag geplakt.

  1. Controleer of de optie Lagen behouden bij plakken niet is geselecteerd in het contextmenu Lagen dat wordt weergegeven wanneer u met de rechtermuisknop op een willekeurige plaats in het deelvenster klikt.
  2. Selecteer objecten en kies Bewerken > Kopiëren of Bewerken > Knippen.
  3. Klik in het deelvenster Lagen op een andere laag om van die laag de doellaag te maken.
  4. Kies Bewerken > Plakken.

Een laag dupliceren

Wanneer u een laag dupliceert, kopieert u ook de inhoud en instellingen van deze laag. De gedupliceerde laag komt in het deelvenster Lagen boven de oorspronkelijke laag te staan.

Voer in het deelvenster Lagen een van de volgende handelingen uit:

  • Selecteer de laagnaam en kies Laag dupliceren in het contextmenu Lagen dat wordt weergegeven wanneer u met de rechtermuisknop op een laag (of op geselecteerde lagen) klikt.
  • Sleep de laagnaam naar de knop Nieuwe laag.

De volgorde van lagen wijzigen

U kunt de stapelvolgorde van de lagen in uw document wijzigen door de lagen in de lijst van het deelvenster Lagen opnieuw te rangschikken. Door lagen opnieuw te rangschikken, wijzigt u de volgorde van lagen op elke pagina op de site, niet alleen op de huidige pagina in de ontwerpweergave.

U kunt ook de stapelvolgorde van objecten binnen een laag wijzigen door de positie van objecten in een laag te wijzigen.

Sleep in het deelvenster Lagen een laag omhoog of omlaag in de lijst. U kunt ook meerdere lagen selecteren en slepen.

Lagen en objecten tonen of verbergen

U kunt lagen te allen tijde tonen of verbergen en u kunt objecten op een laag tonen of verbergen. Verborgen lagen en objecten kunnen niet worden bewerkt en verschijnen niet op het scherm in de ontwerpweergave, in voorvertoningen, in de publicatieweergave of na het exporteren van websites. Het kan nuttig zijn lagen te verbergen wanneer u een van de volgende handelingen moet uitvoeren:

  • Verberg objecten wanneer u sites met een responsieve lay-out ontwerpt. U kunt objecten desgewenst verbergen als u een pagina voor verschillende apparaten op één canvas ontwerpt. Zo kunt u bijvoorbeeld een traditioneel menu verbergen en in plaats daarvan een accordeonstructuur gebruiken bij het opmaken van een site voor mobiele telefoons. Zie Objecten in een responsieve lay-out tonen of verbergen als u wilt weten hoe u objecten in een responsieve lay-out kunt verbergen.
  • Delen van een document verbergen die niet in het definitieve document mogen komen te staan.
  • Andere versies van een document verbergen.
  • De weergave van een document vereenvoudigen, zodat andere delen in het document gemakkelijker kunnen worden bewerkt.
  • Voorkomen dat een laag wordt geëxporteerd.
  • De weergave op het scherm versnellen wanneer een laag afbeeldingen met een hoge resolutie bevat.

Opmerking: Verborgen lagen of verborgen pagina-elementen worden niet geëxporteerd. De pagina wordt echter nog wel weergegeven in de ontwerpweergave als de elementen aanwezig zijn. Een verborgen tekstkader duwt onderliggende elementen bijvoorbeeld nog steeds verder omlaag op de pagina. Zo voorkomt u dat pagina-inhoud wordt verplaatst als u lagen toont of verbergt.

Voer een van de volgende handelingen uit om lagen te verbergen of te tonen:

  • U kunt telkens één laag tegelijk tonen of verbergen door in het deelvenster Lagen op het vierkantje links van de laagnaam te klikken om het oogpictogram voor deze laag te verbergen of weer te geven.
  • Als u afzonderlijke objecten op een laag wilt weergeven of verbergen, klikt u op het driehoekje links van de laagnaam om alle objecten op een laag weer te geven en klikt u vervolgens op het oogpictogram om het object weer te geven of te verbergen.

Lagen vergrendelen of ontgrendelen

Door lagen te vergrendelen, voorkomt u dat ze per ongeluk worden gewijzigd. Naast een vergrendelde laag in het deelvenster Lagen staat een pictogram van een doorgestreept potlood. De objecten op vergrendelde lagen kunnen niet rechtstreeks worden geselecteerd of bewerkt. Als objecten op vergrendelde lagen echter kenmerken hebben die indirect kunnen worden bewerkt, worden deze wel gewijzigd. Als u bijvoorbeeld een tintstaal bewerkt, zullen de objecten op vergrendelde lagen waarop het tintstaal is toegepast, overeenkomstig worden aangepast.

U kunt het deelvenster Lagen ook gebruiken om objecten in een laag te vergrendelen of te ontgrendelen. Als u lagen wilt openen en sluiten, doet u het volgende:

  • Als u één laag wilt vergrendelen of ontgrendelen, klikt u in het deelvenster Lagen op een vakje in de tweede kolom van links om de laag weer te geven (vergrendelen) of te verbergen (ontgrendelen).

Lagen verwijderen

Onthoud dat elke laag op elke pagina van een site wordt weergegeven. Voordat u een laag verwijdert, is het wellicht verstandig om eerst alle andere lagen te verbergen en vervolgens elke pagina van de site te bekijken om te controleren of de resterende objecten veilig kunnen worden verwijderd. Als u zeker weet dat u een laag wilt verwijderen, gaat u als volgt te werk:

  • Als u een laag wilt verwijderen, sleept u de laag uit het deelvenster Lagen naar het pictogram Geselecteerde laag verwijderen (prullenbak) rechtsonder in het deelvenster Lagen of klikt u met de rechtermuisknop en kiest u Laag verwijderen in het contextmenu.
  • Als u meerdere lagen wilt verwijderen, houdt u Ctrl of Command ingedrukt terwijl u op de lagen klikt om deze te selecteren. Vervolgens sleept u de lagen van het deelvenster Lagen naar het pictogram Geselecteerde laag verwijderen (prullenbak) of klikt u met de rechtermuisknop en kiest u Lagen verwijderen in het contextmenu.
  • U kunt een object op een laag verwijderen door het object in het deelvenster Lagen te selecteren en op het pictogram Verwijderen te klikken.

Lagen in een document samenvoegen

U kunt het aantal lagen in een site verminderen zonder een van de objecten te verwijderen door lagen samen te voegen. Wanneer u lagen samenvoegt, worden alle objecten op de geselecteerde lagen naar de doellaag verplaatst. Van alle lagen die u samenvoegt, blijft alleen de doellaag in het document staan. De andere geselecteerde lagen worden verwijderd. U kunt een site ook afvlakken door alle lagen samen te voegen.

Opmerking: Als u lagen met allerlei verschillende pagina-objecten en stramienpagina-elementen samenvoegt, worden de stramienpagina-elementen naar achteren verplaatst op de resulterende samengevoegde laag.

  1. Selecteer in het deelvenster Lagen een willekeurige combinatie van lagen. Zorg ervoor dat ook de laag is geselecteerd die u als doellaag wilt gebruiken. Als u de site tot één laag wilt samenvoegen, selecteert u alle lagen in het deelvenster.
  2. Klik met de rechtermuisknop op het deelvenster Lagen en kies Lagen samenvoegen in het contextmenu.

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid