Po dokonaniu optymalizacji, grafikę lub dokument można eksportować (lub zapisać, w zależności od oryginalnego typu pliku).

Możesz eksportować (albo w niektórych przypadkach, zapisać) dokument jako pojedynczy obraz GIF, JPEG lub w innym formacie pliku graficznego. Możesz także eksportować cały dokument jako plik HTML i powiązane pliki obrazów, wybrane plasterki lub określony obszar. Dodatkowo, możesz eksportować stany i warstwy Fireworks do osobnych plików obrazu.

Domyślne miejsce, do którego Fireworks eksportuje pliki, jest określone przez:

  1. Bieżące preferencje eksportowania dokumentu, które zostały zdefiniowane, jeśli dokument był kiedykolwiek eksportowany, a następnie zapisany jako plik PNG.

  2. Bieżące miejsce eksportu/zapisu, które zostało zdefiniowane, gdy dokonywano przeszukiwania rozpoczynającego się w domyślnej lokalizacji, określonej w oknie dialogowym Zapisz, Zapisz jako lub Eksportuj.

  3. Lokalizacja bieżącego pliku

  4. Domyślne miejsce, w którym są zapisywane nowe dokumenty lub obrazy w twoim systemie operacyjnym

    Dla kontrastu, domyślne miejsce, w jakim Fireworks zapisuje dokument, jest zależne do kilku czynników. Więcej informacji można znaleźć w sekcji Zapisywanie plików Fireworks.

Eksportowanie stron w formie plików obrazów

  1. Wybierz polecenie Plik > Eksportuj.

  2. Wybierz położenie dla eksportowanych plików.

  3. Wykonaj jedną z poniższych czynności:

    • Wybierz opcję Tylko obrazy z menu wyskakującego Eksportuj, a następnie zaznacz lub anuluj zaznaczenie pola wyboru Tylko bieżąca strona. Strony zostaną wyeksportowane w formacie obrazu ustawionym w panelu Optymalizacja.

    • Wybierz polecenie Strony do plików z wyskakującego menu Eksportuj oraz opcję Obrazy z wyskakującego menu Eksportuj jako. Strony zostaną wyeksportowane w formacie obrazu ustawionym w panelu Optymalizacja.

    • Wybierz polecenie Strony do plików wyskakującym menu Eksportuj i opcję Fireworks PNG w wyskakującym menu Eksportuj jako. Każda strona zostanie wyeksportowana jako oddzielny plik PNG, zgodny wstecz z programem Fireworks 8.

    Uwaga:

    Jeśli chcesz wyeksportować wszystkie strony w wybranym formacie, zaznacz wszystkie strony, a następnie zoptymalizuj ustawienia.

Eksportowanie pojedynczego obrazu

Jeśli pracujesz z istniejącym obrazem, który został otwarty w Fireworks, raczej możesz go zapisać niż eksportować. Więcej informacji można znaleźć w sekcji Zapisywanie dokumentów w innych formatach.

Uwaga:

Aby eksportować tylko niektóre obrazy w dokumencie, musisz najpierw pociąć na plasterki twój dokument, a następnie eksportować tylko wybrane plasterki.

  1. W panelu Optymalizacja wybierz format pliku i ustaw opcje dla danego formatu.

  2. Wybierz polecenie Plik > Eksportuj.

  3. Wybierz miejsce do eksportu pliku obrazu.

    Dla grafiki internetowej najlepszym miejscem jest folder w lokalnej witrynie.

  4. Wpisz nazwę pliku bez rozszerzenia. Rozszerzenie zostanie dodane podczas eksportowania, w zależności od typu pliku.

  5. Z wyskakującego menu Eksportuj wybierz opcję Tylko obrazy.

  6. Kliknij Zapisz.

Eksportowane dokumentu pociętego na plasterki

Domyślnie, kiedy eksportujesz pocięty dokument Fireworks, zostaje eksportowany plik HTML z powiązanymi obrazami. Eksportowany plik HTML może być oglądany w przeglądarce internetowej lub zostać importowany do innej aplikacji do dalszej edycji.

Przed eksportowaniem upewnij się, czy wybrałeś odpowiedni styl HTML z okna dialogowego Ustawienia HTML. Zobacz Ustawianie opcji eksportowania HTML.

Eksportowanie wszystkich plasterków

  1. Wybierz polecenie Plik > Eksportuj.

  2. Przejdź do folderu na dysku twardym, do którego ma zostać wyeksportowany plik.

  3. Z menu Eksportuj wybierz opcję HTML i Obrazy.

  4. Wpisz nazwę pliku w oknie Nazwa pliku (Windows) lub Save As (Mac OS).

  5. Z wyskakującego menu HTML wybierz opcję Eksportuj plik HTML.

  6. Z wyskakującego menu Plasterki wybierz opcję Eksportuj plasterki.

  7. (Opcjonalne) Wybierz opcję Wyślij obrazy do podfolderu.

  8. Kliknij Zapisz.

Eksportowanie wybranych plasterków

  1. Kliknij z przyciśniętym Shift, aby zaznaczyć wiele plasterków.

  2. Wybierz polecenie Plik > Eksportuj.

  3. Wybierz lokalizację, w której mają zostać zapisane wyeksportowane pliki, np. folder w lokalnym serwisie WWW.

  4. Z wyskakującego menu Eksportuj wybierz opcję HTML i Obrazy.

  5. Wpisz nazwę pliku bez rozszerzenia. Rozszerzenie zostanie dodane podczas eksportowania, w zależności od typu pliku.

    Jeśli eksportujesz wiele plasterków, Fireworks używa nazwy, którą wpisałeś jako nazwę główną dla wszystkich grafik, za wyjątkiem tych, które mają własne nazwy określone w panelu Warstwy lub w inspektorze Właściwości.

  6. Z wyskakującego menu Plasterki wybierz opcję Eksportuj plasterki.

  7. Aby wyeksportować tylko zaznaczone wcześniej plasterki, wybierz opcję Tylko zaznaczone plasterki i upewnij się, że opcja Dołącz obszary bez plasterków nie jest zaznaczona.

  8. Kliknij Zapisz.

Aktualizacja plasterka

Jeśli dokument zawierający plasterki został już wyeksportowany, a następnie dokonano w nim zmian w programie Fireworks, można zaktualizować tylko obraz lub plasterek, który uległ zmianie. Aby ułatwić lokalizację nowych plasterków, należy nadawać im niestandardowe nazwy.

  1. Ukryj plasterek i edytuj obszar znajdujący się pod nim.

  2. Pokaż ponownie plasterek.

  3. Kliknij plasterek prawym przyciskiem myszy (Windows) lub kliknij przytrzymując naciśnięty klawisz Control (Mac OS) i wybierz opcję Eksportuj wybrany plasterek.

  4. Zaznacz ten sam folder, co dla plasterka źródłowego wykorzystując tę samą nazwę bazową, a następnie kliknij przycisk Zapisz.

  5. Kliknij OK, kiedy pojawi się pytanie o nadpisanie istniejącego pliku.

    Uwaga:

    Unikaj w Fireworks zmiany wielkości plasterka poza oryginalną wielkość eksportu, ponieważ możesz to wywołać niespodziewane następstwa w dokumencie HTML po uaktualnieniu plasterków.

Eksportowanie animacji

Po utworzeniu i zoptymalizowaniu animacji, jest ona gotowa do eksportu. Możesz wyeksportować animację do jednego z następujących typów plików:

Animowane pliki GIF

Pliki te dają najlepsze rezultaty w grafikach typu klipart i rysunkach.

Pliki Flash SWF lub Fireworks PNG (eksportowanie nie jest wymagane)

Wyeksportuj animację w formacje SWF, aby zaimportować ją do programu Flash. Możesz też pominąć etap eksportowania i zaimportować plik Fireworks PNG bezpośrednio do programu Flash. Przy użyciu tej bezpośredniej metody możesz importować wszystkie warstwy i stany animacji, a następnie edytować je w programie Flash. Zobacz Praca z programem Flash.

Wiele plików

Wyeksportowanie stanów lub warstw animacji do postaci kilku plików jest przydatne, gdy na różnych warstwach znajduje się wiele symboli dla tego samego obiektu. Na przykład możesz eksportować reklamówkę w formie banera jako wiele plików rozbijając ją na pojedyncze elementy. Zobacz Eksportowanie stanów lub warstw jako wiele plików.

Jeśli dokument zawiera więcej niż jedną animację, możesz wstawić plasterki, aby eksportować każdą z nich z innymi ustawieniami, takimi jak zapętlanie czy opóźnienie klatki.

Eksportowanie animowanego pliku GIF

  1. Wybierz Zaznacz > Odznacz, aby odznaczyć wszystkie plasterki i obiekty, a następnie zaznacz Animowany GIF jako format pliku w panelu Optymalizacja.

  2. Wybierz polecenie Plik > Eksportuj.

  3. Wpisz nazwę dla pliku i wybierz miejsce docelowe.

  4. Kliknij Zapisz.

Eksportowanie wielu animowanych plików GIF z różnymi ustawieniami animacji

  1. Kliknij animację z wciśniętym Shift, aby zaznaczyć je wszystkie.

  2. Wybierz Edycja > Wstaw > Plasterek prostokątny lub Plasterek wielokątny.

  3. W polu komunikatu kliknij opcję Wiele.

  4. Wybierz oddzielnie każdy plasterek i użyj panelu Stany, aby ustawić różne ustawienia animacji dla każdego z nich.

  5. Wybierz wszystkie plasterki, które chcesz animować, a następnie wskaż w panelu Optymalizacja Animowany GIF jako format pliku.

  6. Kliknij plasterek prawym przyciskiem myszy (Windows) lub kliknij przytrzymując naciśnięty klawisz Control (Mac OS) i wybierz opcję Eksportuj wybrany plasterek, aby wyeksportować poszczególne plasterki. W oknie dialogowym Eksportuj wpisz nazwę dla pliku, określ jego miejsce docelowe i kliknij Zapisz.

Eksportowanie stanów lub warstw jako wiele plików

Program Fireworks może eksportować każdą warstwę lub stan w dokumencie jako osobny plik obrazu, przy użyciu ustawień optymalizacji określonych w panelu Optymalizacja. Nazwa warstwy lub stanu wpływa na nazwę każdego eksportowanego pliku. Ta metoda eksportu jest czasami używana dla eksportowanych animacji.

  1. Wybierz polecenie Plik > Eksportuj.

  2. Wpisz nazwę pliku w wybierz folder docelowy.

  3. W wyskakującym menu Eksportuj wybierz opcję:

    Stany do plików

    Eksportuje stany jako wiele plików.

    Warstwy na pliki

    Eksportuje warstwy jako wiele plików.

    Uwaga: Eksportowane są wszystkie warstwy w bieżącym stanie.

  4. Aby automatycznie kadrować każdy wyeksportowany obraz uwzględniając tylko obiekty w stanach, wybierz opcję Przytnij obrazy. Aby uwzględnić cały obszar roboczy (wraz z pustymi obszarami pomiędzy obiektami), anuluj zaznaczenie tej opcji.

  5. Kliknij Zapisz.

Eksportowanie obszaru z dokumentu

  1. Z panelu Narzędzia wybierz narzędzie Eksport obszaru .

  2. Przeciągnij ramkę zaznaczenia, która określa, jaka część dokumentu ma zostać eksportowana.

    Uwaga:

    Możesz ustawiać pozycję ramki zaznaczenia podczas przeciągania jej. Przytrzymując wciśnięty przycisk myszki, naciśnij i przytrzymaj Spację, a następnie przeciągnij ramkę zaznaczenia w inne miejsce kanwy. Zwolnij Spację, aby kontynuować przeciąganie ramki zaznaczenia.

    Kiedy zwolnisz przycisk myszki, obszar eksportu pozostanie zaznaczony.

  3. W razie potrzeby zmień wielkości obszaru eksportowania:

    • Aby zmienić rozmiar ramki obszaru eksportowania z zachowaniem jej proporcji, naciśnij klawisz Shift i przeciągnij uchwyt.

    • Aby zmienić rozmiar ramki względem punktu środkowego, przeciągnij uchwyt naciskając klawisz Alt (Windows) lub Option (Mac OS).

    • Aby zachować proporcje i zmienić rozmiar ramki względem punktu środkowego, przeciągnij uchwyt naciskając klawisze Alt-Shift (Windows) lub Option-Shift (Mac OS).

  4. Podwójne kliknij wewnątrz ramki zaznaczenia eksportowanego obszaru, aby przejść do Podglądu obrazu.

  5. Dostosuj ustawienia w Podglądzie obrazu i kliknij Eksportuj.

  6. Wpisz nazwę pliku w wybierz folder docelowy.

  7. W wyskakującym menu Eksportuj zaznacz Tylko obrazy.

  8. Kliknij Zapisz.

    Uwaga:

    Aby anulować bez eksportowania, kliknij podwójnie poza ramką zaznaczenia eksportowanego obszaru, naciśnij Escape lub zaznacz inne narzędzie.

Eksportowanie plików HTML

Jeśli nie zostaną określone inne ustawienia, podczas eksportowania pociętego na plasterki dokumentu Fireworks wyeksportowany zostanie plik HTML i powiązane z nim obrazy. Aby definiować, w jaki sposób Fireworks eksportuje HTML, użyj okna dialogowego Ustawiania HTML.

Fireworks generuje czysty HTML, który może być odczytany w większości przeglądarek internetowych i edytorów HTML. Domyślnie podczas eksportowania jest używane kodowanie UTF-8.

Jest wiele możliwość eksportowania Fireworks HTML:

  • Eksportuj plik HTML, który może być potem otwarty do edycji przy pomocy innego edytora HTML.

  • Eksportuj każdą stronę w pliku Fireworks do oddzielnego pliku HTML.

  • Kopiuj kod HTML do Schowka w Fireworks, a następnie wklej go bezpośrednio do istniejącego dokumentu HTML.

  • Eksportuj plik HTML, otwórz go w edytorze HTML, ręcznie kopiuj części kodu z pliku i wklej go do innego dokumentu HTML.

  • Eksportuj pliki HTML w postaci warstw CSS (Cascading Style Sheet) oraz XHTML.

  • Użyj polecenia Uaktualnij HTML, aby dokonać zmian w utworzonym wcześniej pliku HTML.

    Fireworks pozwala na eksportowanie HTML do formatów Standardowy, Dreamweaver, Microsoft® FrontPage® i Adobe GoLive®.

    Uwaga: Adobe Dreamweaver jest ściśle zintegrowany z Fireworks. Fireworks w inny sposób dokonuje eksportu HTML do Dreamweaver niż do innych edytorów HTML. W przypadku eksportowania plików Fireworks HTML do programu Dreamweaver patrz sekcja Praca z programem Dreamweaver.

    Ta metoda eksportu Fireworks HTML do innych aplikacji jest idealna, jeśli pracujesz w grupie. Ta metoda dzieli obieg pracy na części, dzięki czemu jedna osoba zajmuje się danym zadaniem w jednej aplikacji, po czym inna osoba może go przejąć, używając innego programu.

Dołączanie komentarzy do eksportowanego pliku HTML

Komentarze Fireworks HTML zaczynają się od ciągu <!-- i kończą ciągiem --> . Wszystko między tymi dwoma znacznikami nie jest interpretowane jako kod HTML czy JavaScript.

  1. Przed eksportowaniem wybierz opcję Dołącz komentarze HTML w zakładce Ogólne okna dialogowego Ustawienia HTML.

Wyniki eksportowania

Podczas eksportowania lub kopiowania pliku HTML z programu Fireworks, generowane są następujące elementy:

  • Jeśli dokument zawiera elementy interaktywne, kod HTML niezbędny do połączenia pociętych obrazów i kodu JavaScript. Fireworks HTML zawiera łącza do eksportowanych obrazów i ustawia kolor tła strony internetowej na kolor kanwy.

  • Jeden lub więcej plików obrazów, w zależności od tego, ile plasterków znajduje się w twoim dokumencie i jak wiele stanów posiadają twoje przyciski.

  • Plik o nazwie spacer.gif, jeśli to konieczne. Spacer.gif jest przezroczystym plikiem GIF o rozmiarze 1x1 pikseli, którego program Fireworks używa do wstawiania odstępów, gdy pocięte na plasterki obrazy zostają na nowo połączone w tabeli HTML. Możesz wybrać, czy Fireworks ma eksportować plik odstępu.

  • Podczas eksportowania menu wyskakujących, eksportowane są następujące elementy: pliki mm_css_menu.js i .css zawierające kod CSS menu wyskakującego. Jeśli twoje wyskakujące menu zawiera podmenu, zostaje eksportowane również arrows.gif.

  • Jeśli eksportujesz lub kopiujesz HTML do Dreamweaver, są tworzone pliki notek, które ułatwiają integrację Fireworks z Dreamweaver. Te pliki mają rozszerzenie .mno.

Eksportowanie plików Fireworks HTML

  1. Wybierz polecenie Plik > Eksportuj.

  2. Przejdź do folderu na dysku twardym, do którego ma zostać wyeksportowany plik.

  3. Z menu Eksportuj wybierz opcję HTML i Obrazy.

  4. Kliknij przycisk Opcje i wybierz edytor HTML z wyskakującego menu Style HTML w zakładce Ogólne okna dialogowego Ustawienia HTML. Jeśli poszukiwany edytor HTML nie jest wymieniony na liście, wybierz polecenie Ogólne.

    Uwaga:

    Należy pamiętać o wybraniu własnego edytora HTML jako stylu HTML. W przeciwnym razie interaktywne elementy, takie jak przyciski i najazdy, nie będą dobrze działały po zaimportowaniu do edytora HTML.

  5. Kliknij OK.

  6. Z wyskakującego menu HTML wybierz opcję Eksportuj plik HTML.

  7. Jeśli twój plik zawiera plasterki, wybierz Eksportuj plasterki z wyskakującego menu Plasterki.

  8. Aby zapisać obrazy w oddzielnym folderze, wybierz opcję Wyślij obrazy do podfolderu. Możesz wybrać określony folder lub użyć domyślnego folderu obrazów w programie Fireworks.

  9. Jeśli eksportujesz wielostronicowy dokument Fireworks, usuń zaznaczenie pola wyboru Tylko bieżąca strona, aby eksportować wszystkie strony do oddzielnych dokumentów HTML.

  10. Kliknij Zapisz.

    Po wyeksportowaniu przez program Fireworks, pliki znajdą się na twardym dysku. Obrazy i plik HTML są generowane w miejscu, które określiłeś w oknie dialogowym Eksportuj.

Kopiowanie kodu HTML do Schowka

Możesz kopiować kod HTML do Schowka w programie Fireworks na dwa różne sposoby. Możesz użyć polecenia Kopiuj kod HTML lub skorzystać z opcji Kopiuj do schowka w oknie dialogowym Eksportuj. Kod HTML można następnie wkleić do dokumentu w wybranym edytorze HTML.

Podczas określania sposobu, w jaki kod Fireworks HTML ma zostać umieszczony w innych aplikacjach, należy rozważyć następujące wady kopiowania kodu HTML do Schowka:

  • Brak opcji zapisywania plików do podfolderów. Musisz przechowywać je w tym samym folderze, w którym wklejałeś i kopiowałeś HTML. Wyjątkiem jest HTML kopiowany do Dreamweaver.

  • Wszystkie łącza i ścieżki używane w wyskakujących menu Fireworks zostaną odwzorowane na twój twardy dysk. HTML kopiowany do Dreamweaver jest wyjątkiem.

  • Jeśli używasz edytora HTML innego niż Dreamweaver czy Microsoft FrontPage, kod JavaScript połączony z przyciskami, zachowaniami i obrazami najazdu jest kopiowany, ale może nie działać poprawnie.

    Jeśli sprawia to problem, użyj opcje Eksportuj HTML zamiast kopiowania HTML do Schowka.

    Uwaga: Przed kopiowaniem kodu HTML upewnij się, czy wybrałeś odpowiedni styl HTML i czy zaznaczyłeś opcję Dołącz komentarze HTML na karcie Ogólne w oknie dialogowym Ustawienia HTML.

Kopiowanie kodu Fireworks HTML przy użyciu opcji Kopiuj kod HTML

  1. Wybierz Edycja > Kopiuj kod HTML.

  2. Postępuj zgodnie z instrukcjami wyświetlanymi w kreatorze. Gdy pojawi się takie pytanie, określ folder, który będzie docelowy dla eksportowanych obrazów. Musi to być miejsce, w którym znajduje się twój plik HTML.

    Uwaga:

    Jeśli planujesz wklejanie kodu HTML do programu Dreamweaver, miejsce eksportu obrazów nie gra roli, o ile znajdują się one w tej samej witrynie Dreamweaver, co plik HTML, do którego chcesz wkleić kod.

Kopiowanie kodu Fireworks HTML przy użyciu okna dialogowego Eksportuj

  1. Wybierz polecenie Plik > Eksportuj.

  2. W oknie dialogowym Eksportuj, określ folder jako miejsce docelowe dla eksportowanych obrazów. Musi to być to samo miejsce, w którym znajduje się twój plik HTML.

    Uwaga:

    Jeśli planujesz wklejanie kodu HTML do Dreamweaver, to miejsce eksportu obrazów nie gra roli, jak długo są one w tej samej witrynie Dreamweaver, w której jest plik HTML, do którego chcesz wkleić swój kod.

  3. Z wyskakującego menu Eksportuj wybierz opcję HTML i Obrazy.

  4. Z menu wyskakującego HTML wybierz opcję Kopiuj do Schowka.

  5. Jeśli plik zawiera plasterki, z wyskakującego menu Plasterki wybierz polecenie Eksportuj plasterki.

  6. Kliknij przycisk Opcje, wybierz edytor HTML z okna dialogowego Ustawienia HTML i kliknij OK.

  7. Kliknij Zapisz.

Wklejanie kodu HTML skopiowanego z programu Fireworks do dokumentu HTML

  1. W twoim edytorze HTML otwórz istniejący dokument HTML lub utwórz nowy. Zapisz dokument w tym samym miejscu, do jakiego eksportowałeś twoje obrazy.

    Uwaga:

    Zapisywanie pliku HTML w tym samym miejsce, w jakim znajdują się eksportowane obrazu, nie jest konieczne, jeśli używasz programu Dreamweaver. Jeśli eksportujesz obrazy z programu Fireworks do witryny Dreamweaver i zapisujesz plik HTML w obrębie tej witryny, program Dreamweaver automatycznie poprawi ścieżki do połączonych obrazów.

  2. Wyświetl kod HTML i umieść punkt wstawiania pomiędzy znacznikami <BODY>.

    Uwaga:

    Kod HTML skopiowany z programu Fireworks nie zawiera otwierających oraz zamykających tagów <HTML><BODY>.

  3. Wklej kod HTML.

    Jeśli to możliwe, podczas kopiowania do Schowka wyeksportuj obrazy do docelowej lokalizacji na stronie internetowej. Fireworks używa względnych adresów URL, więc jeśli HTML lub obrazy zmienią miejsce, łącza URL przestają działać.

Kopiowanie kodu z eksportowanego pliku Fireworks i wklejanie go do innego dokumentu HTML

  1. Otwórz plik Fireworks HTML, który eksportowałeś, w edytorze HTML.

  2. Podświetl potrzebny kod i kopiuj go do Schowka

  3. Otwórz istniejący dokument HTML lub utwórz nowy.

  4. Wklej kod do nowego pliku HTML. Nie musisz kopiować tagów <HTML><BODY>, ponieważ są one już umieszczone w docelowym dokumencie HTML.

    Jeśli wybierzesz Dołącz komentarze HTML w oknie dialogowym Ustawienia HTML w programie Fireworks, postępuj zgodnie z instrukcjami w komentarzach, aby kopiować i wklejać kod do odpowiednich lokacji.

  5. Jeśli dokument Fireworks zawiera elementy interaktywne, skopiuj kod JavaScript.

    Kod JavaScript jest otoczony tagami <SCRIPT> i jest umieszczony w sekcji <HEAD> dokumentu. Skopiuj i wklej całą sekcję <SCRIPT>, chyba że docelowy dokument zawiera już sekcję <SCRIPT>. W takim przypadku powinieneś skopiować i wkleić samą zawartość sekcji <SCRIPT> do istniejącej już sekcji <SCRIPT>, uważając aby nie nadpisać istniejącej zawartości. Upewnij się również, czy nie duplikujesz funkcji JavaScript w sekcji <SCRIPT> po wklejeniu kodu.

Aktualizacja wyeksportowanego kodu HTML

Aktualizacja umożliwia dokonywanie zmian w dokumencie Fireworks HTML, który został wcześniej wyeksportowany. Funkcja ta jest przydatna, gdy należy zaktualizować jedynie część dokumentu.

Uwaga:

Funkcja Uaktualnij HTML działa inaczej w dokumentach Dreamweaver, niż w innych dokumentach HTML. Więcej informacji można znaleźć w sekcji Praca z programem Dreamweaver.

Kiedy uaktualniasz , możesz zastąpić tylko zmienione obrazy lub nadpisać cały kod i obrazy. Jeśli wybierzesz zastąpienie zmienionych obrazów, wszystkie dokonane zmiany pliku HTML uczynione poza Fireworks, zostają niezmienione.

Uwaga:

Aby dokonać dużych zmian w wyglądzie dokumentu, dokonaj ich w Fireworks, a następnie ponownie eksportuj plik HTML.

  1. Wybierz Plik > Uaktualnij HTML.

  2. Wybierz plik, który ma zostać zaktualizowany.

  3. Kliknij przycisk Otwórz.

  4. Wykonaj jedną z poniższych czynności:

    • Jeśli nie został znaleziony żaden HTML wygenerowany przez Fireworks, kliknij OK, aby wstawić nowy HTML na końcu dokumentu.

    • Jeśli został odnaleziony HTML wygenerowany przez Fireworks, wybierz jedną z poniższych możliwości i kliknij OK:

      Zastąp obrazy i ich HTML

      Zastępuje wcześniejszy kod Fireworks HTML

      Uaktualnij tylko obrazy

      Nadpisuje tylko obrazy

  5. Jeśli pojawia się okno dialogowe Wybierz folder obrazów, wybierz folder i kliknij Otwórz.

Eksportowanie warstw CSS

Warstwy CSS mogą być położone jedna na drugiej. W Fireworks zwykłe wyjście HTML nie nawarstwia się.

  1. Wybierz polecenie Plik > Eksportuj.

  2. Wpisz nazwę pliku w wybierz folder docelowy.

  3. Z menu Eksportuj wybierz opcję CSS i Obrazy.

    • Aby eksportować tylko bieżący stan, wybierz Tylko bieżący stan.

    • Aby eksportować tylko bieżącą stronę, wybierz Tylko bieżącą stronę.

    • Aby wybrać folder dla podobrazów, wybierz opcję Wyślij obrazy do podfolderu.

  4. Kliknij Opcje, aby określić właściwości strony HTML.

  5. Kliknij opcję Przeglądaj, aby wybrać obraz tła i ustawić sposób nakładania obrazu tła:

    • Wybierz opcję Brak powtarzania, aby wyświetlić obraz tylko jeden raz.

    • Wybierz opcję Powtarzaj, aby powtarzać obraz (układać obok siebie) w poziomie i w pionie.

    • Wybierz opcję Powtórz-x, aby układać obraz obok siebie w poziomie.

    • Wybierz opcję Powtórz-y, aby układać obraz obok siebie w pionie.

  6. Wybierz wyrównanie strony w przeglądarce do lewej, do środka lub do prawej.

  7. Kliknij przycisk OK, a następnie kliknij przycisk Zapisz.

Eksportowanie kodu XHTML

XHTML jest kombinacją HTML, obecnego standardu formatowania i wyświetlania stron internetowych, i XML (Extensible Markup Language). Kod XHTML jest kompatybilny wstecz – co znaczy, że większość obecnych przeglądarek go obsługuje – ale także może być odczytany przez dowolne urządzenie, które wyświetla zawartość XML, np. PDA, telefony komórkowe i inne urządzenia przenośne.

Fireworks importuje także XHTML. Zobacz Tworzenie plików Fireworks PNG z plików HTML.

Więcej informacji na temat XHTML można znaleźć na stronie organizacji World Wide Web Consortium (W3C), zawierającej specyfikacje XHTML, pod adresem www.w3.org.

  1. Wybierz opcje Plik > Ustawienia HTML, wybierz styl XHTML z wyskakującego menu Styl HTML na karcie Ogólne i kliknij przycisk OK.

  2. Eksportuj swój dokument za pomocą jednej z dostępnych metod eksportowania lub kopiowania HTML. Zobacz Eksportowanie kodu HTML.

    Uwaga:

    Podczas eksportu XHTML, Fireworks używa kodowania UTF-8.

Eksportowanie plików z kodowaniem UTF-8 oraz bez niego

UTF-8 (skrót od Universal Character Set Transformation Format-8) jest sposobem kodowania tekstu, który umożliwia wyświetlanie w przeglądarkach internetowych różnych zestawów znaków (na przykład tekst chiński oraz polski) na tej samej stronie HTML. Kodowanie UTF-8 jest domyślnie włączone.

Fireworks potrafi także importować dokumenty, które używają kodowania UTF-8. Zobacz Tworzenie plików Fireworks PNG z plików HTML.

Eksportowanie dokumentów bez kodowania UTF-8

  1. Wybierz Plik > Ustawienia HTML.

  2. Na karcie Określony dokument anuluj zaznaczenie pola wyboru Kodowanie UTF-8 i kliknij przycisk OK.

  3. Eksportuj dokument przy użyciu jednej z dostępnych metod eksportowania lub kopiowania HTML.

Ustawienia opcji eksportowania HTML

Okno dialogowe Ustawienia HTML pozwala ci na zdefiniowanie, w jaki sposób Fireworks eksportuje HTML. Zmiany wykonane na karcie Określony dokument dotyczą tylko bieżącego dokumentu. Ustawienia Ogólne i Tablica są globalnymi preferencjami, które mają wpływ na wszystkie nowe dokumenty.

  1. Wykonaj jedną z poniższych czynności:

    • Wybierz Plik > Ustawienia HTML.

    • Kliknij przycisk Opcje w oknie dialogowym Eksportuj.

  2. Na karcie Ogólne wybierz odpowiednie opcje.

    Styl HTML

    Wybierz styl dla eksportowanego kodu HTML.

    Standardowy HTML działa z dowolnym edytorem HTML. Jednak jeśli dokument zawiera zachowania lub inną interaktywną zawartość, wybierz swój edytor, o ile widnieje na liście.

    Aby eksportować twój dokument w standardzie XHTML, wybierz odpowiedni styl XHTML z wyskakującego menu.

    Rozszerzenie

    Wybierz rozszerzenie pliku z wyskakującego menu lub wpisz nowe.

    Dołącz komentarze HTML

    Wybierz tę opcję ,aby dodać komentarze dotyczące miejsca kopiowania i wklejania w dokumencie HTML. Ta opcja jest zalecana, jeśli twój dokument zawiera interaktywne elementy, takie jak przyciski, zachowania lub obrazy najazdów.

    Nazwa pliku małymi literami

    Wybierz tę opcję, aby dokument HTML i powiązane z nim pliki zostały wyeksportowane z małymi literami w nazwie.

    Uwaga: Ta opcja nie powoduje zmiany rozszerzenia pliku HTML na pisane małymi literami, jeśli z menu wyskakującego Rozszerzenie zostało wybrane rozszerzenie pisane wielkimi literami.

    Użyj CSS dla wyskakujących menu

    Wybierz tę opcję, aby używać kodu CSS zamiast JavaScript dla menu wyskakujących. Możesz użyć programu Dreamweaver w celu indeksowania menu, a także aktualizacji łączy w kodzie.

    Zapisz CSS do pliku zewnętrznego

    Wybierz tę opcję, aby kod CSS został zapisany w zewnętrznym pliku .css, który zostanie wyeksportowany do tej samej lokalizacji, co plik HTML. Nazwa pliku .css odpowiada nazwie pliku HTML (za wyjątkiem rozszerzenia pliku). Wybranie tej opcji także eksportuje plik o nazwie mm_css_menu.js do tego samego miejsca, w jaki znajduje się pliku HTML.

    Uwaga: Ta opcja jest dostępna tylko po wybraniu opcji Użyj CSS dla wyskakujących menu.

    File Creator (Mac OS)

    Wybierz połączoną aplikację z wyskakującego menu. Po dwukrotnym kliknięciu na twardym dysku eksportowanego pliku HTML, automatycznie otworzy się wybrana aplikacja.

  3. W zakładce Tabela wybierz ustawienia dla tabel HTML. Więcej informacji można znaleźć w sekcji Definiowanie sposobu eksportowania tabel HTML.

  4. W zakładce Określony dokument wybierz jedną z następujących opcji:

    Nazwy plików plasterków

    Wybierz wzór dla funkcji automatycznego nazywania plasterków w wyskakujących menu. Możesz użyć domyślnych opcji lub wybrać swoje własne.

    Uwaga: Jeśli wybierzesz opcję Brak w trzech pierwszych menu, program Fireworks będzie eksportował pliki plasterków nadpisujące się wzajemnie i w efekcie zostanie wyeksportowana tylko jedna grafika oraz tabela, wyświetlająca tę grafikę w każdej komórce.

    Domyślny znacznik Alt

    Wpisz tekst, który pojawia się w miejscu wszystkich obrazów, podczas gdy są one pobierane z sieci i w miejscu obrazów, których nie udało się pobrać. W niektórych przeglądarkach może on się wyświetlać jako krótki opis, w momencie gdy znajduje się nad nim wskaźnik myszki. Jest to także pomoc dla użytkowników niedowidzących.

    Eksportuj kilka stron HTML z paskiem nawigacji (do użytku bez zestawu ramek)

    Wybierz tę opcję podczas eksportowania paska nawigacji łączącego kilka stron. Program Fireworks wyeksportuje dodatkowe strony dla każdego przycisku na pasku nawigacji.

    Dołącz obszary bez obiektów plasterka

    Wybierz tę opcję, aby dołączyć te obszary obszaru roboczego, które nie są pokryte plasterkami.

    Kodowanie UTF-8

    Ta opcja jest domyślnie włączona. Umożliwia wyświetlanie w wyeksportowanym dokumencie znaków z różnych zestawów. Aby wyłączyć tę opcję, anuluj zaznaczenie pola wyboru.

  5. Aby zapisać ustawienia jako globalne ustawienia domyślne, kliknij opcję Ustaw domyślnie.

Eksportowanie plików Adobe PDF

Jeśli chcesz wydrukować projekt z programu Fireworks (np. aby poddać go ocenie), można wyeksportować go do pliku Adobe PDF. W programie Adobe Reader® lub Acrobat® recenzenci mogą dodawać komentarze i odpowiadać na komentarze innych. Informacje na temat konfigurowania przeglądu plików PDF można znaleźć w pomocy programu Acrobat.

Wyeksportowane pliki PDF zachowują wszystkie strony oraz łącza hipertekstowe, umożliwiając recenzentom nawigację na wzór serwisu WWW. Jednak w odróżnieniu od plików źródłowych HTML, pliki PDF zawierają zabezpieczenia, które uniemożliwiają recenzentom dokonywanie zmian lub skopiowanie projektu.

  1. Wybierz Plik > Eksportuj.

  2. Z menu Eksportuj wybierz opcję Adobe PDF.

  3. Wybierz strony do wyeksportowania i wybierz opcję Wyświetl plik PDF po wyeksportowaniu, aby automatycznie otworzyć go w programie Adobe Reader lub Acrobat.

  4. Aby dostosować plik PDF, kliknij Opcje, a następnie dostosuj następujące ustawienia:

    Zgodność

    Określa, które przeglądarki plików Adobe PDF mogą otwierać wyeksportowany plik.

    Kompresja

    Określa rodzaj kompresji obrazu, co umożliwia zmniejszenie wielkości pliku. Kompresja JPEG i JPEG2000 daje najlepsze wyniki w przypadku obrazów o ciągłych przejściach między kolorami (takich jak fotografie). Format ZIP jest lepszy w przypadku ilustracji zawierających duże obszary o jednolitym kolorze.

    Jakość

    W kompresji JPEG lub JPEG2000 oferuje ustawienia jakości obrazu. Wybranie opcji Wysoka jakość daje duże pliki z dobrą jakością obrazu.

    Konwertuj na skalę szarości

    Konwertuje obrazy na skalę szarości, zmniejszając wielkość pliku.

    Włącz zaznaczanie tekstu

    Osoby przeglądające mogą kopiować tekst z wyeksportowanego pliku. Usunięcie zaznaczenia tej opcji umożliwia znaczne zmniejszenie wielkości pliku.

    Wartość spadu

    Określa szerokość (w pikselach) pustego obramowania otaczającego obraz na wszystkich stronach. Na przykład wartość 20 powoduje otoczenie każdego obrazu obramowaniem o szerokości 20 pikseli.

    Użyj hasła do otwarcia dokumentu

    Do otwarcia wyeksportowanego pliku potrzebne będzie hasło otwierania.

    Użyj hasła do zablokowania zadań

    Do wykonania następujących funkcji potrzebne będzie hasło zabezpieczające: drukowanie, edycja, kopiowanie oraz dodawanie komentarzy.

  5. Kliknij przycisk OK, aby zamknąć okno dialogowe Opcje.

  6. Podaj nazwę i położenie pliku, a następnie kliknij przycisk Zapisz.

    Uwaga:

    Jeżeli strony dokumentu Fireworks posiadają przezroczysty obszar roboczy, wtedy podczas eksportu do formatu PDF obiekty posiadające przezroczystości tracą związane z nimi cechy. Aby uniknąć tej sytuacji, należy przed eksportem do formatu PDF ustawić nieprzezroczyste tło dla obszaru roboczego.

Wideo

Tworzenie wersji próbnych dla klienta w postaci plików PDF lub HTML za pomocą programu Fireworks (00:05:32)

Dowiedz się, w jaki sposób używać menu Eksport programu Fireworks, aby przygotować dokument PDF lub HTML do zatwierdzenia przez klienta lub ocenę przez zespół.

Autor: Tom Green

W programie Adobe Acrobat lub Adobe Reader podczas eksportowania plików PDF zastosuj następujące ustawienia:

  1. W programie Adobe Acrobat lub Adobe Reader wybierz polecenie Edycja > Preferencje.

  2. W lewym panelu zaznacz opcję Wyświetlanie strony.

  3. Ustaw Rozdzielczość własną na 72 piksele na cal.

  4. Ustaw wartość Powiększenie na 100%.

Eksportowanie plików FXG

FXG to format plików obsługiwany przez programy Flash Catalyst, Fireworks, Illustrator i Photoshop. Podczas eksportowania pliku zawierającego obrazy wektorowe i bitmapowe przy użyciu eksportowania FXG tworzony jest oddzielny folder o nazwie <filename.assets>. Folder ten zawiera obrazy bitmapowe skojarzone z tym plikiem.

Operacja importowania nie powiedzie się, jeśli którykolwiek ze skojarzonych plików zostanie usunięty z tego folderu.

Uwaga:

Elementy, filtry, tryby mieszania, gradienty i maski, dla których nie ma odpowiedniego znacznika odwzorowania w pliku FXG, eksportowane są jako grafiki bitmapowe.

  1. Wybierz Plik > Eksportuj i przejdź do miejsca, w którym chcesz zapisać pliki.

  2. Wprowadź nazwę pliku dla pliku FXG.

  3. Wybierz FXG i obrazy z menu Eksportuj w oknie dialogowym Eksportuj.

  4. Kliknij Zapisz.

Uwaga:

Obiekty, które w programie Fireworks znajdują się poza obszarem roboczym, są wyświetlane w całości, gdy wyeksportowany plik FXG otwierany jest w programie Flash Catalyst.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online