Używanie programu Fireworks z programem Dreamweaver

Programy Adobe Dreamweaver® oraz Fireworks rozpoznają i współdzielą wiele sposobów edycji pliku, takich jak zmiana łączy, mapy obrazu i plasterki tabeli. Obie aplikacje zapewniają ciągły proces pracy obejmujący edycję, optymalizację i umieszczanie plików grafik internetowych na stronach HTML.

Umieszczanie obrazów Fireworks w plikach Dreamweaver

Podczas wstawiania w programie Dreamweaver plików JPEG programu Fireworks, jakość danego pliku obliczana jest automatycznie. Dla niektórych plików wartość ta może wynosić 79.

Uwaga:

Przed użyciem opisanych tutaj procedur upewnij się, że program Dreamweaver został określony jako typ HTML w oknie dialogowym Ustawienia HTML.

Wstawianie obrazów Fireworks do programu Dreamweaver przy użyciu panelu Pliki

  1. Eksportuj twój obrazek z programu Fireworks do folderu serwisu lokalnego, który jest zdefiniowany w programie Dreamweaver.

  2. Otwórz dokument Dreamweaver i upewnij się, czy jesteś w widoku Projekt.

  3. Przeciągnij rysunek z panelu Pliki do dokumentu Dreamweaver.

Wstawianie obrazów Fireworks do programu Dreamweaver przy użyciu menu Wstaw

  1. Wskaż miejsce wstawiania w oknie Dokument Dreamweaver, w którym chcesz umieścić obrazek.

  2. Wykonaj jedną z poniższych czynności:

    • Wybierz polecenie Wstaw > Obraz.

    • Kliknij obrazy: Przycisk Obraz w kategorii Wspólne zakładki Wstaw.

  3. Przejdź do obrazka zaimportowanego z programu Fireworks i kliknij przycisk OK.

Tworzenie nowych plików Fireworks z elementów zastępczych Dreamweaver

Elementy zastępcze obrazów umożliwiają eksperymentowanie z różnymi układami strony przed utworzeniem ostatecznej grafiki dla strony. Użyj Elementów zastępczych w celu określenia rozmiaru i położenia obrazów Fireworks w programie Dreamweaver, które zostaną wprowadzone w późniejszym czasie.

Kiedy tworzysz obrazek Fireworks z elementu zastępczego obrazka Dreamweaver, jest tworzony nowy dokument Fireworks, z kanwą o tych samych wymiarach, co zaznaczony element zastępczy.

Uwaga:

Wszystkie zachowania użyte w ramach programu Fireworks nie ulegają zmianie przy eksporcie do Dreamweaver. Podobnie większość zachowań Dreamweaver zastosowanych do elementów zastępczych obrazków jest zachowana podczas wczytywania i edycji w programie Fireworks. Istnieje jednak jeden wyjątek: rozłączne najazdy zastosowane do elementów zastępczych obrazków w programie Dreamweaver nie są zachowane podczas otwarcia i edycji w programie Fireworks.

Gdy skończysz sesję w programie Fireworks i powrócisz do aplikacji Dreamweaver, nowa grafika Fireworks zajmie miejsce pierwotnie zaznaczonego elementu zastępczego.

  1. W programie Dreamweaver zapisz dokument HTML w twoim folderze witryny Dreamweaver.

  2. Ustaw punkt wstawiania w żądanym miejscu w twoim dokumencie i wykonaj jedną z poniższych czynności:

    • Wybierz Wstaw > Obiekty obrazu > Element zastępczy obrazu.

    • Kliknij obrazy: wyskakujące menu Obraz z kategorii Wspólne w zakładce Wstaw i wybierz Element zastępczy obrazka.

  3. Wpisz nazwę, wymiary, kolor i tekst zastępczy dla elementu zastępczego.

    Element zastępczy obrazka zostaje wstawiony do dokumentu Dreamweaver.

    Element zastępczy obrazu
    Element zastępczy obrazu

  4. Wykonaj jedną z poniższych czynności:

    • Wybierz element zastępczy obrazka i kliknij Utwórz w inspektorze Właściwości.

    • Naciśnij klawisz Control (Windows) lub Command (Mac OS) i dwukrotnie kliknij element zastępczy obrazu.

    • Kliknij prawym przyciskiem myszy (Windows) lub kliknij, wciskając klawisz Control (Mac OS), aby wybrać opcję Utwórz obraz w programie Fireworks.

      Zostanie otwarty program Fireworks z pustym obszarem roboczym, który dokładnie pasuje rozmiarem do elementu zastępczego obrazka. Szczyt okna Dokument oznacza, że edytujesz obrazek z programu Dreamweaver.

  5. Utwórz obraz w programie Fireworks i kliknij przycisk Gotowe.

  6. Określ nazwę i położenie źródłowego pliku PNG.

  7. Wprowadź nazwę dla wyeksportowanych plików obrazów.

    Te pliki obrazka są wyświetlane w programie Dreamweaver.

  8. Określ położenie w folderze serwisu Dreamweaver dla wyeksportowanych obrazów, a następnie kliknij opcję Zapisz.

    Gdy powrócisz do programu Dreamweaver, element zastępczy obrazu, który pierwotnie wybrałeś, zostanie zastąpiony przez nowy obraz lub tabelę Fireworks.

    Element zastępczy obrazu zastąpiony nowym obrazem Fireworks
    Element zastępczy obrazu zastąpiony nowym obrazem Fireworks

Wstawianie kodu Fireworks HTML do programu Dreamweaver

Dwukrokowa operacja eksportowanie plików Fireworks do programu Dreamweaver. Pliki z programu Fireworks są eksportowane bezpośrednio do folderu serwisu Dreamweaver. To generuje plik HTML i powiązane pliki obrazów w podanej przez ciebie lokacji. Następnie kod HTML jest umieszczany w programie Dreamweaver za pomocą funkcji Wstaw Fireworks HTML.

  1. Wyeksportuj dokument Fireworks HTML do formatu HTML.

  2. Zapisz twój dokument w określonym serwisie w Dreamweaver.

  3. Określ punkt wstawiania w dokumencie; będzie oznaczał początek wstawionego przez ciebie kodu HTML.

  4. Wykonaj jedną z poniższych czynności:

    • Wybierz polecenie Wstaw > Obiekty obrazów > Fireworks HTML.

    • Kliknij obrazy: wyskakujące menu Obraz z kategorii Wspólne w zakładce Wstaw i wybierz Fireworks HTML.

  5. W oknie dialogowym, które się pojawi, kliknij Przeglądaj, aby wybrać plik Fireworks HTML.

  6. (Opcjonalnie) Wybierz Usuń plik po wstawieniu, aby przenieść plik HTML do Kosza (Windows) lub ostatecznie go usunąć (Mac OS) po zakończeniu operacji.

    Ta opcja nie dotyczy plików źródłowych PNG powiązanych z plikiem HTML.

  7. Kliknij OK, aby wstawić kod HTML wraz z dołączonymi obrazkami, plasterkami i JavaScript, do dokumentu Dreamweaver.

Kopiowanie kodu Fireworks HTML do wykorzystania w programie Dreamweaver

Po skopiowaniu kodu Fireworks HTML do Schowka, cały kod HTML i JavaScript, który jest powiązany z dokumentem Fireworks, zostaje skopiowany do dokumentu Dreamweaver. Obrazy zostają wyeksportowane w określone wcześniej miejsce, a program Dreamweaver uaktualnia kod HTML poprzez dodanie względnych łączy do obrazów.

Uwaga:

Ta metoda działa tylko z programem Dreamweaver. Nie działa z innymi edytorami HTML.

  1. Skopiuj kod HTML do Schowka w programie Fireworks, a następnie wklej w dokumencie Dreamweaver.

Uwaga:

Możesz otworzyć i wyeksportować plik Fireworks HTML do programu Dreamweaver, a następnie kopiować i wklejać wybrane części kodu do innego dokumentu Dreamweaver.

Uaktualnianie kodu Fireworks HTML eksportowanego do Dreamweaver

Uwaga:

Roundtrip HTML oferuje wiele korzyści podczas pracy z kodem HTML wyeksportowanym do programu Dreamweaver (zobacz Roundtrip HTML — Informacje).

  1. Dokonaj zmian w dokumencie PNG w programie Fireworks.

  2. Wybierz polecenie Plik > Uaktualnij HTML.

  3. Przejdź do pliku Dreamweaver, który zawiera HTML do uaktualnienia, i kliknij Otwórz.

  4. Przejdź do folderu, w którym chcesz umieścić uaktualnione pliki obrazów, a następnie kliknij opcję Otwórz.

    Fireworks uaktualnia kod HTML i JavaScript w dokumencie Dreamweaver. Fireworks także eksportuje uaktualnione obrazki powiązane z kodem HTML i umieszcza je w określonym folderze docelowym.

    Uwaga:

    Jeśli program Fireworks nie jest w stanie znaleźć odpowiedniego kodu HTML do uaktualnienia, istnieje możliwość wstawienia nowego kodu HTML do dokumentu Dreamweaver. Fireworks umieszcza część nowego kodu JavaScript na początku dokumentu, a tabelę lub łącze HTML – na końcu.

Eksportowanie plików Fireworks do bibliotek Dreamweaver

Element biblioteki jest częścią pliku HTML, umieszczoną w folderze o nazwie Library w folderze głównym. Elementy biblioteki pojawiają się jako kategorie w panelu Zasoby w Dreamweaver. W programie Dreamweaver elementy biblioteki ułatwiają edycję i aktualizację często używanych elementów strony WWW. Możesz przeciągnąć element biblioteki (plik z rozszerzeniem .lbi) z panelu Zasoby do dowolnej strony w serwisie.

Nie ma możliwości przeprowadzania edycji elementu biblioteki bezpośrednio w dokumencie Dreamweaver; można edytować wyłącznie elementy głównej biblioteki. Następnie możesz sprawić, że Dreamweaver uaktualni każdą kopię tego elementu, która jest umieszczona w twojej witrynie. Elementy biblioteki programu Dreamweaver są podobne do symboli w Fireworks; zmiany uczynione w głównej bibliotece (LBI) dokumentu są widoczne we wszystkich instancjach biblioteki w witrynie.

Uwaga:

Elementy biblioteki Dreamweaver nie obsługują wyskakujących menu.

  1. Wybierz polecenie Plik > Eksportuj.

  2. Z menu Eksportuj wybierz opcję Biblioteka programu Dreamweaver.

    Wybierz lub utwórz folder o nazwie Library w serwisie Dreamweaver, stanowiący lokalizację dla plików. W nazwie jest rozróżniana wielkość liter.

    Uwaga:

    Dreamweaver nie rozpoznaje eksportowanego pliku jako element biblioteki, chyba że jest on zapisany w folderze Library.

  3. Wpisz nazwę pliku.

  4. (Opcjonalnie) Jeśli twój obraz zawiera plasterki, wybierz opcje dla plasterkowania.

  5. Wybierz opcję Wyślij obraz do podfolderu, aby wybrać osobny folder dla zapisywanych obrazów.

  6. Kliknij Zapisz.

Edycja plików Fireworks za pomocą programu Dreamweaver

Funkcja Roundtrip HTML ściśle integruje programy Fireworks i Dreamweaver. Dzięki niej zrobienie zmian w jednej aplikacji od razu odzwierciedla je w drugiej.

O Roundtrip HTML

Fireworks rozpoznaje i zachowuje większość sposobów edycji dokonanych w dokumencie Dreamweaver, a w tym zmianę łączy, edycję map obrazu, tekstu i HTML w plasterkach oraz zachowania współdzielone między Fireworks a Dreamweaver. Inspektor właściwości w programie Dreamweaver pomaga zidentyfikować w dokumencie obrazy, plasterki tabeli i tabele wygenerowane w programie Fireworks.

Program Fireworks obsługuje większość plików edytowanych w programie Dreamweaver. Jednak wprowadzanie daleko idących zmian w strukturze tabel w programie Dreamweaver może powodować powstawanie nieodwracalnych różnic pomiędzy obiema aplikacjami. W przypadku dokonywania znacznych zmian w wyglądzie tabeli, użyj funkcji „uruchom i edytuj” programu Dreamweaver, aby edytować tabelę w programie Fireworks.

Uwaga:

Przy użyciu technologii Fireworks, program Dreamweaver oferuje podstawowe funkcje edycji obrazów, przydatne podczas ich modyfikacji, bez konieczności użycia zewnętrznej aplikacji. Funkcje edycji obrazków Dreamweaver dotyczą tylko formatów GIF i JPEG.

Edycja obrazu Fireworks umieszczonego w programie Dreamweaver

Uwaga:

Przed dokonaniem edycji grafik Fireworks w programie Dreamweaver należy wykonać kilka wstępnych operacji. Więcej informacji można znaleźć w sekcji Ustawianie opcji uruchamiania i edycji.

  1. W programie Dreamweaver wybierz opcje Okno > Właściwości, aby otworzyć Inspektora właściwości.

  2. Wykonaj jedną z poniższych czynności:

    • Wybierz obrazek. (Inspektor Właściwości identyfikuje zaznaczanie jako obrazek Fireworks i wyświetla nazwę znanego pliku źródłowego PNG dla tego obrazka). Następnie kliknij Edycja w inspektorze Właściwości

    • Naciśnij klawisz Control (Windows) lub Command (Mac OS) i dwukrotnie kliknij obraz, który chcesz edytować.

    • Naciśnij klawisz Control (Windows) lub Command (Mac OS) i dwukrotnie kliknij obraz oraz wybierz opcję Edytuj z Fireworks z menu kontekstowego.

  3. Jeśli pojawi się zapytanie, określ, czy należy podać źródłowy plik Fireworks dla umieszczonego rysunku.

  4. W programie Fireworks, wyedytuj obrazek.

    Zastosowane zmiany zostaną zapisane w programie Dreamweaver.

  5. Kliknij przycisk Gotowe, aby wyeksportować obraz przy użyciu bieżących ustawień optymalizacji, zaktualizować plik GIF lub JPEG używany w programie Dreamweaver oraz zapisać plik źródłowy PNG, jeśli został wybrany.

    Uwaga:

    Kiedy otworzysz obrazek z panelu Witryna Dreamweaver, uruchomi się domyślny edytor dla tego typu obrazka, który jest określony w Preferencjach Dreamweaver. Kiedy obrazek jest otwarty z tego miejsca, Fireworks nie otwiera źródłowego pliku PNG. Aby skorzystać z funkcji integracji Fireworks, otwórz obrazek w oknie Dokument Dreamweaver.

Edycja tabeli Fireworks umieszczonej w programie Dreamweaver

Uwaga:

Przed edytowaniem tabel Fireworks w programie Dreamweaver należy wykonać wstępne czynności związane z uruchamianiem i edycją. Więcej informacji można znaleźć w sekcji Ustawianie opcji uruchamiania i edycji.

  1. W programie Dreamweaver wybierz opcje Okno > Właściwości, aby otworzyć Inspektora właściwości.

  2. Wykonaj jedną z następujących czynności, aby otworzyć źródłowy plik PNG w oknie dokumentu:

    • Aby zaznaczyć całą tabelę, kliknij wewnątrz tabeli, a następnie kliknij znacznik TABLE na pasku stanu. (Inspektor Właściwości identyfikuje zaznaczenie jako tabelę Fireworks i wyświetla nazwę znanego pliku źródłowego PNG dla tej tabeli). Następnie w inspektorze Właściwości kliknij Edycja.

    • Zaznacz obraz w tabeli, a następnie kliknij opcję Edycja w Inspektorze właściwości.

    • Naciśnij klawisz Control (Windows) lub Command (Mac OS) i dwukrotnie kliknij obraz, a następnie wybierz opcję Edytuj z Fireworks z menu kontekstowego.

  3. Dokonaj zmian w programie Fireworks.

    Dreamweaver rozpoznaje i zachowuje wszystkie zmiany dokonane w tabeli w Fireworks.

  4. Po zakończeniu edycji tabeli, kliknij przycisk Gotowe w oknie dokumentu.

    Pliki HTML i plasterki rysunku dla tabeli są eksportowane za pomocą bieżących ustawień optymalizacyjnych, tabela umieszczona w Dreamweaver zostaje uaktualniona, a plik źródłowy PNG zostaje zapisany.

    Uwaga:

    Możesz otrzymać informację o błędzie programu Dreamweaver, jeśli zagnieździsz inną tabelę wewnątrz tabeli oryginalnie wygenerowanej przez program Fireworks, a następnie spróbujesz edytować tabelę przy użyciu funkcji Roundtrip w programie Dreamweaver. Aby uzyskać więcej informacji, zobacz TechNote 19231 na stronie internetowej Adobe.

Informacje na temat obsługiwanych i nieobsługiwanych zachowań programu Dreamweaver

Jeśli pojedyncza, nie pocięta na plasterki grafika Fireworks zostaje wstawiona do dokumentu Dreamweaver i zostaje zastosowane zachowanie Dreamweaver, to ta grafika będzie posiadać na sobie plasterek w momencie otwarcia i edycji w Fireworks. Początkowo plasterek nie jest widoczny, ponieważ cięcie na plasterki jest automatycznie wyłączane, kiedy otwierasz i edytujesz pojedynczą, nie pociętą grafikę, do której zastosowano zachowania Dreamweaver. Możesz oglądać plasterki poprzez włączenie widoczności z Warstwy Internetu w panelu Warstwy.

Gdy w programie Fireworks oglądasz właściwości plasterka, do którego zostało dołączone zachowanie Dreamweaver, okno tekstowe Łącze w inspektorze Właściwości może wyświetlać javascript:;. Usuwanie tego tekstu jest bezpieczne. Możesz wpisać zamiast niego wpisać URL, a zachowanie pozostanie niezmienione po powrocie do Dreamweaver.

Kiedy pracujesz z Roundtrip HTML za pomocą Dreamweaver, Fireworks wspiera formaty plików po stronie serwera, takie jak CFM czy PHP.

Dreamweaver wspiera wszystkie zachowania zastosowane w Fireworks, nawet te, które są wymagane do najazdów i przycisków.

Uwaga:

Elementy biblioteki Dreamweaver nie obsługują wyskakujących menu.

W czasie sesji „uruchamiania i edycji”, program Fireworks obsługuje następujące zachowania programu Dreamweaver:

  • Najazd prosty

  • Zamień obraz

  • Przywróć zamieniony obraz

  • Ustaw tekst paska stanu

  • Ustaw obraz paska nawigacji

  • Wysuwane menu

Uwaga:

Fireworks nie wspiera zachowań nieaktywnych, między innymi zachowań po stronie serwera.

Optymalizacja obrazów i animacji Fireworks umieszczonych w programie Dreamweaver

Zmiana ustawień optymalizacji obrazu Fireworks umieszczonego w programie Dreamweaver

  1. Zaznacz obraz w programie Dreamweaver i wykonaj jedną z następujących czynności:

    • Wybierz Polecenia > Optymalizuj obraz.

    • Kliknij przycisk Optymalizuj w Inspektorze właściwości.

    • Kliknij prawym przyciskiem myszy (Windows) lub przytrzymując klawisz Control (Mac OS) i wybierz z wyskakującego menu opcję Optymalizuj w Fireworks.

  2. Jeśli pojawi się zapytanie, określ, czy należy otworzyć źródłowy plik Fireworks dla umieszczonego rysunku.

  3. Wykonaj zmiany w oknie dialogowym Podgląd eksportu:

    • Aby edytować ustawienia optymalizacyjne, kliknij zakładkę Opcje.

    • Aby zmienić rozmiar obszaru eksportowanego obrazu, kliknij zakładkę Plik. Jeśli zmienisz wymiary obrazka w programie Fireworks, po powrocie do programu Dreamweaver będziesz musiał również wyzerować wielkość obrazka w Inspektorze właściwości.

    • Aby edytować ustawienia animacji obrazu, kliknij kartę Animacja.

  4. Po zakończeniu edytowania kliknij przycisk OK, aby wyeksportować obraz, zaktualizuj go w programie Dreamweaver i zapisz w postaci pliku PNG.

    Jeśli zmieniłeś format obrazka, kontroler łączy Dreamweaver poprosi cię o uaktualnienie odniesień do obrazka.

Zmiana ustawień animacji

Jeśli otwierasz i optymalizujesz Animowany plik GIF, możesz także zmienić jego ustawienia animacji. Opcje animacji w oknie dialogowym Podgląd eksportu są podobne do tych, które udostępnia panel Stany w Fireworks.

Uwaga:

Aby móc edytować element graficzny w animacji Fireworks, musisz otworzyć i wyedytować animację Fireworks.

Ustawianie opcji uruchamiania i edycji

Aby używać efektywnie funkcji Roundtrip HTML, należy wykonać wstępne operacje, takie jak ustawienie programu Fireworks jako głównego edytora w programie Dreamweaver, określenie preferencji „uruchom i edytuj” w programie Fireworks i zdefiniowanie serwisu lokalnego w programie Dreamweaver.

Konfigurowanie programu Fireworks jako głównego zewnętrznego edytora obrazów w programie Dreamweaver.

Dreamweaver dostarcza preferencji automatycznego uruchamiania określonych aplikacji w celu edycji pewnych typów plików. Aby użyć funkcji „uruchom i edytuj” w Fireworks upewnij się, czy Fireworks jest ustawiony jako pierwszy edytor dla plików GIF, JPEG i PNG w Dreamweaver.

Uwaga:

Ustawienie tej preferencji jest niezbędne tylko w przypadku występowania problemów podczas uruchamiania programu Fireworks w programie Dreamweaver.

  1. W Dreamweaver wybierz Edycja > Preferencje, a następnie wybierz Typy pliku/Edytory.

  2. Na liście Rozszerzenia wybierz rozszerzenie plików obrazów używanych w sieci (.gif, .jpg lub .png).

  3. Z listy Edytorów wybierz opcję Fireworks. Jeśli na liście nie ma Fireworks, kliknij przycisk Plus (+), znajdź lokalizację aplikacji Fireworks na twardym dysku i kliknij Otwórz.

    Preferencje programu Dreamweaver
    Preferencje programu Dreamweaver

  4. Kliknij Ustaw jako pierwszy.

  5. Powtarzaj kroki od 2 do 4, aby ustawić Fireworks jako pierwszy edytor dla innych typów plików obrazków w  sieci.

Ustawienie preferencji „uruchom i edytuj” dla plików źródłowych Fireworks

Preferencje „uruchom i edytuj” Fireworks pozwalają określić, w jaki sposób obsługiwać źródłowe pliki PNG podczas otwierania plików Fireworks z innej aplikacji.

Program Dreamweaver rozpoznaje preferencje „uruchom i edytuj” programu Fireworks tylko wtedy, gdy otwierany i optymalizowany obraz nie jest częścią tabeli Fireworks i nie zawiera poprawnej ścieżki Uwag do projektu do źródłowego pliku PNG. We wszystkich innych sytuacjach, włącznie ze stosowaniem preferencji „uruchom i edytuj” dla obrazów Fireworks, program Dreamweaver automatycznie otwiera źródłowy plik PNG, prosząc o zlokalizowanie źródłowego pliku, jeśli nie można go odnaleźć.

  1. W programie Fireworks wybierz polecenie Edycja > Preferencje (Windows) lub Fireworks > Preferences (Mac OS).

  2. Kliknij kategorię Uruchom i edytuj oraz ustaw odpowiednie opcje.

    Więcej informacji można znaleźć w sekcji Preferencje Uruchom i edytuj.

O Design Notes i plikach źródłowych

Za każdym razem, gdy eksportujesz plik Fireworks z zapisanego pliku źródłowego PNG do serwisu Dreamweaver, program Fireworks zapisuje Uwagi do projektu (Design Notes), które zawierają informacje o pliku. Gdy otwierasz i edytujesz grafikę Fireworks w aplikacji Dreamweaver, korzysta ona z Uwag o projekcie, aby zlokalizować źródłowy plik PNG dla tego pliku. Zawsze zapisuj plik źródłowy PNG Fireworks i pliki eksportowane w serwisie Dreamweaver, aby osiągnąć najlepsze wyniki pracy. To zapewni, że każdy użytkownik współdzielący ten serwis może umieścić plik źródłowy PNG podczas uruchamiania Fireworks z programu Dreamweaver.

Przesyłanie plików serwisu przy użyciu przycisku Zarządzanie plikami

Przycisk Zarządzanie plikami , umieszczony na górze okna dokumentu, umożliwia łatwy dostęp do poleceń przesyłania plików. Użyj tego przycisku, jeśli dokument znajduje się w folderze serwisu Dreamweaver, a serwis ma dostęp do zdalnego serwera. Aby folder został rozpoznany w programie Fireworks jako serwis, użyj okna dialogowego Zarządzanie serwisem w programie Dreamweaver, w celu zdefiniowania folderu docelowego (lub folderu zawierającego) jako lokalnego folderu źródłowego serwisu.

Uwaga:

Przed użyciem opcji Odłóż i Pobierz w programie Fireworks należy zaznaczyć opcję Włącz pobieranie i odkładanie plików dla serwisu Dreamweaver, w którym znajduje się dokument.

Pobierz

Kopiuje zdalną wersję pliku do lokalnego serwisu, nadpisując lokalną kopię.

Pobierz do edycji

Pobiera plik, nadpisując lokalny plik jego zdalną kopią.

Wyślij

Kopiuje lokalną wersję pliku do zdalnego serwisu, nadpisując zdalną kopię.

Odłóż

Pobiera lokalny plik, nadpisując zdalny plik jego lokalną kopią.

Cofnij pobieranie do edycji

Cofa pobieranie lokalnego pliku i odkłada go, nadpisując plik lokalny jego zdalną kopią.

Uwaga:

Polecenie Zarządzanie plikiem jest włączone w Fireworks tylko, jeśli dokument jest umieszczony w folderze serwisu Dreamweaver ze zdefiniowanym zdalnym serwerem. Polecenia Fireworks Zarządzenie plikiem mogą tylko dotyczyć plików, które są umieszczone w serwisie korzystającym z metod FTP i Local/Network. Pliki w serwisach korzystających z SFTP i innych metod transportu (takich jak SourceSafe, WebDAV i RDS) nie mogą być przesyłane ani pobierane ze zdalnego serwera za pomocą Fireworks.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online