• Można w prosty sposób importować, kopiować i wklejać, czy eksportować z Fireworks wektory, bitmapy, animacje, wielostanowe graficzne przyciski do programu Adobe Flash®.

  • W systemie Windows tekst TLF z programu Flash kopiowany jest do programu Fireworks jako pusty obraz bitmapowy. Przekonwertuj tekst TLF na tekst ASCII i zaimportuj go do programu Fireworks.

  • Funkcjonalność „uruchom i edytuj” ułatwia również edycję grafiki Fireworks z poziomu aplikacji Flash. Podczas pracy w programie Flash stosowane są zawsze preferencje uruchamiania i edycji ustawione w programie Fireworks.

  • Styl Flash HTML nie wspiera kodu dla wyskakujących menu. Zachowania przycisku Fireworks i inne typy interaktywności nie są importowane do Flash.

Umieszczanie grafik Fireworks w programie Flash.

Importowanie lub kopiowanie pliku Fireworks PNG daje dużą kontrolę nad sposobem importowania grafik i animacji do programu Flash. Możesz również importować pliki JPEG, GIF, PNG i SWF, które wyeksportowano z programu Fireworks.

Uwaga:

Kiedy grafiki Fireworks są importowane lub kopiowane i wklejane do Flash, niektóre atrybuty są gubione (takie jak filtry aktywne i tekstury). Nie możesz importować lub kopiować i wklejać efektu konturu gradientu z programu Fireworks do dokumentu Flash. Dodatkowo, Flash wspiera tylko kryjące wypełnienia, wypełnienia gradientem i podstawowe obrysy.

Importowanie plików Fireworks PNG do programu Flash

Możesz importować pliki źródłowe Fireworks PNG bezpośrednio do programu Flash bez potrzeby eksportowania ich na inny format graficzny. Wszystkie wektory, bitmapy, animacje i wielostanowe graficzne przyciski Fireworks mogą być importowane do Flash.

Uwaga:

Zachowania przycisku Fireworks i inne typy interaktywny nie są importowane do Flash, ponieważ zachowania Fireworks są włączone dzięki JavaScript, który jest zewnętrzny względem tego formatu pliku. Flash używa wewnętrznego kodu ActionScript.

  1. Zapisz dokument w programie Fireworks.

  2. Przełącz się do otwartego dokumentu w programie Flash.

  3. (Opcjonalnie) Kliknij stan kluczowy i warstwę, do której chcesz importować zawartość Fireworks.

  4. Wybierz polecenie Plik > Importuj.

  5. Przejdź do pliku PNG i wybierz go.

  6. W oknie dialogowym Importuj dokument Fireworks wykonaj jedną z następujących czynności:

    • Wybierz opcję Importuj jako pojedynczą spłaszczoną bitmapę.

    • Wybierz opcję importu z dwóch wyskakujących menu.

  7. Wybierz, w jaki sposób ma być importowany tekst.

  8. Kliknij OK.

    Uwaga:

    Wybory wykonane w oknie dialogowym Importuj dokument Fireworks są zapisywane i stosowane jako ustawienia domyślne.

Opcje importowania grafiki, obiektów wektorowych i tekstu Fireworks

Opcje importowania grafiki

Importuj jako pojedynczą, spłaszczoną bitmapę

Importuje pojedynczy obraz, bez możliwości edycji.

Importuj wszystkie strony do nowych stanów jako klipy filmowe

Importuje wszystkie strony z pliku PNG do nowej warstwy Flash, która dziedziczy nazwę po pliku PNG. Stan kluczowy zostaje utworzony na nowej warstwie w bieżącej lokalizacji stanu, pierwsza strona pliku PNG zostaje umieszczona jako klip filmowy w tym stanie, a wszystkie pozostałe strony zostają umieszczone w następnych stanach także jako klipy filmowe. Hierarchia warstw i stanów wewnątrz pliku PNG jest zachowana.

Importuj Stronę 1 do bieżącego stanu jako klip filmowy

Zawartość zaznaczonej strony jest importowana jako klip filmowy, który jest umieszczony w aktywnym stanie i warstwie pliku Flash. Hierarchia warstw i stany wewnątrz pliku PNG są zachowywane.

Importuj wszystkie strony do nowych scen jako klipy filmowe

Importuje wszystkie strony z pliku PNG i umieszcza każdą z nich w nowej scenie jako klipy filmowe. Wszystkie warstwy i stany wewnątrz strony są zachowane. Jeśli sceny istnieją już w pliku Flash, importowanie dodaje nowe sceny za już istniejącymi.

Importuj Stronę 1 do nowej warstwy

Zaznaczona strona zostanie zaimportowana jako nowa warstwa. Stany są importowane do osi czasu jako oddzielne stany.

Opcje importowania obiektów wektorowych

Importuj jako bitmapy, aby zachować wygląd

Zachowuje możliwość edycji obiektów wektorowych, chyba że posiadają one specjalne wypełnienie, obrys lub efekty, które nie są obsługiwane przez program Flash. Aby zachować wygląd takich obiektów, Flash konwertuje je na nieedytowalne obrazki bitmapy.

Importuj jako ścieżki edytowalne

Zachowuje możliwość edycji dla wszystkich obiektów wektorowych. Jeśli obiekt posiada specjalne wypełnienie, obrys lub efekty, których nie obsługuje program Flash, właściwości te mogą wyglądać inaczej po zaimportowaniu.

Opcje importowania tekstu

Importuj jako bitmapy, aby zachować wygląd

Zachowuje możliwość edycji tekstu, chyba że posiada on specjalne wypełnienie, obrys lub efekty, nieobsługiwane przez program Flash. Aby zachować wygląd takiego tekstu, Flash konwertuje go na nieedytowalny obrazek bitmapy.

Uwaga:

Tekst TLF z programu Flash kopiowany jest w programie Fireworks jako pusty obraz bitmapowy.

Zachowaj możliwość edycji tekstu

Zachowuje możliwość edycji całego tekstu. Jeśli obiekty tekstowe zawierają specjalne wypełnienie, obrys lub efekty, których nie obsługuje program Flash, obiekty te mogą wyglądać inaczej po zaimportowaniu.

Kopiowanie lub przeciąganie grafiki Fireworks do programu Flash

Aby kopiować grafikę do aplikacji Flash w wersji wcześniejszej niż Flash 8, wybierz opcję Edycja > Kopiuj kontur ścieżki.

Uwaga:

Konieczne może być rozgrupowanie obiektów (Modyfikuj > Rozgrupuj), aby można je było edytować jako oddzielne obiekty wektorowe w programie Flash.

  1. W Fireworks wybierz obiekt lub obiekty do kopiowania:

  2. Wybierz Edycja > Kopiuj i wybierz Kopiuj z wyskakującego menu programu Flash.

  3. We Flash, utwórz nowy dokument i wybierz Edycja > Wklej lub przeciągnij plik bezpośrednio z Fireworks do Flash.

  4. W oknie dialogowym Importuj dokument Fireworks wybierz opcję Do:

    Bieżący stan jako klip filmowy

    Wklejona zawartość jest importowana jako klip filmowy, który jest umieszczony w aktywnym stanie i warstwie pliku Flash. Hierarchia warstw i stany wewnątrz pliku PNG są zachowywane.

    Nowa warstwa

    Wklejona strona zostanie zaimportowana jako nowa warstwa. Stany są importowane do osi czasu jako oddzielne stany.

  5. Określ, w jaki sposób mają być importowane obiekty wektorowe.

  6. Wybierz, w jaki sposób ma być importowany tekst.

  7. Kliknij OK.

    Uwaga:

    Wybory wykonane w oknie dialogowym Importuj dokument Fireworks są zapisywane i stosowane jako ustawienia domyślne.

O strukturze biblioteki Flash

Obiekty Fireworks są importowane do a Folderu obiektów Flash w bibliotece Flash. Struktura wewnątrz tego katalogu jest następująca:

Plik 1 folder // Nazwany za pomocą nazwy pliku Fireworks

  • Strona 1 folder // Nazwany za pomocą nazwy strony (jeśli jest ponad jedna strona)

    — Strona 1 // Nazwana jak nazwa strony

    — — Stan 1 folder // Nazwana za pomocą nazwy stanu (jeśli jest więcej niż jeden stan)

    — Stan 1 // Nazwana jak nazwa stanu

    — — — Symbol 1 w Stanie 1 // Nazwana na podstawie nazwy symbolu

    — — — Symbol 2 w Stanie 2

    ...

    — Dzielone biblioteki, folder // Dzielone warstwy w stanach na Stronie 1

    — — Dzielone warstwy, folder // Nazwany tak jako dzielona warstwa

    — — Dzielona warstwa, symbol

  • Strona 2 folder

    — Strona 2

     —Symbol 1 na Stronie 2 (dla stron bez stanów)

    ...

  • MasterPage, folder

    — MasterPage

    — Symbol 1 na MasterPage

    ...

    — Dzielone warstwy, folder // Dzielone warstwy na stronach

    — — Dzielone warstwy, folder // Nazwany tak jako dzielona warstwa

    — — Dzielona warstwa, symbol

Informacje na temat importowania symboli Fireworks w programie Flash

Podczas importowania symboli Fireworks w programie Flash, należy wziąć pod uwagę następujące uwagi:

  • Jeśli symbol wykorzystuje skalowanie 9-plasterkowe, cztery linie pomocnicze plasterka zostaną zaimportowane i zachowane w programie Flash. Skalowanie 9-plasterkowe nie jest jednak zachowywane w przypadku animacji. Importowane symbole są zapisane jako symbole w bibliotece Flash.

  • Utracone zostaną wszystkie łagodne zmiany inteligentnych symboli. Jest importowana kopia główna symbolu.

  • Symbole bogatych grafik są przechowywany jako pliki PNG i JSF. Tylko pliki PNG są importowane. Jeśli symbol składa się z kilku ścieżek, są one połączone w jeden symbol.

  • Aby uzyskać pełną funkcjonalność inteligentnych symboli w programie Flash, zamień je wersjami odpowiednich symboli z programu Flash.

O zachowaniu widoczności i blokowaniu

Obiekty i warstwy ukryte w pliku PNG pozostają ukryte po zaimportowaniu do programu Flash. Jednak niewidoczne części inteligentnych symboli grafiki nie są importowane (na przykład stany przycisku Over i Down).

Jeśli warstwa jest zablokowana lub ukryta, wszystkie obiekty znajdujące się w warstwie dziedziczą te ustawienia i utrzymują je po zaimportowaniu do aplikacji Flash.

Po zaimportowaniu pojedynczej strony do nowej warstwy w programie Flash tworzona jest jedna warstwa dla całej strony i wyświetlane są wszystkie obiekty. Atrybuty widoczności i blokowania nie są zachowywane.

Obsługiwane efekty warstw programu Photoshop

Photoshop, Efekt aktywny – Cień

Odwzorowanie jest następujące:

  • rozmiar jest odwzorowany na rozmycieX i rozmycieY;

  • odległość odwzorowuje na odległość;

  • kolor jest odwzorowywany na kolor;

  • kąt odwzorowuje na 180 – (Photoshop, Efekt Kąt).

Photoshop, Efekt aktywny – Cień wewnętrzny

Odwzorowanie jest następujące:

  • rozmiar jest odwzorowany na rozmycieX i rozmycieY;

  • odległość odwzorowuje na odległość;

  • kolor jest odwzorowywany na kolor;

  • kąt odwzorowuje na 180 – (Photoshop, Efekt Kąt).

Photoshop, Efekt aktywny – Blask zewnętrzny

Odwzorowanie jest następujące:

  • krycie odwzorowuje na intensywność;

  • kolor odwzorowuje na kolor;

  • rozmiar jest odwzorowany na rozmycieX i rozmycieY.

Photoshop, Efekt aktywny – Blask wewnętrzny

Odwzorowanie jest następujące:

  • krycie odwzorowuje na intensywność;

  • kolor odwzorowuje na kolor;

  • rozmiar jest odwzorowany na rozmycieX i rozmycieY;

  • obiekty korzystające z dowolnego innego efektu warstwy Photoshop są rasteryzowane.

Eksportowanie grafik Fireworks do innych formatów używanych w programie Flash

Możesz eksportować grafiki Fireworks jako JPEG, GIF, PNG i pliki Adobe Illustrator 8 (AI), a następnie importować je do Flash.

Mimo że PNG jest formatem rodzimym dla Fireworks, pliki graficzne PNG eksportowane do Fireworks różnią się od źródłowych plików, które zapisujesz w Fireworks. Wyeksportowane pliki PNG, podobnie do plików GIF i JPEG, zawierają tylko dane obrazu bez dodatkowych informacji na temat plasterków, warstw, interaktywności, filtrów aktywnych lub innej zawartości, którą można edytować.

Eksportowanie grafik i animacji Fireworks jako plików SWF

Grafiki i animacje Fireworks mogą być eksportowane jako pliki Flash SWF. Aby zachować formatowanie rozmiaru i koloru obrysu, wybierz opcję Zachowaj wygląd w oknie dialogowym Opcje eksportowania Flash SWF.

Następujące formatowanie zostaje utracone podczas eksportowania do formatu SWF: tryb mieszania, warstwy, maski (zastosowane przed wyeksportowaniem), obiekty plasterków, mapy obrazu, zachowania, wypełnienia wzorem i gradient konturów.

  1. Wybierz polecenie Plik > Zapisz jako.

  2. Wpisz nazwę pliku i wybierz folder docelowy.

  3. Wybierz format Adobe Flash SWF.

  4. Kliknij Opcje. Następnie wybierz opcję Obiekty:

    Zachowaj ścieżki

    Pozwala zachować ścieżki do edycji. Efekty i formatowanie są utracone.

    Zachowaj wygląd

    Konwertuje obiekty wektorowe na obiekty bitmapowe i zachowuje wygląd zastosowanych obrysów i wypełnień. Możliwość edycji jest utracona.

  5. Wybierz opcję Tekst:

    Zachowaj możliwości edycyjne

    Pozwala zachować możliwości edycyjne tekstu. Efekty i formatowanie są utracone.

    Konwertuj na ścieżki

    Konwertuje tekst na ścieżki, zachowując własny kerning i odstępy, które określono w programie Fireworks. Możliwość edycyjne jako tekst są utracone.

  6. Ustaw jakość obrazów JPEG przy użyciu wyskakującego suwaka Jakość JPEG.

  7. Wybierz stany do eksportu i szybkość odtwarzania w sekundach.

  8. Kliknij przycisk OK, a następnie kliknij przycisk Zapisz w oknie Eksportuj.

Eksportowanie 8-bitowych plików PNG z przezroczystością

Aby wyeksportować 32-bitowy plik PNG z zachowaniem przezroczystości, zaimportuj pliki źródłowe Fireworks PNG bezpośrednio do programu Flash. Aby wyeksportować 8-bitowe pliki PNG z zachowaniem przezroczystości, wykonaj następujące czynności:

  1. W programie Fireworks wybierz opcje Okno > Optymalizacja, aby otworzyć panel Optymalizacja.

  2. Wybierz PNG 8 jako format eksportowanego pliku oraz opcję Przezroczystość alfa z wyskakującego menu Przezroczystość.

  3. Wybierz polecenie Plik > Eksportuj.

  4. Wybierz Tylko obrazy z wyskakującego menu Zapisz jako typ.

  5. Określ nazwę pliku i zapisz go.

Importowanie grafik i animacji Fireworks do programu Flash.

  1. Utwórz nowy dokument we Flash.

    Uwaga:

    Jeśli importujesz grafikę Fireworks do istniejącego pliku Flash, utwórz nową warstwę we Flash.

  2. Wybierz opcje Plik > Importuj i zlokalizuj plik grafiki lub animacji.

  3. Kliknij Otwórz, aby importować plik.

Używanie programu Fireworks do edycji grafiki w programie Flash

Dzięki zintegrowanej funkcji uruchamiania i edycji możesz użyć programu Fireworks w celu dokonania zmian w grafice zaimportowanej do aplikacji Flash, nawet jeśli nie została ona wyeksportowana z programu Fireworks.

Uwaga:

Rodzime pliki PNG programu Fireworks zaimportowane do programu Flash stanowią wyjątek — plik PNG musi zostać zaimportowany jako spłaszczona bitmapa.

Jeśli grafika została wyeksportowana z programu Fireworks, a oryginalny plik PNG został zapisany, plik PNG można edytować w programie Fireworks z poziomu programu Flash. Kiedy wrócisz do Flash, zarówno plik PNG, jak grafika we Flash będą uaktualnione.

  1. W programie Flash kliknij prawym przyciskiem myszy (Windows) lub kliknij, wciskając klawisz Control (Mac OS) plik graficzny w panelu Biblioteka dokumentów.

  2. Wybierz opcję Edycja w Fireworks z wyskakującego menu.

    Uwaga:

    Jeśli opcja Edycja w Fireworks nie pojawia się w menu, wybierz Edytuj w i zlokalizuj aplikację  Fireworks.

  3. Jeśli chcesz zlokalizować oryginalny plik PNG dla grafiki w aplikacji Fireworks, kliknij Tak w oknie Znajdź źródło, a następnie wybierz Otwórz.

  4. Dokonaj edycji obrazka i po zakończeniu kliknij przycisk Gotowe.

    Program Fireworks eksportuje nowy plik graficzny do programu Flash i zapisuje oryginalny plik PNG.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online