Wyodrębnianie właściwości obiektu CSS

Istnieje możliwość wyodrębnienia właściwości obiektu CSS, takich jak zaokrąglone narożniki, gradienty, cienie oraz przekształcenia.

  1. Zaznacz obiekt.
  2. Wybierz kolejno Okno > Właściwości CSS.
  3. Kliknij Kopiuj wszystko, aby skopiować właściwości CSS zaznaczonego obiektu. Kliknij Kopiuj zaznaczone, aby skopiować pojedyncze właściwości.
    Aby uzyskać więcej informacji, zobacz temat Wyodrębnianie właściwości CSS z obiektów projektowych przy użyciu programu Fireworks CS6.

Eksportowanie plasterków jako elementów Sprite CSS

Obiekty w dokumencie można dzielić na plasterki i eksportować je jako pojedyncze obrazy Sprite CSS. Użycie pojedynczego obrazu Sprite CSS zamiast wielu obrazów skraca czas wczytywania strony internetowej poprzez ograniczenie liczby zapytań wysyłanych do serwera.

Podczas eksportowania plasterków jako obrazu sprite CSS wraz z plikiem obrazu generowany jest również plik CSS, zawierający wartości przemieszczenia.

  1. Kliknij prawym przyciskiem myszy plasterek lub grupę plasterków.
  2. Wybierz polecenie Eksportuj obiekty CSS Sprite.
  3. Kliknij Eksportuj w oknie dialogowym Eksportuj.

Aby uzyskać więcej informacji, zobacz temat Praca z obiektami CSS Sprite w programie Fireworks CS6.

Tworzenie motywów jQuery dla urządzeń mobilnych

Bazując na domyślnych elementach Sprite i próbkach, można tworzyć motywy jQuery dla urządzeń mobilnych. Można również uzyskać podgląd motywu jQuery dla urządzeń mobilnych oraz wyeksportować go jako element CSS i Sprite.

  • Aby utworzyć motyw dla urządzeń mobilnych, wybierz kolejno Polecenia > Motyw jQuery dla urządzeń mobilnych > Utwórz nowy motyw.
  • Aby uzyskać podgląd motywów w przeglądarce, wybierz kolejno Polecenia > Motyw jQuery dla urządzeń mobilnych > Podgląd motywu.
  • Aby wyeksportować motyw dla urządzeń mobilnych jako elementy Sprite i CSS, wybierz kolejno Polecenia > Motyw jQuery dla urządzeń mobilnych > Eksportuj motyw.
  • Aby uzyskać podgląd motywu, wybierz kolejno Okno > Rozszerzenia > Podgląd motywu jQuery dla urządzeń mobilnych w aplikacji.
  • Aby dodać element zastępczy ikony, wybierz Motyw jQuery dla urządzeń mobilnych > Wstaw element zastępczy ikony.

Aby uzyskać więcej informacji, zobacz temat Tworzenie motywów jQuery dla urządzeń mobilnych przy użyciu programu Fireworks CS6.

Udoskonalenia wydajności

  • W celu rozwiązania problemu zbyt małej ilości pamięci użycie obiektów GDI przez program Fireworks zostało ograniczone.
  • Zwiększono także limit wykorzystania pamięci w komputerach z 64-bitową wersją systemu Windows w celu uzyskania lepszej stabilności podczas otwierania i zapisywania dużych plików.
  • W systemie Mac OS udoskonalono częstotliwość odświeżania Inspektora właściwości podczas przełączania pomiędzy obiektami.

Oddzielne ustawianie krycia dla wypełnienia i obrysu

  1. Zaznacz obiekt, a następnie wybierz próbnik kolorów obrysu lub wypełnienia. Możesz także wybrać próbnik kolorów wypełnienia lub obrysu z paska narzędzi.
  2. Kliknij suwak Krycie.
  3. Przeciągnij suwak na wybraną wartość.
    W systemie Max OS wpisz wartość w polu tekstowym.

Film

Obsługa funkcji Alfa w ramach wypełnienia i obrysu (00:02:50)

Zapoznaj się z omówieniem obsługi funkcji Alfa w ramach wypełnienia i obrysu. Omówienie to podkreśla oszczędzającą czas wszechstronność nowej funkcji.

Autor: Patrick Foster

Udoskonalenia wybierania kolorów

  • Do określenia opcji typu wypełnienia, takich jak brak, jednolite, gradient i wzorki w Inspektorze właściwości i pasku Narzędzia służą przyciski. Wcześniej opcje te były obsługiwane za pomocą wysuwanych menu.
  • Obecnie można określić położenie Obrysu (wewnątrz, w środku, na zewnątrz) przy pomocy okna dialogowego Obrys.

Film

Szybki dostęp panelu Kolor (00:03:02)

Odkryj zalety nowego, ulepszonego panelu Kolor, poznając jednocześnie nowe krycie wypełnienia/obrysu, gradienty, a także uzyskując informacje o wycinaniu i wklejaniu kolorów szesnastkowych i RGB.

Autor: Patrick Foster

Ustawianie kąta dla wypełnień gradientem lub wzorkiem

  1. Zaznacz obiekt.
  2. W Inspektorze właściwości wybierz wypełnienie gradientem lub wzorkiem.
  3. Określ wartość kąta w oknie dialogowym Edytuj gradient lub Edytuj wzorek.

Nowe rozszerzenie nazwy pliku fw.png

Zapisywany plik jest domyślnie zapisywany z rozszerzeniem fw.png.

Aby zmienić to domyślne zachowanie, wybierz opcję Edycja > Preferencje. Na karcie Ogólne okna dialogowego Preferencje usuń zaznaczenie opcji Dołącz rozszerzenie .fw.png i kliknij OK.

Możesz również usunąć to rozszerzenie w oknie dialogowym Zapisz jako.

Różne udoskonalenia

  • Udoskonalenia panelu Style.
  • Położenie węzła dla znacznika koloru w narzędziu Gradient jest oznaczane.
  • Używając narzędzia Kroplomierz, można kopiować, wypełniać lub obrysowywać kolorem.
    Wybierz narzędzie Kroplomierz, kliknij prawym przyciskiem myszy dany obiekt i wybierz żądaną opcję.
  • Teraz możesz odnaleźć domyślny szablon programu Fireworks oraz symbole wspólnej biblioteki w katalogu Users (Użytkownicy).
    Jeśli symbol zostanie usunięty ze wspólnej biblioteki, jego nowa kopia zostanie utworzona po ponownym uruchomieniu programu Fireworks.
  • Nazwa i poziom powiększenia zaznaczonego obiektu nie są teraz wyświetlane na pasku tytułowym dokumentu. Informacja ta jest dostępna w panelu Warstwy i pasku aplikacji.
  • Aktualizacje panelu ścieżki i próbek.
  • W systemie Mac OS pliki obrazów można teraz przeglądać w programie Google Chrome.
  • Opcja Ścieżka, zapewniająca szybki dostęp do wielu poleceń związanych ze ścieżkami, znajduje się w menu Okno.
  • Opcję Grupuj jako maska umieszczono w menu kontekstowym dostępnym po naciśnięciu prawego przycisku myszy.
  • Domyślnym ustawieniem optymalizacji dla nowego pliku jest PNG32.
  • Wycofywane funkcje:
    • Eksport AIR
    • Tworzenie pokazu slajdów
    • Tworzenie skórek Flex
    • Device Central
    • Udostępnij mój ekran
  • Obecnie można zablokować ograniczenia dla narzędzia Kadrowanie przy pomocy Inspektora właściwości.
  • Ikony miniatur dla obiektów w panelu Warstwy.
  • Następujące zasoby są obecnie dostępne w bibliotece: Gesty, Ikony, iPhone, jQuery Bootstrap, Wireframe, Reklamy Wireframe, Wireframe dla urządzeń iPad, Wireframe dla urządzeń iPhone, Wireframe dla urządzeń z systemem Windows Phone 7.
  • Biblioteka stylów została uzupełniona o następujące kategorie: style symboli przycisków, wzorki projektów wypełnienia, kolorowe kropki obrysów i style przycisków internetowych.
  • Podpowiedzi są teraz dostępne dla czynności Importowanie pliku.
  • Podczas zapisywania symbolu we wspólnej bibliotece zostaje on zachowany na obszarze roboczym.
  • Udostępniono więcej opcji dla wzorków i tekstur.
  • Wewnątrz okna dialogowego Wypełnienie gradientem użyj klawiszy Ctrl+strzałka w lewo lub Ctrl+strzałka w prawo, aby przechodzić pomiędzy znacznikami koloru lub znacznikami krycia. Na komputerze Mac użyj Command+strzałka w lewo lub Command+strzałka w prawo.
  • Biblioteki są uzupełniane o kolejne wzorki i tekstury.

Udoskonalenia API

Nowe metody

  • fw.appTemplatesDir: Zwraca ścieżkę do katalogu szablonów.
  • fw.commonLibraryDir: Zwraca ścieżkę do katalogu wspólnej biblioteki.
  • fw.activeTool: Potwierdza, czy aktywne narzędzie jest wybranym narzędziem.
    Na przykład, użyj if(fw.activeTool==Tools.pen), aby sprawdzić, czy aktywnym narzędziem jest narzędzie Pióro. Metoda ta nie zależy od nazwy narzędzia w wersji zlokalizowanej.
  • fw.appPatternsDir: Zwraca ścieżkę do katalogu Wzorki.
  • fw.appTexturesDir: Zwraca ścieżkę do katalogu Tekstury.
  • fw.reloadPatterns: Ponownie wczytuje wzorki z katalogu Wzorki.
  • fw.reloadTextures: Ponownie wczytuje teksturę z katalogu Tekstury.
  • dom.updateSymbol: Aktualizuje symbol zaimportowany ze wspólnej biblioteki.

Zaktualizowane metody

  • fw.browseForFileURL(browseType, title, previewArea, startFolder): Nowy parametr opcjonalny startFolder określa katalog główny dla okna dialogowego Przeglądaj.
  • fw.setDocumentImageSize(boundingRectangle, resolution, currentPageOnly, interpolationMethod): Nowy parametr opcjonalny interpolationMethod przyjmuje wartości całkowite od 1 do 4, określające odpowiednio sąsiada dwusześciennego, dwuliniowego, miękkiego i najbliższego.
  • fw.saveAs(doc, url, defaultFromOptions): Domyślna wartość dla parametru defaultFromOptions została zmieniona na fałsz. Jeśli jest ustawiona na prawda, plik jest zapisywany z bieżącymi ustawieniami optymalizacji.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online