Przeczytaj ten artykuł, aby nauczyć się dodawania, ustawiania i modyfikowania warstw w programie Adobe Muse.

Uwaga:

Do programu Adobe Muse nie są już dodawane nowe funkcje, a jego obsługa zostanie wycofana 26 marca 2020 r. Aby uzyskać szczegółowe informacje i pomoc, zobacz stronę na temat wycofania usługi Adobe Muse.

Praca z panelem Warstwy w programie Muse

W programie Muse jest dostępny panel Warstwy, za którego pomocą można stworzyć strukturę elementów strony oraz uporządkować projekty witryny. W tym artykule znajdziesz informacje na temat panelu Warstwy oraz strategie ułatwiające aktualizowanie projektów.

Omówienie pojęcia warstw

Każda strona witryny Muse zawiera domyślnie co najmniej jedną nazwaną warstwę. Zastosowanie wielu warstw umożliwia tworzenie i edytowanie określonych obszarów i typów zawartości, przy czym odbywa się to bez wpływu na inne obszary lub zawartość. Za pomocą warstw można np. w jednym projekcie internetowym wyświetlać zawartość strony głównej oraz informacje na paskach bocznych. Można także umieścić rzadko aktualizowaną zawartość na jednej warstwie, a na innej warstwie tego samego typu zawartość aktualizowaną regularnie.

Warstwy można porównać do ułożonych na sobie przezroczystych arkuszy. Jeśli na warstwie nie ma żadnych obiektów, widać przez nią obiekty znajdujące się na warstwach poniżej.

Zapoznaj się z panelem Warstwy i zastanów się nad sposobem działania kolejności układania.

Panel Warstwy w programie Adobe Muse
Panel Warstwy w programie Adobe Muse.

W powyższym przykładzie Warstwa 1 zawiera pole tekstowe z cyfrą 1, Warstwa 2 pole tekstowe z cyfrą 2, a Warstwa 3 pole tekstowe z cyfrą 3.

Elementy umieszczone na warstwie 3 (górnej) będą wyświetlane nad elementami warstw 2 i 1. Zachowanie to przypomina kolejność układania, którą można ustawić po zaznaczeniu elementu i wybraniu polecenia Ułóż > Przesuń na wierzch. Z wyjątkiem sytuacji, w której elementy zostają umieszczone na określonych warstwach, ich organizacja umożliwia decydowanie o kolejności układania grup elementów.

Aby zmienić kolejność układania, możesz zaznaczyć warstwę i przeciągnąć ją na inne miejsce porządkowe w panelu Warstwy. W tym przykładzie Warstwa 1 została przeciągnięta do górnej części panelu Warstwy, a Warstwa 3 została umieszczona na spodzie stosu.

Zmiana kolejności warstw w programie Adobe Muse
Zmień kolejność warstw, aby przesunąć wybrany element na wierzch.

Każda warstwa może zawierać wiele elementów, a ich kolejność na warstwie decyduje o tym, czy są wyświetlane nad czy pod pozostałymi elementami na stronie.

Warstwy zapewniają kontrolę nad aranżacją elementów na stronach witryny Muse.

Korzystanie z warstw w witrynach programu Muse

Nawet jeśli wcześniej zdarzyło ci się pracować z panelami warstw w innych narzędziach (np. edytorach zdjęć), zalecamy zapoznanie się ze sposobem działania warstw w programie Muse.

Rozwiń i zwiń warstwy. Z lewej strony nazwy każdej z warstw jest umieszczona trójkątna ikona. Gdy warstwa jest zwinięta, kliknięcie ikony trójkąta rozwija zawartość warstwy. W ten sposób uzyskujemy dostęp do listy obiektów znajdujących się na warstwie aktywnej strony oraz ich kolejności. Także grupy, widżety oraz wybrane części widżetów mają ikonę trójkąta, której kliknięcie rozwija zestaw obiektów tworzących zawartość. Obiekty te można dowolnie porządkować, blokować i odblokowywać oraz dodawać i usuwać z grup. Warstwy niezawierające obiektów na bieżącej stronie nie mają ikony trójkąta, ponieważ są już rozwinięte.

Obiekty na stronach wzorcowych są wyświetlone u dołu każdej z warstw. Obiekty wzorcowe mogą być wyświetlane przed obiektami strony dokumentu, jeśli zostały umieszczone na wyższej warstwie. Domyślnie są one jednak umieszczane na samym końcu.

Warstwy dotyczą wszystkich stron witryny, w tym wzorcowych. Jeśli np. ukryjesz Warstwę 1 podczas edytowania strony głównej dokumentu, zawartość na Warstwie 1 pozostanie ukryta na wszystkich stronach aż do ponownego wybrania opcji jej pokazania.

Omówienie panelu Warstwy

Panel Warstwy jest stosunkowo zaawansowany i zapewnia szereg przydatnych funkcji, które mogą usprawnić pracę. Poświęć chwilę na zapoznanie się z najważniejszymi funkcjami:

  • Tworzenie nowych warstw
  • Ustawianie opcji warstwy
  • Dodawanie obiektów do warstw
  • Zaznaczanie, przenoszenie i kopiowanie obiektów na warstwach
  • Wklejanie obiektów do różnych warstw
  • Powielanie warstwy
  • Zmiana kolejności warstw
  • Pokazywanie i ukrywanie warstw i obiektów
  • Blokowanie i odblokowywanie warstw
  • Usuwanie warstw
  • Scalanie warstw w dokumencie

Szczegółowy opis tych funkcji znajdziesz w odpowiednich sekcjach poniżej. Najważniejsze elementy panelu Warstwy zostały przedstawione poniżej.

Schemat funkcji w panelu Warstwy.
Schemat funkcji w panelu Warstwy.

A. Warstwa aktywna B. Usuń warstwę C. Nowa warstwa D. Wyszukaj E. Pomoc w zakresie warstw F. Warstwa zablokowana G. Warstwa ukryta H. Warstwa widoczna 

Tworzenie nowych warstw

Warstwy możesz dodać w każdej chwili, klikając przycisk Nowa warstwa u dołu panelu Warstwy. Liczba dozwolonych warstw w dokumencie jest ograniczona jedynie ilością pamięci RAM dostępnej dla programu Muse. Nowo utworzone warstwy będą zawsze wyświetlane w górnej części panelu Warstwy, jednak możesz dowolnie zmieniać ich kolejność, przeciągając je w inne miejsce.

Wykonaj poniższe kroki, aby utworzyć nową warstwę:

  1. Kliknij kartę Warstwy, aby aktywować panel Warstwy, lub wybierz polecenie Okno > Warstwy, aby go otworzyć (jeśli jest zamknięty).
  2. Kliknij przycisk Nowa warstwa znajdujący się u dołu panelu Warstwy.

Uwaga: jeśli chcesz jednocześnie utworzyć nową warstwę i otworzyć panel Opcje warstwy, kliknij przycisk Nowa warstwa z naciśniętym klawiszem Alt/Option.

Ustawianie opcji warstwy

Aktualizując atrybuty warstw w panelu Warstwy, możesz zmienić kodowanie koloru powiązanego z warstwą, pokazać lub ukryć warstwy, pokazać lub ukryć linie pomocnicze oraz zablokować warstwy, zapobiegając ich przypadkowemu zaznaczeniu lub edycji. Wykonaj poniższe kroki, aby zaktualizować opcje warstwy.

  1. Kliknij istniejącą warstwę prawym przyciskiem myszy lub dwukrotnie lewym. (Możesz także kliknąć przycisk Nowa warstwa z wciśniętym klawiszem Alt/Option).
  2. W oknie dialogowym Opcje warstwy określ opcje warstwy, a następnie kliknij OK.
Okno dialogowe Opcje warstwy
Zaktualizuj ustawienia w oknie Opcje warstwy.

Zaktualizować można następujące ustawienia:

  • Nazwa: wprowadź opisową nazwę warstwy, aby ułatwić porządkowanie zawartości strony.
  • Kolor: przypisz kolor identyfikujący obiekty istniejące na danej warstwie. Przypisanie warstwie koloru sprawia, że łatwiej jest określić, na jakiej warstwie znajdują się poszczególne zaznaczone obiekty. Po zaznaczeniu obiektu na stronie, jego obwiednia, uchwyty wyboru kształtu, ramki tekstowe i krawędzie ramki obrazu przybierają kolor warstwy, na której znajduje się obiekt. Kolor warstwy jest wyświetlany wyłącznie po zaznaczeniu obiektu.
  • Pokaż warstwę: zaznacz tę opcję, aby warstwa była widoczna. Zaznaczenie tej opcji wywołuje taki sam efekt jak kliknięcie ikony oka w panelu Warstwy, które sprawia, że warstwa jest widoczna.
  • Zablokuj warstwę: zaznacz tę opcję, aby uniemożliwić wprowadzanie zmian w obiektach na warstwie.

Dodawanie obiektów do warstw

Po zaznaczeniu całego widżetu Wskaźnik zaznaczenia w lewym górnym rogu panelu sterowania będzie wyświetlać słowa Formularz: Zwykły. Wskaż warstwę docelową, klikając ją.

Nowe obiekty można dodać do warstwy docelowej w jeden z poniższych sposobów:

  • tworząc nowe obiekty za pomocą narzędzi Tekst lub Prostokąt;
  • importując, umieszczając lub wklejając tekst lub grafikę;
  • zaznaczając obiekty na innych warstwach, a następnie przenosząc je na nową warstwę.

Nie można narysować ani umieścić nowego obiektu na warstwie ukrytej lub zablokowanej. Po wybraniu narzędzia do rysowania, narzędzia Tekst lub umieszczeniu pliku, gdy warstwa docelowa jest ukryta lub zablokowana, przy wskaźniku umieszczonym nad stroną w widoku Projektowanie jest wyświetlana przekreślona ikona ołówka. Należy wówczas pokazać lub odblokować aktywną warstwę, albo uaktywnić inną, która jest widoczna i niezablokowana.

Gdy warstwa jest ukryta lub zablokowana, wybranie polecenia Edycja > Wklej powoduje wyświetlenie ostrzeżenia z opcją pokazania lub odblokowania warstwy.

Po wskazaniu warstwy kliknięciem w panelu Warstwy w prawym górnym rogu warstwy pojawia się ikona trójkąta, a ponadto nazwa warstwy staje się pogrubiona i podświetlona, co oznacza, że jest aktywna.

Zaznaczanie, przenoszenie i kopiowanie obiektów na warstwach

Domyślnie można zaznaczyć dowolny obiekt na każdej warstwie. W panelu Warstwy kolorowe kwadraty po prawej oznaczają warstwy zawierające zaznaczone obiekty. Mały kwadrat oznacza, że na warstwie zaznaczono co najmniej jeden obiekt, a duży oznacza, że na warstwie zaznaczono wszystkie elementy. Kolor zaznaczenia warstwy pomaga rozpoznać warstwę obiektu. Aby zapobiec zaznaczaniu obiektów na określonej warstwie, zablokuj ją (lub ukryj).

  • Aby zaznaczyć poszczególne elementy na warstwie, kliknij ikonę trójkąta znajdująca się na lewo od jej nazwy, aby rozwinąć jej zawartość, a następnie zaznacz wybrany element na liście. Możesz także przeciągnąć obiekt docelowy w inne miejsce, nie zaznaczając go.
  • Aby zaznaczyć wszystkie elementy na określonej warstwie, kliknij kwadrat znajdujący się na prawo od jej nazwy.
  • Aby przenieść lub skopiować obiekty na inną warstwę, zaznacz jeden lub więcej obiektów na stronie zwykłej lub wzorcowej za pomocą narzędzia Zaznaczanie. W panelu Warstwy przeciągnij kolorowy kwadrat znajdujący się po prawej stronie listy, aby przenieść zaznaczone obiekty na inną warstwę.

Wklejanie obiektów do różnych warstw

Opcja Wklejanie z zapamiętaniem warstwy wpływa na interakcję obiektów wklejonych z innych lokalizacji z istniejącymi warstwami.

Jeśli opcja Wklejanie z zapamiętaniem warstwy jest włączona, obiekty wycinane lub kopiowane z innych warstw zachowują powiązania z warstwami po wklejeniu na nową stronę lub w nowe miejsce. Jeśli wkleisz obiekt na stronę, która nie ma takich samych warstw jak strona źródłowa, program Muse doda nazwę warstwy obiektu w panelu Warstwy drugiego dokumentu, a następnie wklei obiekt na odpowiednią warstwę.

Jeśli opcja Wklejanie z zapamiętaniem warstwy nie jest włączona, obiekty wycinane lub kopiowane z innych warstw są wklejane razem na bieżącej warstwie docelowej.

  1. Upewnij się, że opcja Wklejanie z zapamiętaniem warstwy jest wyłączona w menu kontekstowym panelu Warstwy, klikając prawym przyciskiem myszy w dowolnym jego miejscu.
  2. Zaznacz obiekty, a następnie wybierz polecenie Edycja > Kopiuj lub Edycja > Wytnij.
  3. W panelu Warstwy kliknij inną warstwę, aby wskazać ją jako docelową.
  4. Wybierz polecenie Edycja > Wklej.

Powielanie warstwy

Powielanie warstwy jest równoznaczne ze skopiowaniem jej zawartości oraz ustawień. Powielona warstwa pojawia się nad oryginalną warstwą w panelu Warstwy.

Wykonaj jedną z następujących czynności w panelu Warstwy:

  • Zaznacz nazwę warstwy, a następnie kliknij ją prawym przyciskiem myszy i w menu kontekstowym wybierz polecenie Powiel warstwę.
  • Przeciągnij nazwę warstwy i upuść ją na przycisku Nowa warstwa.

Zmiana kolejności warstw

Kolejność ułożenia warstw w dokumencie można zmienić, przemieszczając je w panelu Warstwy. Przemieszczenie warstw powoduje zmianę ich kolejności na każdej stronie, a nie tylko strony otwartej aktualnie w widoku Projektowanie.

Można również zmienić kolejność ułożenia obiektów w warstwie poprzez zmianę ich położenia w danej warstwie.

Przeciągnij warstwę w dół lub w górę listy w panelu Warstwy. Można także przeciągać kilka zaznaczonych warstw.

Pokazywanie i ukrywanie warstw i obiektów

W dowolnym momencie możesz ukryć lub pokazać dowolną warstwę oraz znajdujące się na niej obiekty. Ukrytych warstw i obiektów nie można edytować i nie są one wyświetlane na ekranie w widoku Projektowanie, Podgląd i Publikowanie ani po wyeksportowaniu witryn. Ukrywanie warstw jest przydatne w następujących sytuacjach.

  • Ukrywanie obiektów podczas projektowania witryn za pomocą układu responsywnego. Możesz też ukryć obiekty podczas projektowania strony dla różnych urządzeń na jednym obszarze roboczym. Na przykład możesz ukryć tradycyjne menu i zamiast niego użyć menu typu harmonijka podczas przygotowywania witryny przeznaczonej dla urządzeń przenośnych. Aby dowiedzieć się, w jaki sposób ukryć obiekty w układzie responsywnym, zobacz Pokazywanie lub ukrywanie obiektów w układzie responsywnym.
  • Ukrywanie tych części dokumentu, które nie będą widoczne w gotowym dokumencie.
  • Ukrywanie alternatywnych wersji dokumentu.
  • Uproszczenie wyświetlania dokumentu, aby ułatwić edytowanie innych jego części.
  • Uniemożliwianie eksportu warstwy.
  • Przyspieszanie odświeżania ekranu, gdy warstwa zawiera grafikę o wysokiej rozdzielczości.

Uwaga: ukryte warstwy lub elementy strony nie są eksportowane. Mimo to strona jest nadal wyświetlana w widoku Projektowanie, jak gdyby elementy były obecne. Ukryta ramka tekstowa wciąż spychałaby w dół strony wszystkie elementy, które znajdują się pod nią. Zapobiega to przesuwaniu zawartości w miarę ukrywania/pokazywania warstw.

Warstwy możesz ukryć lub pokazać w jeden z poniższych sposobów:

  • Aby ukryć lub pokazać warstwy pojedynczo, otwórz panel Warstwy, a następnie kliknij kwadrat w pierwszej kolumnie po lewej stronie nazwy warstwy, aby wyświetlić lub ukryć ikonę oka dla tej warstwy.
  • Aby pokazać lub ukryć poszczególne obiekty w warstwie, kliknij ikonę trójkąta przy nazwie warstwy, aby wyświetlić wszystkie znajdujące się na niej obiekty, a następnie kliknij ikonę oka, aby pokazać lub ukryć wybrany obiekt.

Blokowanie i odblokowywanie warstw

Dzięki blokowaniu można zapobiec przypadkowym zmianom na warstwie. Obok zablokowanej warstwy w panelu Warstwy wyświetlana jest ikona przekreślonego ołówka. Obiekty na zablokowanej warstwie nie mogą być zaznaczane ani bezpośrednio edytowane. Jednak jeżeli mają one atrybuty, które można edytować pośrednio, to będą ulegały zmianom. Jeśli np. zmodyfikujesz próbkę tinty, zmianie ulegną obiekty na zablokowanych warstwach, w których ta próbka tinty została wykorzystana.

Obiekty na warstwie możesz blokować i odblokowywać za pomocą panelu Warstwy. Aby odblokować i zablokować warstwy, wykonaj poniższe instrukcje:

  • Aby zablokować lub odblokować pojedynczą warstwę, otwórz panel Warstwy, a następnie kliknij kwadrat w drugiej kolumnie po lewej stronie nazwy warstwy, aby pokazać (odblokować) lub ukryć (zablokować) daną warstwę.

Usuwanie warstw

Pamiętaj, że każda warstwa ma charakter ogólno witrynowy, co oznacza, że jest wyświetlana na każdej stronie witryny. Przed usunięciem warstwy rozważ w pierwszej kolejności ukrycie pozostałych warstw, a następnie przejrzyj każdą stronę, aby upewnić się, że usunięcie obiektów, które pozostały, jest bezpieczne. Po upewnieniu się, że warstwa ma zostać usunięta, wykonaj poniższe instrukcje:

  • Aby usunąć warstwę przeciągnij ją na ikonę kosza (Usuń) u dołu panelu Warstwy lub kliknij ją prawym przyciskiem myszy i w menu kontekstowym wybierz polecenie Usuń warstwę.
  • Aby usunąć wiele warstw, kliknij ich nazwy z wciśniętym klawiszem Control/Command. Następnie przeciągnij je na ikonę kosza (Usuń) w panelu Warstwy lub kliknij je prawym przyciskiem i w menu kontekstowym wybierz polecenie Usuń warstwy.
  • Aby usunąć obiekt z warstwy, zaznacz dany obiekt w panelu Warstwy, a następnie kliknij ikonę kosza (Usuń).

Scalanie warstw w dokumencie

Liczbę warstw w witrynie można zmniejszyć przez ich scalenie bez koniczności usuwania jakichkolwiek obiektów. Podczas scalania warstw obiekty ze wszystkich zaznaczonych warstw przenoszone są na warstwę aktywną. Ze scalonych warstw w dokumencie pozostanie tylko warstwa aktywna; pozostałe zaznaczone warstwy zostaną usunięte. Witrynę można także spłaszczyć, scalając wszystkie warstwy.

Uwaga: jeśli scalisz warstwy zawierające obiekty stron oraz elementy strony wzorcowej, te ostatnie zostaną przesunięte na spód nowo powstałej warstwy.

  1. W panelu Warstwy zaznacz dowolną kombinację warstw. Pamiętaj o tym, aby zaznaczenie objęło warstwę, która ma być aktywną warstwą scalenia. Jeśli spłaszczasz witrynę do pojedynczej warstwy, zaznacz w panelu wszystkie warstwy.
  2. Kliknij prawym przyciskiem myszy w panelu Warstwy, a następnie wybierz w menu kontekstowym opcję Scal warstwy.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online