Przeczytaj ten artykuł, aby dodawać, konfigurować i testować widżety Pełnoekranowy pokaz slajdów i Pokaz slajdów miniatur w programie Adobe Muse.

Uwaga:

Do programu Adobe Muse nie są już dodawane nowe funkcje, a jego obsługa zostanie wycofana 26 marca 2020 r. Aby uzyskać szczegółowe informacje i pomoc, zobacz stronę na temat wycofania usługi Adobe Muse.

Widżety pokazu slajdów w programie Adobe Muse to interaktywne widżety współpracujące z obrazami. Podobnie do widżetu Panel z kartami, gdy użytkownik kliknie kontener miniatur, w innym, większym kontenerze na stronie zostanie otworzony odpowiadający mu obraz główny.

Program Adobe Muse obsługuje następujące typy widżetów pokazu slajdów:

  • Podstawowy: ten widżet zawiera duży kontener, w którym możesz dodawać obrazy; pod kontenerem możesz dodać podpis. W obszarze podpisu dostępne są również przyciski Poprzednia i Następna oraz numer bieżącego slajdu.
  • Pusty: opcja jest podobna do podstawowego pokazu slajdów. Niemniej w tym widżecie kontenery są puste.
  • Pełny ekran: ten widżet jest wyświetlany na pełnym ekranie po przeciągnięciu i upuszczeniu do obszaru roboczego. Domyślnie w małym kontenerze w lewym górnym rogu strony znajdują się przyciski Poprzednia i Następna oraz numer bieżącego slajdu.
  • Ramka lightbox: ten widżet zaciemnia pozostałą część strony poza pokazem slajdów lub elementem galerii, który jest aktywnie wyświetlany na stronie. Ramka lightbox jest typowo używanym widżetem dla pokazów slajdów, ponieważ uwaga użytkownika zostaje od razu skupiona na aktywnej galerii.
  • Miniatury: widżet ten jest podobny do widżetu kompozycji, w którym miniatury znajdują się po lewej stronie obszaru galerii. Gdy użytkownik kliknie miniaturę, w obszarze galerii zostanie wyświetlony odpowiadający jej obraz.

W poniższym artykule utworzymy galerię zdjęć, która będzie się składać z serii miniatur wyświetlanych u góry oraz większego okna, w którym będzie wyświetlana większa wersja wybranego zdjęcia. Za pomocą panelu Opcje możesz sterować zachowaniem i wyglądem galerii zdjęć. Wygląd pokazu slajdów możesz także wystylizować, dostosowując ustawienia w panelu sterowania.

Dodawanie pokazu slajdów o pełnej szerokości: dowiedz się, jak dodać pokaz slajdów o pełnej szerokości do projektu witryny w programie Adobe Muse. Pokaz slajdów o pełnej szerokości jest dostępny w Bibliotece widżetów.
Danielle Beaumont

Dodawanie widżetu Pokaz slajdów miniatur do strony

Pokazy slajdów można także dodawać do stron bezpośrednio, jednak w tym przykładzie zajmiemy się zagnieżdżeniem widżetu Pokaz slajdów miniatur w obszarze zawartości widżetu Panel z kartami. Aby dodać pokazy slajdów bezpośrednio, wykonaj następujące czynności:

  1. Otwórz program Adobe Muse. Na ekranie powitalnym wykonaj jedną z następujących czynności:

    • Kliknij polecenie Utwórz nowy, aby dodać widżet Pokaz slajdów do nowej strony, nad którą właśnie pracujesz.
    • Kliknij polecenie Otwórz i otwórz istniejący plik .muse, do którego chcesz dodać widżet. Kliknij dwukrotnie i otwórz stronę, na której chcesz umieścić widżet Pokaz slajdów.
  2. Otwórz panel Biblioteka widżetów (Okno > Biblioteka widżetów) i rozwiń sekcję Pokaz slajdów. Wybierz żądany widżet z listy. Wybierz na przykład widżet Pokaz slajdów miniatur z listy i przeciągnij go do widoku Projektowanie.

    Pokaz slajdów miniatur w programie Adobe Muse, Biblioteka widżetów.
    Przeciągnij widżet Pokaz slajdów miniatur na stronę.

    Zauważ, że po lewej stronie znajduje się kontener miniatur, kontener dla obrazu głównego oraz kontener z podpisem pod obrazem.

    Uwaga:

    Aby usunąć domyślną zawartość uzupełnioną w widżecie, kliknij prawym przyciskiem myszy na widżecie i wybierz opcję Wyczyść zawartość widżetu.

  3. Aby usunąć miniatury, zaznacz zawartość zastępczą (ramkę obrazu oraz ramkę tekstową w obszarze zawartości) i usuń ją.

Konfigurowanie widżetu Pokaz slajdów miniatur za pomocą panelu Opcje

Możesz skonfigurować ustawienia widżetu pokazu slajdów przy użyciu panelu Opcje powiązanego z widżetem. Czytaj dalej, aby dowiedzieć się, jak włączyć automatyczne odtwarzanie, efekty przejścia, przesuwanie dla urządzeń dotykowych itp.

  1. Zaznacz widżet i kliknij niebieską ikonę strzałki, aby otworzyć panel Opcje. W tym przykładzie przyciski Następny i Poprzedni nie są potrzebne. Dlatego też usuń zaznaczenie opcji Poprzedni i Następny, aby je wyłączyć. Zwróć uwagę, że przyciski znikają natychmiast po usunięciu zaznaczenia.

    Usuń zaznaczenie opcji Podpisy i Licznik, tak aby na stronie pozostały tylko przyciski wyzwalaczy miniatur oraz większy kontener celu. Przejrzyj opcje i zaktualizuj je, aby dopasować je do ustawień wymienionych poniżej:

    • Nowy obraz główny: Wypełnij ramkę proporcjonalnie
    • Nowa miniatura: Wypełnij ramkę proporcjonalnie
    • Przejście: Blaknięcie
    • Szybkość przejścia: 0,5 s
    • Odtwarzanie automatyczne: Wyłączone
    • Wznów po: Włączone
    • Odtwórz raz: Wyłączone
    • Przetasuj: Wyłączone
    • Włącz przesuwanie palcem: Włączone
    • Ramka lightbox: Włączone
    • Pełny ekran: Włączone
    • Automatyczna ramka Lightbox: Wyłączone
    • Własny układ miniatur: Włączone
    • Pierwsza: Wyłączone
    • Poprzednia: Włączone
    • Następna: Włączone
    • Ostatnia: Wyłączone
    • Podpisy: Włączone
    • Licznik: Włączone
    • Przycisk Zamknij: Wyłączone
    • Miniatury: Włączone
    • Pokaż części ramki lightbox podczas edytowania: Włączone
    • Edytuj razem: Włączone
    Panel opcji pokazu slajdów
    Zaktualizuj ustawienia widżetu Pokaz slajdów miniatur w panelu Opcje.

  2. Poszczególne widżety różnią się opcjami, a niektóre z nich są bardziej skomplikowane od innych. Przyjrzyj się opcjom menu przez chwilę, aby zapoznać się z dostępnymi ustawieniami. Oto krótkie omówienie:

    Dodaj obrazy: kliknięcie ikony folderu umożliwia przeglądanie i wybór obrazów do wyświetlenia.

    Nowy obraz główny: określa sposób wyświetlania zawartości większego obrazu w kontenerze docelowym.

    • Dopasuj zawartość proporcjonalnie: pierwotne wymiary pliku obrazu zostają zachowane, nawet jeśli nie pasuje ono do kontenera celu. Część kontenera, w której nie mieści się obraz, może być pusta.
    • Wypełnij ramkę proporcjonalnie: wielkość pliku zdjęcia zostaje zmieniona, aby dopasować ją do proporcji kontenera celu. Część obrazu może zostać wykadrowana.

    Nowa miniatura: określa sposób wyświetlania zawartości mniejszej miniatury obrazu w kontenerze wyzwalacza.

    • Dopasuj zawartość proporcjonalnie: pierwotne wymiary pliku obrazu zostają zachowane, nawet jeśli nie pasują one do kontenera celu. Część kontenera, w której nie mieści się obraz, może być pusta.
    • Wypełnij ramkę proporcjonalnie: wielkość pliku zdjęcia zostaje zmieniona, aby dopasować ją do proporcji kontenera celu. Część obrazu może zostać wykadrowana.

    Przejście: metoda animacji wykorzystywana w czasie, gdy zawartość kontenera celu jest zastępowana innym kontenerem. Przejścia są dostępne także na urządzeniach mobilnych, więc jeśli tworzysz witryny dla takich urządzeń. osoby odwiedzające mogą przesunąć palcem po ekranie, aby odtworzyć przejście przed wyświetleniem kolejnego elementu zawartości.

    • Blaknięcie: krycie nowego kontenera zwiększa się w miarę zanikania istniejącego kontenera.
    • Poziomo: nowy kontener pojawia się z boku w pozycji poziomej i nachodzi na istniejący.
    • Pionowo: nowy kontener pojawia się z boku w pozycji pionowej i nachodzi na istniejący.

    Szybkość przejścia: czas potrzebny na odtworzenie animacji wyrażony w sekundach.

    Odtwarzanie automatyczne: gdy ta opcja jest włączona, pokaz slajdów będzie odtwarzany automatycznie, a nie w wyniku interakcji, która wymaga od osoby odwiedzającej kliknięcia każdego z wyzwalaczy w celu wyświetlenia odpowiedniej zawartości w sekwencji. Ustaw liczbę sekund, przez jaką ma być wyświetlany obraz zanim nastąpi przejście do kolejnego.

    Przetasuj: gdy opcja jest włączona, obrazy są wyświetlane losowo, a nie po kolei.

    Ramka lightbox: gdy opcja jest włączona, pokaz slajdów zaciemnia pozostałą część strony, wyświetlając nakładkę podczas odtwarzania zawartości kontenera celu.  Po zamknięciu ramki lightbox podgląd całej strony zostaje przywrócony.

    Włącz przesuwanie palcem: gdy opcja jest zaznaczona, a witryna jest dostępna w układzie Tablet lub Telefon, który umożliwia wyświetlanie zawartości na urządzeniach mobilnych, interaktywne elementy widżetu obsługują gesty wykonywane palcami na ekranie.

    Sekcja Części:

    • Pierwsza: gdy opcja jest zaznaczona, wyświetlany jest przycisk nawigacyjny Pierwsza.
    • Poprzednia: gdy opcja jest zaznaczona, wyświetlany jest przycisk nawigacyjny Poprzednia.
    • Następna: gdy opcja jest zaznaczona, wyświetlany jest przycisk nawigacyjny Następna.
    • Ostatnia: gdy opcja jest zaznaczona, wyświetlany jest przycisk nawigacyjny Ostatnia.
    • Podpisy: gdy opcja jest zaznaczona, pod galerią wyświetlane są podpisy.
    • Licznik: gdy opcja jest zaznaczona, wyświetlany jest licznik galerii.
    • Przycisk Zamknij: gdy opcja jest zaznaczona, wyświetlany jest przycisk Zamknij.

    Miniatury: gdy opcja jest zaznaczona, wyświetlane są przyciski wyzwalacza miniatur.

    Sekcja Edytowanie:

    • Pokaż części ramki lightbox podczas edytowania: gdy opcja Ramka lightbox jest zaznaczona, każdy obszar celu jest domyślnie wyświetlany tylko po wybraniu odpowiadającego mu wyzwalacza na stronie. Włączenie tej opcji podczas projektowania układu ułatwia podgląd celów. Ustawienie to nie ma wpływu na wyświetlanie pokazu slajdów podczas uzyskiwania podglądu strony w widoku Podgląd lub w przeglądarce. Jeśli opcja Ramka lightbox nie jest zaznaczona, opcja ta jest nieaktywna (wyszarzona). 

    Zauważ, że opcja Pokaż części ramki lightbox podczas edytowania jest aktywna tylko po wybraniu widżetu Pokaz slajdów Lightbox.

    • Edytuj razem: ta opcja jest domyślnie włączona, co usprawnia edytowanie widżetów. Jeśli nie ma konieczności, aby każdy wyzwalacz wyglądał inaczej, warto pozostawić tę opcję zaznaczoną. Dzięki temu zmiana dokonana na jednym elemencie zostanie automatycznie zastosowana wobec pozostałych.

    Po przejrzeniu dostępnych opcji kliknij w dowolnym miejscu na stronie, aby zamknąć menu Opcje.

    Uwaga:

    Opcje Lightbox i Tryb pełnoekranowy nie są aktywne dla Pełnoekranowych pokazów slajdów.

    Nie możesz włączyć opcji Tryb pełnoekranowy dla żadnego innego widżetu pokazu slajdów, poza Pełnoekranowym.

Zmiana rozmiaru i położenia elementów widżetu Pokaz slajdów miniatur

  1. Kliknij i wybierz widżet Pokaz slajdów. Za pomocą narzędzia Zaznaczanie przeciągnij uchwyty widżetu, aby zmienić jego wymiary na 790 pikseli szerokości i 490 pikseli wysokości. Aby sprawdzić wymiary, spójrz na panel Przekształć lub pola przekształcania na panelu sterowania.

  2. Nie usuwając zaznaczenia pokazu slajdów, kliknij ponownie Kontener miniatury, aby zaznaczyć kontener zawierający trzy miniatury. Poszerz pokaz slajdów za pomocą bocznych uchwytów transformacji, a następnie za pomocą narzędzia Zaznaczenie przeciągnij miniatury, aż znajdą się pionowo nad środkiem kontenera z obrazem głównym.

    Kontener z pięcioma miniaturami
    Zaznacz kontener wyzwalacza miniatur i umieść go nad większym kontenerem celu.

    O wyrównaniu kontenera miniatur z kontenerem obrazu głównego w pionie poinformuje niebieska, inteligentna linia pomocnicza, która wyświetli się na moment podczas przeciągania elementu.

    Wykonaj poniższe kroki, aby dodać grafikę do galerii zdjęć, generując jednocześnie kontenery miniatur odpowiadające poszczególnym obrazom i kontener obrazu głównego.

  3. Kliknij niebieski przycisk strzałki, aby otworzyć menu Opcje. Kliknij ikonę folderu obok pozycji Dodaj obrazy..., a następnie przejdź do folderu z zapisanymi plikami.

  4. Wybierz żądane pliki obrazów. Kliknij przycisk Otwórz, aby zamknąć okno dialogowe Importuj.

    Okno dialogowe Importuj
    Zaznacz zestaw pięciu zdjęć znajdujących się w folderze gallery.

    Po zaznaczeniu wielu plików obrazu zostają one wczytane do widżetu Pokaz slajdów miniatur. Ta strategia umożliwia zaznaczenie wielu obrazów plików i wygenerowanie przycisku kontenera miniatury odpowiadającego każdemu nowemu, większemu plikowi obrazu w kontenerze obrazu głównego.

    Nowe obrazy zostaną dodane do istniejących przycisków miniatur.

  5. Dwukrotnie kliknij i wybierz obraz miniatury, który jest wyświetlany domyślnie po pierwszym dodaniu pokazu slajdów. Naciśnij przycisk Delete (Mac) lub Backspace (Windows), aby usunąć każdy z nich przy zaznaczaniu, aż zostaną tylko nowe miniatury.

    Miniatury i obraz pokazu slajdów
    Zaznacz każdą z czarno-białych miniatur i naciśnij klawisz Backspace lub Delete, aby kolejno je usunąć.

    Uważaj, aby przypadkowo nie usunąć całego zestawu miniatur. Jeśli tak się stanie, cofnij ostatnią operację, wybierając polecenie Edycja > Cofnij. Następnie, przed naciśnięciem klawisza Backspace lub Delete upewnij się, że we wskaźniku zaznaczenia jest widoczne słowo Miniatura.

  6. Zaznacz kontener zawierający zestaw pięciu obrazów miniatur. Użyj uchwytów transformacji, aby zmienić ich rozmiar tak, żeby pozostałe miniatury znalazły się centralnie nad kontenerem z obrazem głównym.

    Miniatury i obraz pokazu slajdów
    Zmień rozmiar kontenera miniatur, aby wyrównać go z kontenerem obrazu głównego.

Korzystanie z responsywnych widżetów pokazu slajdów

Pokazy slajdów są domyślnie responsywne lub elastyczne. Aby korzystać z responsywnego widżetu Pokaz slajdów na swojej witrynie Adobe Muse, wykonaj jedną z poniższych czynności:

  • Jeśli tworzysz nową witrynę, otwórz ją oraz przeciągnij i umieść w niej widżet Pokaz slajdów z panelu Biblioteka widżetów. Zauważ, że widżet jest domyślnie responsywny.
  • Jeśli masz istniejący plik .muse, otwórz ten plik, używając najnowszej wersji programu Adobe Muse. Wybierz widżet. Aby widżet był responsywny, zaznacz elementy widżetu i wybierz opcję Responsywna szerokość i wysokość lub Responsywna szerokość z listy rozwijanej Zmiana rozmiaru w menu kontekstowym.
Wybieranie opcji Zmiana rozmiaru w celu uzyskania responsywnego widżetu Pokaz slajdów
Wybieranie opcji Zmiana rozmiaru w celu uzyskania responsywnego widżetu Pokaz slajdów

Jeśli dodajesz widżet pokazu slajdów do witryny responsywnej, sprawdź położenie i rozmiar widżetu we wszystkich punktach przerwania. Możesz zmodyfikować zawartość i rozmiar poszczególnych elementów w widżecie Pokaz slajdów. Możesz również włączyć ustawienia responsywności dla poszczególnych elementów, takich jak przycisk Poprzedni, Następny lub Podpisy w różnych punktach przerwania.

Testowanie wyglądu widżetu Pokaz slajdów miniatur

Po zmianie położenia elementów pokazu slajdów i usunięciu zastępczych obrazów miniatur możesz przetestować pokaz slajdów, aby sprawdzić jego wyświetlanie.

  1. W pierwszej kolejności przetestuj galerię zdjęć w widoku Projektowanie, klikając każdą z miniatur u góry, aby uzyskać podgląd zdjęcia głównego w większym kontenerze poniżej.

  2. Kliknij przycisk Podgląd, aby zobaczyć, jak galeria będzie się prezentować w przeglądarce. Wejdź w interakcję z pokazem slajdów i sprawdź, czy po kliknięciu miniatury jest wyświetlana większa wersja obrazu.

    Testowanie miniatur i pokazu slajdów
    Umieść galerię tak, aby znajdowała się pośrodku kontenera Obszar zawartości widżetu Panel z kartami.

  3. Wybierz polecenie Plik > Podgląd strony w przeglądarce, aby wyświetlić stronę w domyślnej przeglądarce.

    Zmień rozmiar przeglądarki i wyświetl podgląd widżetu Pokaz slajdów przy różnych rozmiarach ekranu. Możesz zobaczyć, że widżety pokazu slajdów są domyślnie responsywne. Oznacza to, że zmieniają rozmiar i dostosowują się do rozmiaru ekranu. 

    Możesz też użyć suwaka w widoku projektowania, aby wyświetlić podgląd widżetów. Jeśli chcesz zmodyfikować widżet lub zmienić jego położenie w dowolnym miejscu, dodaj punkt przerwania i ponownie wyrównaj widżet. 

  4. Przetestuj działanie widżetu Panel z kartami. Kliknij karty, aby wyświetlić przypisaną do nich zawartość w kontenerach. Następnie przetestuj pokaz slajdów na karcie „Gallery”, klikając przyciski miniatur, co powinno spowodować wyświetlenie obrazów głównych poniżej.

Tworzenie prezentacji ze slajdami za pomocą widżetu Pokaz slajdów

Widżet Pokaz slajdów to kolejna funkcja witryny, którą można dodać do strony. Możesz skonfigurować pokaz slajdów, który będzie wymagać od osób odwiedzających klikania miniatur w celu wyświetlenia większych wersji zdjęć. Możesz także tworzyć pokazy, które będą odtwarzane automatycznie po wczytaniu strony. Pokazy z funkcją autoodtwarzania to wspaniały sposób dodawania do witryny interesującej zawartości w postaci serii zdjęć. Możesz sterować odtwarzaniem pokazu slajdów, ustawiając typ przejść, które kontrolują animację pokazu.

W poniższej podsekcji dodamy do strony domowej witryny pokaz slajdów z autoodtwarzaniem.

W widoku Planowanie kliknij dwukrotnie miniaturę strony domowej, aby otworzyć ją w widoku Projektowanie.

Konfigurowanie widżetu Pokaz slajdów na autoodtwarzanie

Wykonaj poniższe kroki, aby utworzyć prezentację zestawu zdjęć:

  1. W bibliotece widżetów kliknij opcję Pokazy slajdów.

  2. Zaznacz widżet Podstawowy i przeciągnij go na stronę.

  3. Domyślnie widżet Podstawowy pokaz slajdów zawiera jeden ciemny prostokąt (obraz zastępczy), zastępczy podpis, liczbę obrazów (1-1) oraz dwa przyciski strzałek (następna/poprzednia), za pomocą których osoby odwiedzające mogą przeskakiwać między obrazami w zestawie.

  4. Kliknij niebieską ikonę strzałki, aby otworzyć menu Opcje. Sprawdź i ustaw poniższe opcje:

    • Przejście: blaknięcie
    • Odtwarzanie automatyczne: wolno
    • Nowy obraz główny: wypełnij ramkę proporcjonalnie
    • Nowa miniatura: wypełnij ramkę proporcjonalnie
    • Ramka lightbox: usuń zaznaczenie
    • Części: usuń zaznaczenie wszystkich opcji, aby ukryć podpisy, licznik oraz przyciski następna/poprzednia.

    Uwaga:

    Pokaz slajdów uruchomi się automatycznie po wczytaniu strony bez udziału osoby odwiedzającej. Jeśli chcesz utworzyć pokaz slajdów sterowany kliknięciami osoby odwiedzającej, pozostaw puste pole Odtwarzanie automatyczne, a w sekcji Części w menu Opcje zaznacz opcje Następna i Poprzednia.

  5. Kliknij w dowolnym miejscu poza menu Opcje, aby je zamknąć. Zwróć uwagę, że po dokonaniu zmian widoczny jest tylko ciemny prostokąt. W dowolnej chwili możesz zmienić konfigurację widżetów, korzystając z ustawień w menu Opcje.

  6. Kliknij dwukrotnie i wybierz ramkę obrazu (ciemnoszary prostokąt), a następnie przeciągnij uchwyty boczne, aby rozszerzyć pokaz slajdów na całą szerokość strony.

    Ramka obrazu pokazu slajdów
    Przeciągnij boczne uchwyty ramki obrazu pokazu slajdów, aby dopasować go do wielkości strony.

  7. Za pomocą strzałek górnej i dolnej zwiększ długość ramki obrazu, aby wypełnić całą stronę główną. U dołu rozciągnij ramkę obrazu i zatrzymaj ją tuż nad obrazem z zygzakowatym wypełnieniem, który znajduje się w górnej części stopki. Na tym etapie ciemnoszary element zastępczy może zakrywać obraz brązowej kropli po prawej stronie paska nawigacyjnego.

  8. Kliknij niebieską ikonę strzałki, aby otworzyć ponownie menu Opcje. Tym razem kliknij ikonę folderu obok opcji Dodaj obrazy.

  9. W oknie dialogowym Importuj przejdź do folderu zasobów i otwórz zasoby. Kliknij Wybierz, aby dodać obrazy do pokazu slajdów.

  10. Kliknij Podgląd, aby odtworzyć pokaz slajdów. Szybkość autoodtwarzania jest niska, jednak możesz zmienić to ustawienie w menu Opcje, jeśli chcesz, aby obrazy przełączały się szybciej. Zwróć uwagę, że po wyświetleniu ostatniego zdjęcia pokaz slajdów zapętla się i powtarza sekwencję od nowa. Gdy opcja autoodtwarzania jest włączona, pokaz zapętla się w nieskończoność.

Na tym etapie pokaz slajdów jest gotowy. Jeśli jednak chcesz rozwiązać problem kropli po prawej, musisz wykonać jeszcze jeden krok.

  1. W widoku Planowanie kliknij dwukrotnie miniaturę strony A-wzorcowej, aby otworzyć ją w widoku Projektowanie.

  2. Za pomocą narzędzia Zaznaczanie zaznacz brązową kroplę w prawej górnej części grafiki nawigacyjnej.

  3. Kliknij obraz kropli prawym przyciskiem myszy i w menu kontekstowym wybierz polecenie Ułóż > Przesuń na wierzch.

  4. Kliknij X na karcie strony A-wzorcowej, aby ją zamknąć. Otwórz stronę, na której dodano widżet Podstawowy. Kliknij Podgląd i zwróć uwagę, że obraz kropli jest teraz wyświetlany na tle pokazu slajdów z funkcją autoodtwarzania. Po sprawdzeniu pokazu slajdów wróć do widoku projektowania.

    Uwaga:

    Z racji tego, że pasek nawigacyjny został utworzony na stronie A-wzorcowej, wszelkie zmiany dotyczące nawigacji oraz innych wspólnych elementów można wprowadzać tylko po otwarciu tej strony w widoku Projektowanie. Choć elementy strony wzorcowej, takie jak nagłówek i stopka, widać na innych edytowanych stronach, nie można ich tam edytować.

Dodawanie widżetów pełnoekranowego pokazu slajdów

Możesz tworzyć pełnoekranowe pokazy slajdów przy pomocy widżetu Fullscreen Slideshow. Gdy odwiedzający klika pełnoekranowy pokaz slajdów, zawartość jest skalowana tak, by wypełniała całe okno przeglądarki na komputerze lub ekran urządzenia, tymczasowo przesłaniając resztę zawartości witryny. W razie potrzeby pokaz slajdów może być ustawiony na automatyczne odtwarzanie, tak aby rozpoczynał cykl zmiany obrazów po załadowaniu się strony. Odwiedzający mogą wyjść z pokazu slajdów wciskając klawisze Escape.

Wykonaj następujące czynności, aby dodać widżet pełnoekranowego pokazu slajdów do witryny:

  1. Uruchom program Adobe Muse. Kliknij dwukrotnie stronę, aby otworzyć ją w widoku Projektowanie.

  2. Wybierz Okno > Biblioteka widżetów, aby przejść do biblioteki widżetów, lub kliknij kartę Biblioteka widżetów w zestawie panelu, aby ją uaktywnić.

  3. Rozwiń sekcję pokazów slajdów na liście widżetów. Wybierz widżet pełnoekranowego pokazu slajdów w sekcji Pokazy slajdów.

    Biblioteka widżetów
    Znajdź i wybierz widżet pełnoekranowego pokazu slajdów w Bibliotece widżetów.

Konfiguracja widżetów pełnoekranowego pokazu slajdów

Widżet pełnoekranowego pokazu slajdów zachowuje się inaczej niż pozostałe widżety w programie Adobe Muse. Poświęć chwilę, by zobaczyć, jak działa.

  1. Przeciągnij widżet pełnoekranowego pokazu slajdów z biblioteki widżetów na stronę.

    Zauważ, że domyślna zawartość zostaje przeskalowana tak, aby pasowała zarówno do wysokości, jak i szerokości całego okna przeglądarki.

    Widżet pełnoekranowego pokazu slajdów
    Widżet pełnoekranowego pokazu slajdów rozszerza się tak, by pokryć widoczny obszar witryny, wypełniając okno przeglądarki.

    Domyślnie po dodaniu widżetu pełnoekranowego pokazu slajdów wyświetla on przyciski Poprzednia, Następna i pole licznika w prawym górnym rogu.

  2. Kliknij niebieską strzałkę, aby obejrzeć ustawienia w panelu Opcje.

    Panel opcji pokazu slajdów
    Panel Opcje wyświetla domyślnie ustawienia zastosowane wobec widżetu pełnoekranowego pokazu slajdów.

    Opcja Wypełnij ramkę proporcjonalnie jest automatycznie stosowana do nowego obrazu głównego (dużych obrazów) i nowych miniatur obrazów, w celu usprawnienia widoku pełnoekranowego.

  3. Wybierz typ przejścia, który chcesz zastosować. Użyj menu Przejście, aby wybrać pomiędzy przejściem Zanikaniem, Poziomym i Pionowym. Domyślnie prędkość przejścia jest ustawiona na 0,5 sekundy, ale możesz dowolnie ją dostosować.

    Gdy włączona jest opcja Automatycznie odtwarzanie, pokaz slajdów rozpoczyna się, gdy strona zostaje załadowana i zmienia zawartość co zadaną liczbę sekund. Domyślnie przy włączonym automatycznym odtwarzaniu każdy obraz jest wyświetlany przez 3,5 sekundy.

    Podczas konfiguracji widżetu pełnoekranowego pokazu slajdów częste jest włączanie przycisków nawigacji Następna i Poprzednia, dzięki czemu miniatury są domyślnie ukryte. Jednak możesz włączyć opcję miniatur, jeśli chcesz je wyświetlać na górze głównego obrazu pokazu slajdów.

    Jeśli miniatury są ukryte, należy upewnić się, że elementy Następna i Poprzednia są włączone. Licznik jest opcjonalny — pomaga odwiedzającym zorientować się, który obraz w zestawie jest aktualnie wyświetlany.

  4. Jeśli chcesz wyświetlić przyciski Następna, Poprzednia oraz licznik w określonej części strony, skorzystaj z narzędzia Zaznaczanie, aby przesunąć je do żądanej lokalizacji, a następnie przypnij te elementy sterujące. Jeśli chcesz też, aby miniatury pozostały w tym samym miejscu strony, umieść zestaw miniatur i również przypnij go do miejsca. Jeśli chcesz wyświetlić przyciski Następna, Poprzednia oraz licznik w określonej części strony, skorzystaj z narzędzia Zaznaczanie, aby przesunąć je do żądanej lokalizacji, a następnie przypnij te elementy sterujące. Jeśli chcesz też, aby miniatury pozostały w tym samym miejscu strony, umieść zestaw miniatur i również przypnij go do miejsca.

    Możesz zmodyfikować ustawienia przypinania i zmiany rozmiaru dla różnych punktów przerwania, gdy dodasz ten widżet do witryny responsywnej.

Dodawanie obrazów do pełnoekranowego pokazu slajdów

Następnie dodajesz obrazy do widżetu pełnoekranowego pokazu slajdów. Wykonaj następujące czynności:

  1. Wybierz polecenie Plik > Umieść.

  2. W wyświetlonym oknie importu przytrzymaj klawisz Shift i kliknij, aby zaznaczyć kilka sąsiadujących plików obrazów na komputerze. Jeśli tak wolisz, możesz wcisnąć i przytrzymać klawisze Command (Mac) lub Control (Windows) podczas wybierania kilku nie sąsiadujących ze sobą plików obrazów z folderu zasobów.

  3. Kliknij Otwórz, aby pobrać wybrane pliki do modułu umieszczania.

    Uwaga:

    Nawet jeśli wybrane obrazy mają różne rozmiary i proporcje, opcja Wypełnij ramkę proporcjonalnie przeskaluje je tak, aby dokładnie pasowały do wymiarów strony.

  4. Kliknij jednokrotnie pokaz slajdów, aby dodać wybrane pliki obrazów. Pamiętaj, że domyślne obrazy pokazu slajdów są usuwane automatycznie natychmiast po dodaniu nowych obrazów.

  5. Wybierz polecenie Plik > Podgląd strony w przeglądarce. Zmień rozmiar okna przeglądarki i obserwuj, jak zawartość pokazu slajdów zostaje przeskalowana i przycięta tak, by wypełniła całe okno przeglądarki. Klikaj przyciski Następna i Poprzednia, aby przerzucać serię obrazów, lub po prostu pozwól na odtwarzanie obrazów, jeśli włączona jest opcja autoodtwarzania.

  6. Zamknij okno przeglądarki i powróć do programu Adobe Muse.

Konfigurowanie miniatur Free Form w widżecie Pokaz slajdów

Opcja miniatur Free Form daje pełną kontrolę nad tym, jak miniatury w pokazie slajdów będą wyświetlane. Zamiast wyrównywania miniatur w rzędzie lub zestawie rzędów, możesz umieścić każdą miniaturkę w dowolnej lokalizacji, którą wybierzesz.

  1. W widoku Projektowanie otwórz Bibliotekę widżetów i rozwiń sekcję Pokaz slajdów. Przeciągnij dowolne widżety pokazu slajdów na stronę.

  2. Gdy zaznaczono całą stronę, kliknij dwukrotnie i wybierz obraz miniatury. Możesz zobaczyć, który element został zaznaczony przez sprawdzenie Wskaźnika zaznaczenia w lewym górnym rogu panelu sterowania.

    Kontener miniatur
    Obwiednia otacza kontener miniatur, gdy jest on zaznaczony.

    Domyślnie miniatury wyświetlane w widżetach Pokazu slajdów są przechowywane w kontenerze o nazwie Kontener miniatur. Ten zewnętrzny kontener zapewnia, że miniatury są wyrównane w liniach prostych, zależnie od zmian rozmiaru zewnętrznego kontenera. Zestaw miniatur obrazów jest zagnieżdżony w Kontenerze miniatur dla wszystkich pokazów slajdów z włączonymi miniaturami, dopóki nie zostanie włączona opcja Miniatury Free Form.

Konfigurowanie ustawień wyświetlania miniatur Free Form

Jeśli wolisz wyświetlać miniatury w losowych lub niewyrównanych pozycjach, możesz usunąć zewnętrzny kontener i umieścić każdy obraz miniatury w żądanym położeniu na stronie. Wykonaj poniższe kroki:

  1. Gdy wybrany jest widżet pokazu slajdów, kliknij niebieską strzałkę, aby wejść do menu Opcje.

  2. Zaznacz pole wyboru obok opcji: Miniatury Free Form. Obwiednia wokół Kontenera miniatur w widoku Projektowanie natychmiast znika, a we wskaźniku zaznaczenia widoczna jest fraza: Pokaz slajdów.

    Panel opcji kontenera miniatur
    Włączenie opcji Miniatury Free Form usuwa kontener miniatur.

  3. Aby zamknąć menu Opcje, kliknij w dowolnym miejscu na stronie.

    Teraz po usunięciu zewnętrznego kontenera miniatur możesz zmienić pozycję każdego obrazu miniatury tak, by pasowała do projektu strony.

  4. Skorzystaj z narzędzia Zaznaczanie, aby wybrać jedną miniaturkę. Gdy zostanie wybrana, Wskaźnik zaznaczania wyświetli słowo: Miniatura. Przesuń wybraną miniaturkę w wybrane położenie. Powtarzaj ten krok, aby zmienić pozycję wszystkich miniatur. Jeżeli chcesz, aby wszystkie miniatury pozostały w miejscu podczas przewijania lub zmiany rozmiaru przeglądarki, możesz przypiąć każdą miniaturkę.

    Uwaga:

    Jeżeli chcesz zmienić rozmiar kontenera miniatur tak, by miały inne rozmiary, wyłącz opcję Edytuj razem w menu Opcje a następnie skorzystaj z narzędzia Zaznaczanie, aby indywidualne przeciągnąć rogi każdej miniatury i przeskalować je w żądany sposób.

    W przypadku witryny responsywnej możesz też ponownie wyrównywać, zmieniać rozmiar i konfigurować opcje przypinania dla miniatur.

  5. Wybierz polecenie Plik > Podgląd obrazu w przeglądarce. Miniatury pokazu slajdów zostają rozrzucone po stronie. Kliknij miniatury, aby zobaczyć odpowiadający im obraz wyświetlany w pokazie slajdów.

  6. Zamknij przeglądarkę i powróć do programu Adobe Muse.

Utworzenie ramki lightbox powoduje wyświetlenie opcji widżetów Pokaz slajdów

To, że zawartość jest wyświetlana w ramce lightbox, oznacza, że okno pomocnicze przejmuje ostrość i podświetla jego zawartość przy jednoczesnym przyciemnieniu reszty strony. Odwiedzający wpływają na ramkę lightbox, klikając miniaturkę bądź przycisk Następna lub Poprzednia. Aby wyjść z ramki lightbox i powrócić do normalnego widoku witryny, odwiedzający klikają przycisk Zakończ lub wciskają klawisz Escape.

Wszystkie widżety pokazu slajdów w Adobe Muse oferują opcję Lightbox. Dodatkowo, jeden widżet w sekcji Pokaz slajdów jest wstępnie skonfigurowany do korzystania z zachowania ramki lightbox. W widżecie pokazu slajdów Lightbox opcja Lightbox jest domyślnie włączona.

Aby utworzyć pokaz slajdów wyświetlający obrazy w ramce lightbox wykonaj następujące czynności:

  1. W widoku Projektowanie rozwiń sekcję Pokaz slajdów w Bibliotece widżetów. Przeciągnij dowolne widżety pokazu slajdów na stronę.

  2. W menu Opcje znajdź opcję Lightbox w sekcji Układ i sprawdź, czy została zaznaczona.

    Opcja ramka lightbox
    Zaznacz pole wyboru obok opcji Lightbox, jeśli nie zostało jeszcze zaznaczone.

  3. Przy wciąż otwartym menu Opcje dokonaj wszelkich innych zmian w celu odpowiedniego skonfigurowania widżetu. Na przykład możesz pokazać lub ukryć przyciski Poprzednia i Następna, podpisy i licznik. W widoku ramki lightbox wskazane jest włączenie przycisku Zamknij. Zaznacz pole wyboru obok opcji Przycisk Zamknij.

    Przycisk Zamknij
    Przycisk Zamknij (z literą X) pojawi się w prawym górnym rogu pokazu slajdów.

    W razie potrzeby możesz skorzystać z narzędzia Zaznaczanie do przesunięcia przycisku Zamknij w inne położenie. Gdy odwiedzający chcą wyjść z wyświetlania w ramce lightbox i zamknąć okno pomocnicze, mogą kliknąć przycisk Zamknij lub wcisnąć klawisze Escape.

    Uwaga:

    Jeżeli chcesz zmienić szerokość krawędzi okna Lightbox wybierz widżet pokaz slajdów lightbox i zaktualizuj ustawienia Dopełnienie w panelu Odstępy.

  4. Wybierz Plik > Podgląd strony w Przeglądarce, aby przetestować widżet Pokaz slajdów. Kliknij dowolny z obrazów miniatur, aby wywołać efekt lightbox i zobaczyć odpowiadający mu obraz główny w oknie pomocniczym, podczas gdy reszta strony pozostanie przyciemniona.

  5. Klikaj przyciski Poprzednia i Następna, aby poruszać się między obrazami w pokazie slajdów.

  6. Po przetestowaniu pokazu slajdów wyjdź z widoku lightbox, klikając przycisk Zamknij. Lightbox zostaje zamknięty i pojawia się pozostała zawartość strony.

  7. Zamknij przeglądarkę i powróć do programu Adobe Muse.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online