Workspaces, panels, and viewers

  1. After Effects User Guide
  2. Getting started
    1. Get started with After Effects
    2. What's new in After Effects
    3. Release Notes | After Effects
    4. After Effects system requirements
    5. Keyboard shortcuts in After Effects
    6. Planning and setup
    7. Setup and installation
  3. Workspaces
    1. General user interface items
    2. Get to know After Effects interface
    3. Workflows
    4. Workspaces, panels, and viewers
  4. Projects and compositions
    1. Projects
    2. Composition basics
    3. Precomposing, nesting, and pre-rendering
    4. CINEMA 4D Composition Renderer
  5. Importing footage
    1. Preparing and importing still images
    2. Importing from After Effects and Adobe Premiere Pro
    3. Importing and interpreting video and audio
    4. Preparing and importing 3D image files
    5. Importing and interpreting footage items
    6. Working with footage items
    7. XMP metadata
  6. Working with text and graphics
    1. Text
      1. Formatting characters and the Character panel
      2. Text effects
      3. Creating and editing text layers
      4. Formatting paragraphs and the Paragraph panel
      5. Extruding text and shape layers
      6. Animating text
      7. Examples and resources for text animation
      8. Live Text Templates
    2. Motion Graphics
      1. Work with Motion Graphics templates in After Effects
      2. Use expressions to create drop-down lists in Motion Graphics templates
      3. Work with Essential Properties to create Motion Graphics templates
      4. Replace images and videos in Motion Graphics templates and Essential Properties
  7. Drawing, painting, and paths
    1. Overview of shape layers, paths, and vector graphics
    2. Paint tools: Brush, Clone Stamp, and Eraser
    3. How to taper shape strokes
    4. Shape attributes, paint operations, and path operations for shape layers
    5. Use Offset Paths shape effect to alter shapes
    6. Creating shapes
    7. Create masks
    8. Remove objects from your videos with the Content-Aware Fill panel
    9. Roto Brush and Refine Matte
  8. Working with layers
    1. Selecting and arranging layers
    2. Blending modes and layer styles
    3. 3D layers
    4. Layer properties
    5. Creating layers
    6. Managing layers
    7. Layer markers and composition markers
    8. Cameras, lights, and points of interest
  9. Animation, keyframing, motion tracking, and keying
    1. Animation
      1. Animation basics
      2. Animating with Puppet tools
      3. Managing and animating shape paths and masks
      4. Animating Sketch and Capture shapes using After Effects
      5. Assorted animation tools
      6. Work with Data-driven animation
    2. Keyframe
      1. Keyframe interpolation
      2. Setting, selecting, and deleting keyframes
      3. Editing, moving, and copying keyframes
    3. Motion tracking
      1. Tracking and stabilizing motion
      2. Face Tracking
      3. Mask Tracking
      4. Mask Reference
      5. Speed
      6. Time-stretching and time-remapping
      7. Timecode and time display units
    4. Keying
      1. Keying
      2. Keying effects
  10. Transparency and compositing
    1. Compositing and transparency overview and resources
    2. Alpha channels, masks, and mattes
  11. Adjusting color
    1. Color basics
    2. Use the Adobe Color Themes extension
    3. Color management
    4. Color Correction effects
  12. Effects and animation presets
    1. Effects and animation presets overview
    2. Effect list
    3. Simulation effects
    4. Stylize effects
    5. Audio effects
    6. Distort effects
    7. Perspective effects
    8. Channel effects
    9. Generate effects
    10. Transition effects
    11. The Rolling Shutter Repair effect
    12. Blur and Sharpen effects
    13. 3D Channel effects
    14. Utility effects
    15. Matte effects
    16. Noise and Grain effects
    17. Detail-preserving Upscale effect
    18. Obsolete effects
  13. Expressions and automation
    1. Expression
      1. Expression basics
      2. Understanding the expression language
      3. Using expression controls
      4. Syntax differences between the JavaScript and Legacy ExtendScript expression engines
      5. Editing expressions
      6. Expression errors
      7. Using the Expressions editor
      8. Use expressions to edit and access text properties
      9. Expression language reference
      10. Expression examples
    2. Automation
      1. Automation
      2. Scripts
  14. Immersive video, VR, and 3D
    1. Construct VR environments in After Effects
    2. Apply immersive video effects
    3. Compositing tools for VR/360 videos
    4. Tracking 3D camera movement
    5. Work in 3D Design Space
    6. Preview changes to 3D designs real time with the Real-Time Engine
    7. Add responsive design to your graphics 
  15. Views and previews
    1. Previewing
    2. Video preview with Mercury Transmit
    3. Modifying and using views
  16. Rendering and exporting
    1. Basics of rendering and exporting
    2. Export an After Effects project as an Adobe Premiere Pro project
    3. Converting movies
    4. Automated rendering and network rendering
    5. Rendering and exporting still images and still-image sequences
    6. Using the GoPro CineForm codec in After Effects
  17. Working with other applications
    1. Dynamic Link and After Effects
    2. Working with After Effects and other applications
    3. Sync Settings in After Effects
    4. Collaborate with Team Projects
    5. Share and manage changes with Team Project collaborators
    6. Creative Cloud Libraries in After Effects
    7. Plug-ins
    8. CINEMA 4D and Cineware
  18. Memory, storage, performance
    1. Memory and storage
    2. Improve performance
    3. Preferences
    4. GPU and GPU driver requirements for After Effects

Workspaces and panels

Adobe video and audio applications provide a consistent, customizable user interface. Although each application has its own set of panels, you move and group panels in the same way in each application.

The main window of a program is the application window. Panels are organized in this window in an arrangement called a workspace.

Each application includes several predefined workspaces that optimize the layout of panels for specific tasks. You can also create and customize your own workspaces by arranging panels in the layout that best suits your working style for specific tasks.

You can drag panels to new locations, move panels into or out of a group, place panels alongside each other, and undock a panel so that it floats in a new window above the application window. As you rearrange panels, the other panels resize automatically to fit the window.

Example of workspace
Example workspace

A. Application window B. Grouped panels C. Individual panel 

To increase the available screen space, use multiple monitors. When you work with multiple monitors, the application window appears on the main monitor, and you place floating windows on the second monitor. Monitor configurations are stored in the workspace.

Workspaces are stored in XML files in the preferences folder. With some caveats regarding monitor size and layout, these workspaces can be moved to another computer and used there.

  • (Windows) [drive]:\Users\[user_name]\AppData\Roaming\Adobe\After Effects\[version]\ModifiedWorkspaces

  • (Mac OS) [drive]/Users/[user_name]/Library/Preferences/Adobe/After Effects/[version]/ModifiedWorkspaces

See this video tutorial about workspaces by Andrew Devis on the Creative Cow website for more details.

Stacked panel layout

Customize your workspace by grouping panels the way you want to. In a panel group, you can arrange panels in both stacked and tabbed states. 

You can expand and collapse stacked panels with a single mouse-click on the panel header. For more information, see Working with stacked panels.

Navigate and use the Home screen

The Home screen assits you to get started quickly with After Effects. You can use the following options on the left side:

 

  • Home: Click this tab to open the Home screen.
  • New Project: Creates a project in After Effects. 
  • Open Project: Opens an exisitng project.
  • New Team Project: Creates a Team Project.
  • Open Team Project: Opens an exiting Team Project.

If you are a new user, the centre of the screen also gives you the option to create a project. As you create projects in After Effects, the content on the home screen evolves. Experienced users get an option to learn What's New in After Effects, along with other documentation links.

You can also use the Home icon at the left-hand side of the UI to navigate between the project and the Home screen.

Use the Learn workspace and Learn panel

Learn panel

Designed for new-to-After Effects users, you can use tutorials in the Learn panel to quickly learn about the different panels, timeline, and effects in After Effects. You can access the learn panel from the Window menu > Extensions. You can use these lessons to create projects in the application.

The panel is fully interactive with task-oriented videos. When you click a video in the panel, it displays the steps to perform the task. As you try the steps in the UI, the panel tracks your motion and guides you through the steps. Once you complete a task, the status of the task updates to completed.

Learn panel and Learn workspace
Learn panel and Learn workspace

Learn workspace

The Learn workspace offers a simple interface with the following panels that you use to create an After Effects project:

  • Learn panel
  • Project panel
  • Composition panel
  • Timeline panel

To access the workspace, select Help > Learn After Effects. The workspace includes the Learn panel docked to the side so that you can follow the instructions along with clear access to the rest of workspace.

Customizing workspaces

Choose a workspace

You can access custom or default workspaces with a single click in the new workspace bar. The workspace bar occupies the right side of the Tools panel. You can customize the width of the bar by dragging the vertical divider between the tool and the workspace bars.

Save as new workspace

The workspaces that do not fit in the available space display in the chevron menu (>>) on the workspace bar.

Workspace chevron menu

When you move the Tools panel from its position, the Workspace menu replaces the workspace bar.

Workspace menu

Note:

Choose Window > Workspace > Edit Workspaces or click the chevron menu (>>) on the workspace bar to display the Edit Workspaces dialog box. You can select a workspace and reorder workspaces.

Edit Workspaces dialog box

Choose a workspace

  • Choose Window > Workspace, and select the desired workspace.

  • Choose a workspace from the Workspace menu in the Tools panel.

  • If the workspace has a keyboard shortcut assigned, press Shift+F10, Shift+F11, or Shift+F12.

Note:

To assign a keyboard shortcut to the current workspace, choose Window > Assign Shortcut To [Workspace Name] Workspace.

Save, reset, or delete workspaces

Save a custom workspace

As you customize a workspace, the application tracks your changes, storing the most recent layout. To store a specific layout more permanently, save a custom workspace. Saved custom workspaces appear in the Workspace menu, where you can return to and reset them.

  1. Arrange the frames and panels as desired, and then choose Window > Workspace > New Workspace. Type a name for the workspace, and click OK.

Note:

(After Effects, Premiere Pro) If a project saved with a custom workspace is opened on another system, the application looks for a workspace with a matching name. If the application cannot find a match (or the monitor configuration doesn’t match), it uses the current local workspace.

Reset a workspace

Reset the current workspace to return to its original, saved layout of panels.

  1. Choose Window > Workspace > Reset workspace name.

Delete a workspace

  1. Choose Window > Workspace > Delete Workspace.

  2. Choose the workspace you want to delete, and then click OK.

    Note:

    You cannot delete the currently active workspace.

Dock, group, or float panels

You can dock panels together, move them into or out of groups, and undock them so they float above the application window. As you drag a panel, drop zones—areas onto which you can move the panel—become highlighted. The drop zone you choose determines where the panel is inserted, and whether it docks or groups with other panels.

Docking zones

Docking zones exist along the edges of a panel, group, or window. Docking a panel places it adjacent to the existing group, resizing all groups to accommodate the new panel.

Dragging panel onto docking zone to dock it
Dragging panel (A) onto docking zone (B) to dock it (C)

Grouping zones

Grouping zones exist in the middle of a panel or group, and along the tab area of panels. Dropping a panel on a grouping zone stacks it with other panels.

Dragging panel onto grouping zone to group it with existing panels
Dragging panel (A) onto grouping zone (B) to group it with existing panels (C)

Dock or group panels

  1. If the panel you want to dock or group is not visible, choose it from the Window menu.

  2. Do one of the following:

    • To move an individual panel, drag the gripper area in the upper‑left corner of a panel’s tab onto the desired drop zone.

    Drag panel gripper to move one panel
    Drag panel gripper to move one panel

    • To move an entire group, drag the group gripper in the upper‑right corner onto the desired drop zone.

    Drag group gripper to move entire group
    Drag group gripper to move entire group

    The application docks or groups the panel, according to the type of drop zone.

Undock a panel in a floating window

When you undock a panel in a floating window, you can add panels to the window and modify it similarly to the application window. You can use floating windows to use a secondary monitor, or to create workspaces like the workspaces in earlier versions of Adobe applications.

  1. Select the panel you want to undock (if it’s not visible, choose it from the Window menu), and then do one of the following:

    • Choose Undock Panel or Undock Frame from the panel menu. Undock Frame undocks the panel group.

    • Hold down Ctrl (Windows®) or Command (Mac OS®), and drag the panel or group from its current location. When you release the mouse button, the panel or group appears in a new floating window.

    • Drag the panel or group outside the application window. (If the application window is maximized, drag the panel to the Windows taskbar.)

Maximize or restore panel groups

Double-click the active panel's tab, or in the fallow area of the tab well of a panel group to maximize or restore that panel group. You can also press the ` (accent grave) key with the mouse pointer over that panel group to maximize or restore a panel group.

Resize panel groups

Note:

To quickly maximize a panel beneath the pointer, press the ` (accent grave) key. (The accent grave is the unshifted character under the tilde, ~, on standard US keyboards.) Press the key again to return the panel to its original size.

When you drag the divider between panel groups, all groups that share the divider are resized.

  1. Do either of the following:
    • To resize either horizontally or vertically, position the pointer between two panel groups. The pointer becomes a double arrow .

    • To resize in both directions at once, position the pointer at the intersection between three or more panel groups. The pointer becomes a four‑way arrow .

  2. Hold down the mouse button, and drag to resize the panel groups.
    Dragging divider between panel groups to resize them horizontally
    Dragging divider between panel groups to resize them horizontally

    A. Original group with resize pointer B. Resized groups 

Open, close, and show panels and windows

Even if a panel is open, it may be out of sight, beneath other panels. Choosing a panel from the Window menu opens it and brings it to the front of its group.

When you close a panel group in the application window, the other groups resize to use the newly available space. When you close a floating window, the panels within it close, too.

  • To open or close a panel, choose the panel from the Window menu.

  • To close a panel or window, click its Close button . If you accidentally close a panel, choose the panel from the Window menu, and the panel will be displayed again.

  • To open or close a panel, use its keyboard shortcut.

  • If a frame contains multiple panels, place the pointer over a tab and roll the mouse scroll wheel forward or backward to change which panel is active.

  • If a frame contains more grouped panels than can be shown at once, drag the scroll bar that appears above the tabs.

     

Scroll bar for showing tabs of other panels
Scroll bar for showing tabs of other panels

Viewers

A viewer is a panel that can contain multiple compositions, layers, or footage items, or multiple views of one such item. The Composition, Layer, Footage, Flowchart, and Effect Controls panels are viewers.

Locking a viewer prevents the currently displayed item from being replaced when you open or select a new item. Instead, when a viewer is locked and a new item is opened or selected, After Effects creates a new viewer panel for that item. If you select the item from the viewer menu of a locked viewer, a new viewer isn't created; the existing viewer is used.

Instead of housing multiple items in a single viewer and using the viewer menu to switch between them, you can choose to open a separate viewer for each open composition, layer, or footage item. When you have multiple viewers open, you can arrange them by docking or grouping them, like any other panels.

For example, you can create one Composition viewer each for different 3D views (Top, Bottom, Back, Front, custom views) so that you can maximize each of the views with the ` (accent grave) keyboard shortcut, which maximizes or restores the panel under the pointer.

Note:

To create a custom workspace with multiple viewers, ensure that all viewers are unlocked before you save the workspace. Locked viewers are associated with a specific project context and are therefore not saved in the preferences file.

  • To create a new viewer, choose New from the viewer menu. (See Open panel, viewer, and context menus.)

  • To lock or unlock a viewer, choose Locked from the viewer menu, or click the Toggle Viewer Lock button.

  • To lock the current viewer, split the current frame, and create a new viewer of the same type in the new frame, press Ctrl+Alt+Shift+N (Windows) or Command+Option+Shift+N (Mac OS).

  • To cycle forward or backward through the items in the viewer menu list for the active viewer, press Shift+period (.) or Shift+comma (,).

Edit this, look at that (ETLAT) and locked Composition viewers

If a Composition viewer is locked, the Timeline panel for another composition is active, and the Composition viewer for the active composition is not shown, then most commands that affect views and previews operate on the composition for which the viewer is shown.

For example, pressing the numpad 0 can start a preview for the composition visible in a locked Composition viewer rather than the composition associated with the active Timeline panel.

This behavior facilitates a working setup sometimes referred to as edit-this-look-at-that (ETLAT). The most common scenario in which this behavior is useful is the scenario in which you make a change in the Timeline panel for a nested (upstream) composition and want to preview the result of the change in a containing (downstream) composition.

Note:

ETLAT behavior works for keyboard shortcuts for zooming, fitting, previewing, taking and viewing snapshots, showing channels, showing and hiding grids and guides, and showing the current frame on a video preview device.

To prevent this behavior, unlock the Composition viewer or show the Composition viewer for the composition that you want to view or preview.

Adobe logo

Sign in to your account