Voici une liste des problèmes résolus dans RoboHelp (2019 release) et les versions ultérieures de correctifs.

Consultez le forum de RoboHelp pour accéder aux solutions, aux alternatives ou aux dernières informations.

Mise à jour 5 de RoboHelp (2019 release) - 7 février 2019

Amélioration des fonctionnalités

Sélection et utilisation de plusieurs fichiers

Une fonctionnalité très demandée dans RoboHelp Classic fait désormais partie de RoboHelp 2019. Vous pouvez sélectionner plusieurs fichiers dans les panneaux Contenu et Table des matières et déplacer des fichiers et des dossiers dans la hiérarchie, les supprimer, définir des propriétés et utiliser la fonction de glisser-déposer.

Publication dans SharePoint Online et autres améliorations de publication

Vous pouvez désormais facilement publier les résultats Responsive HTML5 et WebHelp sur SharePoint Online au format ASPX natif. Vous pouvez utiliser les options de publication pertinentes à partir de tous les paramètres prédéfinis de sortie. Vous pouvez facilement afficher le résultat dans un navigateur pour RoboHelp Server et SharePoint Online. 

Utilisation d’une liste améliorée de rubriques

La ligne d’en-tête de la liste de rubriques est maintenant fixe et visible lors du défilement de la liste. Vous pouvez redimensionner toutes les colonnes dans la liste. La vue de la liste de rubriques est maintenant active, de sorte que les modifications apportées au projet sont automatiquement reflétées dans la liste de rubriques, sans avoir à actualiser la liste manuellement.Vous pouvez supprimer tous les filtres et également afficher de nouvelles colonnes pour Maquette et Voir aussi. Vous pouvez lancer la liste des rubriques à partir du panneau Rapports ou du menu Afficher. Elle est supprimée de la barre d’outils Auteur.

Utilisation de feuilles de style améliorées

Vous pouvez maintenant créer des bordures avec des coins arrondis et utiliser la fonctionnalité de rayon dans les styles de bordures.

Pour les styles de liste, vous pouvez définir le style du préfixe (tel que des bordures arrondies) et le contenu d’une liste séparément. Vous pouvez également définir un style différent pour chaque niveau de la liste.

Utilisation d’un correcteur orthographique amélioré

Le correcteur orthographique est désormais disponible via la touche F7 et l’option de menu Édition > Vérification orthographique. Les mots mal orthographiés sont indiqués et vous pouvez implémenter, ignorer ou ajouter des suggestions au dictionnaire.

Association des fichiers de projet à des applications externes

Vous pouvez associer des applications externes à un type de fichier pour l’ouvrir et l’éditer. Dans RoboHelp, vous pouvez double-cliquer sur un fichier ou cliquer sur Modifier pour l’ouvrir dans une application associée. 

Utilisation des améliorations dans l’import Word

Vous pouvez maintenant importer des listes à plusieurs niveaux et utiliser des formats de numérotation améliorés. L’importation de tableaux est améliorée pour importer les styles de largeur et de bordure sans problème. Les styles en ligne font partie du fichier HTML dans l’attribut de style.

Utilisation des champs améliorés

Vous pouvez maintenant utiliser des formats supplémentaires disponibles pour les champs Date, Heure, Titre et d’autres champs. Les valeurs des champs sont visibles en fonction de la langue de votre projet. Vous pouvez modifier et ajouter de nouveaux champs et choisir de mettre à jour automatiquement ses valeurs.

Améliorations relatives au format PDF

Les définitions d’en-tête et de pied de page de la maquette sont maintenant converties en en-tête/pied de page au format PDF. La prise en charge de la variable de numéro de page est ajoutée. Dans l’onglet Mise en page prédéfinie PDF, l’interface utilisateur de la maquette est améliorée. Le problème des liens rompus à l’origine des échecs de génération PDF est corrigé. RoboHelp génère un fichier PDF et affiche un avertissement dans le journal.

Rapport amélioré

RoboHelp enregistre désormais les modifications apportées aux filtres et à la sélection des colonnes pour tous les rapports par projet. Vous pouvez effacer tous les filtres à la fois en cliquant sur Réinitialiser les filtres. Vous pouvez également utiliser deux nouveaux types de rapport, ID de mappage et Voir aussi.

Améliorations de l’éditeur de table des matières

L’expérience de glisser-déposer dans la table des matières est améliorée, le déplacement d’un élément pour le remplacement est supprimé.Dans les propriétés de la table des matières, un indicateur s’affiche si le titre est remplacé.
La table des matières et les propriétés d’espace réservé de projet fusionné sont corrigées, les options non pertinentes sont supprimées. L’option d’édition est ajoutée à la vue d’exploration.

Importation de fichiers HTML

Vous pouvez maintenant importer des fichiers existants dans le projet avec tous les actifs associés.

Autres améliorations

Vous pouvez maintenant appuyer sur F2 pour renommer une rubrique ou un dossier à partir du panneau de contenu et d’autres zones. Vous pouvez maintenant dupliquer un habillage dans le panneau Habillages.

Problèmes résolus

  1. Les rubriques avec une extension .html dans des projets RoboHelp Classic ne se mettent pas à niveau correctement.
    (Référence : 3732)
  2. Certains formats de variables de champ issus de projets RoboHelp Classic ne sont pas mis à niveau correctement.
    (Référence : 3699)
  3. Le titre du projet n’est pas mis à niveau dans la barre de titre de l’application si vous modifiez les paramètres du projet. 
    (Référence : 3726)
  4. Je ne peux pas ajouter de dossier racine si le panneau Contenu ne dispose pas d’un espace vide.
    (Référence : 3719)
  5. Les options du menu de synchronisation pour les documents associés sont également affichées pour les fichiers non associés.
    (Référence : 3752)
  6. Le dernier onglet devient vide lorsque d’autres onglets sont fermés.
    (Réf - 3691, 3628)
  7. Impossible d’archiver un fichier modifié dans SharePoint.
    (Référence : 3127)
  8. Si vous sélectionnez plusieurs fichiers dans la liste des rubriques et essayez de mettre à jour en bloc le fichier de feuille de style à l’aide de la boîte de dialogue Propriétés, le chemin relatif du fichier CSS n’est pas résolu correctement.
    (Référence : 3725)
  9. Je ne peux pas revenir à la vue Auteur même après avoir corrigé l’erreur dans la vue Source.
    (Référence : 3751)
  10. Le numéro de mappage d’aide contextuelle spécifié au format hexadécimal ne se met pas à niveau correctement. 
    (Référence : 3757)
  11. Le glisser-déposer de la table des matières est irrégulier, tous les dossiers se développent trop rapidement. 
    (Référence : 3692)
  12. Impossible de taper avant la variable s’il s’agit du premier élément de la rubrique. 
    (Référence : 3720)
  13. La zone de recherche de texte ne fonctionne pas correctement en mode Source lorsque vous tapez rapidement. 
    (Référence : 3766)
  14. Le marqueur de fin de paragraphe n’est pas présent pour les éléments de la liste. 
    (Référence : 3706)
  15. Les info-bulles des termes du glossaire, le texte des conditions et les hyperliens ne figurent pas dans la vue Auteur.
    (Référence : 3690)
  16. L’insertion d’un champ de titre dans la rubrique ne fonctionne pas. 
    (Référence : 3683)
  17. La suppression de texte dans la ligne sélectionnée supprime la ligne. La sélection de toutes les lignes et l’appui sur Supprimer supprime le tableau. 
    (Référence : 3594)
  18. L’aide contextuelle ne fonctionne pas pour le fichier CHM généré. 
    (Référence : 3756)
  19. Azure Blue - l’option « Ouvrir par défaut » située sous les barres latérales ne fonctionne pas. 
    (Référence : 3615)
  20. Lors de la publication d’un projet RoboHelp, les fichiers CSS importés ne sont pas copiés dans la sortie. 
    (Réf - 3093)
  21. Tous les fichiers ne sont pas ajoutés à SharePoint. 
    (Référence : 2639)

Mise à jour 4 de RoboHelp (2019 release) - 10 janvier 2019

Amélioration des fonctionnalités

Importation et liaison des fichiers FrameMaker

Vous pouvez maintenant importer et lier des fichiers FrameMaker (.fm, .mif, et .book) dans Robohelp. Vous pouvez mapper des styles à partir de documents FrameMaker à l’aide d’un fichier CSS personnalisé lors de l’importation. Vous pouvez enregistrer et réutiliser les paramètres d’importation.

Remarque :

La mise à jour 2 de FrameMaker 2019 ou version ultérieure est requise pour que cette fonctionnalité fonctionne.

Pour plus d’informations, voir Importation de documents FrameMaker dans un projet.

Publication sur le serveur RoboHelp

Vous pouvez maintenant publier des sorties WebHelp et Responsive HTML5 sur Robohelp Server 10. Vous pouvez également gérer facilement les informations sur plusieurs serveurs de projets.

Pour plus d’informations, voir Publication sur un serveur RoboHelp.

Publication de la sortie sur un serveur FTP, un serveur FTP sécurisé ou un système de fichiers

Vous pouvez désormais publier des sorties WebHelp et Responsive HTML5 sur n’importe quel serveur FTP ou FTP sécurisé. Vous pouvez également publier dans un dossier local ou partagé. Gérez et partagez facilement tous les emplacements de publication d’un projet à l’autre.

Génération d’une sortie XML

Vous pouvez maintenant utiliser le nouveau paramètre prédéfini de sortie pour XML pour générer des rubriques au format XHTML5 et tous les autres fichiers au format XML. 

Utilisation des sections Voir aussi et Rubriques connexes

Vous pouvez désormais utiliser les nouvelles sections modernes Voir aussi et Rubriques connexes dans RoboHelp.

Vous pouvez gérer à partir d’un emplacement unique les mots-clés Voir aussi, les rubriques associées et les rubriques dans lesquelles les utiliser. Vous pouvez contrôler le style de la section Voir aussi à l’aide de classes CSS. Vous pouvez accéder à Voir aussi en mode Auteur à partir de la barre d’outils Auteur. Vous pouvez ajouter des mots-clés Voir aussi aux rubriques à partir des propriétés de rubrique.

Vous pouvez utiliser les rubriques connexes de la même manière, mais les informations sont limitées à une seule rubrique.

Lors de la mise à niveau d’un projet à partir de RoboHelp Classic, RoboHelp migre les contrôles de Voir aussi et de Rubriques connexes vers la nouvelle structure.

Utilisation d’une liste de rubriques améliorée

Vous pouvez maintenant accéder aux listes de rubriques dans la vue Auteur à partir de la barre d’outils Auteur. Vous pouvez filtrer les informations de rubrique selon vos besoins, créer des rubriques en double et plus encore dans la liste de rubriques. Vous pouvez également faire un glisser-déposer du panneau Table des matières vers la liste des rubriques. Le panneau Propriétés indique le nombre de rubriques présentes dans la liste de rubriques. Vous pouvez utiliser ces informations tout en filtrant des rubriques spécifiques. RoboHelp mémorise tous les filtres et sélections de colonnes d’une session à l’autre.

Correction de liens rompus

Vous pouvez maintenant réparer les liens rompus dans les rubriques ouvertes via une boîte de dialogue qui affiche la liste des liens rompus et leur emplacement. Vous pouvez pointer des liens rompus vers d’autres rubriques ou créer une rubrique. Vous pouvez également réparer les liens rompus à partir du rapport Liens rompus à l’aide des options du menu contextuel.

Utilisation de Team Foundation Server amélioré

Vous pouvez maintenant facilement archiver tous les fichiers, car tous les fichiers sont sélectionnés par défaut, et éventuellement entrer des commentaires d’archivage. Les fichiers internes ne sont pas visibles lors de l’archivage.

Utilisation d’une fonction d’importation améliorée dans Word

Vous ne devez pas sélectionner un modèle de nom de rubrique maintenant car <$paratext> est le modèle de nom de rubrique par défaut. La « balise HTML définie par l’utilisateur » est fusionnée dans la liste de mappage de style de paragraphe, qui dispose également d’une option pour mapper sur « pré ». L’importation de liste prend désormais en charge les listes à numérotation automatique et complexes à plusieurs niveaux.

Utilisation d’un style amélioré pour la mini-table des matières

La table des matières des rubriques est renommée Mini-table des matières afin de préserver la cohérence avec les produits Adobe. Vous pouvez utiliser une nouvelle option pour réduire la mini-table des matières à partir de l’onglet Général du panneau Propriétés. Vous pouvez contrôler tous les aspects du style de la mini-table des matières dans un nouveau projet en copiant les nouvelles classes depuis default.css.

Utilisation d’un éditeur de style de table amélioré

Vous pouvez maintenant utiliser un éditeur de tableau repensé qui offre un contrôle complet sur tous les aspects du style. Utilisez les  nouvelles options pour appliquer le formatage à un tableau entier, effacer le formatage et appliquer un style aux lignes et aux colonnes.

Suppression facile des styles de caractères

Vous pouvez maintenant simplement sélectionner du texte et effacer le formatage de tout texte faisant partie de cette sélection. Après avoir sélectionné le texte, vous pouvez utiliser une option pour supprimer le formatage dans l’onglet Général du panneau Propriétés.

Faites l’expérience d’une suppression améliorée des variables et des champs

Vous pouvez maintenant appuyer sur Retour ou utiliser une option du menu contextuel pour supprimer une variable ou un champ. Si une variable est utilisée dans une rubrique, un extrait de code ou une page maître, une boîte de dialogue d’avertissement apparaît avec trois options : Supprimer une variable et ses références, Supprimer une variable uniquement et Supprimer une variable et la remplacer par le contenu.

Importation d’un fichier de mappage (.h) existant dans votre projet

Vous pouvez maintenant importer un fichier .h dans votre projet grâce à l’option Importer dans le panneau Fichiers de mappage.

Définition de filtres dynamiques sans groupe

Vous pouvez maintenant choisir de créer des filtres dynamiques avec ou sans groupe. Vous pouvez définir des filtres dynamiques sans groupes de balises et glisser-déposer des balises de condition sans les associer à des groupes de balises. Vous pouvez également modifier les filtres précédemment définis pour supprimer des groupes de balises ou en ajouter.

Utilisation de la nouvelle barre d’outils dans l’éditeur de paramètres prédéfinis de sortie

Si un paramètre prédéfini de sortie est ouvert pour modification, vous pouvez maintenant utiliser la nouvelle barre d’outils située en haut pour générer le paramètre prédéfini, afficher la sortie et procéder à la publication.

Problèmes résolus

  1. Un style n’est pas appliqué à une sélection de plusieurs paragraphes en une fois.
    (Référence : 3417)
  2. Les noms de fichiers complets ne sont pas visibles lors de l’insertion d’images ou de liens. La taille n’est pas mémorisée si la boîte de dialogue d’insertion est redimensionnée.
    (Référence : 3300
  3. Comportement inattendu dans les feuilles de style et les panneaux de propriétés lorsque des valeurs décimales sont utilisées.
    (Référence : 3198
  4. Un style de tableau avec un nom de classe non défini est en cours de création.
    (Référence : 3424
  5. L’onglet Styles du panneau Propriétés du sujet ne mémorise pas le dernier état sélectionné.
    (Référence : 3410
  6. Pour les éléments ayant l’attribut ID, le texte en vert est visible pendant la création.
    (Référence : 3401)
  7. Dans la boîte de dialogue Création d’une nouvelle rubrique, le texte du titre de rubrique par défaut n’est pas automatiquement supprimé lors de la tentative de saisie d’un nouveau texte.  
    (Référence : 3302)
  8. Un extrait de code inséré ne s’ouvre pas pour édition lorsque vous cliquez deux fois dessus.
    (Référence : 2068
  9. Ajouter un livre sans lien vers la table des matières crée une erreur d’application.
    (Référence : 3392)
  10. Dans l’éditeur de séquence de navigation, l’annulation et la restauration ne fonctionnent pas avec les touches Ctrl + Z et Ctrl + Y.
    (Référence : 3336)
  11. Dans la boîte de dialogue Paramètres d’importation de Word, les listes déroulantes Caractère et Paragraphe sont vides.
    (Référence : 3403
  12. Impossible de créer un projet à des emplacements autres que le dossier « Documents ».
    (Référence : 3521
  13. L’erreur « Le projet existe déjà » s’affiche lors de la création d’un projet dans un dossier vide.
    (Référence : 3414)
  14. Impossible de créer une connexion Team Foundation Server sur les systèmes d’exploitation français, allemand et japonais.
    (Référence : 3075)
  15. Dans la sortie générée, il n’y a pas d’espace entre un terme de glossaire et une définition.
    (Référence : 3373)
  16. Les liens entre les rubriques ne fonctionnent pas dans la sortie EPUB.
    (Référence : 3442)
  17. Des numéros supplémentaires sont ajoutés à l’URL dans la table des matières de la sortie Responsive HTML5.
    (Référence : 1192
  18. La génération de sortie échoue si un projet fusionné est présent dans la table des matières.
    (Référence : 3396)
  19. Le lien de courrier électronique est rompu dans la sortie HTML5 générée.
    (Référence : 3426

Problèmes résolus dans RoboHelp Classic (2019 release)

  1. La liaison de fichiers FrameMaker 2019 à RoboHelp Classic 2019 lance FrameMaker 2017.
    (Référence : 3356)
  2. Des numéros supplémentaires sont ajoutés à l’URL dans la table des matières de la sortie Responsive HTML5.
    (Référence : 1192)
  3. Le correcteur orthographique ne fonctionne pas.
    (Référence : 3541)

Mise à jour 3 de RoboHelp (2019 release) - 30 novembre 2018

Amélioration des fonctionnalités

Utilisation de variables définies par l’utilisateur dans le titre de la sortie

Vous pouvez maintenant utiliser des variables dans le titre de n’importe quel type de sortie.

Pour plus d’informations, voir Insertion d’une variable.

Génération d’une sortie avec des noms de fichier en minuscules.

Vous pouvez désormais générer des sorties WebHelp et Responsive HTML5 avec des noms de fichiers en minuscules.

Utilisation de nouveaux raccourcis clavier

Vous pouvez désormais basculer entre les modes Auteur, Source et Aperçu à l’aide des touches Ctrl + E, Ctrl + R et Ctrl + W. Vous pouvez également changer d’onglet dans les vues Auteur et Sortie en utilisant les touches Ctrl + Pg.Suiv et Ctrl + Pg.Préc.

Pour plus d’informations, voir Raccourcis clavier RoboHelp.

Utilisation d’un éditeur de feuille de style/CSS amélioré

L’éditeur permet désormais de supprimer facilement les styles de liste du contenu. De nouvelles options de menu contextuel sont ajoutées et des pseudo-classes sont regroupées pour réduire l’encombrement. Des états d’hyperlien tels que « survoler » et « visité » sont ajoutés par défaut. Le style des listes non ordonnées est amélioré pour créer facilement des listes à plusieurs niveaux. L’éditeur de tableau est amélioré pour gérer l’édition des tableaux mis à jour des projets RoboHelp Classic. 

Utilisation d’un index amélioré

Vous pouvez maintenant glisser-déposer des mots-clés d’index dans un sujet ou utiliser des signets dans le panneau Index pour créer des termes d’index de niveau contenu. 

Création et publication des mappages d’image

Vous pouvez maintenant redimensionner et déplacer des zones réactives tout en créant des mappages d’image. RoboHelp affiche des infobulles avec des liens et les zones sont numérotées. Vous pouvez également contrôler le chevauchement des zones superposées.

Utilisation d’un glossaire amélioré

Dans la vue développée d’un fichier de glossaire, vous pouvez désormais accéder aux options de chaque terme en cliquant avec le bouton droit de la souris ou en cliquant sur . Vous pouvez également glisser-déposer un terme de glossaire sur le texte sélectionné, créer un terme de glossaire à partir du texte en surbrillance et supprimer le glossaire en cliquant avec le bouton droit de la souris sur une zone réactive du glossaire.

Utilisation de signets améliorés

Un signet créé sur le texte sélectionné est inséré au début de la sélection. Le symbole des signets s’affiche désormais en cas de texte sélectionné également. Dans la boîte de dialogue Signet, vous pouvez voir la liste des signets avec le texte de paragraphe associé.

Utilisation d’une fonction d’insertion d’image améliorée

Vous pouvez désormais utiliser Ctrl + G pour insérer rapidement une image. La boîte de dialogue Insérer une image a été améliorée : l’onglet Fichiers récents a été déplacé sous l’onglet Contenu et les derniers chemins et onglets utilisés sont mémorisés.

Édition de fichiers JavaScript

Vous pouvez maintenant modifier un fichier JavaScript dans RoboHelp. Le nouvel éditeur de source met en évidence la syntaxe et affiche les erreurs.

Utilisation de propriétés de rubrique améliorées

Dans la boîte de dialogue/le panneau Propriétés de rubrique, RoboHelp enregistre désormais les informations d’utilisation de la page principale pour une utilisation ultérieure. Les options par défaut pour Langue, Statut et Maquettes sont rationalisées. Toutes les sections déroulantes sont fermées par défaut et leur état précédent est mémorisé.

Utilisation d’une fonction de lien améliorée

Vous pouvez désormais synchroniser des fichiers individuels ou tous les fichiers liés depuis l’emplacement source au projet et inversement si les fichiers sont modifiés dans RoboHelp. Vous pouvez voir l’emplacement source et d’autres informations sur chaque fichier lié grâce à la nouvelle option Propriétés.

Utilisation d’une séquence de navigation améliorée

Vous pouvez désormais accéder aux options via le nouveau menu contextuel. La barre d’outils des séquences de navigation contient de nouvelles options : Déplacer vers le haut, Déplacer vers le bas et Ajouter une rubrique. Vous pouvez également annuler et rétablir les modifications.

Utilisation d’une table des matières de rubriques améliorée

Le style d’une table des matières de rubriques a été amélioré. Vous pouvez facilement contrôler la mise en forme, afficher/masquer le comportement, supprimer les légendes, etc.

Ajout d’un nouvel habillage à un exemple de projet

Un nouvel habillage nommé Coffee, basé sur la mise en page Indigo, est ajouté à l’exemple de projet Learn a Latte.

Problèmes résolus

  1. Si un numéro est spécifié dans le champ Démarrer à partir de lors de la modification de la liste, celle-ci commence par un numéro supérieur au nombre spécifié.
    (Réf - 3206)
  2. Lorsque vous associez un mot-clé d’index à un signet dans une rubrique, le mot-clé d’index disparaît de la liste des mots-clés d’index.
    (Réf - 3176). 
  3. Si les feuilles de style ou les styles en ligne utilisent une unité non approuvée par Adobe, elle n’apparaît pas dans la feuille de style ni dans le panneau Propriétés.
    (Réf - 3199)
  4. Effacer le formatage ne fonctionne pas pour les sélections.
    (Réf - 3200
  5. Les sélections d’images d’arrière-plan ne sont pas mémorisées lors de la fermeture et de la réouverture d’une feuille de style.
    (Réf - 3151
  6. Lorsque vous tentez de quitter RoboHelp s’il existe un fichier non enregistré et que vous cliquez sur Annuler dans l’invite, RoboHelp se ferme sans enregistrer le fichier.
    (Réf - 3204
  7. La suppression d’un dossier vide nécessite le redémarrage de RoboHelp.
    (Réf - 3205). 
  8. Les entrées de la table des matières de rubriques affichent du texte tronqué.
    (Réf - 3185, 3192)
  9. Problèmes de table des matières de rubriques multiples.
    (Réf - 3115)
  10. Impossible de supprimer la couleur d’arrière-plan sans modifier manuellement le code CSS.
    (Réf - 3108)
  11. En cliquant dans une feuille de style, vous pouvez sélectionner accidentellement de gros blocs de l’interface.
    (Réf - 3109)
  12. Les boîtes de dialogue de mappage d’image n’affichent pas la destination actuelle du lien pour les zones de mappage d’image.
    (Réf - 3111
  13. Lorsqu’un signet est créé dans une rubrique et inséré dans une autre rubrique, il affiche le nom du fichier et non le titre de la rubrique.
    (Réf - 3174
  14. Il manque quelques raccourcis clavier.
    (Réf - 3147
  15. Les marqueurs d’alias de rubrique de FrameMaker ne sont pas convertis correctement après l’importation dans RoboHelp.
    (Réf - 619)
  16. Après la mise à niveau d’un projet RoboHelp Classic vers RoboHelp 2019, certains styles de tableau sont manquants.
    (Réf - 3154
  17. Les images Favicon ne s’affichent pas dans les projets mis à niveau. 
    (Réf - 2613)
  18. Le format SSL HTML5 Multiscreen ne fait pas partie des projets mis à niveau ; il devrait s’agir de Responsive HTML5 avec tous les paramètres conservés.
    (Réf – 3183)
  19. L’option Nouveau dans certains panneaux de composants de projet n’ouvre pas automatiquement les fichiers à modifier.
    (Réf – 3150)
  20. Le texte sélectionné en mode Auteur ne s’affiche pas correctement en mode Source.
    (Réf - 3164
  21. Lorsqu’un sujet en double est créé, son titre ne change pas.
    (Réf - 2732)
  22. Lors de la génération d’une sortie d’application mobile, si vous modifiez l’icône par défaut, le nouveau chemin d’accès à l’icône doit être enregistré après la génération de la sortie.
    (Réf - 1195)
  23. Problèmes liés au champ d’écran de démarrage <Informations de l’application> lors de la génération de la sortie de l’application mobile.
    (Réf - 1252)
  24. Une image Twisty ne se tord pas lorsqu’une liste déroulante est ouverte avec la mise en surbrillance de la recherche.
    (Réf - 1229)
  25. En cliquant sur l’icône de recherche à gauche dans la sortie Responsive HTML 5 (Bleu ciel et Gris anthracite), la zone de recherche n’a pas de mise au point automatique.
    (Réf - 864)
  26. Les mises à jour de la table des matières ne sont pas synchronisées avec la table des matières étendue dans le panneau Table des matières, sauf si elle est réduite et développée à nouveau.
    (Réf - 3097)
  27. Les caractères trémas de la table des matières/du glossaire ne se chargent pas correctement dans la sortie Microsoft HTML Help.
    (Réf - 3156
  28. Dans un habillage Indigo, il n’y a pas d’espaces ni de séparateurs entre les éléments de chemin de navigation.
    (Réf - 3094)
  29. La barre latérale de recherche ne s’ouvre pas lorsqu’une recherche est exécutée dans une mise en page Bleu ciel.
    (Réf - 1831)
  30. Les images incorporées dans les fragments affichent le chemin absolu au lieu du chemin relatif, dans la sortie Responsive HTML, et le répertoire des fragments n’est pas inclus dans la sortie.
    (Réf - 3197)

Problèmes résolus dans RoboHelp Classic (2019 release)

  1. Les résultats de recherche ne sont pas mis en surbrillance dans les projets seuls ou fusionnés et dans tous les navigateurs.
    (Réf - 2703)
  2. La liste à plusieurs niveaux est corrompue. 
    (Réf - 32103240)
    Solution : après l’installation de la mise à jour 3, enregistrez les rubriques concernées et appliquez de nouveau le style de liste à plusieurs niveaux.
  3. En cliquant sur l’icône de recherche à gauche dans la sortie Responsive HTML 5 (Bleu ciel et Gris anthracite), la zone de recherche n’a pas de mise au point automatique.
    (Réf - 864)
  4. Si la barre latérale est réduite, la barre latérale de recherche ne s’ouvre pas lorsqu’une recherche est effectuée à partir de la barre supérieure dans les mises en page Bleu ciel et Gris anthracite. 
    (Réf - 1831)

Mise à jour 2 de RoboHelp (2019 release) - 18 octobre 2018

Amélioration des fonctionnalités

Utilisation d’une table des matières améliorée

Les titres de rubrique du panneau Table des matières sont désormais automatiquement synchronisés avec les modifications apportées aux titres de rubrique actuels.Vous pouvez désormais repérer les liens rompus dans la table des matières à l’aide des marques x rouges en regard des rubriques concernées. Lors de la création automatique d’une table des matières, une invite vous permet de décider si vous souhaitez d’abord supprimer le contenu de la table des matières actuelle.

Pour plus d’informations, voir Création et gestion d’une table des matières.

Prise en charge de Team Foundation Server (TFS)

Vous pouvez utiliser la version 2018 de TFS pour le contrôle de version à partir de RoboHelp. Vous pouvez archiver, extraire, afficher les différences entre les versions, résoudre les conflits de fusion et synchroniser les fichiers à l’aide de TFS.

Pour plus d’informations, voir Collaboration à l’aide de Team Foundation Server.

Insertion et utilisation aisées à l’aide des listes à plusieurs niveaux

Les listes à plusieurs niveaux des projets RoboHelp Classic sont désormais mises à niveau en toute simplicité dans les rubriques et les feuilles de style des projets RoboHelp 2019. Vous pouvez désormais utiliser des modèles dans les formats numérotés et à puces afin d’insérer facilement une liste à plusieurs niveaux depuis la barre d’outils standard.

Pour plus d’informations, voir Utilisation des listes.

Utilisation de signets améliorés

Vous pouvez désormais modifier l’affichage des signets dans le panneau Contenu et dans les rubriques. Vous pouvez facilement créer des hyperliens dans des rubriques en faisant glisser des signets depuis le panneau Contenu. Vous pouvez également créer des entrées de table des matières pour les signets et utiliser les signets dans des fichiers de mappage d’aide contextuelle (CSH).

Utilisation des images Twisties

Vous pouvez désormais utiliser l’éditeur de feuille de style intégré pour ajouter des images Twisty à un style Hyperlien et appliquer le style à des textes déroulants et à développer. 

Pour plus d’informations, voir Ajout ou modification d’images Twisty.

Fermeture de texte dans les zones sensibles déroulantes et à développer

Vous pouvez désormais disposer d’une zone de texte distincte pour les titres dans les états développés et réduits. Vous pouvez également donner un titre plus significatif pour réduire un texte à développer ou déroulant.

Utilisation des vues Auteur et Sortie améliorées

Désormais, tous les composants de projet ouverts lancés à partir de la barre d’outils Auteur sont visibles et accessibles uniquement dans la vue Auteur. Si vous souhaitez passer à la vue Sortie, RoboHelp demande d’abord d’enregistrer les composants ouverts, puis lance la vue Sortie. Le même comportement s’applique aux composants lancés depuis la barre d’outils Sortie et lorsque vous basculez entre la vue Sortie et Auteur.    

Utilisation de l’outil Pipette pour choisir les couleurs

Vous pouvez désormais utiliser l’outil Pipette pour choisir les couleurs que vous souhaitez depuis n’importe quelle zone de l’écran.

Utilisation des mappages d’image

Vous pouvez désormais créer, modifier et publier les mappages d’image.Les mappages d’image définis dans les projets RoboHelp Classic sont également mis à niveau vers la structure de projet RoboHelp 2019.

Utilisation d’un éditeur de tableau amélioré

La sélection de lignes, de colonnes ou de cellules dans un tableau est désormais visible et facilement identifiable. Vous pouvez désormais sélectionner une ligne ou une colonne entière en un seul clic.

Utilisation de l’aide contextuelle

Lorsque vous utilisez l’aide contextuelle, vous pouvez désormais mapper des rubriques ou des signets sur des ID de mappage uniques. Vous pouvez également importer des fichiers de mappage, modifier et créer des mappages à l’aide de rubriques non assignées et afficher la liste des rubriques avec des signets lors du mappage. Vous pouvez également exporter les mappages dans un fichier .h et publier les mappages dans les types de sortie WebHelp, Responsive HTML5 et Microsoft HTML Help.

Pour plus d’informations, voir Utilisation de l’aide contextuelle.

Utilisation de feuilles de style améliorées

Les mises à jour vers une feuille de style reflètent désormais instantanément les rubriques ouvertes qui utilisent cette feuille de style. 

Numérotation automatique dans les feuilles de style

Vous pouvez désormais appliquer la numérotation automatique à tous les styles de paragraphe et de titre dans votre rubrique en modifiant les feuilles de style associées. Par ailleurs, une fois la version de la mise à jour 2 installée et les rubriques ouvertes, l’ancienne numérotation automatique est automatiquement mise à niveau dans les feuilles de style et rubriques.

Utilisation d’images en tant que puces dans les listes à puces

Vous pouvez désormais appliquer les images telles que lespointes de flèche,en tant quepuces dans les listes à puces.

Définition et présélection des filtres de contenu dynamique

Vous pouvez désormais définir et présélectionner un filtre de contenu dynamique pour vos sorties WebHelp et Responsive HTML5. Le contenu étiqueté avec le filtre présélectionné s’affiche par défaut dans la sortie.

Utilisation d’une table des matières de rubriques améliorée

Désormais, le style par défaut d’une table des matières de rubriques n’est pas une liste numérotée. Vous pouvez désormais afficher et masquer l’affichage d’une table des matières de rubriques.

Personnalisation des paramètres Windows pour les types de sortie sélectionnés

Vous pouvez désormais personnaliser et publier les paramètres Windows pour le type de sortie Microsoft HTML Help. Les paramètres personnalisés des précédentes versions de RoboHelp sont conservés lors de la mise à niveau vers RoboHelp 2019.

Utilisation de balises de condition améliorées

Vous pouvez désormais sélectionner plusieurs paragraphes dans votre rubrique et utiliser la fonction glisser-déposer pour appliquer les balises de condition. La couleur de la balise est visible dans la vue et l’aperçu Auteur.

Utilisation d’une fonction Importer les documents Word améliorée

Lors de l’importation d’un document Word, vous pouvez désormais spécifier les paramètres de style de tableau dans la boîte de dialogue Importer un document Word.

Utilisation d’une phrase secrète (mot de passe) pour la clé Git SSH

Vous pouvez maintenant utiliser une clé SSH avec une phrase secrète pour vous connecter au référentiel Git.

Pour plus d’informations, voir Collaboration à l’aide de Git.

Utilisation d’un éditeur d’habillage amélioré

Vous pouvez à présent annuler et rétablir les modifications dans l’éditeur d’habillage. 

Utilisation du nouveau menu contextuel pour supprimer les hyperliens

Vous pouvez maintenant utiliser l’option de menu contextuel Supprimer un hyperlien pour supprimer un hyperlien dans la vue Auteur.

Utilisation des menus contextuels améliorés

L’apparence du menu contextuel dans une rubrique dans une vue Auteur est désormais semblable aux autres menus contextuels et les options de menu ont été réorganisées.

Utilisation des raccourcis clavier pour insérer des composants

Vous pouvez désormais utiliser les raccourcis clavier pour insérer des variables, des fragments et des champs qui s’affichent lorsque vous cliquez sur l’icône Insérer des variables/fragments/champs dans la barre d’outils standard.

Pour plus d’informations, voir Insertion d’une variable et Insertion d’un extrait de code.

Problèmes résolus

  1. L’aperçu de l’habillage ne reflète pas les modifications effectuées dans les paramètres de mise en page.
    (Réf - 2863)
  2. Les textes à développer et déroulants s’affichentsous la forme développéedans la sortie Microsoft HTML Help.
    (Réf - 2839). 
  3. Le panneau Propriétés > Styles dans une rubrique ouverte ne reflète pas les mises à jour apportées aux feuilles de style.
    (Réf - 2767
  4. La table des matières dans la sortie Responsive HTML5 ne se synchronise pas lorsque vous naviguez à l’aide d’une séquence de navigation.
    (Réf - 2716
  5. La recherche de fichiers Icône favorite est limitée au dossier Actifs > Images au lieu de s’appliquer à tous les dossiers système.
    (Réf - 2673)
  6. Les images ne s’affichent pas dans l’aperçu de l’éditeur d’habillage si RoboHelp est installé et si le projet est enregistré sur différents lecteurs de votre ordinateur.
    (Réf - 2464
  7. Impossible de personnaliser la mise en page Indigo pour uniquement utiliser la page Rubrique au lieu de la page d’accueil par défaut.
    (Réf - 2403
  8. Lorsque vous cliquez sur une rubrique en double, le nom du fichier s’affiche sans l’extension.
    (Réf - 2301). 
  9. Les paragraphes vides entre le contenu n’apparaissent pas dans l’aperçu et la sortie de la rubrique.
    (Réf - 2073
  10. Des champs cliquables sont requis sur toutes les boîtes de dialogue de création de composants du projet (telles que les balises de condition, les variables et les rubriques) afin de pouvoir saisir du texte. La touche Entrée ne fonctionne pas.
    (Réf - 1846
  11. Dans l’éditeur d’habillageResponsiveHTML5, le bouton du menu Affichage de la tablette ou du téléphone n’est pas correctement étiqueté comme fermé.
    (Réf - 1833
  12. Les filtres de contenu dynamique ne se chargent pas si parents ou enfants autonomes sont générés.
    (Réf - 708
  13. Les listes à plusieurs niveaux dotées de filtres de contenu dynamique ne fonctionnent pas comme prévu dans la sortie.
    (Réf - 693
  14. Les listes à plusieurs niveaux dans le texte déroulant ne fonctionnent pas.
    (Réf - 688
  15. Les listes numérotées perdent leurs numéros dans les listes déroulantes DHTML.
    (Réf - 338
  16. Remplacez le nom de l’hyperlien Popover verbiage par Popup.
    (Réf - 2859)
  17. Le codage de la propriété Curseur CSS ne fonctionne pas dans le panneau Aperçu de la rubrique Rh11 ni dans le navigateur CHM.
    (Réf - 961)
  18. La recherche par rubrique ne fonctionne pas sur les fichiers avec une extension en majuscules. 
    (Réf - 531)

Mise à jour 1 de RoboHelp (2019 release) - 17 septembre 2018

Amélioration des fonctionnalités

Accès aux vues Sortie et Auteur depuis un seul écran

Dans la version 2019 de RoboHelp, les vues Auteur et Sortie s’ouvrent dans deux fenêtres distinctes.

Désormais, les vues Auteur et Sortie sont fusionnées et accessibles via les onglets respectifs de la barre d’outils standard dans l’espace de travail RoboHelp.

Pour plus d’informations, consultez Familiarisez-vous avec l’espace de travail RoboHelp.

Utilisation d’un texte à développer et déroulant amélioré

Vous pouvez désormais réduire ou développer un texte ou tous les textes à développer/déroulants dans votre rubrique dans la vue Auteur et dans l’aperçu de la rubrique. Vous pouvez également modifier l’affichage des bordures de texte à développer/déroulant.

Pour plus d’informations, reportez-vous aux sections Utilisation d’un texte à développer et Utilisation d’un texte déroulant.

Utilisation des maquettes améliorées

Vous pouvez maintenant accéder aux maquettes via la barre d’outils Auteur dans la vue Auteur et non plus dans la vue Sortie.

Vous pouvez également appliquer une maquette à une rubrique lors de la création d’une rubrique. L’aperçu de la rubrique affiche également la maquette appliquée à la rubrique. 

Pour plus d’informations, consultez Utilisation des maquettes.

Utilisation des séquences de navigation

Vous pouvez désormais ajouter, modifier et supprimer les séquences de navigation. Dans une séquence de navigation, vous pouvez glisser-déposer les rubriques à partir du panneau Contenu et de la table des matières, modifier la séquence des rubriques et les supprimer. 

Pour plus d’informations, reportez-vous à la section Création et gestion des séquences de navigation.

Utilisation d’une table des matières de rubriques

Vous pouvez maintenant insérer, modifier ou supprimer une table des matières de rubriques dans les rubriques et les maquettes. 

Pour plus d’informations, reportez-vous à la section Insertion et personnalisation d’une table des matières de rubriques.

Utilisation des chemins de navigation

Vous pouvez désormais insérer et modifier les chemins de navigation dans les maquettes. 

Pour plus d’informations, reportez-vous à la section Insertion des chemins de navigation.

Utilisation des étiquettes spécifiques à une langue

Vous pouvez désormais modifier et supprimer les étiquettes spécifiques à une langue, annuler ou rétablir les modifications. Vous pouvez également exporter les étiquettes multilingues au format XML pour localisation et importer le texte traduit pour une langue spécifique.

Pour plus d’informations, voir Utilisation des étiquettes.

Annulation de la génération de sortie

Vous pouvez maintenant annuler la génération de sortie depuis le panneau Génération rapide et Paramètres prédéfinis.

Pour plus d’informations, voir Génération de sortie.

Utilisation d’une table des matières améliorée

Lorsque vous utilisez une table des matières dans votre projet, vous pouvez désormais développer une seule table des matières à la fois. Vous pouvez également annuler ou rétablir les modifications et utiliser la touche Supprimer pour supprimer une table des matières, un livre ou une page.

Pour plus d’informations, voir Création et gestion d’une table des matières.

Mise à niveau automatique des habillages

Lorsque vous mettez à niveau votre projet RoboHelp Classic vers l’application RoboHelp (2019 release), tous les habillages Responsive HTML5 sont automatiquement mis à niveau. Si les habillages sont personnalisés en dehors de l’éditeur d’habillage de RoboHelp Classic, utilisez l’onglet Mise en page du panneau Composants de l’habillage dans RoboHelp 2019 pour ajouter un fichier JavaScript ou CSS personnalisé.

Pour plus d’informations, voir Mise à niveau d’un habillage.

Attribution d’un nouveau nom à des paramètres de sortie prédéfinis

Vous pouvez désormais renommer les paramètres de sortie prédéfinis.

Pour plus d’informations, voir Renommer un paramètre prédéfini de sortie.

Modification de l’affichage des marqueurs de paragraphe

Dans votre rubrique ouverte, vous pouvez désormais modifier l’affichage des marqueurs de paragraphe.

Pour plus d’informations, voir Ajout de contenu ou modification d’une rubrique.

Utilisation d’un glossaire amélioré

Dans le panneau Glossaire, vous pouvez désormais développer un seul glossaire à la fois. Dans la vue développée, vous pouvez utiliser les menus contextuels de chaque glossaire et terme de glossaire. 

Pour plus d’informations, voir Création et gestion d’un glossaire.

Conversion des espaces dans les noms de fichier des rubriques en tirets de soulignement

Lorsque vous ajoutez une rubrique dans votre projet et saisissez le nom de la rubrique, RoboHelp convertit automatiquement les espaces dans les noms de fichier en tirets de soulignement. Vous pouvez modifier ce paramètre si nécessaire.

Pour plus d’informations, voir l’onglet Général dans les propriétés de rubrique.

Utilisation de nouvelles options de fermeture de rubrique

Si plusieurs rubriques sont ouvertes, utilisez le menu contextuel d’un onglet de rubrique pour fermer une rubrique, fermer toutes les autres rubriques sauf la rubrique actuelle, puis fermez toutes les rubriques. Lors de la fermeture de plusieurs rubriques, vous pouvez enregistrer les modifications dans une rubrique spécifique.

Pour plus d’informations, voir Options du menu contextuel de l’onglet Rubrique.

Modification des paramètres de sortie prédéfinis spécifiques depuis le panneau Génération rapide

Dans le panneau Génération rapide, vous pouvez maintenant sélectionner et ouvrir un paramètre de sortie prédéfini pour le modifier, sans avoir à rechercher le paramètre de sortie prédéfini dans la fenêtre Paramètres de sortie. Vous pouvez sélectionner et modifier plusieurs paramètres de sortie prédéfinis.

Pour plus d’informations, voir Génération de sortie.

Utilisation d’un index amélioré

Vous pouvez désormais établir une référence croisée d’un mot-clé ou d’un sous-mot-clé d’index avec un autre mot-clé et publier les références croisées. Vous pouvez également ajouter des variables de projet lorsque vous créez ou modifiez des mots-clés d’index.Vous pouvez utiliser les mots-clés d’index associés à des rubriques dans la recherche. Les mots-clés d’index ont le même classement que les mots-clés de recherche.

Pour plus d’informations, voir Création et gestion d’un index.

Recherche d’une rubrique dans une table des matières depuis le panneau Contenu

Vous pouvez désormais utiliser le menu contextuel dans le panneau Contenu pour afficher toutes les tables des matières liées à une rubrique et rechercher la rubrique dans une table des matières spécifique.

Problèmes résolus

  1. RoboHelp ne prend pas en charge Internet Explorer 11.
    (Réf - 2551
  2. Une erreur s’affiche lors de la première connexion à Git après la création de la clé SSH.
    (Réf - 2507
  3. Lors de l’importation d’un fichier Word contenant des tableaux et des listes, les onglets Liste et Tableau sont désactivés dans la boîte de dialogue Paramètres d’importation d’un fichier Word.
    (Réf - 2612
  4. Problèmes de synchronisation entre les fichiers/dossiers sur votre ordinateur et dans le panneau Contenu, notamment après un changement de nom.
    (Réf - 2332
  5. Les images ne sont pas affichées dans l’aperçu de l’éditeur d’habillage.
    (Réf - 2464
  6. Dans une rubrique ouverte, dans le panneau Propriétés > onglet Styles, l’option Aucun dans tous les styles possédait l’icône Modifier.
    (Réf - 2532
  7. Un message d’erreur d’application s’affiche lorsque vous essayez d’afficher le fichier journal lors de la génération de sortie ou après l’échec de la génération de sortie. 
    (Réf - 2442
  8. Lors de la duplication d’une rubrique avec des modifications non enregistrées, RoboHelp ne vous invite pas à enregistrer le document et crée la copie dupliquée sans les modifications non enregistrées.
    (Réf - 2567
  9. Dans les projets fusionnés, la recherche RoboHelp renvoie uniquement les résultats de certains projets enfants et non de tous les projets.
    (Réf - 831
  10. Lorsque vous utilisez des expressions de condition, des mots exclus, des synonymes et des habillages, l’astérisque (*) qui indique des modifications non enregistrées, ne s’affiche pas dans les onglets respectifs.
    (Réf - 2090
  11. RoboHelp ne se souvient pas de la position ou de la taille modifiée de la fenêtre de l’application et n’autorise pas le redimensionnement ou la réduction de l’écran Paramètres de sortie.
    (Réf - 2399
  12. Un index incomplet s’affiche dans la sortie et les mots-clés de filtrage ne fonctionnent pas.
    (Réf - 2398
  13. Les fichiers Icône favorite sélectionnés dans les paramètres de sortie ne s’affichent pas dans la sortie.
    (Réf - 2397
  14. Les info-bulles des termes de glossaire ne fonctionnent pas dans la sortie.
    (Réf - 2400
  15. Une erreur JavaScript s’affiche lors de la désinstallation d’une version précédente de RoboHelp et lors de l’installation et du premier lancement de RoboHelp 2019.
    (Réf - 2278
  16. Les opérations telles que l’insertion d’images et d’éléments multimédia, et le copier/coller s’effectuent plusieurs fois.
    (Réf - 2314
  17. Lors du redimensionnement d’une image à l’aide de l’onglet Général du panneau Propriétés, ses proportions ne sont pas conservées si l’unité est en pourcentage.
    (Réf - 2312
  18. Lors de la génération d’une sortie d’application mobile, un problème d’image d’écran de démarrage est présent.
    (Réf - 1252
  19. Les versions non réduites des fichiers JS principaux (rh.js, layout.js, topic.js et common.js) sont inclus dans la sortie HTML5.
    (Réf - 2357
  20. Les séquences de navigation et le glossaire ne fonctionnent pas dans la sortie CHM.
    (Réf - 2295
  21. Lors de la mise à niveau d’un projet RoboHelp Classic 2017 ou 2019 contenant des fichiers bagage dans la table des matières vers RoboHelp 2019, les liens de la table des matières ne sont pas mis à jour correctement. 
    (Réf - 2446
  22. La génération de sortie échoue sans afficher de message d’erreur si la table des matières comprend des liens rompus.
    (Réf - 2445
  23. Lors de la génération d’une sortie à l’aide de la fenêtre Génération rapide, les paramètres prédéfinis non sélectionnés sont générés et un statut incorrect s’affiche.
    (Réf - 2605
  24. Dans plusieurs rubriques ouvertes, la barre d’onglets occupe plusieurs lignes.
    (Réf - 2496
  25. La recherche de contenu RoboHelp ne fonctionne pas pour certaines langues.
    (Réf - 1873)

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne