Após a otimização de um gráfico ou documento, é possível exportá-lo (ou salvá-lo, dependendo do tipo de arquivo de origem).

Você pode exportar (ou, em alguns casos, salvar) um documento como uma única imagem no formato GIF, JPEG ou outro formato de arquivo gráfico. Também pode exportar o documento inteiro como um arquivo HTML e os arquivos de imagem associados, apenas as fatias selecionadas ou uma área especificada. Além disso, pode exportar estados e camadas do Fireworks como arquivos de imagem separados.

O local padrão para o qual o Fireworks exporta arquivos é determinado pelo seguinte, nesta ordem:

  1. A preferência de exportação atual do documento, que será definida se você já tiver exportado o documento e salvado o PNG

  2. O local atual de exportação/salvamento, que é definido sempre que você navega para outro local que não seja o padrão apresentado em uma caixa de diálogo Salvar, Salvar como ou Exportar

  3. O local do arquivo atual

  4. O local padrão em que novos documentos ou imagens são salvos no seu sistema operacional

    Em contraste, o local padrão no qual o Fireworks salva um documento é determinado por um conjunto diferente de critérios. Para obter mais informações, consulte Salvamento de arquivos do Fireworks.

Exportar páginas como arquivos de imagem

  1. Selecione Arquivo > Exportar.

  2. Escolha o local para os arquivos de exportação.

  3. Siga um destes procedimentos:

    • Selecione Apenas imagens, no menu pop-up Exportar, e marque ou desmarque a caixa de seleção Somente página atual. As páginas são exportadas para o formato de imagem definido no painel Otimizar.

    • Selecione Páginas para arquivos, no menu pop-up Exportar, e escolha Imagens no menu pop-up Exportar como. As páginas são exportadas para o formato de imagem definido no painel Otimizar

    • Selecione Páginas para arquivos, no menu pop-up Exportar, e escolha PNG do Fireworks no menu pop-up Exportar como. Cada página é exportada como um arquivo PNG separado e compatível com o Fireworks 8.

    Observação:

    Se desejar exportar todas as páginas no formato selecionado, selecione todas as páginas e otimize as configurações.

Exportar uma única imagem

Se você estiver trabalhando com uma imagem existente aberta no Fireworks, poderá salvá-la em vez de exportá-la. Para obter mais informações, consulte Salvar documentos em outros formatos.

Observação:

Para exportar apenas certas imagens em um documento, primeiro é necessário fatiar o documento e, em seguida, exportar somente as fatias desejadas.

  1. No painel Otimizar, selecione um formato de arquivo e defina opções específicas para esse formato.

  2. Selecione Arquivo > Exportar.

  3. Selecione um local para o qual exportar o arquivo de imagem.

    Para gráficos da Web, o melhor local é geralmente uma pasta no seu site da Web local.

  4. Insira um nome de arquivo sem extensão. Uma extensão é adicionada durante a exportação com base no tipo de arquivo.

  5. No menu pop-up Exportar, selecione Apenas imagens.

  6. Clique em Salvar.

Exportar um documento fatiado

Por padrão, quando você exporta um documento fatiado do Fireworks, um arquivo HTML e imagens associadas são exportados. O arquivo HTML exportado pode ser exibido em um navegador da Web ou importado para outros aplicativos para edição adicional.

Antes da exportação, certifique-se de ter o estilo HTML apropriado selecionado na caixa de diálogo Configurar HTML. Consulte Definir opções de exportação de HTML.

Exportar todas as fatias

  1. Selecione Arquivo > Exportar.

  2. Navegue até uma pasta no disco rígido para a qual exportar.

  3. No menu pop-up Exportar, selecione HTML e imagens.

  4. Digite um nome de arquivo na caixa Nome do arquivo (Windows) ou Salvar como (Mac OS).

  5. No menu pop-up HTML, selecione Exportar arquivo HTML.

  6. No menu pop-up Fatias, selecione Exportar fatias.

  7. (Opcional) Selecione Colocar imagens em subpasta.

  8. Clique em Salvar.

Exportar fatias selecionadas

  1. Clique com a tecla Shift pressionada para selecionar várias fatias.

  2. Selecione Arquivo > Exportar.

  3. Selecione um local no qual armazenar os arquivos exportados, como uma pasta no seu site da Web local.

  4. No menu pop-up Exportar, selecione HTML e imagens.

  5. Insira um nome de arquivo sem extensão. Uma extensão é adicionada durante a exportação com base no tipo de arquivo.

    Se várias fatias estiverem sendo exportadas, o Fireworks usará o nome inserido como raiz para todos os gráficos exportados, excluindo aqueles para os quais você inseriu um nome personalizado no painel Camadas ou no Inspetor de propriedades.

  6. No menu pop-up Fatias, selecione Exportar fatias.

  7. Para exportar somente as fatias selecionadas antes da exportação, escolha Somente fatias selecionadas e verifique se a opção Incluir áreas sem fatias não está selecionada.

  8. Clique em Salvar.

Atualizar uma fatia

Se você já tiver exportado um documento fatiado e feito alterações subsequentes no documento original no Fireworks, será possível atualizar apenas a imagem ou a fatia alterada. Para facilitar a localização da fatia substituta, dê nomes personalizados às fatias.

  1. Oculte a fatia e edite a área abaixo dela.

  2. Mostre a fatia novamente.

  3. Clique com o botão direito (Windows), ou com a tecla Control (Mac OS) pressionada, na fatia e selecione Exportar fatia selecionada.

  4. Selecione a mesma pasta que a fatia original, usando o mesmo nome base, e clique em Salvar.

  5. Clique em OK quando solicitado a substituir o arquivo existente.

    Observação:

    Evite redimensionar a fatia além do seu tamanho de exportação original no Fireworks; caso contrário, você poderá criar resultados inesperados no documento HTML depois que a fatia for atualizada.

Exportar uma animação

Após a criação e a otimização de uma animação, ela estará pronta para ser exportada. Você pode exportar uma animação como qualquer um dos seguintes tipos de arquivo:

GIFs animados

Fornecem os melhores resultados para clip-art e gráficos ao estilo de quadrinhos.

SWF do Flash ou PNG do Fireworks (exportação desnecessária)

Exporte uma animação como arquivo SWF para importação no Flash. Ou, ignore a etapa de exportação importando um arquivo de origem PNG do Fireworks diretamente no Flash. Usando esse método direto, é possível importar todas as camadas e estados da sua animação e continuar a editá-los no Flash. Consulte Trabalhar com o Flash.

Vários arquivos

Exportar camadas ou estados de animação como vários arquivos é útil quando existem muitos símbolos em diferentes camadas para o mesmo objeto. Por exemplo, você poderia exportar um anúncio de banner como vários arquivos se cada letra do nome de uma empresa fosse animada em um gráfico. Consulte Exportar estados ou camadas como vários arquivos.

Se o seu documento contiver mais de uma animação, será possível inserir fatias a fim de exportar cada animação usando diferentes configurações de animação, como repetição e atraso de estado.

Exportar um GIF animado

  1. Escolha Selecionar > Cancelar seleção, para cancelar a seleção de todas as fatias e objetos, e selecione GIF animado como formato de arquivo no painel Otimizar.

  2. Selecione Arquivo > Exportar.

  3. Digite um nome para o arquivo e selecione o destino.

  4. Clique em Salvar.

Exportar vários GIFs animados com diferentes configurações de animação

  1. Clique nas animações com a tecla Shift pressionada para selecionar todas elas.

  2. Selecione Editar > Inserir > Fatia retangular ou Fatia poligonal.

  3. Na caixa de mensagem, clique em Múltipla.

  4. Selecione cada fatia individualmente e use o painel Estados para definir diferentes configurações de animação para cada.

  5. Selecione todas as fatias que deseja animar e escolha GIF animado como formato de arquivo no painel Otimizar.

  6. Clique em cada fatia com o botão direito (Windows), ou com a tecla Control (Mac OS) pressionada, e selecione Exportar fatia selecionada para exportar cada fatia individualmente. Na caixa de diálogo Exportar, digite um nome para cada arquivo, selecione o destino e clique em Salvar.

Exportar estados ou camadas como vários arquivos

O Fireworks pode exportar cada camada ou estado em um documento como um arquivo de imagem separado e utilizar as configurações de otimização especificadas no painel Otimizar. O nome da camada ou estado determina o nome de arquivo de cada arquivo exportado. Esse método de exportação é usado às vezes para exportar animações.

  1. Selecione Arquivo > Exportar.

  2. Digite um nome de arquivo e selecione uma pasta de destino.

  3. No menu pop-up Exportar, selecione uma opção:

    Estados para arquivos

    Exporta estados como vários arquivos.

    Camadas para arquivos

    Exporta camadas como vários arquivos.

    Observação: Essa opção exporta todas as camadas no estado atual.

  4. Para cortar automaticamente cada imagem exportada, de forma a incluir somente os objetos em cada estado, selecione Aparar imagens. Para incluir no lugar a tela de desenho inteira (inclusive as áreas em branco além dos objetos), desmarque essa opção.

  5. Clique em Salvar.

Exportar uma área de um documento

  1. No painel Ferramentas, selecione a ferramenta Área de exportação .

  2. Arraste uma marca de seleção definindo a parte do documento a ser exportada.

    Observação:

    É possível ajustar a posição de marca de seleção à medida que você arrastar. Ao manter pressionado o botão do mouse, pressione e segure a barra de espaço e arraste a marca de seleção até outro local na tela de desenho. Solte a barra de espaço para continuar a desenhar a marca de seleção.

    Quando você soltar o botão do mouse, a área de exportação permanecerá selecionada.

  3. Redimensione a área de exportação, se necessário:

    • Para redimensionar proporcionalmente a marca de seleção da área de exportação, arraste uma alça com a tecla Shift pressionada.

    • Para redimensionar a marca de seleção a partir do centro, arraste uma alça com a tecla Alt (Windows), ou Option (Mac OS), pressionada.

    • Para restringir as proporções e redimensionar a partir do centro, arraste uma alça com as teclas Alt e Shift (Windows), ou Option e Shift (Mac OS), pressionadas.

  4. Clique duas vezes dentro da marca de seleção da área de exportação para acessar a Visualização da imagem.

  5. Ajuste as configurações na Visualização da imagem e clique em Exportar.

  6. Digite um nome de arquivo e selecione uma pasta de destino.

  7. No menu pop-up Exportar, selecione Apenas imagens.

  8. Clique em Salvar.

    Observação:

    Para cancelar sem exportar, clique duas vezes fora da marca de seleção da área de exportação, pressione Escape ou selecione outra ferramenta.

Exportar HTML

A menos especificado de outra forma, ao exportar um documento fatiado do Fireworks, você exporta um arquivo HTML e suas imagens. Para definir como o Fireworks exporta HTML, use a caixa de diálogo Configurar HTML.

O Fireworks gera um HTML puro que pode ser lido pela maioria dos navegadores da Web e editores de HTML. Por padrão, a exportação especifica a codificação UTF-8.

Existem várias maneiras de exportar HTML do Fireworks:

  • Exporte um arquivo HTML, que mais tarde pode ser aberto para edição em um editor HTML.

  • Exporte cada página em um arquivo do Fireworks para um arquivo HTML separado.

  • Copie o código HTML para a área de transferência no Fireworks e, em seguida, cole-o diretamente em um documento HTML existente.

  • Exporte um arquivo HTML, abra-o em um editor de HTML, copie manualmente as seções de código do arquivo e cole esse código em outro documento HTML.

  • Exporte HTML como camadas CSS (Cascading Style Sheet) e XHTML.

  • Use o comando Atualizar HTML para fazer alterações em um arquivo HTML anteriormente criado.

    O Fireworks permite exportar HTML nos formatos Genérico, do Dreamweaver, do Microsoft® FrontPage® e do Adobe GoLive®.

    Observação:  O Adobe Dreamweaver compartilha uma estreita integração com o Fireworks. O Fireworks lida com a exportação de HTML para o Dreamweaver de maneira diferente em comparação a outros editores de HTML. Se você estiver exportando HTML do Fireworks para o Dreamweaver, consulte Trabalhar com o Dreamweaver.

    O método de exportação que distribui um HTML do Fireworks a outros aplicativos é ideal quando se trabalha em um ambiente de equipe. Ele divide o fluxo de trabalho em segmentos, para que uma pessoa possa realizar uma tarefa em um aplicativo e outra possa assumi-la mais tarde usando outro aplicativo.

Incluir comentários no HTML exportado

Comentários no HTML do Fireworks começam com <!-- e terminam com -->. Nenhum conteúdo entre esses dois marcadores é interpretado como código HTML ou JavaScript.

  1. Antes de exportar, selecione a opção Incluir comentários HTML, na guia Geral da caixa de diálogo Configurar HTML.

Resultados da exportação

Quando você exporta ou copia HTML do Fireworks, o seguinte é gerado:

  • O código HTML necessário para remontar imagens fatiadas e qualquer código JavaScript, se o documento contiver elementos interativos. Um HTML do Fireworks contém links para as imagens exportadas e define a cor de plano de fundo da página da Web como a cor da tela de desenho.

  • Um ou mais arquivos de imagem, dependendo de quantas fatias estão no seu documento e quantos estados estão incluídos nos botões.

  • Um arquivo denominado spacer.gif, se necessário. Spacer.gif é um GIF transparente de 1 por 1 pixel usado pelo Fireworks para corrigir problemas de espaçamento quando as imagens fatiadas são remontadas em uma tabela HTML. Você pode escolher se o Fireworks exportará ou não um espaçador.

  • Se menus pop-up forem exportados, os seguintes arquivos também serão exportados: mm_css_menu.js e um arquivo .css contendo o código de menus pop-up CSS. Se os seus menus pop-up contiverem submenus, um arquivo arrows.gif também será exportado.

  • Se você exportar ou copiar HTML para o Dreamweaver, serão criados arquivos de anotações que facilitarão a integração entre o Fireworks e o Dreamweaver. Esses arquivos têm uma extensão .mno.

Exportar HTML do Fireworks

  1. Selecione Arquivo > Exportar.

  2. Navegue até uma pasta no disco rígido para a qual exportar.

  3. No menu pop-up Exportar, selecione HTML e imagens.

  4. Clique no botão Opções e selecione seu editor de HTML no menu pop-up Estilo HTML, na guia Geral da caixa de diálogo Configurar HTML. Se o seu editor de HTML não estiver listado, selecione Genérico.

    Observação:

    É importante que você selecione seu editor de HTML como o estilo de HTML, para que elementos interativos, como botões e sobreposições, funcionem corretamente quando incorporados a esse editor.

  5. Clique em OK.

  6. No menu pop-up HTML, selecione Exportar arquivo HTML.

  7. Se o documento contiver fatias, selecione Exportar fatias no menu pop-up Fatias.

  8. Para armazenar imagens em uma pasta separada, selecione Colocar imagens em subpasta. É possível selecionar uma pasta específica ou usar a pasta Imagens padrão do Fireworks.

  9. Se você estiver exportando um documento do Fireworks de várias páginas, desmarque a caixa de seleção Somente página atual para exportar todas as páginas em documentos HTML separados.

  10. Clique em Salvar.

    Após a exportação, você verá no disco rígido os arquivos exportados pelo Fireworks. Imagens e um arquivo HTML são gerados no local especificado, na caixa de diálogo Exportar.

Copiar código HTML na área de transferência

Você pode copiar código HTML para a área de transferência no Fireworks de duas maneiras. Use o comando Copiar código HTML ou selecione Copiar para área de transferência como uma opção na caixa de diálogo Exportar. Mais tarde, você irá colar esse HTML em um documento, no seu editor de HTML preferencial.

Ao determinar como inserir um HTML do Fireworks em outros aplicativos, considere as seguintes desvantagens de se copiar o código HTML para a área de transferência:

  • Você não tem a opção de salvar imagens em uma subpasta. Elas devem residir na mesma pasta que o arquivo HTML na qual o HTML copiado é colado. Uma exceção é um HTML copiado para o Dreamweaver.

  • Todos os links ou caminhos usados nos menus pop-up do Fireworks serão mapeados para o disco rígido. O HTML copiado para o Dreamweaver é uma exceção.

  • Se você usar um editor de HTML diferente do Dreamweaver ou do Microsoft FrontPage, o código JavaScript associado a botões, comportamentos e imagens de sobreposição será copiado, mas não funcionará corretamente.

    Se isso representar um problema para você, use a opção Exportar HTML em vez de copiar o HTML para a área de transferência.

    Observação:  Antes de copiar o código HTML, certifique-se de ter selecionado o estilo de HTML apropriado e de ter escolhido Incluir comentários HTML, na guia Geral da caixa de diálogo Configurar HTML.

Copiar HTML do Fireworks usando a opção Copiar código HTML

  1. Selecione Editar > Copiar código HTML.

  2. Siga o assistente. Quando solicitado, especifique uma pasta como o destino das imagens exportadas. Esse deve ser o local em que o arquivo HTML residirá.

    Observação:

    Se você planeja colar o código HTML no Dreamweaver, não importa o local onde as imagens são exportadas, desde que elas residam no mesmo site do Dreamweaver que o arquivo HTML no qual esse código será colado.

Copiar HTML do Fireworks usando a caixa de diálogo Exportar

  1. Selecione Arquivo > Exportar.

  2. Na caixa de diálogo Exportar, especifique uma pasta como o destino das imagens exportadas. Esse deve ser o mesmo local em que o arquivo HTML residirá.

    Observação:

    Se você planeja colar o código HTML no Dreamweaver, não importa o local onde as imagens são exportadas, desde que elas residam no mesmo site do Dreamweaver que o arquivo HTML no qual esse código será colado.

  3. No menu pop-up Exportar, selecione HTML e imagens.

  4. No menu pop-up HTML, selecione Copiar para área de transferência.

  5. Se o documento contiver fatias, selecione Exportar fatias no menu pop-up Fatias.

  6. Clique no botão Opções, selecione o editor de HTML na caixa de diálogo Configurar HTML e clique em OK.

  7. Clique em Salvar.

Colar o HTML copiado do Fireworks em um documento HTML

  1. No editor de HTML, abra um documento HTML existente ou crie um novo. Salve o documento no mesmo local em que as imagens foram exportadas.

    Observação:

    Não será necessário salvar o arquivo HTML no mesmo local que as imagens exportadas se você utilizar o Dreamweaver. Desde que as imagens sejam exportadas do Fireworks para um site do Dreamweaver e o arquivo HTML seja salvo em um local nesse site, o Dreamweaver resolverá os caminhos para as imagens associadas.

  2. Visualize o código HTML e insira o ponto de inserção entre as marcas <BODY>.

    Observação:

    O código HTML copiado do Fireworks não inclui as marcas <HTML> e <BODY> de abertura ou fechamento.

  3. Cole o código HTML.

    Se possível, ao copiar na área de transferência, exporte as imagens para o local em que elas residirão no site da Web. O Fireworks usa URLs relativos a documentos e, sendo assim, se o HTML ou as imagens forem movidos, os links de URL serão rompidos.

Copiar código de um arquivo exportado do Fireworks e colá-lo em outro documento HTML

  1. Abra o arquivo HTML do Fireworks exportado em um editor de HTML.

  2. Realce o código necessário e copie-o na área de transferência.

  3. Abra um documento HTML existente ou crie um novo.

  4. Cole o código no novo arquivo HTML. Não é necessário copiar as marcas <HTML> e <BODY>, já que elas já estarão incluídas no documento HTML de destino.

    Se você escolher Incluir comentários HTML, na caixa de diálogo Configurar HTML do Fireworks, siga as instruções nos comentários para copiar e colar o código no local adequado.

  5. Se o seu documento do Fireworks contiver elementos interativos, copie o código JavaScript.

    O código JavaScript é delimitado por marcas <SCRIPT> e está localizado na seção <HEAD> do documento. Copie e cole a seção <SCRIPT> inteira, a não ser que o documento de destino já tenha uma seção <SCRIPT>. Nesse caso, basta copiar e colar apenas o conteúdo da seção <SCRIPT> na seção <SCRIPT> existente, tomando cuidado para não substituir o conteúdo dessa seção existente. Além disso, certifique-se de que não haja funções JavaScript duplicadas na seção <SCRIPT> depois de colar o código.

Atualizar o HTML exportado

Atualizar permite fazer alterações em um documento HTML do Fireworks anteriormente exportado e é útil quando se deseja atualizar apenas uma parte de um documento.

Observação:

A operação Atualizar HTML funciona de maneira diferente com documentos do Dreamweaver em comparação a outros documentos HTML. Para obter mais informações, consulte Trabalhar com o Dreamweaver.

Durante a atualização, é possível optar por substituir somente as imagens que foram alteradas ou substituir todas as imagens e o código. Se você optar por substituir apenas as imagens que foram alteradas, todas as alterações feitas no arquivo HTML fora do Fireworks serão preservadas.

Observação:

No caso de alterações consideráveis no layout do documento, faça alterações no Fireworks e exporte novamente o arquivo HTML.

  1. Selecione Arquivo > Atualizar HTML.

  2. Selecione o arquivo a ser atualizado.

  3. Clique em Open.

  4. Siga um destes procedimentos:

    • Se nenhum HTML gerado pelo Fireworks for encontrado, clique em OK para inserir um novo HTML no final do documento.

    • Se um HTML gerado pelo Fireworks for encontrado, selecione uma destas opções e clique em OK:

      Substituir imagens e código HTML associado

      Substitui o HTML do Fireworks anterior

      Atualizar somente imagens

      Substitui apenas as imagens

  5. Se a caixa de diálogo Selecionar pasta de imagens aparecer, selecione uma pasta e clique em Abrir.

Exportar camadas CSS

Camadas CSS podem se sobrepor e ficar empilhadas uma em cima da outra. No Fireworks, a saída HTML normal não fica sobreposta.

  1. Selecione Arquivo > Exportar.

  2. Digite um nome de arquivo e selecione uma pasta de destino.

  3. No menu pop-up Exportar, selecione CSS e imagens.

    • Para exportar apenas o estado atual, selecione Somente estado atual.

    • Para exportar apenas a página atual, selecione Somente página atual.

    • Para escolher uma pasta para as imagens, selecione Colocar imagens em subpasta.

  4. Clique em Opções para definir as propriedades da página HTML.

  5. Clique em Procurar para especificar uma imagem de fundo e defina a disposição lado a lado da imagem de fundo:

    • Selecione Sem repetição para exibir a imagem apenas uma vez.

    • Selecione Repetir para repetir ou dispor a imagem lado a lado horizontalmente e verticalmente.

    • Selecione a opção Repetir x para dispor a imagem lado a lado horizontalmente.

    • Selecione a opção Repetir y para dispor a imagem lado a lado verticalmente.

  6. Selecione o alinhamento de página no navegador como à esquerda, centralizado ou à direita.

  7. Clique em OK e, em seguida, em Salvar.

Exportar XHTML

O XHTML é uma combinação de HTML, o padrão atual para formatação e exibição de páginas da Web, e o XML (Extensible Markup Language). O XHTML tem compatibilidade com versões anteriores; ou seja, a maioria dos navegadores atuais consegue exibi-lo e ele pode ser lido por qualquer dispositivo que apresente conteúdo XML, como PDAs, celulares e outros dispositivos portáteis.

O Fireworks também pode importar XHTML. Consulte Criar arquivos PNG do Fireworks a partir de arquivos HTML.

Para obter mais informações sobre XHTML, consulte a especificação XHTML do WC (World Wide Web Consortium) em www.w3.org.

  1. Selecione Arquivo > Configurar HTML, selecione um estilo de XHTML no menu pop-up Estilo HTML, na guia Geral, e clique em OK.

  2. Exporte o documento usando qualquer um dos métodos disponíveis para exportação ou cópia de HTML. Consulte Exportar HTML.

    Observação:

    O Fireworks usa a codificação UTF-8 ao exportar para XHTML.

Exportar arquivos com e sem codificação UTF-8

UTF-8 (Universal Character Set Transformation Format-8), que representa um formato universal de transformação de conjuntos de caracteres, é um método de codificação de texto com o qual os navegadores da Web podem exibir diferentes conjuntos de caracteres (por exemplo, texto em chinês e texto em inglês) na mesma página HTML. A codificação UTF-8 está ativada por padrão.

O Fireworks também pode importar documentos que utilizam essa codificação. Consulte Criar arquivos PNG do Fireworks a partir de arquivos HTML.

Exportar documentos sem codificação UTF-8

  1. Selecione Arquivo > Configurar HTML.

  2. Na guia Específico do documento, desmarque a caixa de seleção Codificação UTF-8 e clique em OK.

  3. Exporte o documento usando qualquer um dos métodos disponíveis para exportação ou cópia de HTML.

Definir opções de exportação de HTML

A caixa de diálogo Configurar HTML permite definir como o Fireworks exporta o HTML. As alterações feitas na guia Específico do documento afetam apenas o documento atual. As configurações em Geral e Tabela são preferências globais e afetam todos os novos documentos.

  1. Siga um destes procedimentos:

    • Selecione Arquivo > Configurar HTML.

    • Clique no botão Opções da caixa de diálogo Exportar.

  2. Na guia Geral, selecione as opções preferenciais.

    Estilo HTML

    Selecione o estilo do HTML exportado.

    HTML genérico funciona em qualquer editor de HTML. Entretanto, se o seu documento tiver comportamentos ou outro conteúdo interativo, selecione o seu editor específico se ele aparecer na lista.

    Para exportar o documento usando o padrão XHTML, selecione o estilo XHTML apropriado no menu pop-up.

    Extensão

    Selecione uma extensão de arquivo no menu pop-up ou insira uma nova extensão.

    Incluir comentários HTML

    Selecione para incluir comentários referentes ao local no HTML para copiar e colar. Essa opção é recomendada quando o documento contém elementos interativos, como botões, comportamentos ou imagens de sobreposição.

    Nome de arquivo em minúsculas

    Selecione para colocar em minúsculas o nome do arquivo HTML e dos arquivos de imagem associados ao exportar.

    Observação: Essa opção não irá alterar a extensão do arquivo HTML para minúsculas se uma extensão em maiúsculas tiver sido selecionada no menu pop-up Extensão.

    Usar CSS para menus pop-up

    Selecione para usar CSS em vez de JavaScript para o código de menus pop-up. Você pode usar o Dreamweaver para indexar os menus e atualizar os links dentro do código.

    Gravar CSS em um arquivo externo

    Selecione para que o código CSS seja gravado em um arquivo .css externo exportado para o mesmo local que o arquivo HTML. O nome do arquivo .css corresponde ao nome do arquivo HTML (exceto pela extensão). Escolher essa opção também exporta um arquivo denominado mm_css_menu.js no mesmo local que o arquivo HTML.

    Observação: Essa opção apenas estará disponível se você tiver escolhido a opção Usar CSS para menus pop-up.

    Criador de arquivos (Mac OS)

    Selecione um aplicativo associado no menu pop-up. Quando você clicar duas vezes no arquivo HTML exportado no disco rígido, ele será aberto automaticamente no aplicativo selecionado.

  3. Na guia Tabela, selecione configurações para as tabelas HTML. Para obter informações, consulte Definir como as tabelas HTML são exportadas.

  4. Na guia Específico do documento, selecione uma das opções a seguir:

    Nomes de arquivos de fatias

    Selecione uma fórmula para nomear fatias automaticamente nos menus pop-up. Você pode usar as configurações padrão ou pode escolher as suas próprias opções.

    Observação: Se Nenhum estiver selecionado para qualquer um dos três primeiros menus, o Fireworks irá exportar arquivos de fatia que substituem uns aos outros, resultando em um único gráfico exportado e em uma tabela que exibe esse gráfico em cada célula.

    Tag Alt padrão

    Insira um texto a ser exibido no lugar de todas as imagens enquanto elas estiverem sendo transferidas por download da Web e no lugar de qualquer imagem que apresentar falhas no download. Em alguns navegadores, esse texto também pode aparecer como dica de ferramenta quando o ponteiro passa pela imagem. Esse recurso também é um auxílio para usuários da Web com deficiência visual.

    Exportar várias páginas HTML de barra de navegação (para uso sem conjuntos de quadros)

    Selecione ao exportar uma barra de navegação que vincula várias páginas. O Fireworks exporta páginas adicionais para cada botão na barra de navegação.

    Incluir áreas sem objetos de fatia

    Selecione para incluir áreas da tela de desenho que não são cobertas por fatias.

    Codificação UTF-8

    Opção ativada por padrão. Permite que o documento exportado exiba caracteres de vários conjuntos de caracteres. Para desativar essa opção, desmarque a caixa de seleção.

  5. Para salvar essas configurações como configurações padrão globais, clique em Definir padrões.

Exportar arquivos Adobe PDF

Quando quiser imprimir um design do Fireworks ou distribuí-lo para revisão, exporte-o para Adobe PDF. Os revisores podem adicionar comentários e responder aos comentários uns dos outros no Adobe Reader® ou no Acrobat®. Para obter informações sobre como configurar revisões de PDF, consulte a Ajuda do Acrobat.

Os arquivos PDF exportados mantêm todos os links de hipertexto e páginas, permitindo que os revisores naveguem como fariam na Web. Entretanto, ao contrário de protótipos HTML, o Adobe PDF possui configurações de segurança que impedem que os revisores editem ou copiem os seus designs.

  1. Escolha Arquivo > Exportar.

  2. No menu pop-up Exportar, escolha Adobe PDF.

  3. Escolha as páginas a serem exportadas e selecione Exibir PDF após exportação para abrir o PDF automaticamente no Adobe Reader ou Acrobat.

  4. Para personalizar o PDF, clique em Opções e ajuste as seguintes configurações:

    Compatibilidade

    Determina quais aplicativos Adobe PDF podem abrir o arquivo exportado.

    Compactação

    Determina o tipo de compactação da imagem, reduzindo o tamanho do arquivo. Em geral, as compactações JPEG e JPEG2000 oferecem melhores resultados em imagens fotográficas que possuem transições graduais entre cores. O ZIP é a melhor opção para ilustrações com amplas áreas de cores sólidas e uniformes.

    Qualidade

    Para compactação JPEG ou JPEG2000, oferece configurações de qualidade de imagem. Selecionar Alta qualidade gera um arquivo grande com boa qualidade de imagem.

    Converter em escala de cinza

    Converte todas as imagens em escala de cinza, reduzindo o tamanho do arquivo.

    Ativar seleção de texto

    Permite que os revisores copiem texto do arquivo exportado. Cancele a seleção dessa opção para reduzir significativamente o tamanho do arquivo.

    Valor de sangria

    Determina a largura de pixels da borda em branco que delimita a imagem em cada página. Um valor de 20, por exemplo, delimita cada imagem com uma borda de 20 pixels.

    Usar senha para abrir documento

    Requer a Senha de abertura para abrir o arquivo exportado.

    Usar senha para restringir tarefas

    Requer a Senha de segurança para executar estas funções selecionadas: impressão, edição, cópia e comentários.

  5. Clique em OK para fechar a caixa de diálogo Opções.

  6. Especifique um nome de arquivo e um local e clique em Salvar.

    Observação:

    Se as páginas no documento do Fireworks tiverem telas de desenho transparentes, os objetos com transparências aplicadas perderão suas características transparentes quando você os exportar para PDF. Para evitar isso, defina a tela de desenho como um plano de fundo não transparente antes de exportar para PDF.

Vídeo

Crie provas de clientes em forma de arquivos PDF ou HTML usando o Fireworks (00:05:32)

Saiba como usar o menu Exportar do Fireworks para preparar um PDF ou um documento HTML para aprovação do cliente ou para resenha da equipe.

Por Tom Green

Quando for exibir arquivos PDF exportados no Adobe Acrobat ou no Adobe Reader, use as configurações a seguir:

  1. No Adobe Acrobat ou no Adobe Reader, selecione Editar > Preferências.

  2. Selecione Exibição de página no painel esquerdo.

  3. Defina a Resolução personalizada como 72 pixels por polegada.

  4. Defina o valor de Zoom como 100%.

Exportar arquivos FXG

FXG é um formato de arquivo compatível com o Flash Catalyst, Fireworks, Illustrator e Photoshop. Ao exportar um arquivo que contém imagens vetoriais e de bitmap usando a exportação de FXG, uma pasta separada com o nome <filename.assets> é criada. A pasta contém as imagens de bitmap associadas ao arquivo.

A operação de importação falhará se um dos arquivos associados for excluído dessa pasta.

Observação:

Elementos, filtros, modos de mesclagem, gradientes e máscaras sem marca de mapeamento correspondente em FXG são exportados como gráficos de bitmap.

  1. Selecione Arquivo > Exportar e navegue até o local onde deseja salvar os arquivos.

  2. Digite um nome para o arquivo FXG.

  3. Na caixa de diálogo Exportar, selecione FXG e imagens no menu Exportar.

  4. Clique em Salvar.

Observação:

Objetos que se estendem além da tela de desenho no Fireworks são completamente exibidos quando o arquivo FXG exportado é aberto no Flash Catalyst.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online