O Fireworks importa arquivos nativos do Photoshop (PSD) e mantém muitos dos recursos do Photoshop. Você também pode exportar gráficos do Fireworks para o Photoshop, para edição detalhada de imagens.

Inserir imagens do Photoshop no Fireworks

Insira imagens do Photoshop no Fireworks usando os comandos Arquivo > Importar e Arquivo > Abrir ou arrastando arquivos até a tela de desenho. O comando Importar fornece acesso a opções exclusivas para as pastas de camadas e camadas de plano de fundo. Por outro lado, o comando Abrir e o método de arrastar arquivos oferecem acesso a opções para guias e estados.

Recursos do Photoshop convertidos e não suportados no Fireworks

Quando um arquivo do Photoshop é aberto ou importado, o Fireworks converte a imagem no formato PNG usando preferências de importação especificadas por você. (Consulte Preferências de importação e abertura do Photoshop.)

  • Máscaras de camada individuais são convertidas em máscaras de objeto do Fireworks. Não há suporte para máscaras de grupo.

  • Máscaras de corte são convertidas em máscaras de objeto, mas sua aparência é ligeiramente alterada. Para manter a aparência, mas perder a capacidade de edição, selecione a preferência Máscaras de corte.

  • Modos de mesclagem para camadas são convertidos em modos de mesclagem para objetos do Fireworks, se os modos correspondentes existirem.

  • Efeitos de camada são preservados por padrão. Se você preferir converter esses efeitos em Filtros em tempo real correspondentes, selecione a preferência Efeitos de camada. Entretanto, observe que efeitos e filtros semelhantes podem ter pequenas variações na aparência.

  • O primeiro canal alfa da paleta Canais é convertido em áreas transparentes na imagem do Fireworks. O Fireworks não oferece suporte a canais alfa adicionais do Photoshop.

  • Todas as profundidades e modos de cores do Photoshop são convertidos em RGB de 8 bits.

Arrastar, abrir ou importar imagens do Photoshop no Fireworks

Cada imagem arrastada, aberta ou importada se torna um novo objeto de bitmap.

Observação:

No Windows, nomes de arquivo do Photoshop devem incluir uma extensão PSD para que o Fireworks reconheça o tipo de arquivo.

  1. Siga um destes procedimentos:

    • Arraste uma imagem ou arquivo do Photoshop até um documento aberto do Fireworks.

    • Selecione Arquivo > Abrir ou Arquivo > Importar e navegue até um arquivo do Photoshop (PSD).

  2. Clique em Open.

  3. Na caixa de diálogo exibida, defina opções de imagem e clique em OK.

  4. Se você tiver usado o comando Arquivo > Importar, será exibido um cursor com forma de L invertido. Na tela de desenho, clique no local em que deseja posicionar o canto superior esquerdo da imagem.

Opções de importação para arquivos do Photoshop

Quando você importa ou abre um arquivo do Photoshop no Fireworks, uma caixa de diálogo permite especificar como importar a imagem. As opções escolhidas determinam a aparência e a capacidade de edição dos arquivos importados.

  1. Especifique dimensões de imagem em pixels ou percentual e determine a resolução de pixels. Para manter a proporção atual entre largura e altura, selecione Restringir proporções.

  2. Se o arquivo do Photoshop tiver composições de camadas, selecione a versão da imagem a ser importada. Selecione Mostrar visualização para exibir uma visualização da composição selecionada. A caixa de texto Comentários exibe comentários do arquivo do Photoshop.

  3. No menu pop-up inferior, escolha como a imagem do Photoshop é aberta no Fireworks:

    Manter capacidade de edição de camadas sobre aparência

    Preserva a maior parte possível da estrutura de camadas e da capacidade de edição do texto, sem sacrificar a aparência da imagem. Se o arquivo incluir recursos não suportados pelo Fireworks, o Fireworks preservará a aparência do documento ao mesclar e rasterizar camadas. Estes são alguns exemplos:

    • Camadas CMYK, camadas de ajuste e camadas que usam uma opção de Supressão são mescladas com as camadas subjacentes.

    • Camadas que usam efeitos de camada não suportados podem ser mescladas, dependendo do modo de mesclagem da camada em questão e da presença de pixels transparentes.

    Manter aparência de camadas do Photoshop

    Nivela todos os objetos em cada camada do Photoshop e converte cada camada do Photoshop em um objeto de bitmap. Essa opção remove a capacidade de editar as camadas do Photoshop no Fireworks. Entretanto, grupos de camadas são mantidos.

    Usar preferências personalizadas

    Importa o arquivo usando as configurações personalizadas de conversão de arquivo que você especificar na caixa de diálogo Preferências. (Consulte Preferências de importação e abertura do Photoshop.)

    Nivelar camadas do Photoshop para uma única imagem

    Importa o arquivo do Photoshop como uma imagem nivelada, sem camadas. O arquivo convertido não mantém objetos individuais. A opacidade é mantida, mas não pode ser editada.

  4. Se você tiver usado o comando Arquivo > Importar, poderá selecionar as seguintes opções:

    Incluir camada de plano de fundo

    Importa objetos a partir da camada de plano de fundo da imagem.

    Importar para nova camada

    Importa a imagem em uma nova pasta de camada rotulada Importação do Photoshop.

  5. Se você tiver usado o comando Arquivo > Abrir ou tiver arrastado o arquivo do Photoshop até o Fireworks, poderá selecionar as seguintes opções:

    Incluir guias

    Mantém as guias do Photoshop em suas posições originais.

    Converter camadas em estados

    Insere cada grupo de camadas do Photoshop em seu próprio estado individual.

Sobre a importação de texto do Photoshop

Observação:

Para importar rapidamente um texto específico em um arquivo do Photoshop, copie-o diretamente no Fireworks. O texto copiado mantém todos os atributos de texto.

Quando você importa arquivos do Photoshop que contêm texto, o Fireworks verifica a existência das fontes necessárias no seu sistema. Se essas fontes não estiverem instaladas, o Fireworks solicitará a devida substituição ou manterá sua aparência.

Se o texto no arquivo do Photoshop tiver efeitos aplicados que são aceitos pelo Fireworks, esses efeitos serão aplicados ao Fireworks. Entretanto, como o Fireworks e o Photoshop aplicam efeitos de forma distinta, eles poderão parecer diferentes em cada aplicativo.

Quando arquivos do Photoshop 6 ou 7 contendo texto são abertos ou importados no Fireworks com a opção Manter aparência selecionada, uma imagem em cache do texto é exibida e, portanto, sua aparência permanece idêntica à do Photoshop. Após a edição do texto, a imagem em cache é substituída pelo texto real. A aparência do texto pode diferir do texto original. Entretanto, os dados de fontes originais são armazenados no arquivo PNG, possibilitando o uso das fontes originais em sistemas nas quais elas estão instaladas.

Observação:

O Fireworks não pode exportar texto no formato do Photoshop 6 ou 7. Se você editar um documento contendo texto do Photoshop 6 ou 7 e, em seguida, exportar esse documento de volta ao Photoshop, o arquivo será exportado no formato do Photoshop 5.5. Entretanto, se você não fizer alterações no texto, o arquivo será exportado no formato do Photoshop 6.

Import/Export Photoshop gradients

A qualidade do gradiente após a importação e exportação depende do tipo de gradiente. Também pode haver uma ligeira variação na cor e na opacidade dos gradientes.

Gradiente

Qualidade da importação

Linear

Praticamente perfeita.

Radial

Praticamente perfeita.

Refletido

Praticamente perfeita.

Losango

Correspondência aproximada (mapeada para forma retangular)

Ângulo

Correspondência aproximada (mapeada para forma cônica)

   

Gradiente

Qualidade da exportação

Linear

Praticamente perfeita.

Radial

Praticamente perfeita.

Barras

Praticamente perfeita.

Retangular

Correspondência aproximada (mapeada para diamante)

Cônica

Correspondência aproximada (mapeada para ângulo)

Elipse

Correspondência aproximada (mapeada para radial)

Ondulações

Correspondência aproximada (mapeada para radial)

Explosão

Correspondência imperfeita (mapeada para expansão de forma)

Contorno, suavização, ondas

Correspondência imperfeita (mapeada para linear)

Manter a aparência da camada de ajuste após a importação

Ao importar um arquivo PSD que contém uma camada de ajuste, a aparência das camadas individuais é mantida após a importação.

  1. Na caixa de diálogo Preferências, selecione Importação do Photoshop/Abrir.

  2. Selecione Manter aparência das camadas ajustadas.

Manter aparência das camadas ajustadas

Ao importar um arquivo PSD que contém uma camada de ajuste, a aparência das camadas individuais é mantida após a importação. Certifique-se de selecionar Configuração personalizada de preferências na caixa de diálogo.

Usar filtros e plug-ins do Photoshop

Você pode usar vários filtros e plug-ins do Photoshop e de terceiros, na janela Filtros em tempo real ou no menu Filtros.

Observação:

Há suporte para plug-ins e filtros do Photoshop 5.5 e versões anteriores. Plug-ins e filtros do Photoshop 6 ou posterior não são compatíveis com o Fireworks.

Ativar plug-ins do Photoshop usando a caixa de diálogo Preferências

  1. Escolha Editar > Preferências (Windows) ou Fireworks > Preferências (Mac OS).

  2. Clique na categoria Plug-ins.

  3. Selecione Plug-ins do Photoshop.

    É aberta a caixa de diálogo Selecionar uma pasta (Windows) ou Escolha uma pasta (Mac OS).

    Observação:

    Se a caixa de diálogo não abrir, clique em Procurar.

  4. Navegue até a pasta na qual os plug-ins e filtros do Photoshop ou de terceiros estão instalados e clique em Selecionar (Windows) ou Escolher (Mac OS).

  5. Clique em OK para fechar a caixa de diálogo Preferências.

  6. Reinicie o Fireworks.

Ativar plug-ins do Photoshop usando a janela Filtros em tempo real

  1. Selecione qualquer objeto de vetor, objeto de bitmap ou bloco de texto na tela de desenho e clique no ícone de adição (+) próximo ao rótulo Filtros no Inspetor de propriedades.

  2. Selecione Opções > Localizar plug-ins, no menu pop-up.

  3. Navegue até a pasta na qual os plug-ins e filtros do Photoshop ou de terceiros estão instalados e clique em Selecionar (Windows) ou Escolher (Mac OS). Se aparecer uma mensagem perguntando se você reiniciar o Fireworks, clique em OK.

  4. Reinicie o Fireworks para carregar os filtros e os plug-ins.

    Observação:

    Como alternativa, você pode instalar plug-ins diretamente na pasta Plug-ins do Fireworks.

Inserir gráficos do Fireworks no Photoshop

O Fireworks oferece amplo suporte para a exportação de arquivos no formato do Photoshop (PSD). Uma imagem do Fireworks exportada para o Photoshop mantém a mesma capacidade de edição, quando reaberta no Fireworks, que os outros gráficos do Photoshop. Os usuários do Photoshop podem trabalhar com gráficos no Fireworks e continuar a edição no Photoshop.

Observação:

É possível usar a extensão Salvar como PSD para exportar rapidamente as páginas e os estados de seu documento do Fireworks como arquivos PSD separados. Essa extensão está disponível em http://www.adobe.com/go/learn_fw_psdsave_br

Exportar um arquivo no formato do Photoshop

  1. Selecione Arquivo > Salvar como.

  2. Nomeie o arquivo e escolha Photoshop PSD no menu Salvar como.

  3. Para especificar configurações de exportação predefinidas para objetos, efeitos e texto, clique em Opções. Em seguida, no menu Configurações, escolha uma das predefinições a seguir.

    Manter capacidade de edição sobre aparência

    Converte objetos em camadas, mantém os efeitos editáveis e converte o texto em camadas de texto editáveis do Photoshop. Selecione essa opção se você planeja editar a imagem extensivamente no Photoshop e não precisa preservar a aparência exata da imagem do Fireworks.

    Manter aparência do Fireworks

    Converte cada objeto em uma camada individual do Photoshop, e os efeitos e o texto se tornam não editáveis. Selecione essa opção se quiser manter o controle sobre objetos do Fireworks no Photoshop, mas também quiser manter a aparência original da imagem do Fireworks.

    Arquivo do Photoshop menor

    Nivela cada camada em uma imagem totalmente renderizada. Selecione essa opção se você estiver exportando um arquivo que contém muitos objetos do Fireworks.

    Personalizada

    Permite escolher configurações específicas para objetos, efeitos e texto.

  4. Clique em Salvar para exportar o arquivo do Photoshop.

    Observação:

    O Photoshop 5.5 e versões anteriores não podem abrir arquivos com mais de 100 camadas. Será necessário excluir ou mesclar objetos se o documento do Fireworks que você está exportando tiver mais de 100 objetos.

Personalizar configurações de exportação do Photoshop

  1. Na caixa de diálogo Salvar como, selecione Photoshop PSD para o tipo de arquivo e clique em Opções.

  2. No menu pop-up Configurações, escolha Personalizada.

  3. No menu pop-up Objetos, escolha uma destas opções:

    Converter em camadas do Photoshop

    Converte objetos individuais do Fireworks em camadas do Photoshop e converte máscaras do Fireworks em máscaras de camada do Photoshop.

    Nivelar cada camada do Fireworks

    Nivela todos os objetos em cada camada individual do Fireworks, e cada camada do Fireworks se torna uma camada no Photoshop. Escolher essa opção faz com que se perca a capacidade de editar objetos do Fireworks no Photoshop. Você também perde recursos, como modos de mesclagem, que estão associados aos objetos do Fireworks.

  4. No menu pop-up Efeitos, escolha uma destas opções:

    Manter capacidade de edição

    Converte Filtros em tempo real do Fireworks em seus equivalentes no Photoshop. Se os efeitos não existirem no Photoshop, eles serão descartados.

    Renderizar efeitos

    Nivela efeitos em seus objetos. Escolher essa opção faz com que se preserve a aparência dos efeitos, embora eles não possam ser editados no Photoshop.

  5. No menu pop-up Texto, escolha uma destas opções:

    Manter capacidade de edição

    Converte texto em uma camada editável do Photoshop. A formatação de texto não suportada pelo Photoshop é perdida.

    Renderizar texto

    Transforma o texto em um objeto de imagem. Escolher essa opção faz com que se preserve a aparência do texto, embora ele não possa ser editado.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online