1. Select File > Record New Software Simulation. The recording window appears.

  2. Click Screen Area or Application.

    Application

    Select this option if you want to specify the application which you want to record as part of your project. In the Select Application menu, select the application that you want to record and select one of the following:

    Custom Size Select this option if you want to customize the dimensions of the recorded project. You can choose from a list of standard sizes, or define a custom size. The selected application is automatically resized to fit inside the boundaries of the recording area. Best practice is to have a clear idea of the dimensions of the project before you start recording it.

    Application Window Select this option if you want to record the entire application window. The dimensions of the application are not altered. The recording rectangle is resized to fit the application.

    Application Region Select this option if you want to record defined areas in an application. For example, if you are recording a window that has three frames, the recording window snaps to individual frames when the mouse moves over them. The dimensions of the application are not altered. The recording rectangle is resized to fit the defined area in the application.

    Screen Area

    Select this option when you want to capture all events that occur within an area on the screen.

    Custom Size Select this option if you want to record your project using a specific dimension. You can choose from a list of standard sizes, or create your own custom size window.

    Full Screen Select this option if you want to set the size of the recording window to the size of your monitor screen. The entire computer screen is treated as the recording window. If you work on dual monitors, you can choose the monitor that you want to use for recording. Recording in this mode can potentially produce large projects and output file sizes due to the large screen resolution on monitors.

  3. Click Automatic or Manual in the Recording Type area. For more information, see Automatic recording, and Manual recording.

  4. Choose the appropriate recording mode from the following:

    • Demo
    • Assessment
    • Training
    • Custom
    Recording modes
    Recording modes

    Demo: If you want to demonstrate a procedure or feature, choose the Demo mode. This can be produced as a video, where user interaction may not be possible. In the Demo mode, Captivate adds text captions using labels. This mode is ideal if you want to show a quick software concept to someone, but you don’t expect the person to follow along and actually perform the steps being demonstrated. 

    Assessment: This mode is used to test your learner's understanding of the procedure being demonstrated. You can set scores and the number of attempts of a user in this mode. When you choose this mode, Captivate adds click boxes and text entry boxes on each mouse click.

    The Assessment mode includes Click Boxes (to make the lesson interactive) and Failure Captions (to help the user who clicks in the wrong place or performs the wrong step) by default. This mode is ideal when teamed with a Demonstration.

    Training: This mode involves the learners' simulations. The learners try the steps of the procedure shown in the simulation, and then move to the next slide. If you record a slide in the Training Mode, Captivate adds click boxes based on the mouse clicks, generates text entry boxes, and also provides failure and hint captions to each one.

    Custom: Use this mode if you need a combination of features available in other modes. In this mode, Captivate does not add any object by default.

  5. Do one or all the following:

    • Select a panning mode if you want the recording window to follow your movements across the screen. For more information, see Panning.

    • If you are adding commentary during recording, select the type of audio input.

    • To change the default settings that Adobe Captivate uses when recording, click Settings at the bottom of the recording options. For more information on customizing recording preferences, see Set recording preferences.

  6. Click Record.

  7. If you have selected Manual recording, press Print Screen (Windows) or Command+F6 (Mac) every time you want to take a screenshot during the procedure.

  8. Press End key (in Windows) or Cmd + Enter (Mac OS) when you have completed recording.

    Set the shortcut keys for starting and ending a recording (Edit > Preferences > Keys (Global)).

    Note:

    Alternatively, on Windows, click the task icon or the system tray icon to stop recording. On Mac, click the dock icon or the status bar icon.

    Recording keys
    Recording keys

The recorded slides are now inserted in a new Adobe Captivate project.

You can resize Adobe Captivate projects, even after you have recorded them. Resizing can save you from having to re-record an entire project. For example, suppose you record your project at a width of 640 and height of 480, but then decided you need a slightly smaller or larger size.

For more information, see Resizing projects.

Note:

Gestures like Swipe Right, Left, Up, or Down are disabled for auto responsive simulation.

Edit length of a slide after recording

By default, a Captivate demo recording creates a video demo for drag and drop and mouse wheel actions.

If a video has been recorded as a video demo, it will show as a red line strike through in the timeline of that slide. The video demo duration can be increased but cannot be decreased.

For more information, see Captivate mouse actions.

Record additional slides for existing projects

  1. Open the project in which you want to record additional slides.

  2. Click Slides > Software Simulation or Video Demo.

    Record additional slides
    Record additional slides

  3. In the Record Additional Slides dialog box, select the slide after which you want the recorded slides to be inserted and click OK.

    The recording window appears.

  4. Set the recording options and click Record.

    Note:

    You can record a video as an additional slide by selecting Video Demo in the recording options.

The newly recorded slides are inserted into your project after the slide you selected.

You can also add slides by importing them from other Adobe Captivate projects or PowerPoint presentations.

Creating responsive simulations

In earlier versions of Captivate, simulations were limited to 1280 px. In the 2017 release of Adobe Captivate, you can record simulations in full HD 2k or 4k resolutions.

To record simulations in 2k:

  1. Create a responsive project (File > New Project > Responsive Project or press Ctrl+H).

  2. On the toolbar, click Modify > Rescale project.

  3. In the Rescale Project dialog, change the width to 2048 pixels and height to 1080 pixels.

    Rescale Project
    Rescale Project

  4. Add a software simulation slide and start recording.

  5. Once you finish recording, you can see a blue rectangle on your simulation slides.

    The rectangular focus area represents the minimum supported device size, pan to the entire slide on the device to see the remainder of the screen.

    Minimum visible area
    Minimum visible area

  6. To preview the visible area on the slide in different devices, choose any device from the Preview in drop-down list.

    For example, the visible area in an iPhone 7 Plus is shown below. The area in white is what you can see in the device. Pan to the slide to view the area outside the area in white.

    iPhone 7 Plus visible area
    iPhone 7 Plus visible area

Mark slides to revisit after recording

Sometimes, while recording simulations, you may click an option that you initially did not plan for. This action can result in unwanted slides in your recorded project. To locate such unwanted screen captures later after recording the entire project can be an arduous task, especially if you have many slides.

To locate the slides you want to delete or revisit in a recorded project, press Ctrl + Shift + Z while recording. For example, if you click an option on the screen and realized that it was a wrong action during recording, press Ctrl + Shift + Z.

The slide that corresponds to the action is marked with an Undo marker and is hidden in the project.

Slide with the ‘Undo’ marker
Slide with the ‘Undo’ marker

The Undo marker is basically a transparent text caption on the slide. If you want to retain the slide, select the caption, and press Delete. Also, right-click the slide, and click Show Slide to unhide the slide.

Note:

Note: You can change the keyboard shortcut for the undo marker in Preferences (Edit > Preferences > Recording > Keys (Global)).

To edit the slide, right-click on the slide in the Filmstrip and click Show slide. To delete the marker, click it and press Delete.

Recording tips

The following tips and tricks can help you create Adobe Captivate projects quickly and easily, while also giving you professional, high-quality results:

Use automatic recording as far as possible

Even for projects that need a few manually generated screenshots, consider automatic recording. Set the autorecord option, but press Print Screen (Windows) or Command+F6 (Mac) whenever you want to take an extra screenshot. This method is effective if you are recording a website that contains many pop-ups, frames, and special effects. Adobe Captivate plays a camera shutter sound each time a screenshot is automatically captured. To generate a screenshot at a place where you do not hear the sound, press Print Screen to manually take a screenshot.

For example, if you are recording Microsoft Internet Explorer, there can be dynamic HTML or Flash menus that appear only when the mouse rolls over them. Adobe Captivate does not automatically capture the change that occurs on mouse rollover. Press Print Screen to manually capture the change.

Go slowly when recording, particularly when recording websites in Internet Explorer

Perform actions more slowly than you would normally during recording. It is especially important to go slowly when capturing actions on a website in Internet Explorer. If you are manually recording, ensure that each web page is loaded before capturing a screenshot.

Wait for the camera shutter sound

During autorecording, wait for the shutter sound before performing another action.

If you are manually recording, Adobe Captivate captures screenshots each time you press a designated key or key combination. The default capture key is the Print Screen key. Each time you want to capture a screenshot, press the Print Screen key; you'll hear the camera shutter sound.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy