了解如何在 Adobe XD 中为对象设置描边、填充和投影并创建混合效果。

将填充颜色应用于对象

  1. 选择对象。

  2. 单击“填充”旁边的矩形。此时会出现“拾色器”。

    拾色器
    拾色器

    注意:

    您还可以使用滴管工具来填充颜色。[ i ] 键可激活“填充”滴管。

    • 单击该键一次将会打开“填充”滴管。
    • 再次单击该键将会关闭“填充”滴管。

  3. 您可以选择:

    • 如果您知道准确的颜色值,请指定 HSBA、RGB 或十六进制值。您也可以在不同的颜色模式之间进行切换。
    • 使用颜色字段和颜色滑块调整颜色。执行此操作时,HSBA、RGB 和十六进制的数字值会相应地进行调整。  
    • 您可以使用颜色滑块或通过指定一个百分比值来设置填充及其不透明度。
    • 使用“滴管”工具从画板中选择颜色。
    • 您也可以将渐变填充应用于对象。如需更多有关渐变的信息,请参阅创建和修改渐变

    修改拾色器中的选项时,您可以预览画板上的更改。

    注意:

    Adobe XD 还支持十六进制代码的简略形式。例如,如果输入 0 并按 Return 键,则 XD 将自动显示代码为 #000000 的颜色。

  4. 您可以将颜色保存为色板,以供将来使用。如需将颜色保存为色板,请单击“拾色器”底部的 + 图标。

    添加色板
    添加色板

    您可以通过将色板拖到新位置来重新排列拾色器中的色板。如需删除色板,请将其拖出拾色器。

将图像填充应用于对象

首先,启用填充(如果尚未启用)(如将填充颜色应用于对象中所述)。然后,将图像从其保存位置(例如,Finder 或 Windows 资源管理器)拖动到对象上。

裁切和放置图像填充

现在,您可以通过双击放置在容器中的图像(“对象”>“使用形状遮盖”)来裁切图像并调整图像填充中图像的位置(从桌面拖动时)。使用图像填充中的裁切模式可以:

  •      双击并进入图像填充的裁剪模式
  •      在裁剪模式下调整图像的位置,或
  •      在裁剪模式下将图像移动到任意位置

此增强功能也适用于从 Photoshop 和 Sketch 导入的文件。导入的文件会保留图像填充和在源应用程序中执行的裁切。

从剪贴板粘贴图像

您还可以从 Adobe XD 之外将图像复制到操作系统的剪贴板中,选择一个形状,并从操作系统剪贴板中将图像作为图像填充进行粘贴。用户也可以通过在选择形状后,选择“文件”>“导入”,来使用图像填充形状。

创建描边并指定描边颜色

  1. 选择对象。

  2. 默认描边宽度为 1。如需指定其他值,请更改“边框”值。

  3. 单击“边框”旁边的矩形色卡。此时会出现“拾色器”。

    拾色器
    拾色器
  4. 您可以选择:

    • 如果您知道准确的值,请指定 HSBA、RGB 或十六进制值。
    • 使用颜色字段和颜色滑块调整颜色。执行此操作时,HSBA、RGB 和十六进制的数字值会相应地进行调整。  
    • 使用“滴管”工具从画板中选择颜色。
    • 使用颜色滑块或通过输入一个百分比值来设置边框的不透明度。
    • 编辑边框大小和创建点线
    • 指定端点(平头、圆头、方头)和连接(斜接、圆角、斜面),以及内部描边和外部描边。

    修改拾色器中的选项时,您可以预览对象上的描边颜色。

  5. 您可以将颜色保存为色板,以供将来使用。如需将颜色保存为色板,请单击“拾色器”底部的 + 图标。

    添加色板
    添加色板

    您可以通过将色板拖到新位置来重新排列拾色器中的色板。如需删除色板,请将它拖离拾色器。

  6. 如果对象是闭合路径,则您可以指定描边宽度。如需沿路径对齐描边,请选择下一个插图所列的以下选项之一:

    默认情况下,XD 会使闭合路径中的内部描边对齐。

    笔触样式
    笔触样式

    A. 内部描边 B. 外部描边 C. 中心描边 D. 平头端点 E. 圆头端点 F. 方头端点 G. 斜接连接 H. 圆角连接 I. 斜面连接 

    注意:

    更改描边宽度或描边对齐方式并不会更改对象的实际大小(从定界框的角度来说)。不过,当您导出对象时,对象的测量值可能会根据所使用的描边的类型发生变化。

    SVG 仅支持中心描边。如果您将具有内部描边或外部描边的对象导出为 SVG,则导出的图像的大小看上去就好像它具有中心描边。

创建投影

  1. 选择对象。

  2. 如需为阴影选择颜色,请单击“属性检查器”中的“阴影”。此时会出现“拾色器”。

    您可以选择:

    • 如果您知道准确的值,请指定 HSBA、RGB 或十六进制值。您也可以在不同的颜色模式之间轻松切换。
    • 使用颜色字段和颜色滑块调整颜色。执行此操作时,HSBA、RGB 和十六进制的数字值会相应地进行调整。  
    • 使用“滴管”工具从画板中选择颜色。
    • 使用颜色滑块或通过输入一个百分比值来设置阴影的不透明度。
  3. 指定以下选项:

    X 偏移和 Y 偏移

    指定您希望投影从对象处偏离的距离。

    B

    (模糊) 指定到要进行模糊处理的阴影边缘的距离。

    指定到要进行模糊处理的阴影边缘的距离。Illustrator 会通过创建一个透明光栅对象来模拟模糊效果。
    指定到要进行模糊处理的阴影边缘的距离。Illustrator 会通过创建一个透明光栅对象来模拟模糊效果。
    指定到要进行模糊处理的阴影边缘的距离。Illustrator 会通过创建一个透明光栅对象来模拟模糊效果。
    指定到要进行模糊处理的阴影边缘的距离。Illustrator 会通过创建一个透明光栅对象来模拟模糊效果。

    如需保存色板,请单击拾色器底部的 + 图标。您可以通过将色板拖到新位置来重新排列拾色器中的色板。如需删除色板,请将它拖离拾色器。

应用混合效果

在设计画布上选择图像或对象(包括形状、文本图层、组、蒙版或组件)。从“属性检查器”中,选择并应用所选的混合模式。有关更多信息,请参阅应用混合效果。

从对象中删除填充、阴影或描边

选择对象。然后,单击“属性检查器”中的“边框”“填充”“阴影”旁边的复选框。如果您想恢复填充、描边或阴影,请再次单击复选框。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略