Importer des fichiers SVG

Dernière mise à jour le 21 sept. 2026

Découvrez comment importer des fichiers SVG en tant que calques de forme natifs et modifiables, prêts à être animés sans nécessiter de conversion.

Double-cliquez dans le panneau Projet ou utilisez Fichier > Import > Fichier pour parcourir et importer le fichier SVG.

Annotation

La dernière version d’After Effects vous permet d’importer le fichier en tant que métrage ou composition.

Glissez-déposez le fichier SVG importé dans le panneau Montage.

Sélectionnez le calque pour utiliser la section Contenu du calque dans le panneau Propriétés pour afficher la structure du SVG.

Le panneau Propriétés est ouvert et les contenus SVG sont listés sous le Contenu du calque.
Utilisez le panneau Propriétés pour afficher le contenu du fichier SVG et ajuster ses propriétés.

Vous pouvez également sélectionner la flèche à côté du calque pour le développer, puis afficher la section Contenu. Vous pouvez voir tous les éléments individuels et leurs propriétés, telles que Tracé, Fond et Transformation.

Le calque avec le fichier SVG est sélectionné, et la section Contenu est développée pour afficher ses propriétés, y compris Tracé, Fond et Transformation.
Développez la section Contenu du calque SVG pour accéder à ses propriétés et les modifier, incluant Tracé, Fond et Transformation.

Vous pouvez utiliser ces propriétés pour l’animer comme n’importe quel autre calque de forme. Par exemple :

  • Animez le Tracé pour créer des effets de morphing.
  • Modifiez la couleur de fond au fil du temps pour obtenir des transitions dynamiques.
  • Utilisez les propriétés de Transformation pour redimensionner, faire pivoter ou déplacer les éléments de manière indépendante.

Si les calques possèdent des fonds et des contours en dégradé, vous pouvez utiliser les propriétés Échelle et Rotation pour animer le dégradé.

Un des calques avec un élément en dégradé est sélectionné, et Fond en dégradé 1 est mis en surbrillance.
Utilisez les propriétés de fond en dégradé pour ajuster le dégradé ou l’animer.

Importer un fichier SVG en tant qu’enregistrement ou composition

L’import SVG dans After Effects offre une bonne flexibilité et un meilleur contrôle sur la façon dont les fichiers SVG sont importés dans votre projet. Avec la dernière version, lorsque vous importez un fichier SVG, vous pouvez choisir de l’importer sous forme de métrage ou de composition.

Importer sous forme de métrage

Importer sous forme de composition

Importe le fichier SVG sous forme de calque vectoriel unique, rastérisable en continu.

Importe le fichier SVG sous forme de composition constituée de calques de forme modifiables.

Maintient une connexion au fichier SVG externe.

Chaque élément est converti en sa propre forme modifiable.

Idéal pour les images vectorielles à calque unique lorsque vous n’avez pas besoin de diviser l’illustration en parties.

Idéal pour modifier les tracés, formes et détails de calque lorsque vous devez animer des éléments individuels.

Vous pouvez contrôler l’approche d’import utilisée par défaut lors de l’import de fichiers SVG en définissant l’option Faire glisser plusieurs éléments de fichier en tant que sous les préférences d’import.

  • macOS : After Effects > Paramètres > Import > Faire glisser plusieurs éléments de fichier en tant que
  • Windows : Édition > Préférences > Import > Faire glisser plusieurs éléments de fichier en tant que
La boîte de dialogue Préférences est ouverte. Dans l’onglet Import, le menu déroulant Faire glisser plusieurs éléments de fichier en tant que est ouvert, offrant des options pour sélectionner la méthode d’import.
Définissez la préférence par défaut pour importer un fichier SVG, en choisissant s’il est importé sous forme de métrage ou de composition.

Double-cliquez dans le panneau Projet ou utilisez Fichier > Import > Fichier pour parcourir et importer le fichier SVG.

Utilisez le menu déroulant Importer en tant que dans la boîte de dialogue Importer un fichier pour sélectionner l’une des options suivantes :

  • Métrage
  • Composition – Conserver les tailles de calque

Choisir Métrage importe le fichier comme un seul calque aplati sans accès aux éléments individuels, ce qui le rend adapté à un usage statique ou lorsqu’aucune animation n’est requise. Sélectionner Composition - Conserver les tailles de calque crée une nouvelle composition où chaque calque source est importé séparément, dimensionné selon son contenu réel, rendant les points d’ancrage plus nets et les transformations plus faciles pour l’animation.

macOS

La boîte de dialogue Importer un fichier est ouverte et il y a des options pour importer le fichier sous forme de métrage ou de composition.

Windows

La boîte de dialogue Importer un fichier est ouverte et il y a des options pour importer le fichier sous forme de métrage ou de composition.

Sélectionnez les options suivantes si applicable :

  • Créer une composition : crée une composition en utilisant les paramètres par défaut et place automatiquement le fichier SVG importé, soit comme enregistrement soit comme composition avec des calques de forme, dans le montage, vous évitant ainsi de devoir créer manuellement une composition et de faire glisser le fichier SVG dedans.
  • Séquence de graphiques vectoriels évolutifs : importe plusieurs fichiers SVG numérotés et les traite comme une séquence d’images vectorielles, image par image.

Si vous avez importé le fichier SVG en tant que composition, utilisez la section Contenu du calque dans le panneau Propriétés ou la section Contenu du calque dans la chronologie pour afficher les éléments individuels et leurs propriétés et travailler avec eux.S’il est importé en tant qu’enregistrement, il se comporte comme un calque ordinaire et peut être ajusté en utilisant les propriétés de transformation standard.

Comme pour les fichiers Illustrator, si le fichier vectoriel est importé en tant qu'enregistrement, vous pouvez sélectionner le calque dans le montage, puis faire un clic droit et sélectionner Créer > Créer des formes à partir du calque vectoriel pour le convertir en calques de forme modifiables, vous permettant d'animer des tracés, contours et remplissages individuels.Dans la dernière version bêta d'After Effects, le texte du fichier source est converti en calques de texte modifiables qui préservent la police, la taille, le remplissage, la position, les styles, les traits et les paramètres de police variable. 

Lorsque vous importez un fichier SVG en tant qu’enregistrement, After Effects conserve un lien actif vers le fichier d’origine. Ainsi, toute modification que vous apportez à ce fichier SVG en dehors de l’application est automatiquement actualisée dans votre projet.

Convertir le texte Illustrator en calques de texte modifiables

Utiliser les nouvelles fonctionnalités de la version bêta

Le texte modifiable des fichiers Illustrator est maintenant disponible pour les tests et les commentaires.Essayez-la maintenant dans After Effects (version bêta).

Dans la dernière version bêta d'After Effects, lorsqu'un calque Illustrator est importé en tant qu'enregistrement, tout texte du fichier source est converti en son propre calque de texte modifiable au lieu d'être aplati en contours de forme.Cela signifie que la police, la taille, le remplissage, la position, les styles (tels que gras et italique), les traits et les paramètres de police variable sont tous conservés, ce qui vous permet de continuer à modifier le texte directement dans After Effects au lieu de le recréer à partir de zéro ou de retourner dans Illustrator pour apporter des modifications.

Sélectionnez Fichier > Importer > Fichier, puis le fichier Illustrator à importer.

Dans la boîte de dialogue Importer un fichier, assurez-vous que Importer en tant que est défini sur Métrage lors de la sélection du fichier à importer.

Dans la boîte de dialogue d'Importation, vérifiez que Type d'importation est défini sur Métrage et sélectionnez les Options de calque selon ce que vous souhaitez importer du fichier Illustrator.

Glissez le fichier importé dans le panneau Montage.

Faites un clic droit sur le calque Illustrator et sélectionnez Créer > Créer des formes et du texte à partir d'un calque vectoriel, ou utilisez Calque > Créer > Créer des formes et du texte à partir d'un calque vectoriel.

Menu Calque > Créer avec Créer des formes et du texte à partir du calque vectoriel en surbrillance, convertissant le texte vectoriel en calques de texte modifiables.
Sélectionnez Créer des formes et du texte à partir du calque vectoriel pour convertir le texte Illustrator en calques de texte After Effects modifiables au lieu de formes.

Le texte est converti en calque de texte modifiable qui correspond étroitement à la police, la taille, le remplissage et la position du fichier d'origine.Vous pouvez ensuite modifier et ajuster le texte directement dans After Effects.

Calque de texte Luminosité sur un graphique de flamme, avec le panneau Caractère affichant la police Adobe Clean Italique, taille 74 px et Remplissage activé.
Après conversion, le texte reste entièrement modifiable — la police, le style, la taille et le remplissage peuvent encore être modifiés dans le panneau Caractère.

Annotation

Le texte avec trait uniquement est toujours converti sous forme de chemins d'accès plutôt qu'en calque de texte modifiable. 

Le contenu vectoriel non textuel est toujours converti en calques de forme comme avant, et si le fichier Illustrator contient les deux, vous obtiendrez un mélange de calques de texte et de forme.

Rejoignez la conversation dans notre communauté After Effects (Beta) à propos de la prise en charge du texte modifiable des fichiers Illustrator.

Copier et collez le contenu illustrator et SVG

Le contenu SVG du presse-papiers peut maintenant être collé dans After Effects en utilisant Édition > Coller. Le contenu est importé sous forme de calques de forme natifs et modifiables, prêts à animer, sans étape d'import intermédiaire requise.

Copier du contenu à partir d'Illustrator

Ouvrez votre illustration dans Adobe Illustrator.

Vérifiez que la préférence Inclure le code SVG est sélectionnée.

  • macOs : Sélectionnez Illustrator > Paramètres > Gestion du presse-papiers et sélectionnez Inclure le symbole SVG.
  • Windows : Sélectionnez Édition > Préférences > Gestion du presse-papiers et sélectionnez Inclure le code SVG.
La boîte de dialogue Préférences est ouverte dans Illustrator et l'option Inclure le code SVG est sélectionnée.
Activez Inclure le code SVG pour conserver votre illustration modifiable et de haute qualité dans les autres applications Adobe.

Sélectionnez l'illustration vers laquelle vous souhaitez copier.

Conseil

Convertissez tout texte SVG en courbes avant de copier, car le texte SVG n'est pas pris en charge lors du collage.

Choisissez Édition > Copier.

Basculez vers After Effects et effectuez l'une des opérations suivantes selon l'état de votre projet :

  • Si aucun projet n'est ouvert, sélectionnez Édition > Coller pour créer un nouveau projet avec une composition contenant le contenu SVG comme calque de forme.
  • Si un projet est ouvert mais qu'aucune composition n'est sélectionnée, sélectionnez Édition > Coller pour créer une nouvelle composition dans le projet actuel contenant le contenu collé.
L'option Édition > Coller est sélectionnée, et le contenu est importé en tant que calques de forme natifs et modifiables prêts à animer.
Édition > Coller importe le contenu sous forme de calques de forme modifiables, prêts pour l'animation.

Si une composition est sélectionnée dans After Effects, sélectionnez Édition > Coller pour ajouter le contenu SVG comme nouveau calque de forme dans cette composition.

Coller du SVG depuis d'autres applications

Le contenu SVG copié depuis toute appli qui écrit du SVG dans le presse-papiers système peut être collé en utilisant le même processus Édition > Coller. La prise en charge dépend du fait que l'application source place des données SVG valides dans le presse-papiers.