Dopo averlo ottimizzato, è possibile esportare l’elemento grafico o il documento, oppure salvarlo, a seconda del tipo di file originale.

È possibile esportare o, in alcuni casi, salvare i documenti come immagine singola in formato GIF, JPEG o in un altro formato grafico. È inoltre possibile esportare l’intero documento come file HTML e relativi file immagine associati, solo le porzioni selezionate o un’area specificata. Inoltre, si possono esportare gli stati e i livelli di Fireworks come file di immagini separati.

La posizione predefinita in cui Fireworks esporta i file viene stabilita in base ai seguenti elementi, nell’ordine:

  1. La preferenza di esportazione corrente del documento, che è impostata se in passato il documento è stato esportato e poi salvato nel formato PNG

  2. La posizione di esportazione o salvataggio corrente, che viene impostata ogni volta che ci si sposta dalla posizione predefinita offerta nelle finestre di dialogo Salva, Salva con nome o Esporta

  3. La posizione del file corrente

  4. La posizione predefinita in cui vengono salvati i nuovi documenti o le nuove immagini nel sistema operativo in uso

    La posizione predefinita in cui Fireworks salva i documenti viene invece stabilita con criteri diversi. Per ulteriori informazioni, consultate Salvataggio dei file di Fireworks.

Esportare pagine come file di immagine

  1. Selezionate File > Esporta.

  2. Scegliete la posizione per i file da esportare.

  3. Effettuate una delle seguenti operazioni:

    • Nel menu a comparsa Esporta, selezionate Solo immagini, quindi selezionate o deselezionate la casella di controllo Solo pagina corrente. Le pagine vengono esportate con il formato immagine impostato nel pannello Ottimizza.

    • Nel menu a comparsa Esporta, selezionate Pagine in file, quindi selezionate Immagini dal menu a comparsa Esporta come. Le pagine vengono esportate con il formato immagine impostato nel pannello Ottimizza.

    • Selezionate Pagine in file dal menu a comparsa Esporta e selezionate PNG Fireworks dal menu a comparsa Esporta come. Ogni pagina viene esportata come file PNG separato, compatibile con Fireworks 8.

    Nota:

    Per esportare tutte le pagine nel formato selezionato, selezionate tutte le pagine e ottimizzate le impostazioni.

Esportare un’immagine singola

Se si lavora con un’immagine esistente aperta in Fireworks, è possibile salvarla invece che esportarla. Per ulteriori informazioni, consultate Salvare documenti in altri formati.

Nota:

Per esportare solo immagini specifiche da un documento, occorre prima suddividerlo in porzioni e poi esportare solo le porzioni desiderate.

  1. Nel pannello Ottimizza, selezionate un formato file e impostate le opzioni specifiche per il formato.

  2. Selezionate File > Esporta.

  3. Scegliete la posizione di esportazione del file.

    Per gli elementi grafici per il Web, la migliore posizione è una cartella nel proprio sito Web.

  4. Immettete un nome file privo di estensione. L’estensione viene aggiunta durante l’esportazione in base al tipo di file.

  5. Nel menu a comparsa Esporta, selezionate Solo immagini.

  6. Fate clic su Salva.

Esportare un documento suddiviso in porzioni

Per impostazione predefinita, quando si esporta un documento di Fireworks suddiviso in porzioni, questo viene esportato come file HTML con le immagini associate. Il file HTML esportato può essere visualizzato in un browser o importato in altre applicazioni per ulteriori modifiche.

Prima dell’esportazione, accertatevi di avere selezionato lo stile HTML appropriato nella finestra di dialogo Impostazioni HTML. Consultare Impostare le opzioni di esportazione HTML.

Esportare tutte le porzioni

  1. Selezionate File > Esporta.

  2. Accedete alla cartella sul disco rigido in cui effettuare l’esportazione.

  3. Nel menu a comparsa Esporta, selezionate HTML e immagini.

  4. Digitate un nome file nella casella Nome file (Windows) o Salva con nome (Mac OS).

  5. Nel menu a comparsa HTML, selezionate Esporta file HTML.

  6. Nel menu a comparsa Porzioni, selezionate Esporta porzioni.

  7. (Facoltativo) Selezionate Inserisci immagine nella sottocartella.

  8. Fate clic su Salva.

Esportare le porzioni selezionate

  1. Fate clic tenendo contemporaneamente premuto il tasto Maiusc per selezionare più porzioni.

  2. Selezionate File > Esporta.

  3. Selezionate la posizione in cui memorizzare i file esportati, ad esempio una cartella nel proprio sito Web.

  4. Nel menu a comparsa Esporta, selezionate HTML e immagini.

  5. Immettete un nome file privo di estensione. L’estensione viene aggiunta durante l’esportazione in base al tipo di file.

    Se si esportano più porzioni, Fireworks usa il nome immesso come nome principale per tutte le immagini esportate, escluse quelle alle quali sono stati assegnati nomi personalizzati utilizzando il pannello Livelli o la finestra di ispezione Proprietà.

  6. Nel menu a comparsa Porzioni, selezionate Esporta porzioni.

  7. Per esportare solo le porzioni selezionate prima dell’esportazione, scegliete Solo porzioni selezionate e accertatevi che non sia selezionata l’opzione Includi aree senza porzioni.

  8. Fate clic su Salva.

Aggiornare una porzione

Se è stato già esportato un documento suddiviso in porzioni e successivamente sono state apportate modifiche al documento originale di Fireworks, è possibile aggiornare solo l’immagine o porzione modificata. Per semplificare l’individuazione della porzione di ricambio, assegnate alle porzioni nomi personalizzati.

  1. Nascondete la porzione e modificate l’area sottostante.

  2. Visualizzate di nuovo la porzione.

  3. Fate clic con il pulsante destro del mouse (Windows) o tenete premuto il tasto Ctrl (Mac OS) e scegliete Esporta porzione selezionata.

  4. Selezionate la stessa cartella della porzione originale con lo stesso nome di base e fate clic su Salva.

  5. Fate clic su OK quando il sistema richiede se sostituire il file esistente.

    Nota:

    evitate di ridimensionare la porzione oltre le sue dimensioni di esportazione originali in Fireworks, altrimenti si potrebbero produrre risultati imprevisti nel documento HTML una volta aggiornata la porzione.

Esportare un’animazione

Una volta creata e ottimizzata, l’animazione è pronta per l’esportazione. Un’animazione può essere esportata in uno dei seguenti formati:

GIF animate

Offrono i migliori risultati per le clipart e le immagini di qualità affini ai cartoni animati.

Flash SWF o Fireworks PNG (non è necessaria l’esportazione)

Esporta un’animazione come file SWF da importare in Flash. In alternativa, salta la procedura di esportazione importando un file sorgente PNG di Fireworks direttamente in Flash. Questo metodo diretto consente di importare tutti i livelli e gli stati dell’animazione per poi apportarvi ulteriori modifiche in Flash. Consultate Operazioni con Flash.

File multipli

L’esportazione di livelli o stati di animazione come file multipli risulta utile quando si hanno più simboli su diversi livelli per lo stesso oggetto. Ad esempio, si può esportare un banner pubblicitario su più file se ogni lettera del nome di una società viene animata in un singolo elemento grafico. Consultate Esportare gli stati o i livelli come file multipli.

Se il documento contiene più di un’animazione, è possibile inserire le porzioni su ogni animazione per esportare ognuna con impostazioni di animazione diverse, come ripetizione continua e ritardo stati.

Esportare un’immagine GIF animata

  1. Scegliete Seleziona > Deseleziona per deselezionare tutte le porzioni e gli oggetti, quindi selezionate GIF animata come formato nel pannello Ottimizza.

  2. Selezionate File > Esporta.

  3. Immettete un nome per il file e selezionate la destinazione.

  4. Fate clic su Salva.

Esportare più immagini GIF animate con diverse impostazioni di animazione

  1. Fate clic tenendo contemporaneamente premuto il tasto Maiusc sulle animazioni per selezionarle tutte.

  2. Selezionate Modifica > Inserisci > Porzione rettangolare o Porzione poligonale.

  3. Nella finestra del messaggio, fate clic su Multipli.

  4. Selezionate ogni porzione singolarmente e utilizzate il pannello Stati per definire impostazioni di animazione diverse per ciascuna.

  5. Selezionate tutte le porzioni da animare e selezionate GIF animata come formato nel pannello Ottimizza.

  6. Per esportare le singole porzioni separatamente, fate clic su ogni porzione con il pulsante destro del mouse (Windows) o tenete premuto il tasto Ctrl (Mac OS) e scegliete Esporta porzione selezionata. Nella finestra di dialogo Esporta, digitate un nome per il file, scegliete la destinazione e fate clic su Salva.

Esportare gli stati o i livelli come file multipli

Fireworks è in grado di esportare ogni livello o stato in un documento come file di immagine separato, utilizzando le impostazioni di ottimizzazione specificate nel pannello Ottimizza. È il nome del livello o dello stato a determinare il nome di ciascun file esportato. Questo metodo di esportazione viene talvolta utilizzato per esportare le animazioni.

  1. Selezionate File > Esporta.

  2. Digitate un nome di file e scegliete la cartella di destinazione.

  3. Nel menu a comparsa Esporta, scegliete un’opzione:

    Stati su file

    Esporta gli stati come più file.

    Livelli su file

    Esporta livelli come più file.

    Nota: in questo modo tutti i livelli vengono esportati sullo stato corrente.

  4. Per ritagliare automaticamente ogni immagine esportata in modo che includa solo gli oggetti di ciascuno stato, selezionate Ritaglia immagini. Per includere l’intera area di lavoro (incluse le aree vuote oltre gli oggetti), deselezionate questa opzione.

  5. Fate clic su Salva.

Esportare un’area da un documento

  1. Nel pannello Strumenti, selezionate lo strumento Area di esportazione .

  2. Trascinate un perimetro di selezione che definisca la parte del documento da esportare.

    Nota:

    è possibile regolare la posizione del perimetro di selezione durante il trascinamento. Tenendo premuto il pulsante del mouse, premete la barra spaziatrice, quindi trascinate il perimetro di selezione in un altro punto dell’area di lavoro. Rilasciate la barra spaziatrice per continuare a disegnare il perimetro di selezione.

    Quando si rilascia il pulsante del mouse, l’area di esportazione rimane selezionata.

  3. Ridimensionate l’area di esportazione come richiesto:

    • Per ridimensionare il perimetro dell’area di esportazione in modo proporzionale, trascinate una maniglia tenendo premuto il tasto Maiusc.

    • Per ridimensionare il perimetro dal centro, trascinate una maniglia tenendo premuto il tasto Alt (Windows) o Opzione (Mac OS).

    • Per vincolare le proporzioni e ridimensionare dal centro, trascinate una maniglia tenendo premuto il tasto Alt-Maiusc (Windows) o Opzione-Maiusc (Mac OS).

  4. Per passare ad Anteprima immagine, fate doppio clic all’interno del perimetro dell’area di esportazione.

  5. Regolate le impostazioni in Anteprima immagine, quindi fate clic su Esporta.

  6. Digitate un nome di file e scegliete la cartella di destinazione.

  7. Dal menu a comparsa Esporta, selezionate Solo immagini.

  8. Fate clic su Salva.

    Nota:

    per annullare l’operazione senza esportare, fate doppio clic al di fuori del perimetro di selezione dell’area di esportazione, premete Esc o scegliete un altro strumento.

Esportazione del codice HTML

Se non specificato altrimenti, quando si esporta un documento di Fireworks suddiviso in porzioni si esporta un file HTML con le relative immagini. Per definire le modalità di esportazione del codice HTML di Fireworks, utilizzate la finestra di dialogo Impostazioni HTML.

Fireworks genera codice HTML puro, leggibile dalla maggior parte dei browser e degli editor HTML. Per impostazione predefinita, l’esportazione specifica la crittografia UTF-8.

Sono disponibili diversi metodi di esportazione HTML da Fireworks:

  • Esportate un file HTML, apribile in un secondo momento per la modifica in un editor HTML.

  • Esportate ogni pagina in un file di Fireworks come file HTML separato.

  • Copiate il codice HTML negli Appunti da Fireworks, poi incollatelo direttamente in un documento HTML preesistente.

  • Esportate un file HTML, apritelo in un editor HTML, copiate manualmente sezioni del codice dal file, quindi incollate tale codice in un altro documento HTML.

  • Esportate l’HTML sotto forma di livelli CSS (Cascading Style Sheet) e XHTML.

  • Utilizzate il comando Aggiorna HTML per apportare modifiche ai file HTML creati in precedenza.

    Fireworks consente di esportare il codice HTML in formato Generico, Dreamweaver, Microsoft® FrontPage® e Adobe GoLive®.

    Nota: Adobe Dreamweaver è strettamente integrato con Fireworks. Fireworks gestisce l’esportazione di HTML per Dreamweaver in modo diverso dall’esportazione per altri editor HTML. Se si esporta HTML di Fireworks per Dreamweaver, consultate Operazioni con Dreamweaver.

    Il metodo di esportazione per trasferire il codice HTML di Fireworks in altre applicazioni rappresenta la soluzione ideale per i gruppi di lavoro. Questo metodo segmenta il flusso di lavoro, consentendo a un utente di eseguire un’operazione in un’applicazione che verrà poi ripresa in un secondo momento da un altro utente in un’altra applicazione.

Includere i commenti nel codice HTML esportato

I commenti HTML di Fireworks iniziano con <!-- e terminano con -->. Tutto ciò che è compreso tra questi due marcatori non viene interpretato come codice HTML o JavaScript.

  1. Prima dell’esportazione, selezionate l’opzione Includi commenti HTML nella scheda Generali della finestra di dialogo Impostazioni HTML.

Risultati dell’esportazione

Durante l’esportazione o la copia di HTML da Fireworks, vengono generati i seguenti elementi:

  • Il codice HTML necessario a riassemblare le immagini suddivise in porzioni e il codice JavaScript, se il documento contiene elementi interattivi. Il codice HTML generato da Fireworks contiene collegamenti alle immagini esportate e imposta il colore di sfondo della pagina Web sul colore dell’area di lavoro.

  • Uno o più file di immagini a seconda del numero di porzioni presenti nel documento e degli stati inclusi nei pulsanti.

  • Un file denominato spacer.gif, se necessario. Questo è un file GIF trasparente da 1 pixel per 1 pixel che Fireworks utilizza per correggere problemi di spaziatura quando le immagini suddivise in porzioni vengono riassemblate in una tabella HTML. È possibile indicare se tale elemento deve essere esportato o meno.

  • Nel caso di esportazione di menu a comparsa, vengono esportati i seguenti file: mm_css_menu.js e un file .css contenente il codice del menu a comparsa CSS. Se i menu a comparsa contengono sottomenu, viene esportato anche il file arrows.gif.

  • Se si esporta o si copia il codice HTML in Dreamweaver, vengono creati file di note che facilitano l’integrazione tra Fireworks e Dreamweaver. Questi file hanno l’estensione .mno.

Esportare HTML di Fireworks

  1. Selezionate File > Esporta.

  2. Accedete alla cartella sul disco rigido in cui effettuare l’esportazione.

  3. Nel menu a comparsa Esporta, selezionate HTML e immagini.

  4. Fate clic sul pulsante Opzioni e selezionate l’editor HTML dal menu a comparsa Stile HTML nella scheda Generali della finestra di dialogo Impostazioni HTML. Se l’editor HTML in uso non è elencato, selezionate Generico.

    Nota:

    è importante selezionate l’editor HTML in uso come stile HTML, in modo che gli elementi interattivi come i pulsanti e i rollover funzionino correttamente una volta importati nell’editor HTML.

  5. Fate clic su OK.

  6. Nel menu a comparsa HTML, selezionate Esporta file HTML.

  7. Se il documento contiene porzioni, selezionate Esporta porzioni dal menu a comparsa Porzioni.

  8. Per memorizzare le immagini in una cartella separata, selezionate Inserisci immagine nella sottocartella. È possibile selezionate una cartella specifica o utilizzare la cartella predefinita delle immagini di Fireworks.

  9. Se si esporta un documento Fireworks composto da più pagine, deselezionate la casella di controllo Solo pagina corrente per esportare tutte le pagine in documenti HTML separati.

  10. Fate clic su Salva.

    Dopo l’esportazione, i file esportati di Fireworks compaiono sul disco rigido. Le immagini e il file HTML sono generati nella posizione specificata nella finestra di dialogo Esporta.

Copiare il codice HTML negli Appunti

Il codice HTML di Fireworks può essere copiato in due modi. Si può usare il comando Copia codice HTML oppure scegliere l’opzione Copia negli Appunti nella finestra di dialogo Esporta. Si potrà poi incollare questo codice HTML nel documento utilizzando l’editor HTML preferito.

Quando si stabilisce la modalità di inserimento dell’HTML di Fireworks in altre applicazioni, è necessario prendere in considerazione i seguenti svantaggi derivanti dalla copia del codice HTML negli Appunti:

  • Non è possibile salvare le immagini in una sottocartella. Le immagini devono trovarsi nella stessa cartella del file in cui è stato incollato l’HTML copiato. Il codice HTML copiato in Dreamweaver costituisce un’eccezione.

  • Tutti i collegamenti o i percorsi utilizzati nei menu a comparsa di Fireworks vengono mappati sul disco rigido. Il codice HTML copiato in Dreamweaver costituisce un’eccezione.

  • Se si utilizza un editor HTML diverso da Dreamweaver o Microsoft FrontPage, il codice JavaScript associato a pulsanti, comportamenti e immagini rollover viene copiato, ma potrebbe non funzionare correttamente.

    Se queste condizioni rappresentano un problema, si consiglia di utilizzare l’opzione Esporta HTML anziché copiare il codice HTML negli Appunti.

    Nota: prima di copiare il codice HTML, accertatevi di aver selezionato lo stile HTML appropriato e l’opzione Includi commenti HTML nella scheda Generali della finestra di dialogo Impostazioni HTML.

Copiate HTML di Fireworks mediante l’opzione Copia codice HTML

  1. Selezionate Modifica > Copia codice HTML.

  2. Seguite la procedura guidata di autocomposizione. Quando richiesto, specificate la cartella di destinazione per le immagini esportate; deve trattarsi della posizione in cui risiederà il file HTML.

    Nota:

    se si prevede di incollare il codice HTML in Dreamweaver, non è importante dove vengono esportate le immagini, purché risiedano nello stesso sito Dreamweaver del file HTML in cui si incollerà il codice.

Copiate il codice HTML generato da Fireworks utilizzando la finestra di dialogo Esporta

  1. Selezionate File > Esporta.

  2. Nella finestra di dialogo Esporta, specificate una cartella come destinazione per le immagini esportate; deve trattarsi della stessa posizione in cui risiederà il file HTML.

    Nota:

    se si prevede di incollare il codice HTML in Dreamweaver, non è importante dove vengono esportate le immagini, purché risiedano nello stesso sito Dreamweaver del file HTML in cui si incollerà il codice.

  3. Nel menu a comparsa Esporta, selezionate HTML e immagini.

  4. Nel menu a comparsa HTML, selezionate Copia negli Appunti.

  5. Se il documento contiene porzioni, selezionate Esporta porzioni dal menu a comparsa Porzioni.

  6. Fate clic sul pulsante Opzioni, selezionate l’editor HTML nella finestra di dialogo Impostazioni HTML e fate clic su OK.

  7. Fate clic su Salva.

Incollate il codice HTML copiato da Fireworks in un documento HTML

  1. Nell’editor HTML scelto, aprite un documento HTML esistente oppure createne uno nuovo. Salvate il documento nella stessa posizione in cui si sono esportate le immagini.

    Nota:

    se si utilizza Dreamweaver, non è necessario salvare il file HTML nella stessa posizione delle immagini esportate. Inoltre, se si esportano le immagini da Fireworks a un sito Dreamweaver e si salva il file HTML in una posizione al suo interno, Dreamweaver risolve i percorsi delle immagini associate.

  2. Visualizzate il codice HTML e collocate il punto di inserimento tra i tag <BODY>.

    Nota:

    il codice HTML copiato da Fireworks non include i tag di apertura e chiusura <HTML> e <BODY>.

  3. Incollare il codice HTML.

    Se possibile, quando si esegue la copia negli Appunti, esportate le immagini nella posizione dove risiederanno nel sito Web. Fireworks usa gli URL relativi, quindi se si spostano l’HTML o le immagini, i collegamenti URL vengono interrotti.

Copiare il codice da un file di Fireworks esportato e incollarlo in un altro documento HTML

  1. Aprite il codice HTML di Fireworks esportato in un editor HTML.

  2. Evidenziate il codice necessario e copiatelo negli Appunti.

  3. Aprite un documento HTML esistente oppure createne uno nuovo.

  4. Incollate il codice nel nuovo file HTML. Non è necessario copiare i tag <HTML> e <BODY>, in quanto dovrebbero essere già presenti nel documento HTML di destinazione.

    Se è stata selezionata l’opzione Includi commenti HTML nella finestra di dialogo Impostazioni HTML di Fireworks, seguite le istruzioni nei commenti per copiare e incollare il codice nella corretta posizione.

  5. Se il documento di Fireworks contiene elementi interattivi, copiate il codice JavaScript.

    Il codice JavaScript è delimitato da tag <SCRIPT> e si trova nella sezione <HEAD> del documento. Copiate e incollate l’intera sezione <SCRIPT>, a meno che il documento di destinazione non contenga già una sezione <SCRIPT>. In questo caso, copiate e incollate solo il contenuto della sezione <SCRIPT> nella sezione <SCRIPT> esistente, facendo attenzione a non sovrascrivere il contenuto della sezione esistente. Inoltre, verificate che, una volta incollato il codice, la sezione <SCRIPT> non contenga funzioni JavaScript duplicate.

Aggiornare HTML esportati

L’aggiornamento consente di apportare modifiche a un documento di Fireworks HTML precedentemente esportato ed è utile se si desidera aggiornare solo una sezione del documento.

Nota:

il comando Aggiorna HTML funziona in modo diverso nei documenti di Dreamweaver rispetto ad altri documenti HTML. Per ulteriori informazioni, consultate Operazioni con Dreamweaver.

Durante l’aggiornamento, si può scegliere se sostituire solo le immagini modificate oppure sovrascrivere codice e immagini. Se si decide di sostituire solo le immagini cambiate, le modifiche apportate al file HTML fuori da Fireworks vengono conservate.

Nota:

in caso di modifiche di notevole entità al layout del documento, apportate le modifiche in Fireworks, quindi riesportate il file HTML.

  1. Selezionate File > Aggiorna HTML.

  2. Selezionate il file da aggiornare.

  3. Fate clic su Apri.

  4. Effettuate una delle seguenti operazioni:

    • Se non si reperisce alcun HTML generato da Fireworks, fate clic su OK per inserire il nuovo HTML al termine del documento.

    • Se invece viene reperito un file generato da Fireworks, scegliete una delle opzioni seguenti e fate clic su OK:

      Sostituzione immagini e del loro HTML

      Sostituisce il codice HTML precedente di Fireworks.

      Aggiorna le sole immagini

      Sovrascrive solo le immagini.

  5. Se compare la finestra di dialogo Seleziona cartella immagini, scegliete una cartella e fate clic su Apri.

Esportare i livelli CSS

I livelli CSS possono essere sovrapposti l’uno sull’altro. In Fireworks, il normale output HTML non supporta la sovrapposizione.

  1. Selezionate File > Esporta.

  2. Digitate un nome di file e scegliete la cartella di destinazione.

  3. Nel menu a comparsa Esporta, selezionate CSS e immagini.

    • Per esportare solo lo stato corrente, selezionate Solo stato corrente.

    • Per esportare solo la pagina corrente, selezionate Solo pagina corrente.

    • Per scegliere una cartella per le immagini, selezionate Inserisci immagine nella sottocartella.

  4. Fate clic su Opzioni per impostare le proprietà di pagina HTML.

  5. Fate clic su Sfoglia per specificare un’immagine di sfondo e impostarne le opzioni di ripetizione:

    • Selezionate Non ripetere per visualizzare l’immagine una sola volta.

    • Selezionate Ripeti per ripetere (affiancare) l’immagine in orizzontale e in verticale.

    • Selezionate Ripeti-x per affiancare l’immagine in orizzontale.

    • Selezionate Ripeti-y per affiancare l’immagine in verticale.

  6. Selezionate l’allineamento della pagina nel browser (a sinistra, al centro, a destra).

  7. Fate clic su OK, quindi su Salva.

Esportare XHTML

XHTML è una combinazione di HTML (l’attuale standard di formattazione e visualizzazione delle pagine Web) e XML (eXtensible Markup Language). XHTML è compatibile con le versioni precedenti, può essere quindi visualizzato con la maggior parte dei browser Web esistenti; inoltre può essere letto da tutti i dispositivi che visualizzano il contenuto XML, come palmari, telefoni cellulari e altri dispositivi portatili.

Fireworks permette anche di importare il codice XHTML. Consultate Creare file PNG di Fireworks da file HTML.

Per ulteriori informazioni su XHTML, consultate la specifica XHTML del World Wide Web Consortium (W3C) all’indirizzo www.w3.org.

  1. Selezionate File > Imposta HTML, scegliere uno stile XHTML dal menu a comparsa Stile HTML della scheda Generale e fate clic su OK.

  2. Esportate il documento utilizzando i metodi disponibili per l’esportazione o la copia HTML. Consultate Esportazione del codice HTML.

    Nota:

    per l’esportazione in XHTML, Fireworks utilizza la codifica UTF-8.

Esportare file con e senza codifica UTF-8

Il metodo di codifica del testo UTF-8 (Universal Character Set Transformation Format-8) consente ai browser di visualizzare set di caratteri diversi nella stessa pagina HTML (ad esempio, testo in lingua cinese e in lingua inglese). La codifica UTF-8 è attivata per impostazione predefinita.

Fireworks permette anche di importare i documenti che utilizzano tale codifica. Consultate Creare file PNG di Fireworks da file HTML.

Esportare i documenti senza codifica UTF-8

  1. Selezionate File > Imposta HTML.

  2. Nella scheda Specifiche del documento, deselezionate la casella UTF-8 e fate clic su OK.

  3. Esportate il documento utilizzando i metodi disponibili per l’esportazione o la copia HTML.

Impostare le opzioni di esportazione HTML

La finestra di dialogo Impostazioni HTML consente di definire le modalità di esportazione del codice HTML di Fireworks. Le modifiche apportate nella scheda Specifiche del documento vengono applicate solo al documento corrente. Le impostazioni delle schede Generali e Tabella sono preferenze globali e hanno effetto su tutti i nuovi documenti.

  1. Effettuate una delle seguenti operazioni:

    • Selezionate File > Imposta HTML.

    • Fate clic sul pulsante Opzioni nella finestra di dialogo Esporta.

  2. Nella scheda Generale, selezionate le opzioni desiderate.

    Stile HTML

    Seleziona lo stile per l’HTML esportato.

    Il formato HTML generico funziona in qualsiasi editor HTML. Tuttavia, se il documento contiene comportamenti o altro contenuto interattivo, si consiglia di scegliere l’editor specifico, se presente nell’elenco.

    Per esportare il documento utilizzando lo standard XHTML, scegliete lo stile XHTML appropriato dal menu a comparsa.

    Estensione

    Scegliete un’estensione per il file dal menu a comparsa o immettetene una nuova.

    Includi commenti HTML

    Consente di includere commenti su dove copiare e incollare il codice HTML. Si consiglia di selezionare questa opzione se il documento contiene elementi interattivi quali pulsanti, comportamenti o immagini rollover.

    Nome file in minuscole

    Consente di esportare il file HTML e i file immagine associati con nomi file in lettere minuscole.

    Nota: questa opzione non applica le lettere minuscole all’estensione del file HTML se nel menu Estensione è stata selezionata l’estensione in lettere maiuscole.

    Usa CSS per i menu a comparsa

    Consente di utilizzare CSS anziché JavaScript per il codice del menu a comparsa. Per indicizzare il menu o per aggiornare i collegamenti con il codice, è possibile utilizzare Dreamweaver.

    Scrivi CSS su un file esterno

    Consente di scrivere il codice CSS su un file .css esterno esportato nella stessa posizione del file HTML. Il nome del file .css corrisponde a quello del file HTML, tranne per l’estensione. Scegliendo questa opzione, nella stessa posizione del file HTML viene anche esportato un file denominato mm_css_menu.js.

    Nota: questa opzione è disponibile solo se è stata selezionata l’opzione Usa CSS per i menu a comparsa.

    Creatore file (Mac OS)

    Consente di scegliere un’applicazione associata dal menu a comparsa. Quando si farà doppio clic sul file HTML esportato sul disco rigido, questo si aprirà automaticamente nell’applicazione selezionata.

  3. Nella scheda Tabella, scegliete le impostazioni per le tabelle HTML. Per informazioni, consultate Definire le modalità di esportazione delle tabelle HTML.

  4. Nella scheda Specifiche del documento, scegliete una delle opzioni seguenti:

    Nomi file porzioni

    Consente di scegliere una formula per l’assegnazione automatica del nome alle porzioni nei menu a comparsa. Si possono utilizzare le impostazioni predefinite oppure scegliere le proprie opzioni.

    Nota: se si sceglie Nessuno per i primi tre menu, Fireworks esporta i file delle porzioni che si sovrascrivono reciprocamente, producendo un singolo elemento grafico esportato e una tabella che visualizza tale elemento in ogni cella.

    Etichetta ALT predefinita

    Consente di immettere il testo da visualizzare al posto di tutte le immagini durante il download dal Web e come sostitutivo di quelle non scaricabili. In alcuni browser, al passaggio del mouse sull’immagine, può comparire anche sotto forma di descrizione comandi. Questa soluzione viene utilizzata anche per gli utenti Web ipovedenti.

    Esporta più file HTML barra di navigazione (da utilizzare senza serie di fotogrammi)

    Selezionate questa opzione quando si esporta una barra di navigazione che collega più pagine. Fireworks esporta pagine aggiuntive per ciascun pulsante della barra di navigazione.

    Includi aree senza oggetti porzione

    Selezionate questa opzione per includere le parti dell’area di lavoro che non rientrano in alcuna porzione.

    Codifica UTF-8

    Per impostazione predefinita, questa opzione è attivata. Consente la visualizzazione di caratteri appartenenti a più set nel documento esportato. Per disattivare questa opzione, deselezionate la casella di controllo.

  5. Per salvare le impostazioni come predefinite, fate clic su Imposta predefiniti.

Esportare file Adobe PDF

Per stampare un lavoro creato con Fireworks o distribuirlo per la revisione, effettuate l’esportazione in Adobe PDF. I revisori possono aggiungere commenti e rispondere ai commenti degli altri in Adobe Reader® o Acrobat®. Per informazioni sull’impostazione delle revisioni di un file PDF, consultate la Guida di Acrobat.

I file PDF esportati mantengono tutte le pagine e i collegamenti ipertestuali; la navigazione funziona quindi esattamente come in una pagina Web. Tuttavia, a differenza dei prototipi HTML, Adobe PDF offre impostazioni di protezione con cui è possibile impedire la modifica o la copia dei lavori.

  1. Scegliete File > Esporta.

  2. Dal menu a comparsa Esporta, selezionate Adobe PDF.

  3. Scegliete le pagine da esportare, quindi selezionate Visualizza PDF dopo l’esportazione per aprire automaticamente il PDF in Adobe Reader o Acrobat.

  4. Per personalizzare il PDF, fate clic su Opzioni, quindi regolate le seguenti impostazioni:

    Compatibilità

    Consente di stabilire con quali applicazioni Adobe PDF sarà possibile aprire il file esportato.

    Compressione

    Consente di stabilire il tipo di compressione per l’immagine, riducendo le dimensioni del file. In generale, la compressione in formato JPEG e JPEG2000 offre risultati migliori su immagini come fotografie con la trasmissione graduale da colore a colore. ZIP è la scelta migliore per le illustrazioni contenenti aree estese di colori uniformi.

    Qualità

    Per la compressione JPEG o JPEG2000, sono disponibili opzioni per la qualità delle immagini. Alta qualità genera file di dimensioni elevate ma con immagini di buona qualità.

    Converti in scala di grigi

    Consente di convertire tutte le immagini in scala di grigi, riducendo la dimensione del file.

    Abilita selezione testo

    Consente ai revisori di copiare il testo dal file esportato. Deselezionate questa opzione per ridurre notevolmente la dimensione dei file.

    Valore pagina al vivo

    Determina la larghezza dei pixel del bordo vuoto che circonda l’immagine su ciascuna pagina. Ad esempio, un valore pari a 20 circonda ogni immagine con un bordo di 20 pixel.

    Password per aprire il documento

    Per aprire il file esportato, è necessario usare Password per apertura.

    Password per limitare le attività

    È necessario usare Password per protezione per eseguire queste funzioni selezionate: Stampa, Modifica, Copia e Inserimento commenti.

  5. Per chiudere la finestra di dialogo Opzioni, fate clic su OK.

  6. Specificaye un nome di file e una posizione, quindi fate clic su Salva.

    Nota:

    durante l’esportazione in PDF, se alcune pagine del documento Fireworks hanno l’area di lavoro trasparente, gli oggetti con eventuale trasparenza perdono le rispettive caratteristiche trasparenti. Per evitare questo inconveniente, impostaye l’area di lavoro come sfondo non trasparente prima dell’esportazione in PDF.

Video

Create bozze per il cliente in formato PDF o HTML utilizzando Fireworks (00:05:32)

Scoprite come utilizzare il menu Esporta di Fireworks per preparare un documento PDF o HTML per l’approvazione del cliente o la revisione del team.

Di Tom Green

Quando visualizzate file PDF esportati in Adobe Acrobat o Adobe Reader, utilizzate le impostazioni seguenti:

  1. In Adobe Acrobat o Adobe Reader, selezionate Modifica > Preferenze.

  2. Selezionate Visualizzazione pagina nel pannello sinistro.

  3. Impostate Risoluzione personalizzata su 72 pixel per pollice.

  4. Impostate il valore di zoom su 100%.

Esportazione di file FXG

FXG è un formato di file supportato da Flash Catalyst, Fireworks, Illustrator e Photoshop. Quando si esporta un file contenente immagini vettoriali e bitmap utilizzando l’esportazione FXG, viene creata una cartella distinta nominata <filename.assets>. La cartella contiene le immagini bitmap associate al file.

Se uno dei file associati viene eliminato da questa cartella, l’operazione di importazione non riesce.

Nota:

gli elementi, i filtri, i metodi di fusione, i gradienti e le maschere per i quali non esistono tag di mapping corrispondenti nel formato FXG vengono esportati come grafica bitmap.

  1. Selezionate File > Esporta e aprite il percorso in cui salvare i file.

  2. Inserite un nome per il file FXG.

  3. Nella finestra di dialogo Esporta, selezionate FXG e immagini dal menu Esporta.

  4. Fate clic su Salva.

Nota:

gli oggetti che si estendono oltre l’area di lavoro in Fireworks vengono visualizzati completamente quando il file FXG esportato viene aperto in Flash Catalyst.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online