Utilizzo di Fireworks con Dreamweaver

Adobe Dreamweaver® e Fireworks riconoscono e condividono molte delle stesse funzioni di modifica dei file, come le modifiche ai collegamenti, alle mappe immagine e alle porzioni di tabelle. Inoltre, Dreamweaver e Fireworks offrono insieme un flusso di lavoro ottimizzato per modificare, ottimizzare e collocare file di grafica per il Web nelle pagine HTML.

Collocare immagini di Fireworks nei file di Dreamweaver

Quando inserite file JPEG Fireworks in Dreamweaver, la qualità del file viene automaticamente calcolata. Il valore può essere 79 per alcuni file.

Nota:

prima di utilizzare le procedure descritte, accertatevi che Dreamweaver sia selezionato come tipo HTML nella finestra di dialogo Impostazioni HTML.

Inserire immagini di Fireworks in Dreamweaver con il pannello File

  1. Esportate l’immagine da Fireworks nella cartella del sito locale come specificato in Dreamweaver.

  2. Aprite il documento di Dreamweaver accertandovi che sia attiva la vista Progettazione.

  3. Trascinate l’immagine dal pannello File al documento di Dreamweaver.

Inserire immagini di Fireworks in Dreamweaver con il menu Inserisci

  1. Posizionate il punto di inserimento in cui intendete inserire l’immagine nella finestra del documento di Dreamweaver.

  2. Effettuate una delle seguenti operazioni:

    • Selezionate Inserisci > Immagine.

    • Fate clic sul pulsante Immagine nella categoria Comune della barra Inserisci.

  3. Passate all’immagine esportata da Fireworks, quindi fate clic su OK.

Creare nuovi file di Fireworks da segnaposto di Dreamweaver

Mediante i segnaposto immagine è possibile provare diversi layout di pagina Web prima di creare il lavoro di grafica finale per la pagina. I segnaposto immagine consentono di specificare le dimensioni e la posizione delle immagini di Fireworks che verranno inserite in Dreamweaver in un secondo momento.

Quando si crea un’immagine Fireworks da un segnaposto immagine Dreamweaver, viene creato un nuovo documento Fireworks con un’area di lavoro delle stesse dimensioni del segnaposto selezionato.

Nota:

tutti i comportamenti applicati all’interno di Fireworks sono conservati al ritorno a Dreamweaver. Allo stesso modo, la maggior parte dei comportamenti di Dreamweaver applicati ai segnaposto immagine sono anch’essi conservati durante l’avvio e la modifica con Fireworks. Tuttavia, c’è un’eccezione: i rollover disgiunti applicati ai segnaposto immagine in Dreamweaver non vengono conservati quando si apre e si modifica l’immagine in Fireworks.

Una volta terminata la sessione di Fireworks e ritornati a Dreamweaver, il nuovo elemento grafico di Fireworks creato prende il posto del segnaposto immagine originariamente selezionato.

  1. In Dreamweaver, salvate il documento HTML desiderato in una posizione all’interno della cartella sito di Dreamweaver.

  2. Posizionate il punto di inserimento nella posizione desiderata del documento ed effettuate una delle seguenti operazioni:

    • Selezionate Inserisci > Oggetti immagine > Segnaposto immagine.

    • Fate clic sul menu a comparsa Immagine nella categoria Comune della barra Inserisci e scegliete Segnaposto immagine.

  3. Immettete il nome, le dimensioni, il colore e il testo alternativo per il segnaposto immagine.

    Nel documento di Dreamweaver, viene inserito un segnaposto immagine.

    Segnaposto immagine
    Segnaposto immagine

  4. Effettuate una delle seguenti operazioni:

    • Selezionate il segnaposto immagine e fate clic su Crea nella finestra di ispezione Proprietà.

    • Fate doppio clic tenendo premuto il tasto Ctrl (Windows) o Comando (Mac OS) sul segnaposto immagine.

    • Fate clic con il pulsante destro del mouse (Windows) o tenete premuto il tasto Ctrl (Mac OS) e scegliete Crea immagine in Fireworks.

      Fireworks si apre con uno spazio vuoto delle stesse dimensioni dell’immagine segnaposto. Nella parte superiore della finestra del documento, è indicato che si sta modificando un’immagine da Dreamweaver.

  5. Create un’immagine in Fireworks e fate clic su Fine.

  6. Specificate un nome e la posizione per il file PNG sorgente.

  7. Specificate un nome per i file immagine esportati.

    Questi sono i file immagine visualizzati in Dreamweaver.

  8. Specificate una posizione nella cartella del sito di Dreamweaver per i file o i file immagine esportati, quindi fate clic su Salva.

    Quando si ritorna a Dreamweaver, il segnaposto immagine originariamente selezionato viene sostituito con la nuova immagine o tabella di Fireworks.

    Segnaposto immagine sostituito dalla nuova immagine di Fireworks
    Segnaposto immagine sostituito dalla nuova immagine di Fireworks

Inserire il codice HTML di Fireworks in Dreamweaver

L’esportazione di file da Fireworks a Dreamweaver è composta da due fasi. In Fireworks, esportate i file direttamente in una cartella sito di Dreamweaver. In questo modo, viene creato un file HTML e i file immagine associati nella posizione specificata. Quindi, inserite il codice HTML in Dreamweaver con la funzione Inserisci HTML di Fireworks.

  1. Esportate il documento HTML di Fireworks in formato HTML.

  2. In Dreamweaver, salvate il documento in un sito definito.

  3. Posizionate il punto di inserimento nel documento in cui desiderate far iniziare il codice HTML inserito.

  4. Effettuate una delle seguenti operazioni:

    • Selezionate Inserisci > Oggetti immagine > HTML di Fireworks.

    • Fate clic sul menu a comparsa Immagine nella categoria Comune della barra Inserisci e scegliete HTML di Fireworks.

  5. Nella finestra di dialogo che viene visualizzata, fate clic su Sfoglia per scegliere il file HTML di Fireworks.

  6. (Facoltativo) Per spostare il file HTML nel Cestino (Windows) o per eliminarlo definitivamente (Mac OS) al termine dell’operazione, selezionate Cancella il file dopo l’inserimento.

    Questa opzione non ha effetto sul file PNG sorgente associato al file HTML.

  7. Fate clic su OK per inserire nel documento di Dreamweaver il codice HTML assieme alle immagini, alle porzioni e al codice JavaScript associati.

Copiare il codice HTML di Fireworks da utilizzare in Dreamweaver

Quando il codice HTML di Fireworks viene copiato negli appunti, tutto il codice HTML e JavaScript associato al documento Fireworks viene copiato nel documento Dreamweaver, le immagini vengono esportate in una posizione specificata dall’utente e Dreamweaver aggiorna l’HTML con collegamenti relativi al documento.

Nota:

questo metodo funziona solo con Dreamweaver, ma non con altri strumenti di editing HTML.

  1. Copiate l’HTML negli appunti di Fireworks, quindi incollatelo in un documento di Dreamweaver.

Nota:

È possibile aprire in Dreamweaver un file HTML di Fireworks esportato, quindi copiare e incollare le sezioni desiderate in un altro documento di Dreamweaver.

Aggiornare l’HTML di Fireworks esportato in Dreamweaver

Nota:

La funzione Roundtrip HTML offre diversi vantaggi quando si utilizzano file HTML esportati in Dreamweaver. Consultate La funzione Roundtrip HTML.

  1. Apportate modifiche al documento PNG in Fireworks.

  2. Selezionate File > Aggiorna HTML.

  3. Individuate il file di Dreamweaver contenente il codice HTML da aggiornare, quindi fate clic su Apri.

  4. Individuate la cartella in cui si desidera collocare i file delle immagini aggiornati, quindi fate clic su Apri.

    Fireworks aggiorna il codice HTML e JavaScript nel documento di Dreamweaver. Inoltre, Fireworks esporta le immagini associate al codice HTML e le colloca nella cartella di destinazione specificata.

    Nota:

    qualora Fireworks non riesca a reperire il codice HTML corrispondente da aggiornare, offre comunque la possibilità di inserire il nuovo codice HTML nel documento di Dreamweaver. Fireworks colloca la sezione JavaScript del nuovo codice all’inizio del documento, mentre la tabella HTML o il collegamento all’immagine vengono inseriti alla fine del file.

Esportare i file di Fireworks in librerie di Dreamweaver

Una voce di libreria, o elemento libreria, è una parte del file HTML che si trova in una cartella denominata Library (Libreria) nella cartella principale del sito. Gli elementi libreria appaiono come categorie nel pannello Risorse di Dreamweaver. In Dreamweaver, gli elementi libreria semplificano la modifica e l’aggiornamento dei componenti dei siti Web usati più di frequente. È possibile trascinare un elemento libreria (file con estensione .lbi) dal pannello Risorse a una pagina qualsiasi del sito Web.

Non è possibile modificare un elemento libreria direttamente nel documento di Dreamweaver. Dal documento si può modificare solo l’elemento libreria principale. Successivamente, Dreamweaver può aggiornare ogni copia di quell’elemento presente nell’intero sito Web. Gli elementi libreria di Dreamweaver sono del tutto simili ai simboli di Fireworks; le modifiche al documento libreria principale (LBI) si riflettono in tutte le istanze della libreria del sito.

Nota:

gli elementi della libreria non supportano i menu a comparsa.

  1. Selezionate File > Esporta.

  2. Selezionate Libreria Dreamweaver dal menu a comparsa Esporta.

    Nel sito di Dreamweaver, selezionate o create una cartella denominata Library in cui posizionare i file. Il nome fa distinzione tra maiuscole e minuscole.

    Nota:

    Dreamweaver non riconosce il file esportato come elemento di libreria a meno che non sia salvato nella cartella Libreria.

  3. Digitate un nome di file.

  4. (Facoltativo) Se l’immagine contiene delle porzioni, scegliete le relative opzioni.

  5. Selezionate Inserisci immagine nella sottocartella per scegliere una cartella separata in cui salvare le immagini.

  6. Fate clic su Salva.

Modificare i file di Fireworks da Dreamweaver

La funzione Roundtrip HTML offre una perfetta integrazione di Fireworks e Dreamweaver. Questa caratteristica consente di apportare modifiche in un’applicazione e fare in modo che queste variazioni si riflettano direttamente anche nell’altra.

La funzione Roundtrip HTML

Fireworks riconosce e conserva la maggior parte dei tipi di modifiche apportate a un documento di Dreamweaver, inclusi le variazioni dei collegamenti, le mappe immagine modificate, il testo e il codice HTML modificato nelle porzioni HTML, nonché i comportamenti condivisi tra Fireworks e Dreamweaver. La finestra di ispezione Proprietà di Dreamweaver consente di identificare le immagini, le porzioni in tabelle e le tabelle generate da Fireworks e presenti nel documento.

Fireworks supporta la maggior parte dei tipi di modifiche apportate con Dreamweaver. Tuttavia, modifiche sostanziali apportate alla struttura di una tabella in Dreamweaver possono creare differenze non riconciliabili tra le due applicazioni. Per apportare modifiche considerevoli a un layout di tabella, utilizzate la funzionalità di avvio e modifica di Dreamweaver all’interno di Fireworks.

Nota:

grazie alla tecnologia di Fireworks, Dreamweaver offre funzioni di base di modifica delle immagini che consentono di modificare le immagini senza ricorrere a un’applicazione esterna. Le funzioni di Dreamweaver per la modifica delle immagini si applicano solo ai formati di file immagine JPEG e GIF.

Modificare un’immagine di Fireworks inserita in Dreamweaver

Nota:

prima di modificare gli elementi grafici di Fireworks da Dreamweaver, è necessario eseguire alcune operazioni preliminari. Per ulteriori informazioni, consultate Impostare le opzioni di avvio e modifica.

  1. In Dreamweaver, scegliete Finestra > Proprietà per aprire la finestra di ispezione Proprietà.

  2. Effettuate una delle seguenti operazioni:

    • Selezionate l’immagine desiderata. La finestra di ispezione Proprietà identifica la selezione come immagine di Fireworks e visualizza il nome del file PNG sorgente noto per l’immagine. Successivamente, fate clic su Modifica nella finestra di ispezione Proprietà.

    • Fate doppio clic tenendo premuto il tasto Ctrl (Windows) o Comando (Mac OS) sull’immagine da modificare.

    • Fate clic con il pulsante destro del mouse (Windows) o tenete premuto il tasto Ctrl (Mac OS) sull’immagine desiderata e scegliete Modifica con Fireworks dal menu di scelta rapida.

  3. Se richiesto, specificate se individuare un file sorgente di Fireworks per l’immagine inserita.

  4. Modificare l’immagine in Fireworks.

    Le modifiche apportate vengono mantenute in Dreamweaver.

  5. Fate clic su Fine per esportare l’immagine utilizzando le impostazioni di ottimizzazione correnti, aggiornate il file GIF o JPEG utilizzato da Dreamweaver e salvate il file sorgente PNG, qualora sia stato selezionato un file sorgente.

    Nota:

    quando si apre un’immagine dal pannello Sito di Dreamweaver, l’editor predefinito per quel tipo di immagine, impostato nelle Preferenze di Dreamweaver, apre il file. Quando le immagini vengono aperte da questa posizione, Fireworks non apre il file PNG originale. Per poter utilizzare le funzioni di integrazione di Fireworks, è necessario aprire le immagini dall’interno della finestra del documento di Dreamweaver.

Modificare una tabella di Fireworks inserita in Dreamweaver

Nota:

prima di modificare le tabelle di Fireworks da Dreamweaver, è necessario eseguire alcune operazioni di avvio e modifica preliminari. Per ulteriori informazioni, consultate Impostare le opzioni di avvio e modifica.

  1. In Dreamweaver, scegliete Finestra > Proprietà per aprire la finestra di ispezione Proprietà.

  2. Per aprire il file sorgente PNG nella finestra del documento, effettuate una delle seguenti operazioni:

    • Fate clic all’interno della tabella, quindi sul tag TABLE nella barra di stato per selezionare l’intera tabella. La finestra di ispezione Proprietà identifica la selezione come tabella di Fireworks e visualizza il nome del file PNG sorgente noto per la tabella. Successivamente, fate clic su Modifica nella finestra di ispezione Proprietà.

    • Selezionate un’immagine nella tabella, quindi fate clic su Modifica nella finestra di ispezione Proprietà.

    • Fate clic con il pulsante destro del mouse (Windows) o tenete premuto il tasto Ctrl (Mac OS) sull’immagine e scegliete Modifica con Fireworks dal menu di scelta rapida.

  3. In Fireworks, apportate le modifiche necessarie.

    Dreamweaver riconosce e mantiene tutte le modifiche applicate a una tabella in Fireworks.

  4. Dopo aver apportato le modifiche alla tabella, fate clic su Fine nella finestra del documento.

    Il codice HTML e i file delle porzioni immagine vengono esportati utilizzando le impostazioni di ottimizzazione correnti. La tabella inserita in Dreamweaver viene aggiornata e il file PNG sorgente viene salvato.

    Nota:

    se si crea una tabella nidificata all’interno di una tabella generata da Fireworks e si tenta di modificarla mediante la funzionalità roundtrip in Dreamweaver, si può verificare un errore di Dreamweaver. Per ulteriori informazioni, consultate la nota tecnica 19231, nel sito Web di Adobe.

I comportamenti supportati e non supportati di Dreamweaver

Se un singolo elemento grafico non suddiviso in porzioni di Fireworks viene inserito in un documento di Dreamweaver e gli viene applicato un comportamento di Dreamweaver, al momento dell’apertura e della modifica in Fireworks all’elemento grafico viene sovrapposta una porzione. La porzione non è inizialmente visibile, dato che le porzioni sono automaticamente disattivate quando si aprono e modificano elementi grafici singoli e non suddivisi ai quali siano stati applicati comportamenti di Dreamweaver. La porzione può essere visualizzata attivandone la visibilità dal Livello Web del pannello Livelli.

Quando si visualizzano le proprietà di una porzione di Fireworks dotata di un comportamento di Dreamweaver, la casella di testo del collegamento nella finestra di ispezione Proprietà potrebbe visualizzare javascript:;. L’eliminazione di questo testo non ha alcuna conseguenza negativa. Anche sovrapponendovi un URL, il comportamento rimarrà comunque intatto alla riapertura del file in Dreamweaver.

Quando si opera con Roundtrip HTML da Dreamweaver, Fireworks supporta i formati lato server quali CFM e PHP.

Dreamweaver supporta tutti i comportamenti applicati a Fireworks, inclusi quelli richiesti per i rollover e i pulsanti.

Nota:

gli elementi della libreria non supportano i menu a comparsa.

Fireworks supporta i seguenti comportamenti di Dreamweaver durante una sessione di avvio e modifica:

  • Rollover semplice

  • Scambia immagine

  • Ripristino di immagini scambiate

  • Impostazione del testo della barra di stato

  • Imposta immagine barra di navigazione

  • Menu a comparsa

Nota:

Fireworks non supporta comportamenti non nativi, inclusi i comportamenti lato server.

Ottimizzare immagini e animazioni di Fireworks aggiunte a Dreamweaver

Modificare le impostazioni di ottimizzazione per un’immagine di Fireworks inserita in Dreamweaver

  1. In Dreamweaver, selezionate l’immagine ed effettuate una delle seguenti operazioni:

    • Selezionate Comandi > Ottimizza immagine.

    • Fate clic sul pulsante Ottimizza nella finestra di ispezione Proprietà.

    • Fate clic con il pulsante destro del mouse (Windows) o tenete premuto il tasto Ctrl (Mac OS) e scegliete Ottimizza in Fireworks dal menu a comparsa.

  2. Qualora richiesto, specificate se aprire un file sorgente di Fireworks per l’immagine inserita.

  3. Apportate le modifiche necessarie nella finestra di dialogo Anteprima esportazione:

    • Per modificare le impostazioni di ottimizzazione, fate clic sulla scheda Opzioni.

    • Per modificare le dimensioni e l’area dell’immagine esportata, fate clic sulla scheda File. Se si modificano le dimensioni dell’immagine in Fireworks, è necessario reimpostare le dimensioni dell’immagine nella finestra di ispezione Proprietà quando si ritorna a Dreamweaver.

    • Per modificare le impostazioni di animazione per l’immagine, fate clic sulla scheda Animazione.

  4. Dopo aver modificato l’immagine, fate clic su OK per esportarla, aggiornarla in Dreamweaver, quindi salvate il file PNG.

    Se è stato modificato il formato dell’immagine, la funzione Controllo collegamenti di Dreamweaver richiede di aggiornare i riferimenti all’immagine.

Modificare le impostazioni di animazione

Se si sta aprendo e ottimizzando un file GIF animato, è possibile anche modificare le impostazioni delle animazioni. Le opzioni di animazione disponibili nella finestra di dialogo Anteprima esportazione sono simili a quelle disponibili nel pannello Stati di Fireworks.

Nota:

per modificare i singoli elementi grafici di un’animazione di Fireworks, è necessario aprire e modificare l’animazione stessa.

Impostare le opzioni di avvio e modifica

Per utilizzare la funzionalità Roundtrip HTML in modo ottimale, è necessario eseguire alcune operazioni preliminari, quali la definizione di Fireworks come editor di immagini principale in Dreamweaver e la specifica delle preferenze di avvio e modifica per Fireworks, nonché la definizione di un sito locale in Dreamweaver.

Impostare Fireworks come principale editor esterno di immagini per Dreamweaver

In Dreamweaver, sono disponibili una serie di preferenze per avviare automaticamente applicazioni specifiche per la modifica di determinati tipi di file. Per utilizzare la funzionalità di avvio e modifica di Fireworks, assicuratevi che questo sia impostato come editor principale per i file GIF, JPEG e PNG all’interno di Dreamweaver.

Nota:

l’impostazione di questa preferenza è necessaria solo se si riscontrano problemi con l’avvio di Fireworks dall’interno di Dreamweaver.

  1. In Dreamweaver, scegliete Modifica > Preferenze, quindi scegliere Tipi di file/Editor.

  2. Nell’elenco Estensioni, selezionate un’estensione per il file Web (.gif, .jpg o .png).

  3. Nell’elenco degli editor, selezionate Fireworks. Se Fireworks non si trova nell’elenco, fate clic sul pulsante con il segno più (+), individuate l’applicazione Fireworks sul disco rigido, quindi fate clic su Apri.

    Preferenze di Dreamweaver
    Preferenze di Dreamweaver

  4. Fate clic su Rendi principale.

  5. Ripetete i passaggi da 2 a 4 per impostare Fireworks come editor principale per gli altri tipi di file immagine Web.

Specificate le preferenze di avvio e modifica per i file sorgente di Fireworks

Le preferenze di avvio e modifica di Fireworks permettono di specificare le modalità di gestione dei file PNG all’apertura dei file di Fireworks da un’altra applicazione.

Dreamweaver riconosce le preferenze di avvio e modifica di Fireworks solo quando si apre e ottimizza un’immagine che non appartiene a una tabella di Fireworks e che non contiene un percorso di Design Note corretto verso il file sorgente PNG. In tutti gli altri casi, compresi tutti i casi di avvio e modifica delle immagini di Fireworks, Dreamweaver apre automaticamente il file PNG sorgente, richiedendo di individuare il file sorgente, qualora non riesca a reperirlo.

  1. In Fireworks, scegliete Modifica > Preferenze (Windows) o Fireworks > Preferenze (Mac OS).

  2. Fate clic sulla categoria Avvio e modifica, quindi impostate le opzioni desiderate.

    Per ulteriori informazioni, consultare Preferenze di Avvio e modifica.

Design Notes e i file sorgente

Ogni volta che si esporta un file di Fireworks da un file PNG sorgente salvato in un sito di Dreamweaver, Fireworks scrive una nota di progettazione (Design Note) contenente informazioni sul file PNG. Quando si apre e si modifica da Dreamweaver un’immagine creata con Fireworks, Dreamweaver utilizza la Design Note per individuare il PNG sorgente per il file dell’immagine. Per garantire risultati ottimali, salvate sempre il file PNG sorgente di Fireworks e i file esportati in un sito di Dreamweaver. Ciò garantisce che qualsiasi utente che condivide il sito sia in grado di individuare il PNG sorgente all'avvio di Fireworks da Dreamweaver.

Trasferimento dei file del sito mediante il pulsante Gestione file

Il pulsante Gestione file , nella parte superiore della finestra del documento, consente di accedere facilmente a vari comandi di trasferimento dei file. È possibile utilizzare questo pulsante se il documento risiede in una cartella del sito di Dreamweaver e se il sito ha accesso a un server remoto. Affinché Fireworks riconosca la cartella come sito, utilizzate la finestra di dialogo Gestisci siti di Dreamweaver per definire la cartella di destinazione (o una cartella contenente degli elementi) come cartella principale locale del sito.

Nota:

prima di utilizzare le opzioni di deposito e ritiro di Fireworks, selezionate l’opzione Abilita deposito e ritiro file per il sito di Dreamweaver in cui risiede il documento.

Scarica

Consente di copiare la versione remota del file nel sito locale, sovrascrivendo il file locale con la copia remota.

Ritira

Consente di ritirare il file, sovrascrivendo il file locale con la copia remota.

Carica

Consente di copiare la versione locale del file sul sito remoto, sovrascrivendo il file remoto con la copia locale.

Deposita

Consente di depositare il file locale, sovrascrivendo il file remoto con la copia locale.

Annulla ritiro

Annulla il ritiro del file locale e lo deposita, sovrascrivendo il file locale con la copia remota.

Nota:

i comandi di Gestione file sono disponibili in Fireworks solo se il documento risiede in una cartella sito di Dreamweaver per cui è definito un server remoto. I comandi di Gestione file possono essere utilizzati per file che risiedono in siti che usano metodi di trasporto Locale/rete e FTP. I file in siti che usano SFTP o metodi di trasporto di terze parti, come SourceSafe, WebDAV e RDS, non possono essere trasferiti al o dal server remoto dall’interno di Fireworks.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online