Estrarre proprietà di oggetti CSS

Potete estrarre le proprietà di oggetti CSS, come angoli arrotondati, gradienti, ombre esterne e trasformazioni.

  1. Selezionate l’oggetto.
  2. Selezionate Finestra > Proprietà CSS.
  3. Fate clic su Copia tutto per copiare le proprietà CSS dell’oggetto selezionato. Fate clic su Copia selezionata per copiare le singole proprietà.
    Per ulteriori informazioni, consultare Estrarre le proprietà CSS da oggetti di progettazione utilizzando Fireworks CS6.

Esportare porzioni come sprite CSS

Potete suddividere gli oggetti di un documento ed esportarli come singola immagine sprite CSS. L’uso di una sola immagine sprite CSS invece di più immagini migliora il tempo di caricamento del sito Web riducendo il numero di richieste server.

Quando si esportano porzioni come immagine sprite CSS, con i file immagine viene generato un file CSS contenente i valori di spostamento.

  1. Fate clic con il pulsante destro del mouse sulla porzione o sul gruppo di porzioni.
  2. Selezionate Esporta sprite CSS.
  3. Nella finestra di dialogo Esporta, fate clic su Esporta.

Per ulteriori informazioni, consultate Utilizzo degli sprite CSS in Fireworks CS6.

Creazione di temi jQuery Mobile

Potete creare temi jQuery Mobile in base a sprite e campioni predefiniti. Potete anche visualizzare in anteprima il tema jQuery Mobile ed esportarlo come CSS e sprite.

  • Per creare un tema mobile, selezionate Comandi > Tema jQuery Mobile > Crea nuovo tema.
  • Per visualizzare in anteprima temi mobili in un browser, selezionate Comandi > Tema jQuery Mobile > Anteprima tema.
  • Per esportare un tema mobile come sprite e CSS, selezionate Comandi > tema jQuery Mobile > Esporta tema.
  • Per visualizzare in anteprima il tema, selezionate Finestra > Estensioni > Anteprima In-App tema jQuery Mobile.
  • Per aggiungere un segnaposto di icona, selezionate Tema jQuery Mobile > Inserisci segnaposto icona.

Per ulteriori informazioni, consultare Creare i temi jQuery Mobile utilizzando Fireworks CS6.

Miglioramenti alle prestazioni

  • Per correggere il problema di memoria insufficiente, l’uso degli oggetti GDI da parte di Fireworks è stato ottimizzato.
  • Il limite di utilizzo della memoria è stato aumentato sui computer Windows a 64 bit per migliorare la stabilità durante l’apertura e il salvataggio di file di grandi dimensioni.
  • In Mac OS, è stata migliorata la frequenza di aggiornamento della finestra di ispezione Proprietà quando si passa da un oggetto all’altro.

Impostare opacità separatamente per riempimento e tratto

  1. Selezionate l’oggetto e scegliete il selettore dei colori tratto o riempimento. In alternativa, selezionate il selettore dei colori tratto o riempimento nella barra degli strumenti.
  2. Fate clic sul dispositivo di scorrimento Opacità.
  3. Trascinate il cursore sul valore desiderato.
    In Mac OS, digitate il valore nella casella di testo.

Video

Supporto Alpha nel riempimento e nel tratto (00:02:50)

Panoramica del supporto Alpha per il riempimento e il tratto che mostra i risparmi e la versatilità creativa offerti da questa nuova funzione.

Di Patrick Foster

Miglioramento della selezione del colore

  • Utilizzate i pulsanti per specificare opzioni tipo di riempimento specifiche quali nessun riempimento, uniforme, gradiente e modelli nella finestra di ispezione Proprietà e nella barra degli strumenti. In precedenza, queste opzioni erano gestite mediante menu a discesa.
  • È possibile ora specificare la posizione del tratto (interno, al centro, esterno) mediante la finestra di dialogo Traccia.

Video

Accesso più rapido al colore (00:03:02)

Scoprite i vantaggi del nuovo pannello Colore migliorato, con le novità in termini di opacità del riempimento/tratto, gradienti e funzione taglia e incolla delle informazioni per il colore esadecimale e RGB.

Di Patrick Foster

Impostare l’angolo per i riempimenti a motivo o sfumatura

  1. Selezionate l’oggetto.
  2. Nella finestra di ispezione Proprietà, selezionate il riempimento a motivo o sfumatura.
  3. Nella finestra di dialogo Modifica gradiente o Modifica motivo, specificate il valore dell’angolo.

Nuova estensione del nome file fw.png

Quando salvate un file, esso viene salvato con l’estensione fw.png per impostazione predefinita.

Per modificare il comportamento predefinito, selezionate Modifica > Preferenze. Nella scheda Generale della finestra di dialogo Preferenze, deselezionate Append.fw.png e fate clic su OK.

Potete anche eliminare questa estensione nella finestra di dialogo Salva con nome.

Miglioramenti vari

  • Miglioramenti al pannello Stili.
  • Il nodo posizione per l’interruzione di colore nello strumento Gradiente è evidenziato.
  • Con lo strumento Contagocce potete copiare, riempire e tratteggiare con il colore.
    Selezionate lo strumento Contagocce, fate clic con il pulsante destro del mouse sull’oggetto e selezionate l’opzione desiderata.
  • Potete ora individuare il modello predefinito di Fireworks e i simboli della libreria comune nella directory Utenti.
    Se un simbolo della libreria comune viene eliminato, una nuova copia del simbolo viene creata quando si riavvia Fireworks.
  • Il nome e il livello zoom dell’oggetto selezionato ora non vengono visualizzati nella barra del titolo del documento. Queste informazioni sono disponibili nel pannello Livelli e nella barra dell’applicazione.
  • Aggiornamenti al pannello del percorso e ai campioni.
  • In Mac OS, è possibile ora vedere in anteprima i file in Google Chrome.
  • L’opzione Tracciato, che consente di accedere rapidamente a molti comandi relativi al tracciato, viene fornito nel menu Finestra.
  • L’opzione Raggruppa come maschera viene fornita con il menu di scelta rapida.
  • L’impostazione di ottimizzazione predefinita per un nuovo file è PNG32.
  • Funzioni obsolete:
    • Esportazione di AIR
    • Creare una presentazione
    • Interfaccia Flex
    • Device Central
    • Condividi schermo
  • È ora possibile bloccare vincoli per lo strumento taglierina utilizzando la finestra di ispezione Proprietà.
  • Icone miniature per oggetti nel pannello Livelli.
  • Le seguenti risorse ora sono disponibili nella libreria comune: gesto, icone, iPhone, jQuery Bootstrap, Wireframe, Wireframe-Ads, Wireframe-iPad, Wireframe-iPhone e Wireframe Windows Phone 7.
  • La libreria di stili è stata aggiornata con le seguenti categorie: stili simboli per i pulsanti, motivi di progettazione di riempimento, punti colore tratto e stili di pulsanti Web.
  • Le descrizioni comandi sono ora disponibili per l’operazione di importazione file.
  • Quando un simbolo viene salvato nella libreria comune, viene conservato nell’area di lavoro.
  • Altre opzioni sono ora disponibili per modelli e texture.
  • All’interno della finestra di dialogo Riempimento gradiente, utilizzate CTRL+tasto freccia sinistra o CTRL+tasto freccia destra per navigare tra le interruzioni di colore e le interruzioni di opacità. In Mac OS, utilizzate Comando + tasto freccia sinistra o Comando + tasto freccia destra.
  • Le librerie vengono aggiornate con più modelli e texture.

Miglioramenti della API

Nuovi metodi

  • fw.appTemplatesDir: restituisce il percorso della directory del modello.
  • fw.commonLibraryDir: restituisce il percorso della directory della libreria comune.
  • fw.activeTool: accerta che lo strumento attivo sia lo strumento specificato.
    Ad esempio, utilizzate if (fw.activeTool==Tools.pen) per accertare se lo strumento attivo è lo strumento Penna. Questo metodo non dipende dal nome dello strumento nella lingua di localizzazione.
  • fw.appPatternsDir: restituisce il percorso della directory Motivi.
  • fw.appTexturesDir: restituisce il percorso della directory Texture.
  • fw.reloadPatterns: ricarica i motivi dalla directory Motivi.
  • fw.reloadTextures: ricarica la texture dalla directory Texture.
  • dom.updateSymbol: aggiorna il simbolo importato dalla libreria comune.

Metodi aggiornati

  • fw.browseForFileURL(browseType, title, previewArea, startFolder): un nuovo parametro opzionale, startFolder, specifica la directory principale della finestra di dialogo Sfoglia.
  • fw.setDocumentImageSize(boundingRectangle, resolution, currentPageOnly, interpolationMethod): un nuovo parametro opzionale, interpolationMethod, prende i valori interi da 1 a 4 specificando rispettivamente bicubico, bilineare, morbido e vicino più vicino.
  • fw.saveAs(doc, url, defaultFromOptions): il valore predefinito per il parametro defaultFromOptions è stato modificato in false. Se è impostato su true, il file viene salvato con le impostazioni di ottimizzazione correnti.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online