Iniziate a usare Adobe Muse. Imparate a conoscere i file .muse, impostare le proprietà di pagina, aggiungere le icone preferiti e altro ancora.

Nota:

Non verranno più aggiunte ulteriori funzioni ad Adobe Muse, e il supporto verrà sospeso a partire dal giovedì 26 marzo 2020. Per ulteriori informazioni e assistenza, consultate la pagina dedicata alla fine del ciclo di vita di Adobe Muse.

Guida introduttiva ad Adobe Muse

Dopo l’accesso, viene aperta l’area di lavoro in cui potete visualizzare la schermata introduttiva di Adobe Muse. Effettuate una delle seguenti operazioni:

  • Fate clic su Crea nuovo per creare un nuovo sito.
  • Fate clic su Apri e caricate un file .muse esistente dal computer in uso.
Schermata iniziale di Adobe Muse
Dalla schermata introduttiva, create un nuovo sito.

Quando create un nuovo sito, si apre la finestra di dialogo Nuovo sito. Selezionate Larghezza fluida per abilitare il layout dinamico o selezionate Larghezza fissa per scegliere il layout alternativo. Questa finestra contiene i campi che consentono di impostare la larghezza massima della pagina, le colonne e il valore impostato per la distanza tra colonne.

Finestra di dialogo Nuovo sito per creare un nuovo sito Web.
Selezionate File > Nuovo sito per creare un nuovo sito.

Fate clic su Impostazioni avanzate per impostare dimensioni, margini, colonne e valori di spaziatura per il sito (con valori numerici, in pixel). Potete anche scegliere la Risoluzione e la Lingua da questa finestra.

In un secondo momento, potete modificare queste impostazioni scegliendo File > Proprietà sito.

Finestra di dialogo Proprietà sito per impostare le proprietà del sito.
Impostate le proprietà del sito nella finestra di dialogo Nuovo sito.

Al termine, fate clic su OK per chiudere la finestra di dialogo.

Per impostazione predefinita, si apre la vista Pianificazione con due elementi già creati. La pagina Home in alto a sinistra è la pagina che viene inizialmente caricata quando un utente visualizza il sito pubblicato. La pagina A-Mastro qui sotto funge da modello. Potete inserire nella pagina A-Mastro tutti gli elementi che devono comparire su tutte le pagine del sito. In questo modo, sarà possibile aggiornare gli elementi comuni del sito da una singola posizione centrale.

NewWebsite
Adobe Muse genera automaticamente una pagina Home e una pagina mastro.

Lungo il bordo superiore, sono presenti quattro collegamenti per le diverse sezioni dell’interfaccia: Pianificazione, Progettazione e Pubblicazione.

Per informazioni sull’uso dell’interfaccia e su come progettare un sito con Adobe Muse, consultate la Guida introduttiva ad Adobe Muse e Creazione del primo sito Web con Adobe Muse.

I file .muse

Quando progettate i siti Web in altre applicazioni, come ad esempio Dreamweaver, create sul computer una cartella contenente le sottocartelle e i file con tutto il contenuto del sito. Può essere difficile gestire un intero set di elementi e accertarsi che tutti i collegamenti funzionino correttamente nel sito.

Quando create un nuovo sito in Adobe Muse e scegliete File > Salva, viene creato un singolo file .muse. Si tratta di una situazione analoga alla creazione di un file PSD in Photoshop, che può contenere numerosi livelli, elementi grafici e risorse collegate. Questo singolo file .muse è l’unico file di cui avrete bisogno per progettare un sito, poiché contiene tutte le immagini, tutti i collegamenti, tutto il codice e tutti i file del sito. Se desiderate collaborare con un altro utente, potete inviare al collega una copia del file .muse che avete creato, in modo che possa aprirlo, apportarvi delle modifiche e pubblicare le modifiche aggiunte.

In genere, è meglio consentire a una sola persona alla volta di lavorare su un file .muse. Dopo aver aggiunto il contenuto sul sito, potete pubblicarlo e inviare a un collega il file .muse, in modo che possa modificarlo e aggiungervi ulteriori contenuti. Al termine, potrà inviarvi di nuovo il file .muse aggiornato con le sue modifiche. In questo modo potrete evitare di sovrascrivere accidentalmente il lavoro degli altri.

In alternativa, potete creare un file .muse e pubblicare un sito temporaneo. Quindi, condividete il file .muse con i vostri colleghi. Possono aprirlo, scegliere File > Salva con nome, apportare delle modifiche alla copia e pubblicare un proprio sito temporaneo, mentre voi continuate a lavorare sul file originale. Tuttavia, se seguite questo flusso di lavoro, le due iterazioni del sito non saranno sincronizzate: la vostra versione del file .muse non verrà aggiornata con le modifiche apportate dai vostri colleghi, e viceversa.

Ogni volta che intendete apportare delle modifiche importanti a un sito Web esistente, aprite sempre il file .muse e scegliete File > Salva con nome. Create quindi un nuovo file .muse con un nome file leggermente diverso e mantenete tutti i file .muse in una singola cartella sul computer. In questo modo, se il cliente preferisce una precedente versione del sito, potrete aprire il file .muse corrispondente e ripubblicarlo per ripristinare tale versione del sito.

È inoltre consigliabile salvare spesso il file .muse. Nel caso in cui Adobe Muse si bloccasse, al riavvio viene in genere presentata la versione ripristinata del file .muse con le ultime modifiche. Se ciò dovesse accadere, salvate la versione ripristinata del file .muse e riprendete a lavorare su di essa. Accertatevi che il file .muse creato venga salvato in un luogo sicuro ed effettuatene una copia di backup, perché ciascun file contiene un intero sito Web. Se perdete un file .muse e non ne possedete una copia di backup, non sarà possibile ricostruire il file .muse scaricando i file del sito che si trovano sul server.

Molti designer Web preferiscono salvare i file .muse con nomi descrittivi, ad esempio sito_v1.muse e sito_v2.muse. Potete anche aggiungere la data al nome del file .muse in modo da individuare facilmente le versioni precedenti, ad esempio sito_2012-4-13.muse e sito_2012-4-30.muse. Potete nominare i file nel modo che ritenete più utile.

Impostazione delle proprietà del sito durante la creazione di un nuovo sito in Adobe Muse

Per creare un nuovo sito e definire le proprietà del sito, effettuate le seguenti operazioni:

  1. Nella schermata introduttiva, scegliete Crea nuovo > Sito. Fate clic su Larghezza fluida per il layout dinamico, o su Larghezza fissa per il layout alternativo.

  2. Nella finestra di dialogo Nuovo sito, impostate Larghezza pagina su 950 e Altezza minima su 800. Impostate le colonne su 3 e la distanza su 20. Nell’area Margini, impostate tutti e quattro i valori su 50. Impostate i valori di spaziatura su 36.

    Impostate gli attributi del sito nella finestra di dialogo Proprietà sito.
    Per impostare gli attributi del sito, digitate i valori direttamente nei campi oppure fate clic sui pulsanti freccia di ciascuna impostazione.

    Nota:

    Se state creando un sito per smartphone e tablet, l’opzione “Reindirizza da Desktop” consente di attivare o disattivare il reindirizzamento per i layout per dispositivi mobili. Questa funzione è utile per i layout che non sono ancora pronti e non devono quindi essere reindirizzati (lavoro in corso). Anche se il reindirizzamento è disattivato, il layout verrà comunque esportato. Tuttavia i browser per dispositivi mobili non applicheranno il reindirizzamento alle pagine mobili e i file esportati non verranno inclusi nel file sitemap.xml finché questa opzione non sarà stata attivata nella finestra di dialogo Proprietà sito.

  3. Fate clic su OK per salvare le impostazioni e chiudere la finestra di dialogo.

  4. Scegliete File > Proprietà sito. Fate clic sull’icona cartella accanto a Immagine per icona preferiti. Individuate la cartella dei file di esempio Kevins_Koffee_Kart e selezionate il file favicon.png. Fate clic su OK.

    fig_07
    Le icone “preferiti” sono le icone che vengono visualizzate nel browser accanto all’URL del sito, nella barra degli indirizzi.

  5. Scegliete File > Salva. Assegnate un nome univoco al nuovo sito, ad esempio NomeKoffeeKart.muse. Il sito campione in questa esercitazione si chiama 01KevinsKoffeeKart.muse.

Aggiungere un’icona preferiti nel pannello Proprietà sito

L’icona preferiti è una piccola immagine quadrata che viene creata e aggiunta al sito e viene caricata per personalizzare i segnalibri e l’URL. Il comportamento dell’icona preferiti varia da browser a browser, ma in genere viene visualizzata nella barra dell’indirizzo del browser, accanto all’URL visualizzato. In molti casi viene anche visualizzata nel segnalibro accanto al nome della pagina oppure nella scheda contenente la pagina caricata. Potete creare un file immagine quadrato da usare come icona preferiti con qualsiasi programma per la modifica di immagini, come Photoshop o Illustrator. Per questa esercitazione, è stato fornito un file PNG.

Per aggiungere al sito un’icona preferiti, effettuate le seguenti operazioni:

  1. Scegliete File > Proprietà sito. Viene aperta la finestra di dialogo Proprietà sito.

  2. Nella scheda Contenuto, fate clic sull'icona della cartella a destra della sezione Icona preferiti. Nella finestra di dialogo Scegliete un’immagine per l’icona preferiti, passate alla cartella dei file di esempio e selezionate il file favicon.png.

    Favicon
    Impostate il file favicon.png in Proprietà del sito.

    Nota:

    Se utilizzate Adobe Muse 2015.0.2 o versioni precedenti, è possibile aggiungere un’icona per il sito, scegliendo File > Proprietà sito e selezionando la scheda Layout.

  3. Fate clic su Apri per selezionare il file e chiudere la finestra di dialogo Scegliete un’immagine per l’icona preferiti. Quindi, fate clic su OK per chiudere la finestra di dialogo Proprietà sito.

  4. Scegliete File > Anteprima sito nel browser. Potete vedere l’icona preferiti nella barra dell’indirizzo nella parte superiore della finestra del browser e, se il sito è stato caricato in una scheda, anche nel titolo della scheda. Provate ad aggiungere un segnalibro per la pagina: l’icona viene visualizzata accanto al nome della pagina nell’elenco dei segnalibri.

    Il sito è ora finalizzato e il passaggio successivo prevede il caricamento del sito sui server di hosting Adobe Business Catalyst.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online