사용 안내서 취소

마스크 만들기

  1. After Effects 사용 안내서
  2. Beta 릴리스
    1. Beta 프로그램 개요
    2. After Effects Beta 홈
  3. 시작하기
    1. After Effects 시작하기
    2. After Effects의 새로운 기능 
    3. 릴리스 정보 | After Effects
    4. After Effects 시스템 요구 사항
    5. After Effects 키보드 단축키
    6. 지원하는 파일 형식 | After Effects
    7. 하드웨어 권장 사항
    8. Apple Silicon용 After Effects
    9. 계획 및 설정
  4. 작업 영역
    1. 일반 사용자 인터페이스 항목
    2. After Effects 인터페이스 알아보기
    3. 워크플로우
    4. 작업 영역, 패널, 뷰어
  5. 프로젝트 및 컴포지션
    1. 프로젝트
    2. 컴포지션 기본 사항
    3. 사전 구성, 중첩, 사전 렌더링
    4. 컴포지션 프로파일러를 사용하여 자세한 성능 정보 보기
    5. Cinema 4D 컴포지션 렌더러
  6. 푸티지 가져오기
    1. 스틸 이미지 준비 및 가져오기
    2. After Effects 및 Adobe Premiere Pro에서 가져오기
    3. 비디오와 오디오 가져오기 및 해석
    4. 3D 이미지 파일 준비 및 가져오기
    5. 푸티지 항목 가져오기 및 해석
    6. 푸티지 항목을 사용한 작업
    7. [장면 편집 감지]를 사용하여 편집 지점 감지
    8. XMP 메타데이터
  7. 텍스트 및 그래픽
    1. 텍스트
      1. 문자 서식 지정 및 문자 패널
      2. 텍스트 효과
      3. 텍스트 레이어 만들기 및 편집
      4. 단락 서식 지정 및 단락 패널
      5. 돌출 텍스트 및 모양 레이어
      6. 텍스트에 애니메이션 적용
      7. 텍스트 애니메이션 예제 및 리소스
      8. 라이브 텍스트 템플릿
    2. 모션 그래픽
      1. After Effects에서 모션 그래픽 템플릿을 사용해 작업하기
      2. 표현식을 사용하여 모션 그래픽 템플릿에 드롭다운 목록 만들기
      3. 기본 속성으로 모션 그래픽 템플릿 만들기
      4. 모션 그래픽 템플릿에서 이미지와 비디오 바꾸기 및 기본 속성
      5. 속성 패널로 보다 빠르고 간편해진 애니메이션 작업
  8. 그리기, 페인트, 패스
    1. 모양 레이어, 패스, 벡터 그래픽 개요
    2. 페인트 도구: 브러쉬, 복제 도장, 지우개
    3. 테이퍼 모양 선
    4. 모양 레이어의 모양 속성, 페인트 작업, 패스 작업
    5. 오프셋 패스 모양 효과를 통한 모양 변경
    6. 모양 만들기
    7. 마스크 만들기
    8. 내용 인식 채우기 패널로 비디오에서 개체 제거
    9. 로토 브러시와 매트 다듬기
  9. 레이어, 마커, 카메라
    1. 레이어 선택 및 정렬
    2. 혼합 모드와 레이어 스타일
    3. 3D 레이어
    4. 레이어 속성
    5. 레이어 만들기
    6. 레이어 관리
    7. 레이어 마커와 컴포지션 마커
    8. 카메라, 조명 및 관심 영역
  10. 애니메이션, 키프레임, 동작 추적, 키잉
    1. 애니메이션
      1. 애니메이션 기본 사항
      2. 퍼펫 도구를 사용한 애니메이션
      3. 모양 패스와 마스크를 관리하고 애니메이션을 적용하기
      4. After Effects를 사용하여 스케치 및 캡처 모양에 애니메이션 적용하기
      5. 종합 애니메이션 도구
      6. 데이터 기반 애니메이션 작업
    2. 키프레임
      1. 키프레임 보간
      2. 키프레임 설정, 선택 및 삭제
      3. 키프레임 편집, 이동 및 복사
    3. 동작 추적
      1. 동작 추적 및 안정화
      2. 얼굴 추적
      3. 마스크 추적
      4. 마스크 참조
      5. 속도
      6. 시간 스트레치와 시간 다시 매핑
      7. 시간 코드 및 시간 표시 단위
    4. 키잉
      1. 키잉
      2. 키잉 효과
  11. 투명도 및 합성
    1. 합성과 투명도 개요 및 리소스
    2. 알파 채널 및 마스크
    3. 트랙 매트와 이동하는 매트
  12. 색상 조정
    1. 색상 기본 사항
    2. 색상 관리
    3. 색상 교정 효과
    4. OpenColorIO 및 ACE 색상 관리
  13. 효과 및 애니메이션 사전 설정
    1. 효과 및 애니메이션 사전 설정 개요
    2. 효과 목록
    3. 효과 관리자
    4. 시뮬레이션 효과
    5. 스타일화 효과
    6. 오디오 효과
    7. 왜곡 효과
    8. 원근 효과
    9. 채널 효과
    10. 생성 효과
    11. 전환 효과
    12. 롤링 셔터 복구 효과
    13. 흐림 및 선명 효과
    14. 3D 채널 효과
    15. 유틸리티 효과
    16. 매트 효과
    17. 노이즈 및 그레인 효과
    18. 세부 사항-확대 유지 효과
    19. 더 이상 사용되지 않는 효과
  14. 표현식 및 자동화
    1. 표현식
      1. 표현식 기본 사항
      2. 표현식 언어 이해
      3. 표현식 컨트롤 사용
      4. JavaScript와 레거시 ExtendScript 표현식 엔진 간 구문 차이
      5. 표현식 편집
      6. 표현식 오류
      7. 표현식 편집기 사용
      8. 표현식을 사용하여 텍스트 속성 편집 및 액세스
      9. 표현식 언어 참조
      10. 표현식 예제
    2. 자동화
      1. 자동화
      2. 스크립트
  15. 몰입형 비디오, VR 및 3D
    1. After Effects에서 VR 환경 만들기
    2. 몰입형 비디오 효과 적용
    3. VR/360 비디오용 합성 툴
    4. 고급 3D 렌더러
    5. 컴포지션에 3D 모델 가져오기 및 추가
    6. Creative Cloud Libraries에서 3D 모델 가져오기
    7. 이미지 기반 조명
    8. 3D 모델에서 조명과 카메라 추출 및 애니메이션 적용
    9. 3D 카메라 움직임 추적
    10. 그림자 표시 및 허용
    11. 포함된 3D 모델 애니메이션
    12. 그림자 캐처
    13. 3D 심도 데이터 추출
    14. 3D 레이어의 질감 속성 수정
    15. 3D 디자인 공간에서 작업하기
    16. 3D 변형 기즈모
    17. 3D 애니메이션을 사용하여 더 많은 작업 수행
    18. Mercury 3D 엔진으로 3D 디자인 변경 사항 실시간 미리 보기
    19. 그래픽에 반응형 디자인 추가 
  16. 보기 및 미리 보기
    1. 미리 보기
    2. Mercury Transmit를 사용한 비디오 미리 보기
    3. 보기 수정 및 사용
  17. 렌더링 및 내보내기
    1. 렌더링 및 내보내기 기본 사항
    2. After Effects의 H.264 인코딩
    3. After Effects 프로젝트를 Adobe Premiere Pro 프로젝트로 내보내기
    4. 동영상 변환
    5. 멀티 프레임 렌더링
    6. 자동 렌더링 및 네트워크 렌더링
    7. 스틸 이미지와 스틸 이미지 시퀀스 렌더링 및 내보내기
    8. After Effects에서 GoPro CineForm 코덱 사용
  18. 기타 애플리케이션으로 작업
    1. Dynamic Link 및 After Effects
    2. After Effects 및 기타 애플리케이션으로 작업
    3. After Effects의 설정 동기화
    4. After Effects의 Creative Cloud Libraries
    5. 플러그인
    6. Cinema 4D 및 Cineware
  19. 공동 작업: Frame.io, Team Projects
    1. Premiere Pro 및 After Effects의 공동 작업
    2. Frame.io
      1. Frame.io 설치 및 활성화
      2. Premiere Pro 및 After Effects에서 Frame.io 사용
      3. 자주 묻는 질문
    3. Team Projects
      1. Team Projects 시작 하기
      2. 팀 프로젝트 만들기
      3. Team Projects 공동 작업
  20. 메모리, 저장소, 성능
    1. 메모리 및 저장소
    2. After Effects가 미리 보기 시 메모리 부족 문제를 처리하는 방식
    3. 성능 향상
    4. 환경 설정
    5. After Effects의 GPU 및 GPU 드라이버 요구 사항
  21. 기술 자료
    1. 알려진 문제
    2. 해결한 문제
    3. 자주 묻는 질문
    4. After Effects 및 macOS Ventura
    5. 미리 보기를 하는 동안 After Effects에서 메모리 부족 문제를 처리하는 방법

After Effects에서 사각형 도구를 사용하여 모양 및 마스크를 만들 수 있습니다. 마스크나 모양 레이어를 만들 때는 다음 사항에 주의해야 합니다.

  • 타임라인 패널에서 레이어를 선택한 상태인 경우 마스크를 만듭니다.
  • 타임라인 패널에서 레이어를 선택하지 않은 상태인 경우 모양 레이어를 만듭니다. After Effects에서 모양 만들기를 참조하세요.
참고:

모양 도구의 단축키는 Q, 도구의 단축키는 G입니다.

마스크 만들기

다음 방법 중 하나를 사용하여 컴포지션에 있는 레이어마다 하나 이상의 마스크를 만들 수 있습니다.

 

모양 또는 도구를 사용하여 패스를 그립니다. 마스크 패스 그리기는 모양 패스 그리기와 유사합니다.

모양 도구로 드래그하여 모양 또는 마스크 만들기펜 도구를 사용하여 베지어 모양 또는 마스크 만들기를 참조하세요.

마스크 모양 대화 상자에서 마스크 패스의 차원을 숫자로 지정할 수 있습니다.

자세한 내용은 숫자를 사용하여 사각형 또는 원형 마스크 만들기를 참조하세요.

 

모양 패스를 마스크 패스로 변환하려면 모양의 패스를 마스크 패스 속성에 복사합니다.

 

[자동 추적] 명령을 사용하여 마스크를 만들기 위해 색상 또는 알파 채널의 값을 추적합니다.

자세한 내용은 자동 추적을 사용하여 채널로 마스크 만들기를 참조하세요.

 

동작 패스를 마스크 패스로 변환합니다.

동작 패스로 마스크 또는 모양 만들기를 참조하세요.

 

다른 레이어나 Adobe Illustrator 또는 Photoshop에서 복사한 패스를 붙여넣습니다.

Illustrator 또는 Photoshop에서 패스 복사를 참조하세요.

텍스트로 마스크 만들기 명령을 사용하여 텍스트 레이어를 단일 단색 레이어에 있으며 편집할 수 있는 하나 이상의 마스크로 변환합니다.

자세한 내용은 텍스트 문자로 모양 또는 마스크 만들기를 참조하세요.

캡처한 모양을 사용하여 모션 그래픽 생성.

자세한 내용은 캡처한 모양을 사용하여 모션 그래픽 만들기를 참조하세요.

유의해야 할 핵심 사항

  • 레이어에 마스크를 만들면 타임라인 패널 개요에 마스크를 만든 순서대로 마스크 이름이 나타납니다. 마스크를 구성하고 추적하려면 마스크 이름을 바꿉니다.
  • 마스크의 이름을 변경하려면 해당 마스크를 선택하고 Enter(Windows) 또는 Return(macOS) 키를 누르거나, 마스크 이름을 마우스 오른쪽 버튼으로 클릭(Windows) 또는 control+클릭(macOS)하고 이름 바꾸기를 선택합니다.
  • 레이어 패널의 한 레이어에 추가 마스크를 만드는 경우 레이어 패널의 대상 메뉴가 없음으로 설정되어 있는지 확인합니다. 그렇지 않으면 마스크를 만드는 것이 아니라 대상으로 지정되어 있는 마스크를 바꾸게 됩니다. 변경하지 못하도록 마스크를 잠글 수도 있습니다.
  • 마스크를 만들거나 편집할 때 [정보] 패널에서 마스크 이름 및 마스크에 있는 정점 개수와 같은 정보를 확인할 수 있습니다.
참고:

마스크하는 기본 레이어와 관계없이 이동할 수 있는 마스크를 만들려면 다음을 수행합니다.

  1. 별도의 흰색 단색 레이어에 마스크를 만들고, 그 단색 레이어를 기본 레이어의 트랙 매트로 사용합니다.
  2. 부모/자식 관리를 사용하여 단색 레이어를 기본 레이어의 자식으로 설정하면 마스크가 마치 기본 레이어에 직접 적용한 것처럼 기본 레이어와 함께 이동합니다. 단색 레이어는 자식 레이어이므로 부모와 관계없이 애니메이션을 적용할 수도 있습니다.
  3. 동작 추적 기능을 사용하여 단색 레이어(마스크 포함)가 기본 레이어의 움직이는 개체를 따르도록 할 수 있습니다. 레이어를 트랙 매트로 변환하기부모와 자식 레이어를 참조하세요.

모양 도구로 드래그하여 마스크 만들기

모양 도구는 사각형 , 둥근 사각형 , 타원 , 다각형 , 도구입니다.

참고:

모양 도구를 활성화하고 여러 도구 사이를 순환 변경하려면 Q 키를 누릅니다.

다각형은 내부 반경 또는 내부 원형률 속성이 없는 별입니다. 따라서 다각형이나 별로 만든 모양의 이름은 다각형 별로 같습니다.

컴포지션 또는 레이어 패널에서 모양 도구로 드래그하여 선택한 레이어에 마스크를 만들 수 있습니다.

참고:

모양 레이어에 마스크를 그리려면 모양 도구를 활성화한 상태로 도구 패널에서 도구로 마스크 만들기 버튼을 선택합니다.

자세한 내용은 모양 도구를 드래그하여 모양을 만드는 방법을 참조하세요.

숫자를 사용하여 사각형 또는 원형 마스크 만들기

타원형 또는 사각형 마스크 만들기

  1. 컴포지션 패널에서 레이어를 선택하거나 레이어 패널에서 레이어를 표시합니다.

  2. 레이어 > 마스크 > 새 마스크를 선택합니다. 컴포지션 또는 레이어 패널에 새 마스크가 나타나고 프레임의 바깥쪽 테두리에 마스크 핸들이 나타납니다.

  3. 레이어 > 마스크 > 마스크 모양을 선택합니다.

  4. 다음으로 다시 설정을 선택하고, 모양 메뉴에서 사각형 또는 타원을 선택하고, 마스크 테두리 상자의 크기 및 위치를 지정합니다.

자동 추적을 사용하여 채널에서 마스크 만들기

  1. 자동 추적 명령을 사용하여 레이어의 알파, 빨강, 녹색, 파랑 또는 광도 채널을 하나 이상의 마스크로 변환할 수 있습니다.
  2. 자동 추적은 레이어에서 지정된 채널 값을 윤곽선으로 만드는 데 필요한 수만큼 베지어 마스크를 만듭니다.
  3. 또한 자동 추적은 선택한 설정에 부합하면서 가장 적은 개수의 정점으로 마스크를 만듭니다.
  4. 다른 모든 마스크와 마찬가지로 자동 추적으로 만든 마스크도 수정할 수 있으며, 표현식을 사용하여 해당 패스를 모양 레이어에 있는 모양 패스와 같은 다른 패스 유형에 연결할 수 있습니다.

[자동 추적]을 적용하면 영향을 받는 레이어가 최고 품질로 자동 설정되어 정확한 결과를 얻게 됩니다.

참고:

자동 추적으로 만들어지는 마스크의 수를 줄이려면 자동 추적을 적용하기 전에 키잉 효과를 레이어에 적용하여 대상을 격리합니다.

  1. 타임라인 패널에서 다음 중 하나를 수행합니다.

    • 단일 프레임에 마스크 키프레임을 만들려면 현재 시간 표시기를 원하는 프레임으로 드래그합니다.
    • 여러 프레임에 마스크 키프레임을 만들려면 해당 범위를 포함하는 작업 영역을 설정합니다.
  2. 하나 이상의 레이어를 선택하고 레이어 > 자동 추적을 선택합니다.

  3. 다음 중 하나를 선택합니다.

    현재 프레임

    현재 프레임에만 마스크 키프레임을 만듭니다.

    작업 영역

    작업 영역 내의 프레임에 대해 마스크 키프레임을 만듭니다.

    완료하면 다음 옵션 중 하나를 선택합니다.

반전: 가장자리를 검색하기 전에 입력 레이어를 반전합니다.

흐림 효과: 추적 결과를 생성하기 전에 원본 이미지를 흐리게 합니다. 작은 아티팩트를 줄이고 들쭉날쭉한 가장자리를 매끄럽게 하려면 이 옵션을 사용합니다. 이 옵션의 선택을 해제하면 고대비 이미지의 세부 정보를 면밀하게 추적합니다.

허용치: 추적된 패스가 채널 윤곽선에서 벗어날 수 있는 거리(픽셀)입니다.

임계값: 픽셀을 테두리의 일부로 간주하려면 해당 픽셀의 채널이 가져야 하는 값(백분율)을 지정합니다. 채널 값이 임계값을 초과하는 픽셀은 흰색에 매핑되고 불투명합니다. 채널 값이 임계값 미만인 픽셀은 검정에 매핑되고 투명합니다.

최소 영역: 원본 이미지에서 추적할 가장 작은 형태를 지정합니다. 예를 들어 4의 값을 지정하면 2픽셀(폭) x 2픽셀(높이)보다 작은 기능이 추적 결과에서 제거됩니다.

가장자리 원형률: 정점에서의 마스크 곡선 원형률을 지정합니다. 입력하는 값이 높을수록 곡선이 매끄러워집니다.

새 레이어에 적용:선택한 레이어와 같은 크기인 새 단색에 마스크를 적용합니다. [변형 축소]를 활성화한 레이어에 대해 자동으로 선택됩니다.

미리 보기: [자동 추적] 명령의 여러 옵션에 대한 결과 및 마스크 결과를 미리 보려면 선택합니다.

레이어 크기의 마스크 만들기

  1. 새 마스크의 대상을 선택합니다.

    • 마스크를 만들려면 타임라인, 레이어, 또는 컴포지션패널에서 레이어를 선택합니다. 모양 레이어에 마스크를 만들려면 모양 도구를 활성화한 상태로 도구 패널에서 도구로 마스크 만들기를 선택합니다.
    • 마스크 패스를 바꾸려면 타임라인, 레이어, 또는 컴포지션 패널에서 마스크를 선택합니다.
  2. 도구 패널에서 사각형 , 둥근 사각형, 타원 , 다각형 또는 도구를 두 번 클릭합니다.

텍스트 문자로 마스크 만들기

텍스트로 모양 만들기 명령은 각 문자의 윤곽선을 추출하고 윤곽선에서 모양을 만들어 새 모양 레이어에 배치합니다. 이렇게 만든 모양은 다른 모양과 똑같이 사용할 수 있습니다.

텍스트로 마스크 만들기 명령은 각 문자의 윤곽선을 추출하고 윤곽선에서 마스크를 만들어 새 단색 레이어에 배치합니다. 이렇게 만든 마스크는 다른 마스크와 똑같이 사용할 수 있습니다.

텍스트로 모양 만들기

  1. 마스크로 변환할 텍스트를 선택합니다.
    • 텍스트 레이어에 있는 모든 문자의 마스크를 만들려면 타임라인 패널 또는 컴포지션 패널에서 텍스트 레이어를 선택합니다.
    • 특정 문자의 마스크를 만들려면 컴포지션 패널에서 문자를 선택합니다.
  2. 다음 중 하나를 수행합니다.
    • 레이어 > 텍스트로 마스크 만들기를 선택합니다.
    • 레이어 또는 텍스트를 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Mac OS)하고 컨텍스트 메뉴에서 텍스트로 마스크 만들기를 선택합니다.

참고 사항

  • 텍스트 레이어의 비디오 스위치가 꺼집니다.
  • 레이어 겹침 순서 맨 위에 새 단색 레이어가 만들어집니다.
  • ie와 같이 복합 패스로 구성되는 문자의 경우 여러 마스크가 만들어져 [빼기] 마스크 모드와 결합됩니다.

동작 패스에서 마스크 만들기

위치 키프레임, 기준점 키프레임 또는 효과 조절점 위치 키프레임을 복사하여 선택한 마스크 패스나 모양 패스에 붙여넣을 수 있습니다. 동작 패스로 마스크 패스나 모양 패스를 만들 때는 단일 [위치] 속성에서만 키프레임을 복사해야 합니다. 다른 속성의 키프레임은 복사하지 마십시오.

참고:

[동작 스케치]를 사용하여 동작 패스를 그린 다음 해당 패스를 마스크 패스 또는 모양 패스에 붙여넣습니다.

참고:

마스크 패스와 동작 패스 간에 복사하는 경우 마스크 패스의 값은 레이어 좌표계(레이어 공간)에, 동작 패스의 값은 컴포지션 좌표계(컴포지션 공간)에 표현됩니다. 이러한 차이로 인해 붙여넣은 패스가 오프셋되므로 패스를 붙여넣은 후 해당 패스의 위치를 다시 지정해야 합니다. (좌표계: 컴포지션 공간 및 레이어 공간을 참조하십시오.)

동작 패스로 마스크 패스 만들기

  1. 타임라인 패널에서 동작 패스를 복사할 위치 속성 또는 고정점 속성 이름을 클릭합니다. 그러면 모든 키프레임이 선택됩니다. 동작 패스에서 일부 키프레임만 선택하려면 Shift 키를 누른 상태로 클릭합니다.

  2. 편집 > 복사를 선택합니다.

  3. 마스크를 만들려면 마스크를 만들 레이어를 선택하고 레이어 > 마스크 > 새 마스크를 선택합니다.

  4. 타임라인 패널에서 동작 패스의 키프레임을 붙여넣을 마스크의 마스크 패스 속성 이름을 클릭합니다.

  5. 편집 > 붙여넣기를 선택합니다.

 Adobe

쉽고 빠르게 지원 받기

신규 사용자이신가요?

Adobe MAX 2024

Adobe MAX
크리에이티비티 컨퍼런스

10월 14~16일 마이애미 비치 및 온라인

Adobe MAX

크리에이티비티 컨퍼런스

10월 14~16일 마이애미 비치 및 온라인

Adobe MAX 2024

Adobe MAX
크리에이티비티 컨퍼런스

10월 14~16일 마이애미 비치 및 온라인

Adobe MAX

크리에이티비티 컨퍼런스

10월 14~16일 마이애미 비치 및 온라인