Dreamweaver에서 편집 가능한 xml 내용을 불러오기 및 내보내기합니다. 한 사이트에서 다른 사이트로 템플릿 기반 내용을 내보내기하는 방법을 살펴봅니다.

템플릿 기반 문서에는 이름/값 쌍으로 표시된 데이터가 포함되어 있는 것으로 생각할 수 있습니다. 각각의 쌍은 편집 가능 영역의 이름과 내용으로 구성되어 있습니다.

XML 편집기, 텍스트 편집기 또는 데이터베이스 애플리케이션 등 Dreamweaver 외부에서 데이터를 사용하여 작업할 수 있도록 이름-값 쌍을 XML 파일로 내보낼 수 있습니다. 반대로, 적절하게 구조화된 XML 문서가 있다면 XML 문서에서 Dreamweaver 템플릿 기반 문서로 데이터를 불러올 수 있습니다.

XML로 문서 편집 가능 영역 내보내기

  1. 편집 가능 영역이 포함된 템플릿 기반 문서를 엽니다.
  2. [파일] > [내보내기] > [템플릿 데이터를 XML로 내보내기]를 선택합니다.
  3. [표기법] 옵션 중 하나를 선택합니다.
    • 템플릿에 반복 영역이나 템플릿 매개 변수가 포함되어 있으면 [표준 Dreamweaver XML 태그 사용]을 선택합니다.

    • 템플릿에 반복 영역이나 템플릿 매개 변수가 없으면 [편집 가능 영역 이름을 XML 태그로 사용]을 선택합니다.

  4. [확인]을 클릭합니다.
  5. 대화 상자가 나타나면 폴더 위치를 선택하고 XML 파일의 이름을 입력한 다음 [저장]을 클릭합니다.

    문서의 매개 변수 및 편집 가능 영역(반복 영역이나 옵션 영역 내의 편집 가능 영역 포함)으로부터 가져온 자료가 포함된 XML 파일이 생성됩니다. 이 XML 파일에는 원본 템플릿의 이름과 각 템플릿 영역의 이름 및 내용이 포함됩니다.

    참고:

    편집 불가능한 영역의 내용은 XML 파일로 내보낼 수 없습니다.

XML 내용 가져오기

  1. [파일] > [가져오기] > [XML을 템플릿에 가져오기]를 선택합니다.
  2. XML 파일을 선택하고 [열기]를 클릭합니다.

    Dreamweaver는 XML 파일에 지정된 템플릿을 기반으로 새로운 문서를 만듭니다. 문서에 있는 각 편집 가능 영역의 내용이 XML 파일의 데이터로 채워집니다. 결과로 생성된 문서는 새 문서 창에 나타납니다.

    참고:

    XML 파일이 Dreamweaver가 기대하는 방법으로 정확하게 설정되지 않은 경우 데이터를 가져올 수 없습니다. 이 문제를 해결하려면 올바른 구조를 가진 XML 파일이 있도록 Dreamweaver에서 더미 XML 파일을 내보냅니다. 그런 다음 내보낸 XML 파일에 원본 XML 파일의 데이터를 복사합니다. 이렇게 하면 가져올 수 있는 적절한 데이터를 포함하는 올바른 구조의 XML 파일이 생성됩니다.

템플릿 마크업 없이 사이트 내보내기

템플릿 마크업 없이 템플릿 기반 문서를 한 사이트에서 다른 사이트로 내보낼 수 있습니다.

  1. [도구] > [템플릿] > [마크업 없이 내보내기]를 선택합니다.

  2. [폴더] 상자에서 파일을 내보낼 대상 폴더의 파일 경로를 입력하거나 [검색]을 클릭하고 폴더를 선택합니다.

    참고:

    현재 사이트 외부에 있는 폴더를 선택해야 합니다.

  3. 내보낸 템플릿 기반 문서의 XML 버전을 저장하려면 [템플릿 데이터 파일 유지]를 선택합니다.
  4. 이전에 내보낸 파일에 대한 변경 사항을 업데이트하려면 [변경된 파일만 추출]을 선택하고 [확인]을 클릭합니다.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책