디자인 노트 정보

디자인 노트는 파일에 대해 만드는 노트입니다. 디자인 노트는 디자인 노트에 설명된 파일과 관련되어 있지만 별도의 파일에 저장됩니다. [디자인 노트] 아이콘이 [노트] 열에 표시되므로 확장된 파일 패널에서 어느 파일에 디자인 노트가 첨부되어 있는지 확인할 수 있습니다.

디자인 노트를 사용하면 이미지 소스 파일의 이름과 파일 상태에 대한 주석 등 문서와 관련된 기타 파일 정보를 추적할 수 있습니다. 예를 들어 한 사이트에서 다른 사이트로 문서를 복사할 경우 원본 문서가 다른 사이트 폴더에 있다는 주석이 포함된 디자인 노트를 해당 문서에 추가할 수 있습니다.

또한 디자인 노트를 사용하면 특정 가격이나 구성을 어떻게 선택했는지 또는 디자인 결정에 영향을 준 마케팅 요인이 무엇인지에 대한 기록과 같이 보안 상의 이유로 문서에 삽입할 수 없는 민감한 정보를 추적할 수 있습니다.

Adobe® Fireworks® 또는 Flash에서 파일을 열어 다른 형식으로 내보내는 경우 원본 소스 파일 이름이 디자인 노트 파일에 자동으로 저장됩니다. 예를 들어 Fireworks에서 myhouse.png를 열어 myhouse.gif로 내보내는 경우 myhouse.gif.mno라는 이름의 디자인 노트 파일이 생성됩니다. 이 디자인 노트 파일에는 원본 파일 이름이 절대 file: URL로 포함됩니다. 따라서 myhouse.gif의 디자인 노트에는 다음과 같은 행이 포함됩니다.

fw_source="file:///Mydisk/sites/assets/orig/myhouse.png"

이와 비슷하게 Flash 디자인 노트에는 다음과 같은 행이 포함됩니다.

fl_source="file:///Mydisk/sites/assets/orig/myhouse.fla"

참고:

디자인 노트를 공유하려면 동일한 사이트 루트 경로(예: sites/assets/orig)를 정의해야 합니다.

그래픽을 Dreamweaver로 가져오면 디자인 노트 파일이 그래픽과 함께 사이트에 자동으로 복사됩니다. Dreamweaver에서 이미지를 선택하여 Fireworks를 통해 편집하기로 선택한 경우에는 Fireworks에서 원본 파일을 열어 편집할 수 있습니다.

사이트의 디자인 노트 활성화 및 비활성화

디자인 노트는 파일과 관련된 기록이지만 별도의 파일로 저장됩니다. 디자인 노트를 사용하면 이미지 소스 파일 이름과 파일 상태에 대한 주석 등 문서와 관련된 추가적인 파일 정보를 추적할 수 있습니다.

[사이트 정의] 대화 상자의 [디자인 노트] 범주에서 사이트에 대해 디자인 노트를 활성화 및 비활성화합니다. 디자인 노트를 활성화할 때 필요에 따라 다른 사용자와 공유하도록 선택할 수도 있습니다.

  1. [사이트] > [사이트 관리]를 선택합니다.
  2. [사이트 관리] 대화 상자에서 사이트를 선택한 다음 [편집]을 선택합니다.
  3. [사이트 설정] 대화 상자에서 [고급 설정]을 확장하고 [디자인 노트] 범주를 선택합니다.
  4. [디자인 노트 유지]를 선택하여 활성화합니다(비활성화하려면 선택 취소합니다).
  5. 사이트의 로컬 디자인 노트 파일을 모두 삭제하려면 차례로 [정리], [예]를 클릭합니다. 원격 디자인 노트 파일을 삭제하려면 수동으로 삭제해야 합니다.

    참고:

    [디자인 노트 정리] 명령은 MNO(디자인 노트) 파일만 삭제합니다. 이 명령은 _notes 폴더 또는 _notes 폴더 내의 dwsync.xml 파일을 삭제하지 않습니다. Dreamweaver에서 사이트 동기화 정보를 유지하는 데 dwsync.xml 파일을 사용하기 때문입니다.

  6. [공유를 위해 디자인 노트 업로드 활성화]를 선택하여 사용자의 사이트와 연관된 디자인 노트를 나머지 문서와 함께 업로드한 다음 [확인]을 클릭합니다.
    • 이 옵션을 선택할 경우 디자인 노트를 팀의 다른 사람들과 공유할 수 있습니다. 파일을 올리거나 내려받을 때, Dreamweaver는 자동으로 관련된 디자인 노트 파일을 올리거나 내려받습니다.

    • 이 옵션을 선택하지 않을 경우, Dreamweaver는 디자인 노트를 로컬로 유지하며 사용자 파일과 함께 업로드하지 않습니다. 사이트에서 혼자 작업할 경우 이 옵션의 선택을 취소하면 성능이 개선됩니다. 파일을 체크 인하거나 파일을 올릴 때 디자인 노트가 원격 사이트로 전송되지 않으며, 로컬 사이트에서 여전히 디자인 노트를 추가하거나 수정할 수 있습니다.

파일에 디자인 노트 연결

사이트의 문서 또는 템플릿에 개별적으로 디자인 노트 파일을 만들 수 있습니다. 또한 애플릿, ActiveX 컨트롤, 이미지, Flash 내용, Shockwave 오브젝트 및 문서에 들어 있는 이미지 필드에도 [디자인 노트]를 만들 수 있습니다.

참고:

템플릿 파일에 디자인 노트를 추가할 경우 해당 템플릿으로 만드는 문서는 디자인 노트를 상속하지 않습니다.

  1. 다음 중 하나를 수행합니다.
    • 파일을 문서 창에서 연 다음 [파일] > [디자인 노트]를 선택합니다.

    • 파일 패널에서 파일을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 마우스로 클릭(Macintosh)한 다음, [디자인 노트]를 선택합니다.

    참고:

    파일이 원격 사이트에 있으면 먼저 파일을 체크 아웃하거나 내려받은 다음 로컬 폴더에서 이를 선택합니다.

  2. [기본 정보] 탭의 [상태] 메뉴에서 문서의 상태를 선택합니다.
  3. [날짜] 아이콘([노트] 상자 바로 위)을 클릭하여 노트에 현재 로컬 날짜를 삽입합니다.
  4. [노트] 상자에 주석을 입력합니다.
  5. [파일이 열릴 때 표시]를 선택하여 파일이 열릴 때마다 디자인 노트 파일이 항상 나타나도록 합니다.
  6. [모든 정보] 탭에서 플러스(+) 버튼을 클릭하여 새로운 키 값 쌍을 추가합니다. 키 값 쌍을 제거하려면 제거할 쌍을 선택한 다음 마이너스(-) 버튼을 클릭합니다.

    예를 들어 [이름] 상자에 Author라는 이름의 키를 추가하고, [값] 상자에 값을 Heidi로 정의할 수 있습니다.

  7. [확인]을 클릭하여 노트를 저장합니다.

    Dreamweaver는 노트를 현재 파일과 동일한 위치에서 _notes라는 폴더에 저장합니다. 파일 이름은 문서의 파일 이름과 같으며 확장명 .mno가 붙습니다. 예를 들어 파일 이름이 index.html이면 관련된 디자인 노트 파일은 index.html.mno가 됩니다.

디자인 노트 작업

파일에 디자인 노트를 연결한 후에는, [디자인 노트]를 열고 디자인 노트의 상태를 변경하거나 삭제할 수 있습니다.

파일과 연결된 디자인 노트 열기

  1. 다음 중 한 가지를 수행하여 디자인 노트를 엽니다.
    • 파일을 문서 창에서 연 다음 [파일] > [디자인 노트]를 선택합니다.

    • 파일 패널에서 파일을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 마우스로 클릭(Macintosh)한 다음, [디자인 노트]를 선택합니다.

    • 파일 패널의 [노트] 열에서 노란색 [디자인 노트] 아이콘을 더블 클릭합니다.

    참고:

    노란색 [디자인 노트] 아이콘을 표시하려면 [사이트] > [사이트 관리] > [사이트 이름] > [편집] > [고급 설정] > [파일 보기 열]을 선택합니다. 목록 패널에서 [노트]를 선택하고 [보기] 옵션을 선택합니다. 파일 툴바에서 [확장] 버튼을 클릭하여 로컬 사이트와 원격 사이트를 모두 표시하면 [디자인 노트]가 있는 모든 파일에 대해 로컬 사이트의 [노트] 열에 노란색 노트 아이콘이 표시됩니다.

디자인 노트에 사용자 정의 상태 지정

  1. 파일이나 오브젝트에 대한 디자인 노트를 엽니다. 앞의 절차를 참조하십시오.
  2. [모든 정보] 탭을 클릭합니다.
  3. 플러스(+) 버튼을 클릭합니다.
  4. [이름] 필드에 status라는 단어를 입력합니다.
  5. [값] 필드에 상태를 입력합니다.

    상태 값이 이미 있으면 새로 입력한 값으로 대체됩니다.

  6. [기본 정보] 탭을 클릭하여 [상태] 팝업 메뉴에 새 상태 값이 나타나는지 확인합니다.

    참고:

    상태 메뉴에는 사용자 정의 값을 한 번에 하나만 표시할 수 있습니다. 이 과정을 반복하면 Dreamweaver는 처음 입력한 상태 값을 새로 입력한 상태 값으로 대체합니다.

사이트에서 관련되지 않은 디자인 노트 삭제

  1. [사이트] > [사이트 관리]를 선택합니다.
  2. 사이트를 선택하고 [편집]을 클릭합니다.
  3. [사이트 정의] 대화 상자의 왼쪽에 있는 [범주] 목록에서 [디자인 노트]를 선택합니다.
  4. [정리] 버튼을 클릭합니다.

    Dreamweaver에서 사이트의 파일과 관련되지 않은 모든 디자인 노트 삭제를 확인하는 메시지를 표시합니다.

    Dreamweaver를 사용하여 관련된 디자인 노트 파일이 있는 파일을 삭제하는 경우 Dreamweaver는 디자인 노트 파일도 삭제합니다. 따라서 Dreamweaver를 사용하지 않고 파일을 삭제하거나 파일의 이름을 변경하는 경우에만 고립된 디자인 노트 파일이 발생합니다.

    참고:

    [정리]를 클릭하기 전에 [디자인 노트 유지] 옵션을 선택 해제한 경우, Dreamweaver는 사이트의 디자인 노트 파일을 모두 삭제합니다.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책