Dowiedz się, jak organizować i ponownie wykorzystywać widżety, szablony i inne elementy projektu za pomocą panelu Biblioteka w programie Adobe Muse CC.

Uwaga:

Do programu Adobe Muse nie są już dodawane nowe funkcje, a jego obsługa zostanie wycofana 26 marca 2020 r. Aby uzyskać szczegółowe informacje i pomoc, zobacz stronę na temat wycofania usługi Adobe Muse.

Panel biblioteki w programie Muse oferuje dogodny sposób przechowania popularnych elementów stron i zarządzania nimi. Dodaj elementy do biblioteki, aby mieć możliwość szybkiego dostępu do nich i dodawania zawartości do stron w ramach Twojej witryny. Biblioteka może zawierać wiele typów elementów, w tym loga, obrazy witryn, próbki kolorów, linii pomocniczych, własne widżety, osadzone style HTML, akapitów, typografii i grafiki. W tym artykule przedstawiamy omówienie procesu korzystania z panelu Biblioteka w celu usprawnienia procesu projektowania.

Dodatki Creative Cloud umożliwiają wybór z szerokiej gamy elementów projektowych, które pomogą wzbogacić projekt. Aby pobrać, przejdź na stronę Dodatki Creative Cloud dla Adobe Muse.

Przechodzenie do panelu Biblioteka

Możesz wejść do panelu Biblioteka w trybie Projektowanie. Wybierz polecenie Okno > Biblioteka lub kliknij zakładkę Biblioteka w przypiętym zestawie paneli, aby uaktywnić panel.

Otwieranie panelu Biblioteka w programie Adobe Muse.
Otwieranie panelu Biblioteka w programie Adobe Muse.

Uwaga:

Kliknij łącze, aby odwiedzić serwis Adobe Muse Exchange i pobrać elementy biblioteki, które możesz wykorzystać w przyszłych projektach witryn.

Zarządzanie folderami w panelu Biblioteka

Tworzenie nowego folderu

Aby rozpocząć korzystanie z panelu Biblioteka, należy utworzyć nowy folder. Wykonaj następujące czynności:

  1. Kliknij przycisk Utwórz folder (ikona folderu) na dole panelu Biblioteka.
Kliknij przycisk Utwórz folder, aby utworzyć nowy, pusty folder.
Kliknij przycisk Utwórz folder, aby utworzyć nowy, pusty folder.

  1. Wprowadź opisową nazwę w polu obok ikony folderu.

Foldery są uporządkowane alfabetycznie w panelu Biblioteka według nazw; dzięki temu możesz korzystać z podobnych nazw, aby zgrupować powiązane elementy obok siebie na liście.

W dowolnym momencie możesz dwukrotnie kliknąć folder w bibliotece, aby zmienić jego nazwę.

Podaj opisową nazwę folderu w tym polu.
Podaj opisową nazwę folderu w tym polu.

Po utworzeniu folderu możesz dodawać elementy do Biblioteki.

Uwaga:

Chociaż można dodawać elementy biblioteki do panelu Biblioteka bez tworzenia folderu, szybciej jest utworzyć folder, nadać mu nazwę a następnie dodać element, niż dodawać nowy element, a następnie zmieniać nazwę zarówno nowego elementu, jak i jego folderu. Niezależnie od wybranej metody, nadawanie zarówno folderom jak i elementom w panelu Biblioteka nazw opisowych jest zalecaną praktyką.

Jeżeli planujesz dodawać wiele elementów do biblioteki, możesz utworzyć i nazwać zestaw pustych folderów przed dodaniem elementów.

Dodaj foldery, aby uporządkować różne elementy witryny Adobe Muse i ułatwić ich odnajdowanie.
Dodaj foldery, aby uporządkować różne elementy witryny i ułatwić ich odnajdowanie.

Dodawanie elementów strony do folderów

Aby dodać elementy do Biblioteki, przyśpieszając dostęp do nich i umożliwiając dodawanie ich do stron, wybierz dowolny element na stronie. Jeżeli wybierasz wiele elementów, wciśnij klawisz Shift lub kliknij i przeciągnij narzędzie Zaznaczenie, aby zaznaczyć żądane elementy.

Wybierz jedną z dwóch opcji, aby dodać elementy do biblioteki:

Opcja 1

  1. Kliknij prawym przyciskiem myszy wybrany element lub elementy, wybierz opcję Dodaj do biblioteki, a następnie wybierz folder w którym zapiszesz element biblioteki.
W menu kontekstowym Adobe Muse wybierz opcję Dodaj do biblioteki.
W menu kontekstowym wybierz opcję Dodaj do biblioteki.

Wybrany element lub elementy zostają dodane do folderu, a w panelu Biblioteka zostanie wyświetlony ich podgląd.

  1. Podaj nazwę opisową elementu w odpowiednim polu.
Podaj nazwę opisową dla nowego elementu w folderze.
Podaj nazwę opisową dla nowego elementu w folderze.

Lub wykorzystaj następujący obieg pracy do dodania wybranego elementu lub elementów do Biblioteki:

Opcja 2

  1. Po wybraniu elementów należy kliknąć przycisk Dodaj wybrane elementy (ikona obrotu strony) w prawym dolnym rogu panelu Biblioteka.
Kliknij przycisk Dodaj wybrane elementy.
Kliknij przycisk Dodaj wybrane elementy.

  1. Wprowadź nazwę elementu w odpowiednim polu.

Gdy folder zawiera przynajmniej jeden element, możesz kliknąć strzałkę w dół widoczną po lewej stronie nazwy folderu, aby rozwinąć lub zwinąć jego zawartość.

W większych plikach projektów możesz zwinąć wszystkie foldery w panelu Biblioteka, skracając listę elementów, aby ułatwić przeglądanie elementów i zarządzanie nimi. Aby otworzyć lub zamknąć folder w panelu biblioteka, przytrzymaj klawisz Option i kliknij strzałkę (lub klawisz Alt w systemie Windows).

Zmiana nazw i organizowanie folderów

Jak wspomniano, w dowolnym momencie możesz kliknąć dwukrotnie folder, aby zmienić jego nazwę. Podczas przechowywania elementów dla określonego klienta lub sekcji witryny warto nazwać wszystkie foldery w panelu Biblioteka tak, aby pojawiały się obok siebie.

Nazwy folderów w panelu Biblioteka Adobe Muse są uporządkowane alfabetycznie.
Nazwy folderów w panelu Biblioteka są uporządkowane alfabetycznie.

Dobrą praktyką jest nadawanie opisowych nazw folderom i elementom Biblioteki — nie należy korzystać z domyślnych nazw bez nazwy nadawanych przez Muse. Dodawanie opisowych nazw umożliwia szybkie odnajdywanie elementów poprzez przeglądanie listy folderów. Praktyka ta umożliwia także wyszukiwanie określonych elementów biblioteki w sposób opisany w kolejnej sekcji.

Zarządzanie zasobami w panelu Biblioteka

Wyszukiwanie w panelu Biblioteka

Gdy panel Biblioteka zawiera wiele różnorodnych elementów, znalezienie folderu z elementem, który chcesz użyć, może być problematyczne. Możesz zawsze rozwinąć folder, aby obejrzeć jego zawartość, ale może to zająć dużo czasu przy pracy z dużymi bibliotekami.

Aby przeszukać panel Biblioteka wpisz dowolną część nazwy szukanego elementu w polu Filtruj według nazwy.

Wszystkie pasujące elementy zostaną wyświetlone na liście poniżej w rozwiniętych folderach biblioteki.

Wyszukiwanie określonego elementu poprzez podanie nazwy w polu wyszukiwania.
Wyszukiwanie określonego elementu poprzez podanie jego nazwy w polu wyszukiwania.

Po zakończeniu wyszukiwania kliknij przycisk X, aby wyczyścić pole i ponownie zobaczyć pełną listę elementów w panelu Biblioteka.

Importowanie zasobów

Własne zasoby Biblioteki mogą być udostępniane użytkownikom, co ułatwia współpracę z innymi projektantami i ustandaryzowanie wyglądu i zachowania projektów witryn. Wyeksportowane pliki biblioteki Muse są zapisywane z rozszerzeniem .mulib.

Aby zaimportować plik biblioteki Muse do bieżącego projektu, kliknij dwukrotnie plik .mulib. Program Muse zostanie uruchomiony (jeśli nie jest już otwarty), a zawartość biblioteki zostanie dodana do panelu Biblioteka.

Możesz również wykonać następujące czynności:

  1. Kliknij przycisk Importuj bibliotekę Muse w lewym dolnym rogu panelu Biblioteka.
  2. W oknie dialogowym Importuj elementy biblioteki, które się pojawi, wskaż na komputerze plik .mulib, a następnie kliknij Otwórz.
Kliknij przycisk Importuj bibliotekę Muse i otwórz plik .mulib w programie Adobe Muse.
Kliknij przycisk Importuj bibliotekę Muse i otwórz plik .mulib.

Importowany folder lub foldery pojawią się w panelu Biblioteka, gotowe do użycia w bieżącym pliku.

Aby zaimportować elementy, gdy nie pracujesz w widoku Projekt, wybierz kolejno pozycje Plik > Otwórz witrynę a następnie wybierz jeden lub więcej plików .mulib w oknie dialogowym Otwórz, które się pojawi.

Wykorzystanie elementów Biblioteki w projektach

Możesz przechowywać różne rodzaje zasobów, w tym grafiki, obrazy wektorowe, formularze, nagłówki, stopki itp. i zarządzać nimi. Elementy te można wykorzystać w projekcie na dwa sposoby.

Umieszczanie elementów Biblioteki

Zaznacz element, który chcesz użyć w projekcie. Przeciągnij element Biblioteki do widoku Projektowanie.

Umieszczanie elementów Biblioteki z punktami przerwania

Jeśli element Biblioteki zawiera punkty przerwania, możesz umieścić takie elementy w swoim układzie, wraz z punktami przerwania. Aby wykorzystać element Biblioteki z punktami przerwania, kliknij symbol plusa obok tego elementu. Przeciągnij element do widoku Projektowanie i upuść go.

Dodawanie pozycji Biblioteki wraz z punktami przerwania w programie Adobe Muse
Dodawanie elementów Biblioteki wraz z punktami przerwania

Punkty przerwania z elementu Biblioteki są dodawane do strony. Ta funkcja umożliwia dodanie zestawu punktów przerwania na stronach wzorcowych i podrzędnych za pomocą jednego kliknięcia. Można także pozostawić punkty przerwania w różnych projektach opracowanych w programie Adobe Muse.

Jeśli dodasz element Biblioteki zawierający punkty przerwania, jeśli punkty przerwania już wcześniej zostały dodane do strony, wszystkie punkty przerwania zostaną aktywowane.

Eksportowanie obrazów i innych zasobów

Po dodaniu zawartości do panelu Biblioteka możesz wyeksportować ją jako samodzielny plik w celu udostępnienia jej innym projektantom (lub przyspieszenia własnego procesu projektowania podczas pracy na wielu komputerach).

Należy zwrócić uwagę, że zawartość powiązana z witryną (a nie osadzona w niej), jak na przykład pliki Adobe Edge Animate OAM, klipy wideo i inna powiązana zawartość nie jest zawierana w pliku .mulib, który tworzysz podczas eksportu elementów z panelu Biblioteka.

Wykonaj poniższe czynności, aby wyeksportować plik biblioteki Muse, który zawiera także pliki obrazów:

  1. W widoku Projekt utwórz element lub zestaw elementów do dodania do Twojej Biblioteki. Ten zestaw elementów może obejmować prostokąty, tekst i pliki obrazów.
  2. Przed dodaniem elementu lub elementów do panelu Biblioteka otwórz panel Zasoby (Okno > Zasoby), kliknij prawym przyciskiem myszy obraz lub obrazy, które chcesz wyeksportować i wybierz Osadź łącze.

Uwaga! Jeżeli element lub elementy Biblioteki, które chcesz wyeksportować nie zawierają plików obrazów, możesz pominąć Krok 2.

  1. Wybierz żądane elementy i dodaj je do Biblioteki.
  2. Kliknij przycisk Eksportuj na dole panelu Biblioteka.
Wybierz foldery lub elementy, które chcesz wyeksportować i kliknij przycisk Eksportuj.
Wybierz foldery lub elementy, które chcesz wyeksportować i kliknij przycisk Eksportuj.

Plik .mulib zostaje utworzony i zapisany na komputerze (lub dowolnym innym określonym miejscu). Wyślij plik .mulib pocztą e-mail lub przekaż plik innemu projektantowi lub członkowi zespołu.

Gdy odbiorca otwiera plik .mulib a następnie dodaje element do Biblioteki do strony, obrazy pojawiają się w panelu Zasoby jako obrazy osadzone.

Tworzenie własnych próbek

Korzystając z panelu Biblioteka możesz zapisać element zawierający wszystkie kolory wykorzystane w projektowaniu witryny. Możesz też wybrać własny zestaw linii pomocniczych i dodać je do panelu Biblioteka. Te praktyki są bardzo pomocne przy standaryzowaniu wyglądu i zachowania projektów witryn.

Wykonaj następujące czynności w celu zaimportowania zestawu kolorów do nowego pliku .muse w celu przyspieszenia procesu projektowania.

  1. Otwórz plik .muse zawierający kolory, które chcesz przechować. Użyj narzędzia Prostokąt, aby stworzyć prosty kształt prostokąta, a następnie przytrzymaj klawisz Option/Alt i przeciągnij prostokąt, aby powielić go kilka razy. Ustaw wypełnienie każdego prostokąta na jeden z głównych wartości kolorystycznych witryny, korzystając z narzędzia kroplomierza w menu Wypełnienie.
  2. Utwórz nowy folder w panelu Biblioteka do przechowywania próbek kolorów.
  3. Użyj narzędzia Zaznaczenie, aby zaznaczyć cały zestaw prostokątów. Możesz kliknąć prawym przyciskiem myszy, aby wybrać grupę prostokątów, albo wybrać Dodaj do biblioteki lub kliknąć Dodaj wybrane elementy na dole panelu Biblioteka. Wprowadź opisową nazwę w polu, aby oznaczyć nią zestaw próbek.
  4. Wybierz folder zawierający próbki i kliknij przycisk Eksportuj na dole panelu Biblioteka, aby wyeksportować plik biblioteki Muse z wybraną zawartością. Prześlij plik .mulib do członka swojego zespołu jako załącznik poczty e-mail lub przenieś plik na dysku USB.
  5. Odbiorca pliku .mulib uruchamia Muse, tworzy nową witrynę, otwiera panel Biblioteka i klika przycisk Importuj, aby zaimportować plik zawierający próbki do swojej Biblioteki. (Alternatywnie, może wybrać Plik > Otwórz witrynę i otworzyć plik .mulib).
  6. Następnie przeciąga element zawierający kolory z panelu Biblioteka na stronę, aby dodać próbki do panelu Próbki.
  7. Odbiorca otwiera następnie panel Próbki (Okno > Próbki), klika prawym przyciskiem myszy panel Próbki i wybiera Usuń wszystkie nieużywane z menu kontekstowego, które się pojawi.
Po zaimportowaniu usuń nieużywane próbki kolorów na nowej stronie Adobe Muse.
Po zaimportowaniu próbek kolorów do nowej witryny możesz wybrać opcję usunięcia niewykorzystywanych kolorów w panelu Próbki.

Po usunięciu niewykorzystywanych próbek w panelu Próbki możesz usunąć element biblioteki ze strony.

Uwaga:

Ten sam sposób działa w przypadku importowania stylów Akapitu i Typografii, jeśli przypisze się je do tekstu i doda Ramkę tekstową jako element w panelu Biblioteka.

Tworzenie własnych miniatur

Panel podglądu panele Biblioteka ma przedstawiać użytkownikowi wizualny wskaźnik wybranej zawartości, ułatwiając wybór elementów Biblioteki i dodawanie ich do stron. Jednak panel podglądu ma ustawienia powodujące, że wyświetla w zasadzie pliki kwadratowe. W wyniku dodania dłuższych lub wyższych elementów do zestawu elementów Biblioteki widoczne miniatury podglądu obrazów są przeskalowane.

Tworzenie niestandardowych miniatur w programie Adobe Muse
Tworzenie niestandardowych miniatur w programie Adobe Muse

Jeżeli to konieczne, możesz utworzyć inny obraz miniatury do wykorzystania jako podgląd elementu biblioteki. Wykonaj następujące czynności:

  1. Skorzystaj z Mac Finder lub Windows Explorer do znalezienia następującego katalogu na komputerze:
  • Mac: ~/Library/Preferences/Adobe/AdobeMuseLibrary/
  • Windows: %AppData%/AdobeMuseLibrary/

Uwaga:

W systemie Mac OSX możesz wybrać Przejdź > Przejdź do folderu, aby uzyskać dostęp do katalogu. W systemie Windows skopiuj powyższą ścieżkę i wklej ją do paska adresu URL, aby zlokalizować folder.

  1. Zlokalizuj nazwę folderu odpowiadającą folderowi Biblioteki w Muse, który chcesz aktualizować. W tym przypadku folder biblioteki ma nazwę nav - tło.
  2. Otwórz folder, aby zobaczyć jego zawartość. Zawiera on plik PNG.
  3. Użyj programu do obróbki obrazów takiego jak Photoshop lub Fireworks, aby otworzyć plik PNG. Edytuj odpowiednio plik PNG.
  4. Zapisz plik PNG w jego bieżącej lokalizacji i wyjdź z programu do edycji obrazów.
  5. Wróć do Muse i wybierz element z Biblioteki. Edytowany plik PNG jest wyświetlony w panelu podglądu.
Miniatura własnego PNG ułatwia zidentyfikowanie pliku rzutem oka.
Miniatura własnego PNG ułatwia zidentyfikowanie pliku rzutem oka.

Aby dowiedzieć się więcej o pracy z Adobe Muse, odwiedź stronę Pomoc i samouczki Adobe Muse i przejrzyj Forum ze wsparciem Adobe Muse.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online