Atualizações de segurança disponíveis para o Adobe Flash Player

Data de lançamento: 13 de outubro de 2015

Última atualização: 7 de janeiro de 2016

Identificador de vulnerabilidade: APSB15-25

Prioridade: Consulte a tabela abaixo

Número do CVE: CVE-2015-5569, CVE-2015-7625, CVE-2015-7626, CVE-2015-7627, CVE-2015-7628, CVE-2015-7629, CVE-2015-7630, CVE-2015-7631, CVE-2015-7632, CVE-2015-7633, CVE-2015-7635, CVE-2015-7636, CVE-2015-7637, CVE-2015-7638, CVE-2015-7639, CVE-2015-7640, CVE-2015-7641, CVE-2015-7642, CVE-2015-7643, CVE-2015-7644

Plataforma: todas as plataformas

Resumo

A Adobe lançou atualizações de segurança para o Adobe Flash Player. Essas atualizações abordam fragilidades críticas que podem potencialmente permitir que um invasor assuma o controle do sistema afetado.

Versões afetadas

Produto Versões afetadas Plataforma
Tempo de execução de desktop do Adobe Flash Player 19.0.0.185 e versões anteriores
Windows e Macintosh
Versão do Adobe Flash Player Extended Support 18.0.0.241 e versões anteriores Windows e Macintosh
Adobe Flash Player para Google Chrome 19.0.0.185 e versões anteriores Windows, Macintosh, Linux e ChromeOS
Adobe Flash Player para Microsoft Edge e Internet Explorer 11 19.0.0.185 e versões anteriores Windows 10
Adobe Flash Player para Internet Explorer 10 e 11 19.0.0.185 e versões anteriores Windows 8.0 e 8.1
Adobe Flash Player para Linux 11.2.202.521 e versões anteriores Linux
Tempo de execução de desktop AIR 19.0.0.190 e versões anteriores Windows e Macintosh
AIR SDK 19.0.0.190 e versões anteriores Windows, Macintosh, Android e iOS
AIR SDK & Compiler 19.0.0.190 e versões anteriores Windows, Macintosh, Android e iOS
  • Para verificar a versão do Adobe Flash Player instalada no sistema, acesse a página Sobre o Flash Player ou clique com o botão direito do mouse no conteúdo do Flash Player e selecione “Sobre o Adobe (ou Macromedia) Flash Player” no menu. Se você usar vários navegadores, faça a verificação em todos os que estiverem instalados no sistema.  
  • Para verificar a versão do Adobe AIR instalada no seu sistema, siga as instruções na TechNote do Adobe AIR

Solução

A Adobe categoriza essas atualizações com as seguintes classificações de prioridade e recomenda que usuários atualizem para a versão mais recente:

Produto Versões atualizadas Plataforma Disponibilidade
Tempo de execução de desktop do Adobe Flash Player
19.0.0.207 Windows e Macintosh
1 Centro de download do Flash Player Distribuição do Flash Player
Versão do Adobe Flash Player Extended Support 18.0.0.252 Windows e Macintosh
1 Suporte Estendido
Adobe Flash Player para Google Chrome 19.0.0.207 Windows, Macintosh, Linux e ChromeOS    1 Versões do Google Chrome
Adobe Flash Player para Microsoft Edge e Internet Explorer 11 19.0.0.207 Windows 10 1 Conselho de segurança da Microsoft
Adobe Flash Player para Internet Explorer 10 e 11 19.0.0.207 Windows 8.0 e 8.1
1 Conselho de segurança da Microsoft
Adobe Flash Player para Linux 11.2.202.535 Linux 3 Centro de downloads do Flash Player
Tempo de execução de desktop AIR 19.0.0.213 Windows e Macintosh 3 Centro de downloads do AIR
AIR SDK 19.0.0.213 Windows, Macintosh, Android e iOS 3 Download do AIR SDK
AIR SDK & Compiler 19.0.0.213 Windows, Macintosh, Android e iOS 3 Download do AIR SDK
  • A Adobe recomenda que usuários do Tempo de execução de desktop do Adobe Flash Player para Windows e Macintosh atualizem para a versão 19.0.0.207 acessando o Centro de Download do Adobe Flash Player ou pelo recurso de atualização do produto quando solicitado [1].
  • A Adobe recomenda que usuários da Versão de Suporte estendido do Adobe Flash Player atualizem para a versão 18.0.0.252 acessando http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html.
  • A Adobe recomenda que os usuários do Adobe Flash Player para Linux atualizem para o Adobe Flash Player 11.2.202.535 acessando o Centro de Download do Adobe Flash Player
  • O Adobe Flash Player, instalado com o Google Chrome, será atualizado automaticamente para a versão mais recente do Google Chrome, que incluirá Adobe Flash Player 19.0.0.207 no Windows, Macintosh, Linux e Chrome OS.
  • O Adobe Flash Player instalado com o Microsoft Edge para Windows 10 será atualizado automaticamente para a versão mais recente, que incluirá o Adobe Flash Player 19.0.0.207.
  • O Adobe Flash Player instalado com o Internet Explorer 10 e 11 para Windows 8.0 e 8.1 será atualizado automaticamente para a versão mais recente, que incluirá o Adobe Flash Player 19.0.0.207.
  • A Adobe recomenda que os usuários do tempo de execução de desktop AIR, o AIR SDK e AIR SDK & Compiler atualizem para a versão 19.0.0.213 acessando o Centro de Download do AIR ou o Centro do Desenvolvedor do AIR
  • Visite a página Ajuda do Flash Player para obter assistência com a instalação do Flash Player.
 
[1] Os usuários do Flash Player 11.2.x ou posterior para Windows, ou do Flash Player 11.3.x ou posterior para Macintosh, que tenham selecionado a opção “Permitir que a Adobe instale atualizações” receberão a atualização automaticamente. Os usuários que não têm a opção “Permitir que a Adobe instale atualizações” habilitada podem instalar a atualização, quando solicitados, usando o mecanismo de atualização do produto.

Detalhes da vulnerabilidade

  • Essas atualizações resolvem vulnerabilidades que podem ser exploradas para ignorar a política de mesma origem e para levar à divulgação de informações (CVE-2015-7628).
  • Essas atualizações incluem um recurso de defesa detalhada da API do corretor do Flash (CVE -2015-5569).
  • Essas atualizações resolvem vulnerabilidades de uso após período gratuito que podem levar à execução de código (CVE-2015-7629, CVE-2015-7631, CVE-2015-7635, CVE-2015-7636, CVE-2015-7637, CVE-2015-7638, CVE-2015-7639, CVE-2015-7640, CVE-2015-7641, CVE-2015-7642, CVE-2015-7643, CVE-2015-7644).
  • Essas atualizações resolvem uma vulnerabilidade de estouro de buffer que pode levar à execução de código (CVE-2015-7632).
  • Essas atualizações resolvem vulnerabilidades de corrupção de memória que podem levar à execução de código (CVE-2015-7625, CVE-2015-7626, CVE-2015-7627, CVE-2015-7630, CVE-2015-7633).

Agradecimentos

A Adobe gostaria de agradecer às seguintes pessoas e organizações por relatarem problemas relevantes e por trabalharem com a Adobe para ajudar a proteger nossos clientes:

  • Dave "dwizzzle" Weston (CVE-2015-5569)
  • bee13oy, trabalhando com o Programa de recompensas de vulnerabilidade Chromium (CVE -2015-7633)
  • desconhecido do Centro de informações de ameaça de segurança Alibaba que funciona com Zero Day Initiative da HP (CVE-2015-7629)
  • Anônimo trabalhando com a Zero Day Initiative da HP (CVE-2015-7632)
  • Nicolas Joly e Natalie Silvanovich do Google Project Zero (CVE-2015-7644)
  • bilou trabalhando com a Zero Day Initiative da HP (CVE-2015-7631)
  • bilou trabalhando com Zero Day Initiative da HP e Yuki Chen, da Qihoo 360 Vulcan Team (CVE-2015-7643)
  • desconhecido do Centro de informações de ameaça de segurança Alibaba (CVE-2015-7630)
  • Jincheng Liu e Lijun Cheng, da Alibaba Security Research Team (CVE-2015-7625, CVE-2015-7626)
  • Kai Kang da Tencent's Xuanwu LAB (CVE-2015-7627)
  • Yuki Chen da Qihoo 360 Vulcan Team (CVE-2015-7635, CVE-2015-7636, CVE-2015-7637, CVE-2015-7638, CVE-2015-7639, CVE-2015-7640, CVE-2015-7641, CVE-2015-7642, CVE-2015-7643)
  • Sr. Tokuji Akamine (CVE-2015-7628)

Revisões

14 de outubro de 2015: CVEs adicionados com crédito à Yuki Chen da Qihoo 360 Vulcan Team

5 de novembro de 2015: CVE-2015-7634 removido do boletim. Este CVE foi originalmente classificado como um problema de corrupção de memória, mas já foi reclassificado como um ponteiro erro de desreferenciamento de ponteiro nulo.

7 de janeiro de 2016: Crédito adicionado ao Sr. Tokuji Akamine por divulgar CVE-2015-7628