Atualizações de segurança disponíveis para o Adobe Flash Player

Data de lançamento: 16 de junho de 2016

Identificador de vulnerabilidade: APSB16-18

Prioridade: Consulte a tabela abaixo

Números CVE: CVE-2016-4122, CVE-2016-4123, CVE-2016-4124, CVE-2016-4125, CVE-2016-4127, CVE-2016-4128, CVE-2016-4129, CVE-2016-4130, CVE-2016-4131, CVE-2016-4132, CVE-2016-4133, CVE-2016-4134, CVE-2016-4135, CVE-2016-4136, CVE-2016-4137, CVE-2016-4138, CVE-2016-4139, CVE-2016-4140, CVE-2016-4141, CVE-2016-4142, CVE-2016-4143, CVE-2016-4144, CVE-2016-4145, CVE-2016-4146, CVE-2016-4147, CVE-2016-4148, CVE-2016-4149, CVE-2016-4150, CVE-2016-4151, CVE-2016-4152, CVE-2016-4153, CVE-2016-4154, CVE-2016-4155, CVE-2016-4156, CVE-2016-4166, CVE-2016-4171

Plataforma: Windows, Macintosh, Linux e ChromeOS

Resumo

A Adobe lançou atualizações de segurança do Adobe Flash Player para Windows, Macintosh, Linux e ChromeOS.  Essas atualizações abordam vulnerabilidades críticas que podem potencialmente permitir que um invasor assuma o controle do sistema afetado.  

A Adobe está ciente de um relatório que informa que há uma falha no CVE-2016-4171 e ela está sendo usada em ataques direcionados e limitados. Consulte APSA16-03 para obter mais detalhes.

Versões afetadas

Produto Versões afetadas Plataforma
Tempo de execução de desktop do Adobe Flash Player 21.0.0.242 e versões anteriores
Windows e Macintosh
Versão do Adobe Flash Player Extended Support 18.0.0.352 e versões anteriores Windows e Macintosh
Adobe Flash Player para Google Chrome 21.0.0.242 e versões anteriores Windows, Macintosh, Linux e ChromeOS
Adobe Flash Player para Microsoft Edge e Internet Explorer 11 21.0.0.242 e versões anteriores Windows 10 e 8.1
Adobe Flash Player para Linux 11.2.202.621 e versões anteriores Linux
  • Para verificar a versão do Adobe Flash Player instalada no sistema, acesse a página Sobre o Flash Player ou clique com o botão direito do mouse no conteúdo do Flash Player e selecione “Sobre o Adobe (ou Macromedia) Flash Player” no menu. Se você usar vários navegadores, faça a verificação em todos os que estiverem instalados no sistema.  

Solução

A Adobe categoriza essas atualizações com as seguintes classificações de prioridade e recomenda que usuários atualizem para a versão mais recente:

Produto Versões atualizadas Plataforma Classificação de prioridade Disponibilidade
Tempo de execução de desktop do Adobe Flash Player
22.0.0.192 Windows e Macintosh
1

Centro de downloads do Flash Player

Distribuição do Flash Player

Versão do Adobe Flash Player Extended Support 18.0.0.360 Windows e Macintosh
1 Suporte Estendido
Adobe Flash Player para Google Chrome 22.0.0.192 Windows, Macintosh, Linux e ChromeOS   1 Versões do Google Chrome
Adobe Flash Player para Microsoft Edge e Internet Explorer 11 22.0.0.192 Windows 10 e 8.1 1 Conselho de segurança da Microsoft
Adobe Flash Player para Linux 11.2.202.626 Linux 3 Centro de downloads do Flash Player
  • A Adobe recomenda que os usuários do Adobe Flash Player Desktop Runtime para Windows e Macintosh atualizem para a versão 22.0.0.192 através do mecanismo de atualização no produto quando solicitado [1] ou através do Adobe Flash Player Download Center.
  • A Adobe recomenda que usuários da Versão de Suporte estendido do Adobe Flash Player atualizem para a versão 18.0.0.360 acessando http://helpx.adobe.com/br/flash-player/kb/archived-flash-player-versions.html.
  • A Adobe recomenda que os usuários do Adobe Flash Player para Linux atualizem para o Adobe Flash Player 11.2.202.626 visitando o Centro de Download do Adobe Flash Player.
  • O Adobe Flash Player, instalado com o Google Chrome, será atualizado automaticamente para a versão mais recente do Google Chrome, que incluirá Adobe Flash Player 22.0.0.192 para Windows, Macintosh, Linux e Chrome OS.
  • O Adobe Flash Player instalado com o Microsoft Edge e Internet Explorer para Windows 10 e 8.1 será atualizado automaticamente para a versão mais recente, que incluirá o Adobe Flash Player 22.0.0.192. 
  • Visite a página Ajuda do Flash Player para obter assistência com a instalação do Flash Player.

[1] Os usuários do Flash Player 11.2.x ou posterior para Windows, ou do Flash Player 11.3.x ou posterior para Macintosh, que tenham selecionado a opção “Permitir que a Adobe instale atualizações” receberão a atualização automaticamente. Os usuários que não têm a opção “Permitir que a Adobe instale atualizações” habilitada podem instalar a atualização, quando solicitados, usando o mecanismo de atualização do produto.

Detalhes da vulnerabilidade

  • Essas atualizações resolvem vulnerabilidades de confusão de tipo que podem levar à execução de código (CVE-2016-4144, CVE-2016-4149).
  • Essas atualizações resolvem vulnerabilidades de uso após liberação (use-after-free) que poderiam levar à execução do código (CVE-2016-4142, CVE-2016-4143, CVE-2016-4145, CVE-2016-4146, CVE-2016-4147, CVE-2016-4148).
  • Essas atualizações resolvem vulnerabilidades do buffer de pilha que poderiam levar à execução do código (CVE-2016-4135, CVE-2016-4136, CVE-2016-4138).
  • Essas atualizações resolvem vulnerabilidades de corrupção da memória que podem levar à execução do código (CVE-2016-4122, CVE-2016-4123, CVE-2016-4124, CVE-2016-4125, CVE-2016-4127, CVE-2016-4128, CVE-2016-4129, CVE-2016-4130, CVE-2016-4131, CVE-2016-4132, CVE-2016-4133, CVE-2016-4134, CVE-2016-4137, CVE-2016-4141, CVE-2016-4150, CVE-2016-4151, CVE-2016-4152, CVE-2016-4153, CVE-2016-4154, CVE-2016-4155, CVE-2016-4156, CVE-2016-4166, CVE-2016-4171).
  • Essas atualizações resolvem uma vulnerabilidade no caminho de pesquisa de diretório usados para localizar os recursos que podem levar à execução de código (CVE -2016-4140).
  • Essas atualizações resolvem vulnerabilidades que podem ser exploradas para ignorar a política de mesma origem e para levar à divulgação de informações (CVE-2016-4139). 

Agradecimentos

  • Aleksandar Nikolic da Cisco Talos (CVE-2016-4132)
  • Mateusz Jurczyk e Natalie Silvanovich do Google Project Zero (CVE-2016-4135, CVE-2016-4136, CVE-2016-4137, CVE-2016-4138)
  • willJ da Tencent PC Manager (CVE-2016-4122, CVE-2016-4123, CVE-2016-4124, CVE-2016-4125, CVE-2016-4127, CVE-2016-4128, CVE-2016-4129, CVE-2016-4130, CVE-2016-4131, CVE-2016-4134, CVE-2016-4166)
  • Nicolas Joly do Programa de Pesquisa de Vulnerabilidade da Microsoft (CVE-2016-4142, CVE-2016-4143, CVE-2016-4144, CVE-2016-4145, CVE-2016-4146, CVE-2016-4147, CVE-2016-4148)
  • Wen Guanxing do Pangu LAB (CVE-2016-4150, CVE-2016-4152, CVE-2016-4153, CVE-2016-4154, CVE-2016-4155, CVE-2016-4156)
  • LMX da Equipe Qihoo 360 Codesafe (CVE-2016-4141)
  • Dan Caselden da FireEye (CVE-2016-4140)
  • Wen Guanxing do Pangu LAB. (CVE-2016-4151)
  • Genwei Jiang da FireEye (CVE-2016-4149)
  • Sebastian Lekies da Google (CVE-2016-4139)
  • kelvinwang da Tencent PC Manager (CVE-2016-4133)
  • Anton Ivanov da Kaspersky (CVE -2016-4171)