已過期的 Mac 封裝憑證

用於簽署 Acrobat 和 Reader 的 Mac 安裝程式及更新封裝憑證已於 2017 年 2 月 21 日過期。由於憑證已過期,MacOS 已開始標記許多 Acrobat 或 Reader 安裝程式和修補程式為未簽署已過期

以下為受影響的完整安裝程式和修補程式:

  • 15.016.20041 以前的 Acrobat DC Continuous 封裝
  • 15.016.20039 以前的 Acrobat Reader DC Continuous 封裝
  • 15.006.30173 以前的 Acrobat DC 2015 封裝
  • 15.006.30172 以前的 Acrobat Reader DC 2015 封裝
  • 11.0.17 以前的 Acrobat 和 Reader XI 封裝

若您嘗試安裝任何受影響的封裝,則會顯示以下警告訊息:

該安裝程式封裝的憑證已過期

如果嘗試使用命令列來安裝這些封裝,Mac OS 會阻止安裝,使安裝失敗。

解決方案:下載最新版本或修補程式

完整安裝程式

最新版本的完整安裝程式不受此問題影響。如果您的 Acrobat/Reader 完整安裝程式封裝顯示警告訊息,請下載最新版本

此位置的安裝程式封裝已重新整理,從最新封裝安裝將無任何問題。 

修補程式

所有軌道的最新修補程式沒有此問題。Adobe 建議您安裝最新更新更新:

請注意,針對以上所有封裝,您不會看到任何警告,安裝上也沒有任何問題。但是,如果您按一下「鎖定」圖示來刻意提取用於簽署封裝的憑證鏈,則會顯示憑證已過期,如下所示:

憑證已過期錯誤訊息

但是,因封裝簽署有效,操作系統不會阻止安裝,您可以使用 pkgutil 命令來驗證:

pkgutil --檢查簽署 <前往 pkg 檔案的路徑>

11.0.19 Acrobat 封裝的例子終端輸出如下所示,該封裝由作業系統信任的憑證簽署:

pkgutil 命令

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策