瞭解如何使用 Adobe Muse CC 中的「資料庫」面板來組織與重複利用 Widget、範本與其他設計元素。

註解:

Adobe Muse 不再增加新功能,並將於 2020 年 3 月 26 日停止支援。如需詳細資訊和協助,請參閱 Adobe Muse 終止服務頁面

Muse 中的「資料庫」面板是儲存和管理常用頁面元素的便利方式。將項目新增到「資料庫」,您便可以進行快速存取,並將內容新增到網站中的頁面。「資料庫」可以含有數種元素類型,包括標誌、網站影像、色票、參考線、自訂 Widget、嵌入式 HTML、段落、字元和繪圖樣式。在本文中,您將取得如何使用「資料庫」面板簡化設計程序的概覽。

Creative Cloud 附加元件可讓您選擇各式各樣的設計元素,協助豐富您的設計。若要下載,請參閱 Adobe Muse 的 Creative Cloud 附加元件

存取資料庫面板

您可在「設計」視圖中存取「資料庫」面板。選擇「視窗 > 資料庫」,或者在停駐的面板組中按一下「資料庫」索引標籤,將面板設為作用中。

在 Adobe Muse 中開啟「資料庫」面板。
在 Adobe Muse 中開啟「資料庫」面板。

註解:

按一下連結造訪 Adobe Muse Exchange,以取得您可下載並用於未來網站專案的資料庫項目。

在「資料庫」面板中管理檔案夾

建立新檔案夾

若要開始使用「資料庫」面板,您需要建立新檔案夾。請依照下列步驟操作:

  1. 按一下「資料庫」面板底部的「建立檔案夾」按鈕 (檔案夾圖示)。
按一下「建立檔案夾」按鈕,以建立新的空白檔案夾。
按一下「建立檔案夾」按鈕,以建立新的空白檔案夾。

  1. 在檔案夾圖示旁的欄位輸入描述性名稱。

檔案夾在「資料庫」面板中會依名稱的字母順序排序,因此您可以使用類似的名稱讓相關項目在清單中排在一起。

您可隨時按兩下資料庫中的檔案夾來重新命名。

在欄位中輸入描述性檔案夾名稱。
在欄位中輸入描述性檔案夾名稱。

在您建立檔案夾後,就可以將項目新增到「資料庫」。

註解:

雖然您不先建立檔案夾也可以將資料庫項目新增到「資料庫」面板,但相較於先新增項目再為新項目和其檔案夾重新命名的工作流程,建立新檔案夾、加以命名然後新增項目的工作流程會更為快速。不論您偏好哪個方法,最好一律為「資料庫」面板中的檔案夾和項目給予描述性名稱。

如果您規劃將數個項目新增到「資料庫」,則可以在新增項目前,先建立和命名一組空白檔案夾。

新增檔案夾以組織不同的 Adobe Muse 網站元素,並使這些元素便於尋找。
新增檔案夾以組織不同的網站元素,並使這些元素便於尋找。

新增頁面元素至檔案夾

若要將元素新增到「資料庫」以便快速存取並將其新增到其他頁面,請選取頁面上的任一元素。如果您要選取多個項目,請按住 Shift 鍵或按住並拖移「選取」工具,以選取想要的元素。

選擇 2 個選項的其中之一,將元素新增到「資料庫」:

選項 1:

  1. 以滑鼠右鍵按一下選取的元素,選擇「新增至資料庫」,然後選取要儲存資料庫項目的檔案夾。
在 Adobe Muse 的環境選單中選擇「新增至資料庫」選項。
在環境選單中選擇「新增至資料庫」選項。

選取的項目會新增到檔案夾,且「資料庫」面板中會顯示預視。

  1. 在提供的欄位中輸入元素的描述性名稱。
為儲存在檔案夾內的新元素輸入描述性名稱。
為儲存在檔案夾內的新元素輸入描述性名稱。

或者,使用本工作流程將選取的項目新增到「資料庫」:

選項 2:

  1. 在選取元素的情況下,按一下「資料庫」面板右下角的「新增所選項目」按鈕 (翻頁圖示)。
按一下「新增所選項目」按鈕。
按一下「新增所選項目」按鈕。

  1. 在提供的欄位中輸入元素名稱。

檔案夾含有至少 1 個項目後,您就可以按一下檔案夾名稱左側的向下箭頭,以切換展開與收合檔案夾內容。

在較大的專案檔案中,您可以收合「資料庫」面板中的所有檔案夾,讓元素清單變得較簡短、更易於尋找,也更容易管理。若要開啟或關閉「資料庫」面板中的所有檔案夾,請按住 Option,同時以滑鼠按一下箭頭 (Windows 為按住 alt 的同時以滑鼠按一下)。

重新命名和組織檔案夾

如先前所述,您隨時可以按兩下檔案夾加以重新命名。如果您要儲存特定客戶或網站區段的元素,為方便作業,您可以為「資料庫」面板中所有的檔案夾命名,以讓檔案夾相鄰排列。

「Adobe Muse 資料庫」面板中的檔案夾名稱是按字母順序排列。
檔案夾名稱在「資料庫」面板中按字母順序排列。

最好給予檔案夾和資料庫項目描述性名稱。請勿使用 Muse 預設指定的「未命名」名稱。新增描述性名稱可讓您透過瀏覽檔案夾清單快速找到項目。如下一節所述,如此也能讓您搜尋特定資料庫項目。

管理「資料庫」面板中的資源

搜尋「資料庫」面板

將許多不同元素新增到「資料庫」面板後,要記住哪個檔案夾含有您要使用的項目可能並不容易。您隨時可以展開每個檔案夾以檢視其內容,但在使用較大的資料庫時,這可能會相當費時。

若要搜尋「資料庫」面板,請在「依名稱篩選」欄位中輸入項目名稱的任何部分。

隨即會在底下的清單中,以展開資料庫檔案夾的形式顯示任何符合項目。

在搜尋欄位輸入名稱以搜尋特定項目。
在搜尋欄位輸入名稱以搜尋特定項目。

當您完成搜尋時,請按一下 X 按鈕清除欄位,並再次查看「資料庫」面板中的整個項目清單。

讀入資源

自訂資料庫資源可在使用者間共用,便於設計師共同協作,並將網站設計的外觀與風格標準化。轉存的「Muse 資料庫」檔案會使用 .mulib 副檔名進行儲存。

若要將「Muse 資料庫」檔案讀入目前的專案,請按兩下 .mulib 檔。隨即會啟動 Muse (如果尚未開啟),並將資料庫檔案內容新增到「資料庫」面板。

或者依照下列步驟操作:

  1. 按一下「資料庫」面板左下角的「讀入 Muse 資料庫」按鈕。
  2. 在顯示的「讀入資料庫項目」對話方塊中,瀏覽以選取桌面上的 .mulib 檔,然後按一下「開啟」。
按一下「讀入 Muse 資料庫」按鈕,並在 Adobe Muse 中開啟 .mulib 檔案。
按一下「讀入 Muse 資料庫」按鈕並開啟 .mulib 檔。

已讀入的檔案夾會顯示在「資料庫」面板中,供目前的檔案使用。

如果您不在「設計」視圖中作業,但想讀入資料庫項目,您也可以選擇「檔案 > 開啟網站」,然後在顯示的「開啟」對話方塊中瀏覽以選取 1 個或多個 .mulib 檔。

在設計中使用資料庫項目

您可以存放及管理圖形、向量影像、表單、頁首、頁尾元素等各種資源。您可以採用下列兩種方式將這些項目用於設計:

放置資料庫項目:

選擇您想用於設計中的項目。將資料庫項目拖曳至「設計」視圖。

放置含中斷點的資料庫項目:

若資料庫項目包含中斷點,您便可將項目連同中斷點一起放置於版面中。若要使用含中斷點的資料庫項目,請按一下項目旁的加號。將項目拖放至「設計」視圖中。

在 Adobe Muse 中新增資料庫項目與中斷點
新增資料庫項目與中斷點

資料庫項目的中斷點隨即會新增至頁面中。有了這項功能,您只要按一下,就可以在主頁面和子頁面新增一組中斷點。您也可以跨不同的 Adobe Muse 專案保留中斷點。

若頁面中已有中斷點,而您又新增含中斷點的資料庫項目,則頁面中會包含所有中斷點。

轉存影像和其他資源

您將內容新增到「資料庫」面板後,即可將其轉存為獨立式檔案,以和其他設計師共用 (或者在多部機器上作業時,加快您自己的設計程序)。

請注意,連結到您網站的內容 (而非嵌入的內容),例如 Adobe Edge Animate OAM 檔案、視訊剪輯和其他連結的內容,皆不包括在從「資料庫」面板轉存元素時所建立的 .mulib 檔內。

依照下列步驟轉存含有影像檔案的 Muse 資料庫檔案:

  1. 在「設計」視圖中建立要新增到「資料庫」的元素或元素組。此元素組可能包括矩形、文字和影像檔案。
  2. 在將項目新增到「資料庫」面板前,請開啟「資源」面板 (「視窗 > 資源」),以滑鼠右鍵按一下您要轉存的影像,然後選擇「嵌入連結」。

注意:如果您要轉存的資料庫項目不含影像檔案,則可以略過步驟 2。

  1. 選取想要的元素並將其新增到「資料庫」。
  2. 按一下「資料庫」面板底部的「轉存」按鈕。
選取您要轉存的檔案夾或項目,然後按一下「轉存」按鈕。
選取您要轉存的檔案夾或項目,然後按一下「轉存」按鈕。

隨即會建立 .mulib 檔,並將其儲存到您的桌面 (或您指定的位置)。透過電子郵件或檔案傳輸,將 .mulib 檔散佈給其他設計師或團隊成員。

當收件人開啟 .mulib 檔並將資料庫項目新增到頁面時,影像會作為嵌入的影像顯示在「資源」面板內。

建立自訂色票

您可以使用「資料庫」面板儲存含有網站設計使用之所有顏色的元素。您也可以選取一組自訂的參考線,並將其新增到「資料庫」面板。這些作法對標準化網站專案的外觀和風格極為實用。

依照下列步驟將特定的一組顏色讀入新的 .muse 檔,以加快設計程序。

  1. 開啟含有您要儲存之顏色的 .muse 檔。使用「矩形」工具建立單一矩形,然後按住 Option/Alt 並拖移矩形,將其複製數次。使用「填色」選單中的滴管工具,將每個矩形的填色設為網站的主要顏色值之一。
  2. 在「資料庫」面板中建立新的檔案夾,以儲存色票。
  3. 使用「選取」工具選取整組矩形。您可以滑鼠右鍵按一下所選的矩形群組,然後選擇「新增至資料庫」,或者按一下「資料庫」面板底部的「新增所選項目」按鈕。在欄位中輸入描述性名稱,以標記色票組。
  4. 選取含有色票的檔案夾,然後按一下「資料庫」面板底部的「轉存」按鈕,以轉存含所選內容的 Muse 資料庫檔案。將 .mulib 檔以電子郵件附件的方式傳送給團隊成員,或者透過 USB 磁碟機傳輸檔案。
  5. .mulib 檔的收件人隨即可啟動 Muse、建立新的網站、開啟「資料庫」面板,然後按一下「讀入」按鈕將含有色票的檔案讀入「資料庫」。(或者,他們可以選擇「檔案 > 開啟網站」並開啟 .mulib 檔。)
  6. 接下來,他們要將含有顏色的元素從「資料庫」面板拖移到頁面上,以將色票新增到「色票」面板。
  7. 收件人接著便可開啟「色票」面板 (「視窗 > 色票」),以滑鼠右鍵按一下「色票」面板,並從顯示的環境選單選擇「刪除所有未使用的項目」。
讀入之後,在新的 Adobe Muse 網站中刪除未使用的顏色色票。
將色票讀入新的網站後,您可以選擇選項,以刪除「色票」面板中所有未使用的顏色。

刪除「色票」面板中未使用的色票後,如果需要,可刪除頁面的資料庫元素。

註解:

如果您為文字指派「段落」和「字元」樣式,並將「文字框」作為元素新增到「資料庫」面板,則可用相同的方法讀入「段落」和「字元」樣式。

建立自訂縮圖

「資料庫」面板的預視窗格是設計用於提供所選內容的視覺指示,可讓人更容易從「資料庫」中選取項目並將其新增到頁面。但是,預視窗格已設定用於顯示一般的方形檔案。您可能會發現,如果您將較長或較高的元素或元素組新增到「資料庫」,預視影像縮圖的結果會進行縮放。

在 Adobe Muse 中建立自訂縮圖
在 Adobe Muse 中建立自訂縮圖

如有需要,您可以建立不同的縮圖影像,以作為「資料庫」項目預視使用。請依照下列步驟操作:

  1. 使用「Mac Finder」或「Windows 檔案總管」在電腦上搜尋下列目錄:
  • Mac:~/Library/Preferences/Adobe/AdobeMuseLibrary/
  • Windows:%AppData%/AdobeMuseLibrary/

註解:

若使用 Mac OSX,您可以選擇「前往 > 前往檔案夾」來存取目錄。若使用 Windows,請拷貝上述路徑,再貼至 URL 列來找出檔案夾。

  1. 找出 Muse 中您要更新之資料庫檔案夾對應的檔案夾名稱。在本範列中,資料庫檔案夾名稱為 nav - background (nav - 背景)。
  2. 開啟檔案夾以查看內容。其中含有 1 個 PNG 檔案。
  3. 使用 Photoshop 或 Fireworks 等影像編輯程式開啟 PNG 檔案。視需要編輯 PNG 檔案。
  4. 將 PNG 檔案儲存在目前的位置,然後結束影像編輯程式。
  5. 返回 Muse 並選取「資料庫」中的項目。您所編輯的 PNG 檔案會顯示在預視窗格內。
自訂 PNG 會顯示更容易一眼就可識別的縮圖。
自訂 PNG 會顯示更容易一眼就可識別的縮圖。

若要瞭解有關使用 Adobe Muse 的詳細資訊,請造訪 Adobe Muse 說明與教學課程頁面,以及查看 Adobe Muse 支援論壇

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策