Apprenez à faire fonctionner Illustrator de manière plus rapide et plus efficace sous Windows.

Plusieurs facteurs ont une incidence sur la rapidité et l’efficacité d’Adobe Illustrator, tels que le système d’exploitation, la configuration matérielle, votre flux de production et les options sélectionnées. Si vous remarquez que l’exécution d’Illustrator est plus lente que d’habitude, essayez les techniques ci-dessous pour optimiser les performances d’Illustrator, mais également celles des autres applications.(Une amélioration des performances est plus évidente lorsque vous travaillez avec des fichiers volumineux)

Avant de commencer

Avant de procéder aux étapes ci-dessous, assurez-vous d’installer la dernière version d’Illustrator ou les dernières mises à jour de la version que vous utilisez. Les mises à jour de logiciel contiennent souvent des correctifs ou des améliorations liés aux performances. 

Si vous utilisez Illustrator CC, vous pouvez mettre à jour Illustrator par l’intermédiaire de l’application de bureau Creative Cloud.

Remarque :

Les procédures décrites ici sont basées sur l’interface par défaut. Si l’interface a été personnalisée, il est possible que certaines procédures soient différentes. Par exemple, le chemin d’accès au panneau de configuration peut varier. Sélectionnez Démarrer > Paramètres > Panneau de configuration ou Démarrer > Panneau de configuration, en fonction de votre version de Windows.Pour obtenir des conseils de dépannage, ainsi que des informations générales sur Windows, consultez le support Adobe et le support Microsoft.

Optimisation de Windows

En configurant votre système d’exploitation pour qu’il s’exécute efficacement, vous augmentez la quantité de mémoire disponible pour les applications, ce qui leur permet de fonctionner de façon plus fluide. Voici plusieurs techniques pour optimiser Windows et pour améliorer les performances d’Illustrator.

Augmentez la quantité de mémoire disponible

La mémoire virtuelle vous permet d’utiliser l’espace du disque dur pour stocker les informations qui sont normalement stockées dans la RAM. Toutefois, il faut plus de temps pour accéder aux informations figurant sur un disque dur qu’à celles figurant dans la mémoire. Par conséquent, cela peut réduire les performances si votre système dépend trop de la mémoire virtuelle.

Pour améliorer les performances, choisissez la taille appropriée pour votre fichier de pagination (la zone du disque dur qui stocke la mémoire virtuelle). Des droits d’administrateur sont requis pour modifier la taille du fichier de pagination. Illustrator est plus efficace lorsque la taille maximale du fichier d’échange est égale à environ trois fois la quantité de RAM installée.

  1. Quittez toutes les applications.

  2. Sélectionnez Démarrer > Panneau de configuration > Système > Paramètres système avancés.

  3. Dans la boîte de dialogue Propriétés système, sélectionnez l’onglet Avancé.

  4. Cliquez sur Paramètres dans la section Performances, puis choisissez l’onglet Avancé.

  5. Cliquez sur Modifier dans la zone Mémoire virtuelle.

  6. Désélectionnez l’option Gérer automatiquement le fichier d’échange pour tous les lecteurs.

  7. Dans la liste des lecteurs, sélectionnez un disque dur comportant au moins trois fois la quantité de la mémoire RAM installée sur l’ordinateur‎. Par exemple, si votre ordinateur dispose de 64 Mo de RAM, sélectionnez un disque dur disposant d’au moins 192 Mo d’espace libre. Pour de meilleures performances, sélectionnez un disque dur non utilisé comme disque de travail par Illustrator.

Désactivez les fonctions de pilote

Certains pilotes de carte graphique offrent des réglages avancés pour accélérer ou modifier l’affichage des fichiers graphiques. Ces paramètres peuvent parfois avoir des conséquences négatives sur les performances de réactualisation d’Illustrator. Tentez de désactiver les fonctionnalités spécifiques aux pilotes pour déterminer les meilleurs paramètres à adopter avec Illustrator. Pour plus d’informations, voir la documentation de votre carte graphique.

Gestion des polices

Chaque police de caractère installée augmente la quantité de RAM utilisée par Windows. Installez uniquement les polices dont vous avez besoin afin d’améliorer les performances du système ainsi que les performances des applications qui accèdent à ces polices. Faites appel à un utilitaire de gestion des polices pour vous aider à gérer un grand nombre de polices.

Limitez les applications lancées au démarrage

Les applications qui se lancent automatiquement sous Windows font concurrence à Illustrator en termes d’utilisation de RAM. Pour empêcher les applications de démarrer automatiquement, procédez comme suit :

  1. Quittez toutes les applications.

  2. Démarrez l’Explorateur Windows.
  3. Désactivez les applications de démarrage en déplaçant toutes les icônes et tous les raccourcis du dossier Démarrage (OSDisk\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp) vers un autre dossier.

  4. Redémarrez Windows.

Pour fermer les applications configurées dans le registre pour démarrer automatiquement, procédez comme suit :

  1. Redémarrez Windows.
  2. Appuyez sur Ctrl + Maj + Echap.

  3. Choisissez l’onglet Processus.

  4. Sélectionnez le nom d’une application, puis cliquez sur Fin de tâche.

  5. Relancez Illustrator. Si les performances d’Illustrator s’améliorent, contactez le fabricant de l’application pour obtenir de l’aide quant à la désactivation permanente du démarrage automatique. Répétez les étapes 2 à 5 pour chaque application de démarrage restante.

Réactivez les icônes et les raccourcis

Si les performances d’Illustrator ne s’améliorent pas après le redémarrage, réactivez les icônes et les raccourcis dans l’Explorateur Windows en les replaçant dans le dossier Démarrage.

Si les performances d’Illustrator s’améliorent, réduisez le problème de performances à un ou plusieurs programmes et réactivez leurs icônes et raccourcis en les plaçant dans le dossier Démarrage à l’aide de l’Explorateur Windows.

Redémarrez votre ordinateur une fois que vous avez réactivé chaque ensemble d’icônes et de raccourcis et testez les performances d’Illustrator.

Répétez ce processus jusqu’à ce que les performances d’Illustrator diminuent. Une fois isolé l’icône ou le raccourci qui provoque le problème de performances, supprimez-le de nouveau. Prenez contact avec le fabricant du programme pour savoir s’il existe une mise à jour.

Optimisation du matériel

Le matériel que vous utilisez a une incidence sur les performances d’Illustrator car plus le processeur ou le disque dur est rapide, plus Illustrator peut traiter les informations rapidement. D’autres améliorations apportées au matériel, telles que l’installation de RAM supplémentaire, l’utilisation d’un système à plusieurs processeurs ou l’optimisation et la défragmentation de disques, peuvent également améliorer les performances. Essayez les techniques ci-après pour optimiser le matériel.

Utilisation d’un processeur plus rapide

La vitesse de l’unité centrale de votre ordinateur (UC) a une incidence sur la vitesse d’Illustrator. Du fait qu’Illustrator manipule une grande quantité de données et effectue un grand nombre de calculs, sa vitesse dépend donc de celle du processeur. Envisagez d’utiliser un ordinateur doté d’un processeur plus rapide.

Installation de RAM supplémentaire

Si Illustrator ne dispose pas d’une quantité de RAM suffisante, il fait appel à l’espace disponible sur le disque dur (mémoire virtuelle et/ou disque de travail) pour traiter les informations. Illustrator fonctionne plus vite s’il peut traiter les informations dans la mémoire, sans avoir à recourir au disque dur.

Optimisation de l’espace disque

Voici quelques façons d’optimiser l’espace disque :

  • Recherchez les éventuelles erreurs sur votre disque dur, défragmentez les fichiers et optimisez l’utilisation de l’espace disponible du disque dur à l’aide des programmes CHKDSK.exe et Disk Defragmenter. Pour plus d’informations, reportez-vous à la documentation de Windows ou à la section Amélioration des performances de Windows.
  • Enregistrez vos fichiers sur des lecteurs offrant des vitesses d’accès plus rapides. Par exemple, utilisez un disque dur interne, plutôt qu’un serveur réseau (lecteur réseau) ou un lecteur externe.
  • Si vous souhaitez enregistrer un fichier sur un lecteur réseau ou sur un lecteur externe, enregistrez d’abord le fichier sur un disque dur interne. Fermez ensuite le fichier et utilisez l’Explorateur Windows pour le copier sur le lecteur réseau ou le lecteur externe.

Utilisation d’une imprimante PostScript

Pour obtenir de meilleurs résultats lors de l’impression à partir d’Illustrator, utilisez une imprimante PostScript. La plupart des imprimantes non PostScript utilisent les informations d’affichage, les ressources de l’ordinateur hôte et des pilotes d’impression exclusifs pour traiter les informations d’impression. Par conséquent, elles peuvent mettre plus de temps à imprimer que les imprimantes PostScript.

Utilisation efficace des fonctionnalités d’Illustrator

La manière dont vous utilisez Illustrator, et en particulier celle dont vous affichez les illustrations, peut avoir un impact sur les performances d’Illustrator. Voici diverses manières d’utiliser efficacement les fonctions d’Illustrator.

Utilisation de l’affichage Contour

L’affichage Contour masque les attributs de peinture pour afficher l’illustration sous la forme de tracés non remplis. L’utilisation de l’affichage des contours peut accélérer l’affichage des illustrations complexes telles que les objets remplis avec des dégradés ou des motifs. L’affichage Contour facilite également la modification d’objets masqués derrière d’autres objets remplis.

Pour utiliser l’affichage Contour pour un document Illustrator, sélectionnez Affichage > Contour.

Création de vues personnalisées

Vous pouvez créer des vues personnalisées du document. Les vues personnalisées permettent de modifier rapidement le mode d’affichage, le grossissement, la position de défilement et les options de calque.

Pour créer une vue personnalisée d’un document Illustrator, définissez les attributs d’affichage que vous voulez enregistrer. Sélectionnez ensuite Affichage > Nouvelle vue et saisissez un nom dans la boîte de dialogue Nouvelle vue. La vue personnalisée s’affiche dans le menu Affichage.

Modification des paramètres des effets de pixellisation

Vous pouvez changer la résolution des effets de pixellisation pour optimiser les performances d’Illustrator.

Pour ce faire, sélectionnez Effet > Effets de pixellisation de document. Dans le menu contextuel Résolution, effectuez l’une des opérations suivantes :

  • Sélectionnez Ecran si vous éditez des fichiers. Illustrator utilise une résolution de 72 ppp pour les effets de pixellisation, ce qui augmente la vitesse d’affichage.
  • Sélectionnez Haute si vous imprimez des fichiers. Illustrator utilise une résolution de 300 ppp pour les effets de pixellisation, ce qui réduit la vitesse d’impression, mais augmente la vitesse d’affichage.

Cliquez ensuite sur OK.

Masquage des calques et suppression des vignettes

Utilisez le panneau Calques pour organiser et modifier des illustrations. Lorsque vous masquez des calques qui contiennent des illustrations complexes ou des images bitmap en haute résolution, Illustrator redessine l’écran plus rapidement.

Pour masquer un calque, cliquez sur l’icône en forme d’œil située à gauche du nom du calque. Pour afficher uniquement le calque sélectionné, cliquez sur l’icône en forme d’œil tout en appuyant sur la touche Alt (Option pour Mac).

Le panneau Calques permet d’afficher des vignettes des calques de niveau supérieur, des calques, des groupes et des objets imbriqués. Pour réduire le nombre de vignettes afin qu’Illustrator redessine l’écran plus rapidement, sélectionnez Options de panneau dans le menu du panneau Calques, puis réduisez le nombre de vignettes.

Panneau Options

Désactivation de l’aperçu de la surimpression

L’option Aperçu de la surimpression fournit un « aperçu des encres » qui est une approximation de l’aspect de la fusion, de la transparence et de la surimpression dans une sortie en trichromie. Pour améliorer les performances, évitez d’utiliser l’Aperçu de la surimpression.

Pour activer et désactiver l’option Aperçu de la surimpression, sélectionnez Affichage > Aperçu de la surimpression.

Suppression des plans de travail inutilisés

Les plans de travail représentent les zones qui peuvent contenir des illustrations imprimables. Pour optimiser les performances, pensez à supprimer les plans de travail inutilisés ou non indispensables.

Pour gérer les plans de travail, sélectionnez Fenêtre > Plans de travail. Sélectionnez un plan de travail à supprimer et cliquez surSupprimer.

Modification des préférences de disque de travail

Lorsque vous travaillez sur une image bitmap intégrée et que le système ne dispose pas d’assez de mémoire vive, Illustrator utilise l’espace disque comme disque de travail. Il faut plus de temps pour accéder aux informations figurant sur un disque dur qu’à celles figurant dans la mémoire. Par conséquent, l’utilisation d’une partie du disque dur en tant que mémoire virtuelle peut réduire les performances. Si vous avez besoin de davantage de mémoire pour travailler dans Illustrator, Adobe vous conseille d’installer une plus grande quantité de RAM.

Par défaut, Illustrator utilise le disque système comme disque de travail. Modifiez le paramètre de disque de travail principal d’Illustrator pour qu’il soit votre disque dur le plus rapide.

Pour changer les préférences de disque de travail, procédez comme suit :

  1. Sélectionnez Édition > Préférences > Modules externes et disques de travail.

  2. Choisissez un disque dur dans le menu contextuel Disque 1. Si vous travaillez avec des images volumineuses et que vous possédez plusieurs disques durs, choisissez un second disque dans le menu contextuel Disque 2.

  3. Cliquez sur OK et relancez Illustrator.

Suppression des éléments inutilisés dans les profils de document

Les profils de document d’Illustrator contiennent les motifs, dégradés, symboles de graphes, couleurs, bibliothèques de couleurs et formes par défaut qui apparaissent dans les nouveaux documents Illustrator. Ces fichiers déterminent également le niveau de zoom, la taille des fenêtres, les préférences d’affichage et la position de défilement des nouveaux documents. Réduisez la taille des nouveaux documents en supprimant les nuanciers et pointes de pinceau inutiles des profils des nouveaux documents Illustrator.

Pour obtenir des instructions sur la création de profils de documents personnalisés dans Illustrator, reportez-vous à l’article Startup Profiles: A great tool to customize your new documents.

Suppression des éléments inutilisés dans des modèles

Les modèles vous permettent de créer des documents qui partagent des paramètres et des éléments de conception communs. Vous pouvez réduire la taille de fichiers des nouveaux documents en supprimant les nuances, les symboles, les styles de graphique et les pinceaux superflus des modèles.

Pour obtenir des instructions sur la création de fichiers de modèles, voir Fichiers et modèles.

Activation de liens vers des images

Les images bitmap incorporées (par exemple, TIFF, BMP ou Photoshop EPS) peuvent augmenter considérablement la taille d’un document Illustrator, ce qui ralentit les performances. Pour améliorer les performances, activez l’option Lien lorsque vous placez une image bitmap. L’option Lien référence l’image placée sur le disque dur.

  • Sélectionnez Fichier > Placer. Dans la boîte de dialogue Placer, sélectionnez Lien.

Si un prestataire de services demande des images intégrées, enregistrez une copie des fichiers. Sélectionnez Inclure les fichiers liés dans la boîte de dialogue Options de format natif d’Illustrator ou Options de format EPS .

Utilisation des aperçus de fichiers EPS en basse résolution

Si un document contient des images EPS liées disposant d’aperçus en haute résolution, Illustrator réactualise l’écran plus lentement lorsque vous modifiez les illustrations. Pour permettre à Illustrator de redessiner plus rapidement l’écran, utilisez les aperçus EPS en basse résolution. Procédez comme suit :

  1. Sélectionnez Édition > Préférences > Gestion des fichiers et presse-papiers.

  2. Sélectionnez Utiliser une vignette basse résolution pour les fichiers EPS liés et cliquez sur OK.

Désactivation de l’option Afficher l’interaction de la transparence DCS

La boîte de dialogue Options du panneau Liens contient une option Afficher l’interaction de la transparence DCS. Si cette option est sélectionnée, le panneau Liens affiche une icône jaune pour identifier les graphiques EPS DCS liés qui sont des objets transparents or transparents se chevauchant. Cette option obligeant Illustrator à déterminer régulièrement si les fichiers EPS liés interagissent avec la transparence, elle peut réduire les performances.

Pour désactiver l’option Afficher l’interaction de la transparence DCS, procédez comme suit :

  1. Sélectionnez Fenêtres > Liens. Dans le menu du panneau Liens, choisissez Options du panneau.

  2. Désactivez l’option Afficher l’interaction de la transparence DCS et cliquez sur OK.

Masquage du panneau Navigation

Le panneau Navigation affiche une vignette de l’illustration en cours pour faciliter la navigation. Le temps de traitement nécessaire pour mettre à jour la vignette à chaque modification du document dépend de la complexité de l’illustration. Afin d’améliorer la vitesse de réactualisation de l’écran dans un document complexe, masquez le panneau Navigation. Sous le menu Fenêtre, désélectionnez Navigateur.

Vous pouvez configurer les vues personnalisées de manière qu’elles zooment plus efficacement sur des zones particulières de votre document.

Désactivation de l’option Illustration lissée

L’option Illustration lissée lisse le texte et les graphiques en fusionnant la couleur des pixels de contour d’un objet avec celle des pixels adjacents. Ce processus peut toutefois ralentir la réactualisation de l’écran. Pour désactiver cette option, procédez comme suit :

  1. Sélectionnez Édition > Préférences > Général.

  2. Désactivez l’option Illustration lissée et cliquez sur OK.

Application de la commande Simplifier

La commande Simplifier réduit le nombre de points d'ancrage dans les tracés et formes de tracés, ce qui réduit la taille des fichiers et augmente les performances. Pour appliquer la commande Simplifier, sélectionnez le chemin ou l’objet de votre choix, puis Objet > Chemin > Simplifier.

Pour plus d’informations sur la commande Simplifier, consultez l’aide d’Illustrator.

Désactivation des repères commentés

Les repères commentés vous permettent de créer, d’aligner, de modifier et de transformer les objets Illustrator par rapport à d’autres objets. Si votre illustration contient plusieurs objets, Illustrator aura besoin de plus de temps pour afficher les Repères commentés. Pour désactiver les repères commentés, dans le menu Affichage, désélectionnez Repères commentés.

Pour plus d’informations sur les repères commentés, voir Règles, grilles, repères et traits de coupe.

Pixellisation des tracés de pointes de pinceau et désactivation des fonctionnalités PDF

Les contours de pointe de pinceau sont composés de plusieurs tracés transparents teintés superposés. Ces tracés, comme tout autre chemin teinté d’Illustrator, interagissent avec la peinture des autres objets, y compris les autres tracés des pointes de pinceau.

Faites des essais avec les pointes de pinceau et le rendu de peinture avant d’entreprendre une illustration à grande échelle. La modification des attributs de pointe de pinceau et leur réapplication remplace toutes les pointes de pinceau.

Lors de l’utilisation des pointes de pinceau, il est possible de limiter la complexité et la taille de fichier du document en procédant comme suit :

  • En pixellisant certains tracés de pointes de pinceau. Enregistrez bien une copie de l’illustration d’origine avant la pixellisation.

Si l’illustration contient un grand nombre (>30) de pointes de pinceau, réduisez la complexité et le nombre des tracés des pointes de pinceau. Sélectionnez les tracés de pointes de pinceau et choisissez la commande Objet > Pixelliser.

  • Désactivez les fonctionnalités PDF.

Illustrator enregistre par défaut les données PDF qui permettent la compatibilité entre les fichiers Illustrator (*ai) et les autres applications Adobe. Sélectionnez Fichier Enregistrer ou Fichier > Enregistrer sous et cliquez sur Enregistrer. Dans la boîte de dialogue Options d’Illustrator, désélectionnez Créer un fichier compatible PDF.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne